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CHAPTER 1

General Information

Thank you for purchasing Rentica! We’re very pleased that you have chosen our theme to use on your website. We’re
doing our best not to disappoint you! Before you get started, please check out these documentation pages. Rentica can
only be used with WordPress and we assume that you already have it installed and ready to go. If you don’t, please
see WordPress Codex to get started.

1.1 Requirements

Before using Rentica, please meet the following requirements:

• Essentials to run WordPress – Read more about WordPress Minimum Requirements – in case any doubts re-
garding the server, contact your host provider.

• Latest version of WordPress, which you can download here.

• Create secure FTP and Database.

1.2 Installation

In our guide, we will show you step by step instructions on how to install our WordPress theme for beginners. Below
you will find two ways to install a WordPress theme.

1.2.1 Installation via Administration Panel

If Rentica files are downloaded from your Themeforest account, you can start an installation using WordPress admin-
istration panel.

Follow steps below to install the theme:

• Step 1 - Once you’ve logged in to your administration panel, go to My Sites > Network Admin.

1
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• Step 2 - Then click on Themes > Add New, you will be directed to a page where you can choose available
themes.

• Step 3 - Once directed to the page, on the upper left side of the screen click on Upload Theme button.

• Step 4 - Choose the Renticatheme.zip file from your computer, then click Install Now.

2 Chapter 1. General Information
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• Step 5 - Click on My Sites then go to Appearance > Themes and Activate Rentica.

• Step 6 - After activating Rentica, you will be sent to Theme Installation Instruction steps. By following this
steps you will be asked to install required plugins, activate them, and import demo content (required).

1.2. Installation 3



Rentica, Release

Common Install Error: Are You Sure You Want To Do This?

If you get the following question message when installing Renticatheme.zip file via WordPress, it means
that you have an upload file size limit. Install the theme via FTP or call your hosting company and ask
them to increase the limit.

1.2.2 Installation via FTP

To install Rentica WP via FTP, follow steps below:

• Step 1 – Unarchive Renticatheme.zip file

• Step 2 – Access your host web server using FTP client

• Step 3 – Find directory wp-content > themes

• Step 4 – Put folder Renticatheme in directory wp-content > themes

4 Chapter 1. General Information
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• Step 5 - Go to your WordPress administration panel, navigate to Appearance > Themes then activate Renti-
catheme.

Learn more:

• WordPress Codex – FTP clients

1.3 Unyson, Extension, and Plugins

Some functionalities of the Rentica Theme are available because of the plugins we used to create it. Once Rentica is
activated in your WordPress admin panel you should see notification about bundled plugins we recommend to install
– they are included in Rentica package – so you don’t have to do anything more than click install and activate.

1.3.1 Unyson

Unyson is a framework for WordPress that facilitates development of a theme. This framework was created from the
ground up by the team behind ThemeFuse from the desire to empower developers to build outstanding WordPress
themes fast and easy. This documentation is heavily modified by createIT to ensure all custom extensions are well
documented.

This documentation assumes you have a working knowledge of WordPress. If you haven’t, please
start by reading WordPress Documentation.

Minimum Requirements

Server:

• PHP 7.2 or greater

• MySQL 5.6 or greater OR MariaDB 10.0 or greater

• Nginx or Apache with mod_rewrite module

• HTTPS support

Wordpress: 4.9

Installation

Unyson is part of Rentica plugin that should be activated to be able to use the fully use this theme.

After plugin will be activated you will notice the Unyson entry in the sidebar:

1.3. Unyson, Extension, and Plugins 5
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Configure the plugin by going to the Unyson menu and activating the following extensions:

• Backup & Demo Content: This extension lets you create an automated backup schedule, import demo
content or even create a demo content archive for migration purposes.

• SASS Compiler: Compiles SASS files. Remember to activate it when you are going to change theme
colors via Customize.

• Breadcrumbs: Creates a simplified navigation menu for the pages that can be placed anywhere in the
theme. This will make navigating the website much easier.

• Visual Composer: Allows for seamless integration with Visual Composer.

• CT Team: This extension will add team post type support

• CT Flickr: This extension will add a flickr shortcode and widget.

• CT Twitter: This extension will add a twitter shortcode.

• CT Rents: This extension will add Cars post type support

• Rentica Portfolio: This extension will add portfolio post type support.

• Rentica FAQ: This extension will add FAQ post type support.

License

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU
General Public License is intended to guarantee your freedom to share and change free software. Unyson inherits the
General Public License (GPL) from WordPress.

1.3.2 Extension

On the Unysone page you’ll see a list of avaliable extensions separated in two sections:

Active Extensions - Extensions that should be activate to be able to fully use Rentica WP theme functionality:

Available Extensions - Extensions not yet downloaded or activate.

Note: We recommend to not activate any of the extensios that are not part of the list above. They may
not be compatible with the theme and could create unexpected issues.

6 Chapter 1. General Information
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1.3.3 Plugins

Visual Composer

Simply drag and drop elements to build your page content. We prepared components which will help you determine
main structure of the webpage – easily set up backgrounds, colors and styles for whole sections as well as lots of
various smaller components which you can freely put wherever you want.

Note: As the VC plugin used with Rentica WP Theme is part of a bundle, that mean that theme author
has a license and only he/she can download latest versions of VC and include it in the theme. You as a
theme user may use Visual Composer free of charge while you use the theme that came with VC (because
you have a license for that theme).

Learn more:

For more information about Visual Composer, please check articles below:

• How to install Visual Composer

• Visual Composer demo

• Visual Composer documentation

1.3. Unyson, Extension, and Plugins 7
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Slider Revolution

How to activate the plugin

Slider Revolution is included in Rentica WP package – so you don’t have to do anything more than click install and
activate as you do with other plugins.

If you are new user of the revolution Slider plugin or you just want to check some of it functionality feel free to check
Slider Revolution Documentation created by the authors of this plugin.

Contact Form 7

Contact forms in Rentica WP are created with the use of Contact Form 7 Plugin. Below you will find information how
to recreate Contact forms used in our theme by adding the correct markup for the Form section of this plugin.

8 Chapter 1. General Information
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If you never before used this plugin I suggest you to check Getting Started with ContactForm 7.

Booki

A modern booking plugin for WordPress. This plugin allows you to setup appointments or reservations with time that
adapts to users timezone. You can make payment via PayPal or simply book and pay later.

1.3. Unyson, Extension, and Plugins 9
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Learn more:

For more information about Booki:

• Introducing Booki

• Booki Demo

MailChimp for Wordpress

MailChimp for WordPress helps you add more subscribers to your MailChimp lists using various methods. You can
create good looking opt-in forms or integrate with any other form on your site, like your comment, contact or checkout
form.

If you never before used this plugin I suggest you to check Knowledge Base for this plugin.

10 Chapter 1. General Information
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1.4 Demo Content

Note: To be able to use theme content installation and backup functionality make sure to activate Backup
& Demo Content Unyson’s extension.

The fastest and easiest way to import our demo content is to use Theme Options Demo Content Installer. It will import
all pages and posts, sample slider, widgets, theme options, assigned pages, and more.

1.4.1 Import Demo Content

To import our demo content, please follow the steps below:

• Step 1 – Navigate to Tools where after activating the Unyson extension Demo Content Install option will be
available

• Step 2 – Choose import option you want to use from available options

• Step 3 - To be able to continue you need to agree to this term.

1.4. Demo Content 11
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• Step 4 – Wait until the content will be installed

Importing can take a few minutes. Please be patient and wait for it to complete. Once it is loading, you will see
message with indicating progress.

We recommend this approach on a newly installed WordPress. It will replace the content you currently have on your
website. However, we create a backup of your current content in (Tools > Backup). You can restore the backup from
there at any time in the future.

12 Chapter 1. General Information
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1.5 Support

All of our items comes with free support. Free support is limited to questions regarding the themes features or
problems. We provide premium support for code customisation or third-party plugins.

Note: Our support hours: 10:00 AM – 6:00 PM UTC +1 on Monday to Friday.

1.5.1 Free Support

For issues and concerns, you can reach us through these support methods:

• E-mail – support@createit.pl

• Help Desk – Click here to go to our support website. Just click on the Submit Ticket button and follow instruc-
tions to create a ticket.

• Forum – Comment/Post on the product you have issues/queries in ThemeForest or CodeCanyon websites.

Before You Post in a Forum

We urge you to follow the steps below, before you post a new topic on the forum, to speed up your
request. It’s in everyone’s interest and will benefit in making the entire forum more efficient:

– Step 1 – Always check the Documentation and the Knowledgebase Section. Most questions are
already answered in those areas.

– Step 2 – If your question hasn’t been brought up on the forum, please post a new topic. Always
be as specific as possible. Creating a topic requires entering the live URL to your home page or
page that shows the issue in question. It also has bars for WP and FTP login info, which aren’t
required, however, providing us with your login information can save a lot of time for both of
us. Login credentials are securely stored and accessible only by our support staff.

– Step 3 – We usually answer questions in 24 hours on working days. However, if you don’t get
any answer within 72 hours bump up your question or send us an e-mail.

For all support methods, you will receive confirmations and replies on your queries through e-mail or by tracking your
ticket which you will also get through e-mail. To track your ticket, please click here.

Once we reply to your query, each ticket will be open for 7 days without a reply from you. On the 6th day without a
reply, an e-mail will be sent to notify you of the ticket’s inactivity. To make the ticket active again, you simply need to
reply or follow the steps in the e-mail. If you won’t make the ticket active within 7 days, on the 8th day the ticket will
automatically be closed.

1.5.2 Premium Support

We can create your website from scratch, redesign it or just extend the current ones. For more information, please take
a look at our website. Typical issues covered by Premium Support:

• Custom CSS

• Support for third party software and plug-ins

• WordPress Installation with Theme configuration

• Server configuration

• Site structure modifications

1.5. Support 13
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• Graphic adjustments, etc.

• WordPress general howto’s

14 Chapter 1. General Information
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Page

You can use Pages to organize and manage any content on your website. You can create multiple pages on your
website for different types of content or setup onepager with scroll-to-section menu.

2.1 Create New Page

To create a new Page in Funfetti follow the steps below:

• Step 1 - In Dashboard, navigate to Pages > Add New. You will be directed to a page where you can add details
on the page.

15
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• Step 2 - Add the Title of the page.

• Step 3 - Add content – we recommend you to create page content using Visual Composer or by modifying demo
content.

• Step 4 - Choose page attributes. To have the same look as the demo, at the Template section of the page attribute,
use VC Template. This is a template set for Rentica.

– Parent – If you want to create this page as a subpage.

– Template – You can choose one of defined page templates. To have the same look as the demo,
use VC Template.

– Order – The order of the page.

2.1. Create New Page 17
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• Step 5 - After adding all the contents of the page, click on the Publish button.

2.1.1 Create Page Using Visual Composer

When using Visual Composer to add content, you have 2 Editor options, the Backend Editor and Frontend Editor.

Backend Editor

18 Chapter 2. Page
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Frontend Editor

In adding contents to the page, there are many options to choose from. Some of the options are:

• Elements - You will be able to choose elements that are needed and used on the page.

2.1. Create New Page 19
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• Text Block – This is where you add Text to the page.

• Row – An area where you can add elements.

20 Chapter 2. Page
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2.2 Homepage Setup

If you have added some pages via Pages > Add New you can choose one and set it up as a homepage.

Use Static front page tool in Settings > Reading and choose from the list your homepage. Remember to click Save
changes at the end of editing.

2.2. Homepage Setup 21
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2.3 Create a Onepager

One page site allows you to put all the content on one page, and the menu items will link to each different section of
the page.

Think of it as a full site but all in one page. Please read below for information on how to set this up.

To create a Onepager site using Weddington, follow these steps:

• Step 1 - Navigate to the Pages section of your Dashboard and click Add New.

22 Chapter 2. Page
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• Step 2 - In the new page, use the Backend or Frontend editor to create a Section.

Note: You can also use Rows for this. Each section/row will serve as a section in the page to locate
using the menu.

• Step 3 - Click on the Edit option in every section you create and look for Section ID. The Section ID will serve
as the anchor of the menu. Make sure that the ID is unique to the section.

2.3. Create a Onepager 23
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• Step 4 - Add the contents in the Section. You can add rows with text and elements inside. Click on Publish
button to save.

24 Chapter 2. Page
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You can see in the sample above that each section have different Section IDs.

• Step 5 - Set this page as the front page by navigating to Settings > Reading. Click on A static page option, then
select the page for the onepager then click on the Save Changes button.

2.3. Create a Onepager 25



Rentica, Release

• Step 6 - To make the Menu for the onepager, navigate the dashboard to Appearance > Menus. Look for create
a new menu, add the Menu Name then click on the Create Menu button.

• Step 7 - You will see options on what to put inside your new menu. Look for Custom Links in the options. If
you don’t see that option, at the upper-right side of the page you will see Screen Options option, click on that
and you will see options with check boxes. Check the box beside Custom Links.

• Step 8 - Using the Custom Links option, write the section’s Section ID inside the URL textbox and the name
of the link inside the Link Text textbox. Then click on the Add to Menu button. After adding all the navigation
menu, Click on Save Menu to save.

26 Chapter 2. Page
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• Step 9 - Click on the Manage Location tab, change the Top primary menu to the menu that you made for the
onepager. Click on the Save Menu button to save.

You can see the changes on the Front Page of the site.

2.3. Create a Onepager 27
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Rentica Elements

3.1 Rentica Custom Shortcodes

With Rentica comes many custom shortcodes for (Visual Composer) VC that are used to show content created in
Rentica.

Below you will find short information about this Visual Composer elements:

29
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3.1.1 Blog Archive

This will let you add blogs that is archived/grouped.

30 Chapter 3. Rentica Elements
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-General Tab-

• Archive Type - How the blogs are archived/grouped.

By Year

– Enter Subtitle - Subtitle written below the year/category.

– Display Posts under the Category - Display number of posts.

– Order - Order in which data should be fetched.

By Categories

– Display Posts under the Category - Display number of posts.

– Order - Order in which data should be fetched.

– Specify Event Categories - Specify a category that you want to show.

– Exclude Categories - Specify a category to exclude.

Sample Blog Archive:

3.1. Rentica Custom Shortcodes 31
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3.1.2 Button

This theme comes with VC element that give you the option to create buttons that can be used in the theme.

3.1. Rentica Custom Shortcodes 33
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-General Tab-

• Text - The label of the button.

• URL (Link) - URL link for the button.

• Style - Display style of the button.

• Shape - Shape of the button.

• Color - Background color of the button.

• Size - Size of the button.

• Alignment - Alignment of the button.

• Add Icon? - Option to add an icon in the button.

34 Chapter 3. Rentica Elements
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• CSS Animation - If Add icon is Yes, this option will show. Add the icon you would like to use.

• Element ID - A unique ID for the button.

• Extra class name - You can add a Custom CSS variable that is made in the Customizer > Additional CSS, click
here for details.

• Advance on click action - Option to be add a javascript action.

Sample Button:

3.1.3 Featured Box

3.1. Rentica Custom Shortcodes 35
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This will let you create a feature box with icon or number counter.

-General Tab-

• Featured Box Type - Type of featured box you would like to show: Icon or Number Counter

• Icon - Select an icon to use.

• Icon Type - How the icon would look and behave.

• Text Align - Alignment of the text.

• Title - Title of the featured box.

• Title Color - Font color of the title.

• Subtitle - Text below the title.

36 Chapter 3. Rentica Elements
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• Subtitle Color - Font color of the subtitle.

• Bigger Subtitle Size - Option to have the subtitle size bigger than the title.

• Add Button - Option to add/enable the button.

• Add Email - Option to add email.

• Add Social Icons - Option to add social icons.

Note: The social icons that will show are the ones that are set in Customizer > Footer > Sub Footer

-Button Tab-

• Text - The label of the button.

• URL (Link) - URL link for the button.

• Style - Display style of the button.

• Shape - Shape of the button.

• Color - Background color of the button.

• Size - Size of the button.

• Alignment - Alignment of the button.

• Add Icon? - Option to add an icon in the button.

• CSS Animation - If Add icon is Yes, this option will show. Add the icon you would like to use.

• Element ID - A unique ID for the button.

• Extra class name - You can add a Custom CSS variable that is made in the Customizer > Additional CSS, click
here for details.

• Advance on click action - Option to be add a javascript action.

Sample Featured Box:
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3.1.4 Gallery Slider

This will let you create a gallery of images slider.
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-General Tab-

• Images - Select images you want to use.

Sample Gallery Slider:
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3.1.5 Styled Google Maps

Lets you add a styled google map on a page. You will be able to customize this map in the Styled Google Maps
Settings.
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-General Tab-

• Address - Set an address for the map.

• Latitude - Option to add a latitude of the address.

• Longitude - Option to add a longitude of the address.

• Custom map height - Height of the map.

• Zoom - Zoom percentage of the map.

• Map marker - Option to add a custom map marker.

• Map style code - Paste “JavaScript Style Array” here, you can find and create it on: snazzymaps.com

Sample Styled Google Maps:
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3.1.6 Rentica Header

Lets you add a styled header on a page. You will be able to customize this header in the Styled Header Settings.
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-General Tab-

• Header type - Set what type of header you want to use.

• Text Align - Text alignment of the header.

• Header Title Light - Text in the part of the header title that has a light color.

• Header Title Dark - Text in the part of the header title that has a dark color..

• Header Title Color - Header title’s main font color.

• Header subtitle - The subtitle that will be shown in the header.

• Header subtitle color - Header subtitle’s font color.

Sample Rentica Header:
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3.1.7 List
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This theme element will let you add list with an icon bullet.

-General Tab-

• Columns - Number of columns to divide the features.

• List of features - Features added to the list. Use a comma (,) to separate the features.

• List icon - icon used as the bullet.

Sample List:

3.1. Rentica Custom Shortcodes 45



Rentica, Release

3.1.8 Pricing Box

This theme element will let you add pricing box with details about the product.
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-General Tab-

• Pricing Box Title - Title for the pricing box.

• Pricing Box Price - Price for the pricing box item.

• Pricing Box Subtitle - Text below the title.

• Set Header Background Color to Motive - Option to set header background color.

• Header Background Color - Background color for the pricing box header.

• Header Title Color - Font color of the title.

• Content Background Color - Content background color for the pricing box header.

• List of Item - Features added to the list. Use a comma (,) to separate the features.
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-Button Tab-

• Text - The label of the button.

• URL (Link) - URL link for the button.

• Style - Display style of the button.

• Shape - Shape of the button.

• Color - Background color of the button.

• Size - Size of the button.

• Alignment - Alignment of the button.

• Add Icon? - Option to add an icon in the button.

• CSS Animation - If Add icon is Yes, this option will show. Add the icon you would like to use.

• Element ID - A unique ID for the button.

• Extra class name - You can add a Custom CSS variable that is made in the Customizer > Additional CSS, click
here for details.

• Advance on click action - Option to be add a javascript action.

Sample Pricing Box:

48 Chapter 3. Rentica Elements

http://confetti-wp.readthedocs.io/en/latest/customize/addCSS.html#content


Rentica, Release

3.1.9 Two Images

Add two images in the same space with an option to move the second image using its X and Y axis.
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-General Tab-

• First Image - Set the first image.

• Second Image - Set the second image.

• First Image Alignment - Where the first image is aligned.

• Rounded Images - Option to have a round image.

• X axis offset - Horizontal offset of the second image from the first image.

• Y axis offset - Vertical offset of the second image from the first image.

• Set Image Width - If you set X Axis Offset not exceeding the column width and/or you want to make the two
images width the same, you may set image width in pixels.

Sample Two Images:
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3.1.10 Video Phone

Lets you display a smart phone that has a video playing.
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-General Tab-

• Video URL - URL of the video you want to show.

Sample Video Phone:
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3.1.11 Events Timer

Lets you display events as a carousel. You can filter the events that will show inside the carousel.

-General Tab-
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• Move Below The Page Title - Option to display the timer below the page title.

Note: Change the Head Height in Header Options to a higher value. Default = 553, which is
equivalent in pixels.

• Scrolldown Button - Option to display a scroll down button.

• Link ID - URL link for the scroll down button.

-Filters Tab-

• Event - What event you want to use for the timer.

Sample Events Timer:
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3.1.12 Events Grid

Lets you display events by grid. You can filter the events that will show inside the grid.

-General Tab-

• Select Gallery Type - Add/Change the margin, border, or padding of the promo section.

-Filters Tab-

• Limit - Set results limit.

• Skip X elements - Skip a number of elements from the results.
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• Order - How the posts order looks.

• Order by - How the posts are ordered.

• Specify Events - Only selected posts are shown.

• Exclude Events - None of the selected posts will be displayed.

• Specify Event Categories - Only show posts under the categories.

• Exclude Event Categories - None of the posts under the categories are shown.

• Specify post tags - Only show posts with selected tags.

• Keyword search - Show items with certain keyword.

Sample Events Grid:
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3.1.13 Upcoming Events

Below you will see all the available options that can/need to be set to use Upcoming Event element.

-General Tab-

3.1. Rentica Custom Shortcodes 57



Rentica, Release

• Background Color - Set the background color for the grid.

• Display Categories - Option to display the categories of the events.

• Display Tags - Option to display the tags of the events.

-Filters Tab-

• Limit - Set results limit.

• Skip X elements - Skip a number of elements from the results.

• Order - How the posts order looks.

• Order by - How the posts are ordered.

• Specify Events - Only selected posts are shown.

• Exclude Events - None of the selected posts will be displayed.

• Specify Event Categories - Only show posts under the categories.

• Exclude Event Categories - None of the posts under the categories are shown.

• Specify post tags - Only show posts with selected tags.

• Keyword search - Show items with certain keyword.

Sample Upcoming Events:
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3.1.14 Rent Booking

This element is used in Rents post type and it lets you add a Booki booking form. You set the Booki Project in the
Rents form under General > Booki Project. For more information, click here.

Note: If the Booki Project is not set, the area with the Rent Booking will be left blank.

Sample Rent Booking:
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3.1.15 Rent Categories

This element shows rents by categories.
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-General Tab-

• Categories - Select rent categories to feature (or leave empty to display all).

• Target page - Select rent page to open after click.

Sample Rent Categories:
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3.1.16 Rent Display

This element shows all the item in rent. You can filter the item to display by using the Filters tab.
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-Filters Tab-

• Limit - Set results limit.

• Skip X elements - Skip a number of elements from the results.

• Order - How the posts order looks.

• Order by - How the posts are ordered.

• Specify Rents - Only selected Rents are shown.

• Exclude Rents - None of the selected Rents will be displayed.

• Specify Categories - Only show Rents under the categories.

• Exclude Categories - None of the Rents under the categories are shown.
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• Specify post tags - Only show Rents with selected tags.

• Keyword search - Show Rents with certain keyword.

Sample Rent Display:
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3.1.17 Rent Features

This element is used in Rents post type. The features that are added at Rents will be the ones that will be displayed.
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-General Tab-

• Title - Select the title of the features you would like to show. All the features that are added in that title will be
displayed.

• Columns - Number of columns to divide the features in a rows. 4 columns is better with a fullwidth row/section.

• Show also unavailable features - Option to show the features that are not available as features.

• Icon for available features - The icon to show that the feature is available.

• Icon for unavailable features - The icon to show that the feature is not available.

Sample Rent Features:
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3.1.18 Rent Search

This element displays the items in Rents with a way to search the items and filter the prices.

-General Tab-

• Type - Select the type of display it will show in the site. There are 2 options: Simple or With technical list

Sample for Simple Rent Search display
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Sample for With technical list Rent Search display

3.1. Rentica Custom Shortcodes 69



Rentica, Release

3.1.19 FAQ

This element lets you add FAQs by category in the site.
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-General Tab-

• Add Title - Option to add a title/header above the FAQs.

• Category To Display - Category of the FAQs that you want to show.

• Enter FAQ Question Title To Active - The FAQ question that’s under the category set that is open/activated.

Sample FAQ:
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3.1.20 Team Display

This element lets you show Team members items with their name ang position in a page.
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-Filters Tab-

• Limit - Set results limit, use -1 to disable limit.

• Skip X elements - Skip a number of elements from the results.

• Order - How the team members order looks.

• Order by - How the team members are ordered.

• Specify Team members - Only selected team members are shown.

• Exclude Team members - None of the selected team members will be displayed.

• Specify Team Categories - Only show team members under the categories.

• Exclude Team Categories - None of the team members under the categories are shown.
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• Specify post tags - Only show posts with selected tags.

• Keyword search - Show events with certain keyword.

Sample Team Display:

3.1.21 Twitter

This element will let you connect to your twitter where all recent post will also be posted on your site. To get the
information needed for the Twitter account, click on this link.
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-General Tab-

• Autoplay - Option to make the slider move by itself.

• Dotted slider navigation - Option to show dotted slider navigation.

• Display arrows in slider - Option to show arrow slider navigation.

• Pause on hover when autoplay is on - Option to pause autoplay when the mouse pointer is hovering.

• Adapt height of slider to current slide - Option to adapt the height of the slider.

Slides Tab

• Slides to show - Number of slides to show.

• Slides to show on tablets - Number of slides to show on a tablet platform.

• Slides to show on phablets - Number of slides to show on a phablet platform.

• Slides to show on phones - Number of slides to show on a phone platform.

• Set initial slide - Set the initial slider that moves.
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-Twitter Tab-

Note: The following information are from the Twitter account you created.

• Username - The twitter account’s username.

• Customer key - The customer key you set in your twitter account.

• Customer secret - The customer secret you set in your twitter account.

• Token - The access token that you got from twitter for your twitter account.

• Token secret - The token secret that you got from twitter for your twitter account.

• Limit - Limit of news to post.

• Parse url - You can display links from the content as plain text, short html links or full html links.

• Parse media - You can display media links from the content as plain text or 3 types of html links.

• Parse user id? - Display user @ids as plain text or links.

• Parse hashtag? - Display #hashtags as plain text or links.

• Embed images? - Option to show embedded images.

• Size of embeded images? - The size of the embedded images if option is yes.

• Tweet length limit - Max length of the tweet that will show.

• Cache results for X seconds - Cache Twitter feeds for better performance ex. 900 = 15 minutes. 0
- disabled.

Sample Twitter:

3.2 Rentica Plugin Elements

Some plugins that are used in Rentica generates an element that helps customize the pages on your site. You will see
the plugin elements as follows:
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3.2.1 Contact Form 7

This is the plugin that can add a Contact Forms on a page. To know how to create a contact form, go to the Create
Contact Form tutorial.
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3.2.2 Revolution Slider & Revolution Slider 5

This plugin lets you add a slider that you made under the Slider Revolution. The slider revolution lets you make your
own customized slider.

To know how to use the slider revolution, go to Slider Revolution Documentation.
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3.2.3 Visual Composer

This element lets you customize your page using a simple drag and drop of elements to build your page content. You
can easily setup the backgrounds, colors, and styles for a whole section as well as lots of various smaller components
which you can freely put wherever you want.

Some of these elements are:
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Single Image

This element will let you add a single image in your page.
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Image Gallery

This element will let you add multiple images in your page.
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Video Player

This element will let you add a video or MP3 file inside your page by adding the link for the video/MP3.
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Progress Bar

This element will add an animated progress bar in your page.
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Chart

This element lets you add a graph. These are the types of graph that you can add:

• Pie

• Round
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• Line

86 Chapter 3. Rentica Elements



Rentica, Release

3.2. Rentica Plugin Elements 87



Rentica, Release

88 Chapter 3. Rentica Elements



CHAPTER 4

Blogs Posts

Rentica is loaded with options for the blog. It offers many different options for you to present your blog posts, along
with several different blog post layouts. In addition, there are numerous theme options and shortcode options that
allow you to customize how posts are displayed.

4.1 Create New Blog Post

No matter which method you use to display your blog posts, first thing you need to do is create them.

Rentica offers several blog post formats:

• Standard - The default format for the blog post. It will show only the text in the blogs page.
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• Aside

• Image - The Featured Image and a small preview of the text will be shown in the blogs page.

• Video - A video and a small preview of the text will be shown in the blogs page.

To be able to use a Video for the blogs post page, the blog format should be Video and the
Video format settings will show where you add the Embed code of the video.

To add a video in the single page of the blog, you can use the Video element in the VC.

• Audio - An MP3 music and a small preview of the text will be shown in the blogs page.

To be able to use a Video for the blogs post page, the blog format should be Video and the
Video format settings will show where you add the Embed code of the video.
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To add a video in the single page of the blog, you can use the Video element in the VC.

• Quote - The quoted word in the blog post will be shown in the blogs page.

• Link - A link in the blog post for a webpage will shown in the blogs page.

• Gallery - The image gallery in the blog post will be shown in the blogs page.

Note: If the settings for Video or Audio format is not displayed, go to Screen Options at the upper right
side of the screen. Click the options for Video format settings or Audio format settings, this should display
the settings.

Follow the steps below to create a blog post:

• Step 1 - Navigate to Blog Posts > Add New in the Dashboard.
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• Step 2 - Create a title and insert your post content in the editing field. You can use any of our shortcode elements
inside the post. If you want to use some additional fields, choose them from Screen Options at the top of the
screen.

• Step 3 - Add Blog Categories on the right side. Categories are meant for broad grouping of your posts, think
of these as general topics. Categories are hierarchical, so you can add sub-categories. Sub-categories are made
when a Category is added to a Parent Category . To assign it to the post, check the box next to the Category
name.

• Step 4 - To add Tags, write the Tags at the textbox below the Blog Categories. Tags are meant to describe
specific details of your posts. They are the micro-data that you can use to micro-categorize your content. Tags
are not hierarchical. Type the name of the tag in the field, separate multiple tags with commas.
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• Step 5 - To add a Single image, click the Featured Image box, select an image and click Set Featured Image.

To add more than one image, use Image Gallery (Visual Composer element) , each image will be a slide in
the gallery slideshow. Gallery can be created by adding images from Media gallery or by adding External
links of the images that will be used.

• Step 6 – To post Video, use Video Player (Visual Composer element) and paste the direct video URL from
Youtube, Vimeo or Dailymotion and more.

• Step 7 – to post Audio, use Video Player (Visual Composer element) and paste the direct audio URL from
Soundcloud, Mixcloud and more.
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• Step 8 – For Quotation, use WordPress Blockquote option (Shift + Alt + Q).

• Step 9 – For Links, use WordPress Inser/Edit Link option (Ctrl + K).

• Step 10 – Create an excerpt – Excerpts are optional hand-crafted summaries of your content that can be used in
your theme. Learn more about manual excerpts.

• Step 11 – Once finished, click Publish to save the post.

You will see all the Blogs created at Blog Posts > All Posts.

4.2 Blog Index Page

The most popular way of displaying blog posts is to setup blog index page. There all of your posts will be displayed
and ordered by publish date.

To set the page as your post page, navigate to Posts page tool in Settings > Reading and choose Blog index page from
the ones you created.
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Note: On Blog index page you will see only your posts, so don’t add any other content to it.

4.3 Blog Category

Categories are meant for broad grouping of your posts, think of these as general topics. Categories are hierarchical,
so you can add sub-categories. Sub-categories are made when a Category is added to a Parent Category.

Adding categories to a blog would make it easier to locate and post on similar topics by category.

4.3.1 Create Blog Category

To create a Category for a blog, follow these steps:

• Step 1 - Navigate your Dashboard to Blog Posts > Categories. You will see the Blog Categories page.
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• Step 2 - In the page, find the Add New Category area. Add All the necessary information.

– Name - The name of the category.

– Slug - The URL-friendly version of the name. Usually all lowercase.
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– Parent Category - If the category is a sub-category, then look for the parent category in the
drop-down box.

– Description - Description of the category.

• Step 3 - Once done filling out the information of the category, click on Add New Category button to save.

4.3.2 Delete Blog Category

To delete a Category, navigate your Dashboard to Blog Posts > Categories.

In the Blog Categories page, you will see all the created category.

To delete a category, you have two options:

• Single Delete - Hover your mouse pointer on the category that you would like to delete. You will see a Delete
option pop-up. Click on Delete to delete.

• Multiple Delete - To delete multiple categories, click on the box beside the categories you would want to
delete. Then click on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button
to delete.

4.4 Blog Tags

Tags are meant to describe specific details of your posts. They are the micro-data that you can use to micro-categorize
your content. Tags are not hierarchical.

Adding tags to a blog post would make it easier to relate a post with another post even if the categories are different.
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4.4.1 Create Blog Tags

To create a Tag for a blog, follow these steps:

• Step 1 - Navigate your Dashboard to Blog Posts > Tags. You will see the Tags page.

• Step 2 - In the page, find the Add New Tag area. Add All the necessary information.

– Name - The name of the tag.

– Slug - The URL-friendly version of the name. Usually all lowercase.

– Description - Description of the tag.

• Step 3 - Once done filling out the information of the tag, click on Add New Tag button to save.
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Note: Adding a tag may affect the tags from other component of the site.

4.4.2 Delete Blog Tags

To delete a tag, navigate your Dashboard to Blog Posts > Tags.

In the Tags page, you will see all the created tags.

To delete a tag, you have two options:

• Single Delete - Hover your mouse pointer on the tag that you would like to delete. You will see a Delete option
pop-up. Click on Delete to delete.

• Multiple Delete - To delete multiple tags, click on the box beside the tags you would want to delete. Then click
on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button to delete.

Note: Deleting a tag may affect the tags from other component of the site.
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CHAPTER 5

Events

5.1 Create New Event

To create a new event, follow the steps:

• Step 1 - To start creating an event, on your Dashboard navigate to Events > Add New. The Add New Event page
will show.

• Step 2 - Once your in the Add New Event page, you can add details about the event like title, pictures, videos,
pricing, etc., to help with the promotion of the event. You can use the Elements in Rentica to customize it to
your liking.
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• Step 3 - This are the needed information for the event, you can add the details.
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1. Title - The name of the event.

2. Editor container - You can add the information for the event, like the rules and requirements to
attend the event.

3. Excerpt - This will serve as the summary of the event.

4. Event Options - Details about the event.

– Maps API Key - API Key for the google map to work in Event Location.

– Event Location - The address/location of the event.

– All Day Event? - Option to set the time of the event for a whole day.

– Date & Time - The Start date and End date and time of the event.

5. Tags - Tags that describes the event.

6. Event Categories - Categories that can be used to group events with similar themes/category.

7. Featured Image - The Image shown in the listings/pages.

Note: To have the same look as the demo, these are the sizes for the Featured Image:

– Small - 996px x 996px

– Big - 1992px x 1992px

– Long - 1992px x 996px

• Step 4 - Add all the needed details and descriptions for the event, Once satisfied click on Publish button.

5.2 Events Category

Categories are meant for broad grouping of your posts, think of these as general topics. Categories are hierarchical,
so you can add sub-categories. Sub-categories are made when a Category is added to a Parent Category.

Adding categories to an event would make it easier to locate and post on similar topics by category.
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5.2.1 Create Events Category

To create a Category for an event, follow these steps:

• Step 1 - Navigate your Dashboard to Events > Event Categories. You will see the Event Categories page.

• Step 2 - In the page, find the Add New Event Category area. Add All the necessary information.
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– Name - The name of the category.

– Slug - The URL-friendly version of the name. Usually all lowercase.

– Parent Category - If the category is a sub-category, then look for the parent category in the
drop-down box.

– Description - Description of the category.

• Step 3 - Once done filling out the information of the category, click on Add New Category button to save.

5.2.2 Delete Events Category

To delete a Category, navigate your Dashboard to Events > Event Categories.

In the Event Categories page, you will see all the created category.
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To delete a category, you have two options:

• Single Delete - Hover your mouse pointer on the category that you would like to delete. You will see a Delete
option pop-up. Click on Delete to delete.

• Multiple Delete - To delete multiple categories, click on the box beside the categories you would want to
delete. Then click on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button
to delete.

5.3 Add Events to Page

To add events on a page, you can use elements in the Visual Composer: Events Grid or Upcoming Events
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This is the element that will add an event on the page. For more information about this element, go to Rentica Custom
Shortcodes > Events Grid/Upcoming Events.

Sample Events Page

• Events Grid

• Upcoming Events
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CHAPTER 6

Rents

6.1 Create New Rent

To create a new Rent, follow these steps:

• Step 1 - To start creating an Rent, on your Dashboard navigate to Rents > Add New. The Add New Rent page
will show.
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• Step 2 - Once your in the Add New Rent page, you can add details about the Rent like title, pictures, videos,
pricing, etc., to help with the promotion of the Rent. You can use the Elements in Rentica to customize it to your
liking.
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• Step 3 - This are the needed information for the Rent, you can add the details.

1. Title - The name of the Rent item.

2. Editor container - You can presonalize the single page of the Rent item here.

Note: The VC elements, Rent Booking and Rent Features, are recommended to be
used here. For more information about these shortcodes, click here.
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3. Excerpt - This will serve as the summary of the Rent description.

4. General - Details about the Rent.

– Price per Day - Price of the rental of the item per day. This is used for filtering purposes.

– Number of Passengers - The limit of the number of passengers for the Rent item. This is
used for filtering purposes.

– Driver - Option for the Rent item to have a driver or not. This is used for filtering purposes.

– Booki Project - This is the Booki Project that you made in Booki and you would like to use
for the Rent Booking element in the single page. To know how to create a Booki project,
click here.

5. Custom technical features list - These are the list of technical details that are added in Rents
> Technical Details. Information that are added here may be shown in Rent Search element by
adding the feature list in 10. Technical Details.

6. Rent Categories - Categories that can be used to group Rents with similar themes/category.

7. Main Features - List the main features of the rent item. You can add a new main feature or use
a pre-added feature.

8. Entertainment Items - List the entertainment features of the rent item. You can add a new
entertainment feature or use a pre-added feature.

9. Other Features - List the other features of the rent item. You can add a new other feature or use
a pre-added feature.

10. Technical Details - List the technical detail that you would like to show in the Rent Search
element.
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11. Featured Image - The Image shown in the listings/pages.

• Step 4 - Add all the needed details and descriptions for the Rent, Once satisfied click on Publish button.

6.2 Rents Category

Categories are meant for broad grouping of your posts, think of these as general topics. Categories are hierarchical,
so you can add sub-categories. Sub-categories are made when a Category is added to a Parent Category.

Adding categories to a Rent would make it easier to locate and post on similar topics by category.

6.2.1 Create Rents Category

To create a Category for Rents, follow these steps:

• Step 1 - Navigate your Dashboard to Rents > Categories. You will see the Categories page.

• Step 2 - In the page, find the Add New item area. Add All the necessary information.
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– Name - The name of the category.

– Slug - The URL-friendly version of the name. Usually all lowercase.

– Parent Category - If the category is a sub-category, then look for the parent category in the
drop-down box.

– Description - Description of the category.

– Image - Add an image to represent the category. This image will be used by the Rent Categories
element to display rent items by category.
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– Content Availability - Who can see content/posts in this category.

• Step 3 - Once done filling out the information of the category, click on Add New item button to save.

6.2.2 Delete Rents Category

To delete a Category, navigate your Dashboard to Rents > Categories.

In the Categories page, you will see all the created category.

To delete a category, you have two options:

• Single Delete - Hover your mouse pointer on the category that you would like to delete. You will see a Delete
option pop-up. Click on Delete to delete.

• Multiple Delete - To delete multiple categories, click on the box beside the categories you would want to
delete. Then click on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button
to delete.

6.3 Rents Features

Features of the rent items can be used by more than one rent item. To make it easier for the user to add features to the
rent items, users can add the features in advance and can reuse it.

These features are divided into 4 types:
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• Main Features - Features that are outstanding and the best parts of the rent item.

• Entertainment Items - Hardware and software items in the rent item that can provide audio or video
entertainment.

• Other Features - Other features or accessories that are included in the rent item.

• Technical Details - The technical details of the rent item. The items that are added here will show
in the Custom technical features list in the Rents form.

6.3.1 Create Rents Features

To create a Feature for Rents, follow these steps:

• Step 1 - Navigate your Dashboard to Rents > Main Features/ Entertainment Items/ Other Features/ Technical
Details.

• Step 2 - In the page, find the Add New item area. Add All the necessary information.
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– Name - The name of the feature.

– Slug - The URL-friendly version of the name. Usually all lowercase.

– Description - Description of the feature.

– Content Availability - Who can see content/posts in this feature.

• Step 3 - Once done filling out the information of the category, click on Add New item button to save.

6.3.2 Delete Rents Features

To delete a Feature, navigate your Dashboard to Rents > Main Features/ Entertainment Items/ Other Features/ Tech-
nical Details.

In the Feature’s page, you will see all the created features.

To delete a feature, you have two options:
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• Single Delete - Hover your mouse pointer on the feature that you would like to delete. You will see a Delete
option pop-up. Click on Delete to delete.

• Multiple Delete - To delete multiple features, click on the box beside the categories you would want to delete.
Then click on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button to
delete.

6.4 Add Rents to Page

To add events on a page, you can use elements in the Visual Composer: Rent Categories, Rent Display or Rent Search
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These are the element that will add an event on the page. For more information about these element, go to Rentica
Custom Shortcodes > Rent Categories/ Rent Display/ Rent Search.

Sample Events Page

• Rent Categories

• Rent Display
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• Rent Search

Sample for Simple Rent Search display
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Sample for With technical list Rent Search display
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CHAPTER 7

FAQ

7.1 Create FAQ Item

Frequently Asked Questions (FAQ) of Rentica is generated by the theme from FAQ items.

To create a new FAQ item, navigate in WordPress Dashboard to FAQ > Add New.

The Add New FAQ page will show, information on the FAQs can be define here.
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1. Title – The FAQ’s question should be written as the title.

2. Editor Container – Where the answers for the question is added.

3. FAQ Categories (optional) – Assign to preexisting category or add a new one.

Once done, click on Publish button.

7.1.1 Create FAQ Categories

Categories are convenient ways to organize your FAQ items, that can be added to more than just one category.

To create new FAQ Category, navigate in WordPress Dashboard to FAQ > FAQ Categories.

The FAQ Categories page will show, here you can add the details of the FAQ Category that you would like to create.
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• Name - The name of the category.

• Slug - The URL-friendly version of the name. Usually all lowercase.

• Parent Category - If the category is a sub-category, then look for the parent category in the drop-down box.

• Description - Description of the category.

• Content Availability - Who can see content/posts in this category.
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After adding all the details, click on Add New category to save.

7.1.2 Delete FAQ Categories

To delete a Category, navigate your Dashboard to FAQ > FAQ Categories.

In the FAQ Categories page, you will see all the created category.

To delete a category, you have two options:

• Single Delete - Hover your mouse pointer on the category that you would like to delete. You will see a Delete
option pop-up. Click on Delete to delete.

• Multiple Delete - To delete multiple categories, click on the box beside the categories you would want to
delete. Then click on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button
to delete.

7.2 Create FAQ Page

Frequently Asked Questions (FAQ) of Rentica is generated by the theme from FAQ.

To create an FAQ Page, follow these steps:

• Step 1 - Create a new page where to add the FAQs.
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• Step 2 - Add a row element to the page, click the Edit this row option of the row. The Row Settings will pop-up.

• Step 3 - Change the settings to your preference.

• Step 4 - In the row, to add a title for the page. You have the option to add a Text Block or Section/Header Title
element.

• Step 5 - Add a new row to add the FAQ items. The FAQ items can be generated by FAQ element in the VC.

• Step 6 - You can customize the page by adding other elements to the page.

• Step 7 - Once you have finished customizing the page, click on the Publish button.

Sample for FAQ Page
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CHAPTER 8

Portfolio

8.1 Create Portfolio Items

To create a new Portfolio Item, navigate in WordPress Dashboard to Portfolio items > Add New

The Add New Portfolio Item page will show. Add the details for the portfolio.
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1. Title - Title of the portfolio item.

2. Editor container - You can presonalize the single page of the portfolio item here.

3. Discussion - Option to allow comments in portfolio.

4. Portfolio settings

• Client

• Client website

• Details

• Date

Note: The Portfolio settings is used as the details on the sidebar of the portfolio.

5. Tags - Tags that describes the portfolio item.

6. Portfolio Categories – Categories that can be used to group the portfolio with similar themes/category.

7. Featured Image - The image visible on the page where the portfolio is used.

After adding all the details, click on Publish button to save.
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8.1.1 Create Portfolio Categories

Categories are convenient ways to organize your FAQ items, that can be added to more than just one category.

To create new Portfolio Category, navigate in WordPress Dashboard to Portfolio items > Portfolio Categories.

The Portfolio Categories page will show, here you can add the details of the Portfolio Category that you would like to
create.
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• Name - The name of the category.

• Slug - The URL-friendly version of the name. Usually all lowercase.

• Parent Category - If the category is a sub-category, then look for the parent category in the drop-down box.

• Description - Description of the category.

• Content Availability - Who can see content/posts in this category.
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After adding all the details, click on the Add New category button to save.

8.1.2 Delete FAQ Categories

To delete a Category, navigate your Dashboard to Portfolio items > Portfolio Categories.

In the Portfolio Categories page, you will see all the created category.

To delete a category, you have two options:

• Single Delete - Hover your mouse pointer on the category that you would like to delete. You will see a Delete
option pop-up. Click on Delete to delete.

• Multiple Delete - To delete multiple categories, click on the box beside the categories you would want to
delete. Then click on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button
to delete.

8.2 Create Portfolio Grid View

Portfolio grid view is made by using the WPBakery Page Builder.
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To get the same look as the sample above, follow these steps:

• Step 1 - In your wordpress dashboard, go to WPBakery Page Builder > Grid Builder, and click the Add New
button.

• Step 2 - You will be directed to the Add Grid template page.
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1. Title - The title of the grid template you are making.

2. Grid Builder - Area where you can customize the look of your grid template.

• Step 3 - To get the same look as the sample, in the Grid Builder, change the drop-down box to Scale in. This
will give your grid an overlay of color if hovered.

• Step 4 - Set the following information in the Normal tab’s settings.
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– General tab

* Height mode - Original

* Add link - Post link

* Use featured image on background? - Yes

* Image size - 476x476

• Step 5 - Set the following information in the Hover tab’s settings.
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– General tab

* Add link - Original

– Design Options tab

* Background - rgba(0,0,0,0.7)

• Step 6 - Add the following elements in the Hover tab.
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– Icon - The icon that will show in the grid when you hover your mouse pointer.
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* Icon library - Font Awesome

* Icon - Choose what you like.

* Icon color - White

* Background shape - Rentica: Outline Circle (Lighter White Border)

* Background color - White

* Size - Mini

* Icon alignment - Center

– Post Title - Where the title of the item that is used will show.
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* Element tag - h6

* Text align - center

– Post taxonomy - The category of the item being shown.
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* Taxonomy name - ct-portfolio-taxonomy

* Limit - 1

• Step 7 - Once done with all the changes, click Publish to save.

8.3 Create Portfolio Page

Portfolio of Rentica is generated by the theme from Portfolio Items.

To create a simple Portfolio Page, follow these steps:

• Step 1 - Create a new page where to add the Portfolio.
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• Step 2 - Add a row element to the page, click the Edit this row option of the row. The Row Settings will pop-up.

• Step 3 - Change the settings to your preference.

• Step 4 - In the row, to add a title for the page. You have the option to add a Text Block or Section/Header Title
element.

• Step 5 - Add a new row to add the Portfolio Items. To add the Portfolio Items, add a Post Masonry Grid element
to the page.

• Step 6 - Change the following information to get the Portfolio Items.
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-General Tab-

– Data source – Ct-portfolio (setting this option, images will be taken from Portfolio item)

– Total items – Choose number of elements that will be visible on the site.

– Display Style – Load more button

– Items per page - Set number as desired.

– Show filter – Yes

– Grid elements per row – choose 3, 4 or 6 Elements per row

– Gap – 30px

– Initial loading animation – Default

-Item Design-

– Grid element template – Choose the masonry grid that you made by following this tutorial.

• Step 7 - You can customize the page by adding other elements to the page.

• Step 8 - Once satisfied with the page, click Publish to save.
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Sample Portfolio Grid View
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CHAPTER 9

Team Member

9.1 Create Team Member

To create a new Team Member item, navigate in WordPress Dashboard to Team members > Add New.

The Add New Team member page will show. Add the details for the team member.
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1. Title - The name of the team member.

2. Editor container - You can add here the role of the team member that will be shown in the website.

3. Team options

• Position - Team member’s position in the company.

• Pinterest url - Team member’s Pinterest account.

• Facebook url - Team member’s facebook account.

• Twitter url - Team member’s twitter account.

4. Team Categories

5. Featured Image - Team members picture that will be shown in the site.

After adding all the details, click on Publish button to save.

9.1.1 Delete Team Member

To delete a Team member, navigate your Dashboard to Team members > All Team members

In the Team members page, you will see all the created team members.

To delete a Team member, you have two options:
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• Single Team member Delete - Hover your mouse pointer on the testimonial that you would like to delete. You
will see a Trash option pop-up. Click on Trash to delete.

• Multiple Team member Delete - To delete multiple testimonials, click on the box beside the testimonials you
would want to delete. Then click on the drop-down box for Bulk Actions and choose the Move to Trash option.
Click on Apply button to delete.

9.2 Create Team Category

Categories are convenient ways to organize your Team items, that can be added to more than just one category.

To create new Team Category, navigate in WordPress Dashboard to Team > Team Categories.

The Team Categories page will show, here you can add the details of the Team Category that you would like to create.
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After adding all the details, click on Add New category to save.

9.2.1 Delete Team Category

To delete a Category, navigate your Dashboard to Team > Team Categories.

In the Team Categories page, you will see all the created category.

To delete a category, you have two options:

• Single Delete - Hover your mouse pointer on the category that you would like to delete. You will see a Delete
option pop-up. Click on Delete to delete.
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• Multiple Delete - To delete multiple categories, click on the box beside the categories you would want to
delete. Then click on the drop-down box for Bulk Actions and choose the Delete option. Click on Apply button
to delete.

9.3 Create Team Member Page

Teams of Rentica is generated by the theme from Team members items.

To create a simple Team Page, follow these steps:

• Step 1 - Create a new page where to add the Teams page.
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• Step 2 - Add a row element to the page, click the Edit this row option of the row. The Row Settings will pop-up.

• Step 3 - Change the settings to your preference.

• Step 4 - In the row, to add a title for the page. You have the option to add a Text Block or Section/Header Title
element.

• Step 5 - Add a new row to add the Team members items. To add the Team members items, add a Team Display
element to the page.

• Step 6 - You can customize the team memebers that you want to display using the filters. Click Save changes to
save.
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• Step 7 - You can add more elements on the page as you like. Once satisfied, click on the Publish button.

Sample of Team Members in a Page
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Booki Plugin

Booki is a modern booking plugin for WordPress. This plugin allows you to setup appointments or reservations with
time that adapts to users timezone. You can make payment via PayPal or simply book and pay later.

10.1 Create New Booking Project

To create a booking project, navigate to Booki > Projects.
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You will be directed to the Create, edit, and delete projects page.

As the page name suggests, you can create, edit, and delete projects in this page.

To create a new project, follow these steps:

Under the Projects tab:

• Step 1 - Choose Create new in the Project’s drop down box.
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• Step 2 - Add the name of your project.

• Step 3 - Fill in the needed information as required for your booking.

Note: Read the descriptions of the information to be guided.

– Booking mode

– Maximum booking days or time slot

– Minimum booking days or time slot

– Calendar mode

– Tag

– Project listing settings

* Description

* Preview Image

– General project settings

* Project status

* New Booking Notification Recipient(s)

* Default step

* Booking wizard mode

* Ban list

* Default date selected

– Booking control label settings

* Booking tab caption

* Custom form fields tab caption

* Attendees tab caption
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* Available days field label

* Selected days field label

* Booking time field label

* Optional features heading

* Next button caption

* Back button caption

* Create booking button caption

* From

* To

* Proceed to login label

* Make booking label

* Available seats label

– Optional HTML content

* Content above booking calendar

* Content below booking calendar

• Step 4 - After all the needed information are added, click the Create button to save.

• Step 5 - Once the project is created, you will see the project short code below the project name.

Note: The short code is used to call the project that you would like to use in an element
or widget.

• Step 6 - Also, after the project is created, other tabs beside project can now be use to customize your
project.
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– Form builder - Create a booking form that allows the user to input information for the
booking.

* Element type

* Label

* Value

* CSS class name

* Column Index

* Row Index

* Validation - Basic constraints

* Validation - Advance constraints

– Booking period - Specify the days that allows booking.

* Booking date range: Start date & End date

* Minimum notice

* Email reminder

* Seats

* Deposits

* Quantity elements general settings

* Quantity elements

* Days to exclude from list of days in selected season

* Cost

– Optional Lists - Add in the booking form extra billable items option for the user.
These are displayed as checkboxes and are added to the bill.

* Optional Item Name

* Cost

– Optional Cascading Lists -

* Select Cascading List

* Label

* Is required

* Value

* Cost

* Dropdown list items

* Select the parent list

10.1.1 Delete Booking Project

To delete a project in booki, navigate to Booki > Projects.

You will be directed to the Create, edit and delete projects page.
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Choose the project you want to delete at the Project dropdown box. The Project dropdown box have all the available
projects.

Scroll down and look for the Delete button.

10.2 Add Booki Project to Rent Page

To add a Booki Project to a Rent page, you must use the Rent Booking element in the VC. This will let you add the
booking form of the Booki Project.

Choose the Booki Project that you would like to use in General > Booki Project.
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If you don’t add a Booki Project, the area where you add the Rent Booking element will be blank.
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CHAPTER 11

Contact Form

11.1 Create Contact Form

To create a new Contact Form item, navigate in WordPress Dashboard to Contact > Add New.

The Add New Contact Form page will show. Add the details for the Contact Form.
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1. Title - The title for the Contact Form

2. Form Details - Details and information of the form.

• Form - The codes for the user interface of the form.

• Mail - Set the email template of the form.

• Messages - Message prompt when an action is done with the form.

• Additional Settings - You can add customization code.

After adding all the details, click on Save button to save.

Note: For information on how to use this plugin or what markup to use click here to go to General Information >
Unyson, Extension, and Plugins > Contact Form 7.

11.2 Create Contact Page

Contact Form Page of Rentica is generated by the theme from Contact Form item.

To create an Contact Form Page, follow these steps:

• Step 1 - Create a new page where to add the Contact Form.
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• Step 2 - Add a row element to the page, click the Edit this row option of the row. The Row Settings will pop-up.

• Step 3 - Change the settings to your preference.

• Step 4 - In the row, to add a title for the page. You have the option to add a Text Block or Section/Header Title
element.

• Step 5 - Add a new row to add the Contact Form item. The Contact Form can be generated by Contact Form 7
of Theme Element.

• Step 6 - The Contact Form 7 Settings will pop-up. Change details as needed.

– Select contact form - The form you want to add to the page.
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– Search title - Optional title to search if no form is added.

• Step 7 - You can customize the page by adding other elements to the page.

• Step 8 - Once you have finished customizing the page, click on the Publish button.
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CHAPTER 12

MailChimp Plugin

MailChimp for WordPress helps you add more subscribers to your MailChimp lists using various methods. You can
create good looking opt-in forms or integrate with any other form on your site, like your comment, contact or checkout
form.

12.1 Create New MailChimp Form

To start with making a MailChimp Form, you must set up a MailChimp list in your MailChimp Dashboard. You can
read how to make a MailChimp list in this article.

Once you have made the MailChimp list, you can make the MailChimp Form.

• In your wordpress dashboard go to MailChimp for WP > Form

Note: Free users: You should be taken to the ‘Edit form’ page straight away.

Premium users: you will need to make a new form by clicking the ‘Create New Form’ button atop
the Sign-up Forms list.
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• You will be redirected to Edit Form, you will see the content of the form here.

• You can add a field in your form by clicking the buttons in Choose a field to add to the form. The items in the
List fields are the items in your MailChimp list.

• To change the look of your form, you can go to the Appearance tab of the MailChimp form. You can choose the
style in Form Style. You can customize the style of the form, just read these article.

• Once you are done, click on the Save Changes button.

12.2 MailChimp Form on Page

Directly to the Page

• You can add the MailChimp shortcode directly to the page where you would like to add it.
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• You can get the MailChimp shortcode at the bottom of the Mailchimp Form or by clicking <> Get shortcode
button below the title of the form.

• Create a new page where to add the the shortcode.

12.2. MailChimp Form on Page 173



Rentica, Release

174 Chapter 12. MailChimp Plugin



Rentica, Release

• Write the MailChimp shortcode at the Editor container.

• You can add other elements in the page if you like. Once done, click on publish.

Integration with Contact Form 7

• You can see other plugins that can be integrated with MailChimp in MailChimp for WP > Integrations.

• Here you can see that contact form 7 is capable on integrating with MailChimp.
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• Click on Contact Form 7 under Enabled Integration to configure the settings.

• Once you are done with the configuration, click on Save Changes button.

• On your dashboard, go to Contact > Add New to create a integrated form in contact form 7.
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• Add the title of the form then create the form by clicking the coding or clicking the buttons on what you would
like the form to show.

Note: To successfully integrate the value from the Contact Form to MailChimp, the tags in contact
form should be the same as of the tags in MailChimp.
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• On the page where you want to add the contact form, add a Contact Fom 7 element to the area you want the
form to show.
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• Then select the form title of the form. You can add other elements in the page if you like. Once done, click on
publish.

Sample Contact Form with the 2 methods
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Rentica, Release

180 Chapter 12. MailChimp Plugin



CHAPTER 13

Revolution Slider

13.1 Edit a Revolution Slider

To edit an existing revolution slider, in your dashboard go to Slider Revolution > Slider Revolution.

You can see the existing revolution slider at the Revolution Sliders area. Choose the revolution slider that you would
like to edit.
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In the Slide Editor, you will see the slides that are created for a revolution slider. Click on the slide you want to edit.

You can edit the text and image content of the revolution slider as you see fit in the editor. For more info on how to
use the Revolution Slider, click here.

Once you are satisfied, click the Save Slide button at the upper right of the page.
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CHAPTER 14

Widgets & Menu

14.1 Widgets

Widgets are small blocks of content, which you can find in theme footer or sidebar. They were originally designed
to provide a simple and easy-to-use way of giving design and structure control of the WordPress Theme to the user,
which is now available on WordPress Themes to include the header, footer, and elsewhere in the WordPress design
and structure.
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14.1.1 Sidebars

In Rentica you have access to 7 sidebars that can be customized using available theme widgets.

• CT Footer column 1, 2, & 3
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You can enable/disable the footer in the Appearance > Customize > Footer, then uncheck the Display CT Footer.

• CT Post Footer column 1 & 2

You can enable/disable the post footer in the Appearance > Customize > Footer, then uncheck the Display CT Post
Footer.

• Blog sidebar
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You can enable/disable blog sidebar in the Appearance > Customize > Blog Settings > Blog/Single blog post, then
uncheck the Display blog sidebar.

14.1.2 How to Edit Widgets

You can access widget edit screen under Appearance > Widgets panel or via Customize on path Appearance > Cus-
tomise > Widgets. It has three main areas:

• Available Widgets

• Inactive Widgets

• Inactive Sidebars and widget areas

To add a widget to your site, drag and drop the name of the widget you want to use from the Available Widgets section
into one of the widget areas on the right-hand side of the window. After you have added it, the widget will open up (or
if it doesn’t, you can click on the triangle to open it) and you can change the settings and save the widget. The specific
settings needed will depend on what type of widget you are using. For instance, if it is a text widget, you just need to
type in the text (and optionally, HTML code), and save the widget.

14.2 Menus

Menus are a list of commands or options you can customize for you to use in your site. This guide covers the basic
tasks a user may carry out when using the built-in menu editor.

14.2.1 Menu Setup

To make a simple menu, follow the steps:

• Step 1 - Navigate your Dashboard to Appearance > Menus. The Menus page will show.
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• Step 2 - In the menus page, you can edit a menu or make a new menu. To make a new menu, locate create a
new menu.

• Step 3 - You will be ask to name your menu. After naming the menu, click Create Menu.

• Step 4 - From the right side choose pages, links, or categories that you want to add to your menu and click on
Add to Menu. Once menu items are added, you can reorder or nest them via drag and drop tool. Remember to
click Save Menu when you finish to keep your changes saved.
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• Step 5 - You can set a menu as a Top primary menu or Secondary menu in the left sidebar.

1. Top primary menu - Visible on the top of the page. For this theme, it is the Top Bar Menu.

• Step 6 - After any changes, click on Save Menu button.
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14.2.2 Multi-level Menu Setup

When planning the structure of your menu, it helps to think of each menu item as a heading in a formal report
document. In a formal report, main section headings (Level 1 headings) are the nearest to the left of the page; sub-
section headings (Level 2 headings) are indented slightly further to the right; any other subordinate headings (Level 3,
4, etc) within the same section are indented even further to the right.

The WordPress menu editor allows you to create multi-level menus using a simple ‘drag and drop’ interface. Drag
menu items up or down to change their order of appearance in the menu. Drag menu items left or right in order to
create sub-levels within your menu.

To make one menu item a subordinate of another, you need to position the ‘child’ underneath its ‘parent’ and then drag
it slightly to the right.

• Position the mouse over the ‘child’ menu item.

• While press and holding the left mouse button, drag it to the right.

• Release the mouse button.

• Repeat these steps for each sub-menu item.

• Click the Save Menu button in the Menu Editor to save your changes.
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CHAPTER 15

Customising Rentica

Rentica comes with an advanced customizer, which allows to edit most of the theme’s elements in one place. If you
want to use it, navigate to Appearance > Customize.
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15.1 Site Identity

Here you will have the option to customize your site’s identity or how it can be viewed by people.
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• Logo - Logo of the site that will be displayed in the header.

• Site Title - The title of the site you created.

• Tagline - The slogan/catchphrase for you site. What people will remember if they see your site.

• Display Site Title and Tagline - Option to show the site title & tagline.

• Site Icon - The icon used as a browser icon. Icons must be square, and at least 512 pixels wide and tall.

Add all the information you like to add, then click on the Save button.
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15.2 General Settings

The General Settings is divided into 2:

• General

– MOTIVE COLOR - The primary color scheme of the site.

– ONEPAGE SITE - Option to activate the effects of onepager mode.

– PRELOADER - Display preloader before page is loaded.
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• 404 Page

– 404 BACKROUND IMAGE - Background image in the 404 page.

– 404 MESSAGE - Text shown in the 404 page.

– 404 BUTTON TEXT - Text inside the button in the 404 page.
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Add all the information you like to add, then click on the Save button.

15.3 Header & Navigation

The Header & Navigation is where you set the behavior of the header and how it looks.

The header settings is divided into 3 parts:
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• Header Settings

– PAGE HEADER - Option to display page header on top of the page. (Customizable in options of every
page)

– MAIN PAGE HEADER - Appears when Page Header is Yes.

– HEAD SECTION TYPE - Choose which type of head section you want to display (works only when
header is enabled).

– BACKGROUND IMAGE - Default background image of the header.

– HEAD HEIGHT - Height in pixels of the header.

– PARALLAX RATIO - Speed of the parallax of the header if header type is parallax.

– BACKGROUND COLOR - Background color of the header.
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• Header Elements

– TITLE COLOR - Text color of the header text.

– TITLE DIVIDER - Option to add a divider.

– BORDERED HEADER - Option to add a border for the header title.

– BORDER COLOR - Color of the header title if border header is Yes.

• Navigation Settings

– SEARCH - Option to add a search icon at the header navigation.

– MOBILE LOGO - Logo for the mobile menu in mobile view.
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Add all the information you like to add, then click on the Save button.

15.4 Blog

This is where you can customize the Blog side bar location:

The blog is divided into 2 parts:
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• Blog Page

– BLOG SIDEBAR - Option to display sidebar on blogs page.

– SIDEBAR LOCATION - Area where the sidebar is located.

– SOCIAL SHARE ICONS - The social share icons that are shown in the blogs page.
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• Single Blog Post

– BLOG SIDEBAR - Option to display sidebar on blogs page.

– SIDEBAR LOCATION - Area where the sidebar is located.

– TAGS - Option to display the tags of the blog below the social share icons.

– SOCIAL SHARE ICONS - The social share icons that will be displayed in the blogs.

– COMMENT - Option to allow comments in the blog.
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Add all the information you like to add, then click on the Save button.
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15.5 Event

This is where you can customize how the Events Single Post would look.
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• Event Single Post

– ADD EVENT TIMER IN HEADER - Option to display the event timer in header.

– SCROLLDOWN BUTTON - Option to display a scroll down button in the header.

– CATEGORIES - Option to show the categories of the event after the post.

– TAGS - Option to display the tags of the event after the post.

– SOCIAL SHARE ICONS - Option to choose what social share icons will display below the
post.

– ENTER EVENTS PAGE URL - The page URL for the “BACK TO EVENTS” button below
the event image.

Add all the information you like to add, then click on the Save button.

15.6 Portfolio

This is where you can customize how the Portfolio Single Post would look.
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• Portfolio Single Post

– PORTFOLIO SIDEBAR - Option to display a sidebar in the portfolio single post.

– SIDEBAR LOCATION - If portfolio is displayed, this option will show. Option where the
sidebar is located.

– ENTER PORTFOLIO PAGE URL - Add a URL link for what page will redirect when you
click the icon in the middle of previous and next button.
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Add all the information you like to add, then click on the Save button.

15.7 Rent

This is where you can customize the Rent account and Rent Item single post:

The Rent is divided into 2 parts:
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• Account

– ENTER LOGIN PAGE URL - URL link for the login page.

• Rent Item

– SCROLLDOWN BUTTON - Option to display a scroll down button in the header.

– SOCIAL SHARE ICONS - Option to choose what social share icons will display below the
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post.

Add all the information you like to add, then click on the Save button.

15.8 Footer

Option for the footer is shown here.
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• Display CT Footer - Option to display the CT Footer area of the site.

• Display CT Post Footer - Option to display the CT Post Footer area of the site.

Add all the information you like to add, then click on the Save button.

15.9 Homepage Settings

Option for the front page is shown here.

• Front page displays - Options on how the front page/home page looks like.

– Your latest posts - Show the latest post on your blogs.
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– A static page - Set a page that would stay the same until the page is replaced manually.
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Note: You can also do this using the Homepage Setup instructions in Page > Homepage Setup.

15.10 Menus

You can change the details and settings of a menu here.

15.10. Menus 215

http://rentica-wp.readthedocs.io/en/latest/Page/Homepage.html#content


Rentica, Release

Menus - These are the menus made by you. You can make/add a new menu or delete it here.

Menu Location - Rentica has a Primary Menu as the menu for the site.

• Top primary menu - Choose which menu in the Menus you would like to use as the primary menu.
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Note: You can also do the same thing by following Menu Setup instructions in Widgets & Menu > Menu > Menu
Setup.

15.11 Widgets

You can customize what is inside the widgets on the page.

Note: If a widget is placed on the page you see on the preview, it will be listed on the left side under widgets.
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• CT Footer column 1

• CT Footer column 2

• CT Footer column 3

• CT Post Footer column 1

• CT Post Footer column 2

• Footer

Note: You can also do the same thing by following How to Edit Widgets instructions in Widgets & Menu > Widgets.
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15.12 Additional CSS

You can add your own CSS code for your site.

Add all the information you like to add, then click on the Save button.
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