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1. Neutrino User Guide

Neutrino is a general purpose simulation and visualization environment developed by
Neutrino Dynamics Initiative.  Neutrino Dynamics is composed of a group of diverse scientific
research team distributed around the world.
Neutrino currently provides research organizations, academia,
various industries a full-featured simulation and visualization environment for the most
demanding tasks and problems.
Neutrino is currently in use in many diverse sectors, including energy research, risk analysis, flooding & bio fuel catalysis.


1.1. Requirements


1.1.1. Hardware Requirements

Neutrino runs on the following hardware


	PC/Mac with atleast 8 GB Memory, Intel/AMD processors


	HPC Cluster







1.1.2. Operating Systems

Neutrino currently runs on the following platforms more platforms are in the works of being
supported


	Microsoft Windows 7/8/10


	Microsoft Windows 2012/2016 Server R1/R2


	CentOS 7.x +


	Ubuntu 13.x +


	SuSE Enterprise 11.x +


	Red Hat Enterprise Linux 7+


	Fedora Linux 16+


	OS X 10.9+







1.1.3. Essential Components


	
	OpenGL 4.x Compatibility mode drivers.

	
	If OpenGL Software drivers (Mesa) are used - Mesa 11.x +















1.1.4. GUI Mode Requirements


1.1.4.1. Recommended Graphics Cards


	NVIDIA Kepler Architecture and above




Optional


	CUDA


	OpenCL











1.2. Installation

Please run the downloadable binary (.run file for Linux/OS-X platforms , .exe for Windows platforms)
and specify the install path for the binaries. The rest of the setup is automatic.




1.3. Interface

Neutrino’s user friendly
interface enables easy setup of models for simulation. Parameters and
operators can be added easily to perform the various operations.
Interface items are depicted below.

[image: _images/n2.png]

1.3.1. Toolbars

[image: _images/sidebar.png]

Scene Inspector

Description of Various Tools in Neutrino.






1.3.2. Scene Inspector

[image: _images/sceneInspectorTree.png]

Scene Inspector

The Scene Inspector contains all the items in the scene which can be selected. The selected item’s properties are displayed in the property editor. Context menu items appear as the right mouse button is pressed with the object being selected.






1.3.3. Property Editor

[image: _images/propedit2.png]

Property Editor

Property Editor is an user editable list of properties for the selected scene item. The properties of the rigid
vary according to the type of item selected.






1.3.4. Scene Builder

[image: _images/SceneBuilder.png]

Scene Builder

Scene Builder is a panel where entries in the scene can be constructed easily without navigating through the menu items.
|
The various categories of neutrino nodes are on the side shelf panel and upon selection they reveal the nodes.
Nodes are created and placed in the scene upon click on that button.






1.3.5. System Inspector

[image: _images/image3.png]

System Inspector

System Inspector is a list of global system entries whose properties can be edited as well.



By default there are four(4) entries in the System Inspector. Selecting each of these entries in the Object Browser
will reveal the properties of them. System Inspector are global entities during each session.


	Base










	Parameter

	Description





	OpenMP Threads

	Number of Threads Neutrino will use for Simulation (8)



	Server Port

	If Neutrino is controlled by external communication protocol the socket number (20200)



	Scene Path

	Specify the information needed to be exported.



	Data Read Directory

	Specifies the directory where all the caches for entries in the scene reside



	Data Write Directory

	Specifies where the cache data will be written onto



	Optimize Net Caches

	In certain cases setting this will optimize block writes onto network drives



	Compress Fluid Caches

	This will create fluid caches with compression but for large particle counts this might
result in performance loss







	GUI










	Parameter

	Description





	Timeline Units

	Number of Threads Neutrino will use for Simulation (8)



	Save OpenGL Frames

	If Neutrino is controlled by external communication protocol the socket number (20200)







1.3.5.1. GL Properties

A Neutrino session can have several interactive views for visualization and model setup and the main engine to render them is OpenGL. Its properties are as follows

[image: _images/glproperties.png]

Rendering Properties .

Many of the global rendering parameters can be controlled using these.
These include Ambient occlusion, transparency etc.




	OpenGL




There can be many OpenGL objects depending on how many views are present in the scene. By default this is 1. The views can be split according to user specification and the View menu described later controls the splits and usage of multiple visualization/model setup views.

The main properties control the render of each of these views.







	Parameter

	Description





	Camera

	The Camera used for rendering this view



	On Screen Display

	Whether or not to display statistics



	Manipulator Space

	Local Space operates with respect to the center of the object .



	World Axes

	The axes ON/OFF in the visualization window



	World Grid

	Whether a flat grid is drawn in the visualization or not



	Clipping

	Uses a normal for clipping objects - Deprecated in favor of a Clipping Object



	Silhouette

	Unused and deprecated



	Ambient Occlusion

	Turning this on produces self shadows and better looking renders (HBAO)



	Antialiasing

	The method used for improving quality of lines etc in the gl/visualization window



	Transparency

	The transparency method used - different modes are a trade-off between quality/time



	Environment Type

	The background image used in visualization (either cube 6 sides or sphere



	Quality Profile

	The render quality used for preview/visualization. Some features are turned off/on for



	Draw Render Area

	Not used



	Save Frames

	Save the frames displayed in this specific visualization window/GL to file (png)



	Save Motion Maps

	DEPRECATED











1.3.6. Timeline

[image: _images/timelineannotated.png]

Timeline

TimeLine, used to record and playback the simulation.















The two modes are Simulate and Playback. Simulate mode is activated by the button. The play button is then used to either simulate (Simulate Mode) or Play (Playback Mode).






















[image: _images/simarmed.png]





Turns Green when armed and ready to simulate
Simulation is Armed to proceed. Next Play would actually Simulate the scene.




















[image: _images/simsim.png]





Run simulation if Armed or just playback the recorded simulation from caches if not armed.


























1.3.7. Connection Inspector

[image: _images/connectioninsp.png]

Connections

View and Modify input/output connection to/from nodes.
Connection Inspector is used to connect various inputs and outputs from nodes to process during simulate/playback mode.
The emitter’s creates Particles (kIOParticles) which is connected to the solver’s input.
Solver’s output (kIOParticles) can be connected to the Measurement Field’s input (kIOParticles).










In Neutrino you can consider all the objects displayed in the Scene Inspector to have inputs and outputs and they
are evaluated during a simulation.
For example the output of a particle emitter would be particles (kIOParticles) and that is automatically connected to
the input of a solver (kIOParticles) .
Some connections are automatically made for example in this case.
But for some other cases the user has to make the connections manually depending on what the scenario is.
If the particle emitter’s  kIOParticles to the solver connection is deleted then there would be no particles input
to the solver and hence no solve.
Neutrino node’s most common inputs/outputs are the following
kIOParticles, kIOTriangleMesh kIOVolumes

























1.3.8. Script Editor

[image: _images/image6.png]

Script Editor

Python based command window.


Script Editor Commands

Script Editor could be used for performing any action in Neutrino but through the python interface. The python interface
to Neutrino’s system is explained in a separate section.








1.3.9. Node Graph Editor

Node Graph Editor, used to visualize various connections.
It can be seen clearly that all fluid objects go to IISPHSolver and measurement field takes data from
IISPHSolver to determine the parameter we are interested in.

Currently its still under works and not recommended for use.

[image: _images/nodegrapheditor.png]



1.3.10. Interactive View Window


Objects can be selected, transformed in the world space visible throught the selected camera
in the GL Widget View. There can be many such views which can be created and deleted in the scene and they are synchronized with each other.

Each view can be split into 2 duplicated and assigned different cameras on the View Menu on top of this window

[image: _images/glviewoptions.png]













If you select an object and select the translate (toolbar) on the left side a translate handle appears in the gl preview window.
you can select each of the arrows in the axes and move them around and that moves the object.
Same goes for scale and rotate, their tools are in the left toolbar.

[image: _images/gltranslatehandles.png]
[image: _images/glrotatehandle.png]
[image: _images/glscalehandle.png]









The camera for the view is selected from the Camera Menu item at the top of the View Window


1.3.10.1. Camera

Alt and mouse will turn the camera around







Alt + middle will pan the camera







Alt + Right will zoom in.out








If a camera gets stuck somewhere you can reset it by selecting the camera in the scene builder and
third mouse button and reset camera.




[image: _images/glcamreset.png]























1.3.11. Neutrino Nodes

Neutrino nodes are entities which can be created in Neutrino which exist in the scene and their properties could be modified by the user. They can be connected/created/deleted etc.

Common to all Neutrino nodes are the following properties







	Property

	Description





	Behavior

	Active: Participate, Cache: Just Load Data, Inactive: Dont participate



	CacheData

	Whether data for this node should be cached/not









1.3.12. Spatial Nodes

Spatial nodes are nodes in Neutrino which can be positioned and modified in Space and exist in 3D/2D space in the view. Examples of Spatial Nodes include Rigid Nodes, Cameras, Lights Fields etc. For some of these nodes positions matter and some others they dont.

The common properties to spatial nodes are the following




1.3.13. Rigid Nodes

For Model setup and 3D Geometry various rigids can be imported into Neutrino which
can then serve as active boundary conditions for the simulation.

Edit ‣ Add ‣ Physical ‣ Rigid

performs this task.

Or the scene builder could be used to accomplish this.

Neutrino accepts various types of implicit and explicit geometry. The basic ones are
1. Box
1. Cuboid
1. Sphere
1. Cylinder

However external geometry modeled in another package such as strata,
Sketchup could be imported  by

Edit ‣ Add ‣ Physical ‣ Rigid Custom

or through

Scene Builder ‣ Physical ‣ Rigid ‣ Rigid Custom

Neutrino currently supports the following subset of file formats


1.3.13.1. COMMON INTERCHANGE FORMATS

1. Autodesk ( .fbx )
1. Collada ( .dae )
1. Blender 3D ( .blend )
1. 3ds Max 3DS ( .3ds )
1. 3ds Max ASE ( .ase )
1. Wavefront Object ( .obj )
1. Industry Foundation Classes (IFC/Step) ( .ifc )
1. XGL ( .xgl,.zgl )
1. Stanford Polygon Library ( .ply )
1. AutoCAD DXF ( .dxf )
1. LightWave ( .lwo )
1. LightWave Scene ( .lws )
1. Modo ( .lxo )
1. Stereolithography ( .stl )

Future extensions are planned as to import various architectural and engineering formats such as DWG and STEP

The Property editor of the new rigid object added has a file name property to import the rigid geometry.

When Rigid Custom is used with STL file, there might be a difference in scale in which the imported geometry might have to be scaled by 0.01 on
all axes to match the units or appropriate unit conversions need to be performed from the STL modeling units since Neutrino just assumes the units
in the input STL file as meters.

Import of Rigids creates a rigid body seeded with rigid SPH particles.

Some of the properties, like viscosity,
adhesion, density and so on, can also be modified easily in
the scene inspector window. The rigid body can either move with the
fluid (dynamic) or stay at constant position (static).




1.3.13.2. Bounding Box

The bounding box display can be activated by

[image: _images/bbox_display.png]





1.3.14. Emitter Nodes

Various particle emitters that emits particles
can be created using

Edit ‣ Add ‣ Daemons ‣ Emitter

Please note For emitters to emit particles a solver needs to be present.


1.3.14.1. Planar Emitters


1.3.14.1.1. Flow Particle emitter

Flow emitter is a particle emitter rectangular in shape which will emit particles at a constant flow as specified by the
flow rate in properties or by a time varying input file.

The rate is specified as part of the properties.
If there is a time dependent file specifying various flow rates at times that can
be loaded as well from the file parameters.

The flow input file of Flow Emitter has the following format:
time, flow rate, width, height;
within a line, all are separated by a comma. The file name extension must be “.csv”.
An example of such a csv file can be Downloaded at FlowRate.csv

The velocity is calculated from the flow rate, width and height.
Only flow in the normal direction to the emitter plane can be created.

Edit ‣ Add ‣ Daemons ‣ Emitter ‣ Flow Particle Emitter

The properties of the Flow Particle Emitter are as follows








	Property

	Description





	Shape

	Number of Threads Neutrino will use for Simulation (8)



	Flow Setting

	Flow Rate Mode



	Velocity is controlled by rate



	Flow Rate

	Flow Rate in m^3/s of the fluid injected into the system



	Speed Mode



	Magnitude of velocity Setting, Flow rate is adjusted



	Flow Rate & Speed Mode



	Area is adjusted appropriately



	Flow Speed

	Magnitude of the velocity in m/s of the flow



	Pipe Pressure Mode



	Flow based on static pressure



	Upstream Pressure

	


	Downstream Pressure

	


	Particle Data Mode



	Input can be time dependent number of particles injected



	Flow Data Mode



	Time dependent input of flowrates vs time as described



	Data File Mode



	Flow rates in a data file (csv)



	Connected Inputs

	The Input connections coming into this node



	Advanced Properties

	








1.3.14.1.2. Torricelli Particle Emitter

Torricelli Particle Emitter is an emitter which models a hydrostatic cuboid source such as a container of fluid
enclosing it and a hole punched in through it.

Torricelli particle emitters can be coupled by laying several in a row and by connecting output kIOParticles of one to another to serve as input.

The Torricelli Particle Emitters can be created from

Edit ‣ Add ‣ Daemons ‣ Emitter ‣ Torricelli Particle Emitter








1.3.15. Volume Fluid Emitters

The following section describes volume emitters. This operates a bit differently than the other emitters and is usually used
when needing to fill containers with fluid. Rather than use dynamic emitters which take a certain amount of time to fill a container
with fluid and settle down, the following emitters in Neutrino could be used as a starting point.




1.3.16. Block Emitter

Block Emitter fills a closed rigid object like a cuboid with fluid. To create a block emitter

Edit ‣ Add ‣ Daemons ‣ Emitter ‣ Block Particle Emitter




1.3.17. Volume Emitter

We can also build fluid bulk with imported closed geometry by converting the rigid body into fluid
particles. The interior of the geometry could be filled with particles.

This is useful for example, if a container of an arbitrary shape needs to be filled with fluid.

Several boolean operations could be performed and daisy chained together using the volume tools in Neutrino to create a desired
container of fluid to be filled with. The emission can be started/stopped at a given time/frame of simulation by the node parameters.

The various volume nodes which can be used are described in the next section.

First the rigid object needs to be converted into a signed distance field (volume) by
adding Mesh to Volume

Edit ‣ Add ‣ Volume ‣ MeshtoVolume

Several cases can be considered after this step


	Basic Container fluid emitter




Volume Particle Emitter

Add ‣ Daemon ‣ Volume Particle Emitter

and finally making the appropriate connections.

Rigid Objects kIOTriangleMesh (output) is connected to MeshToVolume’s kIOTriangleMesh (input)
then
MeshToVolume kIOVolume (output) is connected to Volume Particle Emitter’s kIOVolume (input)

Firstly a mesh can be converted to a volume .
When you import a rigid object or create one in Neutrino - one of the output of that is kIOTriangleMesh and
when you create a MeshToVolume node in Neutrino - one of its inputs is kIOTriangleMesh.
So a Rigid Objects output kIOTriangleMesh could be connected to input of MeshToVolumeNode kIOTriangleMesh.
The output of MeshToVolume is kIOVolume .
This output would be connected to a Volume Emitter daemon (kIOVolume). and the output of that is kIOParticles
which is automatically connected to the solver.

So when a simulation is run in this case the mesh is sampled into a volume filed on the
inside then particles are instantiated from the volume and then sent to the solver.

The volume nodes are explained below.




1.3.18. Volume Nodes

Volume nodes in Neutrino are a set of nodes which have an input or an output as kIOVolume. The volume output from Neutrino are
OpenVDB [https://www.openvdb.org/] volumes. OpenVDB [https://www.openvdb.org/]  is a sparse volume representation. These nodes can be created by

Edit ‣ Add ‣ Volume


1.3.18.1. MeshToVolume

This node accepts kIOTriangleMesh as input and sends kIOVolume as output. The input mesh can be an open or closed mesh. In case of
an open mesh, only the boundaries are converted into a volume.




1.3.18.2. PartToVolume

This node accepts kIOParticles as input and sends kIOVolume as output. The particles are converted into an implicit surface by this node.




1.3.18.3. VolumeFilter

This node accepts kIOVolume as input and outputs kIOVolume. Several topological operations are availabe under this node. Erode, Dilate, Open, Close etc.




1.3.18.4. VolumeCombine

This node accepts one or two input kIOVolume inputs and outputs a combined kIOVolume. Some of the operations available under this node are
Union, Intersection, Sum, Difference etc. This is a node in which the connection order matters as the operation is performed on the first node by the second node.






1.3.19. Particle Killer Nodes

There are different kinds of killers . Killers can be used to save computational time
by removing particles outside the domain or for other purposes like teleporting and/or transporting
particles through obstacles etc. The particles killers can be added by

Edit ‣ Add ‣ Daemons


1.3.19.1. Extent Particle Killer

Particle Killer daemon eliminates particles inside or outside a specified
bounding box. and all particle entering the region of particle killer
will be eliminated.




1.3.19.2. Flow Particle Killer

Just a brief guide on the Flow Particle Killer, its differences compared to the Teleport Particle Killer,
and how to use it with the Flow Particle Emitter altogether.

The Flow Particle Killer is a killer that kills the particles crossing its finite plane section;
compared to the Teleport Particle Killer, it does not kill all the particles within
the other side of the infinite plane.
An outflow boundary is simulated using ghost particles when the permeable mode is activated.
There is no need of a Ghost Volume.
It also includes a flow rate computation, and the corresponding value can be read.

You can connect a Flow Particle Killer to a Flow Particle Emitter.
The connection comes in two modes: flow rate mode and teleport mode.
The former is realised if kIOData is the input-output type, and the latter in the case of kIOParticles.
You can check the connection mode of the emitter in its Property Editor window.

In the flow rate mode, the emitter generates particles according to the flow rate computed by the killer.
The advantage of this mode is that the killer and emitter scales do not need to be the same.
It currently tends to be unstable and does not conserve mass that well; use with caution. I might test a few things to have it working properly in the future.

In the teleport mode, the emitter generates the particles as if they teleported from the killer.
This mode requires the dimensions of the killer and emitter to be the same; prefer it to the flow rate
mode when applicable.

Finally, you can specify a delay between the killing and emission
through the Property Editor of the emitter.




1.3.19.3. Coupler Nodes




1.3.19.4. Inflow Coupler

Inflow shallow water (SW) coupler is now functional.


1.3.19.4.1. Description

Given the topology of the inflow boundary and SW data at gauge positions, the inflow SW coupler generates particles accordingly, enforcing inflow boundary conditions (Dirichlet for the velocity and Neumann for the pressure) and mass conservation, and also avoiding the particle deficiency issue of SPH near boundaries.




1.3.19.4.2. Method

The boundary topology is defined by the positions of the gauges and extremity points and the connections between gauges/extremity point. If the boundary is assumed to be along a rectangle, the connections are automatically computed. The boundary is partitioned into several “sources”, one for each pair of gauges or gauge/extremity point. A source generates particles with a given inflow velocity and height at a time. Interpolations in space and time are performed for Enforcement of the boundary conditions is realised through the use of ghost particles, with velocity prescribed according to the SW data and pressure extrapolated from the neighbouring fluid particles. The ghost particles are generated as far from the boundary as needed in order to avoid the particle deficiency issue. Minimal deviation from mass conservation is ensured with a particle generation minimising the deviation from a rest density, Cartesian grid configuration within a volume defined by the source width, inflow height and velocity, provided by the SW data, and time step.




1.3.19.4.3. Assumptions


	The gravity is in the y-direction, while the fluid displacement is in the x- and z- directions.


	The flow direction is perpendicular to the boundary.


	The boundary topology can be defined as a set of simple, connected, undirected graphs with vertex degrees not higher than two.


	The ground floor is flat at the boundary location.











1.3.20. Particle Fluid Solver Nodes


1.3.20.1. Setup

Fluid solver is key to SPH simulation, particles movements and key
properties are determined the solver. The Solver can be added by

Edit ‣ Add ‣ Physics ‣ Particle Fluid ‣

or through the scene builder by

Physical ‣ Particle Fluid ‣




1.3.20.2. Implicit Incompressible Solver Nodes




1.3.20.3. Neutrino IISPH Solver

There are many key parameters of simulation that can be easily changed
in Neutrino Solver.

Table : Key factors of IISPH Solver and how they can be changed in
specific simulation conditions








	Factors                                          | Choices & Comments





	Integration Scheme

	Verlet (second order integration)/Euler Cromer



	Viscosity Model

	Laminar (a more physical model)/ Artificial



	Solver tolerance

	Max. compressibility allowed as a percentage



	Max. Iteration

	Max number iterations steps to calculate pressure
Usually set to 100 but convergence is reached in usually < 20
more than 20 iterations is usually a sign of slowness/prob



	Max. Time Step

	Max. unit time step allowed
defaults to 0.02 but can be increased to more if blowups and
high velocity projectiles/splashes are not encountered



	Viscosity

	Fluid-fluid viscosity



	Cohesion/Adhesion Coefficient

	Surface tension/wettability coefficient



	Particle Interaction Radius/Particle Rest Distance

	Any change here will be automatically synchronized elsewhere
Interaction Radius is usually 2 times interparticle distance
if cubic spline kernel is used
Interaction Radius is modifiable and rest distance will be set
automatically based on the kernel and other factors
This is the main parameter indicating resolution of simulations



	Kernel Model

	Cubic Spline (Quintic and Weindland kernel support planned



	Particle Visualization

	Different parameter-base coloring; Max./Min. coloring limit



	
	










1.3.21. Neutrino WCSPH Solver Node

Neutrino’s Weakly Compressible SPH Solver can be created by NWCSPH Solver. In certain cases of gas flows/wind fields and non-isothermal flows




1.3.22. Measurement Field Nodes

Sometimes, we would like to measure some parameters in certain area of
interests, in Neutrino additional measurement can be set up onto
any position by Add -> Daemons -> MeasurementField and moving the field to
desired position.
The volume enclosed by the measurement field will be taken into consideration for measurement.


1.3.22.1. Rigid Force Measurement and Data Export

[image: _images/mf.png]

Measurement

Measures Various Quantities of fluid and rigids in the simulation.



To export the force applied by the fluid onto a rigid, do the following:

1) Before simulating, turn on Show Total Force/Torque, to force the solver performing the fluid->solid force computations.
This step is not necessary if the rigid object is dynamic.


	When your simulation is done, first turn on Export Force and enter a path to Export File Path, then playback the simulation.




3) The force data can be found under the repository Measurements.
Let me know if this works for you.
You could also export the pressure and friction components of the force by turning on Export Force Decomposition.

Also in the rigid body Compute Forces/Compute Torque has to be checked to be able to
check the forces on the rigid.

The output file contains a header that specifies what are the units. Something like:

Time (s), Position X,Y,Z (m), Linear Velocity X,Y,Z (m/s), Angular Velocity X,Y,Z (rad/s), Force X,Y,Z (N), Torque X,Y,Z (N.m) ##




1.3.22.2. Fluid Properties Measurement and Data Export

After we put the measurement field in desired position, we can export
the measured parameters by checking the “Export Stats” box in Scene
Inspector. The Measurement field’s input kIOParticles has to be connected to
Solver’s output (kIOParticles) by means of the Connection editor in order for
measurement field to start measuring particle quantities.

Also we can visualize the velocity field inside the
measurement field. Available options of measured data are listed as
following:







	Options

	Meaning





	Export Per Particle

	If checked, information for all particles will be exported at each time step. Or an average will be taken and exported with time
If not checked then averaged information for the measurement field will be written for all timesteps in one file.



	Export Path

	No need to add extension or the full path name. The measurements will be stored under the Measurements subfolder under the current scene
folder.



	Export Type

	Specify the kind of information to be exported . (Not for Per Particle Output)



	Subdivide

	Divide the measurement field with specified mesh division.
If checked, resolution of grid in each direction can be designated by entering the number you want.
Then information will be averaged across each grid to the center of the mesh.



	Velocity arrow scale

	Specify the length of arrow in velocity field. Larger value will give a longer arrow.







[image: _images/image9.png]







1.3.23. Visualization Nodes

Edit ‣ Add ‣ Visual

Any node specically used for Visualization and Rendering only are created from this section.


1.3.23.1. Camera Node

Edit ‣ Add ‣ Visual ‣ Cameras ‣ Camera

This creates a new perspective camera in the scene. The cameras view can be altered interactively or through the properties and the camera can be assigned to a specific view.




1.3.23.2. Light Nodes


1.3.23.2.1. Directional Light

Edit ‣ Add ‣ Visual ‣ Lights ‣ Directional Light

The default light in the scene is a directional light and it shades objects based on direction of the light .




1.3.23.2.2. Spot Light

Edit ‣ Add ‣ Visual ‣ Lights ‣ Spot Light

Spot lights with cone and varying intensity based on distance to light can be created using this light. Creates a more realistic lighting scenario




1.3.23.2.3. Area Light

Edit ‣ Add ‣ Visual ‣ Lights ‣ Area Light

Not functional yet




1.3.23.2.4. Image Based Light

Edit ‣ Add ‣ Visual ‣ Cameras ‣ Camera

Not functional yet




1.3.23.2.5. Sky Light

Edit ‣ Add ‣ Visual ‣ Cameras ‣ Camera

Not functional yet






1.3.23.3. Material Nodes


1.3.23.3.1. PBR

Edit ‣ Add ‣ Visual ‣ Materials ‣ PBR

Physically based shading/rendering of rigid objects. Can be used for metals and other diffuse surfaces




1.3.23.3.2. Phong

Edit ‣ Add ‣ Visual ‣ Materials ‣ Phong




1.3.23.3.3. Structure

Edit ‣ Add ‣ Visual ‣ Materials ‣ Structure

Not functional




1.3.23.3.4. Toon

Edit ‣ Add ‣ Visual ‣ Materials ‣ Toon

Shades rigid objects




1.3.23.3.5. Tone

Edit ‣ Add ‣ Visual ‣ Materials ‣ Tone

Shades rigid objects with tone varying based on a primary color.




1.3.23.3.6. Ocean

Edit ‣ Add ‣ Visual ‣ Materials ‣ Structure

Not functional yet.




1.3.23.3.7. Clear Water

Edit ‣ Add ‣ Visual ‣ Materials ‣ Clear Water

Assigned only to fluid surfaces. Not functional yet.




1.3.23.3.8. Fluid Water

Edit ‣ Add ‣ Visual ‣ Materials ‣ Fluid Water

This is the material which is assigned to particles for fluid to emulate fluid/water like shading with transparency, reflection and refraction.






1.3.23.4. Gizmos


1.3.23.4.1. Null Gizmo

:menuselection:`Edit –> Add –> Visual –> Gizmo –> Null Gizmo`

Null Objects could be placed in the scene.




1.3.23.4.2. Interactive Measurement Gizmo

*Edit ‣ Add ‣ Visual ‣ Gizmo ‣ Interactive Measurement Gizmo*

Measurement can be made in the scene in default scene units (m) using this gizmo. Place the first null at the start point and the second one at the end point and measurement will be shown.




1.3.23.4.3. Clip Plane Node

Edit ‣ Add ‣ Visual ‣ Clip Plane

Objects in the scene can be clipped according to where the clipping plane is placed.








1.3.24. Measurement Data Output

The output can be a text file or a csv file and the output can be either one file / frame of simulation or output for all frames for all particles.
To make it work. Make sure that the kIOParticles of the solver is connected to kIOParticles of the MeasurementField in the connection editor
which it looks like you are already doing since the property editor is displaying those values.

Then check the Export Stats to ON
Then set the Export Path to a some name, by default the name would be the name of the measurement field. For example MeasurementField_0

TXT files are stored with the extention .txt and CSV files are stored with an extension .csv

If particle data for all frames is desired then check the box
Export Per Particle should be set to ON.

Then Rewind the simulation to the beginning.

Then either run the simulation or playback.

The per particle data is stored per frame under Measurements folder with the prefix Measurement File Name and frame number with .txt

For Example MeasurementField_0.000000.txt etc




1.3.25. Visualization/Playback and Recording


	Visualization results are in the Visualization directory.

	
	OpenGL visualizations are under GLFrames/<Camera Name> folder and stored as a png sequence.


	Recording of these images are described in the following sections.









1.3.25.1. Viewing Results

As Neutrino proceeds with the simulation, the results are displayed in the interactive GL Visualization Window. There are several sections to the Visualization window




1.3.25.2. On Screen Displays

The On Screen Displays displays (OSD), display various properties of the nodes in the simulation. There’s a integrated OSD from the Neutrino Dynamic System and there are various user created OSDs.


1.3.25.2.1. Integrated OSD

The integrated OSD displays information about the various nodes in the Neutrino Scene and Global Nodes as well. Each Neutrino node has an OSD property indicating the location of the OSD and some nodes have a toggle to Display Statistics ON/OFF which will turn ON/OFF the display of that node’s OSD. The integrated OSD is depicted in the figure Fig. 1.1


[image: _images/MainOSD1.png]


The integrated OSD is toggled ON/OFF for display as depicted in the figure Fig. 1.2


[image: _images/ViewOSD.png]





1.3.25.2.2. User Defined OSD

There’s another OSD which could be user defined and placed in the scene interactively. Its display is depicted by figure Fig. 1.3. The properties of this OSD could be configured to display user defined custom text labels and Option to turn on/off global time display.


[image: _images/GlobalOSDConf.png]







1.3.25.3. Image recording

Current OpenGL Window used for viewing can be exported as a sequence of frames for playback later.

First check “saveGLFrames” under GUI system inspector and
then check “Save Frames” under the Camera system inspector.


[image: _images/saveframes.png]



[image: _images/saveframes2.png]


Their resolution also can be set as follows


[image: _images/image13.png]


After this is set when either Simulation is either “Run” or “PlayBack” the frames are stored as png files under the appropriate
Camera Name folder under Visualization sub folder under the Scene Folder. The images are prefixed by the padded frame number and its stored
as an image sequence. To convert it into movies for playback, ffmpeg [https://www.ffmpeg.org/] could be used.

For example to store the image sequence as a movie file (MPEG4) for playback in VLC Player or web sites or presentations the following command
could be used.

ffmpeg -i %06d.png -c:v libx264 -r 15 -pix_fmt yuv420p out.mp4










1.3.26. Rendering/Export to VTK/Renderers

Neutrino data can also be exported to VTK [http://www.vtk.org] or other third party visualization packages like ParaView [http://www.paraview.org/] .


1.3.26.1. VTK/ParaView Export

To export the scene data for ParaView [http://www.paraview.org/] VTK files have to be exported. To setup VTK [http://www.vtk.org] export open Render->External Renderer Settings.
[image: vtkRender]  
 The Renderer is set to VTK . Then playback or simulate the simulation in Neutrino. By default the
VTK [http://www.vtk.org] files go under RenderData subfolder under the Scene folder.

Static Rigid Geometry are exported with .vtp extension
Measurement Fields if subdivided are exported as volume files (structured grid) .vts
Particles are exported as vtp as well. Particle data is exported once per frame to be loaded into ParaView [http://www.paraview.org/] easily.






1.3.27. Neutrino Scene Data


1.3.27.1. Results


The results of the simulation are all placed under a directory under the scene directory with the scene name




1.      Log
1.      Measurements
1.      RenderData
1.      SceneGeometry
1.      SimData
1.      Visualization




1.3.27.2. Scene Directory Structure

The following is an example of the directory structure of a sample scene.


[image: _images/sceneTree.png]


All of Neutrino data pertaining to a scene reside in a directory with the same scene name as the .nescene file currently open.


	
	Logs

	
	Messages - Where the log of simulation runs are stored by data










	
	Measurements

	
	MeasurementFieldName - Directory under which measurement data are cached










	
	RenderData

	
	Where data exported to a third party renderer like VTK etc are stored










	
	SceneGeometry

	
	All the local geometry obj, stl files etc stored for use in the scene are here. Rigid pathnames without a path refer to a file stored here.










	
	SimData

	
	
	SphData

	
	
	SolverName

	
	
	The particle caches are stored here

	######.neparticles - Particle data is cached here per frame. Particle data format is documented in the following section
######.sinf - information pertaining to a frame of particles















	
	EmitterName

	
	Various data pertaining to particle emitters in the scene are stored here.
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2. Neutrino API Guide


2.1. Introduction

Neutrino supports dynamic loading of various kinds of plugins which are recognized as they are placed
in the appropriate folder under Neutrino Data.




2.2. Plugin Types


	
	Solvers

	
	Particle Solvers










	
	Emitters

	
	Particle Emitters










	Force Fields


	Surface Generation


	Materials





2.2.1. Particle Solvers

Its best to explain plugins in Neutrino with the help of an example plugin.

In this case lets take an example of an implementation of a sample solver plugin
Look at the example in Data/Plugins/SampleSPHSolver

This implements a solver based on predictive corrective SPH.


2.2.1.1. Building the plugin

A sample qmake pro file is included in the plugin. Please update the NE_BINARY_PATH to where the binary Neutrino is installed.
Typically this is the directory containing the file neutrino.lib or neutrino.so depending on the Operating System.

Execute qmake and build/make.

The dlls or so of the plugin is installed in Neutrino_Install_Directory/Data/Plugins

Next time neutrino is started it loads the plugins from this directory structure. The various kinds of plugins supported by neutrino are indicated
by the subfolders under Plugins.

For example a solver plugin would be under

Neutrino Data Folder (Neutrino Install Dir/Data)
| Plugins -> release -> Spatial -> Physical -> SphFluid (For Release build)

Neutrino finds the plugin type from the directory structure and the type of plugin written and loads it in the Plugin Manager




2.2.1.2. Simulation Init

* NESceneManager::startUpdateTimer()
        * NESceneManager::prepareSceneForSimulation()
                * NESimulationManager::preparePhysicalsForSimulation
                        * NERigidManager::prepareRigidsForSimulation()
                                * Ex: NESphBox::generateBoundaryParticles
                        * NECollisionManager::update()
                                * NECollider::update()
                                * NEUniformGridCollider::update()
                                        *       Ex: NESortedHashingCollider::constructGrid()
                                        *       Ex: NESortedHashingCollider::insertRigidsIntoGrid()
                                        *       Ex: NESortedHashingCollider::insertStaticRigidIntoGrid()
                        * NEGeometryManager::update()
                        * NEPostProcessManager::update()








2.2.1.3. Simulation Update

* NESceneManager::update()
        * NESimulationManger::update()
                * NELiquidManager::updateForces()
                        * NESphLiquidSolver::update()
                * NESphLiquidManager::integrate()
                        * NESphLiquidSolver::integrate()
                * NECollisionManager::update()
                        * NECollider::update()








2.2.1.4. Classes


	
class NESampleSimpleSolver


	Implementation of a simple particle solver. 

A Simple Solver which moves particles 

Inherits from NESphLiquidSolver


Public Functions


	
uint NESampleSimpleSolverinit(uint initMode = NE::kInitOnCreate)


	Node initialization function, should be called from all inheriting classes. 






	
virtual void NESampleSimpleSolverdeleteParticles()


	Deletes all marked particles out of the vector. 






	
virtual void NESampleSimpleSolverdeleteParticle(NEParticle *particle)


	Deletes the particle. 






	
virtual bool NESampleSimpleSolverexplicitBoundaryHandling() const


	Returns true if explicit boundary handling is required used when integrating particles. 






	
virtual uint NESampleSimpleSolvermemoryConsumption()


	Returns the memory consumption of the particles. 








Public Slots


	
virtual void NESampleSimpleSolveraddParticles(NEParticleSource *source, std::vector<NEParticle> &newParticles, const vec3f vel)


	For adding particles to the fluid, for example by a source that is connected to the fluid. 






	
void NESampleSimpleSolverupdate()


	The main update routine for single-phase fluids, called by Liquid Manager. 






	
NESphUpdatePart NESampleSimpleSolverupdateMultiPhase(NESphUpdatePart currentStep)


	The main update routine for multiphase fluids. 






	
virtual qreal NESampleSimpleSolverupdateTimeStep()


	Computes the required time step and sets it. 






	
virtual uint NESampleSimpleSolversaveFrameData(QString path, const int frameNumber)


	Overloaded function, to additionally save the timestep. 






	
virtual uint NESampleSimpleSolverloadFrameData(QString path, const int frameNumber)


	Overloaded function, to additionally load the timestep. 






	
void NESampleSimpleSolversetRadius(qreal r)


	Overloaded function for modifying fluid radius. 






	
void NESampleSimpleSolversetRestDensity(qreal density)


	Overloaded function for modifying rest density of the fluid. 


















2.3. Neutrino Classes

The full class documentation can be found under classes




2.4. Particle Cache Format

Download NEParticleLoader.cpp - sample code which loads an NEParticle cache file and displays
information.

The particle cache file is divided into the following sections


	Header




	1
2
3
4
5
6
7

	     struct NEBinaryDataSection
     {
             short Id;
             int contentFlag;
             int nParticles;
             long long Offset;
     };








	Section Data




Particle as stored sequentially with their corresponding data described as follows.

	 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12

	     enum NEParticleDataType
     {
             IdPosition = 1,
             Color = 2,
             Velocity = 4,
             Density = 8,
             Pressure = 16,
             Vorticity = 32,
             Normal = 64,
             Neighbors = 128,
             Type = 256
     };







struct Color32
{
        inline Color32(){}
        inline Color32(uchar r, uchar g, uchar b, uchar a)
        {
                red = r; green = g; blue = b; alpha = a;
        }
        uchar red;
        uchar green;
        uchar blue;
        uchar alpha;
        inline void Set(uchar r, uchar g, uchar b, uchar a)
        {
                red = r; green = g; blue = b; alpha = a;
        }

        // Some preset colors
        static Color32 kRed;
        static Color32 kGreen;
        static Color32 kBlue;
        static Color32 kMagenta;
        static Color32 kYellow;
        static Color32 kCyan;
        static Color32 kOrange;
        static Color32 kWhite;
        static Color32 kBlack;
};





Data structure describing per particle data.

class NEParticle
{
public:
        NEParticle() :  m_Id(0), m_Color(200,200,255,255), m_Position(0,0,0), m_Velocity(0,0,0),
                m_Density(0), m_Pressure(0), m_Normal(0,0,0){}

        virtual ~NEParticle()  {}

        inline const vec3f& position() const { return m_Position; }
        vec3f& position() { return m_Position; }
        inline void setPosition(const vec3f& position) { m_Position = position; }

        inline const vec3f& velocity() const { return m_Velocity; }
        inline vec3f& velocity() { return m_Velocity; }
        inline void setVelocity(const vec3f& velocity) { m_Velocity = velocity; }

        inline uint id() const {return m_Id; }
        inline void setId(const uint id){m_Id = id; }

        inline const Color32& color() const { return m_Color; }
        inline void setColor(Color32 color) { m_Color = color; }


        inline float density() const { return m_Density; }
        inline float& density() { return m_Density; }
        inline void setDensity(const float density){m_Density = density; }

        inline float pressure() const {return m_Pressure; }
        inline float& pressure() { return m_Pressure; }
        inline void setPressure(float pressure){m_Pressure = pressure; }

        vec3f normal() const { return m_Normal; }
        void setNormal(vec3f val) { m_Normal = val; }

        uint type() const { return m_Type; }
        void setType(const uint &Type) { m_Type = Type; }


protected:

        uint m_Id;
        //      Modifying the relative order of color and position will break the renderer
        // NEW: keep these variables at the end of the member variables list
        Color32 m_Color;
        vec3f m_Position;
        vec3f m_Velocity;
        float m_Density;
        float m_Pressure;
        vec3f m_Normal;
        uint m_Type;
};
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3. Neutrino Physics

This document is a rough guide for the internal physics implementation of the Neutrino SPH solver.
More details of the implementation could be found in [SAMPATH2016], [AKINCI2012] and [IHMSEN2014] and [MKSIISPH].


3.1. Introduction

Smoothed Particle hydrodynamics (SPH) is a common mesh-free
Lagrangian method. It was originally introduced for dealing with astrophysical,
compressible fluid flows [MM1994], and later, its range
of application domain extended to a wider variety of flows, such as
non-Newtonian fluids , granular flows ,
and even solid deformation and fracture . SPH has
been applied to incompressible, free-surface flows for more than two
decades along with the closely related moving
particle semi-implicit (MPS) method. Mainly,
two approaches have been used in SPH for enforcing incompressibility:
(1) state equation-based SPH (SESPH), in which a compressible approach is employed
with an equation of state, relating density, pressure and speed of
sound in the fluid, and (2) in incompressible SPH (ISPH), in which pressure forces
are implicitly computed and iteratively refined by solving a pressure
Poisson equation until the desired compressibility is reached.

SPH requires the computation of sums over dynamically changing sets
of neighboring particles. Spatial data structures are employed to
accelerate the neighborhood search, and efficient construction and
query are thus essential. While hierarchical data structures are used
in simulations with a variable particle interaction radius ,
uniform grids are more efficient when the radius is fixed. The cell
size is usually set to the interaction radius. Index sort-based grids
are often preferred, because the basic grid suffers
from low-cache-hit rate and race conditions during parallel construction.




3.2. SPH Theory

SPH is a numerical method for both interpolating quantities and approximating
spatial differential operators from a set of known quantities at sampled
positions. Among the different ways to interpolate from scattered
data, SPH relies on the use of radial basis functions. The value of
a field at any point of space is estimated based on the value of this
field at neighbor sampling points and its distance to them.

Usually a particle in physics is a minute quantity of matter and could be
one of the following



	Smallest constituents of matter (Standard Model)


	Nanoparticles, colloidal particles


	Dust, powder, ashes


	Sediment grains, water droplets etc.








	However the particles in SPH have the following properties

	
	They are material points


	They have volume, mass, pressure, density, etc.











3.3. SPH Approximation

Particle a has position ra, mass ma, volume Va, etc.
* Particle interaction are computed using the ’kernel’ w(r)
* Cubic Spline Kernel is used in Neutrino




3.4. SPH Kernels

The kernel function used for interpolation in SPH must satisfy a certain number of properties.
* It must be defined on a compact support
* It must also be radial, feature a Gaussian-like shape, be sufficiently smooth
* It is even and normalized leads to a first-order consistent continuous SPH interpolation.
* Note that the particle distribution has an impact on the accuracy.
* A regular and isotropic distribution is desired.

In Neutrino, the cubic B-spline kernel like the following is employed.


[image: _images/kernel2d.png]
Fig. 3.1 Cubic Spline Kernel






3.5. SPH Navier-Stokes Equations

The single-phase, isothermal, incompressible, Newtonian fluid flows
are the considered physical model. In addition, the viscosity is assumed
constant in space, and the surface tension forces are ignored. The
Navier-Stokes equations in their Lagrangian, velocity-pressure formulation
then reads:


(3.1)\[\begin{split}\frac{dv}{dt} & =-\frac{1}{\rho}\nabla{} p+\nu\boldsymbol{\nabla^2}\text{v}+\text{g}\\\end{split}\]


(3.2)\[\begin{split}\frac{d\rho}{dt} & =-\rho\boldsymbol{\nabla}.\boldsymbol{v}\\\end{split}\]


\[\mathbf{v} =
velocity\]


\[\mathbf{p} = pressure\]


\[\mathbf{\nu} = viscosity\]

and


\[\mathbf{g} = gravity\]

Equation (3.1) comes from the momentum
conservation, and involves pressure, viscosity, and gravity forces.
Equation (3.2) is derived from the mass conservation.
The incompressibility condition is satisfied either by


\[\frac{d\rho}{dt} = 0\]

or


\[\boldsymbol{\nabla}.\boldsymbol{v} = 0;\]

these two ways are equivalent in the continuous representation.




3.6. SPH Solvers


3.6.1. Implicit Incompressible SPH (IISPH)

Neutrino base solver is named as IISPH. IISPH
solver computes pressure by iteratively solving a linear system to meet the incompressibility
criterion. IISPH is based on semi-implicit
form of the density prediction using the time rate of change of the
density. By discretizing the continuity equation


\[\frac{{D\rho}}{{Dt}} = - \rho\nabla\]


\[\frac{\rho_{i}(t + t)}{t} = \sum_{j}^{}{m_{j}\mathbf{v}_{\mathbf{\text{ij}}}\left( t + t \right)\mathbf{\bullet \nabla}W_{\text{ij}}(t)}\]

The unknown velocities
\(\mathbf{v}_{\mathbf{\text{ij}}}\left( t + t \right)\) depend on
unknown pressure values at time , it’s firstly predicted using any known
non-pressure forces such as gravity, surface tension and viscosity. Then
the predicted velocity is used to determine a predicted density.


\[\mathbf{v}_{\mathbf{\text{ij}}}^{\text{adv}} = \mathbf{v}_{\mathbf{i}}\left( t \right) + t\frac{\mathbf{F}_{i}^{\text{adv}}(i)}{m_{i}}\]


\[\rho_{i}^{\text{adv}} = \rho_{i}\left( t \right) + t\sum_{j}^{}m_{j}\mathbf{v}_{\mathbf{\text{ij}}}^{\text{adv}}\mathbf{\bullet \nabla}W_{\text{ij}}(t)\]

Now the pressure forces to resolve the compression is searched based on:


\[t^{2}\sum_{j}^{}{m_{j}\left( \frac{\mathbf{F}_{i}^{p}(t)}{m_{i}} - \frac{\mathbf{F}_{j}^{p}(t)}{m_{j}} \right)\mathbf{\bullet \nabla}W_{\text{ij}}\left( t \right) = \rho_{0} - \rho_{i}^{\text{adv}}}\]

Where \(\mathbf{F}_{i}^{p}(t)\) is calculated by1:


\[\mathbf{F}_{i}^{p}\left( t \right) = - m_{i}\sum_{j}^{}m_{j}\left( \frac{p_{i}\left( t \right)}{\rho_{i}^{2}\left( t \right)} + \frac{p_{j}\left( t \right)}{\rho_{j}^{2}\left( t \right)} \right)\mathbf{\nabla}W_{\text{ij}}(t)\]

From this point, a linear system can be got with unknown pressure value
for each particle with the form:


\[\sum_{j}^{}{a_{\text{ij}}p_{j} = b_{i} = \rho_{o} - \rho_{i}^{\text{adv}}}\]

With the calculated pressure on each particle, the unknown velocity
\(\mathbf{v}_{\mathbf{\text{ij}}}\left( t + t \right)\) can be
calculated as:


\[\mathbf{v}_{\mathbf{i}}\left( t + t \right) = \mathbf{v}_{\mathbf{\text{ij}}}^{\text{adv}} + t\mathbf{F}_{\mathbf{i}}^{p}(t)/m_{i}\]

Then we will need this velocity to calculate the position of each
particle. In Neutrino, different time integration schemes are applied.




3.6.2. Time Integration


3.6.2.1. a. Euler Cromer Integration

In Euler Cromer integration scheme, the new position of particle is
calculated as:


\[\mathbf{x}_{\mathbf{i}}\left( t + t \right) = \mathbf{x}_{\mathbf{i}}(t) + t\mathbf{v}_{i}(t + t)\]




3.6.2.2. Verlet Integration

Verlet scheme calculate the new position as:


\[\mathbf{x}_{\mathbf{i}}\left( t + t \right) = \mathbf{x}_{\mathbf{i}}\left( t \right) + t\mathbf{v}_{i}\left( t + t \right) + 0.5t^{2}\mathbf{F}_{i}\]

The numerical tests show Verlet scheme has less numerical dissipation
than Euler Cromer, this is because Verlet has a higher order calculation
of position.








3.7. Momentum Equation

The conservation of momentum equation can be described as:


\[\frac{D\mathbf{v}}{\text{Dt}} = - \frac{1}{\rho}\mathbf{\nabla}P + \mathbf{g} + v_{0}\nabla^{2}\mathbf{v}_{\text{ab}}\]

\(\tau\) represents the viscosity term. In Neutrino, two different
viscosity models are applied: a. Artificial viscosity; b. Laminar
Viscosity.


3.7.1. Artificial Viscosity

The particle acceleration due to artificial viscosity proposed by
Monaghan[MM1994] is defined as:

With


\[\mu_{\text{ab}} = \frac{h\mathbf{v}_{\text{ab}}\mathbf{r}_{\text{ab}}}{\mathbf{r}_{\text{ab}}^{2} + \eta}\]

Distance between particles a and b is


\[\mathbf{r}_{\text{ab}}\]

Average sound speed of particle pair a & b


\[\overset{\overline{}}{c_{\text{ab}}} = \frac{c_{a} + c_{b}}{2}\]

Average density of particle pair a & b


\[\overset{\overline{}}{\rho_{\text{ab}}} = \frac{\rho_{a} + \rho_{b}}{2}\]

\(\eta = 0.01h^{2},\ \alpha\) is the artificial viscosity parameter
and it can be understand in term of kinematic viscosity as[LIU03]:


\[v_{0} = \frac{\text{αhc}}{8}\]




3.7.2. Laminar Viscosity

The laminar viscosity proposed by Morris[MORRIS97] is defined as:


\[\frac{d{{v}}_{a}}{{dt}} = - \sum_{b}^{}{m_{b}\left( \frac{4v_{0}\mathbf{r}_{\text{ab}}\mathbf{\bullet}\mathbf{\nabla}W_{{ab}}}{{(\rho}_{a} + \rho_{b})\mathbf{r}_{\text{ab}}^{2}} \right)}\mathbf{v}_{{ab}}\]


\[v_{0}  \text{ is the kinematic viscosity of fluid simulated}\]






3.8. Boundary Handling

The fluid-rigid boundaries require special attention. First, discontinuities
of physical quantities that occur at boundaries are problematic
for the usual forms of SPH. Proper boundary handling is necessary
to avoid underestimated densities and non-physical pressure
forces. Furthermore, pressure and friction forces between the fluid
and the rigid bodies must be accounted for, and non-penetration must
be ensured. Handling of thin objects or with complex geometries is
particularly challenging, as well as when multiple dynamic objects
are involved. Different strategies have been proposed through
use of distance-based penalty forces, frozen particles
, mirror particles [LIU03] or a
wall renormalisation factor.

In Neutrino an
efficient technique based on frozen particles and able to cope with
complex boundaries, multiple bodies and the discontinuity issue is
employed. Moreover, the technique uses fluid-rigid pressure
and friction force models conserving linear and angular momentum.


3.8.1. Single Layer Boundary Mode

Appropriate adjustments are made to the boundary conditions to ensure the particle
deficiency in using a single layer of particles.

The boundary coefficient is impacting the magnitude of the pressure forces, and it was empirically calibrated.




3.8.2. Multi Layer Boundary Mode

Currently Under Development






3.9. Fluid Structure Interactions

Using a standard SPH method in the sense that the time-integrated scheme works as classically done, with the following chronological steps (at each time step) :


	compute the accelerations using the positions and velocities;


	update the velocities using the accelerations;


	update the positions using the velocities;




Typically, the steps 2) and 3) consists in a variant of Euler, Runge-Kutta, or velocity Verlet method.


3.9.1. IISPH vs Position Based Dynamics (PBD)

Conversely, PBD reformulates the force computations as a set of constraints on the positions and updates the positions directly without using the velocities.
1) compute the constraints using the positions and velocities;
2) update the positions by solving for the constraints;
3) update the velocities using the positions.
Typically, the Stormer-Verlet method, or a higher-order equivalent one, is used.






3.10. Sample Cases & Validations


3.10.1. Dam Break

Dam break is simulated by lots of SPH program or software to demonstrate
the SPH’s power of dealing free-surface slamming phenomena. In this
case, we measure the force exerted by fluid particles onto the dam
structure and compare the results with experimental data. The simulation
is one-to-one scale to real experiments and set up as in Figure 1
according to Cummins work[CUMMINS12]. In neutrino, we firstly put the
gate in position and wait for 1 sec until all fluid particles are
settled down. Then we open the gate and let the fluid flow under the
effects of gravity.

[image: _images/image15.png]
Figure : Comparison of the forces (Simulated Vs Experiment)

[image: _images/dam_break_img.png]
Figure : schematic diagram of the dam geometry[CUMMINS12]

Dual-Sphysics, Neutrino and LAMMPS-SPH can all fulfill dam-break case,
which make it possible to compare their accuracy and time consuming.
Besides, the force exerted from fluid particles to rigid body is an
important factor to our purpose, by comparing the simulation data to the
real experimental data, the feature of each software can be clearly
seen. Table 2 shows the comparison of key parameters for each program. A
comparison of simulated force to experimental data is shown in Figure 2
and a good agreement is found.

Table : comparison of experimental measurement, neutrino, LAMMPS-SPH and
Dual-SPHysics










	
	Force Measurement

	# Particles

	Time Consumption (sec/step)

	Avg. unit Time step (sec)





	Experimental Data

	Yes

	
	
	


	Neutrino

	Yes

	67053

	0.057 (4 cores)

	0.00102



	LAMMPS-SPH

	Need post-processing

	64906

	0.136 (8 cores)

	0.00025



	Dual-SPHysics

	Need post-processing

	116795

	1.454 (4 cores)

	0.00004






Figure : comparison of Neutrino output to experimental data

[image: _images/dam_break_psize_compare.png]
Figure: Comparison of forces using several particle sizes in Neutrino.

The first peak, representing the first slamming from fluid to the dam
structure, is higher than the experimental data. This is mainly caused
by the repulsive boundary treatment at fluid-solid interface. This also
shows SPH is capable of determining fluid-solid interaction accurately.

[image: _images/dam_break_force_compare.png]
Figure: Estimate on the error based on the particle resolution




3.10.2. Aureli Dam Break

The Aureli dam break experiment is based the experiment from [Aureli2015]. The impact forces are about 5x lesser than the previous damn break experiment
and there’s a significant amount of air entrapment.

The measurement of the impact forces is done by smoothing out the highest frequency noise . It seems like the forces are overestimated by about 1N and
the secondary shock not captured very well.

[image: _images/dam_break_aureli_compare.png]



3.10.3. Poisuelle Flow




3.10.4. Faltisen - Wave Sloshing Experiment




3.10.5. Falling Body in Water




3.10.6. Solitary Wave Past Shore
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