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	OScommerce Interface / ZenCart (esale_osc)
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	Object: esale_oscom Tax (esale.oscom.tax)
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	Object: esale_oscom Category (esale.oscom.category)

	Object: esale_oscom PayType (esale.oscom.paytype)

	Object: esale_oscom Language (esale.oscom.lang)

	Object: esale_oscom Product (esale.oscom.product)

	Object: Product Manufacturer that produces the product (product.manufacturer)









	ETL system (etl_interface)
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	Event Certificate (event_certificate)
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	Fleet Management System (fleet_manager)
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	Dependencies
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	Scenario of games (game_scenario)
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	Download links

	Dependencies
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	Object: game.scenario (game.scenario)

	Object: game.scenario.step (game.scenario.step)









	generalize account report module (generalize_account_report)
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	Download links

	Dependencies
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	Object: Generalize Account Report (generalize.account.report)

	Object: Group Configuration (group.detail.configuration)









	Module for Import from file (gnucash)
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	Download links

	Dependencies
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	Object: gnucash.index (gnucash.index)









	Google Blogger (google_blogger)
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	Dependencies
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	Google calendar (google_calendar)
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	Dependencies
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	Google Earth/Map Module (google_earth)
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	Download links

	Dependencies
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	Google Map (google_map)
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	Dependencies
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	Google translation (google_translate)
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	Dependencies
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	Dependencies
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	Object: Semestre (health.semestre)

	Object: religion (health.religion)

	Object: situation (health.situation)

	Object: Room Rate (health.room.tarif)

	Object: Localisation (health.room.localisation)

	Object: Chambres (health.room)

	Object: Rate Dependence (health.tarif.dependance)

	Object: Drug Form (health.drugform)

	Object: Drug Family (health.drugfamilly)

	Object: Profils Pathos (health.pathosprofils)

	Object: Category States Pathologique Pathos (health.pathoscategetats)

	Object: States Patholohgique Pathos (health.pathosetatspatho)

	Object: Facturation (health.facturation)

	Object: Aggir (health.aggir)

	Object: Drugs (health.drug)

	Object: category (health.category)

	Object: soins (health.care)

	Object: Type Evenement (health.evenement.type)

	Object: evenement (health.patient.evenement)

	Object: prescription (health.prescription)

	Object: Tarif Absences (health.tarif.absences)

	Object: Regime (health.regime)

	Object: Output Type (health.exit)
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	Hotel Housekeeping Management (hotel_housekeeping)
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	Hotel Restaurant Management (hotel_restaurant)
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	Object: Hotel Menucard (hotel.menucard)

	Object: Includes Hotel Restaurant Table (hotel.restaurant.tables)

	Object: Includes Hotel Restaurant Reservation (hotel.restaurant.reservation)

	Object: Includes Hotel Restaurant Order (hotel.restaurant.kitchen.order.tickets)

	Object: Includes Hotel Restaurant Order (hotel.restaurant.order)

	Object: Reservation Order (hotel.reservation.order)

	Object: Includes Hotel Restaurant Order (hotel.restaurant.order.list)









	Hotel Management (hotel)
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	Dependencies
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	Object: Floor (hotel.floor)

	Object: Room Type (hotel.room_type)

	Object: amenities Type (hotel.room_amenities_type)

	Object: Room amenities (hotel.room_amenities)

	Object: Hotel Room (hotel.room)

	Object: hotel folio new (hotel.folio)

	Object: hotel folio1 room line (hotel_folio.line)

	Object: hotel Service line (hotel_service.line)

	Object: Service Type (hotel.service_type)

	Object: Hotel Services and its charges (hotel.services)









	Attendances of Employees in Projects (hr_attendance_project)
	Description

	Download links

	Dependencies

	Reports

	Menus

	Views

	Objects





	Attendances Of Employees (hr_attendance)
	Description

	Download links

	Dependencies
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	Human Resources/Change password (hr_change_password)
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	Human Resources Contracts - Human resources Reservations Management (hr_contract_available)
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	Dependencies
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	Download links

	Dependencies
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	Object: Wage Period (hr.contract.wage.type.period)

	Object: Wage Type (hr.contract.wage.type)

	Object: Contract (hr.contract)









	Human Resources Timesheets on contracts (hr_contract_timesheet)
	Description

	Download links

	Dependencies
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	Human Resources Evaluation (hr_evaluation)
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	Download links

	Dependencies
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	Object: Employee Evaluation (hr_evaluation.evaluation)

	Object: Employee Evaluation Type (hr_evaluation.type)

	Object: Evaluation Type Value (hr_evaluation.type.value)

	Object: Employee Evaluation Quote (hr_evaluation.quote)









	Human Resources Expenses Tracking (hr_expense)
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	Download links

	Dependencies
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	Object: Expense (hr.expense.expense)

	Object: Expense Line (hr.expense.line)









	HR Expenses Supplier (hr_expenses_supplier)
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	Download links

	Dependencies
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	Human Resources: Holidays management (hr_holidays_cci)
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	Download links

	Dependencies
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	Menus
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	Hr holidays evaluation (hr_holidays_evaluation)
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	Download links

	Dependencies
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	Object: Holidays note (hr.holidays.note)

	Object: wizard.hr.holidays.evaluation (wizard.hr.holidays.evaluation)









	HR Holiday Request (hr_holidays_request)
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	Download links

	Dependencies
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	Object: Holidays history (hr.holidays.history)

	Object: Holidays history (days.holidays.days)

	Object: Public Holidays (public.holidays.days)

	Object: Holidays history (days.holidays.days.history)
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	Download links

	Dependencies
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	Object: Holidays Status (hr.holidays.status)

	Object: Holidays Per User (hr.holidays.per.user)

	Object: Holidays (hr.holidays)

	Object: hr.holidays.log (hr.holidays.log)









	Human Resources (Interview Evaluation) (hr_interview)
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	Download links

	Dependencies
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	Object: Category Of Candidate (candidate.category)

	Object: Question Category (Question Belongs to Which Category) (category.question)

	Object: Candidate Experience (candidate.experience)

	Object: Interview Evaluation (hr.interview)

	Object: Technical Skill Of Candidate (technical.skill)

	Object: HR interview log (hr.interview.log)









	Human Resources Medical Exam (hr_medical)
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	Download links

	Dependencies
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	Performance Review (hr_performance)
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	Download links

	Dependencies
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	Object: Performance Review Points (hr.performance.line)

	Object: Review Attributes (hr.performance.line.attribute)

	Object: Attributes Lines (attribute.line)









	Human Resources (hr)
	Description

	Download links

	Dependencies

	Reports

	Menus

	Views

	Objects
	Object: Working Time (hr.timesheet.group)

	Object: Employee Category (hr.employee.category)

	Object: Employee (hr.employee)

	Object: Timesheet Line (hr.timesheet)

	Object: hr.department (hr.department)









	Skill Management (hr_skill)
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	Download links

	Dependencies
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	Object: hr_skill.weight.category (hr_skill.weight.category)

	Object: hr_skill.weight (hr_skill.weight)

	Object: hr_skill.skill (hr_skill.skill)

	Object: hr_skill.experience.category (hr_skill.experience.category)

	Object: hr_skill.experience (hr_skill.experience)

	Object: hr_skill.evaluation.category (hr_skill.evaluation.category)

	Object: hr_skill.evaluation (hr_skill.evaluation)

	Object: hr_skill.profile (hr_skill.profile)

	Object: hr_skill.position (hr_skill.position)

	Object: hr_skill.position.profile (hr_skill.position.profile)

	Object: hr_skill.experience.skill (hr_skill.experience.skill)

	Object: hr_skill.profile.skill (hr_skill.profile.skill)

	Object: hr_skill.evaluation.experience (hr_skill.evaluation.experience)

	Object: hr_skill.evaluation.skill (hr_skill.evaluation.skill)

	Object: Languages (hr.lang)

	Object: Languages (emp.lang)

	Object: Pay Scales (hr.scale)

	Object: employee.status (employee.status)









	Complete timesheet from an iCal server (hr_timesheet_ical)
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	Download links
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	Invoice on analytic lines (hr_timesheet_invoice)
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	Download links

	Dependencies
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	Human Resources (Timesheet encoding from project tasks) (hr_timesheet_project)
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	Download links
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	Human Resources (Timesheet encoding) (hr_timesheet)
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	Download links
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	Download links
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	Object: Idea Votes Statistics (idea.vote.stat)
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	Download links
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	Dependencies
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	Poland - Chart of Accounts (l10n_chart_pl)
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	Download links
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	Venezuela -Chart of Account (l10n_chart_ve)
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	Download links
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	Download links
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	Partner labels (label)
	Description

	Download links

	Dependencies

	Reports

	Menus

	Views

	Objects
	Object: report.pagesize (report.pagesize)
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	Pilot Human Resource Management (md_hr_contract)
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	Object: HR Contract Availability (md.hr.contract.availability)
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前言

近些年来，信息系统在提高企业竞争力中日益发挥着显著的作用。
它们经常被用到指导和推进企业的日常活动，而不仅是用来处理重复性的任务。
现今，综合管理软件往往是重要的竞争优势的关键来源。

创建一个基于部门的、具有清晰结构的组织，需要有一套系统化的响应流程，
而且必须具有响应性（译者注：指提供服务的自发性）、可靠性和快速增长的预期。
提高效率需要包括销售部，财务部，后勤部等所有部门对你的问题有普遍一致的认识。

关于这一点，你需要有一个普遍的沟通语言用来共享资讯，策略和通讯。
ERP（企业资源规划）系统是提供这种沟通语言的理想平台。


企业管理之开源软件

风险与整合的成本是企业从ERP系统中获利的重要的障碍。这就是现在的中小型企业很少使用ERP的原因。
另外，像SAP、微软和Oracle这样的大型ERP软件供应商仍然不能解决ERP软件强大的处理能力与用户对ERP系统的简单性和
灵活性的普遍需求。但这却正是中小型企业所需要的。

开源软件的开发过程与开发人员所采用的新的商业模式为解决这类企业软件的成本与质量问题提供了一种新的思路。

要让一个ERP系统在中小企业里完全有效的运行，降低成本是第一要务。开源软件利用强大的可重用软件库
使大幅度降低开发成本成为可能；它减少了批发商的中间环节同时也相应降低了他们高昂的销售费用所引发的成本；而且
软件的免费发布也减少了高昂的销售和市场费用。

因为有成千上万的贡献者与合作伙伴在同一个项目上通力合作，所以软件的质量极大地得益于彼此之间的审查。
你不可能同时做所有的事情：会计，软件开发，销售，ISO9001质量管理，农产品专家，药品专家，这些只是其中的一部分
而已。

面对这些广泛的需求，还有什么能比建立起一个全球范围内的合作伙伴和贡献者网络更好的方式呢？
每个人都根据他或她的专业能力，提供自己的才能。
通过本书，你会了解到当这些工作被良好的组织到一起时，结果将超出任何合理的预期。

但是开发中真正的挑战是确保该方法的简单、灵活和完整。
要达到这种层次的质量要求你需要一个领导者和协调者，他可以组织所有这些活动。
所以TinyERP的开发团队，现在叫OpenERP，主要负责组织，同步和软件的一致性。

OpenERP在所有这些方面都表现得非常出色！




OpenERP 解决方案

由于OpenERP采用模块化，并且协同开发已完全集成在里面，所以任何公司都可以从它庞大的功能列表中找到适合自己的功能。
对于大多数开源软件来说，可访问性，灵活性和易用性是重要的关键词。经验表明没有必要在系统上培训用户数个月，
因为他们可以直接下载并使用它。

所以你将找到适合各种需求的模块，可供选择的模块有上百种，你可以通过简单的分组和配置找到最适合的模块，利用它们
为你的公司建立起量身定制的系统。

这些模块的范围从能和勒克莱尔商店对接的农产品的EDI接口模块，
到可以照顾你的员工的饮食偏好的订购三明治通用演示自动化模块。

结果非常优秀。OpenERP（原本称作Tiny ERP）是一个管理软件，在全世界范围内它比其它的同类软件获得更多的下载次数，
每天超过600次。现在它支持18种语言并且有一个世界范围的合作伙伴和贡献者网络。超过800名开发者共同参与并开发了这
个项目。

据我们所知，OpenERP是唯一的一个不是仅仅被大公司使用的管理系统，它还被很多小公司和独立公司所采用。
这个不同是一个很好的例证，说明了OpenERP的灵活性：在人们广泛希望的功能性与易用性之间优雅的进行协调。

这种多样性还发生在不同的部门和行业中，他们都使用OpenERP，包括农产品，纺织品，公开拍卖，IT，和行业协会。

最后我们希望说明的是，本软件诞生于高质量的代码，良好的体系结构和免费的技术。事实上，你可能惊讶的（如果你从事IT
行业）发现OpenERP的下载包只有差不多6MB. 在安装时展开后，它的大小会改变，这主要是由于官方的翻译也被打包在里面，
而不是因为代码的原因。但是我们希望表达的远不止于此。自从那些地处偏远的工厂的所有者预期可以从ERP受益开始至今，我
们已经走过了如此长的一段路。


本书的意义？

很多书告诉读者该如何管理企业，同样也有很多书致力于指导读者如何使用一款特定的软件。我们并不想像他们那样，因为
我们的方向是不同的。

我们已经帮助很多企业进行了改建和重组，我们希望我们的管理经验可以在理论和实践上都给读者带来改进。我们并不是要写一本OpenERP
的手册，而是通过这种IT工具来介绍一种先进的管理技术。你会看到什么样的管理实践是有效的，具备可能性的，还有如何用OpenERP来实现他们。

这也是我们OpenERP所希望做到的: 不仅限于软件本身而是为您提供一个可以提升管理的工具。




谁是本书的读者？

本书由两个非常成功的CEO撰写，他们的成功得益于新技术的运用。这本书的目标读者是希望改进整个公司管理团队的主管和经理们。
他们可能已经有重要的责任，并且在公司里有重要的影响力。

从功能需求上来看，多数读者可能来自中小型企业（100多人）和独立的公司（independent companies）。但是它也适用于较大的公司。






本书结构

第一章，OpenERP 第一步 安装：从OpenERP的安装开始。如果你已经安装了OpenERP，你可以直接从 OpenERP 漫游指南 节开始。如果你已经非常熟悉OpenERP或者
Tiny ERP，你可以从 如何应用到你的业务中? 节找到如何快速的在一个空数据库中创建一个新的工作流。或者你可以直接略过 ch-crm 从 part2-crm 开始了解
OpenERP中具体的功能模块。

第二章，part2-crm CRM：供应商和客户关系管理（SRM & CRM），你可以在这里找到管理一个高效的销售部门所需要的要素， 自动化处理可以监视任务的执行情况。

第三章，管理你的账簿 一般会计：讲解一般会计和一般会计在企业管理中的主要规则。

第四章，有效的运营管理：处理企业管理中所有的营运职能：通过在analytic(or cost) accounts基础上进行财务上的分析，
以进行项目中的人力资源管理，你可以看到使用了OpenERP后，它是如何帮助你的公司保持领先地位的。

第五章，管理仓库和搞定制造：描述了库存和生产过程中物料的移动过程，包括物料和作为服务的人力等转变为产品的过程。

第六章，基本的业务流程：处理商品和服务的购买与销售。

第七章，流程与文档管理： 本章专注于OpenERP所管理的过程描述和文档、知识管理。

第八章，系统管理与实施: 本章包含两节，首先解释如何管理和配置OpenERP，接下来提供一套在您的企业中实施OpenERP的方法。



Note

关于作者

Fabien Pinckaers

Fabien Pinckaers 18岁开始创业。10年后的今天，他已经创立并管理着几个高科技公司，
都是关于免费/开源软件的。

他组建了Tiny ERP，现在叫OpenERP。他是包括Tiny sprl在内的两家公司的董事，OpenERP的校订者。
三年来他从一个人发展到65人的Tiny团队。在此过程中，没有任何贷款和外部募捐，并且实现了盈利。

他已经开发了多个大型的项目，例如：Auction-in-Europe.com，它已经是比利时艺术品市场的领导者了。
每天在这上面成交的艺术品甚至超过了ebay.be。

他也是Louvain-la-Neuve上LUG（Linux User Group）和多个免费项目（如：OpenReport, OpenStuff and Tiny Report）的建立者
，土木工程师专业(综合技术), 他在IT方面已经多次获得欧洲的奖项，例如Wired
和 l’Inscene。

作为一个对于在企业中使用免费软件的狂热拥护者，他长期在各种讨论中作为演讲人宣传免费软件，不仅如此，
他写了很多的文章介绍企业如何使用免费软件进行管理。

如果您对他感兴趣，可以访问他的博客http://fptiny.blogspot.com/ 或者twitter账号fpopenerp。

Geoff Gardiner

Geoff曾在国际性的制造类公司担任服务和IT系统总监职位。
他是英国剑桥大学制造研究所高级工业研究院研究员，他专注于过程创新。

他建立了Seath公司（http://www.seathsolutions.com/）来为开源软件的使用提供服务， 特别是OpenERP在企业中的应用.
他是文章和书籍的作者，专注于流程和技术的创新，
Geoff也是OpenERP项目的贡献者。
他持有克兰菲尔德管理学院的MBA证书和剑桥大学圣三一堂的工程和电子科学硕士学位。
他同时是工程及科技学会和作家协会的会员。

经过观察，亲身感受，和领导各种组织的流程实施项目，他有很多关于如何成功地通过采用一个管理自动化工具有效的进行管理的想法与大家分享。

Els Van Vossel

Els Van Vossel始终致力于语言方面的工作，包括口头的和书面的。在她看来清楚、明确的交流是最关键的。

毕业于安特卫普的专业翻译，她的工作是作为一个独立翻译将主流ERP软件本地化。 通过这些工作Els获得了ERP知识，
她决定开始作一名ERP顾问和ERP软件的技术交流者。
因此开源软件的世界变的越来越有吸引力。她开始利用业余时间从事OpenERP方面的工作，Els真的很想
与Fabien Pinckaers见一面，以告诉他她对于有关文档和培训策略的想法。
在合作者大会上，她听到Fabien正在找人来管理培训和文档。

这绝对是一个证明自己的机会，现在Els是OpenERP的培训计划经理,负责全球OpenERP的培训和认证计划。

做个多个软件手册的作者，要从事于OpenERP文档的工作和不断的把它带到一个更高的水平是非常有挑战的。请注意，这是一个苦差事，但Els认为做的很高兴！

如果您对她感兴趣，可以访问她的博客http://training-openerp.blogspot.com/ 或者twitter账号elsvanvossel









献辞


Geoff Gardiner


我还要感谢我的合著者，Fabien Pinckaers，为了他在发展Tiny ERP和OpenERP方面的远见和坚韧，同时感谢OpenERP团队出色的工作。

OpenERP依靠的是开源哲学和技术，这些技术已经由大批的天才开发出来并且多年来不断完善。非常感谢他们的努力。

也感谢家人对我的鼓励，包容和一直以来对我的支持。


Els Van Vossel


Fabien，感谢你给我一个与OpenERP共事的机会。感谢我的文档团队帮助我拿到第一份OpenERP 6.0的文档。
在不久的将来，我会致力于重新组织这些文档，使其成为一个真正可以用于实际业务的版本。在这里我预先感谢OpenERP团队的支持。


Fabien Pinckaers


我要对OpenERP团队的全体成员表达我的感谢。感谢他们在准备，翻译和各种形式的校对工作中辛勤的付出。
我要特别感谢Laurence Henrion和我的家人，感谢他们自始至终对我的支持。
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OpenERP 第一步


OpenERP是一个非常棒的应用系统，它容易上手操作而且可以很好地帮助你管理公司。
相比其他企业级的应用软件，它可以很简单地安装在Windows和Linux操作系统上，并提供很多实用的功能。



本书第一章的目的是帮助你开始在练习中了解OpenERP。



第一节, 安装与初始配置 , OpenERP的详细安装配置指导.
如果你不是系统管理员，或者你已经安装好OpenERP，或者你打算选择在线SaaS服务商，那么你可以跳过这章，阅读下一节  OpenERP 漫游指南 。
我们会一步一步地带领你浏览使用demo数据。

如果你曾经使用过OpenERP（或者Tiny ERP），那么你可以直接阅读第三节。
在 如何应用到你的业务中? ，你可以尝试根据实际案例创建一个新的帐套，并模拟运行一个从采购到销售的完整业务流程。


[image: ../../_images/sect1_outline.png]
如何选择阅读本书第一章的内容








	在线订购 & 开始

	安装与初始配置

	OpenERP 漫游指南

	如何应用到你的业务中?
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在线订购 & 开始

无论是测试OpenERP或是布署到生产环境，你至少有两个途径：


	您可以使用OpenERP的在线服务,网址为http://www.openerp.com/online/;

	你可安装到自己的计算机以便使用自己公司的环境来测试。



本章将简要说明简单易用的*OpenERP在线服务*。 有关安装OpenERP在您计算机上的更多信息, 请参阅 part5-crm-install.


Note

OpenERP 相关的一些网站地址:


	官网: http://www.openerp.com,

	OpenERP 在线: http://www.openerp.com/online,

	在线 demo: http://demo.openerp.com,

	文档: http://doc.openerp.com/,

	你可以在社区论坛里得到帮助: http://www.openerp.com/forum/.






Tip

当前文档

安装OpenERP的过程在每个新版本都有所改变和改进,
因此你应当在网站上为最新的安装程序查找相应的发行文档.




OpenERP 在线使用

你想要了解OpenERP,没有比OpenERP在线提供的更容易的了. 你只需要一个浏览器就可以开始了.

在线服务对小公司特别有益, 花费很低的成本就可以快速的使用.
你能立即进入可管理多组织架构的类型的企业的OpenERP完整的管理系统.

OpenERP的在线版本包括以下几种服务：高带宽的主机，数据库管理，稳定的安全更新，备份，7x24小时的维护，错误修复和迁移。

OpenERP保证在线版本同官方的开源版本完全一致。在线版本包含OpenERP的任何改进，这对用户从在线版顺利切换到本地版非常有好处。

所以即使今天OpenERP在线方案可以非常好的满足您的需要，如果以后你的公司变大了或者需求改变了，
你也可以在任何时候很容易的切换到本地安装版本，你也可以在需要时更换服务商而继续使用相同的系统。
因此你不必依靠你的主机。而且，OpenERP以标准和开放的方式运行，所使用的优秀的编程语言允许你导出数据并在任何软件中使用。

这些好处可以让用户完全控制自己的数据，软件和平台。


[image: ../../../_images/start_saas.jpeg]
订购并开始使用在线服务



如果你希望从在线平台开始，你可以访问这个网址 http://www.openerp.com/online。在成功注册后，你就可以配置和使用OpenERP在线版了。
登录进你的OpenERP在线账户后，你会收到你的用户名密码。你可以按照自己的步调来建立适合自己的软件。

OpenERP在线——软件及服务——由OpenERP提供服务，按月订购. 定价模型非常简单。OpenERP按每月每用户收取固定的费用。
根据这段时间你的系统中的注册用户数，你每个月会收到一个发票。如果你在今后的30天内添加了新用户，他们会被算在下次的发票中。
你可以在 http://www.openerp.com/online 找到现行的价格和支付选项的明细。







          

      

      

    


    
         Copyright .
      Last updated on 2015-07-13 16:24:00.
      Created using Sphinx 1.3.1.
    

  

    
      Navigation

      
        	
          index

        	
          next |

        	
          previous |

        	OpenERP v6 

          	目录 

          	OpenERP 用户手册 

          	OpenERP 第一步 
 
      

    


    
      
          
            
  
安装与初始配置


要熟悉OpenERP,可以自己在Windows或Linux下安装OpenERP，安装过程大概只需要半个小时左右。

第一步是在一台服务器PC（即Windows或Linux或Macintosh电脑）上安装OpenERP和数据库服务器（即PostgreSQL）。





第二步你可以选择使用网页浏览器或在用户的电脑上安装OpenERP客户端软件来访问OpenERP服务器


当你安装完OpenERP后，接下来就要创建一个包含一些演示数据的数据库，以便测试安装是否成功。


Note

Tiny ERP 更名为 OpenERP

早在2008年，Tiny ERP更名为OpenERP，所有使用过Tiny ERP的用户应该同样熟悉OpenERP。两个名字所指的是同一个软件，
因此OpenERP的4.2.X版本和Tiny ERP的4.2.X版本在功能上没有差别。本书适用于OpenERP 6.1.0以及之后的版本，但也会
时常参考到6.1之前的版本。




Note

SaaS或按需提供

SaaS (软件即服务 ) 由托管服务商提供服务，客户按月缴纳服务费的形式使用。包括硬件（服务器），系统维护，提供托管服务和支持。

在你这里你可以获得OpenERP一个月的免费试用 http://www.openerp.com/online，它可以让你在不增加系统费用投入的情况下快速的开始试用。
很多OpenERP的合作伙伴都是用它，其中有一些还提供类似的服务。

这项服务对于小公司特别有用，他们往往希望用尽量少的花费，最快的将系统运行起来。
SaaS让你可以快捷的访问一个集成的管理系统，该系统是以银行和其它大型组织的企业架构建立起来的。
OpenERP就是这样的系统，本书会详细介绍具体功能。



无论你是想测试OpenERP还是想把它投入正式生产，至少需要三starting点：


	无需安装，可通过这里进行测试 http://demo.openerp.com,

	在线评估地址 http://www.openerp.com OpenERP SaaS 测试地址 http://ondemand.openerp.com，
或者在OpenERP合作伙伴处体验这些内容，

	在你自己的电脑上安装测试。



在Windows上安装OpenERP和在Linux上安装略有不同，但是一旦安装上，系统提供的功能都是一样的，所以你不必在意你用的是那种服务器。


Note

Linux, Windows, Mac

虽然这本书只涉及在Windows和Linux系统上安装，但是OpenERP的官方网站上相同的版本也可用于Macintosh。




Note

OpenERP的网站


	主站: http://www.openerp.com,

	SaaS 或 OpenERP在线: http://www.openerp.com/online,

	文档站: http://doc.openerp.com/,

	社区论坛，在那里你可以经常得到其他人的帮助:
http://www.openobject.com/forum.






Tip

当前文档



OpenERP的每个新版本的程序安装都会有所改进，所以你应该经常检查文档 - 包括打包的和发布在网站上的 - 以保证能够正确的安装。

一旦你已经安装完成，就可以创建数据库了，并确认您的OpenERP的进程在运行。您可以按照本书前面的章节来实现。



	OpenERP 架构

	OpenERP的安装
	Windows 独立安装
	从其它计算机访问 OpenERP Server

	解决 Windows 安装中的错误





	Linux (Ubuntu) 安装
	技术过程: 初始化安装和配置

	手动安装 OpenERP Server

	手动安装 OpenERP GTK 客户端

	创建数据库

	检查您的 Linux 安装









	数据库的创建
	创建数据库

	数据库 openerp_ch01

	管理数据库





	为OpenERP添加新功能
	扩展OpenERP
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OpenERP 架构

要使用 OpenERP ，你可以:


	使用浏览器指向 OpenERP 服务器，或是

	使用在电脑上安装的应用程序客户端(GTK)。



两种使用方法提供了类似的使用界面和功能，而且你可以同时用两种方法连上同一台服务器使用。
如果 OpenERP 服务器离使用者有段距离(例如服务器在另一洲)，最好是使用浏览器，因为浏览器对时间延迟的容忍度
比 GTK 客户端要好。网页客户端也比较容易维护，因为通常使用者的电脑上已经安装了浏览器。

相反地如果你是使用本地的服务器(例如在同一栋建筑内)，应用程序的客户端(被称为 GTK 客户端，因为内建 GTK 的技术)会较佳)。这种状况下 GTK 客户端响应速度较快，使用满意度也会较高。


Note

网页客户端和 GTK 客户端

网页客户端和 GTK 客户端，这两种 OpenERP 客户端有一点点功能上的不同。
网页客户端提供较多功能，例如，企业情报 的功能和 甘特图。

OpenERP 公司将会在可见的未来里继续支持这两种客户端，所以这两种客户端，你可以爱用哪种就用哪种。



OpenERP 系统是由2部分组成:


	PostgreSQL 数据库服务器，包含了所有数据库，其中每个数据库都包含了所有数据以及OpenERP系统组态大部分的要素。

	OpenERP 应用程序服务器，包含了所有企业的工作逻辑，服务器同时也确保 OpenERP 在最佳状态运行。这其中也包含了网页服务器。




[image: ../../../_images/terp_arch_1.png]
OpenERP 的架构




Note

PostgreSQL 是一种关系型，也是物件型的数据库管理系统。

这是一种免费，开源，高效能的系统，与其他数据库管理系统比起来毫不逊色，例如
MySQL，FirebirdSQL (都是免费系统)， Sybase， DB2，微软 SQL Server (都是有版权的)。
这个系统在各种作业系统上都可以运行，从 Unix/Linux 到许多不同版本的 Windows，也包含了
Mac OS X， Solaris， SunOS 和 BSD.



这两部分可以安装在同一个服务器上，如果有考虑运作的效能需要，也可以分布在不同的电脑服务器上。
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OpenERP的安装

也许您是来自一个小型公司，想要看看OpenERP能否有效帮助公司成长，或是来自大型机构的IT职员，想要评估OpenERP的综合功能和性能，
您的第一步就是要安装上她或者找到一个已经安装好的实例来进行测试。

下表中简要列出了各种安装方法，之后会做详细描述。


Windows或Linux上各种安装方法对比
  
    
    
    数据库的创建
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数据库的创建

使用这个章节里概述的技巧来创建一个新的数据库， openerp_ch01 . 这个数据库将包含 OpenERP 提供的示范数据以及
大部分的 OpenERP 核心功能。你需要知道超级管理员的密码才能使用这个数据库，或者你可以请具有超级管理员权限的人创建这个数据库。


Note

超级管理员密码

任何人只要知道超级管理员的密码，都对服务器上的数据有完整的存取权力 – 可读取，修改或删除任何服务器上任何数据库的任何数据。
在第一次安装完成后，密码是 admin 。 这是写在程序里的缺省值，如果找不到可以存取的服务器组态文件，就会使用这个缺省值。
如果你的系统有配置服务器可写入的组态文件，你就可以透过客户端修改密码；或者，你可以刻意把组态文件设置成只读，这样以后就没有
人可以从客户端修改密码。不论是这两种方式的哪一种，如果你忘记密码，服务器的系统管理员都可以修改密码。

所以你的系统设置是可以从客户端修改密码，你可以从 GTK 客户端的菜单里进行修改 文件 ‣ 数据库 ‣ 管理员密码 ，或是从
网页客户端登出 (单击 登出 链接), 在登入画面单击 数据库 ，然后在管理画面中单击 密码 。

服务器上的配置文件位置，通常是在启动服务器时用 --config 命令的选项来指定。




[image: ../../../_images/change_superadmin_pwd.png]
用网页客户端来修改超级管理员密码




创建数据库

如果你是使用 GTK 客户端， 在菜单的左上方选择 文件 ‣ 数据库 ‣ 新数据库 。
输入超级管理员密码以及要创建的新数据库名称。


[image: ../../../_images/create_new_db_GTK.png]
使用 GTK 客户端创建新资料库



如果你是是用网页客户端，在登入画面单击 数据库 ，然后在数据库管理页面 创建 。
输入超级管理员密码，以及你要创建的数据库名称。

在两种方法里你都会看到核取方块；核取方块是用来确认是否要载入演示数据。不论是否有选取核取方块，结果都不会影响数据库的 整体应用 。

在两种方法里你也都会看到，你可以选择管理员密码。管理员密码可以相当程度确保数据库的安全性，因为从一开始就可以确保数据库的密码是唯一的。
(实际上许多人会难以抗拒使用 admin 作为密码!)




数据库 openerp_ch01

等到信息显示数据库及用户账号及密码 (admin/XXXX  和 demo/demo ) 已经成功创建，你就已经创建了这个数据库，而且你可以不需要知道超级管理员密码，就可以扩充这个数据库。


Tip

用户存取

对每一个数据库来说，用户名称/密码 都是唯一的组合；如果你有管理员的权限，你可以修改全部的用户。

另外，你可以安装 users_ldap 模块，用于管理用户在 LDAP (轻量级目录访问协议， Lightweight Directory Access Protocol， 一个标准系统)，
以及连接到数个 OpenERP 数据库。透过 LDAP 许多数据库可以共享相同的用户账号资讯。




Note

创建数据库失败

如何知道是否已经成功创建你的新数据库？
如果创建数据库不成功，系统会通知你。
如果你用了禁止使用的字符当做数据库的名称 (或数据库没有名称，或名称太短)，系统会用对话框提出警告 不合格的数据库名称! ，
同时会说明如何修正错误。如果你输入了错误的超级管理员密码或是某个已经在使用中的名称 (有些名称是在你不知道的情形下保留的)，系统会用以下对话
框提出警告 数据库创建过程中错误! 。



如果这是你第一次连结到这个数据库，系统会问你一系列的问题来确认数据库的参数。你可以选择 跳过配置向导 或
开始配置 。如果你选择设定应用程序的组态，可以依照以下步奏进行:



	配置你的界面 : 选择 简单化界面 然后单击 下一步 。

	配置你的公司讯息 : 把系统建议的默默认值 OpenERP S.A. 改成你自己公司的名称以你的喜好尽量把地址填完整。
你可以设置你公司使用的币别，或是直接使用默认值。你也可以加上你公司的商标；商标可以显示在报表或其他文件上。单击 下一步 。

	安装应用程序 : 选取你需要的应用程序然后单击 安装 。现在，不要安装任何应用程序。






一旦配置完成，你就已经连接到你的 OpenERP 系统。 现在的系统功能非常有限，因为你选择了 简单化界面 ，
而且没有安装任何应用程序；但是现在这个演示已经足够告诉你安装完成了。


[image: ../../../_images/define_main_co_dlg.png]
在初始数据库配置中定义你的公司






管理数据库

作为超级管理员，你不仅有权利创建数据库，还可以：


	备份数据库

	删除数据库

	恢复数据库



在GTK客户端中，所有这些操作都可以在 File ‣ Databases... 中实现，在网页客户端中通过 Login 界面的 Databases 按钮实现。


Tip

备份（复制数据库）

要复制数据库，可以在网页的 Login 界面上点击 Databases 按钮。然后点击 Backup 按钮，
选择你想要备份的数据库，然后输入超级管理员密码。点击 Backup 确认。




Tip

删除数据库

要删除数据库，可以在网页上的 Login 界面点击 Databases 按钮。然后点击 Drop 按钮，选择你想要删除的数据库，
然后输入超级管理员密码。点击 Drop 确认删除。




Tip

恢复数据库

要恢复数据库，可以在网页上的 Login 界面上点击 Databases 按钮。然后点击 Restore
按钮，点击 Choose File 选择一个要恢复的数据库。给数据库起个名字然后输入超级管理员密码。
点击 Restore 按钮确认。当然，要恢复一个数据库，你需要有一个已经存在的拷贝。




Tip

建立数据库复本

要建立一个数据库副本，你可以：


	从原数据库生成一个备份文件。

	恢复这个备份文件，并且重新命名。



这对于从一个生产数据库建立一个测试库是很有用的。你可以尝试重新配置，新建模块或者仅仅导入新的数据，



在正常生产使用中，系统管理员可以通过配置OpenERP来限制访问这些数据库中的某些功能以提高安全性。

现在你可以利用安装的数据库来熟悉OpenERP的管理和使用了。






为OpenERP添加新功能

你创建和管理的数据库是建立在OpenERP核心功能至上的。核心系统安装在OpenERP应用服务器的文件系统上。只有当你要求的时候，
才会安装到OpenERP数据库中，详情参考下一章节， OpenERP 漫游指南。

如果你想更新或扩展额外的模块该怎么做？


	要进行更新，你的使用本部分前面提到的技术重新安装一个新的OpenERP实例，参照 数据库的创建。

	要进行扩展，你得安装新模块到你现有的OpenERP系统的 addons 目录下，具体操作可以有多种方式。



在这两种情况下你都需要你的OpenERP应用服务器的 root 用户或者 Administrator 用户权限。


扩展OpenERP

要扩展OpenERP，你需要把模块复制到 addons 目录。它在你的服务器 openerp-server 目录（这个目录
在Windows，Mac和不同版本的Linux版本之间会略有不同，在Windows all-in-one版本中则完全不同（not available at all））下。

在哪个目录下你会看到现有系统中已经安装的模块，比如： product and purchase。一个模块可以以
文件、文件夹的形式或者是zip包的形式存在。如果是zip包，那里面的文件结构也是和文件、文件夹类型相同的。

基本上，你可以通过两种方式添加模块 —— 通过服务器或者通过客户端。

通过服务器添加模块是一个传统的系统管理任务。 以 root 用户或者其他合适的用户，你可以把模块放到 addons 目录下并且修改权限以便可以和其它模块一样正确执行。

通过客户端添加模块，你必须首先修改服务器上 addons 目录的权限，将此目录设为可写。只有这样才可以通过OpenERP客户端安装模块。
（应用服务器上的服务软件最终将执行一个任务来完成该操作）


Tip

修改权限

在安装OpenERP系统的Linux服务器上修改权限的最简单的办法是执行命令 sudo chmod 777 <addons文件夹路径>
(<addons文件夹路径>需要使用完整路径，例如： /usr/lib/python2.5/site-packages/openerp-
server/addons)。



OpenERP的所有用户只要进入了管理菜单就可以上传任何新功能，所以在生产环境中你必须慎重考虑该功能。你会在本书
后面的内容中看到上传文件的事例。
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OpenERP 漫游指南


Starting to discover OpenERP, using demonstration data supplied with the system, is a good way to
familiarize yourself with the user interface.
This guided tour provides you with an introduction to many of the available system features.


You would be forgiven a flicker of apprehension when you first sit at your computer to connect to
OpenERP, since ERP systems are renowned for their complexity and for the time it takes to learn
how to use them. These are, after all, Enterprise Resource Planning systems, capable of managing
most elements of global enterprises, so they should be complicated, should not they? But even if this
is often the case for proprietary software, OpenERP is a bit of an exception in the class of
management software.

Even though OpenERP is a comprehensive software, the user interface and workflow management facilities are quite
simple and intuitive to use. For this reason, OpenERP is one of the few software packages with
reference customers in both very small businesses (typically requiring simplicity) and large
accounts (typically requiring wide functional coverage).

A two-phase approach provides a good guide for your first steps with OpenERP:


	Using a database containing demonstration data to get an overview of OpenERP’s functionality
(described in this chapter, OpenERP 漫游指南)

	Setting up a clean database to configure and populate a limited system for yourself (described in
the next chapter, 如何应用到你的业务中?).



To read this chapter effectively, make sure that you have access to an OpenERP server. The
description in this chapter assumes that you are using the OpenERP web client unless it states
otherwise. The general functionality differs little from one client to the other.



	创建数据库

	连接到 OpenERP
	工具栏首选项
	安装新的语言

	站内信





	配置用户

	管理业务伙伴
	业务伙伴列表

	业务伙伴分类









	添加系统新业务
	更新模块列表

	配置及重运行配置向导

	安装新模块及应用

	安装模块及其依赖模块

	安装附加功能





	OpenERP 6.1 新改进
	软件改进

	业务流程改进





	开始使用OpenERP
	基本概念
	业务伙伴及其联系人

	快速定位业务伙伴

	业务伙伴信息窗口

	与业务伙伴操作交互
	产品









	提升销售能力

	管理各种账本

	管理提升员工士气

	掌控项目管理

	掌控销售管理

	掌控采购管理

	优化仓库管理

	提升生产能力

	随时随时分享各种管理文档

	衡量您的业务性能

	工艺流程跟踪

	还不满足？

	提示与技巧
	快捷键概述

	过滤器


















          

      

      

    


    
         Copyright .
      Last updated on 2015-07-13 16:24:00.
      Created using Sphinx 1.3.1.
    

  

  
    
    
    创建数据库
    
    

    

 

















  
  

    
      Navigation

      
        	
          index

        	
          next |

        	
          previous |

        	OpenERP v6 

          	目录 

          	OpenERP 用户手册 

          	OpenERP 第一步 

          	OpenERP 漫游指南 
 
      

    


    
      
          
            
  
创建数据库

在 安装与初始配置 中使用概要的技术来创建一个新的数据库，openerp_ch02 。这个
数据库将包含由OpenERP提供的演示数据以及绝大多数的OpenERP核心功能。
您需要知道系统的超级管理员密码 – 又或找到拥有它的人来创建此种子数据库。

要启动数据库的创建进程，请从 Login 页点击
Databases 然后填写并完成 Create Database 表单项:


	Super admin password : 缺省是 admin , 如果你的系统管理员没有更改,

	New database name : openerp_ch02 ,

	Load Demonstration data checkbox: checked ,

	Default Language : English (US) ,

	Administrator password : admin (因为它在目前阶段最容易记住，但很明显：非常不安全),

	Confirm password : admin .
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连接到 OpenERP

由于这是您第一次连接到 OpenERP, 你将有机会来配置系统.
你可以选择其中一种 Skip Configuration Wizards
或 Start Configuration. 我们将继续通过点击系统配置
Start Configuration.

配置包括一组向导，它可以帮助你通过选项来安装模块。
安装过程在这块是一个非常简单的.



	Configure Your Interface : 选择 Simplified 并点击 Next.








	在 Company Configuration 步骤, 输入你自己的 Company Name 和
Currency. 这里可以加公司地址, 联系方式等其他详细信息和公司 Logo,
如果你有的话, Logo将在报表上展示. 然后, 点击 Next.

	在 Install Applications 部分将允许你添加应用到你的
系统中. 眼下, 点击 Skip 不安装任何应用.
你现在连接到 OpenERP 可以开始以管理员用户来使用系统.






第一屏显示的是下图所示的主菜单 The Main Menu of the openerp_ch02 database:


	在登陆的帐套名提示下面是你当前的登陆用户.

	ONLINE SUPPORT 按钮， 给你一个OpenERP提供的支持服务的总览，他对会员开放，

	右上角的 Preferences 工具栏，用来显示 HOME 页的链接，
EDIT PREFERENCES 页, ABOUT, HELP
和 LOGOUT 按钮,

	下面就是所安装程序的菜单条目的链接图标（用户可以自定义），

	在主页的右侧，主菜单的旁边是一组小工具（widgets）的快捷菜单。




[image: ../../../_images/main_window_openerp_ch02.png]
The Main Menu of the openerp_ch02 database



当前有两个可用菜单:


	Sales

	Administration




工具栏首选项

当你连接到OpenERP，最上面的工具栏指出你是使用哪一个用户进行的连接。所以当前它显示 Administrator
（如果你使用另一个用户登录，它会相应的显示另一个用户名）。

你能看到顶端工具栏右侧包含了一组有用的链接。首先，你会看到一个:guilabel:HOME 页的链接。
This takes you to either the
Home page containing links to the available menus or to another window or dashboard, depending on the
user configuration. In the case of the openerp_ch02 database, so far the Home page
is the Main Menu. But in general each user of the
system is presented with a dashboard that is designed to show performance indicators and urgent
documents that are most useful to someone of the user’s position in the company. You will see how to
assign dashboards to different users in a later chapter, 配置与系统管理.


Tip

Multi-nationals and Time Zones

If you have users in different countries, they can configure their own timezone. Timestamp displays
are then adjusted by reference to the user’s own localization setting.

So if you have a team in India and a team in England, the times will automatically be converted. If
an Indian employee sets her working hours from 9 to 6, that will be converted and saved in the
server’s timezone. When the English users want to set up a meeting with an Indian user, the Indian
user’s available time will be converted to English time.



The next element in the toolbar is a link to EDIT PREFERENCES. By clicking that link, you
get a dialog box where the current user can set his interface in the Current Activity tab;
and in the Preferences tab, set his password, a timezone, a working language,
e-mail and a signature:


	The Interface field in the Current Activity tab allows the user to switch
between the Simplified and Extended interfaces.

	The Language field enables the user’s working language to be changed. But first, the
system must be loaded with other languages for the user to be able to choose an alternative, which
is described in the next subsection of this chapter. This is a mandatory field.

	The Timezone setting indicates the user’s location to OpenERP. This can be different
from that of the server. All of the dates in the system are converted to the user’s timezone
automatically.

	The Menu Tips checkbox gives the user the choice to have tips displayed on each menu action.

	The Change Password button gives users the opportunity to change their own password.
It opens a new dialog box where users may change the password and must logout and login again after the change.
You should take steps (perhaps written policies) to prevent users making these too trivial.

	The Email field is for storing the current user’s default e-mail address.

	The Signature field gives the user a place for the signature attached to messages sent
from within OpenERP.



The ABOUT link gives information about the development of the OpenERP software and
various links to other information.

The HELP link directs the user to the online documentation of OpenERP, where extensive help is available on a host of topics.

The LOGOUT link enables you to logout and return to the original login page. You can
then login to another database, or to the same database as another user. This page also gives you
access to the super-administrator functions for managing databases on this server.


安装新的语言

Each user of the system can work in his or her own language. More than twenty languages are
currently available besides English. Users select their working language using the Preferences link.
You can also assign a language to a partner (customer or supplier), in which case all the documents
sent to that partner will be automatically translated into that language.


Attention

More about Languages

The base version of OpenERP is translated into the following languages: English, German, Chinese,
Spanish, Italian, Hungarian, Dutch, Portuguese, Romanian, Swedish and Czech.

But other languages are also available: Arabic, Afghan,
Austrian, Bulgarian, Indonesian, Finnish, Thai, Turkish and Vietnamese..



As administrator, you can install a new main working language into the system.



	Select Administration in the Menu Toolbar and click
Translations ‣ Load an Official Translation in the main menu window,

	Select the language to install, French for example, and click Load,

	The system will intimate you when the selected language has been successfully installed.
Click Close to return to the menu.






To see the effects of this installation, change the preferences of your user to change the working
language (you may first need to ensure that you have explicitly selected English as your language,
rather than keep the default, before you are given the French option).
You may have to reload the page to see the effects. The main menu is immediately translated in
the selected language. If you are using the GTK
client, you will first have to close the menu then open a new main menu to start seeing things in the
new language.


Note

Navigating the Menu

From this point in the book navigation from the main menu is written as a series of menu entries
connected by the ‣ character. Instead of seeing “Select Administration in
the Menu toolbar then click Translations > Load an Official Translation” you will just get “use menu
Administration ‣ Translations ‣ Load an Official Translation”.






站内信

Requests have been removed in OpenERP 6.1 - a new internal communication system will be added in 7.0.






配置用户

The database you created contains minimal functionality but can be extended to include all of the
potential functionality available to OpenERP. About the only functions actually available in this
minimal database are Customers and Currencies – and these only because the definition of your main
company required this. And because you chose to include demonstration data, both Customers and
Currencies were installed with some samples.

Because you logged in as Administrator, you have all the access you need to configure users. Click
Administration ‣ Users ‣ Users to display the list of users defined in the
system. A second user, Demo User , is also present in the system as part of the
demonstration data. Click the Demo User name to open a non-editable form on that user.

Click the Groups  tab to see that the demo user is a member of only the Employee group,
and is subject to no specialized rules.
The user Administrator is different, as you can see if you
follow the same sequence to review its definition. It is a member of the Administration / Configuration and the Administration / Access Rights groups,
which gives it more advanced rights to configure new users.


Tip

Groups and Users

Users and groups provide the structure for specifying access rights to different documents. Their
setup answers the question “Who has access to what?”



Click Administration ‣ Users ‣ Groups to open the list of
groups defined in the system. If you open the form view of the Administration / Configuration group by clicking its name in the list, the first tab Users gives you the list of
all the users who belong to this group.

You can also see in the Menus tab, the list of menus reserved for this group. By convention,
the Administration / Configuration in OpenERP has rights of access to
the Configuration menu in each section. So Sales / Configuration is
found in the list of access rights but Sales is not found there because it is accessible
to all users. Click the Access Rights tab and it gives you details of the access rights
for that group. These are detailed later in 配置与系统管理.

You can create some new users to integrate them into the system. Assign them to predefined groups to
grant them certain access rights. Then try their access rights when you login as these users.
Management defines these access rights as described in 配置与系统管理.


Note

Changes to Default Access Rights

New versions of OpenERP differ from earlier versions of OpenERP and Tiny ERP in this area:
many groups have been predefined and access to many of the menus and objects are keyed to these
groups by default.
This is quite a contrast to the rather liberal approach in 4.2.2 and before, where access rights
could be defined but were not activated by default.






管理业务伙伴

In OpenERP, a partner represents an entity that you do business with. That can be a prospect, a
customer, a supplier, or even an employee of your company.


业务伙伴列表

Click Sales ‣ Address Book ‣ Customers in the main menu to open the list of partners who are customers. Then click the name of the first partner to get hold of the details – a form appears with
information about the company, such as its corporate name, its primary language, its reference and whether it is a
Customer and/or a Supplier . You will also find several other tabs on it:


	the General tab contains information about different contacts at that partner, postal information,
communication information and the categories it belongs to.

	the Sales & Purchases tab contains information that is slightly less immediate.

	the History tab (visible if you install other modules like crm)
contains the history of all the events that the partner has
been involved in. These events are created automatically by different system documents: invoices,
orders, support requests and so on, from a list that can be configured in the system.
These give you a rapid view of the partner’s history on a single
screen.

	the Notes tab is an area for free text notes.



To the right of the form is a list of Reports, Actions, Links and Attachments related to a partner. Click some of
them to get a feel for their use.


[image: ../../../_images/partner.png]
Partner form




Tip

Partner Categories

Partner Categories enable you to segment different partners according to their relation with you
(client, prospect, supplier, and so on). A partner can belong to several categories – for example
it may be both a customer and supplier at the same time.

But there are also Customer and Supplier checkboxes on the partner form, which are different.
These checkboxes are designed to enable OpenERP to quickly select what should appear on some of the
system drop-down selection boxes. They, too, need to be set correctly.






业务伙伴分类

You can list your partners by category using the menu Sales ‣ Configuration ‣
Address Book ‣ Partners Categories. Click a category to obtain a list of partners in that category.


[image: ../../../_images/main_window_partner_menu_config.png]
Categories of partner



The administrator can define new categories. So you will create a new category and link it to a
partner:



	Use Sales ‣ Configuration ‣ Address Book ‣ Partners Categories
to reach the list of categories in a list view.

	Click New to open an empty form for creating a new category

	Enter My Prospects in the field Category Name. Then click on the
Search icon to the right of the Parent Category field and select
Prospect in the list that appears.

	Then save your new category using the Save button.






You may add exiting partners to this new category using the Add button in the
Partners section.


Tip

Required Fields

Fields colored blue are required. If you try to save the form while any of these fields are empty,
the field turns red to indicate that there is a problem. It is impossible to save the form until
you have completed every required field.



You can review your new category structure using the list view.
You should see the new structure of Prospects / My Prospects  there.


[image: ../../../_images/main_window_partner_tab.png]
Creating a new partner category



To create a new partner and link it to this new category, open a new partner form to modify it.



	Type New Partner into the Name field.

	In the General tab, click the Add button under the
Categories section and select your
new category from the list that appears: Prospect / My Prospects .

	Then save your partner by clicking Save. The partner now belongs in the category
Prospect / My Prospects .

	Monitor your modification in the menu Sales ‣ Configuration ‣ Address Book ‣
Partners Categories. Select the category Prospect / My Prospects. The list of partners opens
and you will find your new partner there in that list.







Tip

Searching for Documents

If you need to search through a long list of partners, it is best to use the available search
criteria rather than scroll through the whole partner list. It is a habit that will save you a lot of
time in the long run as you search for all kinds of documents.




Note

Example Categories of Partners

A partner can be assigned to several categories. These enable you to create alternative
classifications as necessary, usually in a hierarchical form.

Here are some structures that are often used:


	geographical locations,

	interest in certain product lines,

	subscriptions to newsletters,

	type of industry.
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添加系统新业务

All of OpenERP’s functionality is contained in its many and various modules. Many of these, the
core modules, are automatically loaded during the initial installation of the system and can be
updated online later. Although they are mostly not installed in your database at the outset, they are
available on your computer for immediate installation. Additional modules can also be loaded online
from the official OpenERP site http://openerp.com. These modules are inactive when they are loaded
into the system, and can then be installed in a separate step.

You will start by checking if there are any updates available online that apply to your initial
installation. Then you will install a CRM module to complete your existing database.


更新模块列表

Click Administration ‣ Modules ‣ Update Modules List to start the
updating tool. The Module Update window opens notifying the user that
OpenERP will look at the server side for adding new modules and updating
existing ones.

Click Update to start the update on the server side. When it is
complete, you will see a Module update result section indicating how many new modules were added
and how many existing modules were updated. Click Open Modules to return to the updated list.


Note

Modules

All the modules available on your computer can be found in the addons directory of your OpenERP
server. Each module there is represented by a directory carrying the name of the module or by a
file with the module name and .zip appended to it. The file is in ZIP archive format and replicates
the directory structure of unzipped modules.




Tip

Searching through the whole list

The list of modules shows only the first available modules. In the web client you can search or
follow the First / Previous / Next / Last links to get to any point in the whole list, and you can
change the number of entries listed by clicking the row number indicators between Previous
and Next
and selecting a different number from the default of 20.

If you use the GTK client you can search, as you would with the web client, or use the selection field
(currently showing 80) to
the top right of the window to change the number of entries returned by the search from its default
limit of 80, or its default offset of 0 (starting at the first entry) in the whole list.






配置及重运行配置向导

One of the new features of OpenERP is the Configuration wizard. Once run, the Reconfigure shortcut will appear. This wizard provides an easy way to install modules, thanks to its user-friendly and easy-to-use interface. The user may invoke this wizard at his own convenience using the shortcut Reconfigure, found just below the database and user name in the web interface or in the Shortcut menu in the GTK client. The same Configuration dialog box appears that you may have encountered at the time of installing a new database. Why did we call it the Reconfigure wizard? Indeed, because it allows the user to review installed applications and install related additional features or simply to install new applications on the fly.

When you go through the various steps in the wizard, you will come across some options that are checked and greyed. These are applications already installed. In the openerp_ch02 database configuration, you may see that the Customer Relationship Management option is already checked because this Business Application has been installed in this database.
Install extra applications simply by checking the corresponding options and clicking Install or click Skip to stop the configuration. You will eventually also come across the CRM Application Configuration step which you may use to add features to your CRM application. For now, select the Claims option and click Configure. This will in turn install the crm_claim module.


[image: ../../../_images/reconfigure_wizard.png]
Reconfigure wizard showing Customer Relationship Management application as installed



You may continue adding features this way, skip configuration steps or simply exit from this wizard. When you feel the need to
load your system with additional features, you may invoke the Reconfigure wizard again at any point.


Note

You can also change the Configuration Wizard through the Administration ‣ Configuration ‣ Configuration Wizards ‣ Configuration Wizards.






安装新模块及应用

You will now install a module named google_map, which will enable you to add a feature to the partner form to open the location directly in Google Maps. This is part of the core installation, so you do not need to load anything to make this work.

Open the list of modules from Administration ‣ Modules ‣ Modules. Search for the module by entering the name google_map in the Name field on the search screen then clicking it in the list that appears to open it. The form that describes the module gives you useful information such as its version number, its status and a review of its
functionality. Click Schedule for Installation and the status of the module changes to To be installed.


Tip

From now on you can schedule and install modules from list view too. Notice the buttons on the right side and the action button to install.




[image: ../../../_images/install_google_map_module.png]
Installation of the Google Maps module




Tip

Technical Guide

If you select a module in any of the module lists by clicking on a module line and then on
Technical Guide at the top right of the window, OpenERP produces a technical report
on that module. It is helpful only if the module is installed.

This report comprises a list of all the objects and all the fields along with their descriptions.
The report adapts to your system and reflects any modifications you have made and all the other
modules you have installed.



Then, either use the menu Administration ‣ Modules ‣ Apply Scheduled Upgrades, or from the Actions section click Apply Scheduled Upgrades, then Start update on the Module Upgrade
form that appears. Close the window when the operation has completed. Return to the Sales menu; you will
see the new menu Products has become available.


Tip

Refreshing the menu in the GTK Client

After an update in the GTK client you will have to open a new menu to refresh the content –
otherwise you will not see the new menu item. To do that, use the window menu Form ‣
Reload / Undo or use the shortcut Ctrl+R.






安装模块及其依赖模块

Now install the Warehouse Management module using the same process as before.
Start from Administration ‣ Modules ‣ Modules.



	Get the list of modules, and search for the stock module in that list.

	Schedule the module for installation by clicking Schedule for Installation.

	Do the same for account.

	Click Apply Scheduled Upgrades on the action toolbar to the right.

	Click Start update to install both modules.

	After a few seconds, when the installation is complete, you may close this dialog box.

	You will see details of all the features installed by the modules on a new
Features tab on the module form.






When you return to the Warehouse menu, you will find the new menu items under it like
Warehouse ‣ Warehouse Management ‣ Incoming Shipments, Warehouse ‣ Products Moves,  which are a part of the Warehouse management system. You will also see all the accounting functions that are now available in the Accounting menu.

There is no particular relationship between the modules installed and the menus added. Most of the
core modules add complete menus but some also add sub-menus to menus already in the system. Other
modules add menus and sub-menus as they need. Modules can also add additional fields to existing
forms, or simply additional demonstration data or some settings specific to a given requirement.


Note

Dependencies Between Modules

The module form shows two tabs before it is installed.
The first tab gives basic information about the module, and the
second gives a list of modules that this module depends on. So when you install a module, OpenERP
automatically selects all the necessary dependencies to install this module.

That is also how you develop the profile modules: they simply define a list of modules that you want
in your profile as a set of dependencies.



Although you can install a module and all its dependencies at once, you cannot remove them in one
fell swoop – you would have to uninstall module by module. Uninstalling is more complex than
installing because you have to handle existing system data.


Note

Uninstalling Modules

Although it works quite well, uninstalling modules is not perfect in OpenERP. It is not guaranteed
to return the system exactly to the state it was in before installation.

So it is recommended that you make a backup of the database before installing your new modules so
that you can test the new modules and decide whether they are suitable or not. If they are not, then
you can return to your backup. If they are, then you will probably still reinstall the modules on
your backup so that you do not have to delete all your test data.

If you wanted to uninstall, you would use the menu Administration ‣ Modules
‣ Modules and then uninstall them in the inverse order of their
dependencies: stock, account.






安装附加功能

To discover the full range of OpenERP’s possibilities, you can install many additional modules.
Installing them with their demonstration data provides a convenient way of exploring the whole core
system. When you build on the openerp_ch02  database, you will automatically include
demonstration data because you checked the Load Demonstration Data checkbox when you originally
created the database.

Click Administration ‣ Modules ‣ Modules to give you an
overview of all of the modules available for installation.

To test several modules, you will not have to install them all one by one. You can use the dependencies
between modules to load several at once.
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OpenERP 6.1 新改进


软件改进


	OpenERP has been structured as Business Applications and its menu has been changed to match this,

	Major improvements in usability, especially in the Web version,

	Simplified versus Extended view,

	When you search for a record, e.g. a customer / supplier, the web version will propose to create the new partner when no existing partner is found,

	When you click a Business Application in the Web version, the related Dashboard will be opened,

	To display the process view, click the Question Mark next to the title in the web version,

	Menutips & Tooltips will be displayed to explain more about the active screen,

	Dynamic Filters which allow you to easily create and save your own filters, with Group by options, Extended filters, and much more,

	User Roles are no longer used, they have been integrated in the User Groups,

	The Administrator will now only have the rights according to the user groups that have been assigned to him,

	Multicompany has been integrated in the core of OpenERP and does not require the installation of modules. You just have to add the User Group Useability / Multi-Company,

	Perform actions, such as update status, confirm, delete, ... directly from List View,

	Use communication tools such as Fetchmail, Outlook & Thunderbird integration and CalDAV / WebDAV (also available on Android & Iphone),

	Create your own e-mail templates for use throughout OpenERP,

	Use the Scheduler for objects other than Manufacturing too,

	Click the star in the web version to quickly create a shortcut for a screen you often use,

	When you perform an action in List view in the web version, (i.e. change the status of a lead), OpenERP will display a bar containing information about this change. You can click the link to open the lead concerned,

	Updated configuration wizard to install new features using OpenERP modules in user friendly way.






业务流程改进

销售管理


	CRM has been integrated in the Sales Management Business Application,

	Geolocalization module, also allowing you to send qualified opportunities directly to external partners,

	Manage your Marketing Campaigns and send automated e-mails based on your own templates,

	For Leads, OpenERP will check the email address of the contact and when found for an existing partner, it will propose to merge the new contact with the corresponding partner,

	Create your company wiki for Sales FAQ,

	History tab in the Customer form to keep track of all events,

	When you convert a lead to an opportunity, you now have the option to not create a partner, but just keep the contact data in the opportunity,

	Create a new partner from a lead or an opportunity, or merge with an existing partner.



仓储管理


	Push & Pull rules for stock locations have been extended and integrated with multicompany,

	Configure units of measure by reference unit, bigger than / smaller then reference unit,

	Update stock level from the Product form and automatically create a physical inventory for it.



财务管理


	By default, only one Entry Sequence is available for a journal. If you want to use two sequences for your journal numbering, please install the account_sequence module,

	Separate numbering is now also available for Bank Journals,

	Quickly enter Journal Entries from List View from the Journal Items menu. Configure your journal with default debit & credit accounts, select the journal in the Journal Items List View, click New and start creating new entries,

	Chart of Accounts and Chart of Taxes can be displayed for a selected period,

	OpenERP has added a flexible, easy Invoicing module allowing you to keep track of your accounting, even when you are not an accountant. If you install the Invoicing module, in Simplified view, you will only have the Invoicing items. You should not use both Invoicing and Accounting,

	Use the Financial Management Configuration Wizard to easily select features you want to use,

	On installation of a predefined Chart of Accounts, the wizard also proposes default bank and cash accounts, and default Sales and Purchase taxes,

	On a journal you can set whether OpenERP should check if the invoice date is in the current period. This used to be a separate module,

	Different journal types for Refunds and Invoices,

	When creating a new journal, parameters are preset according to the journal type. The Entry Sequence for the journal is automatically created on Save,

	Cash Box, possible to keep a real cash register.



项目管理


	Improved Gantt chart in the Web version,

	Long Term Planning that can be calculated according to the working time of each employee involved in the project with the new Scheduler feature,

	On creation of a new project, OpenERP automatically creates the corresponding Analytic Account in the Projects chart of accounts. You no longer have access to the analytic account from the Project.



生产管理


	Scrap consumed or finished goods and have the related stock moves automatically,

	Consume products partially or completely.



人力资源管理


	Manage your evaluation process,

	Keep track of your recruitments and receive applicant mails directly in OpenERP, including attachments,

	A complete integration of payroll management system with accounting application.









          

      

      

    


    
         Copyright .
      Last updated on 2015-07-13 16:24:00.
      Created using Sphinx 1.3.1.
    

  

  
    
    
    开始使用OpenERP
    
    

    

 

















  
  

    
      Navigation

      
        	
          index

        	
          next |

        	
          previous |

        	OpenERP v6 

          	目录 

          	OpenERP 用户手册 

          	OpenERP 第一步 

          	OpenERP 漫游指南 
 
      

    


    
      
          
            
  
开始使用OpenERP

You will now explore the database openerp_ch02  with these profile modules installed to give
you an insight into the coverage of the core OpenERP software.


Tip

翻译新模块

When you have installed a new module and are using additional languages to English, you have to reload
the translation file. New terms introduced in these modules are not translated by default. To do
this use Administration ‣ Translations ‣ Load an Official Translation.



Depending on the user you are connected as, the page appears differently.
Using the installation sequence above, certain dashboards may be assigned as various
users’ home pages. They show a summary of the information required to start the day effectively. A
project dashboard might contain:


	a list of the tasks to carry out,

	a list of the tasks which is assigned to current user,

	a list of sprints,

	a list of issues assigned to current user,

	a graph of Planned vs Total hours,

	a graph of Remaining hours by Project,

	a graph of Open Issues by Creation Date.



Each of the lists can be reordered simply by clicking the heading of a column – first in ascending, then in descending order as you click repeatedly. To get more information about any particular entry, click on the name in the first column, or if you want to show a particular panel, click Zoom above it.


[image: ../../../_images/admin_project_dashboard.png]
Project Dashboard



A user’s home page is automatically reassigned during the creation or upgrading of a database. It is
customary to assign a dashboard to someone’s home page, but any OpenERP screen can be assigned to the
home page of any user.


Tip

Creating Shortcuts

Each user has access to many menu items from the menu. But in
general, an employee uses only a small part of the system’s functions.

So you can define shortcuts for the most-used menus. These shortcuts are personal for each user. To
create a new shortcut, just click the ‘*’ of the header of the view in web client.

To remove a shortcut just click the link and again click ‘*’ of the header of the view.



The following sections present an overview of the main functions of OpenERP. Some areas are
covered in more detail in the following chapters of this book and you will find many other functions
available in the optional modules. Functions are presented in the order that they appear on the main
menu.


基本概念


业务伙伴及其联系人

To get familiar with the OpenERP user interface, you will start working with information about
partners. Clicking Sales ‣ Address Book ‣ Customers brings up a list of partners that were
automatically loaded when you created the database with Load Demonstration Data checked.




快速定位业务伙伴

Above the partner list you will see a search form that enables you to quickly filter the partners.

The Customers filter is enabled by default showing partners who are customers. If you have applied no filter, the list shows every partner in the system. For space reasons, this list shows only the first few partners. If you want to display other records, you can search for them or navigate through the whole list using the First, Previous, Next, Last arrows.


[image: ../../../_images/partner_search_tab.png]
Standard partner search




Note

List Limits

By default, the list in the GTK client shows only the first 80 records, to avoid overloading the
network and the server.

But you can change that limit by clicking the selection widget (showing 80 by default) to the
right of the search criteria.

Similarly, the list in the web client shows only the first 20, 50, 100, 500 or unlimited records.

The actual number can be switched by clicking the link between the PREVIOUS and NEXT buttons
and selecting one of the other limits.



In the web version, if you click the name of a partner, the form view corresponding to that partner opens in Read-Only
mode. In the list you could alternatively click the pencil icon to open the same form in Edit mode.
Once you have a form, you can toggle between the two modes by clicking Save or Cancel when in
Edit mode and Edit when in Read-Only mode.




业务伙伴信息窗口

The partner form contains several tabs, all referring to the current record:


	General,

	Sales & Purchases,

	Accounting,

	History,

	Notes.



The fields in a tab are not all of the same type – some (such as Name) contain free
text, some (such as the Language) enable you to select a value from a list of options,
others give you a view of another object (such as Partner Contacts – because a partner
can have several contacts) or a list of links to another object (such as Partner Categories).
There are checkboxes (such as the Active field in the Sales & Purchases tab),
numeric fields (such as Credit Limit in the Accounting tab) and date fields (such as Date).

The History tab gives a quick overview of partner activities – an overview of useful information such as Leads and Opportunities, Meetings, Phone Calls, Emails and Tasks. Events are generated automatically by OpenERP from changes in other documents that refer to this partner.

It is possible to add events manually which directly relate to the corresponding form, such as a note recording a phone call. To add a new event click New in the Phone Calls section. That opens a new Phone Call pop-up form enabling a phone-call event to be created and added to the current partner.




与业务伙伴操作交互

To the right of the partner form is a toolbar containing a list of possible Reports ,
Actions and quick Links about the partner displayed in the form.

You can generate PDF documents for the selected object (or, in list view, about one or more
selected objects) using certain buttons in the Reports section of the toolbar:


	Labels : print address labels for the selected partners,

	Overdue Payments : print a letter to notify the selected partners of overdue payments,



Certain actions can be started by the following buttons in the Actions section of the
toolbar:


	SMS Send: enables you to send an SMS to selected partners. This system uses the bulk
SMS facilities of the Clickatell® company http://clickatell.com,

	Mass Mailing: enables you to send an email to a selection of partners,

	Create Opportunity: opens a window to create an opportunity for the partner.




Tip

Reports, Actions and Links in the GTK Client

When you are viewing a form in the GTK client, the buttons to the right of the form are shortcuts to
the same Reports, Actions and Links as described in the text. When you are viewing a list (such as
the partner list), those buttons are not available to you. Instead, you can reach Reports and Actions
through two of the buttons in the toolbar at the top of the list – Print and Action.



Partners are used throughout the OpenERP system in other documents. For example, the menu
Sales ‣ Sales Orders brings up all the Sales Orders in list view. Open an order in form view and click the name of a partner, even when the form is read-only. The Partner form will open.


Tip

Right-clicks and Shortcuts

In the GTK client you do not get hyperlinks to other document types. Instead, you can right-click in
a list view to show the linked fields (that is fields having a link to other forms) on that line.

In the web client you will see hyperlink shortcuts on several of the fields on a form in Read-
Only mode, allowing you to be taken directly to the corresponding form. When the web form is in Edit mode,
you can instead right-click the mouse button
in the field, to get all of the linked fields in a pop-up menu just as you would with the GTK
client.

You can quickly give this a try by going to any one of the sales orders in Sales
‣ Sales Orders. See where you can go from the
Customer field using either the web client with the form in
both read-only and in edit mode, or with the GTK client.




[image: ../../../_images/familiarization_sale_partner.png]
Links for a partner appear in an order form



Before moving on to the next topic, take a quick look at the Sales ‣
Configuration ‣ Address Book  menu, particularly Partner Categories  and  Localisation menus.
They contain some of the demonstration data that you installed when you created the database.


产品

In OpenERP, product is used to define a raw material, a stockable product, a consumable or a service. You can
work with whole products or with templates that separate the definition of products and variants (extra module).

For example, if you sell t-shirts in different sizes and colors:


	the product template is the “T-shirt” which contains information common to all sizes and all
colors,

	the variants are “Size:S” and “Color:Red”, which define the parameters for that size and
color,

	the final product is thus the combination of the two – T-shirt in size S and color Red.



The value of this approach, for some sectors, is that you can just define a template in detail and all
of its available variants briefly, rather than every item as an entire product.



Note

Example Product Templates and Variants

A product can be defined as a whole or as a product template and several variants. The variants
can be in one or several dimensions, depending on the installed modules.

For example, if you work in textiles, the variants on the product template for “T-shirt” are:


	Size (S, M, L, XL, XXL),

	Colour (white, grey, black, red),

	Quality of Cloth (125g/m2, 150g/m2, 160g/m2, 180g/m2),

	Collar (V, Round).



This separation of variant types requires the optional module product_variant_multi.
Using it
means that you can avoid an explosion in the number of products to manage in the database. If you
take the example above, it is easier to manage a template with 15 variants in four different types
than 160 completely different products. This module is available in extra-addons.






The Sales ‣ Products menu gives you access to the definition of products and their templates and variants.


Tip

Consumables

In OpenERP, a consumable is a physical product which is treated like a stockable product, with the exception
that stock management is not taken into account by the system. You could buy it, deliver it or
produce it but OpenERP will always assume that there is enough of it in stock. It never triggers a
procurement exception.



Open a product form to see the information that describes it. The demonstration data show several types of products, which gives quite a good overview of the options.

Price lists (Sales ‣ Configuration ‣ Pricelists) determine the purchase and selling prices and
adjustments derived from the use of different currencies. The Default Purchase
Pricelist uses the product’s Cost Price field for the Purchase price to be calculated. The
Public Pricelist uses the product’s Sale Price field to calculate the Sales price in quotations.

Price lists are extremely flexible and enable you to put a complete price management policy in place.
They are composed of simple rules that enable you to build up a rule set for most complex situations:
multiple discounts, selling prices based on purchase prices, price reductions, promotions on product ranges and so on.

You can find many optional modules to extend product functionality, such as:


	membership : for managing the subscriptions of members of a company,








	product_electronic : for managing electronic products,








	product_extended : for managing production costs,








	product_expiry : for agro-food products where items must be retired after a certain
period,








	product_lot_foundry : for managing forged metal products.



All of the above modules are found in extra-addons, except for the membership and the product_expiry module.








提升销售能力

OpenERP provides many tools for managing relationships with partners. These are available through
the Sales menu.


Tip

CRM & SRM

CRM stands for Customer Relationship Management, a standard term for systems that manage client and
customer relations. SRM stands for Supplier Relationship Management, and is commonly used for
functions that manage your communications with your suppliers.



Through Customer Relationship Management, OpenERP allows you to keep track of:


	Leads

	Opportunities

	Meetings

	Phone Calls

	Claims

	Helpdesk and Support

	Fund Raising



OpenERP ensures that each case is handled effectively by the system’s users, customers and
suppliers. It can automatically reassign a case, track it for the new owner, send reminders by email
and raise other OpenERP documentation and processes.

All operations are archived, and an email gateway lets you update a case automatically from emails
sent and received. A system of rules enables you to set up actions that can automatically improve
your process quality by ensuring that open cases never escape attention.

As well as those functions, you have got tools to improve the productivity of all staff in their daily
work:


	an email client plugin for Outlook and Thunderbird enabling you to automatically store your emails and their attachments in the
Knowledge Management (previously Document Management System) integrated with OpenERP,

	interfaces to synchronize your Contacts and Calendars with OpenERP,

	sync your meetings on your mobile phone,

	build a 360° view on your Customer,

	integration with Google applications.



You can implement a continuous improvement policy for all of your services, by using some of the
statistical tools in OpenERP to analyze the different communications with your partners. With
these, you can execute a real improvement policy to manage your service quality.

The management of customer relationships is detailed in the second section of this book (see
part2-crm).




管理各种账本

The chapters in 管理你的账簿 in this book are dedicated to general and analytic accounting.
Following is a  brief overview of the functions to introduce you to this Business Application.

Accounting is totally integrated into all of the company’s functions, whether it is general,
analytic, budgetary or auxiliary accounting. OpenERP’s accounting function is double-entry and
supports multiple company divisions and multiple companies, as well as multiple currencies and
languages.

Accounting that is integrated throughout all of the company’s processes greatly simplifies the work
of entering accounting data, because most of the entries are generated automatically while other
documents are being processed. You can avoid entering data twice in OpenERP, which is commonly a
source of errors and delays.

So OpenERP’s accounting is not just for financial reporting – it is also the anchor-point for many
of the company’s management processes. For example, if one of your accountants puts a customer on
credit hold, then that will immediately block any other action related to that company’s credit (such
as sales or delivery).

OpenERP also provides integrated analytical accounting, which enables management by business
activity or project and provides very detailed levels of analysis. You can control your operations
based on business management needs, rather than on the charts of accounts that generally meet only
statutory requirements.

OpenERP has added a flexible, easy Invoicing module allowing you to keep track of your documents and payments, even when you are not an accountant. This will allow smaller businesses to keep track of their payments without having to implement a complete accounting system.

Keep track of your Cash Moves by using the new OpenERP Cash Box.




管理提升员工士气

OpenERP’s Human Resources Management Business Application provides functionality such as:


	Manage your Employees, Contracts & Staff Performance,

	Talent Acquisition,

	Keep track of Holidays and Sickness Leaves,

	Manage the Evaluation Process,

	Keep track of Attendances & Timesheets,

	Track Expenses.



Most of these functions are provided from optional modules whose name starts with hr_ rather than the core hr module, but they are all loaded into the main Human
Resources menu.

The different issues are handled in detail in the fourth part of this book 有效的运营管理, dedicated to internal
organization and to the management of a services business.




掌控项目管理

OpenERP’s project management tools enable you to define tasks and specify requirements for those tasks, efficient allocation of resources to the requirements, project planning, scheduling and automatic communication with partners.

All projects are hierarchically structured. You can review all of the projects from the menu Project ‣ Projects. Then select Gantt view to obtain a graphical representation of the project.


[image: ../../../_images/project_gantt.png]
Project Planning



You can run projects related to Services or Support, Production or Development – it is a universal
module for all enterprise needs.

Project management is described in 很棒的项目管理.




掌控销售管理

The Sales menu gives you roughly the same functionality as the
Purchases menu – the ability to create new orders and to review the
existing orders in their various states – but there are important differences in the workflows.

Confirmation of an order triggers the delivery of goods, and invoicing timing is defined by a
setting in each individual order.

Delivery charges can be managed using a grid of tariffs for different carriers.




掌控采购管理

Purchases enables you to track your suppliers’ price quotations and convert them into
Purchase Orders as you require. OpenERP has several methods of monitoring invoices and tracking
the receipt of ordered goods.

You can handle partial deliveries in OpenERP, so you can keep track of items that are still to be
delivered on your orders, and you can issue reminders automatically.

OpenERP’s replenishment management rules enable the system to generate draft purchase orders
automatically, or you can configure it to run a lean process, driven entirely by current production
needs.

You can also manage purchase requisitions to keep track of quotations sent to a multitude of suppliers.




优化仓库管理

The various sub-menus under Warehouse together provide operations you need to manage stock.
You can:


	define your warehouses and structure them around locations you choose,

	manage inventory rotation and stock levels,

	execute packing orders generated by the system,

	execute deliveries with delivery notes and calculate delivery charges,

	manage lots and serial numbers for traceability,

	calculate theoretical stock levels and automate stock valuation,

	create rules for automatic stock replenishment.



Packing orders and deliveries are usually defined automatically by calculating requirements based on
sales. Stores staff use picking lists generated by OpenERP, produced automatically in order of
priority.

Stock management is, like accounting, double-entry. So stocks do not appear and vanish magically
within a warehouse, they just get moved from place to place. And, just like accounting, such a
double-entry system gives you big advantages when you come to audit stock because each missing item
has a counterpart somewhere.

Most stock management software is limited to generating lists of products in warehouses. Because of
its double-entry system, OpenERP automatically manages customer and suppliers stocks as well, which
has many advantages: complete traceability from supplier to customer, management of consigned stock,
and analysis of counterpart stock moves.

Furthermore, just like accounts, stock locations are hierarchical, so you can carry out analyses at
various levels of detail.




提升生产能力

OpenERP’s production management capabilities enable companies to plan, automate and track manufacturing and product assembly. OpenERP supports multi-level bills of materials and lets you substitute sub-assemblies dynamically, at the time of sales ordering. You can create virtual sub-assemblies for re-use on several products with phantom bills of materials.


Note

BOMs, Routing, Workcenters

These documents describe the materials that make up a larger assembly. They are commonly called
Bills of Materials or BOMs.

They are linked to routings which list the operations needed to carry out the manufacturing or
assembly of the product.

Each operation is carried out at a workcenter, which can be a machine or a person.



Production orders based on your company’s requirements are scheduled automatically by the system,
but you can also run the schedulers manually whenever you want. Orders are worked out by calculating
the requirements from sales, through bills of materials, taking current inventory into account. The
production schedule is also generated from the various lead times defined throughout the system, using the same
route.

The demonstration data contain a list of products and raw materials with various classifications
and ranges. You can test the system using this data.




随时随时分享各种管理文档

OpenERP integrates a complete document management system that not only
carries out the functions of a standard DMS, but also integrates with all
of its system-generated documents such as Invoices and Quotations. Moreover, it
it keeps all of this synchronized. You can define your own directory structure and tell OpenERP to automatically store documents such as Invoices in the DMS.

OpenERP provides an FTP Interface for the Document Management System. You will not only be able to access documents from OpenERP, but you can also use a regular file system with the FTP client.
FTP is just a way of getting access to files without needing to use an OpenERP client, to allow you to access files from anywhere.
You can also add documents to be stored in OpenERP directly through the FTP system in the corresponding OpenERP directory. These documents will automatically be accessible from the form concerned in OpenERP.

The Knowledge system is also well-integrated with e-mail clients such as Thunderbird and Outlook. It also allows you to sync your calendars (CalDAV).




衡量您的业务性能

To measure your business performance OpenERP, provides two interesting features:


	Dashboards

	Statistical Reports



On a single page, Dashboards give you an overview of all the information that is important to you.
In OpenERP, each application has its own dashboard which opens by default when you select the specific application.
For example, Administration Dashboard will open when you click the Administration menu.


Note

Dashboards

Unlike most other ERP systems and classic statistic-based systems,
OpenERP can provide dashboards for all system users, and not just managers and accountants.

Each user can have his own dashboard, adapted to his needs,
enabling him to manage his own work effectively.
For example, a developer using the Project Dashboard can see information such
as a list of open tasks, tasks delegated to him and an analysis of the progress of
the relevant projects.



Dashboards are dynamic, letting you navigate easily around the entire information base.
Using the icons above a graph, for example, you can filter the data or zoom into the graph. You can
click any element of the list to get detailed statistics on the selected element.

Dashboards can be customized to fit the needs of each user and each company.


Note

Creating or Customizing Dashboards

OpenERP contains a Dashboard Editor. Create your own dashboard to fit your
specific needs in only a few clicks. Go to the Administration ‣ Customization ‣ Reporting ‣ Dashboard Definition menu to define your own dashboard.



The Statistical Analysis is one of the crucial thing for decision making process in any business. OpenERP provides
Statistical Reports for each application. For example, you can access the statistical analysis of Sales-related information
from the menu Sales ‣ Reporting ‣ Sales Analysis. You can search and group the data using this
Statistical Report.




工艺流程跟踪

Many documents have a workflow of their own, and also take part in cross-functional processes.
Take a document that could be expected to have a workflow, such as a Sales Order, and
then click the ? button above its form to see the full process.


[image: ../../../_images/guided_tour_process.png]
Process for a Sales Order



You can see where a particular document is in its process, if you have selected
a single document, by the solid bar on one of the process nodes. You also link
to documents and menus for each of the stages.

There is a clear distinction between a cross-functional process (that is currently only
shown in the web client) and the detailed document workflow (that is shown in both the
web client from a process node, and the GTK client from the
Plugins > Execute a Plugin... menu and clicking either
the Print Workflow or the Print Workflow (Complex) option.


[image: ../../../_images/purchase_workflow.png]
Workflow for a Purchase Order



Alongside the document management system, the process visualization features make OpenERP
far better for documentation than similar systems.




还不满足？

You have been guided through a brisk, brief overview of many of the main functional areas of OpenERP.
Some of these – a large proportion of the core modules – are treated in more detail
in the following chapters.

You can use the menu Administration ‣ Modules ‣ Modules
to find the remaining modules that have been loaded into your installation but
not yet installed in your database. Some modules have only minor side-effects to OpenERP (such as
google_maps), some have quite extensive effects (such as the various charts of accounts), and
some make fundamental additions.

But there are now more than hundred modules available. You can install them according to your needs.

A brief description is available for each module, but the most thorough way of understanding their
functionality is to install one and try it. So, pausing only to prepare another test database to try
it out on, just download and install the modules that appear interesting.




提示与技巧


快捷键概述


	OpenERP 的快捷键









	Shortcut Key
	What does it do?




	Ctrl+H
	Contextual Help


	Ctrl+O
	Connect


	Ctrl+Q
	Quit






	OpenERP 表单的快捷键









	Shortcut Key
	What does it do?




	Ctrl+D
	Delete


	Ctrl+F
	Find


	Ctrl+G
	Go To Resource ID


	Ctrl+L
	Switch to List/Form


	Ctrl+N
	New


	Ctrl+P
	Preview in PDF


	Ctrl+Page Down
	Next Tab


	Ctrl+Page Up
	Previous Tab


	Ctrl+R
	Reload/Undo


	Ctrl+S
	Save


	Ctrl+T
	Menu


	Ctrl+W
	Close Tab


	Page Down
	Next


	Page Up
	Previous


	Shift+Ctrl+D
	Duplicate


	Shift+Ctrl+H
	New Home Tab


	Shift+Ctrl+Y
	Repeat latest action






	Shortcuts for OpenERP when editing a resource in a popup window









	Shortcut Key
	What does it do?




	Ctrl+Enter
	Save and Close window


	Ctrl+Esc
	Close window without Saving






	Shortcuts in a relation field









	Shortcut Key
	What does it do?




	F1
	Add new Field/Line on the fly


	F2
	Look up information


	F3
	Zoom on current field






	Shortcuts in text entries









	Shortcut Key
	What does it do?




	Ctrl+C
	Copy selected text


	Ctrl+V
	Paste selected text


	Ctrl+X
	Cut selected text


	Enter
	Auto-complete text field


	Shift+Tab
	Previous editable widget


	Tab
	Next editable widget








过滤器

The Advanced Search View is a new feature of OpenERP v6 which provides a very user-friendly filtering mechanism
for the end user to easily look up desired records from the list.

The perfect example of an advanced search view is the Statistical Report of OpenERP.
Such a report shows the statistical summary with filtered results to the end user.

Usually an Advanced Search is composed of three elements, the Filter buttons at the top, the Extended Filters, and the Group by option.
These filters are dynamic, so according to filters you apply, extra columns may be added to the view.

You can also easily combine filters; an arrow will be displayed and you will get a structure according to the order in which you clicked the Filter buttons.

Let’s show an example.
The statistical report for project tasks is Task Analysis which can be displayed using the
menu Project ‣ Reporting ‣ Tasks Analysis when you have installed the Project Management module.


[image: ../../../_images/filter_task_analysis.png]
Task Analysis



You can see the Advanced Search View in the light green shaded area.

You can filter the information of a task according to the Group by features.

Click, for instance, the Stage button in Group by, and then click Task to analyse your tasks by stage and then by task.

This Advanced Search View can also be attached to any List View of an object and hence increase the
search facility when a user looks up the record in list view.


[image: ../../../_images/filter_task_list_view.png]
Search the Tasks which are `In Progress` with Group by Project and State
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如何应用到你的业务中?


Now that you have discovered some of the many possibilities of OpenERP from a tour of the
demonstration database, you will develop a real case. An empty database provides the starting point
for testing a classic workflow from product sales to purchase,
completing your guided tour and your getting familiar with OpenERP.


A database loaded with demonstration data is very useful to understand OpenERP’s general
capabilities. But to explore OpenERP through a lens of your own company’s needs, you should start
with an empty database. You will work in this chapter on a minimal database containing no
demonstration data, so that there is no confusion about what you created. You will keep the
database you have created, to allow you to build on it throughout the rest of this book
if you want to.

You will develop a real case through the following phases:



	Specify a real case;

	Describe the functional needs;

	Configure the system with the essential modules;

	Carry out the necessary data loading;

	Test the system with your database.






The case is deliberately simple to provide you with a foundation for the more complex
situations you might have to handle in your company. Throughout this chapter, we assume that you access OpenERP through its web interface. And it is also assumed (as in the rest of this book) that you are using the latest download of OpenERP version 6, the stable production version at the time of writing (not the trunk version, which is likely to have new and potentially unstable features).



	业务案例

	基本设置

	让你的数据库在没有演示数据的情况下运行起来

	满足你的需求

	帐套配置
	配置会计科目
	科目类型

	科目

	属性





	配置账簿

	配置公司信息

	新建业务伙伴,伙伴分类及伙伴联系人

	新建商品信息及其分类

	配置库位信息

	设置会计科目表

	备份数据库帐套





	优化 采购/销售 业务流程
	采购

	收货

	开票管理

	支付货款

	商机产生销售

	发货备货

	进销存

	客户收款
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业务案例

在本案例中,你要配置系统以达成以下目的:


	从供应商处购买产品,

	在仓库中暂存产品,

	将产品出售给客户.



系统将完成发票到支付的各个业务.




基本设置

在本案例中, 你需要定义下面的这些数据:


	供应商以及该供应商的分类,

	客户以及该客户的分类,

	几个产品以及这些产品的分类定义,

	一次盘点,

	一张采购单,

	一张销售单,

	各种发票,

	各种支付单.



要完成本次测试, 你需要创建至少一个 供应商, 客户, 产品, 仓库, 财务科目表 和 银行帐号 .




让你的数据库在没有演示数据的情况下运行起来

Use the technique outlined in 数据库的创建 to create a new database, openerp_ch03 . This
database will be free of data and contain the least possible amount of functionality as a starting
point. You will need to know your super administrator password for this – or you will have to find
somebody who does have it to create this seed database. You will not be able to use the openerp_ch01  or openerp_ch02  databases that you might have created so far in this book
because they both contain demonstration data.

在新 启动 页面, 点击下面的 管理帐套 并在新窗体中点击 创建帐套 完成财套的新建操作. 创建一个干净的帐套 :


	超级管理员密码 : 默认密码为 admin 

	新帐套名称 : openerp_ch03 ,

	载入演示数据 勾选框: 不勾选 (不勾选很重要, 很多人豆是这步搞错老.),

	默认语言 : English (US) ,

	管理员密码 : admin (这个密码就是你后面登陆OpenERP的管理员密码,请牢记,并设置复杂一些),

	重复密码 : admin .




[image: ../../../_images/openerp_ch03.png]
创建一个干净的帐套



在 新帐套配置从头开始 - 第一步 界面点击 新建 按钮.


[image: ../../../_images/openerp_ch03_s1.png]
新帐套配置从头开始 - 第一步



使用 帐号 admin  以及前面创建帐套时你设置的密码 登陆帐套 openerp_ch03 后, 会弹出帐套配置向导,你可以有两个选择:


	如果你点击开始设置按键, OpenERP将会让你操作以下几步: 设置你的界面 -这一步选择默认的 简单 (另外一个选项是``拓展``); and 设置公司信息 - 输入 公司名 选择一个适合你公司的 币种.
接下来OpenERP将会根据设置中选项的功能，相应安装一些程序 Configuring a database with other applications and functionality when you select Extended view option :




[image: ../../../_images/openerp_ch03_config.png]
Configuring a database with other applications and functionality when you select Extended view option




	或者 -




	点击 跳过向导 进入页面 Starting the minimal database , 你就可以开始使用这个最小化安装的帐套了.




[image: ../../../_images/openerp_ch03_start.png]
Starting the minimal database






满足你的需求

Functional needs can be provided by core modules from OpenERP. You just have to decide which functionality
you want in your system. Click the Check Box of the corresponding application in the Configuration Wizard with the Simplified view option.

For this instance, we need the following applications:


	仓库管理 ( stock 模块),

	财务与会计 ( account 模块),

	采购管理 ( purchase 模块),

	销售管理 ( sale 模块).



To get OpenERP to install these business applications, the Configuration Wizard should look as follows:


[image: ../../../_images/openerp_feature.png]
Configuration Wizard with the Simplified view option



在弹出配置会计一览表的时候, 点击 跳过 按钮. OpenERP 就进入默认已安装模块图标列表页面.


[image: ../../../_images/openerp_ch03_main.png]
Database with all required functionality for this example



If you want to reconfigure your system, then click the Reconfigure link that appears in the header of Database with all required functionality for this example.
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帐套配置

You will create all the elements in the database that you need to carry out the use case. These are
specified in the functional requirements.


配置会计科目

You need to start off with a minimal set of accounts, and to do that you will need a couple of
account types. You can structure your accounts into a chart at any time (and, in fact, you can
structure them into several additional charts at the same time as you will see in the chapter
一步一步配置会计), so you do not need to be concerned unduly about structure.


科目类型

Create account types using Accounting ‣ Configuration ‣
Financial Accounting ‣ Accounts ‣ Account Types and then clicking the
New button. You will need the following four types, the first of which is shown
in figure New Account Type.


Defining Account Types
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优化 采购/销售 业务流程

为了熟悉业务流程,下面我们以采购与销售两个业务做样例.

首先是采购业务,我们要达成下面的目的:



	从 元件供应商 那里以单价 56.00 采购 10 个 钛合金散热器 .

	做采购收货入库操作.

	做供应商采购发票.

	支付该发票.






然后,我们再做销售业务,以下面的数据为样例:



	向 客户 Smith and Sons 以单价 130.00/个 销售 6 个 钛合金散热器 .

	安排发货送货.

	开据客户发票.

	并做客户收款.







采购

要给供应商下达采购任务,菜单入口在 Purchases ‣ Purchase Management ‣ Purchase Orders 中文菜单项为 采购 ‣ 采购管理 ‣ 采购订单
点击 新建 按钮即可。

并填写采购订单中下面的字段:


	Supplier : Plumbing Component Suppliers .



当你选择了 供应商 后, 采购订单会自动完成该供应商的 地址 及 价格表 字段。

录入下面的数据:


	产品 : 钛合金散热器  - 在这里你可以按输入进行产品的模糊查询,当你输入一些产品名称关键词后按 Tab 键或者点击右侧的 放大镜 图标, 就会按给定的关键词弹出相关的产品查询结果窗口,供选择产品(前提是你已录入过相关产品的基础物料数据), 另外,如果你提供的查询只有一个结果时,系统会自动替你选择( Tab 键录入方式)。



当你在采购明细行选择一个产品后，OpenERP会自动将该产品的其他下面的信息带出来:


	单位 : 产品的默认采购单位,

	名称 : 产品的描述性名称,

	交货日期 : 采购预计交付时间,

	单价 : 产品的价格规则产生的默认采购价格,

	辅助核算项 : 当你设置了辅助核算默认项值，会自动带出来。(本例没有设置相关辅助核算),

	税 : applicable taxes defined in the partner, if specified, otherwise in the
product, if specified (there are not any in this example).



按上面的需求,修改采购订单中的数量及价格字段:


	数量 : 10.00.

	价格 : 56.00.



保存采购订单明细,点击 关闭 按钮关闭 明细 窗口. 点 保存 按钮, 可以保存数据并查看明细数据而不关闭窗口.

目前为止采购还仅是询价状态,现在你可以使用 采购经理或者 公司财务的角色 进到本采购单 点击 转换为采购单 的按钮, 批准该笔采购.

现在你点击 收货与发票 页签时，你可以看到收货地址是你所在公司 仓库 的 收货地址 。
并且系统已经自动为本次采购生成了草稿状态(还可以根据需要进行修改)的供应商发票。
因为目前为止还没有涉及财务部分，所以这个留到后面财务人员进行确认核准操作。




收货

在确认采购后,就需要等供应商送货,并按下面的操作进行收货操作:



	点开各个菜单项前的展开图标 仓库 ‣ 仓库管理 ‣ 收货 .









Note

From the Purchase Order

You could have clicked the Receptions link to the right of the Purchase Order
to reach the same screen, but this would confuse the purchasing role with the
stores role. That link is very useful during testing and training, however.







	When the Incoming Shipments window appears, select the name of the entry in the list
(IN/00002)   to display the Packing List itself – you would usually do a search for the supplier name
or order number in a list that was larger than this – then click Process to load the
Process Document form.

	Click Validate to indicate that you are receiving the whole quantity of 10 units.






当你收货确认这一刻,你应该可以在对应库存查询到公司该产品的相应库存量了. 恭喜恭喜...

使用菜单 采购 ‣ 产品 ‣ 产品 你可以找到产品 钛合金散热器 实物库存和虚拟库存数量为10.0了。 单击该产品进入到产品 表单 页后,在右面最右侧的 按库位查看库存 链接可以直接查看该产品在各个物理库位与虚拟库位的数量分布情况。点击 库位库存概要 报表就可以查看到各库位各产品的详细库存情况。


[image: ../../../_images/lots_by_location_pdf.png]
List of products and their stock levels




Tip

复式记帐的物流管理

OpenERP operates a double-entry stock transfer scheme similar to double-entry accounting.
Because of this you can carry out various analyses of stock levels in your warehouse,
along with the corresponding levels in Partner Location at your Supplier.
The double-entry system, analogous to that of accounting, enables you to keep track
of stock movements quite easily, and to resolve any errors that occur.






开票管理

When you have received an invoice from your supplier (which would usually be sent to your Accounts department),
go to the menu Accounting ‣ Suppliers ‣ Supplier Invoices
to open a list of supplier invoices waiting for receipt.
These invoices enable your Accounts Department to match the price and quantities
ordered against the price and quantities on the supplier’s invoice (and since it is not uncommon to receive
an invoice showing details more favourable to the supplier than those agreed at the time of
purchase, this is a useful function).

In this example, you created an invoice automatically when you confirmed the supplier’s Purchase
Order. That is because the Invoicing Control  field on the order was set to From
Order(the default option). Other options enable you to create invoices at the time of
receiving goods or manually. The initial state of an invoice is Draft .

Now click the invoice for your order PO00001 to display its contents. You can compare the
goods that you have recorded there with the invoice received from your supplier. If there is a
difference, it is possible to change the order lines to, for example, add a delivery charge. Click
Validate to confirm the invoice and put it into the Open   state.

当发票核准时,系统会自动生成对应的会计凭证.这时打开 公司的会计科目一览表( 会计 ‣ 表 ‣ 科目一览表 ,
在 科目一览表 窗体中 点击 打开一览表 按钮,
你就可以看到对应的 材料采购 科目借方余额与 应付帐款 科目贷方余额 为 560.00 元.




支付货款

选择菜单 Accounting ‣ Suppliers ‣ Supplier Invoices and click on the Unpaid button
for a list of supplier invoices that have not yet been paid. 写PO00001在源文档文本本身发现发票。在实践中,你将会寻找发票通过订单号,或更普遍而言,他们的付款日期为发票接近。

在打开的供应商发票页面点击 支付发票 按钮, 打开 发票支付 窗体进行发票支付操作.

供应商 与 日期 会自动从发票获取. 你只需要选择 支付方式 并点击 核准 按钮即可.


Note

支付发票

这里描述的方法是为企业,不使用他们的会计系统付账单——
只是来记录他们

If you are using the account module with all its features, other, more efficient, methods let you manage payments,
such as entering account statements, reconciling paperwork, using tools for preparing payments,
interfacing with banks.



You can monitor the accounting impact of paying the invoice through the chart of accounts available
from the menu Accounting ‣ Charts ‣ Chart of Accounts. OpenERP
automatically creates accounting entries from the payment, and can reconcile the payment to the
invoice. You now have a new transaction that has debited the Payable account with 560.00 and
credited the Cash account.

If you look in Accounting ‣ Journal Entries ‣ Journal Entries you will see both
accounting transactions, one in each of the Purchase Journal and Bank Journal in
Draft state.




商机产生销售

In OpenERP, sales proposals and sales orders are managed using documents that are based on the
same common functionality as purchase orders, so you will recognize the following documents in general
but see changes to their detail and to their workflows. To create a new sales proposal, use the
menu Sales ‣ Sales ‣ Sales Orders and click on New button which creates a new order in a state of Quotation , then:



	Select the Customer Axelor . This has the effect of automatically
completing several other fields: Ordering Contact, Invoice Address,
Shipping Address, and the Pricelist Public Pricelist (EUR).  They are
all only defaults, so these fields can be modified as you need.

	Click the New button in Sales Order Lines section to open a Sales Order Lines window.

	Select the product Titanium Alloy Radiator . Although the Product field is not
itself required, it is used by OpenERP to select the specific product so that several other fields
can be automatically completed on the order line of the proposal, such as Description,
Unit of Measure, Unit Price, Procurement Method,
Delivery Lead Time, and Taxes.

	Change the Quantity (UoM) to 6 and the Unit Price to 130.00.
Then click Save & Close and the line appears on the quotation form.

	On the Other Information tab of this Sales Order, select a
Picking Policy of Complete Delivery and
Shipping Policy of Invoice on Order After Delivery from their dropdown menu lists.

	Return to the first tab Sales Order and validate the document by clicking
Confirm Order which calculates prices and the changes the order’s state from Quotation to In Progress as shown in screenshot Sales Order Form.
If you were in negotiation with the prospective customer,
you would keep clicking Compute and Save, keeping the document in Quotation state for as long as necessary.









[image: ../../../_images/order.png]
Sales Order Form







	In the last tab of the order History, you can see the Picking List
that has been created and you will be able to see any invoices that relate to this order when they are
generated.






Go to Sales ‣ Products ‣ Products to display a list of
products: just the one, Titanium Alloy Radiator , currently exists in this example. Its
Real Stock still shows 10.00  but its Virtual Stock now shows 4.00 to reflect the new future requirement of 6 units for dispatch.




发货备货

仓库管理员通过菜单项 仓库 ‣ 仓库管理 ‣ 送货单 可以列出当前待处理的送货单, 本例中, 你可以找到由前面的销售单而产生的送货单.


Tip

Running Schedulers

At the moment, your Sales Order is waiting for products to be reserved to fulfil it.
A stock reservation activity takes place periodically to calculate the needs,
which also takes customer priorities into account.
The calculation can be started from the menu
Warehouse ‣ Schedulers ‣ Compute Schedulers.
Running this automatically reserves products.

If you do not want to have to work out your stock needs but have a lean workflow you can install the
mrp_jit (Just In Time) module.



Although OpenERP has automatically been made aware that items on this order will need to be
dispatched, it has not yet assigned any specific items from any location to fulfil it. It is ready to
move 6.00 Titanium Alloy Radiators  from the Stock location to the Customers
location, so start this process by clicking
Check Availability. The Move line has now changed from the Confirmed  state to
the Available  state.

Then click the Process button to reach the Process Document window, where
you click the Validate button to transfer the 6 radiators to the customer.

To analyze stock movements that you have made during these operations, use
Warehouse ‣ Product ‣ Product and find this product, then click on the action
Stock by Location which is at the right most side to see that your stocks have reduced to
4 radiators and the generic Customers location has a level of 6 radiators.




进销存

Use the menu Accounting ‣ Customers ‣ Customer Invoices
to open a list of Sales invoices generated by OpenERP. If they are in the Draft state, it means that they do not yet have any presence in the accounting system. You will find a
draft invoice has been created for the order SO00008  once you have dispatched the goods
because you had selected Invoice on Order After Delivery .

Once you confirm an invoice, OpenERP assigns it a unique number, and all of the corresponding
accounting entries are generated. So open the invoice and click Validate to do that and
move the invoice into an Open  state with a number of SAJ/2011/001.

You can send your customer the invoice for payment at this stage. Click Print Invoice
to get a PDF document that can be printed or emailed to the customer.

You can also attach the PDF document to the OpenERP invoice record. Save the PDF somewhere
convenient on your PC (such as on your desktop). Then click the Add button to the top right of
the invoice form (it looks like a clipboard). Browse to the
file you just saved (record.pdf  if you did not change its name).
This gives you a permanent non-editable record of your invoice on the OpenERP system.

Review your chart of accounts to check the impact of these activities on your accounting. You will see
the new revenue line from the invoice.




客户收款

Registering an invoice payment by a customer is essentially the same as the process of paying a
supplier. 在菜单中 账户 ‣ 客户 ‣ 客户发票,
点击你想要设置为已付的发票名字:



	使用 Payment 按键打开一个`Pay Invoice`新窗口.

	选择 Payment Method, 在这个例子中使用 现金 then validate the entry.







[image: ../../../_images/familiarization_invoice.png]
发票表单



Check your Chart of Accounts as before to see that you now have a healthy bank balance in the Cash  account.
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管理地址簿

在OPENERP中，合作伙伴和联系人之间有什么区别呢？ 合作伙伴 代表一个与你有业务来往的个体 - 客户, 潜在客户, 甚至你公司的
员工.在其他CRM软件中, 合作伙伴也称为一个账户.
联系人 则代表合作伙伴中的个人.

每个合作伙伴可以有无数个联系人. Openerp同样允许一个合作伙伴有多个相同地址类型的联系人.比如，你可以轻松地链接多个开票地址
给一个客户.


Note

地址类型

如果你已经为相同的合作伙伴登记了多个联系人, 你能够通过指定 地址类型 告诉 OpenERP 用于哪种文档用哪个联系人（例如报价单）。

例如：, 合作伙伴(公司) 可以有一个发运地址以区别于公司的开票地址.
如果地址类型被正确指定, OpenERP 在创建单据的时候，能自动选择合适的地址 —- 发票地址被指派为 地址类型为 发票 ，
否则是默认地址。



OpenERP中合作伙伴的概念要比许多其他管理应用程序灵活得多. 为什么呢？? 因为合作伙伴可以同时是你的供应商和客户。
因此，你更新的任何数据将同时应用于客户和供应商! 多亏了这个,你不再需要为同样的合作伙伴更新您的地址簿几次(甚至在几个地方)。

合作伙伴表单包括了关于公司的信息, 比如公司名称，主要语言，公司是 客户 和/或 供应商 .
合作伙伴的表单由几个标签组成.


	一般 标签包括了合作伙伴不同联系人的信息, 邮政，通信和合作伙伴属于的分类,

	销售和采购 标签包括了诸如默认销售员、销售团队等信息，以及网站,

	日志 标签提供了该合作伙伴相关的完整 通信日志 (会议, 营销活动,
线索和商机, 电话访问, emails) . The events the partner has been involved in are created automatically by
different documents like phone calls, leads, meetings,

	the Notes tab is an area for free text notes.




[image: ../../../_images/crm_partner_hist.jpeg]
The History Tab of a Customer




创建和更新合作伙伴

在讲解如何创建合作伙伴之前，仅说两句OPENERP中合作伙伴不同的显示方式。
列表 视图显示客户列表(你点击客户菜单时的默认显示)。这种视图下，你可以同一时间查看到多个客户信息。
当你选择特定客户开始编辑，或者创建一个新客户时，则显示为 表单 视图。

创建一个新的合作伙伴(公司，客户，供应商 ...) 或者打开已存在的客户列表, 使用菜单 销售 ‣地址簿‣ 客户 Sales ‣ Address Book ‣ Customers .
这个菜单不仅可以创建新的合作伙伴，也可以用来查找合作伙伴.


[image: ../../../_images/crm_partner_default.jpeg]
客户表单




Note

必填项

蓝色区域是必填项, 意思就是必须在这里输入一个值。只要蓝色区域没有填写完成，就不能保存这次修改。



在合作伙伴表单上你至少要输入这个公司的 名字 。有些字段是文本字段，其他字段可能链接到别的地方已经填写过的数据, 比如 国家。

根据以下资料创建一个新的客户：


	名称 : Smith and Offspring,

	客户 选择框 : 勾选,

	供应商 选择框 : 不勾选,

	联系人名称 : Stephen Smith,

	类型 : 默认, 在邮政地址部分，

	保存 这个表单。




Tip

电子邮件

如果你要使用Email网关，OUTLOOK或者迅雷插件, 请不要忘记给每一个联系人登记Email地址， 那么这个网关就会把自动地接收到的邮件附给对应的合作伙伴.



更新合作伙伴信息， 打开对应的表单，选择 编辑 然后修改需要更新的字段。正如之前解释过的，当一个公司既是供应商又是客户时，你
只需要编辑一次这个合作伙伴表单，就会自动应用到供应商和客户上。


Note

选择框

为什么说在合作伙伴表单中正确地设置客户和供应商的选择框是很重要的呢? 这些选择框的设计是为了能让Openerp快速的选择那些
下拉框显示的合作伙伴。比如：当在一张销售报价单中你要选择一个合作伙伴时， Openerp只允许你在客户列表中选择.这正是客户
选择框的用处。






管理你的联系人和地址

一个合作伙伴可以有多个联系人。 联系人代表对方公司跟你联系的员工，
还有他们的详细地址。 你可以定义每个地址的类型 (默认, 开票, 送货, 联系  或者 其他)。

联系人信息记录在 客户 表单的 一般 选项中 ，或者地址列表中 销售 ‣ 地址簿 ‣ 地址 Sales ‣ Address Book ‣ Addresses 菜单。


Tip

Same Contact, Different Partners

你是否有联系人属于多个公司的， 并且需要链接到多个合作伙伴？ 查阅 一个管理联系人的替代方案 章节。






定制合作伙伴字段

OpenERP同样允许根据你的需要定义合作伙伴视图。如果你要添加字段，删除字段或者修改视图中的字段顺序，点击 管理视图 选项。

在 地址 表单视图中给联系人添加一个 生日 字段。要这样做, 转到 销售(Sales) ‣
地址簿(Address Book) ‣ 地址(Addresses) 菜单并打开任意一张表单视图。 在右侧菜单栏，点击 管理视图, 然后 编辑,因为相应的视图已经被选定。

Go to the last line of the view and click the blue plus (+) sign to add a field to the Communication group. Proceed as in the figure below, then click the Update button.


[image: ../../../_images/manage_views_addfield_small.jpeg]
联系人生日



In the Properties screen that appears, you can change the label to Birthday in the String field. To indicate that a new field can be used in the corresponding search view, make sure to select Always Searchable. Click the Update button to confirm your changes. Click Preview to see your result. The Birthday field will now appear in your Address form view, ready to be used.




根据客户执行动作

At the right side of the Customers list or form view, you will find a list of all of the reports, actions and links available for the selected partner(s). You can perform actions and print reports both from List and from Form view, List view allowing you to do actions for several partners at the same time.


Tip

Actions

To display the list of possible actions, just select one or more customers or click the arrow at the top of the right side bar.



You can create a new opportunity for a customer, or start a mass mailing. Mass mailings will usually be started from list view, because you will select several partners at a time.


Note

Campaigns

For mass mailings, you might prefer to use the Direct Marketing application, which offers great functionalities (please refer to chapter 开展营销活动).



Another action enables you to quickly send an SMS message.


Tip

发送手机短消息

你可以在 Clickatell™ http://clickatell.com 网站上注册后, 就可以在OpenERP 中使用发送手机短消息的功能了.

要给合作伙伴发送短消息, 需要先在合作伙们的列表页选择窿们,然后点击 短消息发送(SMS Send) 向导按钮
即可.






用过滤器查找合作伙伴

Open the Customers list view to discover the search options allowing you to easily filter your partners. You can group by Salesman to see which customers have already been assigned a salesman or not. Click the button at the right (the icon of the person) to see the customers you are responsible for.


Tip

Limit

If you want to display more than the 20 partners displayed by default, click the 1 to 20 of - XX option at the bottom of the screen to be able to change the limit.



Filters also allow you to quickly set lists of customers for which you want to do specific actions. Through the New Filter option, you can also add your own filters for any field related to the Customer form.


Note

Filters

You can easily create your own frequently used filters by prefiltering the data the way you want and then using the Save Filter option.






为合作伙伴分组

OpenERP uses categories to organize all of its partners according to their relationship with your company (customer, prospect, supplier, and so on). Each partner may be attached to several categories. To open the list of available partner categories, use the menu Sales ‣ Configuration ‣ Address Book ‣ Partner Categories.


[image: ../../../_images/crm_partner_category_big.png]
合作伙伴分类列表



点击合作伙伴分类结构中的一个分类时,会列出属于该分类下面的所有合作伙伴.如果你点的分类还有下级子分类时,属于下级子分类的
合作伙伴也会同样被列出来.


Note

Categories

To create a new category, go to the menu Sales ‣ Configuration ‣ Address Book ‣ Partner Categories and click the New button.



Because categories can be organized according to a tree structure, you can apply an action at any level of
the structure: a marketing promotion activity, for example, can be applied either to all customers,
or selectively only to customers in one category and its subcategories.

You can create your own categories and assign them to your partner from the Customer form. Another way of assigning the corresponding partner to a category is to open the category from the Partner Categories.

In the 客户分析挖掘 chapter, you will see how to assign partners to categories automatically using segmentation rules.




一个管理联系人的替代方案

According to your kind of business, the standard way of linking several contacts to one partner may not be flexible enough for you. You could perfectly well have the same employees working for several of your companies. Or maybe you work with representatives ensuring follow up of several of your customers. So you would want to have the same contact linked to different partners.

Of course, OpenERP provides an alternative, the base_contact module, which gives you even more flexibility in managing your contacts.

Easily share the same contact (an employee, for instance), who may perfectly have different jobs, with several partners. You only need to enter (or create) the contact once and link it to the partners concerned, while specifying the position the contact holds for each company in particular. Any changes to contact information only need to be made once for them to be applied to all partners the contact is related to!

We illustrate the concept of multiple relationships between contacts and partners (companies) through an example. The figure Advanced Contact Management shows two companies having several addresses (places of business) and several contacts attached to these addresses.

In this example you will find the following elements:


	The ABC bank has two places of business, represented by the addresses of ABC Belgium and ABC
Luxembourg,

	The addresses of Dexey France and Dexey Belgium belong to the Dexey company,

	At the office of ABC Luxembourg, you have the contacts of the director (D. Smith) and the
accountant (A. Doe),

	Mr Doe holds the post of accountant for ABC Luxembourg and Dexey France,

	Mr D. Smith is director of Dexey France and Dexey Belgium and we also have his private address
which is not attached to a partner.



An extra menu option will be added, allowing you to display the list of contacts, through Sales ‣ Address Book ‣ Contacts.

The screenshot below illustrates how contacts are handled with the advanced Contacts configuration.


[image: ../../../_images/crm_contact_with_latest.png]
Advanced Contact Management



This is a clear way to illustrate the complexities that may be accomplished in OpenERP.

If you correct or change a contact name in the contact form, the changes will be applied to all the posts occupied in the different companies.

The screen below represents a partner form. You can add several addresses, such as Invoice & Delivery, and a list of
contacts per address. Each contact has its own data, such as name, function, phone number and email.


[image: ../../../_images/crm_base_contacts.png]
Partner Form with the Advanced Contacts Management



Go to Sales ‣ Address Book ‣ Contacts to open a contact form.
You enter data in the contact form, containing information such as mobile phone, different functions occupied, and personal blog. You can also add a photo of your contact.
If you click the Functions and Addresses line, you will get more details about the job (such as start date, end date and fax).


[image: ../../../_images/crm_partner_poste.png]
Detail of a Position occupied by a Contact at a Partner
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管理线索

To define leads, imagine a bucket full of potential sales contacts expressing an interest in your company’s products.

A lead represents a potential customer with whom you have not established a relationship yet. Usually a lead contains valuable information to realise future sales opportunities. However, the most common mistake is that such key information too often gets lost, because it is registered nowhere. And even when registered, it might still be difficult to track any activity for that lead, because the information is not at hand when you need it.

Storing leads information in a central place such as OpenERP will release you of these worries.

So when would you create a lead in OpenERP, either manually or automatically? The following events could be a trigger:


	An inquiry email sent to one of your company’s generic email addresses, such as sales@mycompany.com, from the mailgateway,

	A business card from a prospective customer met briefly at an exhibition: you have to contact him
again to qualify the lead and to know if there is any possibility of a sales opportunity; registered manually,

	A database of potential customers in a given sector and region imported through a CSV file. The potential customers have to be
contacted again individually or through a mass mailing to determine which contacts require further follow-up,

	An interesting contact that you met during a business networking event. You have to qualify it before assigning a salesperson to the contact,

	A form completed on your website directly integrated into OpenERP using our webservice. Before converting the form
into a sales proposition or opportunity, you should read and handle the person’s request.



Employees in the marketing or presales department will usually work on leads. Once these leads will be converted into customers and/or sales opportunities, the sales department pays individual attention to each opportunity. Of course, before converting a lead into an opportunity, some qualification work has to be done.

OpenERP allows you to easily configure the way your company qualifies leads. You can create your own stages through Sales ‣ Configuration ‣ Leads & Opportunities ‣ Stages. Use the sequence number to determine the order of the stages, i.e. 10 for First Call, 20 for Renewing Contact and so on. Of course, you can also drag & drop a stage to another place to automatically change the order of all the stages. A salesman can change the status of the lead according to the response from the prospect and enter the result of this contact in the lead form (e.g. in the Notes field).

From the Sales ‣ Sales ‣ Leads menu, you can qualify each individual lead through the Stage field that is found up to the right of the lead definition. To move your lead automatically to the next step from the list of leads, you can use the button that looks like a green, right arrow.

Leads can be assigned to a Sales Team for easy follow-up (see  调整 OpenERP 适应你的销售组织). Each user can be added to a default sales team which can be specified in the User Preferences. When you define a tree structure for your sales teams, you can also escalate a lead to another sales team for further actions.


Note

线索与商机

Companies may decide to not use leads, but instead to keep all information directly in an opportunity. For some companies, leads are
merely an extra step in the sales process. You could call this extended (start from lead) versus simplified (start from
opportunity) customer relationship management.
OpenERP perfectly allows for either one of these approaches to be chosen. If your company handles its sales from
opportunities directly, feel free to move on to chapter 通过的商机优化你的销售周期, although most of the features explained below
also apply to opportunities.



In the next sections we will explain in more detail some examples of what Leads in OpenERP can be used for.


Tip

未找到 线索 菜单?

In  Simplified view, Leads will not be displayed. To see not also opportunities, but also leads, you should switch
to the Extended view. You can easily switch from Simplified to Extended view by changing your User Preferences through
the Edit Preferences button.




有效管理业务名片

Potential customers are usually entered as a lead in the system. This means that you do not create a
partner or a sales opportunity until you have qualified whether the lead is interesting or not.


Tip

Qualification

When a qualified lead requires further actions, you can turn the lead into a partner and, eventually, a sales opportunity.



To make a new lead, go to the Sales ‣ Sales ‣ Leads menu and click the New button. In the Lead form that opens, you can enter the contact data of this new potential customer and add notes.


[image: ../../../_images/crm_lead_new.png]
Creating a New Lead



You can also set the status of a lead according to the qualification work that has been carried out:


	Draft : the lead data have been entered, no work has been done yet and a salesperson has not
yet been assigned to the request,

	Open: the lead is being handled,

	Closed: the lead has been converted into a partner and/or a sales opportunity,

	Pending: the lead is waiting for a response from the potential customer,

	Escalate: the lead is escalated to the upper sales team in the tree structure for further actions,

	Cancelled: the lead has been cancelled because the salesperson has decided that it is not worth
following up.



A lead status can easily be changed, even from list view (the standard view when you start the Leads program). Simply click the green arrows to change the status of a lead.

On the Extra tab in the Leads form, you find statistics about days to open and close and more information about the campaign, the channel, and so on.


[image: ../../../_images/crm_lead_extra.jpeg]
Extra Tab



On the Communication & History tab in the Leads form, you can see a complete history of all actions regarding this lead. You can also add internal notes and change the status of a lead  while adding such a note.
Send an email directly from the lead simply by clicking the Send New Email button (to configure your email settings, please refer to chapter ch-crm-fetchmail-install.
You can add attachments to internal notes and emails you send to the prospect. You can customize your message and have the status changed after an email has been sent; you could automatically have the lead set to Pending, because you require a response from the customer before further actions can be taken.


[image: ../../../_images/crm_lead_comm.jpeg]
Communication & History Tab






导入线索数据库

You can also import a huge list of leads. That may be useful if you have bought a database of
potential prospects that you want to load into OpenERP to handle them all at the same time.

Start with a list of leads in CSV format, for instance. If your prospects database is provided in
another format, you can easily convert it to the CSV format using Microsoft Excel or OpenOffice Calc.


Tip

Import

The best thing to do to make sure your import will go smoothly, first export all the required Lead fields using the Export function,
and then edit the resulting csv file for import.



Open the Leads form using the menu Sales ‣ Sales ‣ Leads. In Other Options, click the Import link. (You can also import from List view, just open the action window on the right (by clicking the arrow) and in Other Options, click the Import link.)

Select your file containing the leads information and click Import File. OpenERP will automatically map the column headers from your CSV file to the corresponding fields in OpenERP. If necessary, you can click CSV Options to change the settings so that they match your local settings.


[image: ../../../_images/crm_lead_import1.jpeg]
Importing Leads into the System



Check the online chapter about system administration for more information on import and export on http://doc.openerp.com/v6.0/book/.


Tip

Various Imports

Importing and Exporting data in OpenERP is a generic function available to all resources.
So you can import and export such lists as partners, opportunities, accounting entries,
products and price lists.



Clearly there are other methods of generating leads automatically or semi-automatically:


	Through a Contact Form on your Website;

	Using the Outlook or Thunderbird plugin to insert new leads directly from the salesman’s mailbox when he sees promising emails,

	Using the email gateway for each incoming email from a certain address (such as
sales@mycompany.com) which may create a lead automatically from the contents of the email.



These different methods are described later in this book (see chapter 自动获取线索).




组织线索

To help the users organize and handle leads efficiently, OpenERP provides several features in the CRM to be used according to the needs of each:

Use the Sales ‣ Sales ‣ Leads view to organize your leads:


	Display a list of all the leads (qualified, open, not open, ...) according to the sales team you are linked to,

	Create a new lead by clicking New,

	Display Unassigned Leads, click the button next to the Salesman field,

	Display a list of all your leads you still need to handle (your open and draft leads),

	Display a list of all your leads that are waiting for a customer response (usually in Pending status). This enables you to check periodically on your work to do,

	Display a list of all the leads assigned to different salespeople,

	Use Extended Filters to display all the leads created today or during the last week, in a specific time period, and so on,

	Quickly find leads not yet assigned to a Campaign, by clicking the Group by button and then Campaign.



The sales manager can use this Leads view to easily keep track of what each salesperson is working on.


[image: ../../../_images/crm_leads_list.png]
List of Leads to be Handled



Leads can also be prioritized. Salespeople can assign a priority to their lead, and then start working on their leads from the top of the list, which is sorted by priority.




分析线索

OpenERP also offers statistical reports to keep track of your Lead Management. The Sales ‣ Reporting ‣ Leads Analysis report allows you to check various leads-related elements. You can look at processing delays, number of responses given and emails sent (if you use the email gateway feature). Sort your leads analysis by different groups to get accurate, grained analysis.

These are some analysis possibilities of the Leads Analysis report.


	Leads by State and per Month



To analyse the leads by status, group the leads by qualification level (Stage) and status (State), this can also be done for individual months (first group by Month).


	Leads by Origin



Analyse leads according to their state (open, lost, won) and their stage (e.g. cold / hot or new / qualification / ... ) and find out how many leads belong to each state / stage.


	How effective are your Campaigns?



Group by Campaign to easily find the number of leads by campaign and the total number of leads. You can also select a specific campaign in your filter.


	Leads by Priority.



Group by Priority to see which leads are hot, warm or cold.


[image: ../../../_images/crm_lead_analys.jpeg]
Leads Analysis
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通过的商机优化你的销售周期

While a lead represents the first contact with a prospect yet to be qualified, a sales opportunity represents a potential contract. Each opportunity has to be followed up by a salesperson (or sales team) spending time to qualify the opportunity, and this either by making a quotation or cancelling the opportunity.

Leads are generally handled by the dozen, with the automation of certain responses or emails.
Opportunities, on the contrary, are usually tracked one by one by the salespeople, because an opportunity involves a negotiation process with the customer to be.

Just like for leads, OpenERP provides specific features to handle sales opportunities efficiently. All opportunities can be found in the menu Sales ‣ Sales ‣ Opportunities.

With opportunities, you can manage and keep track of your sales pipeline by creating specific customer- or prospect-related sales documents to follow up potential sales. Information such as expected revenue, opportunity stage, expected closing date, communication history, next action date, next action, and much more can be stored.

Opportunities can be connected to the email gateway: new emails may create opportunities, each of them automatically gets the history of the conversation with the customer. You and your sales team(s) will be able to plan meetings and phone calls from opportunities, convert them into quotations, manage related documents, track all customer-related activities, and much more.


Tip

Attachments

By default, you can keep attachments in OpenERP to make sure all linked documents are directly accessible. At the right side
of the screen, under Attachments, click the Add button to start linking documents to your opportunity. With the Browse
button, you can search for the file to be attached in your directories. You can add attachments in the same way for leads,
for instance.
If you also want those documents to be indexed (not for pictures), you should install the Knowledge Application.




转换线索为客户或者商机

If the salesperson thinks that the lead has been well qualified and that there is a real opportunity, following the contact he had with the prospect, he can easily convert the lead into a partner / opportunity using the button Convert to Opportunity.

Clicking the Convert to Opportunity button offers several possibilities, allowing you also to avoid duplicate partners:


	You can decide to just create the opportunity and keep the contact data from the lead without creating a partner,

	You can convert to an opportunity, and create a new partner if it does not exist yet, or merge the contact with an existing partner,

	You first create a partner, and later you convert the lead to an opportunity.



To create only a partner, click the button Create next to the Customer field. You can also decide to add the contact data of the lead as a new contact to an existing partner.

OpenERP shows a window allowing you to select:


	whether you want to create a new partner,

	whether you want to link this contact to an existing partner (merge).



OpenERP opens a partner form containing the information from the lead. At this stage you can complete the contact details or add any other information for the partner.

The partner created is automatically attached to the lead, which enables you to keep complete traceability from the lead. To find this information, you should take a look at the Communication & History tab in the lead.

Instead, you can also combine the step of creating a partner and directly the lead converting into an opportunity through the Convert to Opportunity feature.


Tip

Convert to Opportunity

When you click the Convert to Opportunity button and the email address of the new contact is filled out, OpenERP will check whether
this email address corresponds to an email address of an existing partner. If so, OpenERP will directly propose to merge the new
contact with the partner found.



When you click the Convert to Opportunity button and the partner already exists, OpenERP opens a window allowing you to select:


	whether you want to create a new opportunity,

	whether you want to add this lead to an existing opportunity (merge).



OpenERP shows the title of the opportunity (taken from the lead description) and the partner.
Make sure to enter the estimated revenue and the success rate (probability) of converting to a sales.


[image: ../../../_images/crm_lead_convert.png]
Converting a Lead into a Sales Opportunity




[image: ../../../_images/crm_opport_data.jpeg]
From Lead to Opportunity: Details






调整 OpenERP 适应你的销售组织

Your sales organization may be composed of several groups which for instance address different customer segments or geographies, sell different products and services and often manage different sales cycles.  As a manager you will want to track the performance not only for each individual but also for each group.

OpenERP allows you to do that by defining Sales Teams. A sales team is a group of sales people who are performing a similar position. Implementing sales teams is a powerful tool. It allows you to:


	Assign leads or opportunities according to their nature to a sales team first. Then according to the company’s policy, the opportunities can be assigned to a given individual. For example opportunities can be assigned to a Western Region sales team or Eastern Region sales team in the first place according to their location. Each sales person may pick unassigned opportunities in his sales team according to his availability,

	You can group your sales teams according to a tree structure (hierarchy). This allows you to have a view of your sales activity at different granular levels (local, regional, national for instance),

	Some sales teams may manage their opportunities through different sales cycles. For instance a car dealership which addresses both the residential and corporate customers, will have different sales cycles.

	For each sales team, you can assign a responsible user and an email address that will be used when creating or replying to emails from OpenERP. This will be proposed by default in OpenERP when you create an event for this customer.




Note

Sales Teams

To define your Sales Teams, go to Sales ‣ Configuration ‣ Sales ‣ Sales Teams.



Let us take the example of a bank to explain how you can define your sales teams. A bank has several departments, such as Insurance, Accounts, Assets, Credit Management. Each department may be divided into several subdepartments. For Insurance, this could be Group Insurance and Home Insurance. The hierarchical structure of your Sales Teams could then be as follows:


	
	Insurance Sales Team

	
	Group Insurance

	Home Insurance









	Accounts Sales Team



	Assets Sales Team



	Credit Management Sales Team








定义销售周期的关键步骤

Each company will have similar, yet customized stages to qualify opportunities.

To see & define stages for Opportunity qualification, go to Sales ‣ Configuration ‣ Opportunities ‣ Stages.

The key steps of your Sales Cycle are what OpenERP calls Stages. You can use the stages to improve your sales capacity, because they allow you to find out the reasons why deals succeed or fail.

Stages will allow salesmen to easily track where a specific opportunity is positioned in the sales cycle. One of the frequent difficulties in using stages is that different sales people may assess differently in which stage their sales opportunity should be. You can avoid this by clearly stating what you expect as a result for each stage. This way, your sales teams will use the same stages throughout the qualification process, allowing the sales manager to get accurate and consistent information. We also recommend to limit the number of stages in your sales cycle to make them easy to follow up.

As you progress in your sales cycle, and move from one stage to another, you can expect to have more precise information about a given opportunity. For example, when setting an opportunity as ‘Qualified’, you may decide that the salesman has to enter the “Expected Revenue” and the “Expected Closing Date.” You can also have the probability changed automatically when changing stages, by selecting the “Change Probability Automatically” checkbox. If checked, OpenERP will set the probability of the opportunity to the probability defined in the stage. If you set a probability of 0% (Lost) or 100% (Won), OpenERP will assign the corresponding stage when the opportunity is marked as Lost or Won.

As an example, to track your opportunities, you can assign the following stages to the sales team. For each stage, you assume you will define criteria that have to be met prior to moving to the next stage.


	Territory - Segment your opportunities into territories.

	Qualified – Attract the prospect’s interest, determine whether the prospect has a need.





	What is the expected result?

	
	The need to buy the product/service has been confirmed,

	Confirm that there is a budget.











	Qualified Sponsors – Ask the right questions and listen carefully to identify and thoroughly understand the prospect’s needs.





	What is the expected result?

	
	Current pain points identified,

	Identify what the prospect wants to achieve,

	Identify the decision-maker.











	Proposition – Discuss some solutions to determine the customer’s preferences, recommend specific solutions to answer the customer’s needs.





	What is the expected result?

	
	Demo and/or Proposal given,

	Decision maker confirmed his interest to purchase,

	Preliminary pricing confirmed/agreed upon.











	Negotiation – Submit the final proposal to the customer and begin the negotiation process.





	What is the expected result?

	
	Negotiation concluded,

	Contract terms/conditions agreed upon,

	Contract submitted for signature.











	Won/Lost – Register the final step of the opportunity.





	What is the expected result?

	
	Contract signed / not signed,

	Next steps.










You can apply your own stages throughout the qualification process by means of the Stage field that is found up to the right of the opportunity definition. To move an opportunity automatically to the next step, you can use the button that looks like a green, right arrow.


[image: ../../../_images/crm_opport_stages.jpeg]
Example of Opportunity Stages



OpenERP also has other sales configuration options; you can define your Campaigns, allowing you to keep track of the event your leads and opportunities refer to. Examples of campaigns are Google Adwords, an event you are hosting, a newsletter.
With Categories you identify your prospect’s needs (e.g. Needs Training, Needs OpenERP Online), while Channels help you to keep visibility on how the lead or opportunity entered the system (email, website, referred by an existing customer).




计划你下个动作

When a lead has been converted into an opportunity, the latter can be assigned to any salesperson. You might designate an opportunity manager in the company who is responsible for assigning the new opportunities to different salespeople according to the job they do, their location or availability.

Of course, OpenERP allows you to automate such steps in your sales cycle. With Automated Rules you can tell the system for instance to automatically assign opportunities to a sales person or to change the status of an opportunity according to specific criteria.


Note

Automated Actions

To access the CRM rules, use the Sales ‣ Configuration ‣ Automated Actions ‣ Automated Actions menu.



Let’s give an example of what you can use Automated Actions for. Suppose you want to have OpenERP assign opportunities for customers in the IT Sector category directly to Thomas, your IT salesman. Thomas should be assigned automatically when a lead is converted to an opportunity by clicking the Convert to Opportunity button in the Leads screen. This can be set through the Object field in the Automated Actions form; just select Convert/Merge Opportunity.

The screenshots below illustrate how you can tell OpenERP to do this automatically for you.

Step 1


[image: ../../../_images/crm_autom_act1.jpeg]
Conditions Tab of Automated Actions



Step 2


[image: ../../../_images/crm_autom_act2.jpeg]
Actions Tab of Automated Actions



When you answer to an opportunity from the Communication & History tab, you can directly have the status of the opportunity changed. You can also add a Global CC, even with multiple email addresses separated by ‘;’. This ensures that when any email regarding this opportunity is sent, all the persons defined in Global CC will be notified.

Planning your next actions also refers to filling fields or performing actions manually, without interference of automated rules. It is important that you fill all the opportunity fields accurately. To ensure good follow-up and prioritise your opportunities, make sure to register the Next Action Date and the Next Action in the Opportunity. In the Opportunities screen, you can group your search results by these fields, so that you know exactly how to plan your work.

You can use the filters to group by Priority and then click the Next Action Date column to sort by next action date to easily follow up your opportunities and know exactly what you have to do.




有效计划你的会议和电话呼叫

Planning your meetings & calls does not only allow you to structure your work, but also to improve your sales skills by learning from your call & meeting history. For both Meetings & Calls, you can enter a complete report of what you discuss!

As explained in chapter crm-flow, you can schedule a meeting directly from an opportunity. When you create a meeting from an opportunity, related fields will be prefilled from the opportunity.
For the ease of reading, Thomas will schedule a new meeting from an opportunity here and set Luc, the Sales Manager, as the person responsible for the meeting. He wants to send Luc a reminder 1 day before the meeting starts.


Note

Schedule a Meeting from an Opportunity

To plan the meeting, Thomas clicks the Schedule Meeting button in the Opportunity and clicks the Week button in the Calendar view. He uses the drag and drop function to schedule the meeting for Luc. He plans the meeting next Wednesday from 2 pm to 3 pm. He sets Luc as the person responsible and sets a reminder to be send 1 day before the start of the meeting. He also changes the Next Action Date in the opportunity to the meeting date.



You can also schedule a meeting directly from a Customer form. Go to the customer for whom you want to schedule a meeting and open the form view. In the list of actions at the right side of the screen, click Schedule a Meeting. If you stay in the Month view of the Calendar, you just have to click the day you want the meeting to be planned, let’s say Thursday in two weeks. A meeting form will be displayed, with the name of the customer and the date prefilled.

Another way to enter a meeting request, is to directly use the meeting calendar from the menu Sales ‣ Meetings ‣ Meetings. You can use the monthly, weekly or daily views to plan a meeting by selecting the corresponding buttons. You can also click a day in the Navigator window to schedule a meeting.

In the Meeting window, enter the meeting data such as meeting summary, type, duration. In the weekly and daily views, you can also press the left mouse button in the calendar and slide the mouse along to create an event of several hours. OpenERP then opens an entry screen for a new meeting.
You can add reminders (or Alarms) to your meetings and send invitations, either to persons from your own company, partner contacts or external people (just specify the email address directly in the invitation). You can send invitations before or after confirmation of a meeting. Either from the meeting itself or from the separate Event Invitations view in the menu Sales ‣ Configuration ‣ Calendar ‣ Event Invitations, you can track and change the attendee status. If you cannot attend a meeting, you can delegate it to one of your colleagues.


Tip

Alarms or Meeting Reminders

Add your own alarms through Sales ‣ Configuration ‣ Calendar ‣ Alarms. You might want to be warned one week in advance of the meeting, so all you have to do is create your own alarm. The screenshot below will show you how to do this.




[image: ../../../_images/alarm.jpeg]
Defining your Own Alarms




[image: ../../../_images/crm_meeting_form.png]
Entering a New Meeting



You may notice different colours and styles in the calendar. That is because OpenERP distinguishes between recurring events, multiple days events and events that only happen once.
Multi-day events have a coloured background, whereas single events have a coloured font. Each event
has a colour that represents the user who created the meeting. You can filter the different users by
selecting them from the list at the right of the screen.


[image: ../../../_images/crm_calendar_month.png]
Monthly Meeting Calendar




[image: ../../../_images/crm_calendar_week.png]
Weekly Meeting Calendar



You can change the Calendar view for meetings and return to the list, form or gantt view by using the buttons at the top right. OpenERP’s usual search tools and filters enable you to filter the events displayed in the calendar or, for example, to display the calendar for only some employees at a time.


Tip

Related Partner

When you hover your mouse cursor over a meeting in Calendar view, the related partner and the sales team will be displayed.



Of course, you can access this OpenERP calendar from your smartphone. For more information about this feature, please refer to chapter 用移动设备同步你的CRM.

OpenERP also allows you to manage incoming (inbound) and outgoing (outbound) calls. Even from the Phone Calls list view, you can directly edit a call (change the status, convert it to an opportunity or schedule a meeting). For every call, you can enter notes about the outcome. While on the phone with your prospect or customer, you can directly schedule a meeting, schedule another call or convert your call to an opportunity. There is no need for you to scroll to several menus to do what you have to: plan an action as a result of your call.

Call management may be used for other needs than planning, such as:


	Entering customer calls so that you keep a record of the communication attached to a partner or a
sales opportunity,

	Calling out to large lists of prospects,

	Scheduling recurring calls or next actions.




Note

Schedule a Phone Call directly

Go to Sales ‣ Phone Calls ‣ Inbound to register incoming calls or Outbound to register outgoing calls.



The phone call will then be visible in the History tab of the Partner form to give you complete visibility of the
events for a customer or supplier.

Of course, OpenERP also allows you to schedule a phone call directly from an Opportunity form through the related Schedule/Log Call button.


Note

Phone Calls in Meeting Calendar

To have one calendar with both your meetings and your phone calls, you may choose to enter phone calls as a meeting, with a specific meeting type, Phone Call.






定期截止

To keep track of the coming sales pipeline, you should enter the expected closing date for each opportunity. By doing this, from the Opportunities screen you can easily filter your pipeline by Expected Closing (button in Group by). This is a clear way to forecast the expected revenues. You can also use this filter to check whether the expected closing date has been set.

Simply by adding an expected closing date, the sales team can manage the sales process more efficiently and effectively.


[image: ../../../_images/crm_opport_closing.jpeg]
Closing Dates
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用email联系以及从移动设备访问


OpenERP provides all the information you need to pursue your company’s business opportunities
effectively. But to stay productive with all the information you have to handle, it is essential
that you can keep using your normal communication tools by interfacing them with OpenERP,
and that you are not limited just to OpenERP’s interface.


Often your sales persons are already used to working with standard email clients to manage their business. OpenERP allows you to perfectly integrate their knowledge with the use of OpenERP.

OpenERP offers this flexibility to those who need to continue using their traditional email programs to maintain their
efficiency: OpenERP can be connected to Outlook and Thunderbird. Your users can participate in many OpenERP-maintained processes without ever leaving their familiar environment, and can avoid double data entry, yet easily link information to OpenERP’s database automatically.

With the Outlook and Thunderbird plug-ins, you can create and/or open contacts directly from your email client in OpenERP without effort.
You can also link emails (with attachments) to OpenERP, to avoid information getting lost.
Both plug-ins enable you for instance to create leads based on exchanges you have with the customer.

The email gateway functionality enables you to use OpenERP’s CRM without necessarily using the OpenERP interface. Up-to-date leads can automatically be stored in OpenERP just by sending and receiving emails through a specific email address. You can even answer such mails from your own mailbox.

And of course, you can link the OpenERP meeting calendar to your mobile device.


通讯工具

The Fetchmail / Mailgateway functionality lets you interface the CRM with incoming and outgoing emails. So you can receive mails in OpenERP and answer them directly from OpenERP.
You can install it when you configure the CRM, through the Reconfigure wizard, Fetch Emails, or by installing the fetchmail module from the list of modules.
Thanks to this feature, each email you receive on the specified email address may automatically create a lead, a contact or an other object in OpenERP, while keeping track of email attachments. This is an easy way to ensure that no crucial sales information gets lost.

You set the generic email address you want to use, such as sales@mycompany.com, and then you tell OpenERP that every incoming email for this address should automatically be created as a lead.


Tip

Objects

You can use this feature for any object in OpenERP, so for instance also to keep track of your helpdesk or job applications.



To use the email gateway, you should install the Fetchmail module. You might need a system administrator to carry out this work.

If you followed the steps in the previous chapters, you should have the Fetchmail module installed. If not, you can install the Fetchmail module from the Configuration Wizard (CRM Configuration Wizard, Synchronization, Fetch Emails), or from the modules list.


Note

Scheduled Action

Click the Fetch email button to get the emails directly. OpenERP also automatically creates a Scheduled Action to fetch the mails every 5 minutes.



Step 1

You can configure your incoming mail account(s) from the Sales ‣ Configuration ‣ Emails ‣ Email Servers.


[image: ../../../_images/email_server_config.jpeg]
How to Configure your Email Server for Incoming Mails?



Go to Tools ‣ Configuration ‣ Email Template ‣ Email Accounts to define the email smtp settings.

In the Description field, type the visible name you would like to use for the account.

In Server, type the mail server, i.e. smtp.googlemail.com.

Type the SMTP port (e.g. 587), configure the other settings according to the specifications of your server.

Add the User Information, such as email address for which the mails will enter OpenERP, i.e. support@mycompany.com, the user name and the password. Configure the other settings to your needs.

Save and click the Test Outgoing Connection button to check whether the settings are correct.

When everything is correctly configured, Approve the account. OpenERP will automatically create a Scheduler for the mails. You can also send/receive mails manually by clicking the Send/Receive button.

Step 2

You can configure your outgoing mail account(s) from the Tools ‣ Configuration ‣ Email Template ‣ Email Accounts.


[image: ../../../_images/outgoing_server_config.jpeg]
How to Configure your Email Server for Outgoing Mails?



Go to Sales > Configuration > Emails > Email Servers to define the email server settings.

Assign a Name and select the Server Type, i.e. IMAP Server.

Click Add Attachments if you want to include attachments for the mails received / sent.

Enter the Server Information, check SSL if necessary, i.e. imap.googlemail.com and the Login Information.

You can also choose to send an automatic reply on receipt of the mail. You can configure the mail here from the Email Server Action field.

Assign the Model to use when a new email arrives, i.e. choose Lead (crm.leads) if you want every new email that arrives to be created as a lead.

Click Confirm to confirm the account settings.


Note

Server Configuration

You will also need your administrator to configure your server settings to allow for an email gateway. This will not be explained
in this book.






Microsoft Outlook 关联你的CRM

The Microsoft Outlook plug-in enables you to carry out a series of OpenERP operations quickly and directly
from the Outlook email client:


	create a contact or partner from an email,

	open a partner from an email,

	save an email and its attachments in OpenERP from your mailbox,

	send any attachment to an OpenERP document (such as opportunities, customers).



Thanks to the plug-in, you can effortlessly link emails and attachments to the corresponding opportunity in OpenERP, or link an attached product folder to a customer, for instance.


Tip

Outlook Versions

The Microsoft Outlook plug-in works with Microsoft Outlook 2003 and 2007, but not with Outlook Express.



In this chapter, only the actual possibilities of the plug-in will be discussed. For more information about how to install and configure the Outlook plug-in, please refer to the chapter outlook

From the Outlook toolbar, have a look at the Tools menu.

The Push option allows you to archive emails to OpenERP, either to new document types or to existing ones (such as Leads). It also allows you to create a new contact.

The Partner option allows you to open the Partner in OpenERP according to the email (i.e. contact email address) selected.

With Document, you can open the document (i.e. a customer, an opportunity) concerned in OpenERP. Make sure your web server is running to use this functionality.


[image: ../../../_images/outlook_config2.png]
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	Link an email to an existing document in OpenERP



To archive an email in OpenERP from Outlook, select the email and click the Push button. Alternatively you can open the menu Tools ‣ Push: the Push to OpenERP screen will open.

In the Link to an Existing Document section, check Partner. Then select the customer you want to attach the selected mail to.
The plug-in also allows you to select several customers at once, simply by selecting a customer and pressing the ctrl button while selecting the next one.

Suppose you decide to no longer link the selected email to a customer, but instead to an opportunity. Then you have to click the Search button to refresh the Documents list to display your opportunities.

From the list of available documents, you can select any document type you defined in the Document Settings section.


	Create a New Document



This feature can be used to create any of the configured document types in the Document Settings tab.
Suppose you would like to create a new lead from an email. In the Create a New Document section, select CRM Lead, then click the Create button. A new lead will be created in OpenERP from the selected email.


	Create a New Contact / Partner



If the partner or contact from your email does not exist in OpenERP yet, the Outlook plug-in allows you to
create one on the fly simply by using the information contained in the email.

Select the email from which you want to create a new contact, then click the Push button.
In the Create a New Contact section, click the New Contact button. This option offers two possibilities:
either you just create a contact (address), or you create a partner with the contact linked to it.



	When you just want to create a new contact, complete the address data in the dialog box and click the Save button.
The contact will then be created in OpenERP.

	When you also want to create a new partner, complete the contact data.
Then click the Create Partner button, add the partner’s name and click the Save button.

	You can also add a new contact to an existing partner. Click the Search button next to the Partner field
and select the corresponding partner from the list. Then complete the contact data and click the Save button.
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Creating a Contact on the Fly from Outlook




	Open the Document created in OpenERP



From your mailbox, simply by clicking an email, you can directly access the corresponding data in OpenERP. Go to the menu Tools ‣ Document which will open the corresponding document (e.g. a lead) in OpenERP, directly from the email you selected.


Tip

Knowledge Management

The Outlook plug-in is compatible with OpenERP’s Knowledge (i.e. Document) Management. If you install the
Knowledge application you will be able to:


	search through the content of your company’s documents (those that have the type .doc, .pdf, .sxw
and .odt) and also in archived emails,

	have a shared file system that is connected to various OpenERP documents to share information and
access it with your favorite browser,

	organize and structure your documents (such as projects, partners and users) in OpenERP’s
system.






	Step 1: Install the Outlook plugin in OpenERP



Use the OpenERP Configuration Wizard and install the Customer Relationship Management application. In the CRM Application Configuration dialog under Plug-In, select MS-Outlook.
Then the Outlook Plug-In wizard appears. Next to the Outlook Plug-in field, click the Save As button to save the plugin to your desktop (or any other location on your computer).

You can also download the installation manual by clicking the green arrow next to Installation Manual.

Another way to use the Outlook plugin, is by installing the OpenERP module outlook. When you install this module, the same Configuration Wizard as explained before will be displayed. Follow the same instructions.


	Step 2: Prerequisites (for more details, please refer to the online documentation)
	Install Python 2.6+

	Python for Windows extensions - PyWin32, this module for python must be installed for the appropriate version of Python.

	Specify the python folder in the system path (typically with this installer C:Python26)








How to set the path in Windows XP
For Windows XP: http://www.computerhope.com/issues/ch000549.htm

How to set the path in Windows 7
To change the system environment variables, follow the steps below.







	From the Windows button, select Control Panel, then click System.

	Click Remote Settings to open the System Properties window.

	In the System Properties window, click the Advanced tab.

	In the Advanced section, click the Environment Variables button.

	Finally, in the Environment Variables window (as shown below) under System Variables, highlight the Path directory,
click Edit and add ;C:Python26.






4. If you are using MS Outlook 2007 then you are required to install “Microsoft Exchange Server MAPI Client and Collaboration
Data Objects 1.2.1 (CDO 1.21)”
Double-click Exchange CDO to install it.


	If you are using MS Outlook 2003, be sure to install the built-in CDO component.







	Step 3: Install the OpenERP extension in Outlook.



	Double-click the file ``OpenERP-Outlook-addin.exe``that you saved on your desktop. Confirm the default settings.

	Double-click the file ``Register plugin``in the OpenERP Outlook Addin folder (typically in C:Program Files).

	Start Outlook.










When you have executed Installation Step 1, Step 2 and Step 3, the first thing to do is connect Outlook to OpenERP.
A little configuration needs to be done.


Tip

Toolbars

If you want the OpenERP connection to be shown as a separate toolbar, go to the menu View ‣ Toolbars. Select OpenERP.




	Go to the menu Tools and select Configuration. If this raises an error, make sure to check the access rights to that particular folder.



A configuration window appears enabling you to enter configuration data about your OpenERP server.
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	On the Configuration Settings tab, under Connection Parameters click the Change button
and type your server settings and XML-RPC port, e.g. http://127.0.0.1:8069,

	Select the database you want to connect to, and type the user and the password required to log in to the database,

	Click the Connect button,

	On the Configuration Settings tab, under Webserver Parameters click the Change button
and type your web server settings, e.g. http://localhost:8080,

	Click the Open button to test the connection.










When your connection has succeeded, you would typically want to configure Outlook to fit your needs.

To define extra document types, go to the Document Settings tab. This is the place where you can add objects from OpenERP that you wish to link mails to. The default installation comes with a number of predefined documents, such as Partners, Leads and Sales Orders.

Here is an example of how to configure extra document types. Suppose you would like to link mails to a meeting:



	In the Title, type Meeting,

	In the Document, type the object from OpenERP, in this example crm.meeting,

	In the Image, select an icon you would like to use,

	Click the Add button to actually create the document type.







Note

A Word about Objects

To find the object you need in OpenERP, go to the menu Administration ‣ Customization ‣ Database Structure ‣
Objects. OpenERP will only show objects for which the corresponding Business Applications / Modules have been installed.
You can only add objects to Outlook that are available in the selected database.






从Mozilla Thunderbird管理你的CRM

With the Mozilla Thunderbird plug-in you can carry out a series of OpenERP operations directly from Thunderbird, such as:


	create a contact or partner from an email,

	open a partner from an email,

	save an email and its attachments in OpenERP,

	send any attachment to an OpenERP document (such as opportunities, customers).



Thanks to the plug-in, you can effortlessly link emails and attachments to the corresponding opportunity in OpenERP, or link an attached product folder to a customer, for instance.

In this chapter, only the actual possibilities of the plug-in will be discussed. For more information about how to install and configure the Thunderbird plug-in, please refer to the chapter thunderbird.

From the Thunderbird toolbar, have a look at the OpenERP menu.

The Push option allows you to archive emails to OpenERP, either to new document types or to existing ones. It also allows you to create a new contact.

The Partner allows you to open the Partner in OpenERP according to the email (i.e. contact email address) selected.

With Document, you can open the document (i.e. a customer, an opportunity) concerned in OpenERP. Make sure your web server is running to use this functionality. You have to open the mail to use this feature.


	Link an email to an existing document in OpenERP
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To archive an email in OpenERP from Thunderbird, select the email and click the Push button. Alternatively you can open the menu OpenERP ‣ Push: the Push to OpenERP screen will open.

In the Link to an Existing Document section, check Partner. Then select the customer you want to attach the selected mail to.
The plug-in also allows you to select several customers at once, simply by selecting a customer and pressing the ctrl button while selecting the next one.

Suppose you decide to no longer link the selected email to a customer, but instead to an opportunity. Then you have to click the Search button to refresh the Documents list to display your opportunities.

From the list of available documents, you can select any document type you defined in the Document Settings section.


	Create a New Document



This feature can be used to create any of the configured document types in the Document Settings tab.
Suppose you would like to create a new lead from an email. In the Create a New Document section, select CRM Lead, then click the Create button. A new lead will be created in OpenERP from the selected email.


	Create a New Contact / Partner



If the partner or contact from your email does not exist in OpenERP yet, the Thunderbird plug-in allows you to
create one on the fly simply by using the information contained in the email.

Select the email from which you want to create a new contact, then click the Push button.
In the Create a New Contact section, click the New Contact button. This option offers two possibilities:
either you just create a contact (address), or you create a partner with the contact linked to it.



	When you just want to create a new contact, complete the address data in the dialog box and click the Save button.
The contact will then be created in OpenERP.

	When you also want to create a new partner, complete the contact data.
Then click the Create Partner button, add the partner’s name and click the Save button.

	You can also add a new contact to an existing partner. Click the Search button next to the Partner field
and select the corresponding partner from the list. Then complete the contact data and click the Save button.
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	Open the Document created in OpenERP



From your mailbox, simply by clicking an email, you can directly access the corresponding data in OpenERP. Go to the menu Tools ‣ Document which will open the corresponding document (e.g. a lead) in OpenERP, directly from the email you selected.


Tip

Knowledge Management

The Thunderbird plug-in is compatible with OpenERP’s Knowledge (i.e. Document) Management. If you install the
Knowledge application you will be able to:


	search through the content of your company’s documents (those that have the type .doc, .pdf, .sxw
and .odt) and also in archived emails,

	have a shared file system that is connected to various OpenERP documents to share information and
access it with your favorite browser,






	Step 1: Install the Thunderbird plugin in OpenERP



Use the OpenERP Configuration Wizard and install the Customer Relationship Management application. In the CRM Application Configuration dialog under Plug-In, select Thunderbird.
Then the Thunderbird Plug-In wizard appears. Next to the Thunderbird Plug-in field, click the Save As button to save the plugin to your desktop (or any other location on your computer).

You can also download the installation manual by clicking the orange arrow next to Installation Manual.

Another way to use the Thunderbird plugin, is by installing the OpenERP module thunderbird. When you install this module, the same Configuration Wizard as explained before will be displayed. Follow the same instructions.


	Step 2: Install the OpenERP extension in Thunderbird.



To do that, use the file ``openerp_plugin.xpi``that you saved on your desktop.

Then proceed as follows:



	From Thunderbird, open the menu Tools ‣ Add-ons.

	Click Extensions, then click the Install button.

	Go to your desktop and select the file openerp_plugin.xpi. Click Open.

	Click Install Now then restart Thunderbird.






Once the extension has been installed, a new OpenERP menu item is added to your Thunderbird menubar.


Tip

Thunderbird Version

The OpenERP plugin for Thunderbird works as from Thunderbird version 2.0.

So check your Thunderbird version before installing, and download the latest version that you need
from the following address: http://www.mozilla.org/products/thunderbird/



When you have executed Installation Step 1 and Step 2, the first thing to do is connect Thunderbird to OpenERP.
A little configuration needs to be done.


Note

Before starting the configuration, make sure your GTK server and web server are running (XML-RPC should be allowed).



Go to the OpenERP menubar and select ` Configuration`.

A configuration window appears enabling you to enter configuration data about your OpenERP server.
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	On the Configuration Settings tab, under Connection Parameters click the Change button
and type your server settings and XML-RPC port, e.g. http://127.0.0.1:8069,

	Select the database you want to connect to, and type the user and the password required to log in to the database,

	Click the Connect button,

	On the Configuration Settings tab, under Webserver Parameters click the Change button
and type your web server settings, e.g. http://localhost:8080,

	Click the Open button to test the connection.










When your connection has succeeded, you would typically want to configure Thunderbird to fit your needs.

To define extra document types, go to the Document Settings tab. This is the place where you can add objects from OpenERP that you wish to link mails to. The default installation comes with a number of predefined documents, such as Partners, Leads and Sales Orders.

Here is an example of how to configure extra document types. Suppose you would like to link mails to a purchase order.



	In the Title, type Purchase Order,

	In the Document, type the object from OpenERP, in this example purchase.order,

	In the Image, select an icon you would like to use,

	Click the Add button to actually create the document type.







Note

A Word about Objects

To find the object you need in OpenERP, go to the menu Administration ‣ Customization ‣ Database Structure ‣
Objects. OpenERP will only show objects for which the corresponding Business Applications / Modules have been installed.
You can only add objects to Thunderbird that are available in the selected database.
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How to Add Extra OpenERP Document Types to Thunderbird?
* organize and structure your documents (such as projects, partners and users) in OpenERP’s system.






用移动设备同步你的CRM

Synchronize your OpenERP calendars with your mobile device and know which meeting to go to from wherever you are!

Make your OpenERP even more efficient and let your sales synchronize their meetings with their mobile devices.
Anywhere your sales people are, they can easily check their planning and confirm new meetings with customers on the spot.

You can synchronize your calendars with iPhone and Android phones, and also with tools such as Evolution and Sunbird/Lightning.


Note

Installation and Configuration

Please note that setting this up requires some technical knowledge, and probably the assistance of IT staff.




OpenERP 服务器和 SSL 设置

Some modules need to be installed on the OpenERP server (or may already be installed). These are:



	
	caldav: Required, has the reference setup and the necessary

	underlying code. Will also cause document & document_webdav
to be installed.







	crm_caldav: Optional, will export the CRM Meetings as a calendar.



	project_caldav: Optional, will export project tasks as a calendar.



	
	http_well_known: Optional, experimental. Will ease bootstrapping,

	but only when a DNS srv record is also used.












When you install the above module(s), a ready-to-go reference setup of the folders is provided.
The OpenERP administrator can add more calendars and (re)structure if needed.

It is highly advisable that you also set up SSL to work for the OpenERP server. HTTPS is a server-wide feature in OpenERP, which means a
certificate will be set at the openerp-server.conf which will be the same for XML-RPC, HTTP, WebDAV and CalDAV.
The iPhone also supports secure connections with SSL, although it does not expect a self-signed certificate (or one that is not verified by
one of the “big” certificate authorities).




在iPhone上的日历

To set up the calendars, proceed as follows:


	Click Settings and go to the Mail, Contacts, Calendars page.

	Go to Add account...

	Click Other.

	From the Calendars group, select Add CalDAV Account.

	Enter the host name.
(e.g. if the URL is http://openerp.com:8069/webdav/db_1/calendars/ , openerp.com is the host)




Tip

Synchronize this Calendar

Go to Sales ‣ Meetings ‣ Synchronize this Calendar and select Iphone. Then the Caldav server will be shown.




	In Username and Password, type your OpenERP login and password.

	As a description, you can either leave the server’s name or
something like “OpenERP calendars”.

	If you are not using a SSL server, you will get an error, do not worry and push “Continue”

	Then click “Advanced Settings” to specify the correct ports and paths.

	Specify the port for the OpenERP server: 8071 for SSL, 8069 without SSL.

	Set the Account URL to the right path of the OpenERP webdav:
the URL given by the wizard (e.g. http://my.server.ip:8069/webdav/dbname/calendars/ )

	Click Done. The phone will connect to the OpenERP server
and verify whether the account can be used.

	Go to the main menu of the iPhone and open the Calendar application.
Your OpenERP calendars will be visible inside the selection of the
“Calendars” button.
Note that when creating a new calendar entry, you will have to specify
which calendar it should be saved to.



If you need SSL (and your certificate is not a verified one),
you will first need to let the iPhone trust the certificate. Follow these steps:


	Open Safari and enter the HTTPS location of the OpenERP server:
https://my.server.ip:8071/
(assuming you have the server at “my.server.ip” and the HTTPS port is the default 8071)

	Safari will try to connect and issue a warning about the certificate used. Inspect the certificate
and click “Accept” so that iPhone now trusts it.






在 Android 上的日历


先决条件

There is no built-in way to synchronize calendars with CalDAV.
So you need to install a third party software: Calendar (CalDav) Sync BETA
from Hypermatix Software (for now, it is the only one).




如何配置?


	Open the Calendar Sync application.
You get an interface with 2 tabs.

	On the Connection tab, in CalDAV Calendar URL, type a URL such as http://my.server.ip:8069/webdav/dbname/calendars/users/demo/c/Meetings.




Tip

Synchronize this Calendar

Go to Sales ‣ Meetings ‣ Synchronize this Calendar and select Android. Then the Caldav server link will be shown. Make sure to use the correct XML-RPC port, it may differ from 8069.




	Type your OpenERP username and password.

	If your server does not use SSL, you will get a warning. Answer Yes.

	Then you can synchronize manually or customize the settings (Sync tab) to synchronize every X minutes.








在Evolution上的日历


	Go to Calendar View.



	File ‣ New ‣ Calendar.



	Enter the data in the form:



	Type : CalDav

	Name : Whatever you want (e.g. Meeting)

	URL : http://HOST:PORT/webdav/DB_NAME/calendars/users/USER/c/Meetings (e.g.
http://localhost:8069/webdav/db_1/calendars/users/demo/c/Meetings)
the one given on top of this window

	Uncheck “User SSL”

	Username : Your username (e.g. Demo)

	Refresh : every time you want Evolution to synchronize the data with the server











Tip

Synchronize this Calendar

Go to Sales ‣ Meetings ‣ Synchronize this Calendar and select Evolution. Then the Caldav server will be shown.




	Click OK and enter your OpenERP password.

	A new calendar with the name you entered should appear on the left side.






在Sunbird/Lightning上的日历


先决条件

If you are using Thunderbird, first install the Lightning module
http://www.mozilla.org/projects/calendar/lightning/




配置


	Go to Calendar View.

	File ‣ New Calendar.

	Choose On the Network.

	As a format, select CalDav
and as a location type the URL (e.g. http://host.com:8069/webdav/db/calendars/users/demo/c/Meetings).




Tip

Synchronize this Calendar

Go to Sales ‣ Meetings ‣ Synchronize this Calendar and select Sunbird/Lightning. Then the Caldav server will be shown.




	Choose a name and a colour for the Calendar, and we advice you to uncheck “alarm”.




	Enter your OpenERP login and password (to give the password only once, check the box Use Password Manager to remember this password).

	Then click Finish; your meetings should now appear in your Calendar view.
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管理你的间接的销售

OpenERP 将帮助你管理你的渠道业务伙伴. 可以将商机进行区域化，只需要在 管理 ‣ 模块 ‣ 模块 在Modules的 Name 字段中输入: crm_partner_assign . 进行检索再点击最后一行的按钮 (在 State 字段后) 进行模块的安装. 注意 State 会转变为’将要安装的模块’. 点击执行左侧的动作`执行已安排的升级`. 模块将被安装，并且增加以下 销售 ‣ 设置 ‣ 线索 & 商机 ‣ 业务伙伴级别 与 销售 –> 报告 –> 商机指定分析.


Note

CRM 配置向导

当你点击`执行已安排的升级`, 配置向导将会显示. 如果不需要安装其他CRM模块，可以点击取消配置向导.




转发商机给渠道业务伙伴

可以使用地域化功能，把商机指派和转交给渠道业务伙伴.

通过 销售 ‣ 设置 ‣ 线索 & 商机 ‣ 业务伙伴级别, 可以创建业务伙伴级别对业务伙伴进行分类, 例如金牌业务伙伴, 银牌业务伙伴, 准业务伙伴. 这些级别将会被用来确定谁可以得到哪些商机.

在客户视图中的 Geo Localization 定位 分页中指定业务伙伴的级别. 同时可指定 重要性 用于指定商机分配给业务伙伴的概率(0表示不分配). 这个`重要性`,举例来说,可以是业务伙伴所能支付的业务合同的最大金额.

如何使用OpenERP来地域化一个商机?

可以将一个线索转化为商机, 或者直接将商机分配给具体的渠道业务伙伴.
Go to the Assignation tab of the Opportunities form, and click the Geo Assign button. The location of the partner in the opportunity will be matched with the geolatitude and the weight of the channel partners. The most appropriate channel partner will be assigned.


Note

GPS

You can also use the geolocalisation without GPS coordinates.



Now you can decide whether this is the correct channel partner for this opportunity. If you feel that another channel partner would be better to follow up this opportunity because he , you can change the assigned channel partner.

To automatically inform the channel partner of the new opportunity, proceed as follows.

Click the Forward button to automatically send an email to the assigned partner with all the details of the opportunity and the prospect.
When forwarding an opportunity to a partner, you can select which information you want to send: Latest email, Whole Story or Case Information. You can add a cc and add attachments to the mail.
You can send the mail to the partner (any contact person you want), to an OpenERP user or to an email address you specify.

To allow your salespeople to keep a view on forwarded opportunities, the assigned opportunity will be displayed for the selected channel partner on the Geo Localization tab of the Customer form.

Use the Opportunity Assignment Analysis for your reporting.


Tip

Google Maps

Use the geolocalization together with the google_map module. This adds a Map button to your Partner form. Click this button to open a browser with the partner’s location displayed in Google Maps.






Partner的地理定位

To determine the geographic location of your partners, you do not have to enter the GPS coordinates yourself. OpenERP can do this for you. All you have to do is click the Geo Localize button in the Customer form. The GPS coordinates will now be filled according to the address of the partner.

In the partner form, the Geo Localization tab gives you the information you need.
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Geolocalizing a Partner
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跟踪你的通讯


跟踪客户日志

Information related to leads & opportunities, meetings, phone calls,  marketing campaigns and emails will be tracked in OpenERP.
The activities are automatically reported in the partner form of the associated customer. To have a complete overview of the activities for a customer, all you have to do is open the Customer form and click the History tab. As you will notice in the screenshot below, this is not merely a report. From this tab, you can also plan new activities for the customer or change existing activities!
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History of Activities in a Customer Form






跟踪销售订单

After intensive opportunity qualification, your customer asks you to make a quotation. You can easily do this from the corresponding opportunity! Just click the Convert to Quote button and OpenERP will create a sales quotation ready for you to be edited. A sales quotation is an unconfirmed sales order. On the quotation, the Source document it was created from (in this case the opportunity) is displayed, to allow you to keep track of which opportunity is linked to which sales quotation / order.

To review the quotation later, you can access it from the Sales ‣ Sales ‣ Sales Orders menu. On the Extra Info tab of the sales quotation, you can find the reference to the related sales quotation / order that has been created from the opportunity concerned.

For more information about sales orders, please refer to the chapter part4-crm-sales.




存储附加单据

For any object in OpenERP, for instance a lead, opportunity, customer, you can attach external documents. Suppose you send a product folder to one of your customers, and to make sure you know exactly which version of the document he received, you can keep it as an attachment in OpenERP.

To attach whatever type of document to the customer, you just have to go to the Sales ‣ Address Book ‣ Customers menu.

Open the Customer form of the selected partner, and click the Add button in the Action bar, just below Attachments. Then click the Browse... button and navigate to the location where the product folder is stored, just like you would do in your file explorer. Click the product folder, and then confirm.

The product folder is now stored in OpenERP as an attachment for the customer. You can open it by clicking the document in Attachments.

OpenERP allows you to add as many attachments as needed. Combined with the Knowledge application, OpenERP will index documents of the type .doc, .pdf, .sxw and .odt, so that you can effortlessly search through their content.


Note

File Storage

If you do not install the Document Management system (Knowledge application) then the attachments in OpenERP are stored
directly in the database.
Once the document management system has been installed,
the contents of the files are no longer stored in the database, but on the OpenERP
server file system.

You can then read and add attachments to OpenERP quite independently of the OpenERP
interface or the FTP server using simple drag and drop.



For more information about the Knowledge and Document Management System, please refer to the online documentation.
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分析销售绩效


组织销售漏斗的复核

Through the Opportunities Analysis, Sales ‣ Reporting, you can keep track of your sales funnel. The analysis report gives you instant access to your opportunities displaying information such as expected revenue, planned cost, missed deadlines or the number of interactions per opportunity. This report is perfect for the Sales Manager to periodically review the sales pipeline with the salesteams concerned.


[image: ../../../_images/opport_analysis.jpeg]
Sales Funnel Review



The powerful Advanced Search View allows you to customize your analysis reports by using Extended Filters and Group by features.

With Extended filters, you can select specific options to filter your opportunities. For example, when you select a partner here, only opportunities related to that specific partner will be displayed.

You can also filter the information of an opportunity according to the Group by features.
Suppose you want to analyse your opportunities by campaign and by salesman. When you open the Opportunities Analysis screen, you will notice that the opportunities are by default grouped by salesman (see Salesman button in the Group by area).

Since you want to group by Campaign first, click the Salesman button to unselect it. Just click the Campaign button, then click Salesman to get the report you want.


[image: ../../../_images/filter_opport_analysis.png]
Opportunities Analysis



Some examples of how you could use the Opportunities Analysis report to analyse your opportunities in various ways.


	
	Customers with Open Opportunities:








Group by Partner, click the Active button to provide a list with the customer names and the number of draft / open opportunities.



	
	Closed Opportunities:








Click the Closed button, then group by State, then by Stage to display a list of closed opportunities divided by stage (lost and won).



	
	Opportunity Sources:








The number of opportunities can be displayed by closing date and sales stage, including expected revenue. Select only the Closed opportunities, group by Date button, then by Stage to obtain this view.



	
	Opportunity Pipeline:








To get an idea of what your salesman’s pipeline is like (or sales team), including the expected sales volume, click the Active button and group by Salesman (or Sales Team).



	
	Opportunities by Category:








Click the Graph button in the Opportunities screen to display the report as a Graph.



Tip

Graph

You can also display the Opportunities Analysis screen as a graph.






销售预测和销售仪表板

OpenERP dashboards are dynamic and allow you to edit or drill-down. Dashboards may be composed of several view types, such as List, Form, Graph view.

When you click the Sales button in the web version (to open the business application, so in the top bar), automatically the Sales Dashboard will appear. You can also access this dashboard from the Sales ‣ Reporting ‣ Dashboard. This dashboard gives you more information about your own sales activities, such as your Open Opportunities and your Quotations. This dashboard is prefiltered according to the OpenERP user who opens it.
Each user can also choose a dashboard that will be opened when he starts OpenERP.


[image: ../../../_images/sales_board.jpeg]
Sales Dashboard



The Sales Manager Dashboard is a powerful tool to have an overview of quotations, sales by month, sales per customer, per salesman or per product in the last 90 days.


[image: ../../../_images/sales_mgr_board.jpeg]
Sales Manager Dashboard



The Statistics Dashboard shows the Opportunities by Category and by Stage, as well as the planned revenue per stage and user. Clicking one of the stages in the graph will allow you to drill down to the details of such an opportunity. So no need to go through several screens to find what you need.


[image: ../../../_images/sales_stat_board.jpeg]
Statistics Dashboard
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开展营销活动


利用营销活动实现线索自动化

OpenERP 提供了一些模块让你轻松创建和跟踪营销活动。
使用 Marketing 模块, 可以定义直销活动,实现与线索的自动化交互。可以通过使用重新配置向导,选择 Marketing 来安装此模块。

营销活动可以以列表或图表试图的方式展现。图表试图使得你可以一目了然的看到营销动作（通过节点表现）和适用条件（通过箭头表现）。


[image: ../../../_images/market_diagram.jpeg]
一个营销活动的图表视图



市场营销活动是通过个性化的消息帮助管理和接触你的目标客户的一次事件或一个活动。一个营销活动在具体的营销环境下可以有很多行为被触发，例如一次实时的响应通过你发送邮件的接触。这种响应（或触发行为）的结果可以是一次邮件的发送，发送的内容在这之前已经在OPENERP里预先编辑好。

为了能够使用邮件功能，你必须配置你的邮件帐户。这一点在 ch-crm-fetchmail-install 章节有讲解。


一个完整的市场营销活动例子

假设我们是一家保险公司，我们正准备启动一项市场营销活动以便获取新的销售线索。公司在其网站上发起一个活动并提供给潜在客户获得汽车保险的免费报价机会。

每次一个潜在客户通过练习表单进行注册，一个销售线索就会在OpenERP里自动产生。关于网页联系表单的更多信息，请参考 自动获取线索 章节。

销售人员负责汽车保险触发活动，通过发送一封关于我们所有保险业务的介绍性邮件的方式，并感谢他们订阅免费汽车保险报价。

基于营销响应，保险公司划分标注销售线索的兴趣点：


	购买汽车保险，

	其他保险政策信息，

	购买保护儿童安全的书籍。



通过我们接收到的来自销售线索的回复，我们汽车保险公司的销售人员发送不同的电邮来满足他们各自的不同需求。


	如果他们对这样的邮件作出回应，那么销售线索就可以转化为销售机会。当这个销售线索买了一份汽车保险，这个销售线索就转化为我们的合作伙伴，并且作为一个客户在OpenERp系统中被自动创建。

	假如我们没有收到邮件回复，那么一周后他们会继续收到关于免费汽车保险报价的问候提醒。如果他们仍旧没有做出回应，我们的销售人员会主动打电话询问他的具体需求。



把上面这个过程看成一个完整的工作流程，使得我们能够对每一个营销机会做出各种合适的响应行为。无人接待客户的可能性将大大降低，对于每一个销售线索，我们都有预设的应对方案来维护他。

此外，通过对达成目标的比照我们可以衡量每种方法的效果。基于目标我们可以评估营销活动的效果，并且分析营销活动是否有改进的空间。


Tip

营销活动实例

为了在OpenERP系统中获取一个完整的营销活动实例，你可以安装 marketing_campaign_crm_demo 模块。






定义营销活动

Designing a marketing campaign is mostly a long term process and the success of any campaign depends on the research and the effectiveness in selecting your target audience for the campaign. There are certain questions that every marketeer always asks while designing a campaign.


	What would be our marketing campaign?

	Who would be the target audience?

	How would we measure the effectiveness of our campaign?



The OpenERP campaign is based on the principle of lead automation. A lead is created according to a specific response by a customer towards a stimulus. An example: filling the car insurance calculator on your website may create a lead in OpenERP.

The first step is to define the campaign, i.e. the sequence of steps to be performed. By defining the campaign, we trigger a set of activities in the Marketing Campaign application of OpenERP.

From the lead automation, we define the sequence of steps we ought to follow, the modes of creating and processing these activities and the cost involved in this campaign. After each activity and based on its respective stimuli, we can trigger the next event of the campaign concerned.




划分营销活动

The two most important points for any successful campaign are the adoption of a concrete methodology of execution and choosing the right segment: a target loop of customers to whom our campaign would be directed (i.e. your target audience). Inappropriate focus on the wrong segment would result in the campaign being misfired and our efforts would reach deaf ears.

Through the Segment tab in the Campaign module, we can define our segment for each Campaign activity. Indeed, it is perfectly well possible that with every step downwards, the segment gets narrowed in terms of number. You can also synchronize the entire campaign steps according to the defined segments.

Our insurance company wants to attack the Spanish market, and will define a segment called Spanish Leads. Of course you would want your segment to be valid for leads coming from Spain only. To achieve this, go to the Leads list view. Filter all the leads for Spain (type Spain in the Country field), make sure to clear the salesteam, so that all leads coming from Spain will be selected. Then click Save Filter and call it for instance Spanish Leads. Now return to the Campaigns menu and open the Segment, then click the Filter field to select Spanish Leads. The segment will now only apply to Spanish leads.

As you can see, the Marketing Campaign module is closely synchronized with the Customer Relationship Management Business Application. Let us consider the segment we cater in the campaign as Leads in OpenERP. Goals are set for each campaign, which would be considered as a desired state. Once a lead meets our objective criteria of goals, we change the lead status by converting it into an Opportunity, meaning that we should give focused attention.

Once the lead satisfies our final objective, we would consider it as a partner/customer and close that lead.




电子邮件模板

OpenERP allows you to create your own email templates. You can use the Expression Builder to have the variables created for you. Suppose you would like to add the Contact Name in the email, but of course, this will be a different name for each email.

In the Expression Builder, in Field, select Contact Name. Automatically, the Expression will be filled. Copy the value from the expression and paste it in your email, e.g. Dear ${object.contact_name}. So your email will start with Dear followed by the name of the contact. This way you automatically create personalized emails.

For each email template, you can have OpenERP generate a Wizard Action / Button that will be related to the object. So if you choose to do marketing campaigns for leads, the action will be added to the right side panel of the Lead form.


Tip

Configuring Marketing Campaigns

Please notice that it requires some technical knowledge to configure Marketing Campaigns.
To be able to see, create, edit campaign, users need to be in the Marketing / User group.






设置营销活动


[image: ../../../_images/crm_market_campaign.png]
Marketing Campaign




	简介



A campaign defines a workflow of activities that items/objects entering the campaign will go through. Items are selected by segments. Segments are automatically processed every few hours and inject new items into the campaign, according to a given set of criteria.
It is possible to watch the campaign as it is running, by following the campaign “workitems”. A workitem represents a given object/item passing through a given campaign activity. See it as a step that still can go either way. Workitems are left behind when the item proceeds to the next activities. This allows an easy analysis and reporting on the running campaign.
Each activity may execute an action upon activation depending on a dynamic condition. When the condition is not met, the workitem is cancelled/deleted; if the condition is met, the action is executed, the workitem is marked as Done, and propagated to the next activities.


	营销活动 (Marketing ‣ Campaigns ‣ Campaigns)




	营销活动

	Each campaign is made of activities and transitions, and must be defined on any specific object the system knows about
(e.g. Leads, Opportunities, Employees, Partners).




	模式

	A campaign can be in one of 4 modes:





	Test Directly: processes the whole campaign in one go, ignoring any delay put on transitions, and does not actually execute the actions, so the result is simply the set of corresponding campaign workitems (see below). Any time a segment adds new items in the campaign they will be processed in the same manner.

	Test in Real time: processes the campaign but does not actually execute the actions, so the result is simply the set of corresponding campaign workitems. Any time a segment adds new items in the campaign they will be processed in the same manner.

	Manual confirmation: No action will be executed automatically, a human intervention is needed to let workitems proceed into the flow. It is like a step-by-step manual process using the Campaign Followup menu. You can ignore the time delays and force any step of the campaign, implementing the campaign at your pace i.e. (you have a test email and want to see if the steps and templates do exactly what you want them to do). You will see that the actions set are defined as To Do and Done and the page has to be refreshed to see the next activities defined by the campaign node: the campaign sends real messages to the actual targets, be warned.

	Normal: the campaign is processed normally, all actions are executed automatically at the scheduled date. Pay attention that in this status, the campaign sends real messages to the actual target audience.






Regardless of the current mode of the campaign, any workitem can be manually executed or cancelled at any time (even if it is scheduled in the future) through Campaign Followup.


	Resource

	Specifies where the campaign will get the information from, i.e. the OpenERP object linked (e.g. Leads, Opportunities,
Employees, Partners).




	Activities

	Activities are steps in the campaign. Each activity is optionally linked to previous and next activities through transitions.



Each activity has:



	one optional condition that stops the campaign,

	one action to be executed when the activity is activated and the condition is True (could be a ‘do nothing’ action),

	one optional signal (ignore it),

	a start flag.






Start Activity

Activities that have the Start checkbox set, will receive a new workitem corresponding to each new resource/object entering the campaign. It is possible to have more than one Start Activity, but not less than one.

Activity Conditions

[a Boolean expression, made of clauses combined using boolean operators: AND, OR, NOT]
Each condition is the criterion that decides whether the activity is going to be activated for a given workitem, or just cancelled.
It is an arbitrary expression composed of simple tests on attributes of the object, possibly combined using or, and & not operators.

See section 6.1 for more information on Comparators.

The individual tests can use the “object” name to refer to the object/resource it originates from (e.g the lead), using a “dot notation” to refer to its attributes. Some examples on a CRM Lead resource:



	object.name == ‘Insurance Offer Lead’ would select only leads whose title is exactly “Insurance Offer Lead”,

	object.state == ‘pending’ would select Pending leads only,

	object.country_id.code == ‘be’ would select leads whose country field is set to Belgium,

	object.country_id.name == ‘Belgium’ would select leads whose country field is set to Belgium.






Tests can also use a ‘workitem’ name to refer to the actual item denoting the position of the object in the campaign. This can be useful to access some specific attributes, such as the segment that selected this item. Some examples:



	workitem.segment_id.name == ‘Insurance Offer EU Zone1 - Industry Consulting/Technology’  would select leads that entered this campaign through the “Insurance Offer Lead EU Zone1 - Industry Consulting/Technology” segment,

	‘EU Zone1’ in workitem.segment_id.name would select only leads that entered the campaign through a segment that has “EU Zone1” in its name.







Tip

Help

In the GTK client you can use “Help > Enable Debug mode tooltips” to see the attribute name of every field in a form. These are the same that you can use during import/export with CSV files.



You can also use the special formula re.search(PATTERN_TO_SEARCH, ATTRIBUTE_TO_SEARCH) where PATTERN_TO_SEARCH is a character string delimited with quotes, and ATTRIBUTE_TO_SEARCH uses the dot notation above to refer to a field of the object.
An example for CRM leads:



	re.search(‘Plan to buy: True’, object.description) would be true if the Notes on a Lead contain this text: “Plan to buy: True”. Be careful that all spaces etc. do matter, so you may use the special pattern characters as detailed at the bottom to account for small variations,

	re.search(‘Plan to.*True’, object.description) would be true if the Notes on a Lead contain this text: “Plan to” followed later on by “True”.






You can combine individual tests using boolean operators and parentheses.
Some examples on a CRM Lead resource:



	object.state != ‘pending’ and ( re.search(‘Plan to by:.*True’,object.description)  and not re.search(‘Plan to use:.*True’,object.description)   )  would be true if the lead is NOT in Pending state and it contains “Plan to buy”, but not “Plan to use”.







创建营销活动的指导方针



	It is a good idea to have an initial activity that will change some fields on the objects entering the campaign to mark them as such, to avoid mixing them in other processes (e.g. set a specific state and Sales Team on a CRM lead being processed by a campaign). You can also define a time delay so that the campaign seems more human (note if the answer comes in a matter of seconds or minutes it is computer generated).

	Put a stop condition on each subsequent activity in the campaign to get items out of the campaign as soon as the goal is achieved (e.g. every activity has a partial condition on the state of the item, if CRM Leads stops being Pending, the campaign ends for that case).







	Email Templates (Marketing ‣ Configuration ‣ Email Template ‣ Templates)



Email templates are composed of the following information:



	The Email headers: to, from, cc, bcc, subject

	The raw HTML body, with the low-level markup and formatting

	The plaintext body






Headers and bodies can contain placeholders for dynamic contents that will be replaced in the final email with the actual content.


	Campaign Segments



Segments are processed automatically according to a predefined schedule set in the menu Administration ‣ Configuration ‣ Scheduled Actions. It could be set to process every 4 hours or every minute for example.
This is the only entry point in a campaign at the moment.

Segment filters

Segments select resources via filters, exactly the same kind of filter that can be used in advanced search views on any list in OpenERP. You can actually create them easily from any OpenERP screen allowing you to save filters. Save your advanced search criteria as a new filters and add them to the segment in the Filter field.
Filters mainly consist in a domain expressing the criteria of selection on a model (the resource).
See section 10.3 for more information on the syntax for these filters.


	For Leads, the following filter would select draft Leads from any European country with “Plan for use: True” or “Plan for buy: False” specified in the body:

	
	[  (‘type’,’=’,’lead’),

	(‘state’, ‘=’, ‘draft’),
(‘country_id.name’, ‘in’, [‘Belgium’,
‘Netherlands’,
‘Luxembourg’,
‘United Kingdom’,
‘France’,
‘Germany’,
‘Finland’,
‘Denmark’,
‘Norway’,
‘Austria’,
‘Switzerland’,
‘Italy’,
‘Spain’,
‘Portugal’,
‘Ireland’,
]),
‘|’,
(‘description’, ‘ilike’, ‘Plan for use: True’),
(‘description’, ‘ilike’, ‘Plan for buy: False’)
]








	Miscellaneous References, Examples



6.1 Reference of Comparison Operators:



	==: Equal

	!=: Not Equal

	<: Bigger than

	>: Smaller Than

	<=: Bigger than or equal to

	>=: Smaller than or equal to

	in: to check that a given text is included somewhere in another text. e.g “a” in “dabc” is True






6.2 Reference of Pattern/Wildcard characters



	. (dot) represents any character (but just one)

	* means that the previous pattern can be repeated 0 or more times

	+ means that the previous pattern can be repeated 1 or more times

	? means that the previous pattern is optional (0 or 1 times)

	.* would represent any character, repeated 0 or more times

	.+ would represent at least 1 character (but any)

	5? would represent an optional 5 character






6.3 Reference of filter domains

Generic format is:  [ (criterion_1), (criterion_2) ] to filter for resources matching both criterions.
It is possible to combine criterions differently with the following operators:



	‘&’ is the boolean AND operator and will make a new criterion by combining the next 2 criterions (always 2). This is also the implicit operator when no operator is specified.
	for example:  [ (criterion_1), ‘&’, (criterion_2), (criterion_3) ] means criterion_1 AND (criterion_2 AND criterion_3)





	‘|’ is the boolean OR operator and will make a new criterion by combining the next 2 criterions (always 2)
	for example:  [ (criterion_1), ‘|’, (criterion_2), (criterion_3) ] means criterion_1 AND (criterion_2 OR criterion_3)





	‘!’ is the boolean NOT operator and will make a new criterion by reversing the value of the next criterion (always only 1)
	for example:  [ (criterion_1), ‘!’, (criterion_2), (criterion_3) ] means criterion_1 AND (NOT criterion_2) AND criterion_3










Criterion format is:  ( ‘field_path_operand’, ‘operator’, value )

Where:



	field_path_operand specifies the name of an attribute or a path starting with an attribute to reach the value we want to compare

	operator is one of the possible operator:
	‘=’ , ‘!=’ : equal and different

	‘<’, ‘>’, ‘>=’, ‘<=’ :  greater or lower than or equal

	‘in’, ‘not in’ : present or absent in a list of value. Values must be specified as [ value1, value2 ], e.g. [ ‘Belgium’, ‘Croatia’ ]

	‘ilike’ : search for string value in the operand





	value is the text or number or list value to compare with field_path_operand using comparator











进一步推动营销活动的成果

Of course, Marketing Campaigns can only be effective when you also do something with the results. OpenERP offers analysis features to help you better manage future campaigns based on the outcome of past campaigns. Learning from your results, that is.

The Marketing ‣ Reporting ‣ Campaign Analysis report allows you to analyse your campaigns in detail, both ongoing and completed campaigns.

Segments allow you to keep good track of the results of a marketing campaign. You can see from which segment you have most demands, for instance.

Thanks to good insights in the way your respondents answer to your campaign, you can continuously improve your marketing results!


[image: ../../../_images/camp_analysis.png]
Campaign Analysis








自动获取线索

Through your website, your company wants to get as much information as possible about the people who visit the website. But how can you make sure that every person who wants to know more about your company is actually registered somewhere?

Well, you could use a Contact form for this. And precisely such a form allows you to register contacts automatically in OpenERP.
By creating a link from your website’s Contact form to OpenERP, your contact data will automatically be created in the CRM (or any other application of your choice, such as HR).

Let us show you an example of how this can be achieved. The figure below shows a Contact form on a website.


[image: ../../../_images/crm_contact_form.png]
来自网站的咨询



All data entered in this form are linked to the Lead form in the CRM. Each time someone enters this contact form, a new lead is automatically created in OpenERP.

Such a system is a very easy yet flexible way of keeping track of your leads and automatically launch your marketing campaigns.


如何将网站联系页面转化为OpenERP线索?

OpenERP is accessible through XML-RPC interfaces, for which libraries exist in many languages.

Python 代码示例

import xmlrpclib
# ... define HOST, PORT, DB, USER, PASS
url = 'http://%s:%d/xmlrpc/common' % (HOST,PORT)
sock = xmlrpclib.ServerProxy(url)
uid = sock.login(DB,USER,PASS)
print "Logged in as %s (uid:%d)" % (USER,uid)
# Create a new lead
url = 'http://%s:%d/xmlrpc/object' % (HOST,PORT)
sock = xmlrpclib.ServerProxy(url)
args = {
'name' : 'A New Lead',
'description' : 'This is a new lead from the web contact form',
'inventor_id': uid,
}
lead_id = sock.execute(DB,uid,PASS,'crm.lead','create',args)





PHP 代码示例

<?
include('xmlrpc.inc'); // Use phpxmlrpc library, available on sourceforge
// ... define $HOST, $PORT, $DB, $USER, $PASS
$client = new xmlrpc_client("http://$HOST:$PORT/xmlrpc/common");
$msg = new xmlrpcmsg("login");
$msg->addParam(new xmlrpcval($DB, "string"));
$msg->addParam(new xmlrpcval($USER, "string"));
$msg->addParam(new xmlrpcval($PASS, "string"));
resp = $client->send($msg);
uid = $resp->value()->scalarval()
echo "Logged in as $USER (uid:$uid)"

// Create a new lead
$arrayVal = array(
'name'=>new xmlrpcval("A New Lead", "string") ,
'description'=>new xmlrpcval("This is a new lead from the web contact form" , "string"),
'inventor_id'=>new xmlrpcval($uid, "int"),
);

$msg = new xmlrpcmsg('execute');
$msg->addParam(new xmlrpcval($DB, "string"));
$msg->addParam(new xmlrpcval($uid, "int"));
$msg->addParam(new xmlrpcval($PASS, "string"));
$msg->addParam(new xmlrpcval("crm.lead", "string"));
$msg->addParam(new xmlrpcval("create", "string"));
$msg->addParam(new xmlrpcval($arrayVal, "struct"));
$resp = $client->send($msg);
?>






Tip

How to Link a Web Contact Form to OpenERP?

For technical information about how to link a web contact form to OpenERP, please also refer to the Technical Memento that you can download from http://www.openerp.com/community, the chapter about WebServices – XML-RPC.








客户分析挖掘

The segmentation tools let you create partner groups (or categories) and act on each segment differently according to questionnaires.
For example, you could create pricelists for each of the segments, or start phone marketing campaigns
by segment. To allow you to work with segments in OpenERP, you should install the crm_profiling module, which can also be achieved from the Configuration Wizard (Marketing - Profiling).

Profiling can be used to qualify your customers according to a questionnaire you define. When you establish a good customer profile, this will surely help you to close your deals. Customer profiles might even help you beat your competitors!


创建售前模板配置

During presales activities it is useful to qualify your prospects quickly. You can ask a series of
questions to find out what product / service to offer to the customer, or how quickly you should handle the
request.


Tip

Profiling

This method of rapidly qualifying prospects is often used by companies who carry out presales by
phone.
A prospect list is imported into the OpenERP system as a set of partners and the operators then
ask a series of questions to each prospect by phone.

Responses to these questions enable each prospect to be qualified automatically which leads to
a specific service being offered based on their responses.



As an illustration, take the case of a software company which offers a service based on the OpenERP
software. The company goes to several exhibitions and encounters dozens of prospects over a few
days. It is important to handle each request quickly and efficiently.

The products offered at these exhibitions are:


	training on OpenERP – for independent people or small companies,

	partner contract – for IT companies that intend to offer an OpenERP service,

	OpenERP as SaaS – for small companies,

	a meeting in conjunction with a partner to provide a demonstration aimed at providing a software
integration – for companies that are slightly larger.



The IT company has therefore put a decision tree in place based on the answers to several
questions to prospects. These are given in the following figure Example of Profiling Customer Prospects by the OpenERP Company:


[image: ../../../_images/crm_profile_tree_eng.png]
Example of Profiling Customer Prospects by the OpenERP Company



The sales person starts by asking the questions mentioned above and then after only a couple of minutes of
work, he can decide what to propose to the prospective customer simply by analysing the prospect’s answers.

At the end of the exhibition, prospects’ details and their responses to the questionnaire are entered
into OpenERP. The profiling system automatically classifies the prospects into appropriate partner
categories.

This enables your sales people to efficiently follow up prospects and adapt their approach according to
each prospect’s profile. For example, they can send a letter based on a template developed for a
specific partner category. They would use OpenERP’s report editor and generator for their sales
proposition, such as an invitation to a training session a week after the show.




高效使用配置模板

To use the profiling system, you have to install OpenERP’s crm_profiling module. You can also use the Reconfigure Wizard and add Marketing / Profiling.

Once the module is installed, you can create several questionnaires through the menu Sales ‣ Configuration ‣ Leads & Opportunities ‣ Questionnaires.  For each questionnaire, OpenERP allows you to create a list of questions and the possible responses through the menu Sales ‣ Configuration ‣ Leads & Opportunities ‣ Questions.

To obtain the scheme presented earlier you can create the following questions and responses:


Questionnaire for Defining Profiles
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管理你的账簿


如果管理系统很好的集成了会计系统，将会受惠于来自财务管理方面的显著支持。本部分涉及到会计实务处理和整个公司的会计
角色规划。



OpenERP的会计模块不仅仅帮助您更明确的遵循出票到付款的会计业务操作，还能通过使用多种财务工具基于实时数据和历史数据
进行分析。



您的会计账户结构可以完全按照A到Z配置好，从而最大可能的贴近您的公司业务情况。
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客户的开票和支付流程

OpenERP提供了多种方式来跟踪你的开票和付款记录。简单的开票流程以及高效的客户付款过程自动编目，使得OpenERP更易于被采用。
在本节中，我们讨论两个流程：一个是面向仅需跟踪付款记录的非会计人员的“简单流程”；另一个是完整会计流程。注：这里仅以客户流程
为例进行描述，当然对于供应商来说，OpenERP提供相同的开票和付款方法。



	简单的客户收据

	开票给你的客户

	跟踪客户的支付进程

	获取你的资金
	合作伙伴的财务分析

	多级提醒
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  OpenERP 的开票流程也很简单,参见下面的工作流程图:


[image: ../../../_images/account_invoice_workflow.png]
开票流程



发票可根据其他各种文件生成，如销售订单，采购订单，或在确认发货时间时生成。 当您的OpenERP是一真正的集成系统时将提供这些方法.

当然，企业通常与记录这些信息的会计师一起工作。在这种情况下，您想知道哪些发票已经开出，并已支付。

Openerp中简明并易用的 开票 系统使你能跟踪您的账务，即使您不是一个专职财务人员。
它提供了一个简单的方法来跟踪你的供应商和客户。您可以使用这个简化的会计系统，即使您和专职财务人员一起工作的情况下，您仍然希望了解付款情况。
开票 系统包括了收款和付款 (一种跟踪销售和采购的简单方法). 它也提供一个简单的方法来登记付款，不需要您填写完整的会计信息


简单的客户收据

当您卖产品给客户时，您可以给他一个真正的发票或销售收据，这也被称为客户收据。销售收据仅仅是一种销售小票，而不是一个真正的发票。

当销售收据确认后，OpenERP的自动创建销售记录，并记录客户有关这张收据的付款情况。 简单的发票系统并不需要做大量的会计配置，因此您能很快上线并快速使用!

您可以通过以下菜单创建和修改销售收据 Accounting ‣ Customers ‣ Sales Receipt.


[image: ../../../_images/account_customer_receipt2.png]
创建客户收据



当您创建一张新的“销售收据”时，您必须录入“客户”——您想创建该凭证的对象。您可以在“销售信息”页签里面定义”销售明细行“，在这儿您必须定义“会计科目”，“金额”，“摘要”.
在表单底部， 您有两个“支付”选项：一个是“直接支付”， 另一个是“稍后付款或集中付款“.
当您选择”立即付款“选项，您必须录入银行“帐户”. 当您点击”计算税“按钮后，”总金额“会自动包含计算的税款（如果您添加了增值税信息）.

当您向供应商采购商品后，您会收到”采购收据“（一张票据），它在会计术语里叫”付款单据“。 When a purchase receipt is confirmed, it creates journal items automatically and you can record
the supplier payment related to this purchase receipt, just like for the sales receipts.

您可通过菜单 :menuselection:`Accounting –> Suppliers –> Purchase Receipt`创建或修改采购收据。


[image: ../../../_images/account_supplier_voucher2.png]
Purchase Receipt




Purchase Receipt 表单和 Sales Receipt 表单看起来很象。在这个表单中，请仔细选择分类帐。





开票给你的客户

很惊讶地看到在21世纪今天，大多数公司仍然采用手工处理报价单及发票，几乎都是通过邮寄或电子邮件的方式。但目前的明显趋势是这类传统媒体将会被即时通讯、社交网络等取代。电子数据交换（简称：EDI）平台在OpenERP中尝试与更多现代通讯系统相连接，在这个平台上，实现与合伙伙伴实时交换和同步电子文件。

最初的OpenERP支持某些特定的OpenERP的文件，如销售订单，采购订单和发票进行简单的电子数据交换（EDI)机制。

事实上，在OpenERP的集成电子邮件和发票系统允许您创建发票，并自动发送一封此发票的电子邮件链接给客户。

然后客户有几个选项。如果你的客户也有一个OpenERP的系统，只需通过点击你发送的链接，他可以很容易地导入此发票。

下面为你介绍一个EDI流程的例子：:


	贵公司发出销售订单，采购订单或发票给一个特定的合作伙伴，我们称呼为Camptocamp。

	合作伙伴Camptocamp收到一封可链接到在线预览文件的电子邮件。

	点击在线预览的文件，Camptocamp可以读取，下载或打印的PDF版本，然后选择几个选项：





	导入此文件在他自己的OpenERP的系统，只需通过提供系统地址;








	如需导入该文件，要求建立一个新的OpenERP的在线系统;








	合作伙伴可以通过相应的EDI导入系统，将原EDI文件导入到他自己的第三方软件.







	合作伙伴Camptocamp可以选择直接通过Paypal在线支付或任何其他贵公司提供的方式来付款.



自由定制的电子邮件模板 菜单 设置(Settings) ‣ 配置(Configuration) ‣ 电子邮件(Email) ‣ 模板(Templates).

要获得EDI和自动发送订单和发票电子邮件，你需要EDI模块，这里是默认安装的。你需要添加一个合作伙伴的电子邮件地址，并确保“选择退出”复选框未选中。请询问您的系统管理员配置发送邮件服务器。注意电子邮件通知将被添加到一个邮件队列中，在一段时间内处理，但你可以强制邮件直接发送：菜单选择：设置 - >电子邮件 - >信息.

您客户将收到的电子邮件，如图所示。.


[image: ../../../_images/account_edi_mail.png]
发邮件给您的客户






跟踪客户的支付进程

有效跟踪客户和供应商的付款是很重要的事，通过设定用户(User)表单中发票和付款（Invoicing & Payments）的访问权限，无论这个人员是否具备会计知识，都可以留意这些付款。

:guilabel:`客户付款(Customer Payment)允许您登记客户支付的款项。为了记录客户付款，你必须输入客户，付款方式（=日记账）及付款金额。OpenERP的会自动匹配核销未清的发票、销售单据、信用票据和（预付）款项。

你可以登记客户支付款项，从OpenERP菜单menuselection：会计(Accounting) ->客户(Customers)->客户付款(Customer Payment），点击新建登记付款。


[image: ../../../_images/account_cust_payment.png]
客户付款



假设您有张3000 EUR的发票，然而您从客户那里收到的是2995 EUR。 您可以认为该发票已经结清，您将如何处理呢？

创建一张新的 Customer Payment, 选择客户，输入 Paid Amount, 比如 2995 并选择 Payment Method, 也就是您的银行分类账。所有的未结清发票，Any open invoices, credit notes or advances for this partner will be displayed on the Payment Information tab.
In this example, the 3000 EUR invoice will be proposed.

Now you have to tell OpenERP that you want to consider the invoice as fully paid. Simply click the invoice line on the Payment Information tab to make it editable. Now select the Full Reconcile checkbox, and notice that the amount changes to the full amount of the invoice.


[image: ../../../_images/account_cust_reconcile.png]
Fully Pay



Select the proper option in the Payment Difference field, i.e. Reconcile Payment (you would use the Keep Open option if you want to claim the 5 EUR from the customer). The write-off amount is already proposed automatically, but you have to enter the Counterpart Account so that write-off entries can be generated by OpenERP. You can also enter a comment about the reconciliation (by default, Write-Off will be proposed). Then post your payment.


Note

Analytic Accounts

When you do analytic bookkeeping as well, you can enter an analytic account for the write-off too.



This easy payment system also allows you to post a payment that you cannot directly attribute to a customer as an advance.

Let us take the following example. A customer has two open invoices, one of 2000, one of 1500. He pays 1000, but you cannot assign this to any of the two invoices directly. You can just enter this payment as an advance. How do you proceed?

When you key in an Amount paid of 1000 in your Customer Payment, the amount will be attributed to the oldest invoice. You do not want this, because you have no idea yet of what invoice the amount should be linked to. Click the amount in the first line and set it to 0.
Validate the payment. The system will now create an advance payment of 1000 for the customer concerned.


Tip

Supplier Payment

The Supplier Payment form allows you to track the payment to your suppliers in the same way as a customer payment.



From the menu Accounting ‣ Suppliers ‣ Supplier Payment, click the New button to create a new Supplier Payment.


[image: ../../../_images/account_supplier_payment2.png]
Supplier Payment Form



Another way of keeping track of your payments is the way accountants will do it, by encoding Bank Statements. For more information about this, please refer to the chapter on invoicemanagement.

You can also push your accounting further by importing your payments electronically through a CODA file you receive from the bank. To do this install the account_coda module.

How should you proceed?

You have to enter your company’s bank account(s) for which you want to accept CODA files. Go to the menu Accounting ‣ Configuration ‣ Financial Accounting ‣ Accounts ‣ Setup your Bank Accounts. Choose the bank account type you want to use (IBAN or normal bank account). For electronic payments, you should use IBAN; do not forget to also enter your bank’s BIC code.


Tip

Bank Journal

When you save the bank account through the Setup your Bank Accounts wizard, a bank journal will be automatically created for that account.



Then add the bank account details for each partner that will pay you through a bank. You can do this in the Partner form, on the Accounting tab.

Download the CODA file from your bank to any directory. Import the electronic bank statement through the menu Accounting ‣ Periodical Processing ‣ Statements ‣ Import Coda Statements.

Enter the data required in the wizard (receivable and payable account, bank journal and a default account to post to when no corresponding partner is found). Then select the CODA file in your directory and click the Import button to start processing the CODA file.

OpenERP will then import a draft bank statement in the selected journal and will match all corresponding customer / supplier payments when possible. You can change the draft statement if necessary from the menu Accounting ‣ Bank and Cash ‣ Bank Statements. You can check any issues during file loading from the menu Accounting ‣ Bank and Cash ‣ Coda Import Logs.
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获取你的资金

OpenERP提供多种工具用来分析客户和供应商帐户。本章我们将解释：


	financial analysis of partners, to understand the reports that enable you to carry out an analysis
of all of your partners,

	multi-level reminders, which is an automatic system for preparing reminder letters or emails when
invoices remain unpaid,

	detailed analysis of individual partners.




合作伙伴的财务分析

When members of your accounting department sign in to OpenERP, they can immediately be presented with the Accounting Dashboard. By default, it contains the customer invoices to approve, a company analysis according to account type, a Treasury graph and a useful graph for analyzing aged receivables. Click the Accounting button in the top toolbar to open the dashboard. You can also call the dashboard from the menu Accounting ‣ Reporting ‣ Dashboard ‣ Accounting Dashboard.

In the dashboard, the graph at the right entitled Aged Receivables represents your receivables week by week. At a glance, you can see the cumulative amount of what your customers owe you by week.

All of OpenERP’s graphs are dynamic. So you can, for example, filter the data by clicking the graph itself and then Filter in the Search form. When you click the graph, data will be displayed in list view. Now you enter extra search criteria and then click the graph button to display the data as a graph again.

To obtain a more detailed report of the aged balance (or order by past date), use the menu Accounting ‣ Reporting ‣ Generic Reporting ‣ Partners ‣ Aged Partner Balance.

When you click that report, OpenERP shows a wizard asking you for the chart of accounts, the start date of the analysis period and the size of the interval to be analysed (in days). The start date will determine which documents will be included in the report (document date until the selected start date) and it will serve as a reference date to calculate the amounts due for the selected interval.
You can print an aged partner balance for Receivable Accounts or Payable Accounts of for both at the same time. The analysis direction may be Past (for entries that are due) or Future to keep track of your cash flow in the next days or weeks (according to your selection). OpenERP then calculates a table of credit balance by period. So, if you request an interval of 30 days, OpenERP generates an analysis of creditors for the past month, past two months, and so on.
An ageing balance will indicate how much of the accounts receivable is overdue. It also reports how far overdue the accounts are (number of days).


Tip

Aged Partner Balance

This report works best of you use payment terms or if you set a due date yourself.




[image: ../../../_images/account_aged_balance.png]
Aged Balance in the Past using a 30-days Period




[image: ../../../_images/account_aged_balance_fut.png]
Aged Balance in the Future using a 30-days Period



For an analysis by partner, you can use the partner balance that you get through the menu Accounting ‣ Reporting ‣ Generic Reporting ‣ Partners ‣ Partner Balance. The system then supplies you with a PDF report containing one line per partner representing debit, credit and balance. The total is displayed per account receivable.


[image: ../../../_images/account_partner_balance_61.png]
Partner Balance



If you want detailed information about all invoices, credit notes and payments related to partner, print the partner ledger from the menu Accounting ‣ Reporting ‣ Generic Reporting ‣ Partners ‣ Partner Ledger. You can choose to print one partner per page.


[image: ../../../_images/account_partner_ledger_61.png]
Partner Ledger



Furthermore, OpenERP also provides statistics about individual account entries, invoices and treasury, for instance. To look up statistic information about your accounting, explore the menu Accounting ‣ Reporting ‣ Statistic Reports. There you will find Invoices Analysis, Entries Analysis and Treasury Analysis to name some. By default these statistics are displayed as a list which you can filter to fit your needs. Standard filter buttons, extended filters and grouping features allow you to make an in-depth analysis of your accounting. But the list is not all OpenERP has to offer. These statistic reports can be displayed as a graph simply by clicking the Graph button at the top right side of the screen. Notice that graphs allow for only one Group by function at a time.


[image: ../../../_images/account_entries_anal.png]
Entries Analysis List View




[image: ../../../_images/account_entries_anal_graph.png]
Entries Analysis Graph View




Tip

Exporting Entries

Remember that you can export all types of resources in OpenERP.
From the web client, you need to navigate to a search list for the resource, then click the Export link at the bottom left of the list. From the GTK client, you would use the menu Form ‣ Export data. The Export feature enables you to easily create your own analysis in tools such as Microsoft Excel or Calc (LibreOffice or OpenOffice), simply by exporting accounting entries.






多级提醒

To automate the management of follow-ups (reminders) you should install the module account_followup (or check the Followups Management option in the Add More Features wizard).

This module is integrated with the email features of OpenERP. Ask your system administrator to define the smtp server through the menu Settings ‣ Configuration ‣ Email ‣ Outgoing Mail Servers.

Once the module is installed, configure your levels of follow-up using the menu Accounting ‣ Configuration ‣ Miscellaneous ‣ Follow-Ups.


Note

Follow-ups

You can define only one follow-up cycle per company, because you cannot link the follow-up cycle to a partner.



The levels of follow-up are relative to the due date; when no payment term is specified, the invoice date will be considered as the due date.

For each level, you should define the number of days and create a note which will automatically be added into the reminder letter. The order in which you define the various follow-up levels determines the order in which letters will be sent.


Example of Configuring Follow-up Levels
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从开票到支付

本章分析OpenERP的会计的基本工作流，从填写发票到确认付款。介绍了具体各种操作，不仅包括填写会计凭证的分录，还有对账过程的账务处理（包括付款单等）。

总帐是公司管理的核心: 公司所有的业务都会影响它。它是一个信息员（有多少现金？什么样的债务需要偿还呢？库存价值多少？），并且，因为它提供的信息，可靠和详细的会计系统可以并且应该有一个重大决策的地位。

In most companies, accounting is limited to producing statutory reports and satisfying the
directors’ curiosity about certain strategic decisions, and to printing the balance sheet and the
income statement several times a year. Even then, there is often several weeks of delay between
reality and the report.


Note

Valueing your Accounting Function

In many small companies, the accounting function is poorly treated.

Not only do you see the data for documents being entered into the system twice,
but also the results are often just used to produce legal documents and regular printouts
of the balance sheet and income statements some weeks after the closing dates.

By contrast, integrating your accounts with your management system means that you can:


	reduce data entry effort – you only need to do it once,

	run your processes with the benefit of financial vision: for example, in managing projects,
negotiating contracts, and forecasting cash flow,

	easily get hold of useful information when you need it, such as a customer’s credit position.





So accounting is too often underused. The information it brings makes it a very effective tool
for running the company if it is integrated into the management system. Accounting information really
is necessary in all of your company’s processes for you to be effective, for example:


	for preparing quotations it is important to know the precise financial position of the client, and
to see a history of any delays in payment,

	if a given customer has exceeded his credit limit, accounting can automatically stop further
deliveries to the customer,

	if a project budget is 80% consumed, but the project is only 20% complete, you could renegotiate
with the client, or review and rein in the objectives of the project,

	if you need to improve your company’s cash flow then you could plan your service projects on the
basis of billing rates and payment terms of the various projects, and not just delivery dates –
you could work on short-term client projects in preference to R&D projects, for example.



OpenERP’s general accounting and analytic accounting handle these needs well because of the close
integration between all of the application modules. Furthermore, the transactions, the actions and
the financial analyses happen in real time, so that you cannot only monitor the situation but also
manage it effectively.

The account module in OpenERP covers general accounting, analytic accounting, and auxiliary
and budgetary accounting. It is double-entry, multi-currency and multi-company.


Note

Accounting


	General accounting (or financial accounting) is for identifying the assets and liabilities of the
business. It is managed using double-entry accounting which ensures that each transaction is
credited to one account and debited from another.

	Analytical accounting (or management accounting, or cost accounting) is an independent accounting
system, which reflects the general accounts but is structured along axes that represent the
company’s management needs.

	Auxiliary accounting reflects the accounts of customers and/or suppliers.

	Budgetary accounts predefine the expected allocation of resources, usually at the start of a
financial year.






Tip

多公司操作

在使用OpenERP多公司操作前, 请参考下面的情形进行配置选择:


	如果你的多个公司间只共用少部分数据(如产品, 合作伙伴以及其他),推荐你为每个公司独立创建一个帐套,

	如果你的多个公司间共用比较多的数据,那你就需要在同一个帐套中进行细致的权限规划配置了,




	you can synchronize specified document types in several databases using the base_synchro
module, which is a shared-funding module rather than a module in the standard open repositories.





One of the great advantages of integrating accounts with all of the other modules is in avoiding the
double entry of data into accounting documents. So in OpenERP, an Order automatically generates an
Invoice, and the Invoice automatically generates the accounting entries. These in turn generate tax
submissions, customer reminders, and so on. Such strong integration enables you to:


	reduce data entry work,

	greatly reduce the number of data entry errors,

	get information in real time and enable very fast reaction times (for bill reminders, for
example),

	exert timely control over all areas of company management.




Tip

For Accountants

You can configure the Accounting application using the information given in the configuration wizard.


[image: ../../../_images/config_wiz_account.png]


With appropriate rights management, this allows trustees to
provide customers with real-time access to their data. It also gives them the opportunity to work
on certain documents that have no direct accounting impact, such as budgets.

This can provide a value-added service that greatly improves the interaction between trustees and
their clients.



All the accounts are held in the default currency (which is specified in the company definition),
but each account and/or transaction can also have a secondary currency (which is defined in the
account). The value of multi-currency transactions is then tracked in both currencies.

For this chapter you should start with a fresh database that includes demo data,
with Sales Management installed and a generic chart of accounts.
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会计工作流和自动创建发票

The chart Accounting workflow for invoicing and payment shows the financial workflow followed by each invoice.


[image: ../../../_images/account_flow.png]
Accounting workflow for invoicing and payment



In general, when you use all of OpenERP’s functionality, invoices do not need to be entered
manually. Draft invoices are generated automatically from other documents such as Purchase Orders.


发票草稿

The system generates invoice proposals which are initially set to the Draft  state. While
these invoices remain unconfirmed, they have no accounting impact within the system. There is nothing
to stop users creating their own draft invoices if they want to.

You can create draft customer invoice manually using the menu Accounting ‣ Customers ‣ Customer Invoices.

The information that is needed for invoicing is automatically taken from the Partner form (such as
payment conditions and the invoice address) or from the Product (such as the account to be used) or
from a combination of the two (such as applicable Taxes and the Price of the product).


Tip

Draft Invoices

There are several advantages in working with draft invoices:


	You have got an intermediate validation state before the invoice is approved.
This is useful when your accountants are not the people creating the initial invoice,
but are still required to approve it before the invoice is entered into the accounts.

	It enables you to create invoices in advance, without approving them at the same time.
You are also able to list all of the invoices awaiting approval.








商业或形式发票

You can approve (or validate) an invoice in the Open  or Pro-forma  state.
A pro forma invoice does not have an invoice number yet, nor accounting entries.
It is commonly used as a preliminary invoice or for customs purposes.
It is more formal than a draft invoice and a pro forma invoice can later be converted to an open invoice.

An open invoice has a unique invoice number. The invoice is sent to the customer and is marked on
the system as awaiting payment.




核销和支付

In OpenERP, an invoice is considered to be paid when its accounting entries have been reconciled
with the payment entries. If there has not been a reconciliation, an invoice can remain in the Open
state until you have entered the payment.


Tip

Payment and Reconciliation

To avoid surprises, it is important to understand the idea of reconciliation and its link with
invoice payment.

You will find the Paid/Reconciled checkbox on an invoice.
It is checked if the Journal Entry of the invoice has been totally reconciled
with one or several Journal Entries of payment.




Note

Reconciliation

Reconciliation links entries in an account that cancel each other out – they are reconciled
to each other (sum of credits = sum of debits).

This is generally applied to payments against corresponding invoices.



Without the reconciliation process, OpenERP would be incapable of marking invoices that have been
paid. Suppose that you have got the following situation for the Smith and Offspring customer:


	Invoice 145: 50,

	Invoice 167: 120,

	Invoice 184: 70.



If you receive a payment of 120, OpenERP will delay reconciliation because there is a choice of
invoices to pay. It could either reconcile the payment against invoices 145 and 184 or against
invoice 167.


Tip

Treatment in Lots

Usually, different transactions are grouped together and handled at the same time rather than
invoice by invoice. This is called batch work or lot handling.

You can select several documents in the list of invoices: check the checkboxes of
the interesting lines using the web client and click the appropriate shortcut button at the right;
or shift-click the lines using the mouse in the GTK client and use the action or print button at
the top –
these give you the option of a number of possible actions on the selected objects.



At regular intervals, and independent of the invoices, an automatic import procedure or a manual
accounts procedure can be used to bring in bank statements. These comprise all of the payments of
suppliers and customers and general transactions, such as between accounts.

When an account is validated, the corresponding accounting entries are automatically generated by
OpenERP.

Invoices are marked as Paid when accounting entries on the invoice have been reconciled with
accounting entries about their payment.

This reconciliation transaction can be carried out at various places in the process, depending on
your preference:


	at data entry for the accounting statement,

	manually from the account records,

	automatically using OpenERP’s intelligent reconciliation.



You can create the accounting records directly, without using the invoice and account statements. To
do this, use the rapid data entry form in a journal. Some accountants prefer this approach because
they are used to thinking in terms of accounting records rather than in terms of invoices and
payments.

You should really use the forms designed for invoices and bank statements rather than manual data
entry records, however. These are simpler and are managed within an error-controlling system.




基于记录的会计系统

All the accounting transactions in OpenERP are based on records, whether they are created by an
invoice or created directly.

So, customer reminders are generated quickly from the list of unreconciled entries in the trade
receivables account for that partner. In a single reminder, you will find the whole set of unpaid
invoices as well as unreconciled payments, such as advance payments.

Similarly, financial statements such as the general ledger, account balance, aged balance (or
chronological balance) and the various journals are all based on accounting entries. It does not
matter if you generated the entry from an invoice form or directly in the invoice journal. It is the
same for the tax declaration and other statutory financial statements.

When using integrated accounting, you should still go through the standard billing process because
some modules are directly dependent on invoice documents. For example, a sales order can be
configured to wait for payment of the invoice before triggering a delivery. In such a case,
OpenERP automatically generates a draft invoice to send to the client.
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发票

OpenERP中, 发票管理包含以下部分:


	客户发票

	供应商发票

	客户红字发票

	供应商红字发票



这四类发票在系统是中同一对象, 仅仅只是发票类型与界面展现方式不一样.

OpenERP 为这四种类型的发票对应设置了四个菜单项,不同的菜单项会打开对应的发票表单, 从表单名就可以区分开.


Note

发票类型

多类型发票使用同一对象有很多方便之处,典型的优势如以下两点:


	多公司环境时公司间的发票,一个公司的客户发票则转为另一个公司的供应商发票.

	在同一个界面下, 你可以检索和处理各种类型的发票.在处理合作伙伴的应收/付帐时,你可以很清楚在这个列表中列出.






Note

Credit Note

A credit note is a document that enables you to cancel an invoice or part of an invoice.



点击菜单 会计(Accounting) ‣ 客户(Customers) ‣ 客户发票(Customer Invoices) 进入客户发票列表.
点击菜单 会计(Accounting) ‣ 供应商(Suppliers) ‣ 供应商发票(Supplier Invoices) 进入供应商发票列表.

通常情况,OpenERP中的发票都是由业务系统自动生成出来的.所以,一般不需要手工创建发票,只需要轻轻一点确认或审核即可.
OpenERP中一般有下面的几种途径去生成发票:


	来自供应商与客户的订单,

	from receipt or dispatch of goods,

	来自员工工单(timesheets, 参阅 人力资源管理的关键特性),

	来自完成的项目工作 (参阅 很棒的项目管理),

	from fee charges or other rechargeable expenses (see 提供高质量服务).



The different processes generate Draft  invoices. These must then be approved by a suitable
system user and sent to the customer. The different invoicing methods are detailed in the following
sections and chapters.

It is also possible to enter invoices manually. This is usually done for invoices that are not
associated with an order (usually purchase orders) or Credit Notes. Also, if the system has not been
configured correctly you might need to edit the invoice before sending it to the customer.

For example, if you have not realized that the customer is tax-exempt, the invoice you generate from an
order will contain tax at the normal rates. It is then possible to edit this out of the invoice
before validating it.


录入客户发票

OpenERP 的发票录入相当方便,而且支持非财务人员录入相应的发票信息.这意味着发票在生成到收款期间,随时可以保证
发票数据及相应税额计算的更新.

同时,具有会计权限的员工可以完成后续的凭证分录的处理.并且分录中的数据还可以继续修改确认.

点击菜单 会计(Accounting) ‣ 客户(Customers) ‣ 客户发票(Customer Invoices) 进入客户发票列表, 再点击 新建(New) 按钮
即可创建一张新的客户发票.

在新打开的发票窗体中,输入下面的信息.


[image: ../../../_images/account_invoice_new.png]
输入新发票



发票包含以下三部分:


	发票的抬头,是客户相关信息,

	发票主体部分,则是发票的明细行,

	发票的下面部分,则是关于所缴税行明细以及发票的汇总.



在填写发票信息的时候,你最好按OpenERP表单上的顺序填定数据.这样的目的是为了让你在录入一些数据后,能自动带出
其他字段的值.如,你选择一个客户后,下面的这些字段会被自动带出来:


	发票地址 默认使用了该客户联系人的发票地址,如果没有发票地址,则使用该客户联系人的默认地址,

	客户应收账款科目 默认使用了该客户窗体中 会计 页签中的 应收账款 科目,

	付款条件 也默认使用了该客户窗体中 会计 页签中的 付款条件, 如: “21天内付50%并在60天内付清余款”.




Note

Properties 字段

合作伙伴 或者 产品 上的 Property 字段是多公司类型的. 该字段的值取决于当前用户所属公司.

在一个账套上使用多公司配置,你可能需要为每个公司配置财务报表. 而且合作伙伴的 资产 与 负债 科目是也按公司分开的.




Tip

Seeing Partner Relationships

在OpenERP中, 你很多数据是相互关联的. 从某一个字段,可以引出相关的很多其他数据信息.


	In the web client in read-only mode, a relation is commonly a hyperlink
- it takes you to the main form for that entity, with all of the actions and links.

	使用浏览器访问时,在编辑模式下,你可以在字段上使用鼠标右键得到相关的功能菜单.

	在GTK客户端里,右键点击字段,可以得到一样的结果.



So one way or another you can rapidly reach the partner’s:


	current sales and purchases,

	CRM requests,

	草稿状态发票,

	accounts records,

	应收/应付科目.





录入发票其他相关内容并选择适当的发票币种.

发票表头输入完成后, 输入表体部分时, 你可以用下面两种方式来输入:


	表体各字段手工输入,

	选择一个产品, 让产品相关数据自动完成相关字段的输入.




Tip

发票明细备注

发票明细备注是对于明细摘要的补充.如果你对于发票明细添加更多的说明时,你只需要在明细窗体中的 备注(notes)
字段中输入即可.



接下去, 发票行选择 电脑兼容主机 产品, 下面的字段会自动带出:


	摘要(Description) : 默认由合作伙伴的产品名称带出,

	Account : determined by the purchase or sales account defined in the
product properties. If no account is specified in the product form, OpenERP uses the properties of
the category that the product is associated with.

	计量单位(Unit of Measure) : 默认由选择的产品的计量单位带出,

	单位价格(Unit Price) : 默认使用所选产品上的销售价格(不含税),

	税(Taxes) : 默认使用产品及合作伙伴窗体上定义的各种税.




Tip

使用含税价

通常情况下, OpenERP 发票等价格是使用的不含税价 – 你可以在OpenERP的税项配置中.勾选 含税价 勾选项而使用含
税价.




Note

产品相关信息

When you are entering invoice data, it can sometimes be useful to get hold of more information about
the product you are invoicing.
在 Web 客户端或者 Gtk 客户端 的 产品(Product) 字段编辑模式下点右键,可以看到关于产品的如下的一些信息:


	库存预测,

	产品成本结构,

	仓库产品库位.





输入完发票明细后, 你还可以继续修改自动带出的相关的信息.

输入完发票明细后,你可能点击 计算税额(Compute Taxes) 按钮, 发票会自动产生下面的相关税项:


	details of tax calculated,

	tax rate,

	total taxes,

	total price.



In the Taxes area at the bottom left of the invoice you will find the details of the totals
calculated for different tax rates used in the invoice.


Tip

计算税额

在发票税项区里双击明细行就可以查看相关税的详细信息.

OpenERP then shows you the detail of the tax charges which will form your tax
declaration at the end of the period.

It shows you the total that will be computed in the different parts of the legal declaration. This
enables you to manage the declaration in OpenERP automatically.
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Detail of tax charges on an invoice



Before approving the invoice you can modify the date and the accounting period, which are entered by
default as today’s date. These fields are found on the second tab Other Info.


Note

Invoice Layout

If you want to make your invoice layout more elaborate you can install the module
account_invoice_layout. This enables you to add various elements between the lines such as
subtotals, sections, separators and notes.



Click Validate when you want to approve the invoice. It moves from the Draft state to the Open  state.

When you have validated an invoice, OpenERP gives it a unique number from a defined sequence. By
default it takes the form Journal Code/Year/Sequence Number for example, SAJ/2010/005 . You cannot modify an
invoice number, but instead, you should modify the sequence numbers through the menu Administration ‣ Configuration ‣ Sequences ‣ Sequences.

Accounting entries corresponding to this invoice are automatically generated when you approve the
invoice. You see the details by clicking the entry in the Journal Entry field and searching
there for the account moves generated by that invoice number.




税的管理

Details on the product form determine the selection of applicable taxes for an
invoice line. By default, OpenERP takes account of all the taxes defined in the product form.

Take the case of the following product


	Applicable taxes:



	TVA: 19.6% type TVA

	DEEE: 5.5, type DEEE











Note

DEEE Tax

The DEEE tax (disposal of electronic and electrical equipment) is an ecological tax that was
imposed in France from 2009. It is applied to batteries to finance their recycling and is a fixed
sum that is applied to the before-tax amount on the invoice.



If you trade with a company in your own country, and your country has a DEEE-type tax, the
applicable taxes for this invoice could be:


	DEEE: 5.5,

	TVA: 19.6%.



If you sell to a customer in another company in the community (intracommunity), instead, then tax is
not charged. In the partner form, in the tab Accounting, the field Fiscal Position
maintains information whether the customer is within the region or not. When you create an invoice for this customer, OpenERP will calculate the following taxes on the product:


	DEEE: 5.5,

	TVA intracommunity: 0%.



If you have not entered the parameters in the customer form correctly, OpenERP will suggest incorrect
taxes in the invoice. That is not a real issue, because you can always modify the
information directly in the invoice before approving it.


Tip

Occasional Invoices

When you create an invoice for a product that will only be bought or sold once, you do not have to
encode a new product.
Instead, you will have to provide quite a bit of information manually on the invoice line:


	sales price,

	applicable taxes,

	account,

	product description.








取消发票

By default, OpenERP will not allow you to cancel an invoice once it has been approved. Since
accounting entries have been created, you theoretically cannot go back and delete them. However, in
some cases, it is more convenient to cancel an invoice when there is an error than to produce a credit
note and reconcile the two entries. Your attitude to this will be influenced by current legislation
in your accounting jurisdiction and your adherence to accounting purity.

OpenERP accommodates either approach. Install the account_cancel module. Then allow cancelling an invoice by checking the box
Allow Cancelling Entries in the Journal corresponding to this invoice. You will then be allowed to
cancel the invoice if the following two conditions are met:



	The accounting entries have not been reconciled or paid: if they have, then you will have to cancel
the reconciliation first.

	The accounting period or the fiscal year has not already been closed: if it is closed then no
modification is possible.






Cancelling an invoice has the effect of automatically modifying the corresponding accounting
entries.

要能取消发票, 你需要安装 account_cancel 模块, 并在你可以取消发票的账簿里配置 允许取消发票(Allow Cancelling Entries) 勾选项.
这时,只要未核销的发票均可以取消该发票, 并重置该发票到 草稿(Draft) 状态.


Tip

Numbering Invoices

Some countries require you to have contiguously numbered invoices (that is, with no break in the sequence).
If, after cancelling an invoice that you are not regenerating,
you find yourself with a break in the numbering you would have to go and modify the sequence,
redo the invoice and replace the sequence number with its original value.

You can control the sequences using the menu Administration ‣ Configuration ‣
Sequences ‣ Sequences.



Cancelling an invoice will cause a break in the number sequence of your invoices. You are
strongly advised to recreate this invoice and re-approve it to fill the hole in the numbering if you can.


Tip

Duplicating a Document

The duplication function can be applied to all the system documents: you can duplicate anything –
a product, an order, or a delivery.




Note

Duplicating Invoices

Instead of entering a new invoice each time, you can base an invoice on a similar preceding one
and duplicate it. To do this, first search for a suitable existing invoice. In the web client, show
the invoice in read-only (non-editable) form view, then click Duplicate. In the GTK client,
select Form ‣ Duplicate from the top menu.

The duplication creates a new invoice in the Draft state. That enables you to modify it before
approving it. Duplicating documents in OpenERP is an intelligent function, which enables the
duplicated invoice to be given its own sequence number, today’s date, and the draft state, even if
the preceding invoice has been paid.




Note

Saving Partner Preferences

OpenERP has many functions to help you enter data quickly. If you invoice the same products
frequently for the same partner you can save the last invoice preferences using conditional
default values.

To test this functionality, create an invoice for a partner and add some lines
(from the GTK client). Then right-click on the Invoice Line field and select
Set Default. Check the box that indicates this default should apply only to you.

Then the next time you create an invoice, these invoice lines will be
automatically created and you will only have to modify the quantities before confirming the invoice.

For taxes, you could put the default amount in the invoice lines (in France it would be
19.6%, in Belgium 21%, in the UK 17.5% or 15%). Doing this, you will not forget to add tax when you are
manually entering invoices.

(The capabilities of the GTK client are more extensive than those of the web client.
You can set defaults for multiple lines in the GTK client but only a single line in the web client,
so you need to be quite sure what is possible before you use this functionality routinely.)




Note

Getting Information by Navigating to it

As you are creating an invoice you will often find you need extra information about the partner to
help you complete the invoice. As described earlier, you can navigate to other
information linked to this partner by right-clicking, such as:


	Monthly Turnover

	Benefit Details,

	Most Recent Invoices,

	Latest Orders - Sales Order, Purchase Order.



Do the same to get information about the products you are invoicing. For example: is there enough
stock? When will you be getting more stocks in? What are the costs and normal list prices for this
product?

By making this information easily accessible while you are invoicing, OpenERP greatly simplifies
your work in creating the invoice.






创建供应商发票

The form that manages supplier invoices is very similar to the one for customer invoices. However,
it has been adapted to simplify rapid data entry and monitoring of the amounts recorded.


Tip

Entering Data

Many companies do not enter data on supplier invoices, but simply enter accounting data corresponding to
the purchase journal.

This particularly applies to users that have focused on the accounting system rather than all the
capabilities provided by an ERP system.
The two approaches reach the same accounting result: some prefer one and others prefer the other
depending on their skills.

However, when you use the Purchase Management functions in OpenERP you should work directly on
invoices because they are provided from Purchase Orders or Goods Receipt documents.



To enter a new supplier invoice, use the menu Accounting ‣ Suppliers ‣ Supplier Invoices.

Everything is similar to the customer invoice, starting with the Journal
unless the default is acceptable, and then the Supplier, which will automatically complete the following fields


	Invoice Address,

	Partner Account.



Unlike the customer invoice, you do not have to enter payment conditions – simply a Due
Date if you want one.
If you do not give a due date, OpenERP assumes that this invoice will be paid in cash.
If you want to enter more complete payment conditions than just the due date, you can use the Payment
Term field which you can find on the second tab Other Info.

You must also enter the invoice Total with taxes included. OpenERP uses this amount
to check whether all invoice lines have been entered correctly before it will let you validate the
invoice.

Indicate the Currency if the invoice is not going to use the default currency, then you can enter
the Invoice lines.

Just like the customer invoice, you have the choice of entering all the information manually or use
a product to complete many of the fields automatically. When you enter a product, all of the following
values are completed automatically:


	the product Account is completed from the properties of the product form or the
Category of the product if nothing is defined on the product itself,

	the Taxes come from the product form and/or the partner form, based on the same
principles as the customer invoice,

	the Quantity is set at 1 by default but can be changed manually,

	set the Unit Price from the total price you are quoted after deducting all
the different applicable taxes,



Click Compute Taxes to ensure that the totals correspond to those indicated on
the paper invoice from the supplier. When you approve the invoice, OpenERP verifies that the total
amount indicated in the header corresponds to the sum of the amounts without tax on the invoice lines
and the different applicable taxes.

OpenERP automatically completes the Date Invoiced and the accounting period.


Note

Dates and Accounting Periods

Accounting periods are treated as legal period declarations. For example, a tax declaration for an
invoice depends on the accounting period and not on the date of invoicing.

Depending on whether your declarations are made monthly or quarterly, the fiscal year contains
either twelve or four accounting periods.

The dates are shown in the document you created in the accounting system. They are used for
calculating due dates.



The two pieces of information do not have to have the same date. If, for example, you receive an
invoice dated 5th January which relates to goods or services supplied before 31st December, the
invoice may be coded into the December accounting period and thus be recognized in that period for
the tax declaration, while the invoice can remain 5th January which remains the basis of the due
date for payment.

You can find that the amounts do not correspond with what your supplier has given you on paper for
reasons that can include:


	the supplier made a calculation error,

	the amounts have been rounded differently.




Tip

Rounding Tax

It often happens that a supplier adds 1 to the total because the tax calculation has been rounded
upwards. Some tax amounts are not valid because of this rounding.

For example, it is impossible to arrive at the amount of 145.50 if you are working to a precision of 2
decimal places and a rate of 19.6%:


	121.65 x 1.196 = 145.49

	121.66 x 1.196 = 145.51





In this case you can modify a value in the lines that the total is based on, or the total amount of
taxes at the bottom left of the form: both are editable so that you can modify them to adjust the
total.

When the totals tally, you can validate the invoice. OpenERP then generates the corresponding
accounting entries. You can manage those entries using the Account fields on the
invoice and on each of the invoice lines.




欠款单据/ 偿还

Entering a customer credit note is almost identical to entering a customer invoice. You just start
from the menu Accounting ‣ Customers ‣ Customer Refunds.

Similarly, entering a supplier credit note is the same as that of the supplier invoice, and so you
use the menu Accounting ‣ Suppliers ‣ Supplier Refunds.

It is easy to generate a credit note quickly from an existing invoice. To do this, select a customer
or supplier invoice which is in Open or Paid state and click the Refund button. OpenERP
opens a new payment invoice form for you in the Draft  state so that you can modify it before
approval.


Tip

Crediting Several Invoices

You can credit more than one customer invoice using the menu Accounting ‣ Customers ‣
Customer Payment. You can find the Invoices and outstanding transactions and Credits for the particular customers.
Enter the amount in the field Paid Amount and validate it.






支付

An invoice is automatically marked as Paid by OpenERP once invoice entries have been reconciled
with payment entries. You yourself do not have to mark the invoices as paid: OpenERP manages that
when you reconcile your payments.


Tip

Reconciling a Credit Note

Generally, you reconcile the invoice’s accounting entries with their payment(s).
But you can also reconcile an invoice with the entries from the corresponding credit note instead,
to mutually cancel them.



You have seen the Payment button in the invoice form which is in Open state.
This lets you enter payments and get entries reconciled very quickly.

You can also manage the payment of invoices when you are entering bank statements and cash
transactions. These allow better control of financial transactions and permit greater flexibility in
areas such as:


	advance and partial payments of invoices,

	payment of several invoices by several payments,

	fine-grained management of different due dates on the same invoices,

	management of adjustments if there are different amounts to those on the invoice.
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会计分录

创建会计分录有多种方法。 比如，你已经清楚地了解了发票是怎么来创建它的分录。

本节讨论


	银行对账单的管理，

	现金管理，

	账簿分录管理。



这里我们给你展示如何进入财务交易。在OPENERP中，你可以处理银行对账单和现金记录。 对这两种交易使用不同的账簿。根据选择的账簿类型，you will have a different screen.


管理银行对账单

OpenERP提供了一个可视化的工具来管理银行对账单，简化了账户数据的录入。
当对账单被确认时，OPENERP就会自动生成相应的会计分录。 所以，非会计人员无需担心贷方，借方和counterparts这些事，也可以记录财务事项。

记录一张银行对账单， 转到菜单 会计(Accounting) ‣ 银行和现金(Bank and Cash) ‣ 银行对账单(Bank Statements) 。
输入数据到银行对账单的表单然后打开如图所示 银行对账单录入界面.


[image: ../../../_images/account_statement.png]
银行对账单录入界面



单据引用的 名称 和 日期 是由OPENERP自动推荐的。这个 名称 在银行对账单确认的时候将被单据编号补充。 你可以通过管理序列号来配置你自己的引用，在 Administration ‣ Configuration ‣ Sequences 系统管理员 ‣ 设置 ‣ 序列 菜单。

接着选择 账簿(Journal). 一般来讲,在期初建立账套的时候,最好为公司的每一个银行账户及现金户各建立一个对应的
账簿(Journal). 然后在这里,你选择与本次银行对账相应的账簿即可.

银行对账单明细行上的币种会沿用对账单所属账簿的币种设置. 如你的银行对帐单明细是 美元(USD), 则你对应应该输入
美元(USD) 的金额. 在确认单据时,非公司本币位的币种会自动按当时有效汇率转换为公司本币位币种. (所以,您必须
首先在 会计(Accounting) ‣ 配置(Configuration) ‣ 其它(Miscellaneous) ‣ 货币(Currencies) 处建立相关币种的汇率)

OpenERP 会自动将上一次对账的余额处理到本次对账单的期初余额中.
You can modify this value and force another value. This lets you enter
statements in the order of your choice. Also if you have lost a page of your statement, you can enter
the following ones immediately and you are not forced to wait for a duplicate from the bank.

So, complete the closing balance which corresponds to the new value in the account displayed on your
bank statement. This amount will be used to control the operations before approving the statement.

接着就是按银行的回单逐行输入进银行对帐单明细中.

输入本次对账的所有交易明细行.
你可以手工录入这些交易明细,你也可以点击 导入发票(Import Invoices) 按钮来自动生成交易明细.




手工分录

当你输入一个合作者的名字, OpenERP 自动调用相应的中央集权的帐户. The total amount due for the customer or supplier is pre-completed (Amount). This gives you a simple indication of the effective payment. You
must then enter the amount that appears on your statement line: a negative sign for a withdrawal and
a positive sign for a cash payment or deposit.

在 收/付款(Payment) 界面按下键 F1 会自动将需要核销的凭证行与本次付款对应起来.




导入发票

点击 导入发票(Import Invoices) 按钮, 选择你要与付款相核销的发票行,并点击 添加(Add) 按钮. 点击OK确认选择; the statement line will automatically be added with the corresponding reconciliation.


[image: ../../../_images/account_statement_reconcile.png]
与银行对帐单的核销




Note

核销

OpenERP 有很多种核销方式: 你可以在支付发票时, 直接选择与之对应的发票相关的凭证行进行核销.也可以
使用 自动核销 工具进行自动核销.

你可以将相关金额全额核销,也可以仅核销一部分.



如果在你的收付款与发票的核销金额不一致时,OpenERP 会进入 销账(Write-off) 向导, 允许你将核销不平衡
余额调账到一个指定的会计科目中去. 通常使用下面的方式去调整余额:


	记入利润或者亏损,

	记入汇兑损益,

	记入销售折扣/回扣/佣金/返利等相关科目.



当付款金额与待付款项和调整科目项之和的金额相符时,就可以完成本次核销.

你还可以选择后面再处理本次核销余额.核销操作会处理两件事:


	标记发票已核销,

	防止已清账的支付信息与发票信息的客户提醒支付邮件重复发送, 客户收到的仅是未核销的支付与发票信息. 如果与
客户相互达成一致对某些欠款或者不明款项进行销账,也可以在核销中处理.



然后,你再确认一下. 只要余额平衡OpenERP 会自动生成对应的凭证分录. 对应的相关发票也会自动标记为已支付.

You can also enter general accounting entries, for example, banking costs. In such cases, you can enter the amounts directly in the corresponding general accounts.

A user with advanced accounting skills can enter accounting entries directly into the bank journal from Accounting ‣ Journal Entries -> Journal Items. The result is the same, but the operation is more complex because you must know the
accounts to use and must have mastered the ideas of credit and debit.




现金管理

要进入现金管理, 请点击菜单 会计 ‣
银行和现金 ‣ 现金记录. 然后每天在 初始余额(Opening Balance) 处输入当前的现金期初盘点.Then open the cashbox to start making entries from the Cash Transactions tab.


[image: ../../../_images/account_cash_registers.png]
定义现金记录(Cash Registers)



All the transactions throughout the day are then entered in this statement. When you close the cashbox, generally at the end of the day, enter the amounts on the CashBox tab, in the
销账(Closing Balance) section. Then confirm the statement to close the day’s cash statement and automatically
generate the corresponding accounting entries. Note that the Calculated Balance and the CashBox Balance need to be equal before you can close the cashbox.


Tip

确认对账单

Accounting entries are only generated when the cash statement is confirmed.
So if the total statement has not been approved (that is to say during the day, in the case of petty
cash), partner payments will not have been deducted from their corresponding account.






管理账簿中的分录

Invoices and statements produce accounting entries in different journals. But you could also
create entries directly in a journal (line by line) without using the dedicated journal views. This functionality is
often used for miscellaneous entries.

手工录入凭证时,进菜单 会计(Accounting) ‣ 会计凭证(Journal Entries) ‣ 会计凭证明细(Journal Items). 在 凭证明细列表页 选择适当的 账簿(Journal) 再点击 搜索(Find) 进行过滤. 这时如果你新建凭证行时, 新的凭证行则默认会记账到你过滤选择的账簿.

下面看一下采购发票的例子,在OpenERP中自动生成会计凭证分录.

点击 新建(New) 按钮, 并按下面的内容填写:


	参考(Reference): 发票及凭证相关的参考信息,

	发生日期(Effective date): 记账的日期,通常使用操作当天的日期,

	会计期间(Period): 业务发生时的会计期间, 通常情况下应该是当前的会计期间,

	合作伙伴(Partner): 与本次业务相关的合作伙伴,

	科目(Account): 记账科目 (如采购科目 材料采购(Products Purchase) ),

	摘要(Name): 发票行的摘要(如: PC2 ),

	借方(Debit): 借方的金额.

	账簿(Journal): 选择要记入的账簿.

	贷方(Credit): 贷方的金额.



按 回车(Enter) 键保存. 凭证会有一个简单的自动编号.因为凭证借贷方并不平衡,所以录入的数据行都是红色的状态.并且
默认情况下录入的发票行都处于草稿状态,还不会直接影响财务报表数据.因此,你需要将该凭证记账.注意凭证中的凭证行的借贷方的金额
必须平衡.

OpenERP now proposes the balancing accounting line to be filled in. If the account used (in this
case account 600000 ) includes taxes by default OpenERP automatically
proposes taxes associated with the amount entered. At this stage you can modify and validate this
second line of the account, or replace it with other information such as a second purchase line.

When you have entered all of the data from your lines, OpenERP automatically proposes counterpart
entries to you, based on the credit entries.


Tip

关于借贷平衡

When an accounting entry is matched, OpenERP moves it to the Valid state automatically and
prepares to enter the next data. Do not forget to definitely post the valid entries by clicking the Action
button and selecting Post Journal Entries.

If you want to add some other balancing lines you can enter the number of the entry on the new line
that you are entering.
In such a case the whole line stays Draft until the whole set balances to zero.






核销过程

The reconciliation operation consists of matching entries in different accounts to indicate that
they are related. Generally reconciliation is used for:


	matching invoice entries to payments, so that invoices are marked as paid and customers do not get
payment reminder letters for those entries (reconciliation in a customer account),

	matching deposits and cheque withdrawals with their respective payments,

	matching invoices and credit notes to cancel them out.



A reconciliation must be carried out on a list of accounting entries by an accountant, so that the
sum of credits equals the sum of the debits for the matched entries.

Reconciliation in OpenERP can only be carried out in accounts that have been configured as
reconcilable (the Reconcile field).


Tip

Do not confuse account reconciliation and bank statement reconciliation

It is important not to confuse the reconciliation of accounting entries with bank statement
reconciliation.
Account reconciliation consists of linking account entries with each other, while statement reconciliation consists of
verifying that your bank statement corresponds to the entries of that account in your accounting system.
You can perform statement reconciliation using the menu Accounting ‣ Periodical Processing ‣ Statements ‣ Statements Reconciliation.



There are different methods of reconciling entries. You have already seen the reconciliation of
entries while doing data entry in an account. Automatic and manual reconciliations are described
here.


自动核销

自动核销是让OpenERP自动从凭证行中按每个合作伙伴检索出金额相符的对应的双向凭证并标记为已核销.

Depending on the level of complexity that you choose (= power) when you start running the tool, the software
could reconcile from two to nine entries at the same time. For example, if you select level 5,
OpenERP will reconcile, for instance, three invoices and two payments if the total amounts correspond.
Note that you can also choose a maximum write-off amount, if you allow payment differences to be posted.


[image: ../../../_images/account_reconcile_auto.png]
自动核销界面



To start the reconciliation tool, click Accounting ‣ Periodical Processing ‣ Reconciliation ‣ Automatic Reconciliation.

自动核销弹出窗口后, 填写如下数据:


	核销科目(Accounts to Reconcile) : 选你将要核销的一个,几个甚至全部可以允许核销的科目,

	需要核销的数据时间范围 (起始日期(Starting Date) / 结束日期(Ending Date)),

	the Reconciliation Power  (from 2  to 9 ),

	允许销账(Allow write off) 是否将核销借贷方的差异进行销账处理.

	information needed for the adjustment (details for the Write-Off Move).




Note

Reconciling

You can reconcile any account, but the most common accounts are:


	all the Accounts Receivable – your customer accounts of type Debtor,

	all the Accounts Payable – your supplier accounts of type Creditor.





The write-off option enables you to reconcile entries even if their amounts are not exactly
equivalent. For example, OpenERP permits foreign customers whose accounts are in different
currencies to have a difference of up to, say, 0.50 units of currency and put the difference in a write-
off account.


Tip

Limit Write-off Adjustments

You should not make the adjustment limits too large. Companies that introduced substantial automatic
write-off adjustments have found that all employee expense reimbursements below the limit were
written off automatically!




Note

默认值

If you run the automatic reconciliation tool regularly, you should set default values for each
field by using the right-click mouse button in the web client (in edit mode) or the GTK client.
The resulting context menu enables you to set default values.
This means that you will not have to retype all the fields each time.






手工核销

For manual reconciliation, open the entries for reconciling an account through the menu Accounting ‣ Periodical Processing ‣ Reconciliation ‣ Manual Reconciliation.

You can also call up manual reconciliation from any screen that shows accounting entries.

Select entries that you want to reconcile. OpenERP indicates the sum of debits
and credits for the selected entries. When these are equal you can click the Reconcile Entries
button to reconcile the entries.



Note

Example Real Case of Using Reconciliation


Suppose that you are entering customer order details. You wonder what is outstanding on the
customer account (that is the list of unpaid invoices and unreconciled payments). To review
it from the order form, navigate to the Partner record and select
the view Receivables and Payables. OpenERP opens a history of unreconciled accounting entries
on screen.



[image: ../../../_images/account_sample2_entries.png]
Unreconciled Accounting Entries



After running the Reconcile Entries wizard, these lines can no longer be selected and will not appear when the                                entries are listed again. If there is a difference between the two entries, OpenERP suggests you to make
an adjustment. This “write-off” is a compensating entry that enables a complete reconciliation. You must
therefore specify the journal and the account to be used for the write-off.











For example, if you want to reconcile the following entries:


Entries for reconciliation
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财务分析


This chapter is dedicated to statutory taxation and financial reporting from OpenERP.
Whether you need reports about customers and suppliers, or statements for various statutory purposes,
OpenERP enables you to carry out a whole range of parametric analyses regarding the financial health of
your company.


Whether you want to analyze the general health of your company or review the status of an Account
Receivable in detail, your company’s accounts are the place to define your various business
indicators.

To show you the most accurate picture of your business, OpenERP’s accounting reports
are flexible, and the results are calculated in real time. This enables you to automate recurring
actions and to change your operations quickly when a company-wide problem (such as cash reserves
dropping too low or receivables climbing too high) or a local problem (a customer that has not paid,
or a project budget overspend) occurs.

This chapter describes the various reports and financial statements supplied by OpenERP’s
accounting modules. It also describes how OpenERP handles purchase and sales taxation, and the
related tax reporting.

For this chapter you should start with a fresh database that includes demo data,
with sale and its dependencies installed and no particular chart of accounts configured.
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总账和试算平衡表

A general ledger includes accounts with their debits and credits, and shows all transactions in an account, for one period, for several periods or for a financial year.

To print the General Ledger, you can use the menu Accounting ‣ Reporting ‣ Legal Reports ‣ Accounting Reports ‣ General Ledger.
You will find the following wizard which is used to filter the resulting report.


[image: ../../../_images/account_wizard_report.png]
Preparing a General Ledger



Select the proper options and journal(s) from the above wizard to print the General Ledger. The report can also be filtered by date or by period. When you choose to print the general ledger from one date to another, or for one or more periods, you can also have the initial balances printed for the periods preceding the periods you selected.
You can sort the report by date or by journal / partner.


[image: ../../../_images/account_general_ledger.png]
General Ledger




Tip

General Ledger for one or more accounts

When you want to print the general ledger for one or more accounts, go to the menu Accounting ‣ Configuration -> Financial Accounting ‣ Accounts ‣ Accounts. Select the account(s) for which you want to print the general ledger and click the General Ledger report at the right side of the screen.



While the general ledger displays transactions for an account, a trial balance will show one amount (either debit or credit) for each account. The aim of the trial balance is to prove that the total of all debit balances is equal to the total of all credit balances.

To print the Trial Balance, go to the menu Accounting ‣ Reporting ‣ Legal Reports ‣ Accounting Reports ‣ Trial Balance.
This report allows you to print or generate a PDF of your trial balance, allowing you to quickly check the balance of each of your accounts in a single report. A trial balance may include all accounts (even the ones without balance), only accounts with transactions or accounts of which the balance is not equal to zero. You can print a trial balance for all posted entries (meaning entries with a Valid state) or all entries, in which case the report will also print entries in a draft state. This option is useful, for instance, when your new financial year has just been opened, and you are preparing miscellaneous entries in the previous financial year.


[image: ../../../_images/account_trial_balance.png]
Trial Balance




Tip

Reporting for One or More Accounts

You can print the Trial Balance report directly from the Account form too.






资产负债表和损益表

OpenERP also offers a Balance Sheet and a Profit & Loss Report.

A Balance Sheet is a financial statement that summarises the assets, liabilities and shareholders’ equity of a company at a specific point in time. These three balance sheet segments give investors an idea as to what the company owns and owes, as well as the amount invested by the shareholders.

The balance sheet complies with the formula below:

Assets = Liabilities + Shareholders’ Equity.

A balance sheet is often described as a snapshot of a company’s financial condition.

The accounts displayed in the Balance Sheet are linked to an account type for which the P&L / Balance Sheet parameter is set to Balance Sheet (either Assets or Liabilities account). To configure Account Types, go to Accounting ‣ Configuration ‣ Financial Accounting ‣ Accounts ‣ Account Types.

The Balance Sheet can be printed from the menu Accounting ‣ Reporting ‣ Legal Reports ‣ Accounting Reports ‣ Balance Sheet. You can print this report in Landscape mode too.


Tip

Reserve & Profit and Loss Account

A Balance Sheet needs a reserve & profit and loss account, but instead of entering it each time you start the report, you can add a default Reserve & Profit and Loss account through the menu:menuselection:Settings –> Companies –> Companies on the Configuration tab. This account will be used as a counterpart to balance your accounts.



The Profit & Loss Report is a financial statement which gives a summary of the revenues, costs and expenses during a specific period of time. Such a report provides information that shows the ability of a company to generate profit by increasing revenue and reducing costs. The P&L statement is also known as an “Income Statement”.

The purpose of the Profit & Loss Report is to show managers and accountants whether the company earned or lost money during the report period.

In general, the Profit and Loss report will be used to determine profit ratios, to examine sales prices and costs, and to set marketing budgets, for instance.

The accounts displayed in the Profit and Loss Report are linked to an account type for which the "P&L / Balance Sheet parameter is set to Profit & Loss (either Expense or Income account). To configure Account types, go to Accounting ‣ Configuration ‣ Financial Accounting ‣ Account Types.

The Profit and Loss report can be printed from the menu Accounting ‣ Reporting ‣ Legal Reports ‣ Accounting Reports ‣ Profit And Loss.


[image: ../../../_images/account_profit_loss.png]
Profit and Loss Wizard




[image: ../../../_images/account_profit_loss_report.png]
Profit and Loss Report






账户分类账

A journal allows you to list entries in chronological order (by default according to date). Each entry posted in OpenERP is recorded in such a journal. To configure the different accounting journals, go to the menu Accounting ‣ Configuration ‣ Financial Accounting ‣ Journals ‣ Journals.


[image: ../../../_images/account_journal_form.png]
Defining a Journal



OpenERP provides three main reports regarding the journals:


	To print a Journal, use the menu Accounting ‣ Reporting ‣ Legal Reports ‣ Journals ‣ Journals. This report will show all entries per journal, e.g. sales entries, purchase entries, etc. Each transaction is mentioned, with date, reference, document number, account, partner, description and debit and credit amount. The Journal report can be printed per period and per journal.




[image: ../../../_images/account_journal_print.png]
Printing a Journal




	To print a General Journal, use the menu Accounting ‣ Reporting ‣ Legal Reports ‣ Journals ‣ General Journals. A General Journal will print a page per period for any journal entries posted in that period, and totalised per journal. The report will show the period, the journal, debit, credit and balance, but no details of the related entries.




[image: ../../../_images/account_gen_journal_print.png]
Printing a General Journal




	To print a Centralizing Journal, use the menu Accounting ‣ Reporting ‣ Legal Reports ‣ Journals ‣ Centralizing Journal. A centralizing journal gives a summary per account for each journal and period of debit, credit and balance.




[image: ../../../_images/account_cent_journal_print.png]
Printing a Centralizing Journal






纳税申报

Information required for a tax declaration is automatically generated by OpenERP from invoices. In the section on invoicing, you will have seen that you can get details of tax information from the area at the bottom left of an invoice.

You can also get the tax information when you open a journal entry by looking at the columns to the right of each line.


[image: ../../../_images/account_journal_vat.png]
Journal Entry with VAT Information



OpenERP keeps a tax chart that you can reach from the menu Accounting ‣ Charts ‣ Chart of Taxes. The wizard will propose to display entries for the current period only, but you can also leave the period empty to see a complete financial year. The structure of the chart is for calculating the VAT declaration, but all the other taxes can be calculated as well (such as the French DEEE).


[image: ../../../_images/account_tax_chart.png]
Example of a Belgian VAT Structure



The tax chart represents the amount of each area of the VAT declaration for your country. It is presented in a hierarchical structure which lets you see the detail only of what interests you and hides the less interesting subtotals. This structure can be altered as you wish to fit your needs.

You can create several tax charts if your company is subject to different types of tax or tax-like accounts, such as:


	authors’ rights,

	ecotaxes, such as the French DEEE for recycling electrical equipment.



By creating several charts of taxes, you can print different declarations from the menu Accounting ‣ Reporting ‣ Generic Reporting ‣ Taxes ‣ Taxes Report. Simply select the chart of taxes you want to print in the wizard.

Each accounting entry can then be linked to one of the tax accounts. This association is done automatically from the taxes which had previously been configured in the invoice lines.


Tip

Tax Declaration

Some accounting software manages the tax declaration in a dedicated general account.
The declaration is then limited to the balance in the specified period.
In OpenERP, you can create an independent chart of taxes, which has several advantages:


	it is possible to allocate only a part of the tax transaction,

	it is not necessary to manage several general accounts depending on the type of sales and the type of tax,

	you can restructure your chart of taxes as required.





At any time, you can check your chart of taxes for a given period using the report Accounting ‣ Reporting ‣ Generic Reporting ‣ Taxes ‣ Taxes Report.

Data is updated in real time. This is very useful because it enables you to preview at any time the tax that you owe at the start and end of the month or quarter.

Furthermore, for your tax declaration, you can click one of the tax accounts to investigate the detailed entries that make up the full amount. This helps you search for errors, such as when you have entered an invoice at full tax rate when it should have been zero-rated for an intracommunity trade or for charity.




管理指标

With OpenERP you can also create your own financial reports. This feature is now included in standard OpenERP. Go to Accounting -_> Configuration ‣ Financial Accounting ‣ Financial  Reports ‣ Account Reports and click Create.

Suppose we would like to create our company Balance Sheet. The first report to be created, should be a View report which will contain the final details. Keep the default Sequence 0.

Now create the Assets report, and set Balance Sheet as the parent for this report. Set the Sequence to 1.

Now create the Liabilities report, and set Balance Sheet as the parent for this report too. Set the Sequence to 2.

Both these reports are of the View type.

Apart from the View type, you can select three other types: Accounts, Account Type and Report Value.


	Accounts: here you can select view accounts or individual accounts that should be included in the report. View accounts offer the advantage that when new accounts are added as a child of such view account, they will automatically be printed on the report. When selecting individual accounts, you need to specifically add each newly created account to get the correct report.

	Account Type: selecting an account type means that all accounts related to the selected account type(s) will be printed on the report.

	Report Value: thanks to this value you can include the balance of existing reports in another report. Example: create a profit & loss report (view) including costs (account class 6) and income (account class 7). In the Balance Sheet, define a report Profit&Loss Balance, with Balance Sheet as the Parent. Set the type to Report Value and link it to the P&L view report you defined. This way, the balance sheet will print the Profit&Loss result.




[image: ../../../_images/financial_reports.png]
Financial Reports



Create a report to print the Asset accounts (class 2 from the Belgian ledger) on the Assets side of the report. As a Parent, define the Assets report; sequence 3, type Accounts. If you want to use all accounts of class 2, just select the class (view account). You can also select various asset accounts. You could also have set this report to Account Type, with type Immo.

If you just want the sum of the selected accounts to appear, you leave the settings as they are. Should you wish to print the account details as well, you can select the Display details checkbox. The report will then also print the selected account numbers.

To print the results, go to Accounting ‣ Reporting ‣ Legal Reports ‣ Accounting Reports ‣ Financial Report. Select the report you want to print (only reports of the View type will be displayed in the list). You can also print a report for specific periods or dates. If you select the Enable Comparison checkbox, an extra Comparison tab will appear in which you can, for instance, select periods from a previous financial year. You have to give the comparison column a name through the Column Label field.


[image: ../../../_images/account_fin_report.png]
Example of a Financial Report
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良好的预算管理

对于公司来说，预算是非常重要的，使你能很好地控制并预计费用和收入。他们使你能衡量财务状况相对于计划的实际表现。

OpenERP 使用总账和辅助核算来管理预算
进入菜单 设置Settings ‣ 模块Modules ‣ 模块Modules 并安装模块 account_budget 就可以做这些工作了.

The first step in defining budgets is to determine the general accounts for which you want to keep budgets (typically expense or income accounts).
That is what you will use Budgetary Positions for, from the menu Accounting ‣ Configuration ‣ Budgets ‣ Budgetary Positions. Here you can select the general accounts for which you want to keep budgets. The aim is to group general accounts logically, according to sales or purchases, for instance. OpenERP has no limitations as to the account types that can be used for budgeting.


[image: ../../../_images/account_budget_pos.png]
Budgetary Position for Sales



要开始预算, 点击菜单 会计(Accounting) ‣ 预算(Budgets) ‣ 预算(Budgets), 点击 新建(New) 按钮可以创建一张预算单据.


[image: ../../../_images/account_budget_form.png]
乐观预算




Tip

预算的版本管理

虽然你 可以 在任何时间进行预算的修改,但我们还是推荐只是做创建一个新的预算,这样才可以很明了地看到预算的整个修改历史.

Rather than edit an existing budget, make a new version so that you can keep your original estimates safe for comparison. This lets you analyse your changing perspectives of the company from revision to revision.



创建一张预算单后,输入 摘要(Name), 编码(Code), 起始日期(Start Date), 终止日期(End Date) . 然后将你要纳入预算管理的某个会计期间的辅助核算科目及预算金额全部一条条地填写进去(注意: 采购类的需要输入一个负数金额):


	an Analytic Account

	a Budgetary Position, for example Sales or Purchases,

	a Start Date and an End Date for the budget,

	a Planned Amount in the default currency of the chart of accounts.



上述信息完成后, 保存该预算单.

预算各阶段的流程:


	确认(Confirmed): 表示预算已审核通过,但还是可以随时进行预算修改.

	Approved: the budget is approved by the budget holder; the name of the user approving the budget will be displayed in the Validate User field.



如果觉得不合适,你随时可以在前面两种状态下, 取消(Cancel) 该预算单后再将其 置为草稿.


	完成(Done): 完成状态的预算单就不允许再做任何修改了. 而且也不能再取消后置为草稿了.



The Theoretical Amount indicates the actual amount that might have been realised for the budget concerned according to the current date. When your budget is 1200 for 12 months, and today is the 30 October, the theoretical amount will be 1000, since this is the actual amount that could have been realised to date.

To print a budget and make calculations of expenditure through budget, use the menu Accounting ‣ Budgets ‣ Budgets. OpenERP then gives you a list of available budgets. Select one or more budgets and then click Print Budgets to create the report for each, in a date range of your choice.

The Print Budget report gives an overview of each analytic account included in your budget, according to the individual budgetary positions for that account. From the percentage and the comparison of planned (budgeted) and practical (actual) amounts, you have a good view on your situation.

From the same list of actions, you can also print the Print Summary report, which will give you a total per analytic account (without splitting by budgetary position).

Each of these reports can be printed from a specific date to a specific date. The End Date selected in the wizard determines how the theoretical amount will be calculated; if you select the last day of your financial year, the theoretical amount will be calculated as a function of that date (thus considering a complete financial year). Note that the theoretical amount will be zero when the Paid Date entered is equal to or greater than the End Date for the budget.

The percentage for a budget is calculated as follows: (practical amount / theoretical amount) x 100.
This way you get a view on how much of the forecasted amount has been actually realised in your accounting.

The figure Printing a Budget gives an example of a budget produced by OpenERP.


[image: ../../../_images/account_budget.png]
Printing a Budget




[image: ../../../_images/account_budget_summ.png]
Summarised Budget



You could also use the menu Accounting ‣ Reporting ‣ Generic Reporting ‣ Budgets ‣ Budget Lines.
This gives an analysis of each budget line.

From the menu Accounting ‣ Configuration ‣ Budgets ‣ Budgetary Positions, you can print the budgets for an individual budgetary position. Open a budgetary position, and click the Budget Lines tab for a graphical representation of your budgetary position.


[image: ../../../_images/account_budget_graph.png]
Graphical Representation of Budgetary Position




Note

Print Reports

You can also print budgets from the menu Accounting ‣ Configuration ‣ Analytic Accounting ‣ Analytic Accounts.






会计仪表板

You can open the Accounting Dashboard in more than one way: either by clicking the Accounting button at the top of the web screen, or from the menu Accounting ‣ Reporting ‣ Dashboard ‣ Accounting Dashboard.


[image: ../../../_images/account_board.png]
Accounting Dashboard



OpenERP gives you an accounting dashboard that will be presented to your accounting staff as they sign in to the Accounting system (you can also set the dashboard as their Home Page by setting the Home Action to Accounting Dashboard in the User form). This dashboard provides an analysis of the company’s financial health at a glance.

The description of the different parts of the dashboard, from top to bottom, then from left to right, is as follows:


	Customer Invoices to Approve : gives the list of invoices waiting to be approved by an accountant.

	Company Analysis : lists the debit, credit and balance of all account types.

	Treasury : shows the balance per Bank account in graphical view.

	Aged Receivables : gives a weekly graph of the receivables that have not yet been reconciled.



For most of the panels of the Accounting Dashboard, you can click a line or a graph to investigate the detail of your financial indicators.

The Accounting Dashboard is dynamically integrated, which means that you can navigate easily through the data if you want more detail about certain factors, and edit the entries if necessary.

The Change Layout button at the top right allows you to change the way the dashboard is displayed; you can choose among several options, such as one column, two columns, etc.
You can also add other features to the dashboard and customise it to your needs with the Add Widget button. You can easily Undo changes or Reset the original dashboard.
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成本分析

There are various reports designed for financial analysis based on the analytic accounts. Most of these reports are available directly from the tree of analytic accounts or from the form view of the analytic account.

From the Accounting ‣ Configuration ‣ Analytic Accounting ‣ Analytic Accounts menu, select one or more analytic accounts and then click one of the reports in the Reports section at the right side of the screen.
OpenERP provides the following financial analyses from the analytic accounts (and maybe more, depending on the additional installed modules):


	Cost Ledger,

	Inverted Analytic Balance,

	Cost Ledger (only quantities).

	Analytic Balance,




Note

Menu

At the time of writing, there is no separate menu to print analytic reporting.




成本账

The cost ledger provides the entries in general accounts for the selected analytic account(s). It enables you to make a detailed analysis of each operation carried out on one or several projects.


[image: ../../../_images/analytic_cost_ledger.png]
Cost Ledger






反向辅助核算余额

The inverted analytic balance provides a summary report relating general accounts and analytic accounts. This report shows the balances of the general accounts broken down by the selected analytic accounts from date / to date.


[image: ../../../_images/analytic_balance_inverse.png]
Inverted Analytic Balance



This enables you to analyse your costs by general account. For example, if you examine your general account for staff salaries, you can obtain all your salary costs broken down by the different analytic (or project) accounts.




成本费用总账 (仅数量)

This report gives the details of entries for an analytic account and a list of selected journals.
Only quantities are reported for this analysis, not costs and revenues. In the wizard you can select from period and to period and one or more journals.


[image: ../../../_images/analytic_cost_ledger_quantity.png]
Cost Ledger with Quantities Only



The report is often used to print the number of hours worked on a project, without exposing the costs and revenues. So you can show it to a customer as a record of the hours worked on a particular project.

To restrict the report to hours worked, without including sales and purchases, select only the services journal in the printing options.


Tip

Multiple Printing

To print several analytic accounts at once, you can make a multiple selection on the different accounts in the tree of accounts. Then
click the appropriate Report in the toolbar (in the web client), or select one of the Print reports (in the
GTK client), to export the whole selection into a single PDF document.






辅助核算余额

The analytic balance is a summary report that relates the analytic accounts to the general accounts. It shows the balances of the analytic accounts broken down by general account for a selected period. The analytic balance allows you to display a breakdown of each project by operation in the general accounts. Quantities are printed too. You can choose to include accounts without a balance as well.

When you select the analytic chart itself (the main analytic account), you can print the analytic balance for the entire analytic chart of accounts.


[image: ../../../_images/analytic_balance.png]
Analytic Balance



This report gives you the profitability of a project for the different operations that you used to carry out the project.


Tip

Multi-company

In a multi-company environment, each company can have its own general chart of accounts on the same database.
The two general charts of accounts are independent, but can be linked in a third chart using a view account to do the consolidation.

If the different companies collaborate on joint projects, they may all share the same analytic chart of accounts.
In this environment, the cross-related reports like the balance and inverted balance are extremely useful, because they enable you to make an analysis per company by linking up to the general accounts.






辅助核算账簿

From the Accounting ‣ Configuration ‣ Analytic Accounting ‣ Analytic Journals, select one or more analytic journals and click the Analytic Journal report at the right side of the screen. This prints a report per analytic journal from debit and credit (general account versus analytic account).


[image: ../../../_images/analytic_journal.png]
Analytic Sales Journal






辅助核算分录分析

You can have the statistical analysis on all analytic entries from the menu Accounting ‣ Reporting ‣ Statistic Reports ‣ Analytic Entries Analysis. By default, analytic entries are grouped by analytic account and month, but you have many options to sort and regroup analytic entries. You can, for instance, first group the information by general account, then by analytic account.


[image: ../../../_images/analytic_entries_analysis.png]
Statistical Report for Analytic Entries




Tip

Graph

You can easily turn this analysis screen into a graph by clicking the Graph button at the top of the screen.
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一步一步配置会计


会计科目可按公司要求配置
本章介绍如何修改会计科目表, 分类账, 权限, 初始余额和会计初始设置的默认值。


良好的会计软件需要很大的实用性和简单的数据录入，以及灵活配置不同的组件。
您应该能够很容易的修改会计模块来满足自己的需求，这样就可以按您想要的方式使用它。

OpenERP让您适应和重新配置很多功能以方便您录入数据:


	为数据项增加控制,

	自定义屏幕,

	系统通过已知数据的查询自动填充字段.





	会计期间和会计年度
	定义一个会计期间或者会计年度

	期末结账





	管理税务结构

	会计科目表
	使用预配置的会计科目表

	建立会计科目表

	虚拟会计科目表





	账簿
	配置账簿

	数据录入的控制和提示





	支付条款

	会计年度的启用和结账
	在一个已有的 OpenERP 配置中，逐步启用一个新的会计年度

	生成期初分录

	会计年度结账





	逐步启动会计年度

	使辅助核算项到位
	设置科目表

	创建辅助核算账簿

	默认辅助核算项(方案)
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会计期间和会计年度


Note

会计期间和会计年度

会计年度 (或财务年度) 对公司而言相当于12个月。
在许多国家，会计年度对应于一个日历年度。而另外一些国家不是这样。

财政年度可分为每月或每3月的会计期间（当你需要一个季度报表时）。



OpenERP的会计年度管理具有足够的灵活性，使您能够在一次创建几个会计年度。这给您一些优势，如可以建立为期三年的预算。


定义一个会计期间或者会计年度

定义会计年度，使用菜单 会计(Accounting) ‣ 配置(Configuration) ‣ 财务(Financial Accounting) ‣ 会计期间(Periods) ‣ 会计年(Fiscal Year) .
您可以提前创建多年的会计年度以便定义长期的预算。


[image: ../../../_images/account_period.png]
定义会计年度和会计期间



先输入会计年度的第一天和最后一天。然后，要创建会计期间, 单击两个底部的按钮中的一个，取决于您需要创建12个1个月还是4个3个月的会计期间:


	按月创建期间(Create Monthly Periods),

	按季创建期间(Create 3 Months Periods) .



OpenERP的自动创建一个初始会计期间，让您录入您的上一财年的余额。请注意这个会计期间 年初/年末 会计期间(Opening/Closing Period) 复选框。




期末结账

要关闭会计期间,，比方税收申报已经做好，到菜单 会计(Accounting) ‣ 配置(Configuration) ‣ 财务(Financial Accounting) ‣ 会计期间(Periods) ‣ 会计期间(Periods).
点击绿色的箭头就可关闭已没有业务需要处理的会计期间。


Tip

打开关已关闭的会计期间

系统管理员可以重新打开一个因错误操作关闭掉的会计期间。



当一个会计期间处于关闭状态，在该期间您不能增加或修改任何业务。并不是必须要关闭会计期间，您可以简单地让会计期间一直保持打开状态。

要关闭会计期间您可以使用菜单 会计(Accounting) ‣ 定期处理(Periodical Processing) ‣ 期间扎账(End of Period) ‣ 关闭期间(Close a Period).
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管理税务结构

本章节处理法定税收和公司通用会计科目的有关问题:


	OpenERP中提供的税制结构，



您可以在交易中增加税款，那样您就能:


	在付款或收款金额中包含税款,

	生成您应向税务机关缴纳的各种税收报告,

	在总帐中跟踪税收情况,

	用OpenERP处理其他货币交易一样的机制来管理付款和退税.



由于税收机制的细节是执行政府政策、为国家积聚税款的一种机制，因此税收规定和税务报表可能很复杂。OpenERP有灵活的机制来满足不同地区的税务要求。

税收机制也可以用于处理类似税收的交易，比如通过一个科目基于交易额的作者的版税。

通过菜单  Accounting ‣ Configuration ‣ Financial Accounting ‣ Taxes  您可以定义您的税收结构。 注意如果您使用预定义（本地化）科目表，多数情况下都已经定义好了税收。

OpenERP的税收机制围绕三大概念运行:


	Tax Code (或 Tax Case), 用于纳税申报， 可以设置成具有树状结构，这样多个税务代码可以像 Chart of Accounts  （会计科目表）一样显示。 税务代码用来定义您的VAT统计表，可以为数字或字母，您可以通过菜单  :menuselection: Accounting –> Configuration –> Financial Accounting –> Taxes –> Tax Codes   定义税务代码。

	Taxes, 在业务中包含计税规则的基本税务概念，它和总帐科目和税务登记号有关。税种下面包含多个税目，不同的税目使用不同的计税规则，因而具有很好的灵活性。

	General Accounts, 用于记录缴纳的税款。由于总帐科目并非是税收特有的，在本书中其他章节也有说明，所以本节不再详细阐述。



您可以为商品设置0至多个 Purchase Taxes 和 Sale Taxes ，这样您可以分别统计采购税和销售税（增值税进项税和销项税，增值税是商品流通环节价值增加而产生的税收）。由于可以设置多个税种，所以您可以对同一商品分别同时处理增值税和消费税。

创建新 Tax Code，使用菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Taxes ‣ Tax Codes 。 您应当定义如下字段：


[image: ../../../_images/account_def_tax_code_form.png]
Tax Code




	Tax Case Name: 用于区分税目的唯一名称，通常来自于增值税申报表，

	Case Code: 用于该税目的一个可选的短的编码,

	Parent Code: 关联到上级税目的代码，用于树状结构，可通过菜单  Accounting ‣ Charts ‣ Chart of Taxes  显示

	Not Printable in Invoice: 一个复选框，允许您以表明链接到有关税务代码的任何税项不应该被打印在发票上，

	Coefficient for parent: 选择 1.00 用于增加到上级科目或选择 -1.00 以从上级科目减少，

	Description: 用于说明的一段文本。



您还会看到两个只读字段：


	Period Sum: 显示本会计期间本税目税款合计数。

	Year Sum： 显示本会计年度本税目税款合计数。



您可能需要为已经定义的每种税率定义两个税务代码，一个用于税收本身，另一个作为发票的计税依据 (所谓的计税基础)， 而且您也可以创建不关联到任何税的税务代码 (类似于总帐科目中的 View  类型) 仅用于组织树形（或层次）结构。

要查看您创建的结构，您可以使用菜单 Accounting ‣ Charts ‣ Chart of Taxes.
此树状视图反映了 Tax Codes 的结构，并显示所选择的会计期间或一个完整的会计年度里目前的纳税情况。


Taxes 被用来定义计算和他们关联的业务的税额，以及他们关联到的总帐科目（通常是增值税科目）和税务代码，既为计税基数又包含税额。


要创建一个新的税，使用菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Taxes ‣ Taxes.


[image: ../../../_images/account_define_tax_form.png]
定义税种



您定义如下字段:


	Tax Name: 本税需要的唯一名称（比如 21% Purchase VAT ），

	Tax Code: 这个税的可选的代码（比如 VAT IN IC ），

	Tax Application: 定义税种是否适用于 Sale, Purchase or All 业务，

	Tax Included in Price: 当选中，显示在商品或发票上的价格将包含这个税，

	Tax Type: 一个必需字段，表明如何计算此税的税额: Percentage,
Fixed Amount, None, Balance or Python Code, (您可从 Special Computation 页签中找到 Compute Code ），

	Amount: 一个必需字段，意思是根据税收计算类型，若 Tax
Type 是 Percentage则税款额为纳税基数乘上税率，当 Tax Type 是 Fixed Amount则以固定金额增加到纳税基数上。

	Invoice Tax Account: 一个用于记录发票上税额的总帐科目， 这可能是多个税使用同一个科目，或按比例分割以便每一税种分配一个科目，

	Refund Tax Account: 一个用于记录发票上退回税额的总帐科目， 其可以是同一个发票税科目，或按不同的税务管辖区分拆成不同的科目，

	Tax on Children: 当选择时税额计算是根据 Child Tax Accounts 的计算结果决定的 （因此您可以有税上税），否则是根据业务金额计算的，

	Include in base amount: 当选上时，税收是加在计税基数上而非单独显示，比方Eco税，

	Child Tax Accounts: 可用于计算税额的其他税项。




Tip

使用子税

当您有一个复杂的税收情况有多个税收代码时您可以使用子税。



以上您提供的税务字段可在总帐中反映，但并不能提供税务机关可能需要的信息。使用 Tax Definition 页, 部分税务申报: Invoices and Credit Notes to define to which tax codes the tax should be assigned:


	Account Base Code: 记录计税基数（不含税）的税收代码，

	Account Tax Code: 记录计算出来的税收金额的税收代码，

	Refund Base Code: 记录计税基数（不含税）退回数的税收代码，

	Refund Tax Code: 记录退回税额的税收代码



当您创建了一个由税务代码和税组成的税务体系后，您可以在各种与税关联或类似税务业务中使用税， 比如生态税（比如回收处理和Bebat）。


Tip

零售客户

当您零售给最终用户而非销售给公司时，您也许希望（或必须）在您的发票上显示含税价格而非不含税价格再加税。



您可以为一种商品制定多个税，假定您已经创建了适当的税，您可以使用菜单 Sales ‣ Products ‣ Products 打开并编辑 Product 定义，然后:


	为您将销售的商品选择一个或多个 Sale Taxes ,它可能包含 Sales Tax  or Output VAT and a Sales Eco Tax ,

	为您将采购的商品选择一个或多个 Purchase Taxes ，它可能包含 Purchase Tax  or Input VAT and a Purchase Eco Tax .



通常您采购或销售时，会自动计算该分配给该商品的税种的应缴税额或抵扣金额（如进项税）。

您也可以指派多个税种到一个会计科目，这样这个会计科目发生业务时您可以自动计算指派的税收金额。 这个概念可以很容易的应用于邮寄没有商品的采购发票时。

与产品和科目关联的税收通常是国内税。 OpenERP is capable of automatically converting national taxes to intracommunal or export taxes through the concept of Fiscal Positions.

Go to the menu Accounting ‣ Configuration -_> Financial Accounting ‣ Taxes ‣ Fiscal Positions. You can use the fiscal positions to automatically convert national taxes to the required intracommunal or export taxes, according to the fiscal position specified for the customer or supplier.

Fiscal positions allow you to make a mapping from national taxes to intracommunal or export taxes, or to map your accounts according to these criteria. You can link fiscal positions to your customers and suppliers to ensure automatic and easy VAT conversion when posting entries.
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会计科目表

配置软件时，OpenERP允许您选择预定义的会计科目表，其中包括所有的基本配置，如税收法规和财政状况。当然，你也可以定义自己的会计科目表。


使用预配置的会计科目表

在安装时，软件可以让您从许多的预定义好的科目表中选择一个默认的会计科目表。 要安装（大多数情况下）贵国的会计科目表以及税种定义，需从 Installation Wizard 中选择符合贵国的列表。 Generic Chart of Accounts 提供一个默认（但有限）的科目表，可作为任何国家科目表的基础。 Chart of Accounts 列表中还包括了很多本地化的会计科目表。


[image: ../../../_images/account_chart.png]
采用通用会计科目表



该向导将根据您所选择的科目表而有所不同。 您如果使用 Generic Chart  将可以添加一个税率，但不适合您安装以下以下案例时，举例说，名字为 Belgium - Plan Comptable Minimum Normalise. 这里的OpenERP也会自动安装比利时税务定义。您也许希望，当增加一个新的产品时可以选择默认的销售和采购税种。


[image: ../../../_images/account_chart_be.png]
采用比利时科目表



请记住，即使您使用默认的会计科目表，您仍然可以修改它以满足您的需求。


Note

模块

您也可以从模块列表中安装一个科目表，要这样在此只需要简单地跳过安装向导。 模块名会类似 l10n_XX ，这里 XX 是表示国家代码的两个字母。 例如,要得到比利时科目表, 通过 Settings ‣ Modules ‣ Modules 安装模块 l10n_be。 结果和通过向导 (Belgium - Plan Comptable Minimum Normalise) 可取得同样的科目表。



许多预定义的科目表是完整且准确的，但也有一些处于试验状态和仅仅显示其可能性如此定义。 您可以修改它们，或在默认科目表上定义自己的科目， 或根据自定义的科目表修改其中项目。




建立会计科目表

通过菜单 Account Types, 创建科目类型来确定年底结帐时科目余额的处理方式。

要增加，修改或删除已存在的科目类型得通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Accounts ‣ Account Types.


[image: ../../../_images/account_type.png]
定义科目类型



用于定义科目类型的字段如下：


	Account Type: 科目类型名称。



	Code: 科目类型编码。



	PL/BS Category: 这个类型确定科目将打印在在何种报表中 (比如资产负债表和利润表)。 共有五种类型可选: 无类型 (/), 平衡表 (资产科目 = active), 平衡表 (负债科目 = passive), 损益类 (收入) 和 损益类 (成本)。



	Deferral Method: 这个字段表明在年度结转时如何及是否结转科目余额。



	None 意味本科目余额不会被结转. 通常用于损益类科目.

	Balance 表明年底科目余额会被结转。通常用于资产负债表科目。

	Detail 表明每一条分录都会被结转到下年。

	Unreconciled 表明只有未核销净的（仍有余额）的分录会结转到下年。 通常用于往来类科目。








	Sign on Reports: 这个字段允许您保留科目的符号，比方收入科目会被显示为正数而非默认的负数，使用 Reverse balance sign 来完成这个。（译注：收入类科目默认发生方向为贷方，国外软件常常在余额表中显示成借正贷负，这个选项类似与国产财务软件中的借贷方向选项）





使用 View 类型来创建科目层次结构，不能用于数据录入。

要增加，修改或删除已存在的会计科目得通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Accounts ‣ Accounts.


[image: ../../../_images/account_form.png]
定义会计科目



科目涉及的主要的字段:


	Name: 科目名称。



	Code: 科目编码数字的位数不受限制. 0为顶级科目的编码。



	Parent: 确定哪个科目是本科目的上级科目， 这样可创建树型科目表。



	Internal Type: OpenERP中有特殊作用的内部类型。正常情况下，有如下类型可选：

View 可用于创建科目（组）的层次结构（译注：非末级科目）,
Regular 不适合别的类型的科目; 大部分科目用于此类型（译注：一般是末级科目）,
Receivable - Payable: 这些类型用于标明汇总科目（用于客户和供应商）会被设置成明细到每一业务伙伴,
Liquidity 用于标明资金类科目(银行存款和现金科目),
Consolidation 用于创建虚拟 (或合并) 科目表,
Closed 标明不再使用的科目。



	Account Type: 选择如上所述相应的科目类型是很关键的。 这会对年底结转和生成报表时产生影响。



	Secondary Currency: 这个科目上的发生数强制使用这种外币。 注意您也可通过菜单 Accounting ‣ Configuration ‣ Miscellaneous ‣ Currencies 定义汇率。



	Outgoing Currencies Rate: 仅当您增加了一个外币时选择。您卖出外汇时有两个选项： At Date 或 Average Rate。买入外汇总是按业务日期 At Date 计算。



	Allow Reconciliation: 决定可否核销这个科目的分录。 为应收应付科目以及其他需要核销（不包括银行对账单）的科目激活这个字段。



	Default Taxes: 使用这个科目用于采购和销售的默认税,它使得在手工录入会计分录时系统可以自动给出税金分录。





科目的树形结构可以随时按需更改，而无需重新计算其中的任何分录。因此，为更好的反映公司财务状况，您可以在一个会计年度中轻松更改科目结构。

您可以通过菜单 Accounting ‣ Charts ‣ Chart of Accounts ，选择会计年度，会计凭证，会计期间，并点击 Open Charts 查看科目一览表， 点击一个科目可下钻到该科目的明细帐。


Note

分层图表

大多数财务软件都是以列表的形式显示会计科目表，在OpenERP中当然也可这样做，但它的树形图具有如下优点：


	它能让您只显示您感兴趣的科目的细节，

	它能够让您获得一个全局的科目视图（当您只显示各科目的汇总时），

	它更加直观，因您能够基于分类进行查询，

	它更加灵活，因您能更容易对他们重新构建。





会计科目的结构是分层的，还有被称为 View 的拥有小计功能科目（译注：有子科目的非末级科目），您可以配置一套只包含您感兴趣的会计科目表。

要获得科目的明细数据对您是非常重要的，您要做的就是点击科目代码或是名称。

显示会计科目表可能需要好几分钟，因为OpenERP是实时计算每个科目的借方、贷方和余额的。




虚拟会计科目表

会计科目的结构是受国家相关的法律制度制约的。不幸的是，这种结构不总是符合公司的需要。

在OpenERP中，您可以在使用相同的会计科目的同时使用虚拟会计科目的概念来管理一些不同的数据展示形式。这些展示可以实时的反映而不需要额外的数据录入。

因此普通会计科目表能够遵守您的国家的制度章程，同时您公司的CEO可以根据需要使用基于一般会计科目的其他虚拟科目。例如，CEO能够为每一个部门创建1个视图，1个现金流和流动资产视图，或者合并不同公司的科目。

虚拟会计科目最有趣的情况是，它能够被用来为整个组织与默认的会计科目拥有相同的方式。例如，您可以从您的合并科目或从您的某个公司的科目来创建预算。


Tip

虚拟科目

虚拟科目能够让您提供一个或多个已存在的会计科目的不同展示格式。创建或重组虚拟科目不影响会计凭证。您可以无风险的使用虚拟科目在修改普通会计科目或未来的会计凭证。

因为他们是被用作相同记录的不同表达方式，他们将非常有用:


	实时合并多个公司数据,

	根据企业投资者的科目表生成报表,

	折旧计算,

	现金流视图,

	获得比那些基于法定的报告更有用的视图,

	为其他用户根据他们权限展示汇总图表.



因此这是一个重要的原因，即通过虚拟的科目展示财务交易的执行，诸如预算和基于公司的特殊视图的财务指标。



创建一个新的会计科目表，您需要通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Accounts ‣ Accounts 创建一个根科目。您的顶级帐户应该有一个名字，一个代码（不同于当前科目表中任何其他科目代码，一个 Internal Type 和 Account Type  View。 然后您可以根据自己的需要创建其他科目， Account Type View是必须的。如果您想从其他科目映射过来，则 Internal Type 应设为 Consolidation  。检查您的虚拟结构通过裁断 Financial Management ‣ Charts ‣ Charts of Accounts 并从屏幕顶部的下拉框中选择相应的科目表

要映射您的虚拟科目表到您的总帐科目，您必须将 Internal Type 设置成 Consolidation 。 通过 Consolidated Children 您可映射科目或创建合成类科目。 在 Consolidated Children, 您可以增加 View 类科目或末级科目，如果您增加了一个 View 科目成合成类科目的子科目， OpenERP 会自动包括该总帐科目中已经存在的和未来增加的子科目。


[image: ../../../_images/account_virtual.png]
Virtual Accounts Mapped to View Account



您既可以在通用会计科目上又可以在虚拟科目上运行 Trial Balance 和  General Ledger 报表从不同的视角审视公司。普通科目的所有动作和状态同样对虚拟科目有效。

最后，您还可以基于另外一个虚拟科目创建一个虚拟会计科目。这样能够提供一个附加的财务分析维度。
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账簿

所有的会计分录需要由会计帐簿来显示。因此您应该为销售发票创建销售分类帐， 为客户退货创建销售红字分类账, 为供应商发票创建采购分类帐， 为供应商欠条创建采购红字分类账以及为银行业务创建一个银行分类账。


配置账簿

要查看，编辑或创建新分类帐，使用菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Journals ‣ Journals.


[image: ../../../_images/account_journal_form1.png]
定义会计分类帐



蓝色字段均为必填字段。当您选择了分类帐类型，将被预置一些配置参数。 分类帐类型告诉系统有关分类帐可用于何处。

每一分类帐都有显示数据的特殊方式。 分类帐类型决定分类帐视图，也就是表明哪些字段需要显示出来和输入会计数据。视图确定字段的顺序和每个字段的属性。 比如, 字段  Statement  在银行分类帐录入数据时会出现，但不会出现在别的分类帐中。

您还可以创建自己的分类帐视图。 然而，在创建新的视图前，最好检查一下有没有已经定义的类似的视图。您应该仅为新分类帐类型创建新的视图。

您可为每一分类帐创建序号。 这个序号为会计分录自动设定号码。 如果您想将多个分类帐定义成使用同一个序号（如果您允许这么做），它们可以使用同一套序号。


Tip

序号编码

序号可通过 Settings ‣ Configuration ‣ Sequences & Identifiers ‣ Sequences 创建。
默认情况下， OpenERP 的分类帐定义中仅有一个序号。 如果您需要在分类帐中保存两个不同的序号，您可安装 account_sequence 模块。



当您通过 Journal Items 录入数据时，默认贷方或借方科目可自动生成对方分录。 在一些分类帐中，借方科目或贷方科目是强制性的，比如在银行日记账中您必须写入相关的银行科目，这样你就不必手动创建每个业务的对应科目。

一个分类账可以标记为集中式的。当您这样做时，相匹配的分录不仅被每张凭证拥有，而且针对给定的分类账和会计期间是全局性的。当您在其中一个分类账中将贷方行和借方行做了集中式标记后，这意味着贷方和借方会在同一行上显示。这个选项常用于开账分录。


Note

银行日记帐，容易配置

在您定义您公司的银行帐户事可自动创建银行日记帐。到 Accounting ‣ Configuration ‣ Financial Accounting ‣ Accounts ‣ Setup your Bank Accounts， 这里您可创建您公司银行帐户的银行帐号或IBAN号。 录入银行名称，那么当您保存时，您的银行日记帐会连同银行名称和科目代码一起自动创建，  这家银行的总帐帐户也会创建。






数据录入的控制和提示

在OpenERP中您有两种方式可以控制分类帐————科目控制和组用户权限控制。除了这些控制之外，您也可启用所有的标准用户权限管理。

为避免在错误的科目中录入会计数据，您可以在总帐科目中设置哪些分类帐可以使用给定的会计科目的条件。 要做到这一点，你必须在第二个页签  Entry Controls 中列出所有有效的科目或科目类型。 如果您没有在此添加任何科目， OpenERP 在分类帐中的会计科目是没有任何约束的。 如果您列出在分类帐中可以使用的科目以及/或科目类型， OpenERP 阻止您使用任何不在该列表中的科目或科目类型。 这一校验步骤从您录入数据时开始， 您仅可选择允许的科目或科目类型。

这一功能通过分类帐中可以使用的科目可限制数据录入中发生错误的可能性。


Tip

数据录入控制

在帐务处理过程中，允许直接从银行A到银行B的会计分录不是一个好主意。如果您录入了银行A直接到银行B的会计分录，则这个分录会被记账两次。

要避免这个问题，通过中间科目C，在数据录入时，系统检查银行分类帐中可接受的科目类型: 只有非 Bank 类型的科目才会被接受。

如果您的财务人员定义了这种特性，则非会计人员不可从一个银行帐户划款到另一银行帐户，这可降低风险。
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支付条款

您可以在OpenERP中根据您的需要定义付款条款。 付款条款确定发票的到期支付日期。

要定义付款条款，使用菜单 会计(Accounting) ‣ 配置(Configuration) ‣ 其它(Miscellaneous) ‣ 付款条件(Payment Terms) 再点击 新建(New).

下图中付款条款后的数字代表天数: 5天内5000, 在本月内支付50%，剩下的在下月15日支付。


[image: ../../../_images/account_payment_term.png]
配置付款条款



要配置新的条款，首先在 Payment Term 中给付款条款一个名称。 在 Description on invoices 中输入该付款条款的简单说明，该说明将被发票所使用。

在 Payment Term 部分新增单独的一行以创建新付款条款。您必须给每行提供一个名称 Line Name . 这些信息并不会对付款条款的实际计算产生影响。  Sequence 字段允许您定义计算规则的顺序。

每行中 Valuation 字段能让您计算付款金额:


	Percent : 本行表明此次付款占总金额的百分比，百分比在 Value Amount 字段中提供， Value Amount 中的取值必须在0到1之间.

	Fixed Amount : 这是一个给定在 Value Amount 中的固定金额.

	Balance : 表明本次付款金额是除去以前付款金额的余款.



仔细思考为何设置最后一行为Balance ， 可以避免舍入误差。顺序号最大的最后计算。

最后两个字段, Number of Days 和 Day of the Month, 能为每一行提供计算延期处理方法。 延期的 Day of the Month 可设置成 -1 , 0 或其他正数。比如，如果今天是2010年12月20日，并且您希望像以下所示设置付款条款：


	5天内5000: 设置 Valuation 为 Fixed Amount, Number of Days 设置为 5 并且 Day of the Month 设置成 0。 则将在2010年12月25日创建一条会计分录。

	50% payment at the last day of current month: 设置 Valuation 为 Percent, Number of Days 为 0 并且设置  Day of the Month 为 -1。 则将在2010年12月31日创建一条会计分录。

	Remaining on 15th of next month: 设置 Valuation 为 Balance, Number of Days 设置成 0 并且  Day of the Month 设置成 15。  则将在2011年1月15日创建一条会计分录。



您可以在合作伙伴的 Accounting 页签将付款条款指定给合作伙伴.
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会计年度的启用和结账

在会计年度结束时，您必须将该年度的期末余额结转成新的会计年度的期初余额。 OpenERP允许您自动生成该分录。您可以多次结转期初余额，因为一次就关闭一个会计年度是不可能的。由于余额会变化因此需要相应修改开账分录。新的余额可很容易地通过一个向导结转，因此您不必记住在以前会计年度中的每一次修改。


Note

OpenERP会计

以下步骤对您已经在OpenERP中具有一个有会计凭证的会计年度有效。




在一个已有的 OpenERP 配置中，逐步启用一个新的会计年度

在为您的每个科目生成期初余额之前，您需要经过多个步骤。


	创建新的会计年度



创建新的会计年度在 定义一个会计期间或者会计年度 中有详细解释。


	定义一个打开的会计期间



通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Periods ‣ Periods 为一个您想打开的会计年度创建新的会计期间 (假设会计期间没有自动生成)。确保会计期间联系上了新定义的会计年度。 选择 Opening/Closing Period 选项框标明 该会计期间用于期初分录。两个日期通常和您的会计年度的第一天相同(比如 01/01/YYYY).


	检查科目类型



生成期初分录之前，确认检查过定义的科目类型，具体说是科目的结转方式， Deferral Method.
结转方式决定了是否和如何将余额结转到新的会计年度。有四种可能的结转方法：不结转, 余额结转, 明细结转, 未核销部分结转。







	结转方式
	动作




	None
	不结转 (常用于损益类科目)


	Balance
	仅结转科目余额(通常是有余额的科目)


	Detail
	所以分录都结转，包括已核销分录


	Unreconciled
	仅结转在新会计年度第一天核销后余额(典型的如应收应付科目)






	检查科目与科目类型之间的联系



检查是否每个科目都设置成了正确的科目类型以避免生成错误的期初分录。


	创建一个 Opening/Closing Journal



通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Journals ‣ Journals。
创建一个新的分类账来存放期初分录。 请务必遵守以下规则:



	Type 应为 Opening/Closing Situation。

	Standard debit/credit account 应为类似“140000 Benefits”。

	Centralised counterpart 当你选择分类账类型时会自动选上，以避免在每一行上有副本，并代替相应的开账科目的一个解放和贷方分录。

	在保存时会自动创建 Entry Sequence 。









生成期初分录

OpenERP提供了一个向导以根据您实际的帐簿自动生成期初分录。在菜单 Accounting ‣ Periodical Processing ‣ End of Period ‣ Generate Opening Entries。

在向导中，输入您想结转余额的会计年度 (Fiscal Year to close)。 然后选择 New Fiscal Year (您要生成期初分录的会计年度)。 您还必须选择提交期初分录的帐簿和会计期间。会生成默认的期初分录摘要，当然您也可以输入您自己的摘要，比如 “YYYY年期初分录” 。 最后您点击 Create 按钮即可根据您的设置生成期初分录。

要检查自动生成的草稿状态的期初分录，通过菜单 Accounting ‣ Journal Entries ‣ Journal Entries . 点击 Unposted 按钮可过滤出仅草稿状态的分录。打开相应的分录并校验数据。点击 Post 按钮确认分录。


Note

上一年度有变化

只要审计工作还在进行，就有可能在已关闭的会计年度中增加额外的分录。要自动获得正确的余额，OpenERP允许您使用 Cancel Opening Entries 向导，这个向导会自动取消已经存在的期初分录。

要更新余额显示正确的结果，需要您再次运行 Generate Opening Entries:guilabel: 向导，新的期初分录将包含正确的余额。这样，您可根据需要多次生成期初分录。






会计年度结账

要关闭一个会计年度，使用菜单 Accounting‣ Periodical Processing ‣ End of Period ‣ Close a Fiscal Year.
一个向导会询问您将关闭的会计年度的信息。

一旦关闭了一个会计年度，您将不能在该年度中新增或修改任何业务。因此切记务必在关闭会计年度前备份数据库。关闭会计年度并非强制性需要，并且当您的会计报表已经交给法定当局，而且不再做任何修改后，您可以在下一年度中任何时候做这件事情。


[image: ../../../_images/account_fy_close.png]
关闭会计年度








逐步启动会计年度

一旦您决定使用OpenERP中的会计模块，您就拥有了一个会计系统，您应该输入您的期初余额和未结分录到OpenERP中。请确保您按配置一章所言初始化好您的会计模块。下面我们简单讲解有关起初余额和未结分录的配置。


	创建新的会计年度



创建新的会计年度在 定义一个会计期间或者会计年度 中有详细解释。


	定义一个打开的会计期间



通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Periods ‣ Periods 为一个您想打开的会计年度创建新的会计期间 (假设会计期间没有自动生成)。确保会计期间联系上了新定义的会计年度。 选择 Opening/Closing Period 选项框标明 该会计期间用于期初分录。两个日期通常和您的会计年度的第一天相同(比如 01/01/YYYY).


	检查科目类型



生成期初分录之前，确认检查过定义的科目类型，具体说是科目的结转方式， Deferral Method。
结转方式决定了是否和如何将余额结转到新的会计年度。有四种可能的结转方法：不结转, 余额结转, 明细结转, 未核销部分结转。







	结转方式
	动作




	None
	不结转 (常用于损益类科目)


	Balance
	仅结转科目余额(通常是有余额的科目)


	Detail
	所以分录都结转，包括已核销分录


	Unreconciled
	仅结转在新会计年度第一天核销后余额(典型的如应收应付科目)






	定义科目表



检查科目表中的每一个有余额的科目是否设置成正确的科目类型。我们建议您定义一个或多个临时科目来结转上以会计年度的未清分录。为每一临时科目勾选 Reconcile ，因为他们的余额将为0。


	创建一个 Opening/Closing Journal



通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Journals ‣ Journals。
创建一个新的分类账来存放期初分录。 请务必遵守以下规则:



	Type 应为 Opening/Closing Situation。

	Standard debit/credit account 应为类似“140000 Benefits”。

	Centralised counterpart 当你选择分类账类型时会自动选上，以避免在每一行上有副本，并代替相应的开账科目的一个解放和贷方分录。

	在保存时会自动创建 Entry Sequence 。







	为未结分录创建一个采购和/或销售帐薄



我们建议您分别创建采购和销售分类帐以便存入您以前的会计系统中未清分录，这将有助于您轻松跟踪您的期初分录。

通过菜单 Accounting ‣ Configuration ‣ Financial Accounting ‣ Journals ‣ Journals.
创建一个新的采购和销售分类帐类记录未清分录，请务必遵守以下设定：



	Type 应为 Purchase or Sales.

	Entry Sequence 会在保存时自动生成。






现在您可以根据自己在年末的未清分录录入客户和供应商往来。

通过菜单 Accounting ‣ Customers ‣ Customer Invoices 录入您的未清销售分录。要录入您的未清的采购分录，通过菜单 Accounting ‣ Suppliers ‣ Supplier Invoices.

我们建议您使用临时科目来代替费用或收入科目。实际上，您的费用和收入科目在上以年度末已经被结转过了，没有必要结转它们的余额到下一年。上一年度的未清分录应该不会包含VAT（增值税）分录；仅包含客户应付给您的余额，或是您应该支付给供应商的余额。


	录入期初余额 (其他分录)



对每一个需要重新打开的科目在分类帐中录入科目数字（借方或贷方），要这样做，得通过菜单 Accounting ‣ Journal Entries ‣ Journal Entries 并选择其他分类帐。


Tip

导入

如果您从其他会计软件中转出科目余额表的话，您还可以使用的OpenERP的通用导入工具。
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使辅助核算项到位

为能更好的初始化辅助核算您应该做到:


	设置会计科目表,

	创建不同的分类帐,

	将辅助核算关联到分类帐上.




设置科目表

开始进入OpenERP之前请选择最时候贵公司的辅助核算方案。要创建不同的辅助核算项，使用菜单 Accounting‣ Configuration ‣ Analytic Accounting ‣ Analytic Accounts 并点击 Create 按钮。
注意您创建辅助核算项时看到数据依赖于您已经安装的模块。


[image: ../../../_images/account_analytic_form.png]
配置辅助核算项



要创建一个辅助核算项，您必须完成如下字段：


	（辅助核算项）名称,

	Code/Reference: 用于选择辅助核算项的快捷方式,

	Parent Analytic Account: 使用这个字段来定义不同辅助核算项的层次结构。

	Account Type: 就像通用科目表一样,  View类型仅用于创建用于层次结构和数据汇总的虚拟项目，不能用来录入数据。  Normal类型用于包含数据的辅助核算项。



如果一个辅助核算项（特别是一个项目）有时间限制，您可以在此定义一个开始时间和结束时间。


Maximum Time 可用于一个有固定持续时间的合同。



Tip

发票

在OpenERP中你有几种方法可用于自动发票：


	服务型公司通常因采购订单，辅助核算项或项目管理任务而开具发票。

	制造业或贸易企业经常因发货或客户采购订单而开具发票。
orders.



如需要项目发票的更多信息，请参阅有关项目和服务管理的书（即将发布）。



一旦您定义了不同的辅助核算，您就可以通过菜单 Accounting ‣ Charts ‣ Chart of Analytic Accounts 查看清单。 您可以一个会计年度中一个或多个会计期间的辅助核算项目。


[image: ../../../_images/account_analytic_chart.png]
辅助核算表




Tip

设置辅助核算项

辅助核算项设置画面可因安装在帐套中的模块而有很大不同。例如仅当您安装了 hr_timesheet_invoice 模块后才能看到有关收取服务成本费用的信息。

这些模块增加了一些对管理有用的针对辅助核算项的统计表。最有用的可能是模块 account_analytic_analysis ，它增加了利润率、发票金额和最新的服务日期和发票日期等信息。






创建辅助核算账簿

一旦为您的公司创建了辅助核算一览表那么您必须建立不同的帐簿。这谢帐簿可使您按不同类型的会计分录进行分录，比如：


	服务，

	费用报销，

	材料采购，

	其他指出，

	销售。




Note

最小分类帐

至少，您必须分别创建一个销售和采购辅助核算帐簿。如果您没有创建这两个帐簿，OpenERP不会验证关联到辅助核算的发票，因为它不能自动创建一个辅助核算分录。




[image: ../../../_images/account_analytic_journal.png]
创建辅助核算账簿



要定义辅助核算分类账，使用菜单 Accounting ‣ Configuration ‣ Analytic Accounting ‣ Analytic Journals 然后点击 Create 按钮。

很容易创建辅助核算分类账，进需给一个 Journal Name, 一个 Journal Code 和一个 Type. 可用类型有：


	Sale, 适用于销售给客户和欠款，

	Purchase, 适用于采购和费用,

	Cash, 适用于凭证分录,

	Situation, 开始运作时的调整科目, 或在本会计年度结束时,

	General, 其他分录。



辅助核算现在已链接到您的通用分类帐以便OpenERP放置辅助核算分录。比如，如果您在为客户录入发票，OpenERP 会自动搜索类型为 Sales的辅助核算关联到销售分类帐上。
通过菜单 Accounting‣ Configuration ‣ Financial Accounting ‣ Journals ‣ Journals 并选择比方销售分类帐。 在 Analytic Journal 中也选择销售辅助分类帐。


[image: ../../../_images/account_general_journal.png]
关联辅助核算分类账到分类账






默认辅助核算项(方案)

安装 account_analytic_default 模块后您可以在OpenERP中使用默认辅助核算项。 注意这个模块和 sale, stock 以及 procurement 模块有关联。

系统会根据以下条件选择辅助核算项:


	按 所选产品 产生默认

	按 所选业务伙伴 产生默认

	按 登陆用户 产生默认

	按 所选公司 产生默认

	按 日期 产生默认



您可以通过菜单 Accounting ‣ Configuration ‣ Analytic Accounting ‣ Analytic Defaults 并点击 Create 按钮创建这些标准。
根据您在此定义的条件，当创建订单或发票时系统将推荐正确的辅助核算项。


[image: ../../../_images/account_analytic_default.png]
提供条件以自动选择辅助核算项
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有效的运营管理


公司的管理是一个关于人力资源和工作流程的协调的过程，如果你希望公司能更高效，就必须有一个卓有成效的管理。
你必须组织它，使它系统化，并优化这些主要的流程。一些因管理不善造成的信息孤岛会影响整个公司的价值链。



这部分内容介绍了一些可以提高公司效率的途径，也提供了一些使用OpenERP解决具体的问题的方案。对于每一个企业，
OpenERP都可以自动归集任务，系统的解决复杂的工作流程，并且简化了信息的传输和控制成本。




	辅助核算

	人力资源管理的关键特性

	提供高质量服务

	很棒的项目管理
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辅助核算


作为公司流程的核心,分析会计（或成本会计）是您的操作管理的不可缺少的工具。与你的财务会计不同，他们为更多的会计
师服务,同时也适用于老板和项目经理们。


你需要一个通用的方法,将用户,服务和文档同公司的业务流程有效地整合到一起。在OpenERP里面,分析会计(也叫做管理会计或者
成本会计)提供这样一个通用的方法。

分析会计通常作为企业战略决策的基础。但因为这需要把所有信息集合到一起，在大多数系统的核心业务处理中，OpenERP的分析会计是一个有用的
管理工具。

这里有几点原因：


	反映整个管理活动,

	不同于财务会计，分析会计的结构不依据会计准则的规范制定，所以每个公司都可以调整适应自己的需要。




Note

独立于财务会计

在某些软件中，分析会计是财务会计的扩展 - 例如，通过使用帐户代码的最后两个数字来表示分析会计帐户。

在OpenERP的中，分析会计被关联到财务会计，但是被完全独立的对待。
所以，你可以使用各种不同的分析会计功能，不必在财务会计中有相应的分析会计科目。



虽然法律规定了财务会计科目表的结构，但分析会计科目可以更好更紧密地适应一个公司的需求。

正如在财务会计帐户，你会发现不同的分析会计科目产生各自的会计分录。每个会计分录可以关联到一个财务会计科目，正如你
所希望的。
相反，财务会计中的一个科目可以关联到一个，多个或没有相应的分析会计科目。

通过下面分析会计独立性的说明，你会发现它的许多优点。耐心点儿，这里是更多优势说明：


	你可以管理很多不同的分析操作，

	因为它的独立性，在经营活动中，你可以在任何时候修改分析计划，

	你能避免财务会计科目的爆炸行增长，

	即使是那些不使用OpenERP的财务会计功能的公司也可以使用分析会计管理业务。




Tip

谁受益于分析会计？

不同于财务会计，OpenERP的分析会计不只是记账工具，可以作为公司里面任何一个人的管理工具。 （这就是为什么他们
也被称为管理会计）。

分析帐户的主要用户应该是公司董事，总经理和项目经理。



分析会计提供了一个能在很多情况下使用的强大工具。关键是要建立你自己的分析会计科目表，和自身的需求密切配合。

在本章中，你应该使用一个包括了演示数据的全新数据库，安装`销售`及其依赖模块，并没有什么特别的会计科目配置



	公司辅助核算科目表
	案例 1: 制造行业企业

	案例 2:  律师事务所

	案例3: IT服务行业





	辅助核算凭证
	跟总账集成

	手工录入凭证

	自动生成凭证

	辅助核算模型
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公司辅助核算科目表

为了清楚地说明分析会计，将使用三个案例，分别应用在三个不同类型的公司：



	制造行业企业,

	律师事务所,

	IT服务公司.







案例 1: 制造行业企业

在工业中，你会经常发现分析科目表建立在部门和产品上，这也是公司建立的基础。

因此，目标是研究部门和产品的成本，销售和利润。结构的第一级由不同的部门构成，下级代表公司制造和销售的产品系列。


Note

工业制造公司的分析科目表


	市场部



	商务部



	行政部



	生产部



	产品系列1

	子产品系列

	产品系列2












在日常使用中，将每次采购发票标注到相应的分析账户是非常有用的。分析账户是采购成本的分配。当发票被核准时，它会自动生成财务和相应的分析账户的分录。因此，在每个总账分录上至少有一个分析账户分录以分配发生成本的部门。

这里有上面的例子中的一些的会计分录，归集到多个分析账户：


财务和分析会计分录明细（案例1）
  
    
    
    辅助核算凭证
    
    

    

 

















  
  

    
      Navigation

      
        	
          index

        	
          next |

        	
          previous |

        	OpenERP v6 

          	目录 

          	OpenERP 用户手册 

          	有效的运营管理 

          	辅助核算 
 
      

    


    
      
          
            
  
辅助核算凭证


跟总账集成

正如在总账，辅助核算分录必须属于一个会计帐户和一个辅助核算账簿。

通过以下几个特点辅助核算记录可以区别于普通会计记录：


	它们不一定是必要的会计凭证,

	它们不一定属于现有会计期间,

	它们根据它们自己的日期管理，而不是一个会计期间管理,

	它们不产生借方和贷方分录，而是一个正数金额（收入）或负数金额（成本）.




[image: ../../../_images/account_analytic_move.png]
为客户项目的分析账户记录



图 为客户项目的分析账户记录 的辅助核算会计记录了客户项目并为客户项目展示辅助核算会计中的分录条目。

你可以看到有:


	该项目工作人员的服务费用成本,

	报销去见客户往返程的费用成本,

	客户的购买的已交付货物,

	销售收回这些成本.






手工录入凭证

尽管大多数辅助核算分录目由其他Open ERP文件自动生成，有时使用手动记录分录还是必要的。它通常需要一定的分析操作，而它在总账
里没有对应的操作。

使用手动记录分录，请使用 会计 ‣ 账簿的分录 ‣ 辅助核算明细 Accounting ‣ Journal Entries ‣ Analytic Journal Items ，然后点击 新建 按钮。


Note

辅助核算记录

建立一条辅助核算记录，Open ERP要求你指定一个总账账户。这只是给不同的交叉报告一个信息。它不会在总账中产生任何新记录。



选择一个辅助核算并完成不同的栏目。把支出费用记为负数，收入记为正数。


Tip

输入日期

在编辑列表中选择输入一个日期，你可以在web客户端或者在GTK客户端中使用日历小工具，如果你只输入一个月中的某一天，
当您按下Tab键时Open ERP系统会自动填充年份和月份。




Note

成本的分摊示例

辅助核算操作中的手工录入数据分录的用途之一是成本分摊。例如，一个已交付的项目的研发，可再次使用在另一个项目上，你
可以分摊部分成本到这个项目上。

在这种情况下，在第一个帐户上做一个正数的分录，第二个项目的帐户上做一个相同数额的负数分录。






自动生成凭证

辅助核算会计与其他Open ERP模块完全集成，所以你永远不必重新输入记录。他们会自动生成以下操作：


	确认发票销售或采购生成辅助核算分录关联到帐户显示在发票行,

	关于服务的分录为这项特定项目的服务成本生成一个辅助核算分录,

	生产产品生成一个关于该产品范围内的每一项操作的生产成本分录。



其他文件关联到这三个操作中的任何一个产生间接的辅助核算记录。例如，当你进入客户的销售订单，你可以把它链接到客户的辅助核算
项。当您管理案子或项目时，把项目同订单做上标记。这个订单将生成客户发票，这将关联到辅助核算项。当发票得到确认时，它会自动
为相应的项目创建辅助核算会计记录。

来自雇员的费用收据可以关联到辅助核算项报销。当收据得到公司批准时，购买发票将会被创建。这发票作为员工福利登在公司的借方。
每一行购买发票自动链接到一个辅助核算项，分摊成本到相应的项目。

可视化以下各种动作的普通分录，您可以通过使用以下菜单之一来实现：



	查看的所有分录, 会计 ‣ 账簿的分录 ‣ 辅助核算明细 Accounting ‣ Journal Entries ‣ Analytic Journal Items

	查看每个帐户的分录，每个用户，每个产品或每个业务伙伴，你可以使用菜单 会计 ‣ 报告 ‣ 统计报表 ‣ 辅助核算分析 Accounting ‣ Reporting ‣ Statistic Reports ‣ Analytic Entries Analysis.







[image: ../../../_images/account_analytic_analysis2.png]
Analytic Entries Analysis






辅助核算模型

Standard OpenERP allows you to post analytic entries to one chart at a time. Using the Analytic Model concept (install the option Multiple Analytic Plans from the Add New Features wizard), you can distribute your income or expenses to one or several analytic charts of account at the same time.
You can define the combination of analytic plans through the menu Accounting ‣ Configuration ‣ Analytic Accounting ‣ Multi Plans ‣ Analytic Plan.


[image: ../../../_images/account_analytic_plan_61.png]
Definition of Analytic Plan



Using the link Distribution Models at the right side of the Analytic Plan form, you can define the distribution of either your expenses while creating a supplier invoice, or revenue when defining customer invoices.
Thanks to these models, you can have one amount distributed amongst several analytic accounts. Models can be reused, and they can be applied to one analytic chart of accounts, but also to a combination of various charts of account, such as projects and cost centers.


[image: ../../../_images/account_distribution_model_61.png]
Definition of Distribution Models



For example, when you create the invoice (suppose 1000 EUR) for the product Client Project with the analytic distribution defined above.

When the invoice has been validated, you can find the Analytic Journal Entries with the amount distributed amongst the analytic accounts through the menu Accounting ‣ Journal Entries ‣ Analytic Journal Items.


[image: ../../../_images/analytic_journal_entry_analytic_distribution_61.png]
Journal Entries with Distributed Amount



You can also specify a default Analytic Distribution for a particular product, partner, user and company for a specific time interval using the menu Accounting ‣ Configuration ‣ Analytic Accounting ‣ Analytic Defaults.
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人力资源管理的关键特性


本章描述OpenERP的主要人力资源及员工服务功能. 在财务分析的基础上, 有很多关于业务或项目方面的管理方案.


一个公司的有效性取决于其员工的优异的工作。OpenERP的人力资源模块，使您能够管理员工的工作效率的重要方面，
如他们的技能，合同，工作时间。

本章，您应开始一个新的数据库（包含演示数据）。在配置向导中配置人力资源模块时您需要勾选”Human Resources”项（译注：6.0版本的内容，6.1以后变化了）。


[image: ../../../_images/config_wiz_HR.png]
配置向导中的人力资源模块





	管理人力资源
	关联员工和OpenERP用户，促进权限的管理

	定义员工的账单价格和成本

	定义员工分类，给不同的员工组别指定不同的休假权限

	用合同起止日期、试用期来定义合同类型和工资类型

	管理考勤(上班/下班)





	招聘
	根据进来的邮件自动创建申请人并跟踪附件，如简历和求职信

	在招聘进程中定义阶段来跟踪进程

	定义下个动作以及日期

	跟踪申请人的邮件通信记录

	计划电话呼叫或者访问

	应聘者填写调查问卷（例如初步调查问卷）





	假期管理
	定义不同的休假类型

	管理假期申请和批准

	跟踪前面的请假

	允许员工输入他们自己的分配请求





	通过考评激励你的员工
	制定各种考核等级

	计划考评日期

	连接调查和工作考评





	考勤和计工单管理
	工作“上班”/“下班”管理考勤

	跟踪计工单和考勤的差异





	管理各种费用开支
	允许员工输入费用

	完善审批审核流程

	通过辅助核算在付给客户














          

      

      

    


    
         Copyright .
      Last updated on 2015-07-13 16:24:00.
      Created using Sphinx 1.3.1.
    

  

  
    
    
    管理人力资源
    
    

    

 

















  
  

    
      Navigation

      
        	
          index

        	
          next |

        	
          previous |

        	OpenERP v6 

          	目录 

          	OpenERP 用户手册 

          	有效的运营管理 

          	人力资源管理的关键特性 
 
      

    


    
      
          
            
  
管理人力资源

为了建立一个和整个公司管理系统集成在一起的系统，您需要建立当前员工的清单。


Note

不要混淆员工和用户

就OpenERP而言，所谓 员工 是指与公司签署劳动合同的自然人。包括所有类型的合同：长期的和临时的，也
包括全职的和兼职的。

所谓 用户 是指有权访问公司系统的自然人。绝大部分的员工是用户，但是一些用户却不是员工，例如外部
合作伙伴可以访问系统的部分模块。



一些取决于员工名单准确性的功能如下所示:


	服务成本，取决于员工的劳动合同,

	项目计划，取决于项目贡献者的工作模式,

	客户端计费率，可能取决于员工的工作职能,

	连锁的命令或者责任，与公司的分层结构相关.




关联员工和OpenERP用户，促进权限的管理

在OpenERP中使用菜单 人力资源(Human Resources) ‣ 员工(Employees) 中定义一个新员工.


[image: ../../../_images/service_employee_form.png]
员工详细信息表单



在 名称 框输入员工姓名和在 公司 框输入员工所在公司的名称。然后在 用户 中填写一个新用户从而建立一个新的ERP系统 用户 。

即使这个员工不是用户，最好也为该员工创建一个系统账号以便于您可以从一开始就掌控他们的访问权限（如果您需要您可以
通过这个字段这么做）。


Tip

员工和用户的关联

如果员工在系统中有用户名，你可以通过他（她）的用户名连接到员工表。

创建这个链接后员工模块中的相关界面中的 员工 字段能够自动完成，例如服务和费用记录。



输入员工地址.

这个出现在ERP中的合作伙伴联系表中，自员工与公司签订合同开始，他们就可以像数据库中其他合作伙伴一样有记录。因此在
合作伙伴联系一栏输入员工的名字和地址。然后所有的功能既适用于一个合作伙伴也适用于一个员工。这个对于跟踪账户中借贷
方特别有用-例如您可以跟踪薪酬支付。

你可以通过在 配置导向 中选择工时表安装 hr_timesheet_sheet ，帮助 员工们 编制和确认 工时表 和考勤。然后你可以在工时表中
为这个员工设立一个成本凭证薄和一个产品。如果你这么做了，这些信息将用于跟踪服务。现在，完成下列表单信息:


	Analytic Journal : 通常是一个 工时表日志,

	Product : 一个描述了这个员工被解除的服务产品，例如 工时服务表 。






定义员工的账单价格和成本

你首先必须要确认员工是系统用户，才能够使用工时表。员工基本信息包括必要的信息，例如职务和小时成本。

成本凭证薄 和 产品 这两模块有利于管理工时表.

所有关于服务次数成本的分析将保存在成本凭证薄中。它们能帮助你将服务成本与公司的其他成本分开，例如原材料的购买，
费用和分包。你可以通过部门或者功能给每个员工指定不同的成本凭证薄来区分成本。

员工也与ERP数据库中的一个产品相关联。一个员工与一个产品相关联，所以他们可以是 ‘购买’（分包）也可以是 ‘开票’（
项目管理）。你必须为每一个工作类型建立一个产品。

在产品界面中下列信息至关重要:


	名称 : 秘书 ， 销售人员 或者 项目经理 ,

	产品类型 : 服务

	计量单位 : 小时 或者 天

	成本价格

	销售价格

	成本计算方法 : 标准价格 或者  平均价格




Tip

价格指数

当在 产品 页面中 成本计算方法 是 平均价格法 时，你可以使用 成本价格 字段旁边的 更新 按钮打开更换成本价格的向导。



总之，每一个公司员工应该对应下列主要事项:


	合作伙伴

	员工 表,

	系统用户.



一个公司工作职位对应一个 产品 。


Note

工时价格

默认地，员工小时成本来自于员工对应产品的标准成本。
但如果你安装了 人力资源合同 hr_contract 模块，将可以管理不同的合同。当员工输入他们的工时数据时，员工的小时成本
将根据员工的雇用合同自动计算。

为此，软件中用一个因素定义合同类型（例如总月工资，每天计算）。理想地，这个因素应该考虑到工资
成本，税，保险和其他费用支付。






定义员工分类，给不同的员工组别指定不同的休假权限

（你必须为员工建立和分派类型）以便于（能够根据类型）分配和管理（离开和分配要求）。你可以在 人力资源 ‣ 结构 ‣ 人力资源 ‣ 员工 ‣ 员工分类 Human Resources ‣ Configuration ‣ Human Resources ‣ Employees ‣ Categories of Employee
中将 员工分类 。在分类框填入一个新的分类名称从而建立一个新的分类。一个分类也可以被分配一个 父类 。


[image: ../../../_images/employee_categories.png]
Example of categories defined for employees



从 人力资源 ‣ 人力资源 ‣ 员工 Human Resources ‣ Human Resources ‣ Employees 中找到员工将其归到一个 分类 中。在 分类 栏中，你可以通过选择 添加 和选定一个分类将一个员工归到
不止一个类别中。


[image: ../../../_images/employee_assign_category.png]
Assign categories to an employee in the Employee form



现在，当你在 人力资源 ‣ 假期 Human Resources ‣ Holidays 下面的菜单中建立一个新的 离开 或者 分配请求 ，如果你的 离开类别 或者分配类别是 员工类别 ，那么
你必须选者一个预先定义的 类别 。这个请求将适用于所有属于这个类别的员工。例如你可以为 学员 类别的员工建立一个分配要求，
使他们的离开少于其他员工。




用合同起止日期、试用期来定义合同类型和工资类型

如果你安装了 人力资源合同 hr_contract 模块，你就可以打开合同明细员工记录。这个模块的安装如下图所示:


[image: ../../../_images/config_wiz_contract.png]
Configuration wizard to install hr_contract



在 人力资源 ‣ 设置 ‣ 人力资源 ‣ 合同 ‣ 合同类型 Human Resources ‣ Configuration ‣ Human Resources ‣ Contract ‣ Contract Types 中建立一个新的合同类型。


[image: ../../../_images/hr_contract_type_list.png]
Contract Types list



你可以用同样方法在 人力资源 ‣ 设置 ‣ 人力资源 ‣ 合同 ‣ 工资类型 Human Resources ‣ Configuration ‣ Human Resources ‣ Contract ‣ Wage Type 中建立一个新的工资类型。在表格中输入下列信息:


	工资类型名称 : 一个工资类型名称.

	工资期间 : 选择一个预先定义的工资期间。工资期间在 人力资源 ‣ 配置 ‣ 人力资源 ‣ 合同 ‣ 工资期间 Human Resources ‣ Configuration ‣ Human Resources ‣ Contract ‣ Wage period 中设定。

	类型 : 毛工资 或者 净工资 。

	小时成本因素 : 根据每个员工的合同通过工时系统计算每小时工作价格。




[image: ../../../_images/hr_wage_type.png]
Wage Type form



你可以在 人力资源 ‣ 人力资源 ‣ 合同 Human Resources ‣ Human Resources ‣ Contracts 中建立和编辑合同。


[image: ../../../_images/service_hr_contract.png]
Definition of a working contract for a given employee



你可以输入员工雇用合同的信息，如下:


	合同编码

	职务名称

	工作安排

	开始日期

	结束日期

	薪酬结构 : 在预先定义的工资期间选择一个。

	合同类型 : 在预先定义的合同期间选择一个。

	试用期开始日期 : 开始日期为合同的试用期。

	试用期结束日期 : 结束日期为合同的试用期。






管理考勤(上班/下班)

在一些公司中，员工必须上班时签入，下班时签出。如果员工是系统用户，他们可以在ERP中使用 人力资源 ‣ 考勤 ‣ 签入/签出 Human Resources ‣ Attendances ‣ Sign in / Sign out
进行签字（签入/签出）。

如果一个员工下班时忘记签出，系统将在第二天他们准备下班签出时，建议他们手工签出。这是一个管理忘记签出的简单方法。

在 人力资源 ‣ 员工 Human Resources ‣ Employees 中的员工表格中找到员工考勤详情。

你可以使用下列有效记录，在ERP的员工表格中看到员工考勤详情:


	每月考勤

	每周考勤

	考勤异常记录



最后一份报告显示在考勤数据中输入的错误。显示员工是否手工输入进入或者离开时间以及事实和期望签出签入时间的区别。

第二份报告显示选定月份的考勤数据。
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招聘

使用ERP可以高效的管理招聘新员工的流程。可以很好的管理从最初接触到雇用应聘者的全部招聘过程。

你需要安装 人力资源招聘 模块 hr_recruitment 来高效地管理招聘流程。安装此模块的配置向导如下图所示:


[image: ../../../_images/config_wiz_recruitment.png]
安装人力资源招聘模块的配置向导



在 人力资源 ‣ 招聘 ‣ 申请人 Human Resources ‣ Recruitment ‣ Applicants 中显示申请人 申请表 Applicants 。


[image: ../../../_images/recruitment_applicant_form.png]
申请人申请表



你可以使用申请人申请表管理下列信息:


	申请人姓名

	申请的职位

	部门

	阶段: 初期工作要求, 工资协议, ...

	负责人: 面试人

	联系人 联系方式

	合同信息: 包括有效（天数），期望的薪酬，提议薪酬

	资格

	状态: 实际招聘状态: 新建 , 进行中 , 待定 , 拒绝 或者 录用



最初，申请状态是 新建 ，然后转变为 进行中 。如果申请人处于 等待人力资源部审批 或者 等待接受录用 的任何一种
状态下，申请状态是 待定 。当状态处于 录用 时，你就可以在员工列表中看到该申请人的详细材料。

职位信息 保存在 人力资源 ‣ 招聘 ‣ 职位 Human Resources ‣ Recruitment ‣ Job Positions 。


[image: ../../../_images/recruitment_job_position.png]
系统中的职位



在ERP中，使用 招聘模块 hr_recruitment 招聘新员工的主要功能有:


	管理职务职位和招聘过程.

	利用 调查模块 survey 为不同工作设定面试.

	利用邮件网关自动跟踪邮件发送到jobs@yourcompany.com.

	利用文件管理系统在简历库中保存和查找简历.



你可以通过 人力资源 ‣ 报告 ‣ 招聘分析 Human Resources ‣ Reporting ‣ Recruitment Analysis 分析招聘过程数据.


根据进来的邮件自动创建申请人并跟踪附件，如简历和求职信

你可以在 申请人申请表 中看到如何建立一个新的申请人。你也可以在ERP中安装电子邮件服务器从而在接收到邮件的同时建立新的
申请人。例如，如果你有一个邮件地址，你可以安装它，这样所有通过这个地址接收到的电子邮件将自动生成新的申请人。

因此，你可以通过 使用重新设置向导 和 在客户管理设置部分安装读取电子邮件设备 来配置安装 读取电子邮件模块 fetchmail 。

浏览 销售 ‣ 安装 ‣ 邮件 ‣ 邮件服务器 Sales ‣ Configuration ‣ Emails ‣ Email Servers 并且点击 新建 。 邮件服务器 表提供下列信息:


	名称 : 服务器配置名称.

	服务器类型 : POP服务器 或者 IMAP服务器 .

	添加附件 : 设置 真 可以检索到简历，求职信等附件.

	服务器 : 服务器地址.

	端口 : 服务器端口.

	用户名 : 电子邮件服务器用户名.

	密码 : 访问电子邮件账户的密码.

	模型 : 你希望生成的记录。这种情况下选择 申请人 （人力资源-申请人）.




[image: ../../../_images/recruitment_config_server.png]
配置一个电子邮件服务器



配置服务器之后，点击 确认 按钮启用此配置并且开始接收电子邮件

如果在安装好的电子邮件地址中接收一封新邮件，那么与此同时（一个与该新邮件主题相同的）新申请人主题名称被建立。申请人
电子邮件详细内容被保存（用于今后核对）。你可以添加更多的详情到这个工作申请中。你可以在 人力资源—招聘—申请人 Human Resources ‣ Recruitment ‣ Applicants 中查看
这些新建立的申请人并且通过点击 清除 键清除所有过滤器。电子邮件中的申请人在求职者数据中自动建立，电子邮件中的前三个
申请人被自动创建, 参见图: Job applicants automatically created from e-mails.


[image: ../../../_images/recruitment_from_email.png]
Job applicants automatically created from e-mails



由于您的服务器已安装添加附件，如果一个收到的电子邮件中包含 附件 ，它将会链接到相应的申请人记录。你可以在申请表
右侧附件部分找到。你可以点击附件打开。


[image: ../../../_images/recruitment_email_attach.png]
Applicant form with its corresponding attachments






在招聘进程中定义阶段来跟踪进程

很少会只是一个单独的见面或者一个电话之后就结束招聘。为了有个良好的结果通常一个招聘过程是一系列的筹划。你可以设定招聘
过程中会经历的阶段。使用 人力资源 ‣ 设置 ‣ 招聘 ‣ 阶段 Human Resources ‣ Configuration ‣ Recruitment ‣ Stages 来设定不同阶段。


[image: ../../../_images/recruitment_stages.png]
Defining recruitment stages



你必须给出 阶段名称 。当显示阶段明细时，使用 序列 领域给出序列指令。你也可以将 部门 与 阶段 联系在一起。你设定的阶段在申请表
的阶段领域可用。使用这个，你可以使持续的招聘过程有效地从一个阶段到另一个阶段。




定义下个动作以及日期

申请表 上的 下一个操作 和 下一个操作日期 字段允许你设定未来某个时间想要实施的行动。这可以提醒招聘主管接下来要做的事情和时间。




跟踪申请人的邮件通信记录

使用 应聘申请表 上的 联系与历史 栏，你可以添加上仅供内部参考的注释或者发送电子邮件给应聘者。你也可以在 历史 部分查看交流历史
和注解招聘申请。如果你在 全局抄送 字段中指定电子邮件地址，那么该电子邮件地址将（在所有入站和出站的电子邮件发送前）添加
到邮件的 抄送 字段中。你可以用逗号分隔多个电子邮件地址。

点击 添加内部说明 按钮建立一个内部说明。在弹出框中 添加 一个描述说明。你也可以在这里改变应聘状态。点击添加保存注解使其
可以在 历史 部分看到。

点击 发送新电子邮件 按钮给应聘者发送邮件。在弹出框中，你必须填入下列信息:


	From : E-mail address used to send an e-mail.

	Reply To : E-mail address for receiving a reply.

	To : The applicants e-mail address

	Subject : Subject of the e-mail. By default, it takes the subject of the recruitment application.

	Message : The message to send in the e-mail.




[image: ../../../_images/recruitment_send_mail.png]
发送电子邮件给应聘者



这里你也可以改变应聘状态。你也可以在弹出的 附件框 中添加附件。点击 发送 发送电子邮件。如图所示你可以看到一个对应列表:


[image: ../../../_images/recruitment_comm_history.png]
History of communication for the recruitment application






计划电话呼叫或者访问

使用 人力资源模块 hr_recruitment 的一个优点是你可以计划安排给未来的员工打电话和预约。这是由于其与 客户关系管理 crm 模块中的电话和会议功能
相结合的原因。

你可以通过点击  打电话 键从 应聘申请表 中安排一个电话。弹出框如下所示:


[image: ../../../_images/recruitment_sched_phone.png]
安排一个呼出电话给应聘者



你需要在弹出框中输入下列信息:


	分配 : 电话负责人.

	计划时间 : 打电话的日期和时间.

	目标 : 电话议程.

	类别 : 呼入 或者 呼出 (默认).



然后你可以点击 安排打电话 键创建一个打电话计划。如果你的打 电话类别 是 呼出 ，那么在 呼出 表中你可以添加更多的信息。一旦
确定打电话，你可以输入 持续时间 并且点击 确定 按钮。你可以通过 销售 ‣ 打电话 ‣ 呼出 Sales ‣ Phone Calls ‣ Outbound 来跟踪和进行你的打电话计划.


[image: ../../../_images/recruitment_outbound_phone.png]
Details of an outbound phone call to an applicant



就像你安排打电话一样，你也可以为应聘者 安排面谈 。在 应聘申请表 中点击 会见 键。 会见 表格中有一个会议日程。在这里，你可以
点击时间的空白处，确定你希望安排会议的时间。如图所示:


[image: ../../../_images/recruitment_sched_meeting.png]
为应聘者安排会谈



你可以从这张表格中管理以下信息:


	摘要 : 默认地招聘申请主题，当然你可以更改它.

	开始日期 : 面谈开始的日期和时间.

	结束日期 : 面谈结束的日期和时间.

	持续时间 : 面谈持续多少小时.

	地点 : 面谈地点.

	提醒 : 如果你想提醒面谈，你可以在面谈开始前设定会议提醒.

	描述 : 在这里你可以指定会谈内容.



在 邀请信息 栏，你也可以邀请参加会议的人。当你输入必要的信息后点击 保存 。然后你可以在日程中看到这个会议，如图所示:


[image: ../../../_images/recruitment_calendar_meeting.png]
日程中可以看到申请人的预约会议



你可以通过 销售 ‣ 会议 ‣ 会议 Sales ‣ Meetings ‣ Meetings 来跟踪和编辑你的会议。默认地，你将会看到会议的“月份形式的日历”。




应聘者填写调查问卷（例如初步调查问卷）

你可以将调查问卷作为面试应聘者的工具。为了能够让应聘者使用调查问卷，你必须首先通过 工具 ‣ 调查 ‣ 设定调查 ‣ 调查 Tools ‣ Surveys ‣ Define Surveys ‣ Survey 设定问卷。
点击  新建 打开一个新的调查表。你可以输入 调查标题 和 负责人 。


[image: ../../../_images/recruitment_job_survey.png]
调查表



一个调查可以有多页。每一页可以包含多个问题并且每一个问题可以有多个答案。不同的使用者可以给出不同的答案。你可以在 表格
的调查框中进行设定这些。当你在表格中输入必要信息后点击 保存 。面试时使用这个调查问卷，点击 打开 键更改调查问卷（从 草稿
到 打开 ）的状态。

然后，在 人力资源 ‣ 招聘 ‣ 职位 Human Resources ‣ Recruitment ‣ Job Positions 中选择应聘者应聘的岗位或者创建一个新的岗位。在 工作岗位 表格的 调查 字段中，输入你建立的调查
问卷名称，从而链接到这一工作的调查问卷并且在面试中使用该问卷。

现在你可以打开你希望进行初步面试的应聘者的表格。如果申请的  职位 与某个调查相连接， 答案 按钮将可用。点击它进行初步调查，
并且在应聘者回复中填写。调查问卷完成后，你可以点击申请者 申请表 上的 面试 按钮在PDF中查看应聘者回复。


[image: ../../../_images/recruitment_survey_answers.png]
The applicant’s response in a PDF file
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假期管理

你可以使用 hr_holidays 模块来管理员工假期，这个模块的安装配置向导如下图所示:


[image: ../../../_images/config_wiz_holidays.png]
hr_holidays模块安装配置向导



员工请假可以使用菜单 人力资源 ‣ 假期 ‣ 准假申请 Human Resources ‣ Holidays ‣ Leave Requests 来实现。

请假申请由员工建立，并由他们的主管来审核。一旦申请被审核通过，它就会自动出现在员工的日程表上。
你可以定义多种准假方式（如有薪假期，病假等）然后分别进行管理。

OpenERP 为高效的假期管理流程提供了如下的功能:


	帮助你管理假期及假期申请。

	与内部议程同步（使用 客户关系管理 crm 模块）是可能的: 你必须将准假状态与事实部分相连接，这样才可以当一个准假
申请被接受时它将自动生成事实。

	你可以根据你的假期类型设置不同的颜色，如“病假”可以在报表中显示为红色。

	员工可以通过 人力资源 ‣ 假期 ‣ 分配准假 Human Resources ‣ Holidays ‣ Allocation Requests 申请新的分配准假，从而申请更多的假期。



使用菜单 人力资源 ‣ 报表 ‣ 假期 ‣ 假期分析 Human Resources ‣ Reporting ‣ Holidays ‣ Leaves Analysis 可以查看假期统计报表。


定义不同的休假类型

你可以定义不同的请假类型，便于员工区分其请假申请。定义一个新的请假类型，点击菜单 人力资源 ‣ 设置 ‣ 假期 ‣ 请假类型,
然后点击 新建 按钮。


[image: ../../../_images/holidays_leave_type.png]
请假类型表单



你可以设置如下的信息：


	请假类型 : 请假类型的名称。

	报表中的颜色 : 请假摘要报表中显示的颜色。

	会议: 如果你选择了一个会议，一旦此申请被审核通过，日历中就会创建一个事件。

	二次审核 : 如果勾选此项，则此类型的申请均需要做二次审核。

	允许不顾限制 : 如果勾选此项，则此类型的申请中，员工享受的假期可以超过最大的限制值。



完成信息输入后，请点击 保存 按钮。




管理假期申请和批准

员工可以在 人力资源 ‣ 假期 ‣ 准假申请 Human Resources ‣ Holidays ‣ Leave Requests 中请假。你要在一个新的准假申请表中填入以下信息.


	说明 : 请假原因.

	模式 : 按员工 或者 按员工分类 .

	员工 : 如果准假分类是 员工 ，你必须选择一个 员工 .

	分类 : 如果请假分类是 员工分类 ，你必须选择 员工分类 .

	准假类型: 选择提前设置好的准假类型.

	开始日期 : 请假开始时间.

	结束日期 : 请假结束时间.

	天数 : 共请假天数(据 开始日期 与 结束日期 计算所得) .




[image: ../../../_images/employee_leave_request_form.png]
Leave Requests form



员工点击 确认 后将准假申请提交给他的领导等待审批。经理可以在 人力资源 ‣ 假期 ‣ 准假申请 Human Resources ‣ Holidays ‣ Leave Requests （还是“要审批的请假申请”）”中
找到等待审批的员工准假申请，可以点击 清除 或者 过滤器 。经理可以打开一个待审批的申请然后点击 拒绝 按钮拒绝申请或者点击
审批 按钮批准申请。如果是 双重验证 类型的准假申请，最后审批的经理将决定申请的最终结果，申请将从最后的 待审批 变为 已审批 或者 拒绝 。




跟踪前面的请假

在OpenERP的一系列方式中可以找到以前的假期申请。你可以在 人力资源 ‣ 假期 ‣ 准假申请 Human Resources ‣ Holidays ‣ Leave Requests 中看到所有用户的准假申请记录.
点击 清除 然后 生效 从而看到所有已批准的准假申请。看拒绝的申请，点击 清除 并且看到红色标记的记录。

在 人力资源 ‣ 假期 ‣ 分配准假 Human Resources ‣ Holidays ‣ Allocation Requests 中看到以前的分配准假，之后的操作流程同上。

在 人力资源 ‣ 假期 ‣ 准假摘要 Human Resources ‣ Holidays ‣ Leaves Summary 中，用同样的方法你可以找到以前的
准假摘要，但是仅限于当前登录的用户。默认地，你可以根据准假类型看到不同的申请分类。

在 人力资源 ‣ 报告 ‣ 准假 ‣ 准假分析 Human Resources ‣ Reporting ‣ Holidays ‣ Leaves Analysis 中可以看到请假统计纪录，并且根据员工和准假类型分类。点击 清除 看到
所有未分类的准假申请。

通过各种过滤和分类上述所有统计报告有助于你搜索到你需要的信息。你可以通过他们的 状态 （ 生效, 确认, 审批）， 员工 ， 部门
和 准假类型 来过滤申请。你也可以查看 当月 的申请。你可以通过 员工 ， 经理 ， 部门 ， 类型 和 状态 分类。


[image: ../../../_images/holidays_leaves_analysis.png]
Leaves Analysis statistical report



在 人力资源 ‣ 报告 ‣ 假期 ‣ 部门准假 Human Resource ‣ Reporting ‣ Holidays ‣ Leaves by Department 中可以看到完整的部门准假。你也可以选择一个 开始时间 ， 准假类型
（ 生效， 确认 或者 生效确认 ）并且至少喜欢则一个部门。点击 打印 将根据你的设置生成一个PDF文件。


[image: ../../../_images/holidays_dept_leaves.png]
Leaves by Department PDF report






允许员工输入他们自己的分配请求

为了能够休假，员工必须被分配一些可以利用的假期。通常管理会为员工安排一些休假。但是当一个员工由于特殊原因要在周末
上班，那么他将被允许在其他时间休假。这种情况下，员工被允许自己安排休假，但准假申请是否被批准由他的经理决定。如果
获得批准，那么员工根据该休假类型及限制进行休假。

在 人力资源 ‣ 假期 ‣ 分配准假 Human Resources ‣ Holidays ‣ Allocation Requests 中进行分配准假。需要完成下列信息:


	说明 : 请假类型名称.

	分配模式 : 按员工 或者 按员工分类 .

	员工 : 如果分配分类是 员工 ，必须选择一个 员工 .

	分类 : 如果分配分类是 员工分类 ，必须选择 员工分类 .

	准假类型 : 选择之前设置好的准假类型.

	天数 : 分配准假的天数.

	原因 : 说明原因.




	一旦申请被批准或者被拒绝那么其余部分是只读并且将获得细节。员工点击 确认 将分配准假发送给他的经理。此时申请将处于

	待审批 状态。




[image: ../../../_images/holidays_allocation_request.png]
Allocation Requests form



经理将在他的分配准假明细中找到申请。他可以点击 拒绝 拒绝该申请或者点击 审批 批准该申请.
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通过考评激励你的员工

员工的工作积极性可以提高工作效率，带来更好的收益。OpenERP可以通过定期考评员工绩效来激励员工的工作积极性。

定期的人力资源评价对员工和公司都有益。为了高效的定期评价员工绩效，你需要安装“人力资源-评价”模型。安装此模型的
配置向导如下图所示:


[image: ../../../_images/config_wiz_evaluation.png]
Configuration wizard to install hr_evaluation module



你可以在 人力资源 ‣ 评价 ‣ 评价 Human Resources ‣ Evaluations ‣ Evaluations 中建立和管理新的评价。


[image: ../../../_images/employee_evaluation.png]
Employee Evaluation form



为每个员工设定一个评估计划。这些评估计划都设定好频率和方式。你可以设定好评价步骤并且在每一步骤上都附带评价表格。
OpenERP可以管理所有类型的评价: 自下而上,自上而下,自评和经理终评。

OpenERP涵盖以下主要评价功能:


	建立员工评价表。

	员工可以建立发送给下级的或者经理的评价表。

	评价遵循评估计划，评估计划包含各种各样的问卷。每一特定级别的员工对应特定的问卷。最终由经理终评并确认评价完成。

	每个员工填写的评价表都可以用pdf格式查看。

	OpenERP根据评价计划自动生成评价申请。每个员工定期收到邮件，要求对他们的同事进行评价。



你可以通过 人力资源 ‣ 报告 ‣ 评估分析 Human Resources ‣ Reporting ‣ Evaluations Analysis 分析评估数据。


制定各种考核等级

在 人力资源 ‣ 设置 ‣ 定义复核 ‣ 评估计划 Human Resources ‣ Configuration ‣ Periodic Evaluations ‣ Evaluation Plans 中建立新的评估计划。点击 新建 并且完成下列信息


	评估计划 : 评估计划名称,

	初次评估月份 : 设定好评估计划后的首次员工评估时间,

	评估周期 : 上一次评估与下一次评估的间隔时间.




[image: ../../../_images/eval_evaluation_plans.png]
Evaluation Plans form



你还必须建立 评估计划阶段 ，让计划可以从一个阶段到下一个阶段，并且能很好的完成每个阶段的指令，例如发送电子邮件。你必须在
评估计划阶段安装下列设置:


	阶段 : 评估计划阶段名称.

	等待前面的阶段 : 你可以设定当前面的所有阶段完成后开始此阶段.

	序列 : 此阶段的序列号.

	操作 : 选择一个操作，可以是 自上而下的评估申请 ， 自下而上的评估申请 ， 自我评估申请 也可以是 最终评估 .

	评价表 : 链接到这个阶段的问卷.



如果你使用GTK-client,将可以打开评估计划阶段窗体视图.这里你可以自定义更多的设置,例如你是否想在这个阶段发送电子邮件。你也
可以选择发送这个阶段的结果给经理和员工。




计划考评日期


	一旦一个评价计划被建立，你可以使用它评价 员工 。在 人力资源 ‣ 评价 ‣ 评价 Human Resources ‣ Evaluations ‣ Evaluations 中建立一个新的评价。选择一个 员工 同时选择一个 计划 。在

	评估截止时间 选择一个评估截止时间。



虽然，评价提醒是根据 评价计划表 中的 第一个评价月 和 评价周期 进行提醒的。你可以用这些规范评价日期。




连接调查和工作考评


	一个评价计划是一系列的阶段，每一阶段对应一个评价表。这个评价表只不过是一个调查，一个通过问卷调查评估的工具。在

	工具 ‣ 调查 ‣ 定义调查 ‣ 调查 Tools ‣ Surveys ‣ Define Surveys ‣ Surveys 中设定调查。一个评价开始后，采访要求在评价计划的基础上自动创建。如果你要建立额外的采访要求，你必须将采访与 调查 相连接。这个调查可以处于任何状态（甚至是 草稿 ），但是要启用采访时，调查必须处于 打开 状态。
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考勤和计工单管理

在大多数使用OpenERP的服务公司中，服务表或者工时表改变了管理的一贯做法。这些服务表是由每个员工为正在运行的不同的项目建立
的。这些是通过系统中的一个分析账户来反映的。

一天中，员工需要将他们花在每个项目上的时间明细都添加在工时表中。一天结束后，员工必须记录他们当天所有的工作时间从而构成
一天的工作时间。如果（项目）账户不在系统中，那么工作时间不被计入任何指定的一天，而是另外记为小时。


[image: ../../../_images/service_timesheet_list.png]
Timesheet for a working day



此工时表 Timesheet for a working day 为一个员工工时表的例子。


Note

不要混淆工时表与考勤情况

工时表并不是一个考勤表。工时表无法控制超出的服务时间，如果员工愿意他们可以每天工作八小时，九小时甚至
更长时间。

如果你决定实行这个系统，那么一定要跟员工讲清楚这一点（工时表并不是考勤表），我们的目的不是控制时间，
因为时间是由员工自己输入的，但是任务运行和成本分配是由管理层负责的。



确保系统中的所有功能与 工时表 相关联，配置向导如下所示:


[image: ../../../_images/config_wiz_timesheets.png]
Configuration wizard for Timesheet



工时表系统的功能有很多，这里列举一些重要的功能:


	通过计算花在项目上的时间来跟踪项目的真实成本,

	追踪不同员工提供的服务,

	将项目真实的耗时时间与最初计划的时间进行比较,

	在服务时间的基础上自动提供进销存率

	获得指定客户端的服务时间明细

	获知运行公司所需的成本，例如市场成本，新员工培训成本以及客户进销存率.



工时表分类

你需要安装 制造应用（制造资源计划） mrp 从而访问工时分类。在 制造 ‣ 设置 ‣ 资源 ‣ 工作期间 Manufacturing ‣ Configuration ‣ Resources ‣ Working Period 中设定不同的工时表分类（工作会议时间）
并且可以选择一组（例如： 每周38小时 ）。


[image: ../../../_images/service_timesheet_def.png]
Timesheet category for full time 38 hours per week



输入工时表数据

为了充分使用工时表，可以通过在 重新配置向导 中选择 工时表 同时点击 设置 来安装 人力资源工时表 hr_timesheet_sheet 模块。一旦此模块被安装并且
设置好员工，那么不同系统的用户可以在 人力资源 ‣ 时间跟踪 ‣ 工作小时 Human Resources ‣ Time Tracking ‣ Working Hours 中输入他们的工时表数据，然后点击 新建 。


Tip

工时表快捷方式

使用工时表的所有员工可以将这个菜单放在他们的快捷方式中。因为他们每天要使用很多次。



一个新的条目:



	The 用户 : 本身是默认的，但是如果你编码的是公司其他员工的第一个工时表的话，你可以更改。

	The 日期 : 自动默认为当天日期，但是如果你要编码前一天的工时表，你也可以更改。

	帐户分析 : 运行中的项目，需要提前设定。

	描述 : 一个空白的文本文档用来描述工作时间。

	数量 : 时间单位数量（单位作为产品的一部分）。






其他字段将自动完成，但是可以修改： 服务产品 例如咨询，计量单位 （预定义的，也可能是分钟，小时或者天）， 服务成本
（默认计算地）以及相关的 普通账户。

每位员工可以编码一天的工作时间。它有助于在一天结束时再访明细从而确认工作时间的正确性。总输入的时间显示在服务小时明细的
右下角。


Tip

隐藏的服务成本

默认地，当员工编码每个项目的小时总数时，OpenERP会显示每个服务的成本。你可以通过在时间表视图中添加
invisible=True 来修改此字段。

其方法是要么修改文件系统上视图，要么使用网络客户端当前数据库中的修改视图。对于后者，在每个你可以访
问 管理视图 的表格的左下方有一个淡灰色 【自定义】 标识。如果你有足够的权限，你可以编辑设定当前视图的文
档。

成本中的价值显示的是员工为公司花费的时间成本，因此不应当总是隐藏此项。



服务输入的准确性对于计算不同工作的收益率和服务补给至关重要。不同的报告对于核对员工输入数据的准确性都很有用。员工可以使用
以下报告核对他们工时表:


	通过 人力资源 ‣ 报告 ‣ 工时表 ‣ 员工工时表 Human Resources ‣ Reporting ‣ Timesheet ‣ Employee Timesheet 打印指定员工工时表。

	通过 人力资源 ‣ 报告 ‣ 工时表 ‣ 员工工时表 Human Resources ‣ Reporting ‣ Timesheet ‣ Employees Timesheet 打印多个员工的工时表。你可以在每个用户每一天的表格中打印总表。




[image: ../../../_images/service_timesheet_all.png]
Employees’ monthly summary timesheet




	通过 人力资源 ‣ 报告 ‣ 工时表 ‣ 工时表利润 Human Resources ‣ Reporting ‣ Timesheets ‣ Timesheet Profit 审查工时表利润。

	你可以通过在 人力资源 ‣ 报告 ‣ 工时表 ‣ 工时表分析 Human Resources ‣ Reporting ‣ Timesheets ‣ Timesheet Analysis 与 人力资源 ‣ 报告 ‣ 工时表 ‣ 工时表分析 Human Resources ‣ Reporting ‣ Timesheets ‣ Timesheet Sheet Analysis 中使用统计报告分析你的每
时期的，每产品的，每账户的服务。




[image: ../../../_images/service_timesheet_graph.png]
Chart of timesheet by account



使用屏幕上方的过滤器可以使组成这个例表视图的数据不同。如果你想了解更多的细节，可以切换至图形视图。

计算服务成本

我们知道，工时表与成本科目（分析账户）密切相连。工时表中的各个项目与成本科目（分析账户）相一致。工时记录本身也是分析
（成本）记录。

这些记录包括各种不同于一般账户的分析操作。因此修改和创建工时表线的所有操作将自动影响相应的分析线，反过来，分析线上的
更改也将自动影响工时表线。


Note

工时表和分析数据

OpenERP中，有关于分析记录的工时表实施是由一个继承机制管理的:
工时表对象继承分析记录对象。

这样相同的信息不需要输入两次，避免了不一致的错误。
不过他们被存储在两个不同的表里，因为计工单一定是个成本凭证行，但成本凭证行不一定是计工单。



这不是传统的实现方式，但符合逻辑并且实用。员工的计工单是服务型企业在成本会计管理过程中分析服务成本在各个项目中分布的
重要指标。

成本科目应该在会计科目上反映，但成本科目与会计科目并非一一对应。取而代之的是，如果员工的每小时成本有了很好的预算，全月
的计工单条目余额应与月底支付给员工的工资加提成相匹配。

尽管如此，要精确计算出一个员工每小时的平均成本是很难的，因为它依赖于:


	额外的工作时间,

	假期或病休,

	工资变量及其他相关成本，如社保基数.



一系列的报表可以用于比对会计科目和成本科目的发生额，并且有利于你评估不同员工的工时成本。在成本科目上的产品余额与会计
科目上的产品余额的差异可以计入产品的成本。有些公司在月底用一个特殊的会计科目和另一个成本科目来处理这些差异。这个成本
科目的余额应该趋向于零。

因为你拥有了一个完整的计工单系统，所以你可以:


	追踪成本科目中项目的盈利,

	按项目或员工查找计工单的历史记录,

	定期通过与实际成本的比较来调整每小时成本,




Important

项目成本控制

严格控制项目的成本和利润是非常重要的。

有利于很好地估算以及为不同的服务产品和项目分配预算，如销售、研发。你还能通过清晰的证据来论证你的
理由而不是通过猜测来决定是不是应该在项目后期重新与客户讨论修正合同。



在成本会计模块中按项目或员工来分析盈利能力。分析的依据是所有的发票以及每个项目上花费的时间。


工作“上班”/“下班”管理考勤

在一些公司中，员工必须上班时签入，下班时签出。如果员工是系统用户，他们可以在ERP中使用 人力资源 ‣ 考勤 ‣ 签入/签出 Human Resources ‣ Attendances ‣ Sign in / Sign out 进行签字
（签入/签出）。

如果一个员工下班时忘记签出，系统将在第二天他们准备下班签出时，建议他们手工签出。这是一个管理忘记签出的简单方法。

在 人力资源 ‣ 员工 Human Resources ‣ Employees 中的员工表格中找到员工考勤详情。

你可以使用下列有效记录，在ERP的员工表格中看到员工考勤详情:


	每月考勤

	每周考勤

	考勤错误记录



最后一份报告显示在考勤数据中输入的错误。显示员工是否手工输入进入或者离开时间以及事实和期望签出签入时间的区别。
第二份报告显示选定月份的考勤数据。




跟踪计工单和考勤的差异

当工时表能够被正确使用时，它对于项目经理将是一个很好的控制工具，可以为其提供成本和次数意识。

员工团队很重要，因此必须执行一个控制体系。所有的员工都应该正确的完成他们的工时表，因为这是项目计划控制，财务管理以及
开发票的基础。

在 实现服务质量 提供高质量服务 中，月底你可以根据工时表自动开票。但同时，一些合同的预付时间是有限的。这些时间以及它们的扣减（从原始限制中的扣减）也是由这些工时表管理的。

这种情况下，没有编码到工时表中的时间反映了公司的亏损。所以建立后续的服务工时表及其编码是很重要的。你需要安装
人力资源-工时表-表 模块 hr_timesheet_sheet 从而建立一个使用工时表的控制体系（ 配置向导 中的 工时表 ）。


[image: ../../../_images/timesheet_flow.png]
Process of approving a timesheet



这个模型提供了一个新的过滤器使你能够通过周期管理工时表。工时表的记录由员工每天完成的。一个星期结束后，员工核实一周的
工时表然后发给服务经理批准。周期由公司设定，可以是一个月也可以是一个星期。

员工通过 人力资源 ‣ 时间追踪 ‣ 我的工时表 Human Resources ‣ Time Tracking ‣ My Timesheet 输入工时表数据。


[image: ../../../_images/service_timesheet_sheet_form.png]
Form for entering timesheet data



在屏幕的上面部分，用户可以进行签入和签出。系统掌控着每一天的考勤。屏幕左边的 签入 和 签出 按钮能够使时间自动完成。这些
时间可以由员工修改，所以它不是一个真实的管理控制系统。

屏幕底部是选定日期的员工时间记录表。总体来说，这个包含了在公司工作的时间数。为一整天的考勤时间提供了一个简单的核查。

工时表的第二栏 天数 给出了在不同项目上工作的时间数。如果考勤表和时间表记录有差距，你可以用第二栏检测（天数）或者
（输入错误的记录）。


[image: ../../../_images/timesheet_sheet_hours.png]
Detail of hours worked by day for an employee



工时表 账户显示了所有项目的工作时间。这样你可以看到员工在不同项目的工作时间。

一周或者一个月结束时，员工确认其工时表。如果公司的考勤时间与工时表相一致，那么就将工时表确认好发送给部门经理，由部门
经理核查批准。

每一位经理都可以在 人力资源 ‣ 报告 ‣ 工时表 ‣ 工时表表分析 Human Resource ‣ Reporting  ‣ Timesheet ‣ Timesheet Sheet Analysis 中看到其部门等待审批的工时表。经理可以批准“等待审批的工时表”
也可以将其退回。

通过 人力资源 ‣ 配置 ‣ 人力资源 ‣ 部门 Human Resources ‣ Configuration ‣ Human Resources ‣ Departments 设定部门结构。


Tip

工时表审批

工时表的审批对于部门经理来说是一个很烦琐的事情。然而，这一步骤对于有效管理是至关重要的。在公司，
我们经常会发现这种情况：经理超负荷的工作，但是他们却不知道自己的员工在做什么。

因此至少每周一次由经理审批每一个员工的工时表（即工作大纲）。每个不同的项目所花费的时间都有所记录，
都要审批。



一旦工时表被通过，你可以利用工时表控制成本以及管理开发票给客户的时间。

合同及其费用，计划和进销存方法将在下个章节讲述， 提高服务质量 提供高质量服务 。
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管理各种费用开支

员工费用是员工为公司垫付的。公司应将这些费用报销给员工。最常见的收据有以下几种:


	汽车费用，每（英里或公里）费用报销,

	生活费用，根据账单报销,

	其他商品，例如员工使用的文具和书籍.




[image: ../../../_images/service_expense_workflow.png]
处理费用报销的过程



员工费用可以一个星期一报也可以一个月一报。在一个星期或者一个月结束时，员工可以将复核好的所有费用及费用清单发
给部门经理。经理负责批准本部门所有的费用报销申请。费用清单上必须有员工的签字，同时也必须将收据附在费用清单上。

一旦部门经理批准费用清单后，费用清单将被送到财务部门（记录了公司对员工的负债）。财务可以用支票支付报销费用
也可以以员工最初提供的支付方式支付报销费用。

一些收据是项目费用，因此需要一个分析账户。当这些收据被批准后，这些费用被添加到分析账户的成本中。

经常会有一些在客户中产生的费用，具体的费用要根据合同情况而定。差旅费和生活费就是这样产生的。如果合同价包括
这些费用，那么可以在月底的时候向客户索取。

如果你要通过很多步骤收回费用，那么会很繁琐，特别是员工那些大量的不同的费用。如果你有一个好的管理系统，那么
你可以避免很多麻烦并且提高员工的工作效率。

如果用系统处理费用，那么你可以通过有效的设置销售条款从而避免重大损失。在固定价格的合同中，费用报销通常是根
据实际发生的费用报销。这将有利于系统化处理，自动程序最大化。


允许员工输入费用

安装人力资源-费用模块 hr_expense 自动管理费用处理。安装该模块的配置向导如下所示。


[image: ../../../_images/config_wiz_expenses.png]
Configuration wizard to install hr_expense module



用户可以通过 人力资源 ‣ 费用 ‣ 费用 Human Resources ‣ Expenses ‣ Expenses 输入和查看他们的费用。


[image: ../../../_images/employee_expenses.png]
Expenses form to enter and review expenses



公司认可通过OpenERP产品类型创建的各种费用的模板。例如，你可以创建一个 每公里0.25元的汽车费用 报销产品:


	名称 : 汽车费用 ,

	默认计量单位 : 公里 ,

	成本价 : 0.25 ,

	销售价 : 0.30 ,

	产品类型 : 服务 .



员工在规定的每个周期之前应该保持它的费用清单处于 草稿状态。到达规定时期（星期或者月）时，员工通过点击 确认 按钮
来确认他的报销清单。确认后报销清单处于 等待批准状态。




完善审批审核流程

在一段时期后，部门经理通过 人力资源 ‣ 费用 ‣ 费用 Human Resources ‣ Expenses ‣ Expenses 访问等待批准的费用清单。

费用报销由部门经理批准。点击 发票按钮 创建供应商发票以便于员工报销。分析账户编码到每一行发票中。当发票确认后，一般的分析会计条目将自动生成。




通过辅助核算在付给客户

如果你基于服务时间或者分析成本开票，当客户发票根据相关服务项目生成时，费用将自动计入客户。

根据时间表开票你可以准备好所有的发票，包括费用以及项目客户的时间表。

你可以通过 人力资源 ‣ 报告 ‣ 费用分析 Human Resources ‣ Reporting ‣ Expenses Analysis 查看到费用统计分析。
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提供高质量服务


This chapter focuses on the management of contracts, and the services associated with that.
The complete process of managing services is studied here: from defining prices and contracts to
automatically invoicing the services through planning, and the treatment of
additional costs such as expense receipts.


For this chapter you should start with a fresh database that includes demo data,
with sale, project and all of their dependencies installed, and
no particular chart of accounts configured.



	管理服务合同
	固定造价合同

	成本补偿合同

	Fixed-price Contracts Invoiced as Services are Worked

	Contracts Limited to a Quantity
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管理服务合同

Contracts can take different forms within OpenERP, depending on their nature. So you can have
several distinct types of service contracts, such as:


	fixed-price contracts,

	cost-reimbursement contracts, invoiced when services are completed,

	fixed-price contracts, invoiced monthly as services are carried out.




Tip

Contract Quotations

Some companies commit to contracts on the basis of a requested volume at a certain price for a
defined period.
In such a case, the contract is represented by a pricelist for that specific customer.

The pricelist is linked in the Sales and Purchases tab of the Customers form,
so that it is brought up whenever anything is bought from or sold to this partner
(depending on whether it is a purchase or sales agreement).
OpenERP automatically selects the price based on this agreed pricelist.




固定造价合同

Fixed price contracts for the sale of services are represented in OpenERP by a Sales Order. In
this case, the supply of services is managed just like all other stockable or consumable products.

You can add new orders using the menu Sales ‣ Sales ‣ Sales Orders.

The new Sales Order document starts in the Quotation state, so the estimate has no
accounting impact on the system until it is confirmed. When you confirm the order, your estimate
moves into the state Manual In Progress .


[image: ../../../_images/service_sale_workflow.png]
Process for handling a Sales Order



Once the order has been approved, OpenERP will automatically generate an invoice and/or a delivery
document proposal based on the parameters you set in the order.

The invoice will be managed by the system depending on the setting of the field Shipping
Policy on the order’s second tab Other Information:


	Payment Before Delivery : OpenERP creates an invoice in the Draft state.
Once this is confirmed and paid, the delivery is activated.

	Invoice on Order After Delivery : the delivery order is produced when the order is
validated. A draft invoice is then created when the delivery has been completed.

	Shipping & Manual Invoice : OpenERP starts the delivery from the confirmation of
the order, and adds a button which you manually click when you are ready to create an invoice.

	Invoice From The Picking : invoices are created from the picking stage.




Note

Delivery of an Order

The term ‘delivery’ should be taken in the broadest sense in OpenERP.
The effect of a delivery depends on the configuration of the sold product.

If its type is either Stockable Product or Consumable, OpenERP will make a request for it to be
sent for picking.
If the product’s type is Service, OpenERP’s scheduler will create a task in the project management
system,
or create a subcontract purchase order if the product’s Procurement Method is Make to Order.

Invoicing after delivery does as it says: invoicing for the services when the tasks have been
closed.



When you sign a new contract, you can just enter the order into the system and OpenERP will track
the order.

This works well for small orders. But for large valued service orders, you might want to invoice
several times through the contract, for example:


	30% on order,

	40% on completion,

	30% one month after the system has gone into production.



In this case you should create several invoices for the one Sales Order. You have two options for this:


	Do not handle invoicing automatically from the Sales Order but carry out manual invoicing instead,

	Create draft invoices and then link to them in the third tab History of the
Sales Order, in the Related
Invoices section. When you create an invoice from the order, OpenERP deducts the amounts of the
invoices already linked to the order to calculate the proposed invoice value.






成本补偿合同

Some contracts are not invoiced from a price fixed on the order but from the cost of the services
carried out. That is usually what happens in the building sector or in large projects.

The approach you use for this is totally different because instead of using the sales order as the
basis of the invoice you use the analytic accounts. For this you have to install the module
hr_timesheet_invoice.

An analytic account is created for each new contract. The following fields must be completed in this
analytic account:


	Partner : partner associated with the contract,

	Sale Pricelist,

	Invoicing.



The selection of an invoicing rate is an indirect way of specifying that the project will be
invoiced on the basis of analytic costs. This can take different forms, such as delivery of
services, purchase of raw materials, and expense reimbursements.


Note

Pricelists and Billing Rates

You can select a pricelist on the analytic account without having to use it to specify billing
rates.

An example of this is a client project that is to be invoiced only indirectly from the analytic
costs.
Putting the pricelist on the analytic account makes it possible to compare the actual sales with
a best case situation where all the services would be invoiced.
To get this comparison you have to print the analytic balance from the analytic account.



Services are then entered onto timesheets by the various people who work on the project.
Periodically the project manager or account manager uses the following menu to prepare an invoice
Accounting ‣ Periodical Processing ‣ Billing ‣
Bill Tasks Works.

OpenERP then displays all of the costs that have not yet been invoiced. You can filter the proposed
list and click the appropriate action button to generate the corresponding invoices. You can select
the level of detail which is reported on the invoice, such as the date and details of the services.


[image: ../../../_images/service_timesheet_invoice.png]
Screen for invoicing services




Note

Project Management and Analytic Accounts

Analytic Accounts is only available once you have
installed the module account_analytic_analysis.
It provides various global financial and operational views of a project manager’s projects.



Select an entry and click Invoice analytic lines link on the right of the form.
You can then invoice the selected entry by clicking Create Invoices.




Fixed-price Contracts Invoiced as Services are Worked

For large-valued projects, fixed-price invoicing based on the sales order is not always appropriate.
In the case of a services project planned to run for about six months, invoicing could be based on
the following:


	30% on order,

	30% at the project mid-point,

	40% at delivery.



Such an approach is often used in a company but there are other options. This method of invoicing
can pose many problems for the organization and invoicing of the project:


	It is extremely difficult to determine if the project is on track or not. The endpoint is fuzzy,
which can result in a tricky discussion with the client at the moment of final invoicing.

	If the project takes more or less time than forecast, it will effectively result in under- or
over-invoicing during the project.

	Whether you get a proper return can depend on the client. For example, if the client takes a long
time to sign off on project acceptance, you cannot invoice the remaining 40% even though you might
have supplied the agreed service properly.

	The account manager and the project manager are often different people.
The project manager has to
alert the account manager about the moment that the client can be invoiced, but that moment can easily be
forgotten or mistaken.

	The project can be fixed for service costs but have agreed extras, such as reimbursement for
travel expenses. Invoicing from the order does not adapt well to such an approach.



OpenERP provides a third method for invoicing services that can be useful on long projects. This
consists of invoicing the project periodically on the basis of time worked up to a fixed amount that
cannot be exceeded. At the end of the project, a final invoice or a credit note is generated to meet
the total amount of value fixed for the project.

To configure such a project you must set an invoicing rate, a pricelist and a maximum amount on the
analytic account for the project. The services are then invoiced throughout the project by the
different project or account managers, just like projects that are invoiced by time used. The
managers can apply a refund on the final invoice if the project takes more time to complete than
permitted under the contract.

When the project is finished you can generate the closing invoice using the  Final Invoice  button
on the analytic account. This automatically calculates the final balance of the bill, taking the
amounts already charged into account. If the amount already invoiced is greater than the maximum
agreed amount, then OpenERP generates a draft credit note.

This approach offers many advantages compared with the traditional methods of invoicing in phases
for fixed-price contracts:


	Fixed-price contracts and cost-reimbursable contracts are invoiced in the same way, which makes
the company’s invoicing process quite simple and systematic even when the projects are mixed.

	Everything is invoiced on the basis of worked time, making it easy to forecast invoicing from
plans linked to the different analytical accounts.

	This method of proceeding educates project managers just as much as the client because refunds
have to be given for work done if the project slips.

	Invoicing follows the course of the project and avoids a supplier’s dependence on the goodwill of
the client in approving certain phases.

	Invoicing of expenses follows the same workflow and is therefore very simple.




Note

Negotiating contracts

In contract negotiation, invoicing conditions are often neglected by the client.
So it can often be straightforward to apply this method of invoicing.






Contracts Limited to a Quantity

Finally, certain contracts are expressed in terms of a quantity rather than a fixed amount. Support
contracts comprising a number of prepaid hours are a case in point. To generate such contracts in
OpenERP you should start by installing the module account_analytic_analysis.

Then you can set a maximum number of hours for each analytic account. When employees enter their
time worked on the support contract in the timesheets, the hours are automatically deducted from the
maximum set on each analytic account.

You must also name someone in the company responsible for renewing expired contracts. They become
responsible for searching through the list of accounts showing negative remaining hours.

The client contract can be limited to a certain quantity of hours, and it can also be limited in
time. For that, you set an end date for the corresponding analytic account.
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很棒的项目管理


如果您有一个好的系统来管理任务，您的整个公司都将受益。OpenERP的项目管理模块能让你有效地管理和跟踪任务，有效地开展工作,
迅速委派任务并同时保持密切跟踪您委派的任务。OpenERP还有助于贵公司的人组织他们的个人时间，本章提出了一种旨在提高管理者的
生产力的方法。


新建一个包含演示数据的帐套，安装“销售管理”和“项目管理”并选择通用会计科目表



	项目管理
	创建项目和相关项目任务

	任务管理

	开票任务

	项目优先级管理

	任务委派





	长期项目规划
	项目阶段

	排程
	计算阶段计划

	计算任务计划









	提高领导能力的规划
	按时间还是按任务作计划？

	计划你的时间

	在层次每个级别都进行计划





	没有压力的生产力的艺术
	并非所有急事必然是重要的

	有条不紊地组织你的生活
	相关环境因素

	时间盒

	方法和迭代过程

	令人信服的结果
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项目管理

在前面的章节中，您基于OpenERP的辅助核算、实例结构了解了项目的财务管理。这种工作方式使您能够分析时间计划和预算，
和管理不同合同的发票。

在这里，我们将解释使用项目管理模块来组织任务和计划您需要完成的工作。所有必要的操作均出自于 Project
菜单中。


Tip

记得您在简化界面中比在扩展界面中选项更少.




Note

项目

在OpenERP中，项目代表了一系列需完成的任务。项目有一个树状结构，可以划分阶段和子阶段。这种结构非常有益于组织您
的工作。

相对于辅助核算是审视公司过去的活动，项目管理的作用是规划未来。虽然在两者之间存在密切的联系（如项目已通过OpenERP
计划和完成），他们仍然是两个不同的概念，各自形成自己的工作流程。



大多数自定义项目由以下构成:


	总账系统中一个或多个辅助核算以跟踪合同及其不同阶段,

	项目管理系统中一个或多个项目以跟踪需完成的不同任务.



这里项目和辅助核算可以直接关联，这是因为每创建一新的项目，OpenERP会在 项目 辅助核算表中自动创建对应的辅助核算项。
注意您不能从项目中直接存取辅助核算。


创建项目和相关项目任务

定义一个新项目，到菜单 Project ‣ Project ‣ Projects ，点击 New 并给项目一个 Project Name .

您可以将这个项目作为一个 Parent Project 的子项放入一个层次结构中，并指派一个 Project Manager 。
通过输入 Start Date 和 End Date 确定总持续时间。

Administration 选项卡显示关于计划时间的信息，并根据已完成任务计算项目花费的时间。如果选中了 Warn Manager 选择框，
您可设置系统在每一任务完成时向项目经理发一条 Request 。

万一项目运行时间过长，它可升级成另一项目 project_issue 。在 提升 处选择需提升成项目的已进行任务。
which can be done by selecting  in the Reconfigure wizard. In Project Escalation, enter the project that will be used for escalated tasks.
为自动电子邮件定义一个一般的 Reply-To Email Address ；这允许您直接从OpenERP中接收回复。您可定义一个 Working Time 类型，这可用于计算项目时间，特别是通过甘特图。

项目有如下状态:


	打开: 项目开出来了,

	中止: 项目暂停,

	取消: 项目因为取消而中断,

	关闭: 项目成功结束,

	模板: 该项目作为模板以据此创建新项目。



在 Members 选项卡，将 Members 添加到该项目，这与访问权限有关。

在 Billing 选项卡，您能看到客户的发票信息。选择 Customer ，客户表单的“客户地址”会自动填入。您必须完成其他信息，
比如 销售价格表 和在任务完成后直接 按任务进展开票 。OpenERP允许您设置项目（或子项目）的 最大开票价 。
已开票金额 显示的是相关项目的已开发票的总金额。

如果您想自动使您的客户了解项目的进展情况，选中 通知业务伙伴。


Note

通知业务伙伴

如果您选中 通知业务伙伴 ，在 发票 页签中需要您定义一个常用的 邮件头 和 邮件页脚 用于
自动生成的电子邮件（仅扩展用户界面）。OpenERP会准备好电子邮件，用户可以在每个任务结束后发给客户。这封电子邮件的
内容是基于项目任务的详细信息，并且在发送电子邮件之前，可以由用户修改。在这个页签下面，OpenERP显示了多个可用于电
子邮件的变量。




Note

客户满意度的研究

一些企业运行的电子邮件系统在任务完成时自动发送邮件，请求客户完成网上调查。这项调查通过公司询问有关工作开展的
一些问题，来衡量顾客对项目进程中的满意程度。

此功能也可用于通过ISO 9001认证的公司，来衡量顾客的满意度。 OpenERP还允许您创建自己的调查。



Task Stages 选项卡允许您定义阶段帮助你分割您的任务。您可以添加一个序列号来设置各阶段顺序，使您考虑优先的工作任务，
即：首先，您将先有 详细说明书 阶段然后才是 开发 。




任务管理

一旦一个项目已被定义，你可以输入要执行的任务。这有两种方法：


	点在项目表单右边的 ACTION Tasks ，然后点 New 按钮,

	从菜单 Project ‣ Project ‣ Tasks ，创建一个新任务并将其分配到现有项目.



每个任务包含以下状态:


	草稿: 任务已经录入但尚未得到有权限的人的审核,

	打开: 您可以开始工作或该任务已在运作,

	关闭: 任务已经结束,

	中止: 已不需要该任务,

	待决: 任务在等待其他人的响应（如客户信息）.



一个任务可以被分配给一个用户，他将负责关闭该任务。但你也可以不分配特定人员：取而代之的是各团队成员共同负责他们的
各自擅长的任务。


[image: ../../../_images/service_task.png]
项目管理中的任务



每个用户利用现有的各种菜单管理自己的任务。要打开已专门指派给您未关闭的任务列表，到菜单 Project ‣ Project ‣ Tasks 。
或是打开未指派的任务，到 Project ‣ Project ‣ Tasks 然后点 Clear按钮再点  Unassigned按钮。.


Tip

快捷方式

每个用户最好在自己的快捷方式里建立到 Tasks 菜单的链接，因为他们将不得不每日多次访问该菜单。



委派 标签允许你定义你的任务之间的联系。从 Parent Tasks 设置和本任务相关联的任务。通过这个方式可以定义需完成任务
的顺序，举例说，任务2不能先于任务1运行。




开票任务

开票的几种方法:


	根据销售订单开票,

	基于成本（服务时间、费用）开票,

	基于发货单开票,

	手工开票.



虽然开票任务可能看起来很有用，但在特定情况下，最好从服务商开票或用采购订单代替。这种开票方式更灵活，可根据价目表开出
不同价位的发票，不同产品也可以进行发票开具。扩大你已有的开票方式对限制你公司的开票方式数量也有帮助。

如果你想连接你的销售订单与项目任务，你应该创建类似 咨询和 深度开发这样的产品。这些产品应如下配置：产品类型 是 服务，
生产方法 是 据订单生产， 供应方法 是 生产。一旦你按此设置，当订单被批准时OpenERP会自动在项目管理中创建一个任务。你甚至
可以在产品中添加一个默认项目。在“产品”表单中，在 需求与库位 页签中，输入可以（从销售订单）自动创建任务的默认项目。

您还可以改变某些参数的顺序，从而影响发票:


	出运政策 : 发票交付后（任务关闭时）

	发票当时情况 : 实际发货量 (任务的实际工时).



利用上述配置创建产品为 咨询 的 销售订单 ，并确认它。您使用 Project ‣ Project ‣ Tasks 菜单
会发现根据销售订单创建的 任务 。一旦找到该任务，点击 开始任务 按钮以启用它。您必须手动指派这项任务所属的项目，
除非你在产品表单提供默认的项目。当你完成任务后，在 工作任务 字段中输入完成信息。单击 完成 按钮，以
通知OpenERP已完成这个任务。作为一个例子，新任务 SO008：Create SRS 如下图所示，据销售订单 SO008 生成的 SO008：Create SRS 。


[image: ../../../_images/project_task_from_sale_order.png]
创建自销售订单的任务




Tip

你需要仔细配置有关这个项目的辅助核算，如果您使用项目的 结算 标签来做到这一点，与项目有关的成本帐户将自动获得相关的设置。



任务结束后，到菜单 项目 ‣ 开发票 ‣ 根据任务开票 去找未开票任务。 当您想根据任务开发票时点击 辅助核算记录 行。


[image: ../../../_images/project_invoice_from_task_work.png]
Form to Create Invoice from Tasks Work






项目优先级管理

有多种方法可以按各自重点确定任务的顺序。OpenERP按照以下方面的功能为任务排序： 序列 ， 优先次序 ， 最后期限 。

使用第二张表单中的 序列 功能，附加信息 来为由多项任务组成的项目作规划。以软件项目举一个例子，所开发的
任务已给出序列，第一项任务为序号一号，以此类推2,3,4等。当你第一次打开项目任务的列表，任务已按序号排列好。你可简单地拖放
任务来改变顺序。

你可从这三种排序的方式中选一种，或者综合运用，这由项目决定。


Note

灵活的方式

OpenERP为软件开发项目项目组合模块补充了灵活的方法论 project_scrum ,

Srum 为系统补充了以下概念：长期计划，冲刺，重复开发，进度报告会议，燃尽图，产品订单。

查看以下网址: http://controlchaos.com 获取更多有关 Srum 的信息。




[image: ../../../_images/service_project_gantt.png]
甘特图，计算最早发运日期



你可在项目文件中设定工作时间。如果不设定，OpenERP会默认为周一到周日每天工作八小时。时间确定后，你可从任务中得到甘特图。
系统之后根据任务顺序和工作时间制定最快完成任务的项目计划。


Tip

日历视图

OpenERP在web客户端和Gtk客户端下都提供不同任务的日历视图。您可以通过拖放删除、创建、修改任务（仅限于web客户端）。


[image: ../../../_images/service_task_calendar.png]


Calendar View of the System Tasks






任务委派

通过委派任务给另外一个用户，您可以变更任务负责人。但是，通过这种方法系统无法帮助您跟踪您委派出去的任务，比方监控工作是否完成。


[image: ../../../_images/service_task_delegate.png]
委派任务给其他人表单



作为替代，您可以在任务上使用 委派 按钮。

您可用该系统调整任务链中不同级别的任务，添加补充信息。任务由一项整体的目标开始，按照等级委托下来变得具体化。

任务表单第二页签，给您一委派任务的完整的历史。您可以找到一个父任务的链接，以及已委派的不同任务。
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长期项目规划

您可以用“长期计划”规划您的项目。要做到这一点，使用的 重新配置 向导，并在项目应用配置一节中，选择 长期规划 ，
并单击 配置 。这会安装 project_long_term 模块。通过使用此功能，您可以将任务和在特定的时间由谁做完的计划链接起来。

传统的分阶段的方法，确定了必须完成的步骤的顺序。Faces [http://faces.homeip.net/] 用于调度阶段和基于日历的任务。因此，可使用此工具跟踪资源的可用
性或资源叶子。甘特图，让您通过拖放即可轻松管理您的资源和计划。日历视图还帮助您审视截止日期和需要注意的任务。


项目阶段

您可以将大项目分拆成多个阶段。定义一个新阶段，在 Project ‣ Project ‣ Project Phases 点击 New .
您必需通过 Project 字段将“项目阶段”和项目关联起来。对于每一个阶段，你可以定义你的需分配的资源（人或设备），描述不同
的任务和之前以及之后阶段。您还可以添加日期和调度相挂钩的约束。项目的甘特视图也来自本菜单，
此菜单为 Project ‣ Long Term Planning ‣ Project Phases .


[image: ../../../_images/project_phase.png]
Form View of Project Phase






排程

你需要确定一个工作进度表以及分支，因为项目调度者会以此来计算定项目周期。请确定您在项目表单中的 Administration
选项卡中 Working Time 字段填入了工作安排。这有助于为您的项目生成精确的甘特图。

如果您有一个任务与项目阶段相关，您可以在“项目阶段”表单中的 Tasks Details 选项卡中看到他们。为其分配日程点 Schedule Tasks 按钮。处于草稿、待决和打开状态的所有任务的日程和他们的工期的计算都基于阶段中的开始日期。


[image: ../../../_images/schedule_tasks.png]
安排相关的结束的任务



您同样可以用以下方式分配项目阶段和分配项目资源:


计算阶段计划

要获得项目阶段的甘特图需通过菜单项 Project ‣ Scheduling ‣ Compute Phase Scheduling ，
会出现一个对话框让您选择的所有项目或单个项目。它将计算给定项目处于草稿、打开和待决状态的各阶段的开始日期和结束日期。
点 Compute 按钮打开甘特图视图。


[image: ../../../_images/gc_project_phases.png]
Gantt Chart for Project Phases






计算任务计划

这一功能和前一功能目的一样，此功能仅用于不分阶段，但包含一系列任务的项目。要访问它，到 Project ‣ Scheduling ‣ Compute Task Scheduling 。
你必须且能选择单个项目来算。它可示资源分配的甘特图。


[image: ../../../_images/gc_resources_allocation.png]
资源分配甘特图











          

      

      

    


    
         Copyright .
      Last updated on 2015-07-13 16:24:00.
      Created using Sphinx 1.3.1.
    

  

  
    
    
    提高领导能力的规划
    
    

    

 

















  
  

    
      Navigation

      
        	
          index

        	
          next |

        	
          previous |

        	OpenERP v6 

          	目录 

          	OpenERP 用户手册 

          	有效的运营管理 

          	很棒的项目管理 
 
      

    


    
      
          
            
  
提高领导能力的规划

在公司中的计划，往往通过团队之间的例会来确定。每个团队都有一定数量的项目和目标，他们必须确定优先事项。

理想的情况下，这些例会应是短暂的，但例行和系统的。取决于业务的要求他们可以每周或每月召开。一次计划会议，通常包括三个阶段:



	先用几分钟对前段时间的工作和计划作对比分析.

	介绍新的项目.

	计划下阶段工作.






规划功能包括将在本节中所述的几个目标:


	根据对客户作出的承诺规划现场项目,

	决定在未来一个月的工作人员（人力资源）的要求,

	安排每个员工或团队下阶段的工作,

	分析在前一阶段的工作完成情况,

	公司高层商议相对较低级别任务接受高级别任务.




Tip

制定计划的作用

很多项目经理认为他们可以独自制定计划。他们往往工作量过大，认为开会浪费时间。

即使员工真的可以安排自己的工作，你还是应该把例会当作一种缓解。否则你将陷入过度压抑的状态:


	有工作负荷的感觉是因为他们对于自身优先权没有把握,

	工作的反馈及跟踪可实现,

	若工作计划不明确,会给人造成组织管理差的印象.



So the social role of planning should not be neglected. We have often experienced a background of
stress in a company stemming from a lack of communication and planning.




按时间还是按任务作计划？

制定计划的方法有两种：按任务或者按时间。你可使用 Open ERP 。

若按任务方式，项目经理可在规定时间内将不同项目分配给员工。雇员认真完成项目经理分配的任务。

若按时间分配方式，每个员工将有一定时间内每个不同项目中分配的时间任务。每个项目的任务由上级分配，可直接分配给接受者，或者
不进行分配。每个员工按计划和任务的先后顺序，选择接下来的任务。


[image: ../../../_images/service_planning_time.png]
员工月度工作时间分配



从员工月度工作时间分配图 员工月度工作时间分配 看出，月度计划制订了每个员工在不同项目上的工作时间。

按照这种按时间分配的方式，客户的优先权不再在计划中体现，而是在任务列表中体现。所以该方法可将项目人力资源规划从任务优先
化处理中区分开来。


Note

两种计划方式比较

为说明按时间规划和按任务规划的不同，以一为期6个月的IT项目为例。该项目循环开发周期约一个月，每周期末
为客户作演示，来作项目跟踪。在会议上，你为下个月作计划。月末，项目的客户经理为客户为已完成的部分开票。

假设该项目由于比预期复杂而延期，若没有其他资源，有两种解决延期的方法:


	完成预期功能但延迟

	准时完成但完成的功能比预期要少.



若按阶段或任务作计划，你要在会议上告知客户现阶段要完成所有任务还需几周时间。相反，若按时间作计划，你要
告知客户停止现行的开发计划，作新计划，但只能提出部分规划的功能。

若客户对延期很在意，那么第一种方法会导致不开心的情况发生。你就必须考虑到延期重新对项目以及项目未来的
进程作计划。后期开票方面也可能出现问题，因为对于延迟完成且未展示给客户的工作部分，开票有难度。




Note

Comparing the Two Planning Methods

第二种方法要求你汇报未完成的功能以及其对未来计划阶段产生的影响。这种方法不会对分配到项目的工作时间产生中断，
但你必须提供两种清单：不同项目人员配置清单和客户项目的任务优化清单。这种方法相对于第一种方法有这些优势:


	客户也可通过制定新阶段计划来延长项目完成时间，或者放弃其中次要的功能来快速完成系统开发,

	客户可能因为考虑到延期, 而重新策划功能.

	你就要让客户意识到, 项目进度背负压力, 工作任务比期初预想的要复杂得多.

	几项功能的延迟发布, 不会对月度开票和项目计划造成影响.



将人力资源规划从任务优化中分离出来，简化了复杂事务的管理，如对员工假期的调整及处理项目中不断变化的岗位级别。






计划你的时间

安装项目计划模块 project_planning ，以获得其它功能，辅助项目规划和报告。使用菜单 Project ‣ Long Term Planning ‣ Plannings
项目—长期规划—计划实施 来开始计划。

在每项规划线内，你应登陆用户，可看到账户分析以及时间分配。分配量以小时或天的形式表示，取决于衡量的单位。每项规划线中，
可对要完成的工作加入简要说明。

保存好计划后，使用其它计划形式选项卡，确认分配给员工或项目的时间是否正确。分配的时间必须与员工的工作合同相一致，例如每周
37.5小时。同时项目预设的时间也应与你和客户的承诺相一致。

你应理想地完成现阶段的所有计划。也可完成未来几个月内的几项计划——如响应客户的承诺，储备不同项目的资源。这使你提前管理
几个月可用的人力资源。

计划可打印或通过邮件发送给员工。每位员工可通过图表清楚地看到他/她在项目上要花费的时间以及目前为止
已工作的时间。所以每位员工可对项目进行优化选择。

然后员工可在最紧急项目中选择任务。她可自己选择分配给她的任务，或者在最紧急任务列表中选择能够完成的任务，且该任务还未直接
分配给别人。

最后，你可对不同项目中所开展的有效工作时间与最初的预计作比较。将计划打印出来，来作计划工作时间和实际工作时间的比较。


[image: ../../../_images/planning_stat.png]
计划工作时间，实际工作时间，项目员工生产力比较



你还可根据 项目 ‣ 上报 Project ‣ Reporting 菜单对项目数据作分析.




在层次每个级别都进行计划

要将规划在整个公司落实到位，你需要运用规划代表团系统。

规划表格能够反应公司的层次结构。要使数据成为规划线的一部分，你可以:


	将项目上要花的时间分配给员工,

	将项目上要花的时间分配给负责其团队的部门经理.



现你可按部门整体来分配项目工作时间，无需细化每个员工的工作任务。当部门经理制定计划时，便可在表格底部看到其管理团队的需求。
而在表格顶部留有空白处，用于将工作具体分配至部门每个成员。

若你不需要在最终稿中作工作时间计划，你可在依附于子帐户的分析帐户作计划.也就是说你可以制定计划来满足高级管理层的最高级
目标,然后分配到不同部门,为每个员工作时间预算.每个经理之后用其计划管理其所在的等级。
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没有压力的生产力的艺术

现你可通过查看ERP提供的一些工具,稍放下单纯的企业管理,来加强你的个人时间管理.这不算绕行,因为良好的组织是你每日工作中
提高生产力的关键.

OpenERP的项目 project_gtd 模块 灵感来自两本有效时间管理为主题的书:


	《Getting Things Done》—无压力环境下提高生产力,戴维艾论著(2001).大部分参考了他本人在2005年草拟的
GTD, 这本书围绕人应该列出未完成任务,然后在一可靠的系统中储存这些任务的细节.




然后他们无须将这些任务记在脑中,他们可以很确定,这些事情已安全记录,他们可让自己放松,并将时间和经历系统
集中在处理任务上.



	《The 7 Habits of Highly Effective People》— 高效能人士的七个习惯(1989): 作者(Stephen R. Covey)建议
组织使用这些实践条例,并在组织中报告生产力提高的结果。





Note

有效安排时间

《Getting Things Done》 — 尽管去做 (David Allen)，企鹅书籍，纽约，2001,267页。(ISBN : 978-0142000281)
见网址：http://davidco.com

《The 7Habits of Highly Effective People》 — 高效能人士的七个习惯(Stephen R. Covey), Free出版社, 1989,
第15期周年改版：2004,384页(ISBN : 978-0743269513)




Tip

自我解压!

将混乱思维的任务理清，将其记录在一个有序的系统中。这能使你快速自我解压，并以最好的方式组织工作开展。

若你因工作负荷倍感压力，按以下方法来告诉自己它的好处。
拿出几页空白纸，将在你脑中要做的事情写下来。
每项工作的下一步用邻近线连接，并在上面标注你要承诺自己完成的时间。


在这个练习的最后，你会觉得做事更有条理，压力和忧虑大大减小。







在这绕行中的目标不是为了具体补充丰富方法论，而是为了介绍 OpenERP项目模块 project_gtd 的辅助工具。


并非所有急事必然是重要的

相对于基础OpenERP系统，模块的第一个调整就是将紧急性和重要性的概念区分开来。工作任务不再按单一的标准分类而是
由两个标准分类，使你在一张列表中看出同具紧急性和重要性的任务。

很多工作任务重的管理者只用紧急性来作为区分工作优先性的方法。其中的问题在于怎样为大多数的工作作计划（如中期目标）。这些工作不紧急但却非常重要。


Note

紧急性和重要性区别举例

如果你组织能力强，紧急的任务通常可以(通常应该)被安排在重要任务之后。从平时的生活中取一例子:
安排时间和你的孩子一起的例子

对于大多数人来说，此项任务是重要的。但是如果你的职业生活很忙碌。每日每周都被没完没了的紧急任务所填满。
即使你将时间安排的很好，几个月过去你仍然没有安排和你的孩子在一起的时间，因为见他们尽管很重要，但是却不像你的
工作那么紧急.



在Open ERP程序中，紧急性由任务的截止期限 Deadline 决定，重要性由优先顺序 Priority 决定。任务的分类由两个因素决定。
最重要和最紧急的任务显示在表格顶端。




有条不紊地组织你的生活

在此部分展示了运用环境联系和时间盒概念来安排自己的方法学


相关环境因素

环境联系是指你要处理某项任务的工作环境。例如你可以为下列环境联系作定义:


	办公室 : 在你工作场所要完成的任务（如打给客户电话或起草一份文件）,

	车 : 要四处奔波的任务（如购物或去邮局）,

	旅行 : 你在出差时在飞机或火车上完成的任务（如写一部作品，或分析一样新产品）,

	家 : 在私人住处完成的任务（如找一家清洁商户或割草）



员工/系统用户可通过菜单 项目 ‣ 配置 ‣ 任务 ‣ 环境因素 Project ‣ Configuration ‣ Tasks ‣ Contexts 来创建自己的相关环境困素.




时间盒

而后你需要为时间盒作定义。你必须完成在时间盒规定的时间间隔中完成任务。你经常通过以下时间段来为时间盒作定义。


	今天 : 今天必须完成的任务,

	本周 : 本周必须完成的任务,

	本月 : 本月必须完成的任务,

	长期 : 一个月之后要完成的任务.



一项任务一次只能放在一个时间盒里。

你必须将时间盒和完成任务的最后期限区分开来，因为任务最后期限是由项目管理者制定的，而时间盒是关于个人的任务。

为你公司的时间盒下定义，要用菜单 项目 ‣ 配置 ‣ 任务 ‣ 时间盒 Project ‣ Configuration ‣ Tasks ‣ Timeboxes.




方法和迭代过程

为有效开展你的任务，OpenERP软件在以下系统及迭代过程基础上使用方法:


#. 确定你要完成的所有任务，包括让你晚上失眠的所有事情，将其输入 任务 中，在菜单 项目 ‣ 项目 ‣ 任务
Project ‣ Project ‣ Tasks 里。


	定期将任务进行分类，为任务指定环境联系和时间盒。同时也指定了任务执行的时间和地点。若一项任务要花少于十分钟的时间，那么这项任务可以很快处理好。



	每天开展以下工作步骤:



	早上的第一件事，从最近一周的时间盒里选择你今天想完成的任务。这些任务按照重要性和紧急性排列，所以
你要从表格的最上方选择任务,

	执行每项任务，也就是说，你自己完成任务或者将任务委托给另一位用户,

	在一天结束的时候要做的就是清空当日的时间盒，并将未完成的任务放至周时间盒.








	每周每月按照各自的时间盒重复相同的步骤









Tip

不要将 议程 和 时间盒 混淆

时间盒和议程是不同的。某些任务，例如会议，必须在指定的时间完成。
所以这样的任务不能由时间盒系统管理，而要由议程管理。

最理想的就是将最小的事放在议程上，并将有明确日期的任务放在议程上。
时间盒系统对于处理多项任务来说更加灵活有效。



所以由输入项目所需的所有任务开始。
这些任务可能已由其他用户输入，并分配给你。
将那些在恼人的任务进行编码很重要，就将他们从你脑中除去。任务可能是:


	待完成的工作,

	短期, 中期或长期目标,

	一个还未分配任务的项目.



几天的项目或目标可在一单项任务中概括。如果你很清楚操作步骤，就不必细化每项操作.

你必须定期清空你的任务。使用菜单 项目 ‣ 项目 ‣ 任务 Project‣ Project ‣ Tasks 为每项任务安排时间盒和环境联系。这个步骤用不了一分钟的时间，
你只是将他们分配，并不是完成任务本身


[image: ../../../_images/service_timebox_day.png]
今天所要完成任务的时间盒



点击顶端右方的 Plannify Timebox .你从包含每周任务的时间盒中选择当天要完成的任务。通过这项操作你可对中期要完成的
任务和目标有整体了解，并让你每天至少回顾一次。然后你根据你任务的先后顺序来分配时间。

任务是按先后顺序分类的，可直接从列表最上方选择任务，一天忙上几个小时。这个步骤只需要一分钟，因为选择无关你未来的
任务，而只是最近一周任务的选择。

时间盒已设定好，你就可以开始你一天的工作。每项任务，你可对其设定开始，删除，结束，取消.

下班后你可点击顶端右边按钮 清空时间盒 。所有未完成的任务将放回周时间盒，并归类到第二天早上计划要完成的任务列表中。

使用相同的原则对每周每月的任务作计划，但要为每个时间段设置合适的时间盒。




令人信服的结果

经过一段时间这种方法的运用，用户报告了以下进展:


	被遗漏的任务和目标减少,

	压力减小，人们对其所在处境控制更强,

	日常开展的工作类型的先后顺序的改变,

	以更长远的时间管理角度来看任务和目标的重要性和紧急性,

	更好地管理所有任务，对任务进行筛选,



最后，注意这个系统完全和OpenERP的项目管理功能完全集成在一起。工作人员可以根据自己的需要决定是否使用该系统。
该系统是对OpenERP的项目管理功能的补充，用于对团队的组织以及对公司的规划.
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管理仓库和搞定制造


本书此部分主要描述实际物流-库存处理及通过组装和制造对物料进行转化.



存货是指产品規格的实体表现形式,而不仅是产品数据清单.存货需要储存,在各库位之间移动,会被以套或个的方式进行追踪.
它们有尺寸,重量以及成本属性.Open ERP 使用了一种有效且独特的方式进行存货管理.



制造是指将物料以及组件，可能还有一些可计量的资源转换成其它产品或服务,为公司增加价值.




	仓库

	定义主数据
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仓库


OpenERP的库存管理看似非常简易, 实则很灵活且功能全面.
它基于带给会计领域革命性变化的复式记帐原理.
系统特点正如 拉瓦锡的名言 “什么也没有失去，一切都改变了” 或者说,
“一切皆为移动”. 在OpenERP中你不会说物料不见了, 消耗了或丢失了:
而是说物料从一个库位移动到了另一个库位.


正如会计复式记帐一样, OpenERP系统管理的每一个主要业务活动
（如采购收货、销售发货、盘盈盘亏、原料损耗等）都有一个对应的库位,
存货移动始终是指物料从一个库位移动到另一个库位. 为了确保每次库存移动都有一个对应库位
软件支持以下不同类别的库位:


	实际库位,

	伙伴库位,

	虚拟库位（作为计划、生产、盘点的对方库位）.



实际库位代表仓库及其层次结构.
实际上就是指通常由传统库存管理系统管理的库位.

伙伴库位代表你的客户和供应商的库存. 在与你的这些伙伴们进行
对帐时, 这些库位就扮演了往来科目的角色. 从供应商收货在系统内就被表示
为物料由伙伴库位移动到了你自己公司的实际库位.
所以你会看到供应商库位通常都会显示负库存而客户库位通常显示为正库存.

与生产对应的虚拟库位通常使用在制造流程中. 制造的特性是消耗原材料,
产出成品.虚拟库位就用作上述操作的对应库位.

盘点库位是贵公司对库存进行盘盈和盘亏操作的对应库位.

下图 系统初始安装后的库位层次结构图 是系统初始安装后的库位层次结构图 (Warehouse ‣ Warehouse Management ‣ Locations).


[image: ../../../_images/stock_location_tree.png]
系统初始安装后的库位层次结构图




Note

结构化库位

在OpenERP中, 库位是结构化的.
你可以将库位设置成基于父子关系的树状结构, 这样的组织方式可以使你更精细的对库存操作和仓库结构进行分析.




Tip

库位与仓库

在 OpenERP 中 Warehouse 仓库代表实际存货的实际存放位置.
可以将仓库设置成多层级库位结构.
库位通常用来对货品进行分门别类的管理, 比如说客户库位和生产
库位.



本章中你可以使用上一章用过的带示例数据的数据库,
已经安装仓库管理及相关模块.

本章中我们要用到以下模块:


List of modules
  
    
    
    理解复式库存管理
    
    

    

 

















  
  

    
      Navigation

      
        	
          index

        	
          next |

        	
          previous |

        	OpenERP v6 

          	目录 

          	OpenERP 用户手册 

          	管理仓库和搞定制造 

          	仓库 
 
      

    


    
      
          
            
  
理解复式库存管理

本章节用于解释库存管理（或存货管理，stock management）的概念，看一下以下操作是怎样产生库存异动的：


	从供应商处接收产品，

	发货至客户

	丢失物料(or 损耗物料？lost materials)的库存操作

	生产



库位结构基于系统初始安装后的库位层次结构图 系统初始安装后的库位层次结构图. 假定还没有任何存货
也没有尚在进行中或已经计划的存货相关操作.

如果你从供应商处订购 ‘30台单车’，OpenERP会在接收时候执行以下操作：


Stock Move Operation from Suppliers to Stock
  
    
    
    管理实际库存结构
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管理实际库存结构


仓库

仓库是设计用于向客户进行交付活动或是接收原材料的实际场所。
当你从供应商处购买产品时，你应该考虑这次采购所要使用的仓库。这也使得最终用户不必从库位列表中进行选择，而是一个真实的仓库

使用菜单 仓库 ‣ 设置 ‣ 仓库管理 ‣ 仓库, 然后点击新建配置一个新的仓库.

A warehouse is defined by a link between three locations:


	库位库存 字段显示了可以直接从这个仓库交付给客户的可用的产品.
可用数 给出在这个库位以及子库位的所有产品。

	The Location Input field shows where ordered products are received from a supplier in that warehouse. It
can be the same as the stock location if, for example, you want to do a quality control operation on
your incoming raw materials.

	The Location Output field (called Output in the demonstration database) is designed as a buffer zone
in which you store all the items that have been picked, but not yet delivered to a customer. You are
strongly advised not to put this location within the stock hierarchy but instead at a higher level or at the same level.




[image: ../../../_images/stock_warehouse.png]
仓库参数



你也能为仓库设置一个地址。这个地址应该是你的公司的一个地址。一旦仓库被定义，你能用在：


	最小库存规则,

	供应商订单,

	客户订单 (用在 POS的定义，关联到一个仓库).




自动产生需求

OpenERP 有多种自动供应(procurement)产品的方法：


	the workflow used by products that have the procurement method Make to Order,

	对于*Make to Stock*产品(存货制造)，可以使用最小库存规则

	对于*Make to Stock*产品(存货制造)，使用主生产计划(Master Production Schedule)



The last two methods are described below.




最小库存规则

当希望自动产生补货请求是，你可以使用最小库存规则. 菜单路径：
Warehouse ‣ Automatic Procurements ‣ Minimum Stock Rules.

规则如下：如果指定地点(location)的虚拟库存(virtual stock)比规则中指定的最小库存量少，
系统会自动建议采购，增加虚拟库存(virtual stock)的数量至规则中规定的最大值


[image: ../../../_images/stock_min_rule.png]
List of Minimum Stock Rules




Tip

Conflict Resolution

You may find draft production or procurement orders to be created although they should not exist.
That can happen if the system is badly configured (for example, if you have forgotten to set the
supplier on a product).

To check this, look at the list of procurements in the exception state in the menu
Warehouse ‣ Schedulers ‣ Procurement Exceptions. More
details about processing these exceptions is given in ch-mnf.



We underline that the rule is based on virtual quantities and not just on real
quantities. It takes into account the calculation of orders and receipts to come.

如下面的例子：


	库存中的产品数量：15

	已下单(Sales Order?)但是未发货的数量：5

	在制数量：2



定义的规则为：


	最小库存: 13

	最大库存: 25.



一旦规则被正确设置，采购经理只需要查看订单(采购订单)列表与供应商进行确认，菜单路径为 Purchases ‣ Purchase Management ‣
Requests for Quotation.


Note

Procurement

注意，供应请求不一定要求你从供应商处购买，如果产品有一个属性
Supply Method Produce,(注：即供应方式为生产)
主生产计划(scheduler)会产生一个生产工单，而不是一个采购订单



你也可以在规则中设置最小包装量(multiple quantities). 如果你设置的最小包装量为3，系统会建议一个15pieces的供应，
而不是真正需要的13。在这种情况下，系统会自动根据最小包装量取上整数。（注：即根据最小包装取整，多买一个最小包装的量）


Note

Maximum Quantity

注意一个事实，最大数量不是你库存的最大量。
比如：一个公司有10 pieces的产品，最小库存规则设置为，最小数量 = 10, 最大数量 = 30 及 最小包装 = 12
如果有一个预计的2 piece订单（销售订单），系统执行计算后会产生一个24 pieces的采购需求。
第一个12 pieces会用于达到最小数量，第二个12 pieces用于达到最大数量。



In a minimum stock rule, when you indicate a warehouse, it suggests a stock location by default in
that warehouse. You can change that default location when the scheduler completes.






库位

一个库位（或 货位）是仓库中的一个组成部分，用来管理所有类型的库存位置。 such as at the
customer’s and production counterparts.

根据你的需求，在你（在系统中）构建你的仓库时候，可以设置不同类型的库位。
Locations are structured hierarchically to account for the subdivision of a warehouse into sections, aisles, and/or
cupboards.
(译：库位是多层级结构的，用于将仓库分为更小的子层级，如 区域、通道 或者 cupboards(货架？))
The hierarchical view also enables you to structure virtual locations such as production counterparts.
That gives you a finer level of analysis.
Go to the menu Warehouse ‣ Configuration ‣ Warehouse Management ‣ Locations, then click New
to define new locations.


[image: ../../../_images/stock_location_form.png]
定义新库位



下面是几种常见的库位:


	供应商库位: 虚拟货位，代表产品是从供应商处接收的(如收货时候，源货位就是供应商货位，代表供应商库存减少)




	视图库位: shows that the location is only an organizational node for the hierarchical structure, and
cannot be involved in stock moves itself. The view type is not made into a leaf node in a
structure – it usually has children.

	内部库位:  您仓库中的物理货位

	客户库位: 虚拟货位，表示货物发送给了客户，(如销售订单发货后，客户货位增加，表示已经发给了客户)

	盘点/损耗库位: virtual location serving as the counterpart for inventory operations used to correct stock levels (physical inventories),

	Procurement: virtual location serving as temporary counterpart for procurement operations when you do not yet know the source (supplier or production). Products in this location should be zero after the scheduler run
completes,

	生产库位: 生产过程的虚拟货位，用来记录原材料消耗(发放至此货位)以及成品完工来源

	多公司间中转库位: 用于多组织环境中的中间过程货位。(如两个组织间调拨时候，货物仍在途的情况)



You can have several locations of the same type. In that case, your product, supplier and warehouse configurations
determine the location that is to be used for any given operation.


库位地址

每个库位可以指定一个地址，使你能够给客户或者供应商建立一个库位。
如：你能够设置库位地址为供应商或者客户的地址。
去 业务合作伙伴 界面，告诉OpenERP，他应该使用这个库位，而不是默认库位
(Go to the partner form to tell OpenERP it should use this location rather than the default location given to partner deliveries.)


Tip

Subcontracting Production

You will see in the on line chapter Manufacturing that it is possible to assign a location to a manufacturing workcenter.
If this location is at a suppliers, you must give it an address so that OpenERP can prepare a delivery order for
the supplier and a receive operation for the manufactured goods.
Creating a location specifically for a partner is also a simple solution for handling consigned stocks in OpenERP.




Note

托管库存(Consigned Stock)

Consigned stock is stock that is owned by you (valued in your accounts), but is physically stocked by your supplier.
Or, conversely, it could be stock owned by your customer (not valued by you), but stocked in your company. Make sure
that you create consignment locations as part of your internal stock.



To enable you to easily consolidate at a higher level, the location definition is hierarchical. This structure is
given by the field Parent Location. That also enables you to manage complex cases of product localization.

例如，你可以想象一下以下场景：一个公司有两个仓库

一个公司有两个仓库，一个在巴黎，一个在波尔多。对于某些销售订单，你需要从巴黎发货，另外一些订单需要由波尔多进行发货。
但你仍需要指定一个虚拟的仓库给OpenERP,让系统计算他应该由巴黎还是波尔多进行发货。
在OpenERP里面，你可以设置一个(虚拟)仓库“法国”，组合(consolidates)了巴黎仓库和波尔多仓库。
(注：也就是设定了 法国.巴黎，以及 法国.波尔多 ？)
你建立了以下物理库位：


	Company
	Output
	Warehouses France
	Warehouse Paris

	Warehouse Bordeaux















OpenERP会从有产品库存的仓库发货。
当产品在几个仓库均有货时，OpenERP会选择最近的仓库(进行发货)。
为了让系统知道仓库之间的距离，你需要为每个仓库设置地理坐标(X,Y,Z)，以便OpenERP搜索最近的货物。
同样，坐标可以用于构建仓库的货架、货道和内部房间。(注：即仓库内部坐标)




链式库位

OpenERP中的库位是可以相互链接在一起，以定义产品的路径的。
因此你能够定义如下规则：所有进入仓库的产品会自动的发送至质量监控(即检验货位)。
仓储和质检由两个不同的货位表示(即类似于收货时，在一个货位做质检，另外一个货位做储存)

这样，当一个货物到达库位时候，OpenERP会自动建议你将货物发送到一个链接的库位。
有3种链接的模式：


	手工操作(Manual Operation),

	自动移动(Automatic Move),

	自动无步骤添加(Automatic No Step Added).



手工操作 模式，一旦货物到达源库位，(系统)会创建一张内部物料搬运单(从当前库位)至链接库位
物料搬运单会等待用户的确认(confirmation of the move)。
This enables you to have a list of moves to do,
物料搬运单由系统建议，由仓管员(storesperson)确认。

自动移动(Automatic Move) 模式会做相同的事情,但不会等待一个用户的确认(即移动步骤系统自动完成了)。
不需要人工的接入，产品会自动发送到链接库位。
这适合于，为了简化操作，你删除了系统上的一个操作步骤，用户自己完成这个(物理的)操作流程。
(即系统上少操作一步，但是现实中库存人员还是做了两步，如检验-入库)

自动无步骤添加(Automatic No Step Added) 模式不会包含额外的库存移动，但会透明的将目标库位进行更改至链接库位。(即直接更改目标库位，不会产生上面两个模式中的物料搬运单)
You could then assign a destination location to which you
send all the products that arrive in your warehouse. The storesperson will modify the goods receipt note.


Tip

Product Logistics

The module stock_location lets you generate paths to follow, not just at the level of locations, but also at the
level of products. It then enables you to manage default locations for a given product or to refer to the products
as a function of operations such as quality control, supplier receipt, and after-sales service.

A more detailed explanation of this module, with examples, is given at the end of this chapter.



If there is linking to do, the Chained Location Type field allows you to determine the destination location. If the field
is set to ‘Customer’, the location is given by the properties of the partner form. If the field is set to fixed, the
destination location is given by the field Chained Location If Fixed.

Some operations take a certain time between order and execution. To account for this lead time, you can set a
value in days in the field Chaining Lead Time. Then the extra move (automatic or not) will be carried out several
days after the original move. If you use the mode Automatic No Step Added, the lead time is inserted directly into
the initial order. In this way, you can add security lead times at certain control points in the warehouse.




结构化库位

In the next part, you will see that by linking locations you can manage a whole series of complex cases for efficient production management:


	Handling multiple operations for a customer order,

	Tracking import and export by sea transport,

	Managing a production chain in detail,

	Managing rented products,

	Managing consigned products.



To show these concepts, different cases of structuring and configuring these locations are given below. Many other
configurations are possible according to company needs.

Examples:


	Handling customer orders



Customer orders are usually handled in one of two ways:



	item note (or preparation order), confirmed when the item is ready to send,

	delivery order (or freight note), confirmed when the transporter has delivered the item to a customer.






You use the following stock move in OpenERP to simulate these operations:



	Packing Note: Stock > Output,

	Delivery Order: Output > Customer.






The first operation is automatically generated by the customer order. The second one is generated by the stock management,
showing that the Output location is linked to the Customer location. The two operations will be displayed in Waiting status. If the
Output location is not situated beneath the stock location, you then have to move the item from stock to the place where
the item is prepared.

Some companies do not want to work in two steps, because it just seems like extra work to have to confirm a
delivery note in the system. You can then set the link mode to ‘Automatic’ to make OpenERP automatically
confirm the second step. It is then assumed all the items have automatically been delivered to the customer.


	Linked production



The stock_location module enables you to manage the linkages by product in addition to doing that by
location. You can then create a location structure that represents your production chain by product.

The location structure may look like this:


	Stock


	Level 1



	Level 2



	Link 1
	Operation 1

	Operation 2

	Operation 3

	Operation 4


















You can then set the locations a product or a routing must go through in the relevant form. All products that enter
the production chain will automatically follow the predetermined path.
You can see the location structure using Warehouse ‣ Inventory Control ‣ Location Structure.






商店

The counterparts for procurement, inventory and production operations are given by the locations shown in the
product form. The counterparts of reception and delivery operations are given by the locations shown in the
partner form. The choice of stock location is determined by the configuration of the warehouse, linked to a Shop,
which can be defined using Sales ‣ Configuration ‣ Sales ‣ Shop.

Once a shop is defined, you will be able to make sales orders from this shop. You need at least one shop in order to be able to make sales orders.




库存

In the Product form, the Stock by Location action will give you the stock levels of the various products in any selected location. If you have not selected any location, OpenERP calculates stocks for all of the physical locations. When you are in the Stock by Location view, click the Print button to print the Location Content or the Location Inventory Overview reports.


Note

Availability of Stock

Depending on whether you look at the product from a customer order, or from the menu of a product form, you
can get different values for stock availability. If you use the Product menu, you get the stock in all of the
physical stock locations. Looking at the product from the order you will only see the report of the warehouse
selected in the order.



In this respect, two important fields in the product form are:


	Real Stock: Quantity physically present in your warehouse,

	Virtual Stock: Calculated as follows: real stock – outgoing + incoming.




Note

Virtual Stock

Virtual stock is very useful because it shows what the salespeople can sell. If the virtual stock is higher than
the real stock, this means products will be coming in. If virtual stock is smaller than real stock, certain
products are reserved for other sales orders or work orders.




Tip

Detail of Future Stock

To get more details about future stock, you can click Stock Level Forecast to the right of the product form to
get the report Forecast Stock Levels as illustrated below. OpenERP shows a graph of the changes in stock
in the days to come, varying as a function of purchase orders, confirmed production and sales orders.




[image: ../../../_images/stock_forecast_report.png]
Printout of forecast stock levels




Tip

Filter Stock by Location

By default, in Product list view, the columns Real Stock and Virtual Stock show the stock figures for all stock
locations where a product is stored. Use the Extended Filters to enter a specific stock location, if you want to
only see the stock in a specific location.




提前期和库位

The tab Procurement & Locations in the Product form contains information about different lead times and
locations. Three lead time figures are available:


	Customer Lead Time: lead time promised to the customer, expressed in number of days between the order
and the delivery to the customer,

	Manufacturing Lead Time: lead time, in days, between a production order and the end of production of
the finished product,

	Warranty (months): length of time in months for the warranty of the delivered products.




Note

Warranty

The warranty period is used in the Repairs management and after-sales service. You can find more information
on this subject in the on line chapter about Manufacturing.



Fields in the section Storage Localisation are for information only; they do not have any impact on the management
of stock.

Counter-Part Locations Properties are automatically proposed by the system, but the different values can be
modified. You will find counterpart locations for:


	Procurement,

	Production,

	Inventory.



A procurement location is a temporary location for stock moves that have not yet been finalized by the scheduler.
When the system does not yet know if procurement is to be done by a purchase or production, OpenERP uses the
counterpart location Procurement. In this location, you will find everything that has not yet been planned by the
system. The quantities of product in this location cancel each other out.




期初库存

Once a product has been defined, use an initial inventory operation to put current quantities into the system by
location for the products in stock. Go to the menu Warehouse ‣ Inventory Control ‣ Physical
Inventories to do your initial inventory.


[image: ../../../_images/stock_inventory_new.png]
Defining a New Inventory Operation



Give a name (for example Initial Inventory or Lost Product XYZ) and a date (proposed by default)
for each inventory operation.

You have three ways of doing an inventory.


	Click the Import Inventory action and select the location concerned. You can choose to include child locations
and set the inventory to zero (especially useful to ensure the count is done correctly).

	You can update the inventory from the Product form. Go to the Information tab, Stocks section, and click
the Update button. On confirmation, OpenERP will create a Physical Inventory.

	You can manually add inventory lines. You can then enter data about the quantities available for each product
by location. Start by entering the location, for example Stock, and then select the product.
OpenERP automatically completes the quantity available for that product in the location shown. You can
then change that value to correct the value in stock.



Enter data for a single line in your inventory:


	Location : Stock,

	Product : PC1 Basic PC,

	Quantity : 23 Units.



When your inventory operation is finished, you can confirm it using the Confirm Inventory button to the bottom
right of the form. OpenERP will then automatically create the stock moves to close the gaps, as mentioned at the
start of this chapter. You can verify the moves generated using the Posted Inventory tab of the inventory operation
form.

The correct levels of your product are now in your stock locations. A simple way of verifying this is to reopen the
product form to see the quantities available in stock.


Tip

Periodical Inventory

You are usually legally required to do a stock check of all your products at least once a year. As well as doing a
complete annual stock check, OpenERP also supports the method of periodical inventory.

That means you can check the stock levels of a proportion of your products every so often. This system is accepted
in France as long as you can guarantee that all of your products have been counted at least once per year. To see
the last inventory count per product, use the report Warehouse ‣ Reporting ‣ Last Product
Inventories.

You can do this the same way for all products and all locations, so you only carry out small inventory operations
through the year, rather than a single large stock check at one point in the year (which usually turns out to be at
an inconvenient time).
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跟踪库存运动


货物接收

在OpenERP中, 你可以有3种方法来接收供应商提供的货物。

The first method is to manually enter the information in the incoming shipment. To receive the products
through this method, you have to go to Incoming Shipments section in the Warehouse
Management submenu, click New and then you enter the information about the receipt.


[image: ../../../_images/stock_getting.png]
Manual Data Entry for Product Receipt



The second method is to receive products from a generated incoming shipment. To achieve the reception
using this method, you have to go to Incoming Shipments section in the Warehouse
Management submenu. You will find the list of waiting incoming shipments.

The third method is to receive products by waiting products without looking at the shipment document.
You can validate the reception by products in Receive Products section in the :guilabel:`
Product Moves` submenu. With this method, you will be able to receive one product, regardless of the
document which is attached to this product.


按采购单接收供应商货物

If you use Purchase Orders in OpenERP, product receipts are automatically generated by the system when the
purchase order is confirmed. You do not have to enter any date, just confirm that the quantities ordered match the
quantities received.

Incoming Shipments forms are automatically prepared by OpenERP from the purchase management
process. You will find a list of all the awaited receipts in the menu Warehouse
‣ Warehouse Management ‣ Incoming Shipments. Use the order number or the supplier name to find the
right goods receipt form for confirmation of a goods-in. This approach enables you to control
quantities received by referring to the quantities ordered.


[image: ../../../_images/stock_picking_in_tree.png]
List of Items Waiting



You can also do goods-in data entry manually if there is no order, using the same menu by clicking the New button.

A new goods-in data entry form opens. Enter the supplier data in the Address field
and type the reference number from your supplier in the field Origin. You should then enter data about the products received in the lines.

The source location is already completed by default because of your supplier selection. You should
then give the destination location where you will place the products. For example, enter Stock.
At this stage, you can set a lot number for traceability (this function will be described later in
this chapter, so leave this field empty for the moment).

Once the form has been completed, you can confirm the receipt of all the products at the same time
using the Process Now button. If you want to enter data for a goods receipt that you are still
waiting for, click the button Process Later.


Note

Partial or Complete Reception

When you process the incoming shipment, you can choose between partial or complete.

If you have to validate a partial incoming shipment, click Process now and change the number of items
according to the quantity received.


[image: ../../../_images/product_to_process.png]
Confirm partial reception



Another object will be generated with a back order reference equal to the
Reference number of the incoming shipment already confirmed.


[image: ../../../_images/partial_shipment.png]
Process a Partial Incoming Shipment



Once the rest of the order has arrived and has been processed, both orders will be merged.




[image: ../../../_images/stock_picking_in_form.png]
Form for Entering Goods received from a Supplier Order



The products then arrive in stock and should reflect the quantities shown on the product form.

In the Incoming Shipments form, the field Invoice Control lets you influence the way you
send invoices to suppliers. If this is set to To be invoiced, a supplier invoice will now be
generated automatically in the draft state, based on the goods received. Your accountant then has to
confirm this pre-invoicing once the supplier’s invoice is received. This enables you to verify that
the invoiced quantities correspond to the quantities received.


Tip

Print the Packing List

In order to print the packing list of an incoming shipment, select the incoming shipment of which you need
the details and click Packing List in the panel at the right side of the screen.

This link is available in the Internal Moves and Delivery Orders sections.



In case you received damaged or wrong products, you can return them to the supplier. In the Incoming shipment
form, click the Return Products button. A window will open that lets you choose the invoicing
process to follow. Once you click Process, a stock move is generated with the same reference number
and return to specify that this is a return move.


[image: ../../../_images/return_product_stock_move.png]
Stock Move for Returned Products






按产品接收供应商货物

The approach shown above is very useful if goods receipts correspond to the original orders. If your suppliers
deliver items that do not necessarily coincide with the orders, however, it is easier to work by products received
rather than by orders.

From this version on, you can also handle receptions by product, even from List view. Go to Warehouse ‣ Products Moves ‣ Receive Products.

Filters allow you to easily select receipts to be done, and so on. One way to quickly receive products is to Group by Supplier and select To Do.

This is very useful functionality when your supplier sends the goods for several purchase orders at a time. You can now just receive the products, regardless of the purchase order they come from, simply by clicking the green arrow at the right side of the screen.

The List view offers great flexibility and allows you to rapidly receive products by keeping full functionality! Of course, you can handle both partial and complete receptions, and you can add information about the production lots and packs.


[image: ../../../_images/receive_products.png]
Receipt of a Supplier Order using Group By



This can be also accomplished from Form view.






内部库存调拨

You should install the stock_location module (from the list of modules, or through Reconfigure wizard, Advanced Routes) if routing products to customers, from suppliers or in your warehouse is determined by the identity of the product itself.


[image: ../../../_images/product_location.png]
Managing the Paths from one Location to Another in a Product Form



This will let you configure logistics rules individually for each product. For example, when a specific product
arrives in stores, it can automatically be sent to quality control. In this case, it has to be configured as a Push Flow
with rules in the Product form. The fields that make up those rules are:


	Source Location: the rule only applies if a product comes from this location,

	Destination Location: the rule only applies if a product ends up in this location,

	Automatic Move: Automatic Move, Manual Operation, Automatic No Step Added,

	Delay (days),

	Operation: a free text field which will be included in the automatic stock move proposed by OpenERP.



There are two main logistic flows:


	Pushed Flows

	Pulled Flows



Push flows are useful when the arrival of certain products in a given location should always be followed by a
corresponding move to another location, optionally after a certain delay. The original Warehouse application already
supports such Push flow specifications on the Locations themselves, but these cannot be refined per product.
Pull flows are a bit different from Push flows, in the sense that they are not related to the processing of product
moves, but rather to the processing of procurement orders. What is being pulled is a need, not directly products.
You will now see some examples of using these locations and logistics by product through Pushed Flows for:


	A rentable product,

	A product bought in China, following its freight by ship from port to port,

	A product that you want to send to quality control before putting it in stocks.



We will develop the third scenario: the quality control.

You can configure the system to put a given product in the Quality Control bay automatically when it arrives in
your company. To do that, you just configure a rule for the product to be placed in the Quality Control location
rather than the Input location when the product is received from the supplier.


Rule to Move Products manually from Input to Quality Control
  
    
    
    定期采购
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