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Lab Setup & Maintenance Handbook

All necessary information on setting up an E-Learning Centre can be found in this handbook.

If you have any queries, please contact Camara. All Camara E-Learning Centres must meet our high standards in
security and safety; equipment will NOT be installed in sub-standard labs.

Layout in Scribus
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1. LAB SIZE AND SHAPE


1.1 L-Shaped

ADVANTAGES OF AN L-SHAPE


	The teacher can observe each computer screen in the classroom without having to walk around.

	Students can seethe whiteboard without obstruction.

	It enables a lab to be set up in a smaller space



[image: image alt lg]

It is important that you correctly measure the room that is proposed will contain the computer lab. Also, note the location of all electrical sockets in the room




1.2 U-Shaped

Camara recommends that all labs be set up in a U-shape.

ADVANTAGES OF A U-SHAPE


	The teacher can observe each computer screen in the classroom without having to walk around.

	Students can see the whiteboard without obstruction.

	In large classrooms, it maybe useful to have chairs and tables in the middle of the room for the theoretical or discussion sections of the class, so that students are not distracted by the computers.

	This lab arrangement avoids cables in the centre of the room which helps to prevent tripping or other accidents.



[image: image alt lg]




1.3 E-Shaped

In some cases, e.g Polytechnic Colleges, Camaralabs maybe in an E­shape.

ADVANTAGES OF AN E-SHAPE


	Increases the amount of available space for learning and equipment.



DISADVANTAGES OF AN E-SHAPE


	Difficult to teach in as the teacher does not have full control of the room.

	Cables and wires must be carefully covered with secure trunking to prevent tripping and breakage
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1.4 Double U-Shaped

In some cases, e.g Polytechnic Colleges, Camaralabs maybe in a Double U-shape.

ADVANTAGES OF A DOUBLE U-SHAPE


	Increases the amount of available space for learning and equipment.



DISADVANTAGES OF A DOUBLE-SHAPE


	Are difficult to teach in as the teacher does not have full control of the room.

	Cables and wires must be carefully covered with secure trunking to prevent tripping and breakage.
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1.5 Accessibility & Safety

ACamara computerlab should be arranged so as to facilitate any student with impaired mobility.


ACCESS FOR PEOPLE WITH MOBILITY IMPAIRMENTS

[image: image alt >]

Doorway Openings:


	at least 81.5 cm (32”) wide



Work Surfaces:


	76 cm (30”) high

	70-75 cm (29”) floor clearance

	at least 51 cm (20”) deep

	minimum width of 1.5 cm (36”) to allow leg space for the seated individual



Aisle width:


	107cm (42“) to 122cm (48”) sufficient to operate a wheelchair.



Ideally, provide at least one adjustable workstation in your computer lab




FIRE SAFETY

[image: image alt >]


	The trainer should not leave the class while students remain present.

	All cables should be safely installed inside trunking to avoid impeding exit. Contact your Emergency Fire Control Centre for design advice



Adequate thought and planning in setting up the lab helps to create a safe and productive learning environment






1.6 Minimum Lab Sizes

[image: ]




1.7 Furniture & Fittings

[image: image alt >]

Camara PCs must be supported on strong, stable and sufficiently large tables, with students using sturdy chairs orbenches.

Computers should be spaced approximately 90 cm apart - this is to ensure that students are not cramped in the classroom, particularly when students are sharing workstations. Tables should be approximately 70 cm high.

All Labs should have a whiteboard (formica) but NOT a blackboard as chalkdust causes damage to computers.






2. INSTALLATION


2.1 Peripherals

Computer peripherals include mice,keyboards, monitors andprinters.

All devices and peripharles should be pluggedin at bootup. USB drives, headphones, etc. maybe plugged in after boot up.

The power cable is connected at the back of the PC. All Power cables are plugged into a surge-protected power bar or UPS (Uninterrupted Power Supply) battery powered power supply unit.

The mice andkeyboard are connectedto the PS/2 ports at the back of the computer.

A flashing green light next to the ethernet port, when an ethernet cable is connected, indicates an active network connection.

The monitor is plugged into a video card port at the back of the computer with a VGA cable. Note: The video card may have a DVI port. If so, a DVI to VGA adapter is required in order to attach a VGA monitor. The adapter must be firmly attached to the computer port.

This section contains essential information to help you set up a Camara computer lab and understand the importance of certain aspects in creating the optimal environment.




2.2 Networking

If yourlab is networked, you may have access to a very large range of extra software, including server-based teaching tools such as Moodle. If an Internet connection is present you may have access to email and the Web at each PC.
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2.3 Printers

It is necessary, before buying a printer, to ensure that is compatible with the installed version of Camarabuntu (Ubuntu).

Ifa network is present, the printer maybe attached and accessed by all networked computers in the lab.
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3. POWER & PROTECTION


3.1 Surge Protection

All Camara Labs MUST have a surge protection unit installed at the E­-Learning Centre. This will prevent damage to the equipment when there are spikes or drops in power.


UPS - UNINTERRUPTED POWER SUPPLY

Camara recommends that an Uninterrupted Power Supply (UPS) be used with computers and equipment where a loss of power could cause a permanent loss of information; UPS’s provide short-term electrical power should the normal supply fail.
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3.2 Cables, Sockets & Trunking

Each Computer-Monitor pair must have one twin socket. For example, a 10 PC lab needs 10 twin sockets for the computers and monitors.You will need additional sockets for networking, wall fans, printers, scanners and projectors.


INSTALLATION

Sockets should be installed below the table line, this will prevent younger students from interfering with them.

All electrical wires should be contained within sealed, insulated trunking. The thickness of the wiring should be 2.5mm or higher. This will prevent shorting due to leaks, loss of current and injury to students and staff.

The thickness of the wires connecting the mains to the surge protection should be between 6-10mm.
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3.3 Backup

It is important to regularly make copies of (or back up) data so that these additional copies can be used to restore information in the event of a data loss.

Backups can restore a system state following a disaster; you can also restore small numbers of files after they have been accidentally deleted or corrupted.

Consult your Camara Technical Representative.






4. SECURITY & SAFETY


4.1 Securing the Lab

It is essential that the computer lab be fully secured. Camara will not install PCs in an insecure location.




COMPUTERS LABS MUST HAVE


	A solid steel or grilled door with a strong lock

	Grilled windows (with the bars firmly attached to the wall)

	Solid walls with no gaps or holes

	Sealed and secured roof/ceiling (if the lab is in a building of its own, a ceiling is not essential provided that the roof is sealed and secure). The ceiling should be strong and made of three-ply or stronger, to stop dust and falling objects from entering the room.

	Cemented floors. These can be covered by carpet or another material, as long as it is non-slip and well-maintained (i.e. no torn edges which can cause people to trip).

	Windows that can be opened. Louvres should be placed over the windows to prevent dust and rain from entering the room; this will also allow light to pass through.

	An alarm system will add further protection, but this is not mandatory for receiving Camara computers.






4.2 Lab Safety




REDUCE THE RISK OF DAMAGE TO COMPUTER PERIPHERALS


	No smoking, food, or drink should be permitted in computer labs, as they can damage the equipment and attract insects or rodents.

	Supply garbage bins, and keep workspaces clean and clear of sharp objects and debris.

	Secure monitors, keyboards, mice and audio hubs to prevent removal and theft.

	Attach a small padlock to the back of each PC to prevent internal components, especially RAM, from being stolen.



The standard user account is camara (password: camara). The administrator’s password should not be disclosed to students.




4.3 Inventory & Lab Access

Camara will supply a full inventory of all equipment supplied upon the completion of any installation. This record is an important document and should be treated as such.

Camara computers are valuable items and access to the lab should only be afforded to appropriate people, the lab should remain locked outside of school hours unless an officially-sanctioned event/training is taking place. Also, a teacher should always
remain in the lab when students are present; this is both for the safety & security of the lab, and the students.

Some computer malfunction may be because of missing internal components. The supplied inventory can be referred to, e.g. to compare the amount of installed RAM in a PC to the amount of RAM originally supplied by Camara (min. 512 MB).




4.4 Ventilation

A computerlab must have good air circulation.


AVOID DAMAGE TO ELECTRONIC COMPONENTS DUE TO OVERHEATING

Computers can generate a lot of heat. Without good air flow it may be difficult for anyone to use the lab for extended periods of time. Camara Labs must be well ventilated as computers are easily damaged by the excess heat.

Classrooms can become quite hot and computers increase the room temperature. In hot regions, rooms must be kept cool by adequate airflow provided by windows and fans, or air conditioning. It is advisable to place thin netting over the windows or louvres to prevent dust from entering the room. This will still allow light and air to pass. Rooms should have fans placed at regular intervals.

Fans may be either wall- or ceiling-mounted, as pictured.
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5. MAINTENANCE


5.1 Safety & Repair

Only trained individuals should fix faulty equipment. Please contact Camara in the event of any problems.

All machines should be powered off and disconnected from the mains before being opened for inspection or cleaning. Even small electrical charges or static can cause irreparable damage to equipment.

Computers contain small and valuable parts that are easily removed – often with little visible change to the machine, but rendering the computer completely inoperable. It important that only trusted individuals have access to, or are allowed to open, the
computers.

The school administration and teachers should be familiar with the parts of a computer and conduct regular checks to ensure nothing is missing or taken. Camara will provide you with a full inventory, including parts, when you receive the computers
for your lab.




5.2 Troubleshooting

Here are some tips to guide you if the following situations occur:


KEYBOARD NOT RESPONDING

Press the Num Lock key to ensure the keyboard is connected and active. (The corresponding LED light should blink on and off).








6. COMPUTER PARTS

[image: image alt >]


RAM

RAM: Random Access Memory. A computer may have multiple RAM sticks. Camara computers have at least 512 MB of RAM (e.g. 1 X 512 MB, 2 X 256 MB). If all the RAM sticks are removed, the computer cannot function and will not turn on. If some, but not all, of the RAM IS removed the computer will operate very slowly.

[image: image alt >]




Hard Drive

The hard drive stores all of the computer’s information; Hard Disk Drives (HDD’s) come in a range of sizes – the larger the hard drive the more space there is to store information. Without a hard drive, the computer cannot not operate.

[image: image alt >]




Motherboard

The motherboard contains all of the components, including the Central Processing Unit (CPU), and all parts of the computer
are connected to it. If the motherboard is damaged, the computer will not work. If the processor is taken out, the computer
will not work. A processor is very difficul and not generally viable, to replace.






7. CAMARABUNTU


7.1 Introduction

The type of operating system determines how someone can use the various programs and interface on a computer. Examples of different
operating systems are: Windows 7, Windows XP, Ubuntu Jaunty and Apple’s Snow Leopard.

The Ubuntu Operating System is Free and Open Source Software (FOSS). This means that you do not need to pay a licence fee to use it. Unlike non open source software, you can also make changes to it and give it to your friends and colleagues without breaking the law.
There are number of other advantages of using Ubuntu:


	It is affected by very few viruses

	It is very stable

	It is takes less time for programs to load and so is faster than many other operating systems.

	You can access thousands of programs and educational tools at no cost.

	You can run many Windows programs on Ubuntu, including Microsoft Office.



[image: ]




7.2 Navigation

For most users, the most substantial difference between Ubuntu and other Operating Systems is the user interface and navigation.

Ubuntu is simple to navigate and you will notice only small differences between Windows and Ubuntu. After completing Camara training, teachers will be able to use the educational materials and tools to teach students confidently and comfortably.

In the case of any problems, Camara is on hand for ongoing support and guidance. In Camara’s experience, students taught how to use Ubuntu are able to easily adapt to and use other operating systems and programs.

Camara supplies its own version of Ubuntu – Camarabuntu – which includes much educational software and tools. The server provided to each lab holds a large software store, so schools can install programs without Internet access or CDs/DVDs.
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8. PRODUCT LIST


8.1 Product List

SECURITY


	Steel Doors

	Grilled Windows

	Internal Locks

	External Padlocks

	Three Ply (Ceilings)

	Softboards (Ceilings)

	Nails

	Screws

	Concrete



POWER & PROTECTION


	Surge protection

	UPS (optional)

	Twin sockets

	Twin switch box

	Screws & Nails

	Wood pegs

	Electrical Cable x 2 types

	Trunking Tube

	Lights



VENTILATION


	Steel Doors

	Ceiling Fans

	Wall Fans

	Louvres

	Air Conditioning Units



FURNITURE & FITTINGS


	Timber

	Tables

	Desk

	Chairs

	Whiteboard








9. COMPUTER COMPONENT & INSTALLATION GUIDE


9.1 Computer Component Introduction

The components or layout illustrated here may be different from your yours. For specific hardware installation, you may refer to the Quick User’s Guide.

You can browse any section of this guide, however, if you read the manual from the front to the back, you will find a logical installation progression.


SYMBOLS USED IN THIS SECTION

[image: ]

TOOLS NEEDED

For the sake of safety and convenience, have these tools to hand before starting work. A cross- or flat-head screwdriver, can be used for most of the installation.

[image: ]

Pliers can be used as an auxiliary tool to pull out the power connectors or remove the brackets. Forceps or Tweezers can be used to pick up tiny screws or set up the jumpers.

An electrostatic wristband can cuts and injury from static electricity.






9.2 General Layout

Below is an example of a typical general installation. The layout of your mainboard may be different from the image below.

[image: image alt lg]




9.3 Components in Detail

DIMM/RAM SLOT

The DIMM slot is used for installing RAM modules.

[image: ]

IDE AND FLOPPY DRIVE INTERFACE SOCKETS

These connectors allow the installation of IDE devices, such as Hard & Floppy Disk Drives.

[image: ]

IDE DEVICE CONNECTOR

The connector, or ribbon cable, enables the installation of IDE devices, e.g. CDROM Drive.

[image: ]

ATX 20-PIN POWER SUPPLY CONNECTOR

This connects the ATX power and provides power to the motherboard.

[image: ]

PCI SLOT

This slot is provided for expansion card with PCI interface. Example - an Audio card for dedicated audio control.

[image: ]

RAM MODULE

Random Access Memory is used when an application, such as a word processor, is in use. The computer temporarily saves the data to the RAM until the user saves the document.

This is why data is lost if the computer is switched off accidentally or improperly.

[image: ]

BIOS BATTERY

The BIOS battery is a standard metal oxide battery.

It does two jobs; first it keeps the computers clock going when it is off; second, it stores information such as RAM size, computer speed and hard drive size.

[image: ]

AGP SLOT

The Accelerated Graphics Port is a slot provided for VGA cards with an AGP interface.

These are primarily used for monitors with high display resolutions. They can also allow the computer to be connected to a projector.

[image: ]




9.4 Installing RAM Modules

We take the DDR (Double Data Rate) RAM modules as an example to show you the installation process. Consult your agent for the proper RAM modules.

[image: image alt lg]

Installing the Floppy Disk Drive

[image: image alt lg]




9.5 Installing IDE Devices

[image: image alt lg]




9.6 Installing Expansion Cards

INSTRUCTIONS

[image: image alt >]


	Remove the computer case.

	Remove the corresponding bracket obstructing the expansion card.

	Locatethe AGP slot onyour mainboard.

	Put the card directly over the proper slot and press one end of the card into the slot first. Gently but firmly press the other end until it is fully seated in the slot.

	Secure the card with a bracket screw.

	Install all other cards and devices and connect all the cables, and then replace the case.



[image: ]




9.7 Installing the BIOS/CMOS-Battery

The CMOS (Complementary Metal-Oxide Semiconductor) battery is located on your computer’s motherboard. It’s similar to that in a handheld calculator.

[image: ]


	GET ACCESS TO THE MOTHERBOARD

Unplug the computer and disconnect all of the cables. Remove the side or top panel to reveal the motherboard.



	LOCATE THE BATTERY

The most common type of CMOS battery is CR2032, a round, silver-colored battery about the size of a US dime coin.



	REMOVE THE OLD BATTERY

Next, remove the old battery. Different motherboards have various configurations of clasps that keep the battery clipped to the motherboard. Be careful not to break the retaining clips, or anything else, on the motherboard.



	INSTALL THE NEW BATTERY

Now install the new battery. Be sure to put the poles in the same position as the original battery: For a CR2032, the positive pole (marked with a plus sign [+]) should be facing up. Use the clips to hold the battery in place.





[image: ]
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9.8 Front & Back Panels

The font and rear panels on your computer may differ from those illustrated here.

[image: image alt lg]
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9.9 Connecting Power

INSTRUCTIONS


	Plug the ATX 20-pin power connector in the female receptacle provided on your mainboard.

	The connector is entirely plugged in securely when you hear the click sound.



[image: ]
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9.10 CheckList

Please use this check list to ascertain the status of your proposed lab.
Once all the boxes are ticked, please notify us so that we can verify
that your lab is ready to receive computers.


	[  ] Is there a steel door?

	[  ] Is there a cemented floor?

	[  ] Are there concrete walls?

	[  ] Is there a ceiling?

	[  ] Are there grilled windows?

	[  ] Are there glass windows?

	[  ] Is there adequate ventilation?

	[  ] Is there a whiteboard?

	[  ] Is there power in the lab?

	[  ] Does the lab have surge protection?

	[  ] Are there secure, stable, sufficiently large tables?

	[  ] Are there enough sockets?
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ICCES Manager training: Basic Computer Skills and Maintenance

[image: ] The story of modern electronic digital computing
should start with Alan Turing, the man for whom the Turing Trust is
named. Turing published a paper in 1936 On Computable Numbers, with an
application to the Entscheidungsproblem. The paper proved that you
could build a machine capable of processing a digital stream of 1s and
0s according to programmed instructions and it would be capable of
solving any computable problem. As it happens, the set of problems
included in this definition is the universe of mechanically solvable
problems. Hence, the Turing Machine is also known as the Universal
Machine, the theoretical precursor to the electronic digital computer
which we use today.

So what is a computer? The computer’s like the human brain. Your brain’s
there inside your body and controls everything your body does, but the
only way you can see it is if you take a look inside your head. When it
comes down to it, the computer is a brain, too; it’s a tiny chip inside
a machine such as a desktop or a laptop, a phone or a car, which, with
your help, controls how the machine works. You don’t need to know how
the chip does its job. It does what it’s told, using instructions
programmed into it by people who know how to tell it what to do.

So the way the computer works is really quite simple. The computer (the
tiny chip) receives input in the form of data, which it processes
according to programmed instructions, and then outputs the processed
data in a form that meets our needs. Input-Processing-Output (IPO).
That’s it. The computer repeats this IPO process over and over again,
millions of times a second, to produce something useful for you and me.

Software, programs such as a word processor or a video game or a
spreadsheet, runs on the computer and accepts input from people like
you and me. The input can also come from other computers if it’s
connected to a network like the Internet. Input can even come from
sensors that have been set up to capture data from the environment (like
weather sensors, or traffic sensors, or cameras, and so on). Inside the
computer are what are called processors, which accept the input and
process it according to the instructions in the program (the software).
After the processing is complete, the computer outputs the processed
data onto some kind of output device, such as a screen, or a printer, or
a speaker, depending on what you, the user, want it to do.

Who would have thought that such a simple machine could do all the
wonderful things that we rely on computers for today? Most manufacturing
today is done on machines controlled by computers. Most office work is
now handled by computers. Hospitals rely on computers to manage all that
patient data and to process all those medical tests and screenings.
Every car on the road has dozens of little computers inside, monitoring
the car’s performance; the same for planes and trains, and ships and
spaceships. The internet (and your phone now relies on the internet) has
transformed our world into a global village, where everyone everywhere
is now no more than a few seconds away from everyone anywhere else in
the world. We go shopping on the Internet; we use the Internet to find
out anything we want to know.

And we’re just beginning to discover what the computer can help us do!


Part I: The Components of a Computer & Basic Operations


Chapter 1: Hardware

[image: ]


Turning the computer on

Booting

Bootingyour computer is the process of starting or restarting it and
starting the operating system. Turning it on may include turning on the
screen as well as the computer. If the screen is separate from the
computer, you will need to turn on the screen first so that you can see
what’s happening when you turn on the computer itself.

Hard and soft boot

A hard boot is when you start the computer using the power button (see
left Figure below). This is also sometimes called a cold boot, because
the computer is not yet warmed up by the flow of electricity. A soft, or
warm, boot is when you restart the computer without turning it off.
You do this using the Restart option in the Start Menu (see right
Figure below).

[image: ] [image: ]




The Processor

ALU—the Arithmetic & Logic Unit

All you need to know about the ALU is that it’s the central “brain” of
the computer; it does all the computation that the software tells it to
do. As such, it’s the most important component in a computer, though
it’s the one we’re least aware of.

Memory

The computer would be just a useless machine without somewhere to store
all the data used during the processing done in the ALU. Memory enables
the computer to store and save the data before and after processing.

There are two types of computer memory: Primary memory and Secondary
memory.

Primary memory (RAM and ROM)

Primary memory is really part of the ALU. Read Only Memory (ROM)
contains special programs the system needs to start itself up during the
boot process explained above. These programs, such as the Basic
Input-Output System (BIOS), are hardwired on the chips inside the ALU
(see Figure below).

[image: ]

Intel’s Core 2 Duo logic board

Random Access Memory (RAM), also called working memory, is made up of a
lot of other chips, all interconnected, which, at any one time, contain
the programs (software, applications like Word or Internet Explorer or a
video game) that are actually running on the computer when you’re using
it to do work, or when you’re playing video games, and so on.

Secondary memory

This is the memory that you have on the computer’s hard drive, or on
your USB drive, or on CDs and DVDs, or Flash memory cards, like the ones
in your camera (see Figure below).

[image: ]

There are lots of types of Secondary memory, even what they call “The
Cloud,” which is Secondary memory that companies like Google or
Microsoft manage for you so you can store all your data (photos, video
clips, Word documents, Spreadsheets, etc.) out there on the network.
We’ll talk more about networks in a bit. There’s no limit to the size of
Secondary memory; it’s literally as big as you want it to be so you can
store all your stuff. We’ll talk about how to sensibly store all your
stuff in a bit, too.




Input devices

A picture tells a thousand words, so he’s a picture which illustrates
all the different types of input devices (see Figure).

[image: ]

The Keyboard

The most traditional input device.

Mouse

The input device that is now commonly part of the Graphical User
Interface (see Part I, Chapter 3, p. 11).

Touch pad

Most common on laptop computers, used with your finger or a stylus
instead of the mouse to scroll and move the mouse pointer on the screen.

Touch screen

Most modern mobile phones use a touch screen so you can scroll through
pictures or text on the phone’s screen. But now regular desktop and
laptop computers come with touch screens if you have the latest
Microsoft operating systems.

Microphone (voice input)

A microphone can be plugged into your computer, or it can come built-in
to the computer screen, so you can speak into the computer and record
your voice, or send your voice over the network when you’re chatting
with someone online.

Camera (video input)

A camera is now more often than not a part of your computer screen, and
certainly built into any modern mobile phone, allowing you to take
pictures or video that you can share with others on the network, or
simply store for your own use.

Scanner

The scanner (illustrated on the previous page) allows you to make a copy
of any paper document or picture and scan it into the computer as a
digital image made up of thousands or millions—even billions—of bits or
pixels, depending on the quality of the scanner’s resolution. A pixel
(PIcture Element) is another name for one of the dots that make
up the scanned image. The more dots, the better the resolution. Low
resolution (thousands of bits) is not nearly as sharp an image as high
resolution (millions or billions of bits).




Output devices

A picture tells a thousand words, so he’s a picture which illustrates
all the different types of output devices (see Figure).

[image: ]

The Screen (Monitor)

The computer screen (or the display on a mobile phone) is the most
traditional computer output device.

Speakers (voice output)

Speakers are built into your computer so you can listen to music or
speech, or hear someone you’re chatting with over the network when
you’re online.

Camera (video output)

A camera (such as a webcam) is built into most every modern
computer—desktop or laptop or phone—so you can see who you’re chatting
with online, or play back video that you’ve captured using the camera.

Printers

There are all kinds of printers. The most traditional printer is the one
attached to your computer, whether it’s inkjet or laser. Inkjet printers
are cheap and provide pretty good colour images, but laser printers are
much higher resolution and also produce the printout much faster than an
inkjet printer. But today they have 3D printers—printers that actually
MAKE THINGS like models and all kinds of 3-dimensional objects. Hold
onto your seat, but they’re now using 3-d printers to make human body
parts (from stem cells)! Yes, it’s mind-boggling, like so much to do
with computer technology.




Communications

Communication is not the same thing as Communications.

Communication, without an “s” on the end of the word, is all about the
art of communicating using writing (in books and magazines, etc.) and
speech (where one or two people are chatting together or where an
audience is gathered for a formal or informal address).
Communications with an “s”, on the other hand, is all about using
electronic media, such as those we’re going to discuss in this
section, for the purpose of Communication. It’s a subtle difference, and
one of which most people are unaware, but it’s good to know, all the
same.

Networks (LAN and WAN, wired and wireless)

In general, electronic media such as the phone and so forth operate over
networks, which can be Wide Area Networks (WANs), linking people in a
village or a town or a city or a nation or between nations, and Local
Area Networks (LANs), linking people in the same house or the same
building. LANs are usually linked to WANs. Today we think of the whole
world as one big networked planet. The WANs and LANs are linked together
either over physical wires and cables strung from telegraph poles or
buried underground or even running along the ocean floor, as well
wireless transmissions via satellites orbiting the earth and microwave
towers dotted over the landscape.

Phone

Today, the modern phone works hand-in-hand with the Internet. It’s
become what they call an “Edutainment device”—something you can use not
just for chatting with your family and friends and business associates
and so forth, but also to access the Internet (see next section), to go
shopping, to book airline flights and call a taxi, and even to watch
movies. You can also use it to write memos and so forth (see personal
organizers in Part I, Chapter 2). The modern phone is rapidly becoming
something that you really cannot be without, which is why they’ve become
mobile, of course.

Email

Email is a method of exchanging digital, computer-based messages from an
author to one or more recipients. Modern email operates across the
Internet. The neat thing about email is that it enables you to send
messages more or less instantaneously around the globe. By contrast,
traditional mail (using the Post Office) is still relatively slow, which
is why it’s called snail mail!

Internet

So the Internet is the mother-of-all communications devices. It
incorporates phone technology and, with the rapidly increasing number of
apps (applications) that are being written for it, the Internet-capable
phone, as a mobile device, is becoming an integral part of all aspects
of our daily lives. It’s like you really want to pick it up and go. Yes,
you can access it on your desktop computer, but you can’t take your
desktop with you. You want it in your pocket or your purse, and that’s
where it will soon (easily within 10 years) be for almost everyone alive
on the planet. Already, in 2014, almost 90% of people on earth have a
mobile phone—that’s 9 out of 10 people. It’ll be closer to 100% by 2014,
guaranteed.

Skype

Skye is a free internet telephone service which incorporates video as
well as speech. It is pretty good, too, though the images are not as
sharp as if you pay for it using a subscription service, and the sound
quality may not be so good either. But it is a free video phone service.

Social Media

Some of the more popular apps available on the internet are what are
called Social Media—Facebook, Twitter, Instagram, and so on. These apps
make it very easy for you to interact all day and all night with family
and friends—if you can afford the internet subscription. The world is
becoming a tiny village where anyone anywhere can quickly and easily
touch base with anyone else. This is changing the way we live.






Chapter 2: Software

Software Applications in general

An application is a computer program designed to help people use the
computer to perform an activity. Examples include an accounting system,
a library management system, a phone network management system, a
manufacturing control system, an image processing program such as Adobe
PhotoShop, video games of all kinds, and so on.

There are literally thousands of applications such as these, and more
are being written by programmers every day.

Office Productivity Software

Office productivity software, such as Microsoft Office, has been
designed to standardize applications such as word processing,
spreadsheets, database management, and presentation software, as well as
drawing and personal organizer software. Standardization means that each
of these office productivity tools has a similar look and feel, which
makes them easier to learn and use.

ICCSE, in collaboration with The Turing Trust, is making available a
separate set of tutorials to help you learn many of the features of
these Office Productivity tools. Let’s briefly take a look at each of
them now so that you know what to expect when you work your way through
the Office tutorials.

Word processing

[image: ]A word processor, such as Microsoft Word or
LibreOffice Write, is designed to help the user with the composition,
editing, formatting, and sometimes printing of any sort of written
material, such as letters, papers, memos, résumés and curriculum vitae
(CVs), contracts, advertising flyers and other signs, greeting cards of
all kinds, and so on. The most useful features of a word processor are
that (a) it makes correcting mistakes easy; and (b) it makes editing,
updating, and formatting of text a snap once you’ve learned how to use
the software. Above all, the word processor makes you look good!

The Spreadsheet

[image: ]Historically, spreadsheets were maintained in
accounting journals or ledgers. They date back to the 14th and 15th
centuries. Nearly 500 years later, in 1978, Dan Bricklin, a young
graduate student at the Harvard School of Business in the USA, came up
with the idea for an interactive spreadsheet and, together with Robert
Frankston, developed the first computer-based electronic spreadsheet
application (called Visicalc).

Pretty soon, every large and small business in the world wanted an
electronic spreadsheet to help them manage their business accounting.
And not long after that, the application (called Excel in Microsoft
Office, Calc in LibreOffice) was being used to manage any kind of
columnar/tabular data, such as weather info, scientific/research data,
even simple apps like an address book or a CD collection. It has all
kinds of built-in mathematical functions and formulas, along with
easy-to-use formatting and layout tools. Think of it like a word
processor for lists of data, whether the lists be numbers or text.

Database Management

[image: ]A database is an electronic storage system that
holds any and all data that you need to access and use. Adatabase
ManagementSystem is a collection of programs that enables you to store
all that data, modify it, and extract information from the database.
“Knowledge is power”; data is the raw material of knowledge. But data is
only useful if you can easily access it and use it to help you in your
daily life. That’s where a database like Microsoft Office Access or
LibreOffice Base comes in handy. It’s like a library that’s organized
in such a way that you can use it to answer questions and accomplish
tasks that would be very hard, if not impossible, without it.

Presentation Software

[image: ]Presentation software such as Microsoft Office
PowerPoint or LibreOffice Impress, are tools designed to help you
present data in the form of multiple media—multimedia—that might be
text, still images, video and/or sound. Presentations are not designed
to teach as such; rather they are designed to help you teach. But they
may, nonetheless, be useful as standalone tools for presenting useful
information.

So, computer-based presentations have various uses. A good teacher or
presenter will often want to use audio-visual multimedia material to
help the members of his or her audience to learn. Computer-based
presentation tools enable the presenter to gather together this
instructional media and organize into attractive, eye-catching,
audio-visually appealing slides that are more likely to engage the
audience’s attention and understanding than simple speech.

A well-designed computer-based presentation can also be displayed online
or in the foyer of a building to give the viewer an overview or
description of some topic of interest, such as a company or university’s
history and goals.

Drawing/Graphics Tools

[image: ]Each of the Office applications is designed for
a particular purpose. Excel is a number cruncher, Word is a powerful
word processor, and PowerPoint is a presentation application
extraordinaire. Although you use the different Office applications for
different purposes, graphics—images, shapes, and clip art—are used for
pretty much the same purpose in all the applications.

Graphics enable you to enhance information and add interest to the
spreadsheets, documents, and presentations that you create. In MS Office
or LibreOffice, the commands and tools used to insert and modify images,
shapes, SmartArt graphics, and clip art are very consistent across the
different applications in the Office suite. So, if you know how to use
graphics in Word, you can apply that knowledge to another Office
application, such as PowerPoint.




Chapter 3: The Graphical User Interface (GUI)

WIMP

The key features of GUIs are the Windows, Icons, Menus, and
Pointers (the components of the so-called WIMP interface) which are
now common to all types of computers—whether it’s a desktop computer,
laptop, tablet, or phone.

[image: ]

Touch screens have now been added to the GUI mix, and the point is that
these interaction tools have made it possible for more or less anyone to
use a computer—even children as young as two years of age.

So you have no excuse for not becoming skilled in the use of a computer.
All you have to do is practice and, as we all know, practice makes
perfect! You’re no doubt already familiar with the GUI from your
experience using computers at various times and in various places during
the course of your life. It’s hard to avoid computers these days. But
you might like to learn some of the keyboard shortcuts that by-pass the
GUI and let you get things done more quickly than if you use the mouse
and point and click.

Quick keyboard shortcuts

Take a moment to try out each of the shortcuts illustrated in the Figure
below, and keep this Figure handy for future use.
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Chapter 4: Working with Files

In computer terminology, a file is any kind of digital object[^1] that
you have created using the computer. Over the years since the digital
computer was invented by Alan Turin in 1936, people have come up with
various ways of using just 1s and 0s to represent text (the characters
on the keyboard), still images and video (which is really just still
images running rapidly one after the other to create a motion picture).
It is also possible to use 1s and 0s to represent sound and even
smells (scents) and tastes (there are computers that have been
programmed to taste wine, for example).

The most common files that you are likely to create and save are text
files and image files (photos, charts, drawings, for example), and
you’ll also often store files that combine text and images. If you learn
to use Office Word, you’ll be creating mostly text files, though
you’ll sometimes include images among the text. If you learn to use
Office Access, you’ll be creating and saving database files. If you
learn to use Office Excel, you’ll be creating and saving spreadsheet
files. And if you learn to use Office PowerPoint, you’ll be creating
and saving presentation files.

Creating files

Every time you take a photo with your phone or any modern camera, you’re
creating a file. It’s a digital file in one of several image formats,
such as .jpg, or .gif, which is automatically saved with a default name
on the memory card in your camera or phone. Every time you use Office
Word to Open a New Blank doc, you’re creating a file, which is empty
until you type some text into the document, such as a letter, and this
new file, too, is saved with a default name—unless you name it yourself.

Naming and renaming files

Naming files is VERY important. Who knows what an image file called
DSCN1525 contains? That’s the kind of default name your camera or phone
gives to the photo files you take. What you should always do, when you
upload the pictures from your phone or camera to a computer such as a
desktop, laptop, or tablet, is rename the picture files with a name
that describes in a couple of words what the picture is all about.
Likewise, if you have a Word document on your computer with a default
name that doesn’t describe what’s in the document, you should rename it.
This is easy enough to do.

As illustrated below, the computer stores all your files in a hierarchy
of folders:

[image: ]

The easiest way to rename a folder or file is by right-clicking on the
name of the folder or file, which brings up what’s called a Context
menu (see Figure).

[image: ]

So whenever you right-click on any object on the screen a Context menu
pops up, which gives you a menu of options that you can carry out on the
object you’re pointing at—such as the option to Rename the file called
DSCN1199. In the Context menu, you select the option to Rename, and
the system highlights the name of the file in blue. Now all you have to
do is type the new file name and hit the Enter key on the keyboard.
Easily done.

[image: ][image: ]

Saving files (Save and Save As)

When you create a new document in Word or any of the other Office
programs, and you go to Save the file, Office will assume that you’ll
want to give the new file an appropriate name. So it will display the
Save As dialog box to prompt you to do this. Notice (see the first
Figure below) that Office automatically chooses a file name based on the
first few words of the new document you’re saving. At this point you
also have the opportunity to decide where you want to save the file—on
the desktop or in one of the folders you already have on your disk
drive. You’ll have the opportunity to practice doing this many times
when you work your way through the ICCES Office tutorials.
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While this Office default name is still highlighted in Blue, you’ll go
ahead and type a file name that briefly describes the content of the
document—in this case Application Letter—and then, still in the dialog
box, click on the Save button (see Figure below).

[image: ]

Organizing files

As illustrated above on pages 14-16, you really should be careful to
give good names to your files and organize them all into folders on your
disks so that they are easier for you to find when you need them. It can
be a pain to do this, but in the long run you’ll be glad you did. When
you work your way through the various ICCES Office tutorials, you will
have lots of opportunities to practice doing this, so you don’t need to
worry about the process at this time. Just be aware that it is
IMPORTANT, in the same way as it’s important that you store things in
your house in some tidy fashion so that you know where everything is.

Deleting files

Deleting files is a bit like the process of cleaning house. After a
while you’ll have hundreds, even thousands, of files on your disk
drives. You may well have duplicates of files all over the place, or you
may have files that you no longer need or want. Deleting them is easy to
do. Basically it’s the same process as when you rename a file. The
easiest way to delete a folder or file is by right-clicking on the
name of the folder or file, which again brings up a Context menu
(see Figure).
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This time, instead of Renaming the file, you want to Delete it. When
you select the option to Delete the file, you’ll be prompted to confirm
that this is what you want to do.

[image: ]

When you click on the Yes button, the file is still not actually gone
altogether. Windows (the Operating System on your computer) puts the
deleted file in the Recycle Bin on your desktop and leaves it there
till you decide to actually throw it away by emptying the Recycle Bin.
In other words, you can still recover the file if you want. To empty the
Recycle Bin, you just go to the Desktop and right click on the Recycle
Bin icon to bring up the Context menu (see Figure) and, in the menu that
pops up, select the option to Empty Recycle Bin.
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Part II: Basic Computer Maintenance


Chapter 1: The importance of keeping your computer healthy

A computer is an expensive piece of equipment, and as with all big
purchases you will want to protect your investment. A computer can help
your school progress. It gives you a means of writing reports, saving
photos, accessing the internet, sending emails…. and so much more.

This booklet provides step-by-step instructions to help you prolong the
life of your computer and to help keep it working at a consistently high
level.

This booklet covers three main areas: keeping it physically clean,
protecting it from malware, and backing up your important files.
There is also a short section at the back detailing ways to prevent
personal strain and injury which can result from long periods at a
computer.




Chapter 2: Keeping your computer physically clean

The main natural physical threats to your computer are:


	Dust

	Heat

	Moisture



Any of them can potentially cause problems for your computer, leading to
very costly repairs or even irreparable damage.

YOU are another threat to your computer. If you eat or drink in
front of it, it is likely that some food or drink will end up on the
keyboard of the computer, which could make some of the keys unusable.

It is good working practice to go away from your computer to get a drink
or to have some food. Getting away from the computer every hour or so
gives you a chance to move around and stretch your legs.

By cleaning your computer regularly, you can help to keep it working
properly and avoid expensive repairs.


Cleaning the keyboard

A dirty keyboard doesn’t look nice and can cause your keyboard to not
work properly. Dust, food, liquid, and other particles can get stuck
underneath the keys, which can prevent them from working properly.

[image: ]Check your owner’s manual to see if the
manufacturer has provided you with instructions for your specific
keyboard. If so, follow them. If not, the following steps are basic
cleaning tips that can help keep your keyboard clean:


	Unplug the keyboard from the USB or PS/2 port. If the keyboard is
plugged into the PS/2 port, you will need to shut down the computer
before unplugging it.

	Turn the keyboard upside down, and gently shake it to remove dirt
and dust.

	Use a can of compressed air to clean between the keys (see
Figure above).

	Moisten a cotton cloth or paper towel with rubbing alcohol (surgical
spirit), again turn the keyboard upside down, and use it to wipe
clean the tops of the keys. Do not pour alcohol (or any
other liquid) directly onto the keys!

	Reconnect the keyboard to the computer once it is clean and dry. If
you are connecting it to a PS/2 port, you will need to connect it
before turning the computer on.



Dealing with liquids

If, heaven forbid, you do spill liquid on the keyboard, quickly shut
down the computer, disconnect the keyboard and turn it upside down to
allow the liquid to drain.

If the liquid is sticky, you will need to hold the keyboard on its side
under running water to rinse the sticky liquid away. Then turn the
keyboard upside down to drain for two days before reconnecting it. The
keyboard may not be repairable at this point, but rinsing the sticky
liquid off of it is the only chance for it to be usable again.

The best way to avoid this situation is to keep drinks away from the
computer area.




Cleaning the mouse

There are two main types of mice: optical and mechanical. Each
is cleaned in basically the same way, although the mechanical mouse
requires a bit more work.


	[image: ][image: ]Optical mice
require no internal cleaning since there aren’t any rotating
parts; however, they can get sticky over time as dust collects
near the light emitter. This can cause erratic cursor movement or
prevent the mouse from working.

	Mechanical mice are especially susceptible to dust and
particles that can accumulate inside the mouse, which can make
it difficult to track—or move—properly. If the mouse pointer does
not move smoothly, the mouse may need to be cleaned.



Before you clean the mouse, check the owner’s manual to see if the
manufacturer has provided you with instructions for your specific mouse.
If so, follow those instructions. If not, the following steps are basic
cleaning tips that will help keep your mouse clean.


	[image: ]Unplug the mouse from the USB or
PS/2 port. If the mouse is plugged into the PS/2 port, you will need
to shut down the computer before unplugging it.

	Moisten a cotton cloth with rubbing alcohol, and use it to clean
the top and bottom of the mouse.

	If you have a mechanical mouse, remove the tracking ball by
turning the ball-cover ring counterclockwise. Then clean the
tracking ball and the inside of the mouse with a cotton cloth
moistened with rubbing alcohol.

	Let all of the parts dry before reassembling and reconnecting
the mouse. If you are connecting it to a PS/2 port, you will need to
connect it before turning the computer on.



If you just want to give the mouse a quick cleaning, place it on a
clean, white sheet of paper and move the mouse back and forth. Some of
the dust and particles should rub off onto the paper.




Cleaning the monitor

[image: ]Dirt, fingerprints, and dust can make your
computer screen difficult to read. However, it’s easy to clean your
screen when needed. Although there are monitor-cleaning kits you can
buy, they may do more harm than good if they are designed for a
different type of monitor. For example, a monitor cleaner that is
designed for glass screens may not work with some non-glass LCD screens.
The safest method for cleaning any monitor is to use a soft, clean cloth
moistened with water.

Do not use glass cleaner (such as Windex) to clean a monitor. Many
screens have anti-glare coatings that can be damaged by glass cleaner.


	Turn off the computer.

	Unplug the monitor from the power. If you are using a laptop, unplug
the laptop.

	Use a soft, clean cloth moistened with water to wipe the
screen clean.



Do not spray any liquids directly onto the screen. The liquid could leak
into the monitor at the edges and damage it.




Tips for cleaning other computer surfaces

From time to time, you should clean your computer case and the sides and
back of the monitor to avoid buildup of dust and dirt. Here are a few
tips you can use when cleaning these surfaces:


	[image: ]Dust is your computer’s main enemy. Use an
anti-static wipe to lightly dust your computer casing. Don’t use
furniture cleaners or strong solvents.

	Use a can of compressed air with a narrow nozzle to blow out debris
from the air intake slots.

	Spray cleaning solution (such as diluted ammonia cleaner or
glass cleaner) on a paper towel or anti-static wipe. Clean the
monitor housing and case (not the monitor screen) by wiping in a
downward motion.

	A safe cleaning solution for computer surfaces (not
computer screens) is ammonia diluted with water, or glass cleaner
comprised mostly of ammonia and water (check the label). Remember,
the milder the solution, the better. Do NOT use these solutions on
the computer screen!






Cleaning Methods Overview



Computer Part      Cleaning method



Keyboard           Shake it upside down to remove dust and dirt

                 Can of compressed air to clear dirt between the keys
                 
                 Wipe with a cotton cloth moist with rubbing alcohol





Mouse              Both Optical and mechanical: wipe with a cotton cloth moist with rubbing alcohol

                 Quick method: move up and down on clean white paper





Monitor            Wipe the screen with a clean cotton cloth moistened with WATER

Computer case      Wipe with an ant-static wipe to prevent dust

Air intake slots   Blow out dust with compressed air

Monitor housing    Wipe with a cleaning solution such as water and ammonia or a glass cleaner






Keep it cool

Don’t restrict airflow around your computer. A computer can generate a
lot of heat, so the casing has fans that keep it from overheating. Avoid
stacking papers, books, or other items around your computer.

Many computer desks have an enclosed compartment for the computer case.
If you have this type of desk, you may want to position the case so it
is not against the back side of the desk. If the compartment has a door,
you may want to leave it open to improve airflow.






Chapter 3: Safeguarding against malware


What is malware?

Malware is any type of software that is designed to damage your computer
or gain unauthorized access to your personal information. It includes
viruses, worms, Trojan horses, spyware, and other types. Most malware is
distributed over the Internet, often bundled with other software. It can
also insert its way into your computer from a USB drive or CD/DVD disc.

The easiest way to think about it is as if it was a virus, infecting a
body. If it gets in, and is not treated, it gets worse and can affect
other computers by passing the virus on to them.




How malware infects your computer

Malware infects your computer in lots of different ways. Some of the
most common ways are as follows:


	Through emails from other infected computers;

	When you download programs or files from the internet; and

	When you visit internet websites that are infected or set up by
people who write programs deliberately set up to infect
your computer.






Signs that your computer is infected

Unlike with a person, it is hard to tell when a computer is infected! A
number of signs are as follows:


	Your computer is running slower than usual;

	Your friends tell you that they have received emails which you
didn’t send yourself;

	You get error messages;

	Internet browsers or programs open, even if you didn’t try to open
them!






How you can avoid malware

Antivirus software

The best way to guard against malware is to install antivirus software.
Antivirus software does three main things:


	Prevents your computer from being infected;

	Searches your computer to see if you have any infections; and

	Removes any malware found.



Although it might sound daunting, downloading and installing antivirus
software is relatively easy, and step-by-step instructions are available
online, and have been written for newcomers to computers.

There are many different companies supplying antivirus software – we
aren’t going to recommend a specific one here. Please search the
internet, or talk to a supplier for the package that suits your needs
and budget (some are even free!).

New malware is being created all the time, so it’s important to update
your antivirus software frequently – this should be done automatically
by the antivirus program when you connect to the internet. But if not,
there is an easy way to change the settings.

Also, antivirus software, such as the software illustrated below, may
run out (for example, after 1 year). It is thus important to know when
that happens so you can update to the newest version.

[image: ]

*General good practice *

It’s important to stay smart when you’re browsing the Web or using
email. If a website or email attachment looks suspicious, trust your
instincts. Keep in mind that your antivirus program may not catch
everything, so it’s best to avoid downloading anything that might
contain malware. You might say that a little paranoia is a good thing.
When it comes to malware such as viruses, you should always be wary of
anything you download to your computer!




What to do if you think your computer is infected


	If you have antivirus software – disconnect from the internet and
run the software. Let it find the malware and delete it from
the system. If this does not work, you will need to contact an
IT specialist.

	If you do not have antivirus software (why not?!) – download one
from the internet and follow the above steps.








Chapter 4: Backing up the data on your computer


Why is backup important?

Imagine what would happen if your computer suddenly stopped working.
Would you lose any important documents, photos, or other files? You
could lose years of work in 1 second!

It may be possible to repair your computer, but your files may be lost
forever. Luckily, you can prevent this by creating backup copies
of all of your files (or just the important ones) on an external hard
drive or an online backup service.




External hard drives


	[image: ]You can purchase an external hard drive
and copy the contents of your computer to it. The initial backup
could take several hours, so you will need to select a period of
time when you do not need access to your computer. Running the
backup overnight usually works best.

	Follow-up backups should be conducted on a regular basis, but will
not take as long because the drive will only need to copy your most
recent files.

	Western Digital, and Seagate produce popular external
hard drives. Conduct some research on which product best suits your
storage needs, or ask a computer sales representative
for recommendations.

	One drawback, compared to online backup services, is that your
external hard drive can be lost, damaged, or stolen just as your
computer might be. Therefore, it is important to keep your drive in
a secure location when not in use.






Online backups


	You can also backup your files to one of the online backup
services like Mozy [http://mozy.com/home],
Carbonite [http://www.carbonite.com/] or
Box [http://www.box.net/], and your files will always be accessible
to you, as long as you are connected to the internet.

	The amount of storage space provided by these sites varies, and you
may have to pay a monthly or yearly fee for adequate storage.

	Again, do your research, as these services are constantly changing
and offer varying features.

	One drawback to online backup services is that the initial backup
can be slow and may even take days to upload if you have a large
number of files. However, subsequent backups should not take
as long.








Chapter 5: Other maintenance techniques and personal health


Other maintenance techniques


	To keep your computer running smoothly, it’s important to keep files
and folders uncluttered. Cluttered or unorganized folders make
it more difficult to find the files you need.



	Additionally, unwanted files can eventually fill up your hard
drive, which will make your computer slower and more difficult
to use. Here are a few things you can do to delete unwanted files
and improve your computer’s performance:



	Delete files: If you have any unwanted files, you can delete
them manually. To do this, simply drag them into the Recycle Bin
(or Trash), then empty the Recycle Bin. Another way to delete a
file is to right click on it, which brings up a Context menu
(see Figure on next page). Then scroll down the menu to select the
Delete option.
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	Disk Defragmenter: Windows includes a Disk Defragmenter
program in the Control Panel (see Figure below). It scans the
files on your hard drive and rearranges them so it can read
them faster. If your computer is running slowly, running Disk
Defragmenter can help to speed it up.
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	Disk Cleanup: Windows also includes a Disk Cleanup program


in the Control Panel (see Figure on the next page. It scans your
computer for temporary files and other files that can
be deleted. You can then delete the files to free up space on your
hard drive.
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Avoiding strain and injury

In addition to keeping your computer healthy, it’s important to think
about your own health. Computer ergonomics is the science of
equipment design and how specific equipment usage and placement can
reduce a user’s discomfort and increase productivity.

Using a computer involves a lot of repetitive motions such as typing
and using the mouse. Over time, these motions can begin to take
their toll on your body, especially your wrists, neck, and
back.

Staring at a monitor for long periods of time can also cause eye
strain.

To minimize, or even altogether avoid, these problems, the simplest
solution is to take frequent breaks from work at the computer. Every
hour at least, get up, take a stroll, relax your arms and wrists and
shoulders—take a break!

You should also take a few moments to make sure your workspace is
arranged in a comfortable and healthy way. Some equipment is designed
with special attention to ergonomics, such as ergonomic keyboards
and ergonomic chairs.




Correct seating position


	Adjust your chair: Make sure your chair is adjusted to allow you
to sit in a natural, comfortable position and at a height where your
eyes are looking slightly down at the screen to minimize strain
on your neck. Use a cushion or pillow if your chair is
not adjustable. A good office chair is specially designed to
support the lower back and promote good posture (see
Figure below).

[image: ]



	Keep the keyboard at a comfortable height: Try to place the
keyboard in a position that allows you to keep your wrists straight
and relaxed to avoid wrist strain. Many desks have a keyboard tray
that can keep the keyboard at a better height. You can also buy an
ergonomic keyboard that is designed to minimize wrist strain
(see Figure below).
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	Keep the mouse close to the keyboard: If possible, place the
mouse right next to the keyboard. If the mouse is too far away,
it will be uncomfortable or awkward to reach after a while.

	Place the monitor at a comfortable distance: The ideal position
for a monitor is 20 to 40 inches away from your eyes. It should
also be at eye level or slightly lower.

	Avoid clutter: The computer area can quickly become
cluttered with papers, computer accessories, and other items. By
keeping this area as uncluttered as possible, you can improve your
productivity and prevent strain or injury.








Chapter 6: Daily, Weekly, Monthly, Quarterly and Annual Maintenance


Daily Maintenance


	Virus Scan - A regular virus scan is essential to the safety of
your computer. We recommend scheduling your anti-virus software to
run a virus scan once a day.

	Data Backups - We recommend at least daily saving of essential
files to a CD-R. Backing up data is a simple process with today’s CD
drives and burning software or you can run the backup utility
provided with Windows

	Shut Down - When you’re done using your computer each day, I
recommend shutting down the system. This saves electricity and wear
and tear on your system’s operating system and hardware. Just doing
this can extend the life of your computer significantly.






Weekly Maintenance


	Disk Cleanup - running system cleanup at least once a week
deletes unnecessary temp files, temporary internet files and your
recycle bin freeing up hard drive space that can slow down
your computer. You can access System Clean up by clicking on
Start &gt;

 All Programs &gt;

 Accessories &gt;

 System Tools &gt;


DiskCleanup.

	Disk Defragmenting - as you create and edit files on your
computer they get saved on your hard drive. Each file is allocated
so much space within on location on your hard drive and for large
files they may take up more space, thus having to take up more than
one space on the hard drive. Running disk defragmenter at least once
week will keep your file fragments down and allow your hard drive to
work more efficiently. You can run disk defragmenter by Start &gt;


All Programs &gt;

 Accessories &gt;

 System Tools &gt;

 Disk
Defragmenter and then select the drive you want to defragment.

	Update Virus Definitions - This is very important to ensure your
computer is up to date on the latest virus threats in cyberspace.

	Shut Down - We recommend doing a complete shut down of your
computer at least once a week when practical. It is very important
for the operating system to have a complete reboot at least once a
week to lower operating system degradation.






Monthly Maintenance


	Windows Updates - This is a good chance to ensure your operating
system is running up to date with the latest security patches. You
can update your Windows Operating System by going to
www.update.microsoft.com.






Quarterly Maintenance

Clean the Computer - Often overlooked, cleaning your computer vents
of dust and other fuzz is very important. With a brush and vacuum
cleaner or a can of air, you can cleanthe vents for the power supply
and side vents on the computer.


	Before cleaning ensure the power is off and follow the instructions
on the can of air to safely accomplish this task.

	Be careful not to breathe in suspended dust particles. We recommend
wearing a dust mask to avoid setting off any allergies.






Annual Maintenance

Your local computer repair technician should be scheduled to have the
inside of your computer cleaned, CPU fan checked, and cables and circuit
cards checked for sound connections.

[^1]: A digital object is any object that can be “read” by a computer,
which means it must be represented in the binary 1s and 0s of
computer language.
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Lesson 1 Introduction to WRITER



1   Introduction to WRITER

      Writing a Conference Call letter







LEARNING OUTCOMES

In this tutorial, along with some helpful hints to bear in mind when
word processing, you will learn the steps required to produce a word
processed document from scratch and carry out basic formatting and
editing functions. These include:


	opening and naming a new word processor document

	entering and saving a document

	updating and simple formatting of a document

	checking a document for spelling and grammar errors

	printing a document

	making a backup copy of a document



BEFORE YOU BEGIN

Lesson 1 makes the assumption that you are already familiar with the
Windows computing environment, though you may not be an expert in its
use. If you are using a computer in a lab at school, you’ll also know:


	where to find the computer lab on campus;

	how to turn the computer on;

	how to log on to the system (using your login name and password).



You also should be familiar with the Windows, Icons, Menus,
and Pointers (the so-called WIMP interface) with which you
interact with the computer. If not, your instructor will make this clear
to you before you proceed with these tutorials.

Lesson 1 assumes that you have received a copy of the set of Work Files
for LibreOffice that accompany these tutorials. These files ideally
should be stored on a Flash drive (USB drive) in three folders named
Base Files, Impress Files, and Miscellaneous Files. You also will
need a fourth folder for the data files that you will be creating
while working your way through the tutorials. This fourth folder will be
called Data Files.

If you do not have these four folders and files ready, prepare them now
before proceeding with this tutorial.

Here are the steps to take:


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will help
you with this if you are working with a class) and Extract them
onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 1.1).


[image: ]

Fig. 1.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 1.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

1.1 Opening, naming & saving a new Writer document

Opening a new Writer document

Before you can use LibreOffice, you must first open the program. Every
system is slightly different in the steps to open a program, so we’ll
assume that you already have that figured out, or you have someone, such
as your instructor or a friend, who can help you get started.

Fig. 1.2 illustrates the screen you will see when you first open a new
Writer document.

[image: ]

Fig. 1.2 New blank Writer document (annotated)

Fig. 1.2 illustrates the Ruler Bar, along with the tool for setting tab
stops and the tools for setting indents—called indent markers.


Check out the tool for setting Tab stops; it’s on the same line as
the Ruler bar, but at the left edge of the Writer window
(see Fig. 1.2 above)—it’s so small you could easily miss it (and a lot
of Writer users do!)

Make a mental note of the Indent Markers too; they’re on the left
and right sides of the Ruler bar (Fig. 1.2 again)




Naming and saving a new Writer document

Here are the steps to save this first Writer document on your flash
drive.


Look at the new document’s default name (it’ll be Untitled1)
at the top left of the Writer window (see Fig. 1.1 above)


The document is given this default name by LibreOffice because you
haven’t yet given it a name of your own. It is ALWAYS a good idea,
however, to immediately—and thoughtfully –name a new document before you
even enter any data, and then save the document on the drive and in the
folder where you intend to keep it.


Make sure your Flash drive is inserted in your computer, then, from
the File menu, select Save As


Writer displays the Save As dialog box (Fig. 1.3).
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Fig. 1.3 The Save As dialog box

The Save As dialog box prompts you, among other things, to


(1) select the location or disk drive where you want to save the new
document (in this case your Flash drive or Removable Disk);

(2) navigate to, and then either create or select, a folder on that
drive in which to save the new document (in this case, your Data Files
folder);

(3) type a name for the document before clicking on the Save button.




The Save As dialog box thus lists the various locations where your files
can be saved.


Make sure your flash drive is in one of the available USB
ports in the computer then, in the left frame of the Save As
dialog box, click on Removable Disk to open it (Fig. 1.3 on
the previous page)

Now, in the list of various folders and files that may be on your
flash drive, locate/navigate to the folder named Work Files for
LibreOffice (you may need your instructor to help you find it on
your computer this first time) and double click on it to open
it




You should now see a list of four folders, including the Data Files
folder you created when you prepared it for use with these tutorials.


Double click to open the Data Files folder (see Fig. 1.3
previous page)


Creating a new folder on a disk

Inside the Data Files folder you need to create a new folder to store
all the documents you will create using Writer.


Still in the Save As dialog box, click on the New Folder icon
(Fig. 1.4)
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Fig. 1.4 The New Folder icon in the Save As dialog box

As you can see, the system immediately creates a New Folder with a
default name highlighted in blue, inviting you to type a name of your
own for the New Folder.


Type Writer Documents for the new folder’s name, hit the
Enter key, then double click on the folder to Open it


Writer opens the new folder so that you can save the new document
inside it (Fig. 1.5).
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Fig. 1.5 Naming the Conference Call Letter


In the File name: data entry box (Fig. 1.5), type Conference
Call Letter to replace the default name and press Enter (or
click the Save button)


The Save As option thus allows you to name your documents and at the
same time determine the location (the folder, on a particular disk) on
which you want to store them.

From now on, you do not need to select Save As to save the document
unless you want to save a backup or save it in some other location.
Whenever you simply Save this particular file, it will be saved with
the name Conference Call Letter in this same folder (Writer Documents)
on your flash drive.

1.2 Some HELPFUL HINTS WHILE USING WRITER

When you are using a computer, the only time you need to hit the Enter
key is at the end of a paragraph, whether the paragraph is an empty
line, one word, one line, or several lines.


Type the following passage (next page) for practice now—remember,
don’t press the Enter key until you get to the end of the
paragraph[^1]

And though he tried to look properly severe for his students, Fletcher
Seagull suddenly saw them all as they really were, just for a moment,
and he more than liked, he loved what he saw. No limits, Jonathan? he
thought, and he smiled. His race to learn had begun.[^2]

Now press Enter at the end of the paragraph




Notice how the word processor took care of the end of each line.

Removing unwanted Returns (using the Show ¶ option)

You can have Writer show you exactly where, in your document, you hit
the Enter key (say, at the end of paragraphs). The easiest way to do
this is to click on the Show ¶ icon in the Standard Toolbar (Fig.
1.6).
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Fig. 1.6 The Show ¶ icon on the Standard toolbar

Click on the Show ¶ tool now




The Show ¶ tool also puts a dot to show wherever there is a space
anywhere in the text.


Position the cursor immediately before the sentence that begins “No
limits, Jonathan?…”, then hit the Enter key twice


Notice the ¶ symbols that show you where you hit the Enter key—one at
the end of the previous line, and the other on the empty line ahead of
the cursor.


Now remove the Paragraph marks you just entered by pressing the
Backspace key twice

Finally, click on the Show ¶ icon in the Paragraph Group
of the Home Ribbon to turn off the paragraph marks and all the
dots between the words




Undoing unintended actions

If you do something you didn’t intend, or if you make a mistake, you’ll
select Undo from the Standard toolbar which is located immediately
below the Menu Bar (Fig. 1.7). This is a lifesaver that you will use
often!
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Fig. 1.7 Undo/Redo tools


Check out this Undo option in the Standard toolbar now so you
can see where to find it


A quicker way to Undo is to use the shortcut Ctrl-z on your
keyboard.

Scrolling through a document

We need to open a longer document so you can practice different ways of
scrolling.


From the File menu select Open, navigate to USB drive >
Work Files for LibreOffice > Miscellaneous Files >
Practice folder, and double click to open the document
called Term Paper


Now, with the Term Paper document open on the screen, take a look at the
scroll bars (Fig. 1.8).
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Fig. 1.8 The scroll boxes

On the right of the screen you have a vertical scroll bar and, inside
it, the vertical scroll box. At the bottom of the screen you have a
horizontal scroll bar and horizontal scroll box.

At either end of the scroll bars are arrows pointing in opposite
directions (left and right, or up and down). Clicking on these arrows
will scroll a document left or right or up and down. Scrolling from left
to right or right to left is simpler than scrolling up or down, since
you only have the width of the page to deal with. But the process is the
same for scrolling up and down, too.


Try scrolling now from side to side—left to right and back again—by
clicking on the scroll arrows to move the scroll box in the
horizontal scroll bar

Try scrolling up and down by clicking on the scroll arrows to move
the scroll box in the vertical scroll bar




You can scroll a lot faster by positioning the mouse arrow on the scroll
box itself, holding down the left mouse button, and dragging the box
left or right, up or down, in the scroll bars.


Try this, too


If you click either side of the scroll box inside the horizontal or
vertical scroll bars, this causes the document to scroll in jumps from
side to side or up and down.


Try this as well


You also can scroll and position the cursor very precisely across a line
of text, character by character, or up and down from line to line, by
using the arrow keys on the lower right of the keyboard.


Try this as well


Finally, yet another vertical scrolling option is available if you have
a mouse with a rubberized wheel between the buttons, as illustrated in
Fig. 1.9.
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Fig. 1.9 The scrolling wheel on the mouse


Try this, too

When you have finished experimenting with the scroll bars, close
(File > Close) the Term Paper document




Shortcuts or quick keyboard commands

The quickest way to save your work is to press Ctrl-s on the
keyboard. The Ctrl (Control) key is in the lower left corner of the
keyboard. Locate it now. You’ll be using it a lot as you become more
familiar with the Office programs. It is always used in combination
with one or two other keys. Ctrl-s, for example, is executed by
holding down the Ctrl key and, while holding the Ctrl key down,
simultaneously quickly pressing on the “s” key.

Renaming a document

You will sometimes want to rename a document that you’ve already saved
on your disk. One way you can do this from the desktop is by
right-clicking on the icon for the document you want to rename. Then,
from the context menu that pops up whenever you right-click on an
object on the screen, select the option to Rename…, which highlights
the document’s name so that you can type a new name for it.

To rename a document which you already have open in Writer, or in any
other LibreOffice application, you would choose Save As from the
File menu. This will give you the opportunity to save the document with
a new name of your choice. Bear in mind, though, that when you do this,
the document with the original name will still be on your disk—a second
copy, if you like. If you don’t want to keep this copy, you should
delete it right away so as to remove unwanted clutter from your disk
drives.

1.3 CREATING AND Saving A document

Practice makes perfect

You still should have open the Conference Call Letter, with the Jonathan
Livingstone Seagull quote. You need to clear the Seagull quote from the
document, so here are the steps to remove it.


In the Edit menu choose Select All then press the
Backspace key once to remove the highlighted text from the
document


You can also Select All using the Quick Keyboard command Ctrl-a,
or you can use the mouse (or your finger if you have a touch screen) to
drag to highlight the whole paragraph, or you can quadruple
click on the paragraph.

Notice that the Backspace key removes all highlighted text. The Del(ete)
key, in this case, does the same.

Typing the Conference Call letter

You should now have a blank page with the cursor waiting in the top left
corner, ready for you to type in the Conference Call Letter. Fig. 1.10
on the next page has the full text of the Conference Call letter. The
Figure also shows where all the Paragraph marks (¶) are. This will help
you remember to hit the Enter key only where necessary, not at the
end of every line. There’s no need to show Paragraph marks in your
version of the document.

As you type, Writer will automatically warn you of any spelling or
grammar errors it finds (by underlining them in red or blue on your
screen). This will occur as you type the contents of Fig. 1.10.
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Fig. 1.10 First version of the Conference Call Letter

Once you have typed in the whole document and saved it, you should go
back and correct any errors you may have made, and then save the
document again. Remember: when you save a document with the same name as
before, you are replacing the earlier version. You won’t be creating
a second copy.

1.4 UPDATING AND simple formatting of A document

Now that your letter is saved on disk, you can make any revisions you
want. Refer back to Fig. 1.10 while you complete the next few sections
of the tutorial.

Inserting the date

There is no date in the Conference Call Letter in Fig. 1.10. A
letter is incomplete without a date, so here are the steps to have
Writer put today’s date in the letter.


Click to position the insertion point cursor right after the
zip code in the first address at the top of the page, then press
Enter


The cursor should now be waiting at the beginning of the next line.


In the Insert Menu > Fields Menu click on the Date tool
(Fig. 1.11)
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Fig. 1.11 Inserting the Date into a document

As soon as you click on the Date tool, Writer immediately inserts
today’s date at the cursor.

There is, however, one problem with the date’s format (all numeric)—it
uses the USA style, with the month first and the day second. Elsewhere
in the world, the date is shown with the day first and the month second.
So, where you have 3/4/2014, is that March 4, 2014, or April 3, 2014.
You really can’t be sure.

Fortunately, LibreOffice has a quick way around that problem by
allowing you to select another format for the date which can in no way
be confused. Here’s what you need to do.


Use the mouse to right click on the date, and in the context
menu that pops up, select Fields…

The Edit Fields dialog box comes up, enabling you to select from a
long list of possible date formats (Fig. 1.12)
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Fig. 1.12 Selecting a commonly-recognized date format

Noticed the two options in the Select column for the Date. You can
either choose a Fixed Date, which is the default and inserts the current
date as a fixed value which will not change over time. The second option
is not fixed; Date (not fixed) inserts the date as a variable function;
the date will change each time you open the document in which it is
inserted.

The Conference Call Letter is a one-off letter, so the fixed Date option
is what you want.


Make sure Date (Fixed) is highlighted, then click to select the
date format Friday, December 31, 1999 and click on OK


Now check the new format for the date; it’s clear what the date is now.

**Adding text to an existing document **

You will most always want to add text to an existing document—make
revisions and so forth; it is an activity which is fundamental to the
whole process of writing. Let’s practice now.

There is no limit to the extra details that could be added to the
letter, but for the sake of this exercise you will add just one sentence
to the next to last paragraph to help the parents appreciate what Hellen
will get out of the experience at the Institute.


Position the insertion point cursor so it is at the END of the
paragraph which begins “The institute has a wonderful
reputation...“—so after the phrase “…state of Florida.”, then
press the space bar and type the sentence:

She would thus be able to meet and make friends with others of her
own age and academic ability.




Read over the sentence you just typed to check for errors. Correct any
you may have made. Before you go on to the next section you should save
what you have done so far.


Press Ctrl-s to save the changes you have made to the letter


Removing text

There are several ways of removing text. In a moment you’ll learn how to
highlight a block of text in order to move or delete larger sections of
text. But if all you want to do is remove a few words, or a short
sentence, the quickest way is to use the Backspace key.

You are going to remove the second sentence of the second paragraph.
This second sentence begins “I have attended the facility myself...”.


Position the insertion point cursor at the beginning of the
third sentence of the second paragraph—the sentence that
begins “Hellen would take part ...“

Press the Backspace key as many times as is necessary until the
second sentence of this paragraph is removed from the letter




You’ll find the automatic repeat feature of the keyboard (activated by
holding down a key such as the Backspace key) will come in handy for a
delete operation like this.


Press Ctrl-s again to save the changes you just made


Changing text

It is often necessary to change a word or words here and there in a
document. The Conference Call Letter overuses the word “program,” for
example. The word appears once in the first paragraph and then is used
twice in the final paragraphs. To improve the letter it would be better
to rewrite the first sentence of the second paragraph to read: “The
Institute has a wonderful reputation for its offerings for both children
and adults.”


Place the cursor between the period (full stop) and the “s” at
the end of the first sentence in the second paragraph (right
at the end of the word “programs” but before the period (full
stop))

Use the Backspace key to remove the text “both children and
adult programs”

Make sure there is still a space after the word “for”, then
type the phrase “its offerings for both children and adults.”




Another change you need to make is to the telephone number in the first
sentence of the last paragraph. A common error with numbers is called
transposition, where one accidentally reverses the order of digits. The
number is supposed to be 772–3232, not 3223.


Position the cursor just at the end of the telephone number,
press the Backspace key 2 times, then type the digits
“32”, and press Ctrl-s


At this stage your Conference Call Letter should look much the same as
Fig. 1.13.

^Jane\ Doe^

^Hodge\ Road\ Elementary\ School^

^123\ Mingo\ Bluff\ Road^

^Cape\ Coral,\ FL\ 23456^

^Thursday,\ June\ 5,\ 2014^

^Mr.\ and\ Mrs.\ M\ Mayosha^

^856\ SW\ 2nd\ Place^

^Cape\ Coral,\ FL\ 23456^

^Dear\ Mr.\ and\ Mrs.\ Mayosha,^

^I\ am\ pleased\ to\ inform\ you\ that\ your\ daughter,\ Hellen,\ has\ been\ selected\ by\ the\ Fifth\ Grade\ teachers\ to\ represent\ Hodge\ Road\ Elementary\ School\ at\ the\ Newfound\ Harbor\ Marine\ Biology\ Institute\ in\ Key\ West,\ Florida,\ as\ a\ Junior\ Biologist.\ Since\ Hellen\ has\ shown\ both\ academic\ excellence\ and\ sound\ social\ skills\ this\ past\ school\ year,\ she\ would\ be\ a\ great\ candidate\ for\ the\ program.\ We\ very\ much\ hope\ that\ you\ will\ support\ Hellen\ in\ this\ opportunity.^

^The\ Institute\ has\ a\ wonderful\ reputation\ for\ its\ offerings\ for\ both\ children\ and\ adults.\ Hellen\ would\ take\ part\ in\ a\ two-week\ session\ in\ June\ with\ 5th\ graders\ from\ all\ over\ the\ state\ of\ Florida.\ She\ would\ thus\ be\ able\ to\ meet\ and\ make\ friends\ with\ others\ of\ her\ own\ age\ and\ academic\ ability.\ ^

^Please\ call\ me\ (619)\ 772-3232\ or\ email\ me\ (mprendergast@hodgeroad.edu)\ to\ discuss\ more\ details\ about\ the\ program.\ I\ look\ forward\ to\ hearing\ from\ you\ soon.^

^Sincerely\ yours,^

^Ms.\ Mary\ Prendergast^

^Head\ of\ Science^

Fig. 1.13 Intermediate update to the Conference Call letter****

Selecting (highlighting) a block of text

Let’s take a few minutes to learn about highlighting text in a Writer
document. Highlighted text is text that stands out from the rest of the
document because, in the case of LibreOffice, the background of the
highlighted text becomes a block of light blue color (Fig. 1.14).
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Fig. 1.14 Highlighted text

When you highlight text, you can do things to it (delete it, move it,
copy it, change the margins set for it, change the font, the text style
or color, and so on) without affecting the rest of your document.

You can highlight a single character...


Use the mouse to position the cursor so it is immediately before the
“H” in “Hodge” in the address at the top of the letter

Hold down the left mouse button and keep it down as you carefully
drag across just the “H” at the beginning of the word so that it
becomes highlighted




This latter operation is tricky the first few times you try it. If you
drag across more than just the “H”, keep your finger on the left mouse
button and drag back until you have just what you want highlighted. You
can select as much or as little of the text as you want. Remember,
you’re in control.[^3]


Let go of the left mouse button when just the “H” is highlighted

Now click anywhere in the text to remove the highlighting (i.e. to
deselect the selected text)

Try this a few times on different letters anywhere in the document




Double clicking to highlight a single word...


Position the I–beam cursor anywhere over the word “Elementary“
in the first line of the address at the top of the letter and
double click the left mouse button


The single word “Elementary” should be highlighted on the screen.


Click anywhere in the text to remove the highlight

Try this on a few more words anywhere in the document till you’re
comfortable with the action




Triple clicking to quickly highlight a sentence...


Position the cursor anywhere in the middle of a paragraph and
triple click on the left mouse button

Click anywhere in the text to remove the highlight, then try this
again on other sentences elsewhere in the document till you’re
comfortable with the action




Quadruple clicking to quickly highlight an entire paragraph...


Position the cursor anywhere in the middle of a paragraph and
quadruple click on the left mouse button

Click anywhere in the text to remove the highlight, then try this
again on another paragraph elsewhere in the document till you’re
comfortable with the action




You can highlight an extended area (or block) of text...


Place the cursor right at the start of the first paragraph of
the letter (before the sentence that reads: I am pleased to inform
you… )

Now, while you hold down the Shift key, click at the end of the
last paragraph (after the sentence that reads: I look forward to
hearing from you soon. and notice that the whole paragraph is
highlighted

Click anywhere in the text to remove the highlighting




You can quickly highlight an entire document...

You should be getting the hang of this highlighting by now. You can drag
the mouse to highlight several paragraphs or even an entire document of
several pages. However, dragging through a 50 page document would
quickly become tedious. So Writer provides a short cut to select an
entire document—you may recall using this feature earlier in the
tutorial.


Press Ctrl-a (or in the Edit menu choose Select All)

Simple; now click anywhere in the text to remove the highlighting




Using the Writer Indent Markers

The letter is nearly ready to be printed. There are just a couple more
changes you need to make.

For example, one style for letter–writing is to indent the first line of
every paragraph ½”. Another is to position the first address (the
address of the sender) so it appears at the top right of the first
page, instead of on the left. In this case, the closing signature could
also be aligned on the right side of the page at the end of the letter.

Fig. 1.15 illustrates these final changes you are going to make to the
Conference Call Letter.


^Jane\ Doe^

^Hodge\ Road\ Elementary\ School^

^123\ Mingo\ Bluff\ Road^

^Cape\ Coral,\ FL\ 23456^

^Thursday,\ June\ 5,\ 2014^

^Mr.\ and\ Mrs.\ M\ Mayosha^

^856\ SW\ 2nd\ Place^

^Cape\ Coral,\ FL\ 23456^

^Dear\ Mr.\ and\ Mrs.\ Mayosha,^

^I\ am\ pleased\ to\ inform\ you\ that\ your\ daughter,\ Hellen,\ has\ been\ selected\ by\ the\ Fifth\ Grade\ teachers\ to\ represent\ Hodge\ Road\ Elementary\ School\ at\ the\ Newfound\ Harbor\ Marine\ Biology\ Institute\ in\ Key\ West,\ Florida,\ as\ a\ Junior\ Biologist.\ Since\ Hellen\ has\ shown\ both\ academic\ excellence\ and\ sound\ social\ skills\ this\ past\ school\ year,\ she\ would\ be\ a\ great\ candidate\ for\ the\ program.\ We\ very\ much\ hope\ that\ you\ will\ support\ Hellen\ in\ this\ opportunity.^

^The\ Institute\ has\ a\ wonderful\ reputation\ for\ its\ offerings\ for\ both\ children\ and\ adults.\ Hellen\ would\ take\ part\ in\ a\ two-week\ session\ in\ June\ with\ 5th\ graders\ from\ all\ over\ the\ state\ of\ Florida.\ She\ would\ thus\ be\ able\ to\ meet\ and\ make\ friends\ with\ others\ of\ her\ own\ age\ and\ academic\ ability.\ ^

^Please\ call\ me\ (619)\ 772-3232\ or\ email\ me\ (mprendergast@hodgeroad.edu)\ to\ discuss\ more\ details\ about\ the\ program.\ I\ look\ forward\ to\ hearing\ from\ you\ soon.^

^Sincerely\ yours,^

^Ms.\ Mary\ Prendergast^

^Head\ of\ Science^




Fig. 1.15 The final version of the Conference Call Letter

Using the Indent Markers

Indent Markers are used to adjust the first line, and the left and right
margins, of paragraphs—not individual lines, unless a paragraph only has
one line.

The tip of the mouse pointer is the hot spot (Fig. 1.16).
Moving small indent markers is a delicate operation; be sure to position
the very tip of the mouse pointer on an indent marker.

Fig. 1.16 The tip of the mouse pointer is the Hot Spot

On the left side of the ruler, at the 0” hash mark, you can see the two
indent markers that are used to set the First Line Indent and the
Left Indent for paragraphs. On the right side of the ruler you can see
the Right Indent marker (Fig. 1.17).
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Fig. 1.17 The Indent Markers

In this exercise you will practice using just the First Line Indent
marker and the Left Indent marker. In Lesson 2 you will have plenty of
opportunity to learn about the Hanging Indent and the Right Indent
markers.

Let’s learn how to use the First Line Indent marker now.


Click to put the cursor anywhere within the first paragraph of the
letter (this tells Writer which paragraph of text to reformat)

In the Ruler bar, place the tip of the mouse pointer on the
First Line Indent marker (see Fig. 1.17)

Now use the mouse to drag the First Line Indent marker across
½” to the right (to the ½” hash mark on the ruler)




Notice that the First Line Indent marker (the upper triangular marker)
and the Left/Hanging Indent marker (the lower triangular marker) moved
independently and that only the first line of the paragraph has moved
to the right half an inch (½”).

Next you are going to set the First Line Indent marker for the second
and third paragraphs in the body of the letter.


First, make sure you can see the whole letter in the window (maximize
the window if necessary), then click to position the cursor before the
first word of the second paragraph (before “The Institute…”)

Now, while holding down the Shift key, click at the end of the
third (last) paragraph (after the words “…from you soon.”)




Both the second and third paragraphs of the letter should be
highlighted.


Now position the tip of the mouse arrow on the First Line Indent
marker and slide it to the right to the ½” hash mark on the
ruler


Notice that the first line margin of each paragraph is now set at ½” and
the rest of each paragraph is set at 0”.

Practice makes perfect

If this is the first time you’ve used these markers you may still feel
uncomfortable working with them, if only because they’re rather small
and may be difficult for you to grab with the mouse pointer. More
practice will cure that.

You are going to use the Left Indent marker to adjust the left margin
for the First Address and the Date at the top of the letter, and then do
the same to the left margin for the sign off at the end of the letter.
Follow these steps carefully.


Drag to select (highlight) the First Address and Date lines at
the top of the letter (the first four lines)

Point at the Left Indent marker (the small marker at the bottom of
the indent markers on the left of the Ruler bar), hold down the
left mouse button and drag both the indent markers together
over to the 4” hash mark on the ruler

Let go of the mouse button, then click anywhere in the text to
de-select the highlighted text




The address and date should now be lined up on the new 4” margin. If
you weren’t successful the first time, just go through the steps again
until you get the hang of it.


Next scroll down to the end of the letter if it doesn’t show on
the screen

Select the lines that begin: “Sincerely yours,” and that conclude
with “Ms. Mary Prendergast” and “Head of Science” (including
all three of the blank lines in between)

With these lines highlighted, again point at the Left Indent
marker, hold down the left mouse button and drag both the
indent markers together over to the 4” hash mark on the ruler

Press Ctrl-s to save this (almost final) version of the document




1.5 Checking the document for spelling errors

LibreOffice comes with a spelling checker. However, it cannot spell
for you—yet! Nor can it correct errors such as the misuse of “to”,
“too”, and “two”! A spelling checker is not an alternative to
proofreading. You should always proofread your work on the printed page
(in hard copy form) after you have run it through the spelling
checker.

Accessing the spelling checker


In the Standard Toolbar click on the icon for Spelling and
Grammar (Fig. 1.18)
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Fig. 1.18 The Spelling and Grammar tool in the Standard toolbar

This will bring up the dialog box shown in Fig. 1.19.

[image: ]

Fig. 1.19 Spelling and Grammar dialog box

The Writer spelling and grammar checker is probably already working
for you if those functions are in automatic mode, if you see strange
looking red or blue underlines under some of the words you typed.

If Writer highlights a word or phrase, this does not necessarily mean
there is anything wrong with it. You still have to be able to tell if
you have made an error and also know how to correct it.

If you tell the Spelling Checker to check your document, and it has “No
suggestions” for a word highlighted, the dialog box gives you the option
to have the Spelling Checker Ignore it (because the word is correct as
is); or Ignore All occurrences of the same word in your document
(because you don’t want the Checker to stop for them again); or Add
the word to the custom dictionary (so it won’t be flagged in future
documents you work on). This is generally useful for proper names.

In the example in Fig. 1.19 on the previous page, the word “Elementary”
has been mistyped and, as you can see, the misspelling was picked up by
the spelling checker and drawn to your attention. To fix the problem,
you just click on the Correct button, and Writer will fix it on the
spot.


Using the Spelling and Grammar... option in the Standard
Toolbar, work your way through the Conference Call Letter

Correct any spelling or typing errors you may have made, then
Save your work




In Lesson 2 you will make more extensive use of the Writer Spelling
Checker.

1.6 Printing a first draft of the document

Print Preview–ing your work

It is always useful to preview your work on screen before sending it to
the printer. In LibreOffice, you will be able to preview your work in
the Print dialog box before you send it to the printer. Let’s see how
this works.


From the File menu select Print (or press Ctrl-p)


Writer will present you with the Print dialog box which will be
similar to that shown in Fig. 1.20 on the next page (though every
computer has minor variations when it comes to printing).

[image: ]

Fig. 1.20 Typical Writer Print dialog box

What kind of printer are you using?

If you have a laser printer, the quality is always “Best.” But if you
have an inkjet printer, for example, you can choose the quality of
output you require. You select the print quality by clicking on the
Properties button in the Print dialog box (Fig. 1.20 above).

Printing a range of pages

With regard to Page Range, the Print All Pages option is selected by
default. The Conference Call Letter is only one page long, so you will
by default want to print the entire document. If you wanted to print a
subset of the pages of a long document, say from page 3 to page 6, you
would click the radio button next to Pages (see Fig. 1.20 above) and
enter the numbers of the range of pages in the data entry box (ex.
1,3,5-12).

Setting the number of copies

Writer also asks you how many copies you want to print. As you can see
(Fig. 1.20), the number 1 is already selected by default, and for a
draft copy that is certainly as many as you would normally want.

You are now ready to print the document.


Click on OK in the Print dialog box


If all is well with your printer connections and so forth, your printer
will now go ahead and produce a hard copy of your document. Now you
should take the time once again to carefully read over what you have
typed.

If all is well, you are ready to go ahead and print the final version.

SKILL CONSOLIDATION

Complete these exercises to reinforce what you have learned in Lesson 1.
This will help you appreciate the usefulness of the word processor for
all your writing tasks.

1. Use Writer to write a letter to someone in your family or to a
friend using the same layout as the Conference Call letter. There must
be at least four paragraphs in the body of the letter. Print out a draft
copy of the story, proof read it, correct any errors, then print out a
final copy of the story. Hand in both copies to your instructor.

2. Write a letter to a school district superintendent explaining the
details of a field trip that you are planning for your class. Print out
a draft copy of the story, proof read it, correct any errors, then print
out a final copy of the story. Hand in both copies to your instructor.

3. Write a short story of at least four paragraphs using Writer. Set
the right and left margins at 1.5 inches. Print out a draft copy of the
story, proof read it, correct any errors, then print out a final copy of
the story. Hand in both copies to your instructor.

4. Use Writer to type up a paper of your choice. Print out a draft
copy of the paper, proof read it, correct any errors, and then print out
a final copy of the paper. Hand in both copies to your instructor.

5. Using Writer, type a paper of at least four paragraphs explaining
what you have learned so far in tutorial 1. Print out a draft copy of
the paper, proof read it, correct any errors, and then print out a final
copy of the paper. Hand in both copies to your instructor.

6. Open Writer to create a new document. Name the document “A Day at
the Beach” and type at least four paragraphs on this topic. Practice
adding and deleting words, phrases, and whole sentences. Print out a
draft copy of the paper, proof read it, correct any errors, and then
print out a final copy of the paper. Hand in both copies to your
instructor.

7. Open the document “Conference Call Letter.” Change the date so that
it is the current date, save the updated document. Remove all the first
line indents from the paragraphs. Add a paragraph explaining that if
Hellen cannot attend the Institute this year, the offer will be open
again next year. Save the updated document. Print out a draft copy of
the letter, proof read it, correct any errors, then print out a final
copy of the letter. Hand in both copies to your instructor.

[^1]: The lines on your screen may be longer or shorter.

[^2]: From the book “Jonathan Livingston Seagull: a story” by Richard
Bach. New York, NY: Avon, 1970. And yes, the grammar is correct, so
don’t worry if it seems odd to you here and there!

[^3]: If you are new to word processing, the secret here is: don’t
panic! No matter how much you might think to the contrary, when
you’re working with computers you are in control—as long as you know
what you’re doing. The computer is just a dumb machine designed to
serve your information processing needs. These tutorials will help
you make this dumb machine your friend.
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Lesson 2 More on Word Processing



2   More on word processing

      Working with larger documents







LEARNING OUTCOMES

In this tutorial you will review what you learned in Lesson 1. Then
you will be introduced to functions of Writer that are especially
valuable when working with longer documents. Amongst these are the
following:


	Inserting page numbers

	tools for formatting text

	bullets and numbered lists

	more on indenting text

	creating sections and columns of text

	finding and replacing text

	moving and copying text within a document

	setting off a block of text with a border

	adding graphics to a Writer document



Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (Continuing with
the tutorial, on the next page). If you did not complete Lesson 1,
then you must do this now, before proceeding with the rest of Lesson 2.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

If you do not have these four folders and files ready, prepare them now
before proceeding with this tutorial. Here are the steps to take:


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will help
you with this if you are working with a class) and Extract them
onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 2.1).
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Fig. 2.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 2.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

Continuing with the tutorial

This tutorial is designed to give you practice working with a longer
document since this presents challenges that do not arise when dealing
with documents that are no more than a page or two in length. Rather
than have you type in a long paper of your own, the Work Files for
LibreOffice come with a document prepared for the exercises in this
tutorial.


Make sure you have the disk drive (your flash drive) containing your
Work Files for LibreOffice in the computer, and Open the
LibreOffice program


The name of the document you will be working with is Term Paper. You
will find this document in the Practice folder which is inside the
Miscellaneous Files folder of the Work Files for LibreOffice. Here are
the steps to open it.


From the File menu select Open…, then, in the Open dialog
box that pops up, scroll if necessary in the left hand frame of
the dialog box in order to locate the Removable Disk icon—which is
your flash drive—then click once on the icon in order to open
it

Now, on your flash drive navigate to, and double click to open the
Work Files for LibreOffice folder, then double click again to
open the Miscellaneous Files folder




There are five folders in the Miscellaneous Files folder: Alphabet,
Merge Documents, Other Documents, Practice, and Templates. The
document you are going to use for this set of exercises is in the
Practice folder.


Double click on the Practice folder to open it, then double
click on the document Term Paper and wait while Writer opens
it


You are going to make lots of changes to this Term Paper document,
including fixing grammar and spelling errors that have been purposefully
introduced. But you do not want to lose this original version of the
Term Paper, so you need to save it somewhere else on your flash drive.
The ideal place will be in your Data Files folder amongst your Writer
Documents, as you did for Lesson 1.


In the File menu select Save As, then, in the Save As
dialog box, scroll if necessary in the left hand frame to locate
the Removable Disk icon—which is your flash drive—then click
once on the icon to open it

Now navigate to, and double click to open the Work Files for
LibreOffice folder, then double click again to open the Data
Files folder

Finally, double click to open the Writer Documents folder and
click on Save




As you are working your way through this tutorial, you can now safely
hit Ctrl-s to save your work as you go along. Every time you save
the Term Paper document, you will be replacing and updating the version
that is in your Data Files folder. The original document, which is in
your Miscellaneous Files folder, will remain untouched.

You are ready to begin work.

2.1 INSERTING PAGE NUMBERS

It would be useful to insert page numbers in the Term Paper for easier
reference as you work your way through the remainder of this tutorial.
You should insert page numbers in either the header or the footer of
your document. Writer takes care of keeping the numbers sequenced as
your page numbering changes.


First, click in the header section of the first page of the Term
Paper document, above the first line (First Things First), to
open the Header, then click on the light blue Header box that
pops up on the page (Fig. 2.1)
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Fig. 2.2 The Header section on Page 1 of the Term Paper document

This will open a header on every page of the document, which will allow
you to put a page number up there. Notice that the cursor is waiting at
the left hand edge of the header section.


Next, type the word Page followed by a space, then in the
Insert menu select Fields > Page Number (Fig. 2.3)
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Fig. 2.3 Inserting page numbers into the header of a document

You now have a page number (Page 1) in the header at the top left of the
page (Fig. 2.4).

[image: ]

Fig. 2.4 Inserting a page number into the header of a document

Scroll down to pages two, three and four and notice that there is a page
number there, too, with the same format. If there were 200 pages in the
document, every page would now have an appropriate page number in the
same format.

The only other change you’re going to make is to move the page number
over to the right hand side of the header. This is simple enough to do
because you only have to do it to the page number on any one of the
pages for the change to occur throughout the document.


First, make sure the cursor is still in the header at the top of
one of the pages


In the Formatting toolbar there are four text alignment tools—one for
left alignment, another for center alignment, another for right
alignment, and a fourth for justified alignment (where the text is
aligned with the margins on both side of the page) (Fig. 2.5).
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Fig. 2.5 The Text Alignment tools in the Formatting toolbar


In the Formatting toolbar click on the Right alignment icon,
then save your work (Ctrl-s)


That’s all there is to it. Now check every page again and make sure the
page numbers there are aligned on the right as well.

If you wanted to start a document at some page number other than 1 you
would click anywhere in the first paragraph of the document, then in the
Format menu select Paragraph… to bring up the Paragraph dialog box
(Fig. 2.6).
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Fig. 2.6 The Paragraph dialog box showing the Text Flow settings

Say you wanted to start the page numbers at page 12 (because your
document is in two parts, for example, the first part being 11 pages
long). In the Paragraph dialog box > Text Flow > Breaks
options (check Fig. 2.6 above) you would click in the boxes next to
Insert and With Page Style and then in the Page Number entry box
you’d type the number 12, and click on OK. Simple as that!

Another page numbering option, which you will apply to your Term Paper
document here, is to NOT have a page number on the first page of the
document. This is a common practice, especially in longer documents.
Let’s do this now.


Start by clicking anywhere in page 1, then click, in the
Formatting toolbar, on the Styles and Formatting icon (Fig.
2.7)
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Fig. 2.7 The Styles and Formatting icon in the Formatting toolbar

This brings up the Styles and Formatting dialog box (Fig. 2.8).
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Fig. 2.8 The Styles and Formatting dialog box


In the Styles and Formatting dialog box, click on the Page
Styles icon (Fig. 2.8), then, in the list of Page Styles, double
click on First Page

Close the Styles and Formatting dialog box, and scroll through
the document to check that the page number now appears only on the
second and subsequent pages—there should be no page number on page 1




Now you’re ready to learn about more tools for formatting text.

2.2 MORE TOOLS FOR formatting text

A word about default settings

Your installation of Writer has default settings for the typical
printed page. The normal margins are set at 0.79”, top and bottom,
left and right. The normal spacing between lines is single spaced.
The default alignment is left (the text is aligned to the left
margin). The default number of columns on the page is 1, and the
default color of the text is black on a white background. The font
selected for the Term Paper document is Times New Roman and the size of
the characters throughout is 10 point (because that is how it was saved
in the Practice Files folder)*. *

In general, there is no point changing these settings unless they are
unsatisfactory. But you can reset any of the format options to meet
your needs. The exercises that follow will give you the opportunity to
practice doing this as you reformat the Term Paper document.

A word about WYSIWYG

WYSIWYG (computerese, pronounced “wizzywig”) is an acronym for “What
You See Is What You Get.” It is used to describe
computer systems such as the one you are using, where the appearance of
a document on the screen is what you will get on paper when you print it
out. As you make formatting changes to your document, they will show
on the screen so that you can visually check the effect of the changes
before printing.

Setting the margins

First, you need to reset the margins to 1” all round. The easiest way to
change any of the four margins on a page is in the Page Style dialog
box.


In the Format menu select Page… to bring up the Page Style
dialog box, then click on the Page tab (Fig. 2.9)


Notice that the Page Style dialog will allow you to make various changes
to the page style, including the Paper format (the paper size and
orientation and so forth). All you need to change is the margins.
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Fig. 2.9 The Page tab in the Page Style dialog box


Change each of the four Margins settings to 1.0” then click on
Apply and click on OK


Remember that you can use the Page Style dialog box to change the
margins on your printed page.

Aligning text

Justified text

When you align text on both margins, called justified text, both sides
of your text run flush with the right and left margins. Seeing is
believing, so carry out the steps that follow to see the effect of this
option. First you need to select the entire document so that you can
set justified alignment from page one to the last page of the
document. This takes a second.


In the Edit menu choose Select All (or simply press
Ctrl-a) to highlight the entire Term Paper document


Remember, if you make a mistake, it’s not a problem! You can undo
whatever you did by selecting Undo from the Edit menu or just
hit Ctrl-z). And you can do this multiple times to step back to a
point where you want to resume your work.


Now, with the entire document highlighted, click on each Text
Alignment tool in turn and scroll up and down in the document so
you can see how your text looks each time you change the alignment

You want the final version of the document to be justified, so
finish this exercise by clicking on the icon for Justified text
(aligned on both margins—the last of the four alignment icons
highlighted in the Formatting toolbar)

Now click anywhere on the Term Paper document to deselect the
highlighted text, then Save this updated version of the Term
Paper in your LibreOffice Work Files > Data Files >
Writer Documents folder (or simply hit Ctrl-s)




Notice that the margins on both sides of the screen are now aligned to
be flush with the left and right margins except lines that do not reach
all the way across the page (such as the title lines and some of the
lines at the end of paragraphs).

Centered text

Centered text stands out on a page and is often used for titles. The
following exercise steps you through the process of centering the titles
on the first page of the Term Paper document.


First, if necessary, scroll all the way back to the beginning of the
Term Paper document

Now, highlight all 3 Title lines at the top of the first page
(down to and including the author’s name)

In the Formatting toolbar click on the Centered alignment icon

After you have centered the title lines, click anywhere in the
text of the document, then once again save your work in progress
(Ctrl-s)




Choosing font faces

Font faces come in all shapes and sizes, and you probably have several
dozen available to you on your computer. Times New Roman font comes
standard with all computers, so the text displayed on your screen is
almost certainly in this font since the Term Paper document was saved
with this font.

Times New Roman is a serif font, which means it has serifs.[^1]
Serifs are the small marks (flourishes) used to complete a letter (Fig.
2.10).
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Fig. 2.10 Serif (Times) and sans serif (Arial) font faces

A sans serif font doesn’t have these flourishes, as you can see if you
look closely at a font such as Arial (Fig. 2.10 above).

In general, serifs improve readability by increasing the definition of
letters. However, the clean lines of sans serif fonts can prove easier
to read in some contexts, especially, for example, with larger font
sizes. Sometimes you may need to set off one font against another (as
in these tutorials) so sans serif fonts such as Ariel and Comic Sans
MS will often come in handy.

It will be useful for you to practice changing fonts. This will also
give you the opportunity to discover the wide variety of fonts you can
use.


From the Edit menu choose Select All (or Ctrl-a) to
highlight the entire Term Paper document

In the Formatting toolbar, click on the down arrow next to the
Font Name tool (Fig. 2.11 next page) to drop down the list of
available fonts on your computer

Click on any of the fonts in the Font menu and you wil be able to
see how the font will look if you were to select it for the Term Paper




Do this again for several different fonts. Each time, check the
letters carefully to see what type of font you have chosen. Is the
font you chose serif or sans serifs? Do you like any particular
fonts? Which is your favorite font?

[image: ]

Fig. 2.11 The menu of available fonts

Very important: For the sake of this tutorial you need to set the
entire Term Paper document to Times New Roman font after you have
finished checking out some of the many fonts available with Writer.
This is because the relative sizes of fonts may create variations in the
page numbers of the Term Paper document we’re working with, and this may
affect the directions for the rest of the tutorial.


Select All (Ctrl-a) and choose the Times New Roman font)
to return the document to Times New Roman font, then Save
(Ctrl-s) the document again


Now you are going to choose a different font just for the table on page
1 of the Term Paper document. The Table begins about half way down the
page with the header: Skill or Concept and ends with the caption:
Table 1 ISTE Foundational teacher skills and concepts.


First, click anywhere in the Term Paper document to deselect any
highlighted text and scroll, if necessary, to page 1

Use the mouse and drag to select all the items in the table on
page 1—from the Title: Skill or Concept down to the end of the
caption:Table 1 ISTE Foundational teacher skills and concepts

Now select Arial as the font for the text in the table, click
anywhere to deselect the table text and Save your work
(Ctrl-s) before you move on




Changing the point size of text

The size of fonts is measured in points.

9 point is quite small;

12 point is standard;

36 point is quite large.

The smallest font size is 4 point (tiny); the largest possible font size
is 255 point (huge!). The font size for the body of the Term Paper
document can be left at 10 pt. But it would be interesting to use a
larger font size for the Title lines and we will also need to reduce the
font size for the text in the Table which will end up on Page 2 after
we’re done with the following exercises. Let’s start with the Title
lines.


Go to the beginning of the Term Paper document and highlight the
first Title line on the first page: FIRST THINGS FIRST, then
In the Formatting toolbar use the Font Size tool to select
36 pt (Fig. 2.12)
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Fig. 2.12 Changing the size of fonts

Now there’s a headline for you! Complete this exercise by changing the
size of the remaining Title lines as follows:


Make the second line of the title (the sub-title) 24 pt and
make the author’s name 18 pt and Save your work (Ctrl-s)


Inserting Page Breaks

It is often the practice to keep an Abstract on a page by itself, ahead
of the main body of a paper. So, for this exercise you are going to
set a page break after the Abstract.


Still on page 1 of the Term Paper, click to position the cursor at the
beginning of the line: “ISTE Foundational skills and concepts”
(about half way down page 1)

Now, in the Insert menu select Manual Break…




This will bring up the Insert Break dialog box (Fig. 2.13).

[image: ]

Fig. 2.13 The Insert Break dialog box


Notice that the Page Break option is selected by default, so
click on OK

Scroll up and down between pages 1 and 2 so that you can see how
the Page Break worked




Notice that Writer moves the “ISTE Foundational skills and concepts”
section to a new page following the Abstract. Thus the Abstract will
now print on page 1 by itself, following the title lines.

Practice makes perfect

Let’s try this again by inserting a Page Break immediately before the
text which follows the Table of ISTE Foundational teacher skills and
concepts. Here again are the steps to do this:


Position the cursor just about half way down page 2 of the
document, at the beginning of the line that reads “It will be useful
to examine...” (that’s the line that follows the table caption:
“Table 1 ISTE Foundational teacher skills and concepts”)

Insert a Page Break here, too (Insert menu > Manual
Break… and click on OK to accept Page Break)




One last task before you move on. You are going to increase the font
size of all the text that is now on pages 3 thru 5 of the Term Paper
document.


Position the cursor at the top of page 3 (immediately before
“It will be useful…”, then scroll to the last page of
the document (page 5), and hold down the Shift key while you
click at the end of the Bibliography section—the end of the Term
Paper document

Now with the contents of pages 3-5 highlighted, change the font
size of the text from 10 to 12

Save your work (Ctrl-s)




Changing the layout of the Skill or Concept table

There are some formatting changes you need to make to the Skill or
Concept table which is now on Page 2. When you are done, it will have
a similar layout to Fig. 2.14.
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Fig. 2.14 ISTE table after the first set of updates


Scroll back to page 2, if necessary, and highlight the title
of the table (Skill or Concept) by dragging across it (or
triple click on it)

In the Formatting toolbar, click on the center alignment icon

With the title of the Table still highlighted, use the Font Size
tool to make 14 pt the font size of the table Title, and,
still in the Formatting toolbar, click on the Bold icon (Fig.
2.15), then click at the end of the title to put the cursor there and
hit the Return/Enter key once to space the table’s contents
down from the Title line
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Fig. 2.15 The Bold icon in the Formatting toolbar


Now highlight the caption at the end of the table (Table 1 ISTE
Foundational teacher skills and concepts), center it and change
its font size to 8 pt

Finally, click to position the cursor at the beginning of the caption,
right before Table 1 ISTE… and hit the Return/Enter key
once to space the caption down from the table




At this point the Skill or Concept table on Page 2 of the Term Paper
document should look like Fig. 2.14 on the previous page.


Save your work (Ctrl-s) before you move on


Spacing before and after paragraphs


Make sure that you can still see all of the Table of ISTE
Foundational skills and concepts on page 2 of the document


Sometimes it is easier to read a list of items if they are slightly
separated one from the other by what is called white space (the parts of
a page where there is no text). Let’s do this next.


Drag with the mouse to select (highlight) all the items in the
BODY of the table (from Demonstrate ability... at the
beginning of the table to …roles of the learner and the educator
at the end of the table—NOT including the caption)

Now, in the Format menu select Paragraph…, to bring up the
Paragraph dialog box and click on the Indents & Spacing tab
(Fig. 2.16)
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Fig. 2.16 Paragraph dialog box


Change the Spacing > Below Paragraph: setting to 0.05”,
click on OK, then click anywhere in the text to remove the
highlighting (to deselect it) and save your work up to this point
(Ctrl-s)


Notice how much easier it is now to pick out each of the items in the
Skill or Concept table.

2.3 BULLETS AND NUMBERED LISTS

Numbered lists

For the next exercise you are going to use the Bullets and Numbering
Styles in Writer to number each of the items in the Table of ISTE
Foundational Teacher Skills and Concepts on page 2 of the Term Paper
document.

You can use any of several numbering and bullet styles. But let’s keep
it simple for now.


Once again, highlight all the items in the body of the table
(from Demonstrate ability... to …roles of the learner and the
educator)

In the Formatting toolbar, click on the Numbering On/Off tool
to quickly number each of the items in the Table (Fig. 2.17)
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Fig. 2.17 The Numbering On/Off icon in the Formatting toolbar


Click anywhere to deselect the highlighted Table, then Save your
work again (Ctrl-s)


At this stage, the Table should look much like the illustration in Fig.
2.18.
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Fig. 2.18 The numbered list of Skills and Concepts

Notice the hanging indents for each item in the table. Writer uses a
hanging indent so that the numbers stand out. We’ll return to the
subject of hanging indents later in the lesson, where you will practice
creating them yourself.

You can also start numbering from a number other than 1. You would
need to know how to do this, for example, if you broke up a numbered
list into two sections with text in between that is not numbered. If you
wanted to start numbering from a number other than 1, you would do this
by selecting the Format menu > Bullets and Numbering… and, in the
dialog box that pops up (Fig. 2.19), you would click on the Options
tab and, in the Start at: box type the starting number you want for
the list of items you are working with.
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Fig. 2.19 Settings for Customizing a Numbered List


For our purposes, however, we want to start at 1, so make sure the
Start at: value is 1 (don’t change a thing) and click on
OK


Bulleted lists

If you wanted bullets instead of numbers, you would select the Bullets
On/Off tool, which is right next to the Numbering tool in the
Formatting toolbar (Fig. 2.20).
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Fig. 2.20 The Bullets On/Off tool in the Formatting toolbar

There are several styles of Bullets that you can choose in
LibreOffice, and you can check them out by selecting Format menu


Bullets and Numbering… and, in the Bullets and Numbering dialog
box that comes up, you would select one or other of the bullets styles
that show in the Bullets tab (Fig. 2.21).


[image: ]

Fig. 2.21 Bullet styles dialog box


Did you save your work? Hit Ctrl-s before you forget…


2.4 SETTING OFF A BLOCK OF TEXT WITH A BORDER

The ISTE Table should now be starting to look more like a table! Let’s
make one more update to set off the table as a separate item from the
running text of the Term Paper.

Sometimes, for emphasis or effect, it looks professional to set off a
section of a document with a border or frame.

You are going to do this to the Table of ISTE Foundational Teacher
Skills or Concepts on page 2. It will end up looking something like
Fig. 2.22.
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Fig. 2.22 ISTE Table with a border


Once again highlight the contents of the body of the Table (the 13
numbered Skills and Concepts, NOT including the centered
Table Title (Skill or Concept) at the top, or the centered
caption (Table 1 ISTE, etc.) at the bottom

Now, in the Format menu, select Paragraph… to bring up the
Paragraph dialog box and click on the Borders tab (Fig. 2.23)
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Fig. 2.23 The Borders tab in the Paragraph dialog box


Use Fig. 2.23 above carefully to make sure you select the correct
settings for the table Border:

Click on the 2^nd^ Line arrangement button to Set All Four
Borders

In the Spacing to contents section, make sure each of the values
is 0.20”

In the Shadow style section select the 4^th^ option to put the
shadow at lower left of the table

Now click on OK, then click anywhere in the document to remove
the highlighting so you can see the effect of the changes you have
made to the ISTE Table on Page 2 of the Term Paper document—it should
look much the same as Fig. 2.22 on the previous page

Save your work again (Ctrl-s) and take a break!




2.5 USING TAB STOPS

Inserting Tab Stops

Let’s take a short break from the Term Paper exercise and learn about
Tab Stops in general. No need to close the Term Paper document, though,
because you still have plenty of work to do with it, including setting
some tab stops here and there. To practice using tab stops, you’ll be
using a new blank document.


From the File menu select New > Text Document, and wait
while a Blank Writer Text Document opens


Tabs are very useful for lining up text in columns, as illustrated in
Fig. 2.24.


Andrew Freshman 186 90.35

Mary Senior 95 85.50

Teresa Sophomore 87 87.90

Bernard Senior 210 100.00

Josephine Junior 123 78.25




Fig. 2.24 Typical columnar organization of data

In the table in Fig. 2.24 the first column has a list of names aligned
left. The second column has a list of academic year designations which
are centered on the column. The third column has whole numbers which
are usually aligned right. Finally there is a column of decimal
numbers which are aligned around the decimal point.

If you have never used Tab Stops before, you may find them confusing.
The exercise that follows will help you understand what Tab Stops are
all about and how they work.

The purpose of Tab Stops is to help you align data, often in columns,
like in the table above. One thing you should never do in a word
processor is try to line data up using the space bar; this is a
surefire recipe for getting things out of line because of the way modern
word processors use relative spacing for the characters in a line or
on a page*. *

Notice the Tab selector icon at the left edge of the Ruler bar—top left
corner of the Writer window. It looks like the capital letter L
(Fig. 2.25) because the default tab selector icon is for left
alignment.
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Fig. 2.25 The Tab selector icon to the left of the Ruler bar

This means that, if you click anywhere along the Ruler bar to set a Tab
Stop while this tab icon is selected, a left Tab Stop will be set at
that place in the ruler. If you use the Tab key on the keyboard to tab
across to that Tab Stop, you will be left aligned on it, and any text
you type will proceed from the left of the Tab Stop to the right.

The best way to understand this is, of course, to do it, so here goes.
Put your thinking cap on, OK? First thing you need to do is remove/clear
any existing tab stops that may already be inserted along the Ruler bar
of your blank document. Here’s how you do this.


In the Format menu select Paragraph…, then in the Paragraph
dialog box that pops up, click on the Tabs tab (Fig. 2.26), and
click on Delete all
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Fig. 2.26 The Tabs/Delete all option in the Paragraph dialog box

You are going to put four different Tab Stops along the Ruler bar.
Fig. 2.27 shows the Tab Stops you should end up with for the correct
alignment of the data in the table illustrated in Fig. 2.24 on page 48
above.
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Fig. 2.27 Tab settings for the table in Fig. 2.24 (page 48 above)

Try the following to see how to select some of the commonly used Tab
Stops before using them to align data on a page of text.


Click once on the Tab icon button in the top left corner of
the screen, and you’ll see the icon change to the icon for
centering text on the Tab Stop (it looks like an upside down
‘T’ and indicates that text aligned on it will be centered on it
and move to either side of the Tab Stop, left and right, as you
type)—it’s the second Tab Stop in Fig. 2.27

Click again (a second time) on the Tab icon button and you’ll see
the icon for right alignment (this Tab Stop looks like a backwards
‘L’, indicating that text aligned on it will go to the left of
the tab stop because it’s aligned from the right—if you’ve never used
Tab Stops before, that must sound confusing, but you’ll see how it
works in a minute when you complete the exercises that follow)—the
right alignment Tab Stop is the third one along the ruler in Fig. 2.27

Finally, click again (a third time) on the Tab icon button and
you’ll see the icon for decimal alignment (this Tab Stop looks
like an upside down ‘T’ with a dot to denote the decimal
point—this is for decimal numbers, like dollars and cents, for
example, and makes sure everything is lined up on the decimal
point)—check the decimal alignment Tab Stop on the right hand side of
Fig.2.27




If you continue clicking on the tab icon button, you’ll see other Tab
Stops and indent markers. You won’t need these for this exercise.

Your task is to reproduce the table illustrated in Fig. 2.24 on page 48
above. You’ll need to begin by setting the four Tab Stops as they are
illustrated in Fig. 2.26 above.


Click on the Tab icon until you see that the left Tab Stop is
selected, then click once at the 1” hash mark on the ruler

Click again on the Tab icon until you select the center Tab
Stop and click once at the 2 ½ ” hash mark on the ruler

Click again on the Tab icon until you select the right Tab
Stop and click once at the 4” hash mark on the ruler

Finally, click on the Tab icon until you select the decimal
alignment Tab Stop and click once at the 5” hash mark on the
ruler




Now, with the Tab Stops in place, you can start to enter the data from
the table in Fig. 2.24 on page 48 above.


First, make sure the cursor is still waiting at the left edge at
the top of the blank page

Hit the Tab key to move the cursor across to the first tab, and
enter the first name in the table (Andrew—which will be left
aligned on the tab stop)

Hit the Tab key again, and enter the class that goes with the
first name (Freshman—notice how it is centered on the Tab Stop
as you type it)

Hit the Tab key again, and enter the rating value that goes
with the first name (186—again notice how it is right aligned
on the Tab Stop)

Hit the Tab key again, and enter the test score that goes with
the first name (90.35—and notice how the value is aligned on the
decimal point)

Continue in this way until you have entered all five (5) lines of
data in the table




Removing Tab Stops

To remove a Tab Stop, you need to position the tip of the mouse
pointer on the Tab Stop marker and drag the Tab Stop down off the
ruler. When you release the mouse button the Tab Stop will be gone.
This is tricky to do if you’re not used to it because the Tab Stop is
small and you have to be very careful to use just the tip of the mouse
pointer. Try this for yourself.


Position the cursor anywhere on the first line of the student
records, then position the tip of the mouse pointer on each of the
Tab Stops one by one and drag the stop down below the ruler, then
release the mouse button to throw it away


This will mess up the layout of the data in that first line, but that’s
OK for now since you’re just practicing.


Now undo what you just did by pressing Ctrl-z four times


You can also remove all the Tab Stops at one time. You already did
this at the beginning of this exercise (see Fig. 2.25 on page 49 above),
but here’s a reminder of how you do this.


Click anywhere on the first student record and then double
click on any one of the Tab Stops


This brings up the Paragraph dialog box.


Now, in the Paragraph dialog box, click on the Tabs tab, then
click on the Delete All button


There! All the Tab Stops are gone for that particular student record.
To clear the Tab Stops for ALL the student records in one go, simply
highlight all the records (Ctrl-a), double click on one of the Tab
Stops in the ruler, and in the Paragraph > Tabs dialog box click on
Delete All.


Now Close the Untitled document and don’t Save it; this
was just an opportunity for you to practice how to use Tab Stops


**2.6 STYLE OF TEXT AND LINE SPACING **

Text Styles

When writing, it is often important to draw attention to certain words
or phrases by adding emphasis to them. This can be accomplished by
boldfacing, italicizing, or underlining the text.

These options are available from the appropriate icons in the Formatting
toolbar (Fig. 2.28).
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Fig. 2.28 Text style icons in the Formatting toolbar

Alternatively, you can apply the styles using Quick Keyboard cCommands:
Ctrl-b for Boldface, Ctrl-I for Italics, and Ctrl-u for
Underline.

Boldface

Titles and sub-titles should stand out on a page. Increasing the size
certainly helps. Using all capital (uppercase) letters can also add
emphasis and draw the eye of the reader. You have seen both of these
techniques applied to the Titles at the top of the first page of the
Term Paper document.

Boldface also will improve the appearance of the three section
headers (Abstract, ISTE Foundational skills and concepts, and
References) and make them stand out on the page. While you’re at it,
you might as well incease the font size, too.


Scroll to Page 1, highlight the Abstract header and make it
boldface (Ctrl-b) and increase the font size to 14 pt

Now apply boldface and 14 pt font size to the two other
section headers (ISTE Foundational Skills & Concepts at the top of
Page 2 and Bibliography on page 6)

Save your work (Ctrl-s)




Underline

On page 2 of the Term Paper document (the page after the Abstract) we
have the table of the 13 ISTE Foundational teacher skills and
concepts. Following this table, on pages 3 through 6, each skill or
concept is taken one by one for further explanation.

Your task is to underline the skill or concept at the beginning of
each of the 13 sections on pages 3 through 6. When you do this, you
will underline just the words that describe the skill or concept; do not
include the number of the concept—so you’ll underline just the line or
two of words immediately after the number that states the skill or
concept.

Fig. 2.29 illustrates what you need to do.
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Fig. 2.29 Underline only each of the Skills or Concepts from the Table
on page 2

Here is a step-by-step explanation of how to do the first one.


Scroll to the beginning of page 3 and, in the first skill or
concept, click to put the cursor immediately before the T of
“Teachers...“

Now hold down the Shift key and at the same time click at the end
of the skill or concept (i.e. after the period at the end of the
word “...software.”) to highlight the text of the skill or
concept, and press Ctrl-u to underline the skill or concept




That’s all there is to it. Go ahead now and underline the remaining 12
skill or concept section titles. When you have finished this exercise,
the underlined section titles will look as illustrated in Fig. 2.29
above.


Don’t forget to save your work when you’ve finished underlining


Italics

Your next task is to italicize the author’s name on the first page.
You can probably figure this out for yourself, but just in case you need
help, here are the steps.


Select the author’s name under the title on the first page of the
Term Paper and press Ctrl-I, then save your work again


Line spacing

Papers may be printed with variable spacing between lines. The
following steps show you how to do this in Writer.


Select the entire paper by pressing Ctrl-a (Select All)

Now from the Format menu select Paragraph…, then, in the
Paragraph dialog box click on the Indents and Spacing tab

Click on the arrow at the end of the line spacing box (Fig.
2.30) and select Double for the spacing option, then click on
OK
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Fig. 2.30 Line Spacing in the Paragraph dialog box


Your document was set in single spacing when you loaded it from the
Work Files for LibreOffice. Double spacing is required for many
written documents and now you know how to do this using Writer.


For the sake of this exercise, however, be sure to return the document
to single spacing (Ctrl-a > Format menu >
Paragraph… > Indents and Spacing tab > Line spacing


Single > OK)


Now press Ctrl-s to save your work to date




2.7 INDENTING TEXT

Adjusting (moving) the Indent Markers

You practiced doing this in Lesson 1, but maybe you need more practice
since these indent markers can be tricky to apply.

There are two indent markers on the left side of the Ruler bar, one
above the other, as illustrated in Fig. 2.31. The First Line Indent
marker is on top, the Left/Hanging Indent marker is on the bottom.
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Fig. 2.31 The indent markers in the Ruler bar

The indent markers establish where text is aligned in relation to a
paragraph as a whole. The First line Indent marker (it looks like an
upside down triangle) is applied only to the first line of a
paragraph. The Left Indent/Hanging Indent marker control the
margin for all the lines after the first line in a paragraph.


Carefully examine Fig. 2.31 to clearly identify each indent
marker before proceeding with the tutorial

Tip #1: Remember that the tip of the mouse arrow is the
hot spot. Moving the small indent markers is a precise task, so
be sure to position the tip of the mouse arrow on the indent
marker that you want to move.

Tip #2: When you drag on the Left/Hanging Indent marker
(Fig. 2.29 above) both of the markers move together. When you
drag on the first line indent marker, which is above them, it
moves on its own, leaving the First Line/Hanging Indent marker in
place.




Traditionally, an indent is commonly used for the first line of
paragraphs—where the margin is set in a few spaces from the rest of
the paragraph (Fig. 2.32A).
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Fig. 2.32A Fig. 2.32B


Then there is the indent for a list such as a bibliography—where you set
the margin for the first line back a few spaces from the rest of the
paragraph. Writer refers to this latter indent as a “hanging indent”
because the lines that follow look as if they are hanging off the first
line (Fig. 2.32B).

The Term Paper document that you have open on the screen would benefit
from the use of both types of indent markers.

Indenting the first line of paragraphs

Right now in the Term Paper document it is difficult to tell where one
paragraph ends and another begins. Let’s indent the first line of the
paragraphs in the Abstract so you can see what a difference this simple
change makes.


Click at the beginning of the first line of the first
paragraph of the Abstract on page 1 (immediately ahead of
the words “The teaching profession…” at the beginning of the next
line after the Abstract header)

Hold down the Shift key and click again at the end of the
Abstract, to highlight all the Abstract text

Now, on the left side of the Ruler bar at the top of the document,
position the tip of the mouse arrow on the First Line Indent
marker (the upper marker) (see Fig. 2.31 on the previous page), and
drag this First Line Indent marker to the right a ½
inch (to the ½” hash mark), then click anywhere to remove the
highlighting




Notice how Writer indents only the first line of each of the two
paragraphs in the Abstract. This makes it easier to tell where one
paragraph begins and another ends.

Pages 3 through 6 of the Term Paper document have 13 numbered sections
which discuss each of the skills or concepts in the Table on page 2.
In the next exercise, you are going to indent the first line of all the
paragraphs on pages 3 through 6. Fig. 2.33 illustrates what you need
to do.
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Fig. 2.33 Indenting the First line of paragraphs

Let’s do the first numbered Skill or Concept section together, so you
see what is required.


Scroll to the top of Page 3 and position the cursor at the
beginning of line 3, immediately before the sentence that begins:
“The use of computer-based systems….”

Hold down the Shift key, and click at the end of the section,
immediately after the phrase “lesson planning.”




This selects all the commentary in the first numbered section on page


	




Now, in the Ruler bar, drag the First Line Indent marker over
to the right (to the ½” hash mark), just as you did for the
Abstract on page 2


Now on to the second numbered section.


Position the cursor at the start of line 3 of the second
numbered section—the sentence that begins: “Evaluation involves
keeping current….”

Hold down the Shift key, and click at the end of the section,
immediately after the phrase “exchange of ideas.”




This selects all the commentary in the second numbered section on page


	




Now, in the Ruler bar, drag the First Line Indent marker over
to the right (to the ½” hash mark), just as you just did for
the previous section

Continue in the same way and change the First Line Indent for the
remaining paragraphs in sections 3 through 13 on pages 3 through
6 of the Term Paper document (but do not indent the numbered
lines that begin each section and don’t do anything with the
Bibliography section just yet)




This task won’t take you long. You might be thinking to yourself: “Why
the heck is the lesson making me do this over and over again?” Well, as
anyone knows, practice makes perfect, and by the time you’re finished
with this tutorial, you’ll feel pretty pleased with what you’ve learned,
so stay with it, OK?


When you are done with this exercise, hit Ctrl-s to save the work
completed to this point


Hanging indents

There are many occasions when it is useful to indent parts of your text
using hanging indents. A hanging indent is where the second and
subsequent lines of a paragraph of text are indented to the right of
the first line. For example, you may want to make a list of points
with a “bullet” at the beginning of each point, like this:


	Don’t settle down at the computer until you have carefully planned
what you want to do. If you plan ahead you will be sure to do a
better job and save yourself a whole bunch of time!



or like this:


	Don’t forget to clean your teeth and make your bed after you’ve had
your breakfast every morning!



This is easy to do with the bulleting and numbering tools built into the
word processing software. But it is also important to know how to use
the indent markers to create hanging indents that do not involve the
use of bullets. For example, hanging indents are used when you write a
paper that includes a list of sources cited, as illustrated in Fig.
2.34.
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Fig. 2.34 An example of a hanging indent


Scroll down to the end of the Term Paper document


Notice that indentation has not yet been used for the Bibliography
section, but it should be because it is standard practice. Without
hanging indents as illustrated in Fig. 2.34 above, it would be difficult
to determine where one Bibliography entry ends and another begins,
especially in a long list of references. So your next task is to tell
Writer to use hanging indents for this last section of the paper.


Highlight all the references by clicking at the beginning of the
first reference (not the References header), then hold down
the Shift key and click again after the last reference

Position the tip of the mouse arrow on the Left Margin/Hanging
Indent marker (the lower of the two triangular-shaped markers), and
drag this Left Margin/Hanging Indent marker across ½” (4
hash marks) to the right, then let go of the mouse button




When you let go of the mouse button, the entire References section will
be adjusted ½” to the right.


Now you need to slide the First line indent marker back ½” to the
0” hash mark on the Ruler


When you’re done, your Bibliography section should look like Fig. 2.32B
a couple of pages back (on page 55). Notice how the references are
nicely indented after the first line. That’s just the way it should
be. To reinforce this skill, you are now going to work your way once
again through pages 3 through 6, creating a hanging indent for each of
the thirteen numbered and underlined skills and concepts. You are going
to apply a hanging indent of just ¼”. Let’s do the first one together
so you can see what is required.

Fig. 2.35 on the next page illustrates how each numbered skill or
concept should look when you’re done.


Use the tip of the mouse pointer to drag the Left Margin/Hanging
Indent marker over to the right just 2 hash marks (¼”)
and then grab the First Line Indent marker and drag it back to the
0” hash mark on the Ruler bar

Do this again for section number “2.”




That’s all there is to it. Notice how the hanging indent improves the
appearance of those numbered underlined skills and concepts.


Complete the same task for the remaining 12 numbered items on pages
3 through 6 so they end up looking like those illustrated in Fig.
2.35 on the next page, then Save your work when you are done
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Fig. 2.35 Hanging indents for the numbered items in the Term Paper


Position the cursor anywhere in the section number “1.” at
the top of page 3


2.8 CREATING SECTIONS AND COLUMNS OF TEXT

Columns are often useful for documents such as class newsletters.
Reducing the width of lines of text can make for easier reading. In
the exercise that follows, you will create a two-column section within
the Term Paper document. The rest of the paper before and after the
two-column section will remain single column. Here are the steps to do
this.


Scroll to the top of page 3 and position the insertion point
cursor immediately before the text: “It will be useful to
examine…”, then, in the Insert menu, click on Section… to
bring up the Insert Section dialog box (Fig. 2.36)
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Fig. 2.36 Inserting a Continuous section break


Click on the Columns tab, set the number of columns to 2,
and increase the spacing between columns to 0.20”, then click
on the Insert button


The next step is tricky, so follow the directions carefully.


The cursor is still waiting at the top of Page 3, before the first
line which reads: “It will be useful…”; make sure it is still
there

Now, use the scroll bar on the right of the window, or use the
roller on the mouse, to scroll down all the way to the
end of the last of the teacher skills and concepts on Page 6,
hold down the Shift key, and click immediately after the phrase
“professional work with children.”




The whole section that discusses the 13 Teacher Skills and Concepts
should now be highlighted.


Careful now; hit Ctrl-x—this will cut everything that’s
highlighted from the document and save it on the clipboard


Page 3 should now look like Fig. 2.37. Notice the two new faint
bracketed areas on your screen.
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Fig. 2.37 Page 3 after cutting all the Teacher Skills and Concepts
information

You are now going to Paste everything from the clipboard into this new
two-column section of the Term Paper document.


First, click to position the cursor one line up, inside the
left bracketed area, and Paste (Ctrl-v) the data from the
clipboard back into the Term Paper Document


If you followed the directions correctly, Page 3 of your document should
now look something like Fig. 2.38.
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Fig. 2.38 Two-column text

If it does, that’s AWESOME! If it doesn’t, just hit Ctrl-z repeatedly
till you get back to a point where you see where you were at at the
beginning of this section of the tutorial, then try it again. But
hopefully you’re in good shape and we can proceed.


Save your work before going on, then scroll to the top of Page
1 of the Term Paper document, and notice that Pages 1 and 2 are
still single column text, then scroll down through the document
to the end to take a look at the difference the Columns tool
makes, and notice also that the Bibliography is still single
column as well


So, you have now divided the paper into three sections: Pages 1 and 2
are the first section; Pages 3-6, not including the Bibliography, are
the second section; and the Bibliography is the third section. If you
had not inserted the new section at the top of page 3, your whole
document (including the Title lines, the Abstract, the ISTE Table, and
the Bibliography section) would be in two column format. The section
allows you to control exactly which pieces of a document you want
adjusted in certain ways.


Scroll down to the end of the Term Paper, if you aren’t already
there


In summary, if you need different formatting for different parts of a
document, you would do so by inserting sections wherever necessary.
LibreOffice makes this very easy indeed

The Skill Consolidation exercises at the end of this lesson will provide
you with an opportunity to practice this and other more advanced word
processing features.

2.9 finding and replacing TEXT

It is surprising how often the Writer Find (Ctrl-f) and Find and
Replace (Ctrl-h) functions come in handy when you are working with
larger documents. You may want to find each place in a document where
a certain word or phrase is used and either delete it, or change it, or
correct a misspelling. Or you may want to jump quickly to a certain
page because you have to rewrite something or insert a sentence. You
could scroll through the document looking for what you want, and you
might even eventually find it! But don’t count on it. In any case,
this takes time and there is always the possibility that you might miss
the text in question on a first or second pass.

The Writer Find function will swiftly and unerringly locate any
specific text you are looking for.

Finding a text string

A point to ponder before you proceed

When you are using computers, a character is anything that you type
at the keyboard (including numbers, spaces, and punctuation marks). A
sequence of characters is often referred to as a “string” in
computerese. In this sense a word is no different than a
phrase as far as a computer is concerned; both are
strings—sequences of characters.

You are going to add a sentence to the Term Paper document. The
proposed new sentence is as follows:


Teachers cannot be expected to use computer-based learning systems
effectively unless they acquire these skills and assimilate these
concepts.


The new sentence is to go immediately after the sentence in the document
that begins: “These skills and concepts should form…” Now, before
selecting and entering a string of text for a search, you should take a
moment to think about what the string of text should be.

The phrase that marks the point in the document you are trying to find
(“These skills and concepts”) is long enough to probably be
unique. This will more unerringly locate the exact string of text
you’re looking for.

Here then are the steps to quickly locate and add the proposed new
sentence (see highlighted text towards the end of the previous page) in
the specified location in the Term Paper document.

It is often easiest to start a search at the beginning of a document if
you are not absolutely sure where the text you want to find occurs.


In case you are not already there, use the right scroll bar to
scroll to the top of the first page of the paper, place the
insertion point cursor immediately ahead of the title FIRST
THINGS FIRST at the top of the paper, then press Ctrl-f to
activate the Find function tools


Writer now displays the Find dialog at the bottom of the Writer
window (Fig. 2.39).
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Fig. 2.39 The Find function tools (Ctrl-f)

Writer needs you to enter the text for the search. To make sure the
phrase is unique, you might as well type “These skills and concepts”
as your search text.


In the Find dialog box type These skills and concepts
(including the uppercase “T”) and hit the Enter/Return key


Look now at the highlighted phrase in the document and you will see that
this small string of characters is indeed the start of the phrase you’re
looking for.

If you mis-typed the search text so that Writer is unable to find it,
the search will conclude with a warning message telling you that the
search was unsuccessful and asking you if you want to try again from the
beginning of the document (Fig. 2.40), and you would try again with a
corrected sequence of characters or another phrase altogether.

[image: ]

Fig. 2.40 Unsuccessful search

Once the search is successful, the text you have been looking for is
selected (highlighted). You want to insert the new sentence immediately
after the sentence that Writer has found for you.


Click after the period at the end of the sentence to put the
insertion point cursor after the phrase “...teach in the modern
computerized classroom.“

Press the space bar to put a space after the period, then type the new
sentence: Teachers cannot be expected to use computer-based learning
systems effectively unless they acquire these skills and assimilate
these concepts.

Click anywhere to remove the highlighting, read it over to check for
errors, then Save the changes you have made




Replacing a multiple occurrence of a text string

Suppose you have just finished typing the Term Paper into Writer and
saved it on your disk. You print a draft copy so that you can read it
over before producing a finished copy. Amongst other edits, you decide
to change the phrase “skills and concepts”, which is a phrase that
occurs throughout the paper, with the words “concepts and skills”.

Again, you could use your eyes to visually scan through the text on the
screen until you find each occurrence of “skills and concepts” and, each
time you find it, change the phrase to “concepts and skills”. But this
would take some time and, anyway, you will be likely to miss some of the
changes.

Alternatively, you can use the Find and Replace option to locate each
occurrence of “skills and concepts” and change it to “concepts and
skills”. Follow these steps to use this function now.


Position the cursor at the beginning of the Title at the top of
Page 1

Press Ctrl-h (or from the Edit menu select Find &
Replace…)




Writer presents the Find and Replace dialog box with the Replace tab
selected in the set of index options (Fig. 2.41).
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Fig. 2.41 Replace options in the Find and Replace dialog box


Type skills and concepts in the Search for box, and concepts
and skills in the Replace with box, then click on the Find
button


Writer goes to work and highlights the first occurrence of “skills and
concepts”. If you cannot see this highlighted phrase on your screen,
it may be because the Find and Replace dialog box is covering it. You
can move the window around on the screen by dragging on the light pink
Title bar at the top of the Find and Replace dialog box.

The basic options available to you in the Find and Replace dialog box
are as follows. You can:


	Click on the button to Replace All occurrences of the search
text in the entire document;

	click on the button to Replace only the one occurrence
of the search string;

	click on the button to Find the next occurrence of the search
string without changing anything;

	click on the button to Find All occurrences of the search
string without changing anything.



As a rule of thumb, you should be wary of telling Writer to Replace
All occurrences of a piece of text unless you are absolutely sure you
know what you are doing. It is surprising how easy it is to specify a
string of characters that turns out to be not quite what you had in
mind. By telling Writer to Replace All occurrences of a string of
text you might result in your document being peppered with unwanted
changes.

So be careful! Suppose, for example, you told Writer to correct a
misspelling where you spelled receive with the “i” before the “e”
(“recieve”). You specify “ie” as the search text, and innocently tell
Writer to replace all occurrences of “ie” with “ei” (because you want
to correct the misspelling of “receive.” Well, as it happens, in the
Term Paper document the character sequence “ie” occurs many times (about
50 times!) in all kinds of innocent words (technologies, belief, etc.)!

Should they all be replaced with “ei”? Clearly not. Even “cie”
occurs 8 times in the Term Paper, and so on. So you have to be careful
(1) to specify the search text that will get you right away the result
you want, and (2) work your way through the document selecting only the
iterations of the string you want to replace. In our hypothetical case
you would type the entire incorrectly spelled word “recieve.” Then you
could safely tell Writer to replace all occurrences of it with the
correctly spelled word “receive.”

Back to our example. As it happens, the search string (“skills and
concepts”) is sufficiently unique for you to go ahead and Replace All
occurrences.


Click on the Replace All button


Writer may take a few seconds to make the changes, depending on how
fast your Windows computer is. Soon you will see a window telling you
how many occurrences of the search string were replaced. So… How many
were there? There should have been 10.


Click on OK, then close the Find and Replace dialog box
and press Ctrl-s to save the changes you have made


In the course of completing this exercise you may have noticed some
spelling and typo errors in the text. Later in this lesson you will
use the Spelling and Grammar feature to clean up the document. The
more you use the word processor, the more you will appreciate the power
of the simple word processing tools such as the ones you have just
learned. The best, however, is yet to come.

2.10 MOVING and copying text within a document

In Lesson 1 you learned to appreciate the power of a word processor as a
tool for writing because of the ease with which you can edit your
work. Now you will learn how to move sections of text from one place
to another within a document. You already practiced doing this when you
used cut and paste to move all those concepts and skills to a special
2-column section of its own.

The ability to move text is crucial to the process of successful
writing. Using a traditional typewriter, you would be lucky if you
could get away with doing this by using a pair of scissors and literally
cutting and pasting your document onto new sheets of paper in the
sequence that you required. More often than not you might have to
re-type the whole document before you could submit it for others to
read.

The word processor, on the other hand, makes editing tasks such as
moving text around simple and fast. You can manipulate the text at
will, trying ideas on the fly, and save different versions until you
decide on the one best version that makes the desired impact you’re
looking for.

Very few, if any, writers write without needing to edit their work.
Indeed, you might say that bad writers are the ones who can’t be
bothered to edit at all. The word processor takes much of the sting
out of editing. Because of this, it literally helps to make you a
better writer by simplifying the essential task of molding your ideas
into nuggets of golden thought.

Moving text within a document

As with all the functions of Writer, the steps involved in moving text
within a document are simple enough. In the Term Paper document you
are going to move a paragraph from one place to another within the
document. Here are the steps to do this.


Once again, make sure the cursor is positioned at the top of the
paper

Use the Find function (Ctrl-f) to locate the phrase:
Training is thus important




The phrase (in the Abstract on page 1) should be highlighted on your
screen. The next step can be tricky for beginners, so don’t be surprised
if you have to try it a couple of times before you get it right.


Click to position the insertion point cursor immediately before
the word “Training“

Scroll down if necessary so you can see the rest of the paragraph,
then hold down the Shift Key, and keep it down, while you click at
the end of the paragraph




This will highlight the whole paragraph. Another, quicker, way to
highlight a paragraph in LibreOffice is by triple-clicking on it.
Now that the paragraph is selected (highlighted), you need to cut it
to the clipboard.[^2]


Press Ctrl-x to Cut the paragraph out of the Term Paper
document


Cutting text removes the selected text from the document and transfers
it to the clipboard. Once it is on the clipboard you can move it
anywhere you want, either within the same document, or to some other
document altogether.

You are going to move the “Training is thus...” paragraph (currently
on the clipboard) to page 6 of the document, immediately after the last
paragraph in the second column of the two-column section you created
earlier in this tutorial.


Scroll to the end of the document on page 6 and click to position
the cursor right at the end of the paragraph that ends
“…professional work with children.”

Hit the Enter key and then hit Ctrl-v (or from the Edit
menu select Paste)

With the mouse pointer somewhere on this last paragraph (the one you
just pasted), change the font size to 12 pt




Writer completes the paste process in no time at all by pasting the
section from the clipboard back into the document at the insertion
point. Now you have a strong concluding statement before your
Bibliography.


When you are satisfied that all is well, press Ctrl-s again to
save the changes you have made thus far


Copying text within a document

The process of copying text is almost identical to that of moving
text. You select the section of text you want to copy, in the same way
as you did when you cut text in the previous exercise. But now you
will have Writer copy the selection without cutting it, and then
paste a duplicate of it somewhere else in the document, leaving the
original text where it is.

For example, let us say you want to copy the title lines of the paper so
that they occur not only at the top of the first page but also at the
top of Page 2. The title lines include the two title lines followed by
the author’s name—three lines in all. Follow these steps to place a
copy of the title lines at the top of Page 2.


Position the insertion point at the top of the paper

Hold down the Shift key while you click at the end of the author’s
name (or drag down to select all three title lines)

Press Ctrl-c to copy the selected text to the clipboard




Notice that the original text is still in place—you haven’t cut it
from the document. All you have done is transfer a copy of the text to
the clipboard.


Now scroll to the top of the second page of the document and click
to position the cursor at the top of this second page
(immediately before the section header “ISTE Foundational skills and
concepts”), press the Enter/Return key once on the keyboard,
and click in the empty line above the section header to put the
cursor there

Press Ctrl-v to paste the title lines from the clipboard




Writer instantly makes a copy of the titles where the insertion point
cursor is located.


Press the Enter/Return key once more to space down after these
title lines, then scroll down to check the effect of the copy
operation

Press Ctrl-s again to save the changes




2.11 SPELLING AND GRAMMAR CHECKING

Now would be a good time to check the document for spelling errors and
other typos. As you already may have noticed, there are a few errors
that have been intentionally introduced into the document.. Before you
begin checking for errors, though, remember that a spelling checker is


1. only as good as the person using it;

2. unable to pick up grammar or word choice errors (where the word “to”
may have been typed, when “too” or “two” was intended);

3. may find a problem when there is none (such as an abbreviation it
doesn’t recognize).




You may already have had the experience where you have corrected
someone’s spelling only to have the person retort: “But I ran it through
the spelling checker!!” Be sure, of course, that you know how to spell
the word in question yourself. Then, assuming you are right, take
advantage of the situation to tell your friend that a computer is just a
dumb machine—it depends on people for its intelligent use. Since the
Spelling Checker is only as good as you are, you would be wise to always
have a good dictionary at hand. Get into the habit of looking up words
that are new to you when you come across them in your reading.

This will be the case when you are checking the spelling of the Term
Paper document. There are quite a few important technical terms in the
document that you may not have come across before. Some of them may
not be in the Writer dictionary. Does this mean you can’t check
them? Of course not. Look them up in your dictionary so as to extend
your word power. Make this a lifelong task.

Time to go ahead and run the document through the Spelling Checker.


Start by running the document through the AutoSpellcheck, using
the AutoSpellcheck tool in the Standard toolbar


Don’t trust the AutoChecker, though. You should still run the basic
Spelling and Grammar checker AND proofread the document by reading it
through carefully yourself.


Put the cursor at the beginning of the Term Paper document, then
in the Tools menu click on Spelling and Grammar… (or click on
the Spelling and Grammar button in the Standard toolbar)


This brings up the Spelling and Grammar dialog box (Fig. 2.42).
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Fig. 2.42 The Spelling and Grammar dialog box


Now… For each word that is highlighted (in red), choose whether to
Ignore (the suggested error) Once, Ignore All (further
occurrences of the same word), Add (the word) to the
dictionary, Correct (the word to a suggested alternative or to
one of the suggested correctly spelled versions), or Correct All
(including further occurrences of the same word)

The first “error” found by the system is actually not an error at all
(“imparter” is a perfectly good word in this context), so you will
click on the Ignore once button because it may be used incorrectly
later in the document




As you work your way through the document, notice how often the Spelling
and Grammar checker makes sense of what should be there and makes
recommendations that are really, really useful. You might even be
tempted to think the computer has some kind of intelligence. But the
fact is that a lot of spelling and grammar is formal and computable.
The computer seems intelligent because it has been programmed by
intelligent humans, like you, so don’t be afraid to make the computer
your friend.


Press Ctrl-s to save the corrected document after you have
completed the Spelling and Grammar check


2.12 ADDING DROP CAPS

Drops caps are neat, easy to use, tool which helps to set off one
section, or one chapter, of a document from another. You have
undoubtedly read books where the first letter of any section or chapter
is made distinctive like this (Fig. 2.43).
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Fig. 2.43 Using Drop Caps to highlight the beginning of a new section of
text

You are going to do this for each of the 13 sections which explain the
various Concepts and Skills that every teacher should have acquired to
be proficient in a modern teaching environment.


First, position the cursor, in Column 1 towards the top of page
3, after the underlined title of the first Teacher
Concept and Skill, and immediately before the phrase “The use of
computer-based systems…” (Fig. 2.44)
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Fig. 2.44 Where to put the first drop cap


In the Format menu > Paragraph… dialog box click to put a
check mark in the Settings > Display drop caps box and
change the Lines: item from 3 to 2 to make the Drop
Cap letter two lines high, then click on OK (Fig. 2.45)
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Fig. 2.45 Formatting the drop cap

The drop cap letter for the first Concept or Skill in your Term Paper
document on Page 3 should now look like what you see in Fig. 2.46.
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Fig. 2.46 Using Drop Caps

The last thing you need to do is move the Drop Cap letter to the left
edge of the column. You need to do this for all the Concepts and Skills
on pages 3 thru 5 of the document, so before you add a Drop Cap to the
first paragraph of the other Concepts and Skills, let’s change the First
Line Indent for all the first paragraphs to 0”.


Position the cursor anywhere in the first paragraph of each of the
13 Concepts and Skills sections and, in the Ruler bar, each time,
slide the First Line Indent marker back to the 0” hash mark

Now, for each of the other 12 sections, position the cursor at the
beginning of the first line of the first paragraph, then, in the
Format menu > Paragraph… dialog box (Fig. 2.43 above),
click to put a check mark in the Settings > Display drop
caps box and change the Lines: item from 3 to 2 to make the
Drop Cap letter two lines high, then click on OK




The end result for each of the 13 items will look like Fig. 2.47.
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Fig. 2.47 The Drop Cap letter aligned on the left margin of the column

2.13 CREATING A TABLE CONTENTS

You’re almost done with the tutorial. It is sometimes useful to put a
Table of Contents (TOC) at the beginning of a longer document and there
are appropriate ways of doing this. You are going to add a TOC on a
page by itself right after the Title page (Page 1).

So the TOC will become Page 2 of the Term Paper document. The following
figure illustrates how the TOC will look when you have completed this
exercise (Fig. 2.48).
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Fig. 2.48 Finished Table of Contents


Click to put the cursor at the end of the Abstract on Page 1

In the Insert menu select Manual Break…, and click on OK
to accept the default Page Break




The cursor should now be waiting at the top of the new page (page 2).
Notice that the cursor is indented ½” because that was the indent you
set for the Abstract earlier in this tutorial. You need to change that
back to 0” on the Ruler bar.


Use the mouse to drag the First line Indent marker (the upper of
the two markers on the left of the Ruler Bar) back to the 0” hash
mark on the Ruler

As you see in Fig. 2.48 on the previous page, the title Table of
Contents is boldface and centered on the page, and it is
also a larger font size than the rest of the text (16 pt), so,
in the Formatting toolbar > Font size menu, select a font
size of 16 pt, click on the boldface icon, then click on the
center icon and type Table of Contents

Hit Enter twice, then click on the boldface icon to turn off
boldface, select Left justify for the items that go in the Table
of Contents and change the font size to 12 pt

Move the Left Indent Marker (the lower of the two indent markers
on the left of the Ruler bar) to the ½” hash mark on the ruler,
then type Abstract for the first item in the TOC (Table of
Contents)




Now you need to set a Tab Stop for the right edge of the TOC, where
you want all the page numbers to line up on the right and you want
what are called “dot leaders” to run across the page to visually
connect the TOC item with its page number (see Fig. 2.48 on the previous
page).


On the Tab Stop tool (over to the far left of the Ruler bar—see
Fig. 2.48 on the previous page), click twice to change the Tab
stop to Right Tab, then click once on the ruler at the
6” hash mark to place the Right Tab Stop there (see Fig. 2.48
on the previous page again)

Now, with the tip of the mouse pointer positioned on this
Right Tab Stop at the 6” hash mark, double click on the
Tab Stop to bring up the Paragraph dialog box, then click on
the Tabs tab (Fig. 2.49)
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Fig. 2.49 Paragraph/Tabs dialog box


In the Leader section of the dialog box, click in the radio
button next to ……., which will give you the dot leaders in
the TOC, then click on the Set button, and click on OK


Dot leaders will now be applied to every item you subsequently type into
the TOC.


Hit the Tab key just once to put a line of dots all the way
across the page as far as the Right Tab Stop (these dots are
called dot leaders and they help the eye flow across the page to
the correct page number relative to the item in the Table of Contents
to which it refers)

Type the page number 1 and hit Enter

Now type up the rest of the TOC as per Fig. 2.48 on page 71,
moving the left indent marker to the 1” hash mark for the 13
Concepts or Skills, and back to the 1/2” hash mark for the
Bibliography item

Save the document when you’re done creating the TOC




Backing up your Term Paper document

You should know how to do this by now, but if you need a refresher, here
are the steps.


Go to File > Save As > Navigate to your Work Files for
LibreOffice folder > Data Files folder > name the document
Term Paper Backup > click on Save


Printing the document

At some convenient time[^3], print out a draft copy of the entire Term
Paper document. Carefully proofread the printed copy of the paper.
Have a dictionary handy. Any words you don’t understand, look them up;
extend your vocabulary. Use a pen with some color other than black to
correct any errors you spot that were not picked up by the spelling
checker. Go back to the Writer document, correct any errors you
find, save the document again, and print a final letter-quality (“Best”)
version to present to your instructor.

SKILL CONSOLIDATION

Complete as many exercises as you can so as to reinforce what you have
learned in Lesson 2.

1. Load the document Term Paper onto the Desktop.


	Use the Find and Replace function to locate the words “electronic
bulletin board”

	Use the Find and Replace function to replace every occurrence of
“conferences” with “meetings”

	Boldface the title lines at the top of the first page (before
the Abstract)

	Move a complete section of your choice so that it follows the
section it currently precedes.



2. Underline the word “computer” wherever it appears in the document
Term Paper, then adjust the line spacing to 1½ for the entire Term Paper
document.

3. Open up a new word processor document. Call the document “Format
Options.” Type in a list of at least ten words, and select a different
option for each one: normal, italics, boldface, font size of 14, font
size of 20, centered, underlined, and any combination of these you
want. Proof read it, correct any errors, then print out the document.

[^1]: Sans is French for “without.” So Sans Serif refers to fonts
without the extra little flourishes that embellish the characters.

[^2]: Recall that if you click on the right mouse button while pointing
at an object, Writer will bring up a context menu which will allow
you to access the cut and paste functions.

[^3]: It may not be convenient to run off a copy of the document during
a lab session when other students in your class may be waiting in
line for the printer. Also, if you are using your own printer at
home and it’s an inkjet printer, you may want to save ink on the
draft copy by using the Quick Print option in the Print
Preferences.
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Lesson 3 The LibreOffice Drawing Tools



3   The LIBREOFFICE Drawing Tools



LEARNING OUTCOMES

Lesson 3 will cover the following:


	Drawing, moving, rotating, resizing, and otherwise editing simple
shapes and lines

	AutoShapes

	Selecting one or more objects at once—overlapping, ordering,
aligning, and rotating objects

	Using colors, patterns, and other visual effects

	Grouping and ordering objects

	Using Fontwork



3.1 GETTING STARTED

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (Continuing with
the tutorial, on the next page). If you did not complete Lesson 1,
then you must do this now, before proceeding with the rest of Lesson 3.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to take to prepare these folders now before
proceeding with this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will help
you with this if you are working with a class) and Extract them
onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it and, in the Work Files for LibreOffice folder, select
New Folder (Fig. 3.1)
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Fig. 3.1 Creating a New Folder

The system will create a new folder and then wait for you to give it a
name of your choice (Fig. 3.1 above).


Call the new folder Data Files


Continuing with the tutorial

This tutorial is designed to give you practice working with the drawing
tools that are built into the various LibreOffice applications,
including Writer. Drawings that you create in one LibreOffice
application such as Writer, can be easily copied and pasted into other
LibreOffice applications, such as Impress or Calc.

For this lesson it will be useful to have a separate folder, inside your
Data Files folder, for all the drawing-based documents you’re going to
create.


On your computer, go to your USB drive (Removable Disk) >
Work Files for LibreOffice > Data Files folder, and, in the
dialog box, click on New folder and name the new folder Drawing
Documents


3.2 OVERVIEW OF THE LIBREOFFICE DRAWING TOOLS

In this lesson you will learn about many of the more frequently used,
and indispensable, drawing tools, all of which are accessed in the
View menu > Toolbars option (Fig. 3.2).
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Fig. 3.2 The Toolbars you need for this lesson

Overview of the tools for working with Lines and Shapes

If you are drawing lines and shapes you’ll use the tools in the
Drawing toolbar (Fig. 3.3).
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Fig. 3.3 The set of lines and basic shapes in the Drawing toolbar

Aside from basic lines and shapes, the Drawing toolbar provides symbol
shapes, callout shapes, block arrow shapes, flowchart shapes, and
star shapes.

In order to work with those lines and shapes—change the line or border
color or the area style or filling of a shape, rotate the shape, and so
on—you’ll use the tools in the Drawing Object Properties toolbar (Fig.
3.4).
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Fig. 3.4 Working with existing lines and shapes

Grouping and Aligning objects on the page

When using the drawing tools to create shapes and other objects, you may
well want to align some or all of them and perhaps group them together
so that they become one object. To do this you would use the Select
tool in the Drawing toolbar to select or “gather” the objects you want
to group together. Having done that, you would then select from the
several alignment tools available in the Align Objects toolbar to
align them according to your design (Fig. 3.5).
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Fig. 3.5 Aligning selected groups of objects on the page

If you wanted to convert several objects into a single object, you would
use the Group/Ungroup tools to “combine” them as one. This is very
useful when you have a complex set of objects (perhaps an architectural
drawing, for example) that you need to move around en bloc on the
page, or transfer to another page or another document, and so forth.

Working with your own Pictures

If, on the other hand, you are working with a picture that you already
have stored on your disk—such as a photograph or a diagram or a
chart—you’ll use the Picture toolbar (Fig. 3.6).
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Fig. 3.6 The set of tools for working with photographs and other
prepared images

The Picture tools enable you to create watermarks, for example,
convert a picture to grayscale, make adjustments to color density,
brightness, and contrast, adjust the transparency of a picture,
and rotate and flip it in various ways.

Bullets and Numbering

In Writer you will sometimes have lists of items in your document. If
you want to use bullets or have a numbered list, or if you needed to
create different levels, or change the level of a list item; or if you
needed to adjust the numbering of the list, you would use the Bullets
and Numbering toolbar (Fig. 3.7).
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Fig. 3.7 The Bullets and Numbering toolbar

Fontwork

LibreOffice lets you create eye-catching text-based graphics, which
can come in handy when you want to create signs, posters, and displays
of various kinds. You’ll find this toolbar, called Fontwork, in the
View > Toolbars menu, too (Fig. 3.8).
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Fig. 3.8 Fontwork toolbar with a Fontwork example

3D-Settings

Any shape you draw can be rendered as a 3-dimensional (3D) object, a
process called extrusion. Fig. 3.9 shows the 3D-Settings toolbar, also
accessed from the View > Toolbars menu.
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Fig. 3.9 The 3D-Settings toolbar with example of an extruded puzzle
shape

Changing the Page Orientation

In Writer there are two possible orientations for a page—Portrait
and Landscape (Fig. 3.10).
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Fig. 3.10 Portrait or Landscape page orientation

You want Landscape orientation for most of the exercises that follow.
The default in LibreOffice is Page Orientation, but here is how you
select one or the other.


From the Format menu select Page…, in the Page dialog box
click on the Page tab, then in the Paper format section click
on the radio button to select Landscape (Fig. 3.11)
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Fig. 3.11 Selecting Portrait or Landscape Page Orientation

Landscape orientation turns the page on its side. This mirrors the
orientation of the computer screen and often makes it easier for you
when you are working with drawing objects, though there will be many
occasions when you will want to work in Portrait orientation, too.

Using the Zoom tool

The Zoom tool lets you zoom in on a page (so you can check out the
details) or zoom out (so you can see the big picture of a page or the
document as a whole).

While using the LibreOffice drawing tools, you will often want to zoom
in on an object you are working on, and it is also useful at times to
zoom out so you can check out the big picture. For this reason it is
good to know where to find the Zoom tools (Fig. 3.12 on the next page).

As you can see in Fig. 3.12, you can Zoom in and out using the various
selections in the View menu > Zoom… options. Alternatively, you can
Zoom in and out very discretely using the slider in the Status bar at
the bottom right of the Writer page (check the second illustration
in Fig. 3.12).


Try out each of these Zoom options now to see how they work

When you’re done, make sure you leave the Zoom setting at 100%




In the sections that follow, you will practice zooming in and out of the
pages you are working on, and you also will use most of the tools in the
various drawing toolbars.

Time to get to work.
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Fig. 3.12 The Zoom tools

3.3 drawing, moving, ROTATING, resizing, and otherwise editing basic
shapes and lines

Let’s start by learning how to use the basic drawing tools to work with
simple shapes and lines.


In the View menu > Toolbars menu click on the
Drawing option to bring the Drawing toolbar onto the Writer
screen (Fig. 3.13)


Fig. 3.13 Drawing toolbar (annotated)

Look at the bottom of your Writer screen, which is where the Drawing
toolbar is located.


Slide your mouse pointer along the toolbar and read the descriptions
about each of the drawing tools (Fig. 3.13 above summarizes the
sections of tools)


As you can see, there are dozens of shapes to choose from, including
the simplest shapes such as lines, rectangles, ellipses, and freeform
lines, which you will practice using in this section of the tutorial.


In the Drawing toolbar, click on the Rectangle shape (Fig.
3.13 above)


Immediately, LibreOffice Writer brings up the Drawing Object
Properties toolbar, which offers a range of options (Object
Properties) for the rectangle you want to draw even before you’ve drawn
it (Fig. 3.14)!
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Fig. 3.14 The Drawing Object Properties toolbar

Because the Drawing tool bar and Drawing Object Properties toolbar pop
up at the bottom of the Writer window, it will be easiest to complete
the exercises that follow if you zoom out on the page. This will allow
you to view the whole page on the screen without the toolbars getting in
the way.


Use the zoom slider in the lower right corner of the
LibreOffice window (Fig. 3.15 and see Fig.12 on the previous page)
to zoom out to at least 84% (the first hash mark to the left
of center in the slider)
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Fig. 3.15 The LibreOffice Zoom tool set at 84%

There, now you can see what you’re doing. You could, if you wanted to,
move the toolbars (by grabbing them with the mouse pointer and dragging)
to the top of the window, amongst the other toolbars, or even to either
side of the page, but it is convenient to leave them where they are for
now.


Go ahead and draw a rectangle of any size or shape on the page


Notice that the rectangle has a set of handles around it, which allow
you to change the shape of the rectangle on the fly by grabbing any
handle and dragging on it (Fig. 3.16).

Fig. 3.16 The set of handles around shapes and other images

You’re working with a rectangle, so you won’t need the simple line or
arrow tools at the left of the toolbar. But you may want to have a
different size (thickness), color, or style of border on the
rectangle.


With the rectangle selected (it has the handles around it), in the
Drawing Object Properties toolbar, take a look at the various
tools for working with drawing objects (Fig. 3.17)


[image: ]

Fig. 3.17 The Drawing Object Properties toolbar (annotated)

Let’s quickly check out each of these tools. Refer to the illustration
above (Fig. 3.17) as you read the sections that follow.

Line Style

A line can be continuous, or it can be dashed or dotted in different
ways. The same applies to the border around a rectangle or any other
shape.


With the rectangle selected (it has the handles around it),
try out each of these Line Styles before proceeding with the
tutorial


Line Width

A line can be thick or thin—or even invisible! The same applies to the
border around a rectangle or any other shape.


With the rectangle selected (it has the handles around it),
try out some border thicknesses as well as the 0 (zero)
thickness option before proceeding with the tutorial


Line Color

A line or border can be any color. The same applies to the border around
a rectangle or any other shape.


With the rectangle selected (it has the handles around it),
try out some of the border Color options before proceeding
with the tutorial


Area

The Area tool gives you access to all the various options when it comes
to filling a shape with color, or creating a shadow on the shape, and so
forth.


With the rectangle selected (it has the handles around it),
take a look at each of these Area options, and try some of them
for yourself before proceeding with the tutorial


Area Style / Filling

As you probably noticed when you checked out the Area tool above, the
area of a shape (inside area, not including the border) can be filled
with a range of colors, but it can also be filled with several Styles
of fill, such as Gradients, Hatching, and Bitmap (Fig. 3.18).
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Fig. 3.18 Gradients, Hatching, and Bitmap options for Area Style /
Filling


With the rectangle selected (it has the handles around it),
try out each of these Area Style / Filling options before
proceeding with the tutorial—have fun with it!


Drawing lines

Let’s start with drawing lines.


In the Drawing toolbar (at the bottom of the Writer window)
click on the line tool to select it, then use the mouse to
draw a straight line anywhere on the page


It doesn’t get any simpler than that.

Working with lines

Complete the following tasks to learn how to work with different styles
of lines.


Click anywhere off the line you just drew and notice that the
handles (little squares) at each end of the line disappear;
the LibreOffice Drawing toolbar also disappears because it is only
useful as long as a drawing object is selected


So… You can only edit or move a drawing object of any kind if the
handles are showing. The handles indicate that the object is selected.
Clicking ON the object selects it; clicking OFF the object deselects it.


[image: ]Position the mouse pointer anywhere on the
line and notice how the cursor changes to a crosshair ( ), which
tells you that the mouse is correctly positioned on the line so that
when you click the mouse it will select the line

Click anywhere on the line now, and notice that the handles
(little squares) reappear at each end, and both the Drawing
toolbar and the Drawing Object Properties toolbar reappear,
waiting for you to decide what you want to do with the selected
Drawing object (the selected line)




Now, with the handles showing, you can edit the line you just drew.


Work your way across the Drawing Object Properties toolbar; try
out the Line Styles, the Line Widths, and the Line Color


These are all the options you have when it comes to a simple line. Take
your time; have fun with it and make yourself familiar with the various
options available.


When you are done checking out all the different design options for
the line, hit the Backspace key or the Del key to delete the
line from the page


Working with rectangles and ellipses

Creating and editing lines is simple enough. How about shapes such as
rectangles and ellipses—or squares and circles?


In the Drawing toolbar click on the ellipse (oval) tool, and
use the mouse to draw the ellipse (oval) object on the page


Notice the small handles that surround the shape, which you use to
change the object’s shape.


Grab any of the handles and stretch them this way and that to
change the shape; notice that the corner handles allow you to
stretch the shape diagonally as well as up, down, left, or
right—whereas the handles at the middle of each side only allow
you to stretch the shape up, down, left, or right


Rotating Objects

To rotate an object that you have drawn on the screen, you need to use
the Rotate tool in the Drawing Object Properties toolbar (Fig.
3.19).
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Fig. 3.19 Rotating a shape

Let’s try this now.


First, click on the Oval object to select it, then, in the Drawing
Object Properties toolbar, use the mouse to click on the Rotate
tool (see Fig. 3.19 previous page)


This changes the appearance of the ellipse shape into an object that can
be rotated on a central axis (Fig. 3. 20).
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Fig. 3.20 A drawing object that can be rotated

Notice that the handles have changed from a blue color to a red
color and that in the center of the ellipse there is a focal point
around which the ellipse object can rotate (Fig. 3.20 above).


Position the mouse pointer on any of the corner red handles
(Fig. 3.20 above) and drag in a clockwise or counter-clockwise
circular motion to rotate the object

Now position the mouse pointer on any of the side red
handles and drag in a clockwise or counter-clockwise circular
motion to again rotate the object




Notice that the side handles allow rotation of the shape from side to
side or up and down; whereas the corner handles allow full rotation of
the object on the screen. Take a couple of minutes to check out these
Rotation tools in the Drawing Object Properties toolbar.


While you have the shape selected, in the Drawing Object Properties
toolbar, some of the Line Styles, Widths, and Colors

Also try out some of the Area Style / Filling options,
including Gradients, Hatching, and Bitmaps

When you are done checking out these Drawing Object Properties
tools, hit the Backspace key or the Del key to delete the
shape from the page




As you see, there are dozens—well, actually thousands at least—of
different options that you can apply to any shape that you draw on the
screen.

Drawing a perfect square or circle

Drawing rectangles and ellipses is easy. What about drawing a square or
a circle? If you want to draw a “perfect” square or a “perfect” circle,
you just hold down the Shift key at the same time as you draw with the
rectangle tool or the ellipse tool. Try this now.


In the Drawing toolbar select either the Rectangle or Oval
tool, hold down the Shift key, and draw the shape in any size


Notice that the shape will always be a perfect square or circle as long
as you hold down the Shift key. After you’ve drawn the square, if you
let go of the Shift key you can then go ahead and use the handles to
make the rectangle no longer square or to change the circle to an
ellipse.


Try this now—let go of the Shift key and change the shape of your
circle or rectangle


So the shape will always be a perfect circle or square as long as you
hold down the Shift key. Remember this neat trick. It’ll work with other
software, too.

Moving drawing objects

Creating lines and other shapes is simple enough. But once you have an
object drawn, how about editing it and moving it around on the page? To
do either of these things, the line or rectangle or ellipse or other
drawing object must first be selected (which means clicking on it so
that you can see the handles around it). First let’s practice moving an
object around on the page without changing its shape.


Click on the object you have on the screen to select it (you see
the handles around the shape), slide the mouse pointer over the object
and notice that the pointer changes to a crosshair any time the
pointer is anywhere within the perimeter of the object or on
the object if it’s a simple line—the crosshair tells you that you can
move or edit the object

Now, hold down the left mouse button and drag to move the
object anywhere you like on the page




Resizing drawing objects

How about resizing drawing objects—changing their size and shape? To do
this, once again the line or rectangle or other drawing object must
first be selected so you can see the handles.


Make sure the object from the previous exercise is still
selected—you should be able to see the handles around it


If you want to change the size of the object without losing the
object’s shape, you must use a combination of the Shift key and one of
the four corner handles (not the 4 handles in the middle of each
side). Try this first.


Hold down the Shift key, then position the mouse pointer on one of
the small handles in any corner of the shape (not one of the
4 handles in the middle of each side or the rotate handle), hold down
the left mouse button and drag in or out to stretch or squeeze
the object you have on the screen


Notice that the object keeps its basic shape; when you hold down the
Shift key only the size changes. If you’re not concerned about
distorting the object’s shape you can drag on any of the handles without
holding down the Shift key. Try this now.


Position the mouse pointer on any of the white handles, hold down the
left mouse button and drag to stretch or squeeze the ellipse
anyway you want


The same thing applies to irregular shapes such as polygons in general
or freeform drawings like squiggly lines (yes, there’s a squiggly line
tool, too! It’s called the Freeform Line tool). When you click on the
shape, it shows the handles around it. By holding down the Shift key and
grabbing one of the handles in the corners, you can make the shape
smaller or larger without otherwise distorting it. By grabbing any of
the handles around the shape without simultaneously pressing the Shift
key, you can distort the shape by making it thinner or fatter, taller or
shorter—whatever.

Try this now.


Make sure the object you have on the screen is selected—you
should be able to see the handles around it—then hit the Backspace
key or the Del(ete) key to delete it

In the Drawing toolbar select the Freeform Line tool (Fig.
3.21), then write (scribble) your name anywhere on the page
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Fig. 3.21 The Freeform Line tool


With your name (the object on the page) highlighted, hold the
Shift key down, then position the mouse pointer on any of the
corner handles, hold down the left mouse button and drag
to stretch or squeeze the object anyway you want—it will keep its
basic shape; only the size of your name will change

Now try it again, but this time without holding the Shift key, and
notice the difference—use all the handles and notice the
difference there, too, between using the corner handles or the
handles at the middle of each side

When you are done playing around with your signature, hit the
Backspace key to delete it from the page




Editing (changing) straight lines or arrows

[image: ][image: ]First of all, an arrow
is a type of line, except that it has an arrow head on one end or on
both ends. You can draw an arrow by clicking on the Arrow Style tool in
the Drawing Object Properties toolbar (Fig. 3.22).

Fig. 3.22 The Line tool and the Arrow Style tool in the Drawing Objects
toolbar


Click on the Arrow Style tool, select any style, then draw an
arrow on the page


If you want an arrowhead on both ends of the line, you need to bring up
the Line dialog box. There are two ways to do this.


Either click, at the left end of the Drawing Object Properties
toolbar, on the small yellow Line tool (see Fig. 3.20 on the
previous page)

Or you can position the mouse pointer anywhere along the arrow
line (you’ll see the pointer change to a crosshair), hold down
the right mouse button and, in the context menu that pops up,
select the first item: Line… to bring up the Line dialog box
(Fig. 3.23)
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Fig. 3.23 Changing the Arrow Style in the Line dialog box


Now, towards the top right of the dialog box, click on the down
arrow to drop down the menu of Arrow End Styles (see Fig. 3.23
above) and select the same arrowhead as you selected for the arrow
you just drew on the page


Notice that the Line dialog box also lets you put a shadow on the line
or arrow object you’ve drawn, or you can change the color, size, and
shape.

Editing a straight line or a straight line arrow works a little
differently than solid shapes such as ellipses, polygons, and so forth,
since you only have two handles to worry about—one at either end of the
line or arrow. You use either of the handles to lengthen or shorten the
line. You also can drag on either handle to rotate it from either end.
Let’s try this now.


Grab hold of the handle at either end of the line or arrow, and
drag the handle in or out, up or down, from side to side, so you
can get a feel for how to change its length and orientation

Clear the Page of any drawing objects when you are done




3.4 OTHER DRAWING shapes

There is a wide selection of predefined shapes that you can use to
create your drawings. These shapes are accessed from the Drawing toolbar
(Fig. 3.24).
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Fig. 3.24 Drawing toolbar (annotated)

Specifically, there are Basic Shapes like rectangles, ellipses,
triangles, cylinders, and so forth, most of which would take you quite a
while to create from scratch by hand—unless you’re a talented artist, of
course.

Then there are shapes designed to help you draw Block Arrows, and shapes
to help you create Flowcharts—very useful for planning diagrams. If you
want to add “speech” to characters in a diagram, there is a nice
selection of Callouts you can use. Finally, when you want to create
certificates and such, you can use the Stars and Banners shapes.

For the next exercise, when you have finished the exercise, you are
going to Save the file in your Drawing Documents folder (in the Data
Files folder) so that you can later send it to your instructor as an
attachment in email. So let’s save the blank document you have open on
your screen now before we proceed.


In the File menu select Save As…, navigate to your USB
(Removable) disk > Work Files for LibreOffice > Data
Files folder > Drawing Documents, name the file Practice
Drawing 1, and hit Save

Now, in the Drawing toolbar at the bottom of your Writer page,
spend a few minutes checking out the many sets of shapes available to
you

When you are ready, complete the following exercises—draw each of the
shapes small enough so you can fit them all on the page without
overlapping and don’t delete any of them because you’re going
to send the file to your instructor when you have completed Lesson 3




When you are done with this particular exercise, your page will look
something like (though obviously not exactly the same as) Fig. 3.25.
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Fig. 3.25


Draw at least three Basic Shapes (line, rectangle, ellipse,
freeform shape, triangle, hexagon, cube, etc., etc.)

Draw at least three Block Arrows

Draw at least three Flowcharting Shapes

Draw at least three Callouts

Draw at least three Stars or Banners

Now use the tools in the Drawing Object Properties toolbar to add
Line Styles and Line Colors to lines and the borders of the
various shapes

Fill the Areas of shapes with a mix of colors,
gradients, and bitmaps

Save the file (Practice Drawing 1), then Close the
document (later in the lesson you’ll be sending it as an attachment
in email to your instructor)




Now you are ready for the next exercise.

3.5 using colors, patterns, and other visual effects

Transparencies

As you have already learned, the Writer drawing tools give you lots of
control over colors, patterns, gradients and other visual effects, such
as shadows and 3-D. Let’s take a closer look at some of these tools,
starting with transparencies.


You need a new document for this next drawing exercise, so in the
File menu select Save As…, navigate to your USB
(Removable) disk > Work Files for LibreOffice > Data
Files folder > Drawing Documents, name the file Practice
Drawing 2, and hit Save

Start by drawing a rectangle on the blank page and give it an
Area Fill color of your choice, then draw an ellipse that
overlaps the rectangle and which has a different Area Fill
color than the rectangle—something like Fig. 3.26
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Fig. 3.26 One shape overlapping another

The ellipse, being opaque (a solid color), hides part of the rectangle.
But you can adjust the Transparency of the Area Fill Color of a
drawing object such as the ellipse in this case, thus allowing a drawing
object that is hidden behind it to show through. Let’s try this.


With the ellipse selected, in the Drawing Object Properties
toolbar click on the Area tool to bring up the Area dialog
box (Fig. 3.27)
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Fig. 3.27 Settings for a semi-transparent shape


Now, in the Area dialog box click on the Transparency tab,
then click, in the Transparency mode section, on the radio
button next to Transparency (Fig. 3.24 on the previous page) so
that you will have a 50% transparency for the selected object (the
ellipse), then click on OK


The ellipse shape now looks like a piece of glass or transparent plastic
or sheer material, partially revealing the object that is behind it Fig.
3.28.
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Fig 3.28 The transparent ellipse

Neat, huh? Notice that you can also add gradients to the transparent
shape. Try this now.


With the ellipse still selected, in the Drawing Object Properties
toolbar click on the Area tool to bring up the Area dialog
box, click on the radio button next to Gradient and then
select the Type of gradient you want from the drop down list


Area Fill Effects

Other than plain colors, there are different gradients you can use to
fill shapes with smoothly graded shades of color; there also is a small
selection of hatching fills; and you can fill shapes with bitmaps
that come with LibreOffice. Now let’s check out a couple of other
useful Area Fill tools along these lines.

Filling Shapes with Imported Pictures

Bitmaps are essentially digital images, and can include any picture you
want—pictures that you may have taken yourself, for example, or which
you might find amongst collections of pictures and other art work that
are freely available on the web.


Click on the ellipse shape to select it, and hit the
Backspace/Del(ete) key to remove it from the page, then click on
the rectangle shape to select it

In the Drawing Object Properties toolbar click on the Area
button to bring up the Area dialog box

Click on the Import button




The Import button brings up the Import dialog box, which is
essentially the Open button for the operating system you’re using on
your computer—Windows, Mac OS or otherwise.


In the Import dialog box, navigate to your USB (Removable)
disk > Work Files for LibreOffice > Miscellaneous Files
folder > Practice folder, then double click on the file named
Bouquet


Immediately the Bouquet picture is uploaded to the rectangle shape on
the Writer page (Fig. 3.29).
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Fig. 3.29 Filling a shape with a picture imported from your disk


Depending on the shape of your rectangle, the image may be
distorted, so use the handles to stretch the rectangle one way
or another till it looks OK

In the Drawing Object Properties toolbar click on the Area
Tool to bring up the Area dialog box (Fig. 3.30), and in the
Fill section scroll to the bottom of the list of bitmaps
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Fig. 3.30 Adding a picture to the set of bitmaps in the Area dialog box

Notice that the Bouquet picture has now been added to the set of bitmaps
(Fig. 3.30 above), which means you no longer need to Import it again
from your disk. You’ll be able to easily use it again whether in
Writer, Draw, or any of the other LibreOffice applications.


You do not want to Tile the picture inside the rectangle and you
do want it to Fit, so in the Area dialog box, remove the
check mark next to Tile and put a check mark in the
Autofit box


Rounding corners and applying a Shadow effect on images

LibreOffice provides drawing tools to round off the corners of images
and apply shadow effects. Both are easy enough to use, once you know
how. Let’s round the corners of the picture first.


Right click on the Bouquet picture to bring up its
context menu (Fig. 3.31)
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Fig. 3.31 The picture object’s context menu

Click on the Position and Size… menu item (Fig. 3.31 above) to
bring up the Position and size dialog box

Now click on the Slant and Corner Radius tab and increase the
Corner radius setting to 0.20” and click on OK (Fig. 3.32)
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Fig. 3.32 The Position and size dialog box

Next you need to create a shadow effect on the image.


Right click again on the Bouquet picture to bring up its
context menu (Fig. 3.31 on the previous page) and this time click
on the Area… menu item, then in the Area dialog box click on
the Shadow tab (Fig. 3.33) and, in the Properties section
click to put a check mark next to Use Shadow and, in the drop
down menu of Colors, select Light Grey
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Fig. 3.33 The Shadow tab in the Area dialog box

The final version of the Bouquet image should look like Fig. 3.34.
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Fig. 3.34 Final version of the Bouquet picture


Save the file (still Practice Drawing 2) before proceeding
with the tutorial—(later in the lesson you’ll be sending it to your
instructor), and delete the Bouquet picture object from the
page


3D Effects

All that remains in this section is to try out the various 3-D Effect
tools. These are located in the 3D-Settings toolbar which is accessed
from the View > Toolbars menu.


You need a new name for this next drawing exercise, so in the File
menu select Save As…, navigate to your USB (Removable)
disk > Work Files for LibreOffice > Data Files folder


Drawing Documents, name the file Practice Drawing 3, and
hit Save


In the Drawing toolbar > Symbol Shapes draw a Puzzle
symbol about 3” square on the page

Select any border color for the Puzzle shape and any
gradient for the fill, then in the View menu >
Toolbars menu select 3D-Settings to bring up the 3D-Settings
toolbar (Fig. 3.35 on the next page)

In the 3D-Settings toolbar, click on the Extrusion On/Off tool
to turn on Extrusion
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Fig. 3.35 Draw a Puzzle shape on the page

Extrusion is just another word for the process of making a shaped
object, such as a rod or a tube—or a puzzle shape—by forcing a material
into a mold. On the computer, all this molding and modeling work is
digital and is done using mathematics.

Notice the 3d-Settings toolbar now comes to life with the various 3D
(digital extrusion) tools now available for you to use on the selected
object—the Puzzle shape—which has also been transformed into a basic 3D
image (Fig. 3.36).
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Fig. 3.36 The 3D-Settings toolbar (annotated)

Notice, too, the tools for tilting the image in various directions;
tools for adjusting the depth or direction of the 3D modeling; and the
tools for controlling the light source on the image, the surface
texture, and color.


Your turn; with the Puzzle shape selected, take a few minutes now
to try out each of the various 3D-settings tools to see how
they work and to see what effect they have on the object


Very simple, very effective, very impressive. Actually, if you were
aware of the math that is necessary to create these 3-D effects, you’d
be very impressed indeed!


Save the file (still Practice Drawing 3) before proceeding
with the tutorial, then delete the 3D Puzzle object


The more artistic you are, the more skillfully you will be able to apply
these effects. But even if you don’t think you are artistic, you’ll be
surprised what you can come up with.

3.6 GROUPING, ordering, and aligning objects

You’ve probably noticed that when you put one shape, or drawing object,
on top of another, it stays there, overlapping the other shape, as with
the ellipse and rectangle shapes in the previous exercises.

With the Drawing Tools, every object you create is always a separate
entity from the other objects on the page, even if they overlap.
However, you can group objects together if you want, as we’ll see in a
moment. When you group them, they effectively become one object for as
long as they are grouped. But you also can ungroup them whenever you
please. This is because all the drawing objects are like pieces of a
jigsaw puzzle or a deck of cards. You can group the jigsaw pieces by
fitting them together, or you can group the cards in a deck by gathering
them into a pack of cards–or you can ungroup them by scattering them to
the winds. Let’s see how this works in LibreOffice.


You need a new name for this next drawing exercise, so in the File
menu select Save As…, navigate to your USB (Removable)
disk > Work Files for LibreOffice > Data Files folder


Drawing Documents, name the file Practice Drawing 4, and
hit Save





You are going to draw seven different shapes, one on top of the other,
each with a different border color and fill color or gradient. You’ll
end up with something like Fig. 3.37.
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Fig 3.37 Shapes layered on top of one another


In the Drawing toolbar click on the ellipse tool, draw an
ellipse (no more than about 2” in diameter) on the page and
fill it with a basic color of your choice

Next, in the Drawing toolbar click on the rectangle tool, draw
a rectangle (no more than about 2” square) on the page so that it
overlaps the ellipse and fill it with a basic color of your
choice

Now, in the Drawing toolbar click on the hexagon tool, draw a
hexagon (no more than about 1” on any side) on the page so that it
overlaps the ellipse and/or the rectangle, but doesn’t actually
hide either the ellipse or the rectangle—make sure you can
still see at least a piece of all three shapes and fill the
hexagon with a basic color of your choice

Now use the Line Width tool to increase the thickness (weight)
of the hexagon’s border to at least 0.06”, and use the Line
Color tool to select a different color for the border

Repeat the same steps to draw and fill (using colors or gradients)
both the Border and the Fill area of a parallelogram[^1],
trapezoid, diamond, and triangle (again making sure none
of the objects actually hides any of the others completely—you should
be able to see a piece of all seven (7) shapes when you’re done, as
illustrated in Fig. 3.37 on the previous page)




So now you should have on your page (screen) seven different shapes with
seven different fill colors and various other effects. The reason you
need to be able to see at least a piece of each shape is to make it
easier for you to do the next exercise.


Save the contents of the page (Practice Drawing 4)


**Grouping drawing objects **


You need a new name for this next drawing exercise, so in the File
menu select Save As…, navigate to your USB (Removable)
disk > Work Files for LibreOffice > Data Files folder


Drawing Documents, name the file Practice Drawing 5, and
hit Save





Right now, all the objects are separate—ungrouped. Let’s group them into
three groups.


First, click anywhere off all the shapes so that none of them
is selected

Now use the mouse, and hold the Shift key down, and click on the
ellipse shape and the rectangle shape

Now, right click on the selected shapes (the ellipse and the
rectangle should both have handles around them) and, in the context
menu that pops up, select the Group > Group option (Fig.
3.38)




[image: ]

Fig. 3.38 Grouping objects together

Check your drawings now and notice that the ellipse and rectangle shapes
have just one common set of handles. Now you can treat them as one
object and move them around on the screen as one object, independently
of the other objects.


Grab the rectangle shape with the mouse and slide it over to the
right edge of the page—notice that the ellipse goes right along
with it because they are now grouped together


Complete the following steps to create groups of the other objects.


Again, click anywhere off all the shapes so that none of them
is selected

Using the mouse, and holding the Shift key down, click on the
trapezoid shape and the Triangle shape, right click on the
selected shapes and, in the context menu select the Group >
Group option

Next, slide the trapezoid and triangle shapes up towards the top
center of the page and click anywhere off all the shapes so
that none of them is selected

Using the mouse, and holding the Shift key down, click on the
remaining 3 independent shapes: the hexagon shape, the
parallelogram shape, and the diamond shape, right click on
the selected shapes and, in the context menu select the Group >
Group option

Slide this final group of shapes down towards the left center of
the page




Your page should look something like Fig. 3.39 when you’re done.

[image: ]

Fig. 3.39 Three separate groups of shapes


Check your drawings, click on each group in turn, and slide them
around on the page


Notice that each group now has just one set of handles and that they
move as a group. You can even rotate them as a group.


Try this now by clicking on any of the three groups, click in the
Drawing Object Properties toolbar on the Rotate tool, and
rotate the grouped shapes any way you want


This is often very useful when you create a complicated drawing using
several objects, like lines and shapes, and you want to move them around
a few items at a time, or all together or rotate them as one object or
as several specific objects, and so on. Just group them all together,
and Bob’s your uncle! You’ll have another chance to practice this when
you do the Skill Consolidation exercises at the end of the lesson.

Resizing objects

This is easy.


Click on any of the shapes to select a group and grab hold of one
of the corner handles and drag in to make the group smaller

Do the same thing to reduce the size of the other two groups, then
drag the ellipse and rectangle group to the top right corner of
the page, the trapezoid and triangle to the lower center, and the
hexagon, diamond and parallelogram to the top left corner




Your drawing should now look something like Fig. 3.40.
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Fig. 3.40 Resized grouped sets of objects


Save the contents of the page (Practice Drawing 5)


Ungrouping objects

This is easy, too.


You need a new name for this next drawing exercise, so in the File
menu select Save As…, navigate to your USB (Removable)
disk > Work Files for LibreOffice > Data Files folder


Drawing Documents, name the file Practice Drawing 6, and
hit Save


First, click anywhere off all the shapes so that none of them
is selected

Click on the ellipse-rectangle shape, right click on it and, from
the context menu, select Grouping > Ungroup




Look at the ellipse and rectangle shapes now and notice that all the
handles for each shape have reappeared.


Now click anywhere off the ellipse-rectangle shapes so that
neither of them is selected, then click on just the ellipse shape
and notice that it is now independent of the rectangle shape

Move the ellipse shape away from the rectangle shape so there
is no longer any overlap

Repeat this to ungroup all the other objects—be sure to
ungroup them all for the sake of the following exercises, then move
each of the shapes away from each other so there is no longer any
overlap anywhere—you should now have 7 separate shapes spread out on
the page




Ordering the drawing objects

The order of the shapes right now should still be the same as the order
in which you created them. So the rectangle is in the back, the ellipse
on top of the rectangle, and so forth. Think of the objects as layered
one of top of the other—even if they aren’t actually touching. But
because you’ve moved them all around, they may no longer all be touching
each other. So let’s slide them all back on top of each other in the
middle of the page so you can see how the ordering function works.


Rearrange all the shapes so they are overlapping each other again
in the center of the page (something like in Fig. 3.41)
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Fig. 3.41 Drawing objects layered on top of each other




Notice how they are all still layered in the order that you originally
created them, so the first shape you created (the ellipse) is still on
the bottom and the last shape you created (in Fig. 3.38 it’s the
triangle) is still on top.

You can move (re-order) objects backward or forward in the layers. Time
to try this out; then you’ll see how it works.


Click to select the top shape first (the triangle), right
click on it, then from the context menu select Arrange >
Send Backward


This drops the top shape back behind the next shape down in the pile of
shapes (or deck, if you think of the shapes as a deck of cards). The
trapezoid should now be on top.


Select the new top shape again, right click on it, then from
the context menu select Arrange > Send to Back


Now the top shape (the trapezoid) is moved all the way to the bottom of
the deck. You can bring objects forward or send them back, either one
layer at a time, or all the way forward or all the way back in one go.


Try this now with several of the objects, using each one of the
Order options till you get the hang of it, then Save the file
(Practice Drawing 6) when you’re ready to move on


Aligning Drawing objects

No doubt your page now looks like a work of abstract art! One last task
remains in this section of the tutorial. You need to take a moment to
check out the LibreOffice Align tools, which make it easy for you to
Align an object or a set of objects (shapes) in the space that
contains them. To practice this you can use the set of 7 shapes you were
working with in the previous exercise.


At the left hand end of the Drawing toolbar, click on the
Select tool, then use the mouse pointer to drag from outside
the top left of the 7 shapes down across all the shapes to the
bottom right


You should now see a single set of handles around the 7 shapes as a
whole.


Using the mouse pointer again, grab any of the handles and
drag to make the set of shapes as big as you can to fill the
page


When you’re done “stretching” the shapes, your page might look something
like Fig. 3.42.
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Fig. 3.42 The 7 shapes stretched to fill the page


In the View menu > Toolbars menu, click to select the
Align Objects toolbar (Fig. 3.43)
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Fig. 3.43 The Align Objects toolbar


Now, with all the shapes still selected, click on each of the
tools in the Align Objects toolbar and watch as the shapes are
all aligned, in relation to the set of shapes as a whole, to the
left, horizontally centered, to the right, to the top,
vertically centered, and to the bottom

Save the file (Practice Drawing 6) when you’re ready to move
on, then clear all the shapes off the page




3.7 Using the Textbox tool and Fontwork

Using the Textbox tool

It will be easiest to start over with a new Writer document for this
part of the tutorial.


In the File menu select Close to close Practice Drawing 6,
then in the File menu select Save As…, navigate to your
USB (Removable) disk > Work Files for LibreOffice >
Data Files folder > Drawing Documents, name the file
Practice Drawing 7, and hit Save

In the Drawing toolbar click on the Text tool, then drag with
the mouse pointer to create a textbox on the page (Fig. 3.44)
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Fig. 3.44 The Textbox tool in the Drawing toolbar


Type (or copy and paste) into the text box the following text:

The beauty of these drawing tools is that they give you lots of
control over your art work and make it relatively easy for you to
create very sophisticated designs—once you know how to use them, that
is, and that’s what this lesson is all about. You won’t be an expert
by the time you’re done with this lesson, but you will probably have a
much better idea what you’re doing. It’s up to you to use the tools A
LOT till you become an expert. Only then will you be able to make them
really sing for you!

Play with the handles, stretch the Text box up and down
and from side to side and notice that you can make the Text Box any
shape you want to fit the contents you have put inside it

Now, with the tip of the mouse pointer anywhere on the outside
border (but NOT on one of the handles) hold down the left mouse
button and drag the text box to the right or left or up or
down—you decide where its final position will be on the page

Save your work (Practice Drawing 7)




Everyone needs to know how to do handle layout skills such as this,
where you have a piece of writing in a text box and where you need to
lay it out on a page. You will undoubtedly be putting together handouts,
or maybe you’ll produce a magazine or, even better, you will supervise
others producing a magazine under your direction.

For example, the text box is a useful tool for explaining the contents
of diagrams, as illustrated in Fig. 3.45.
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Fig. 3.45 Using text boxes to explain components of a handout or
illustration

Using the Fontwork tool

Fontwork is a set of graphic fonts that add a touch of flair or pizazz
to your text. The best way to see what this involves is to try it for
yourself.


Click to put the cursor at the beginning of the text in the Text
Box (before the words The beauty of these drawing tools…), hit
Enter twice to move the text down two lines, then click at the
top left just inside the text box to put the cursor there

In the View menu > Toolbars menu, click on Fontwork to
bring up the Fontwork toolbar, then in the Fontwork toolbar
click on the Fontwork Gallery icon (see Fig. 3.46)
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Fig. 3.46 The Fontwork toolbar

This brings up the Fontwork Gallery from which you can choose whichever
style of font graphics appeals to you.


Take a look at the various Fontwork styles in the Fontwork
Gallery, then select one that you like by double clicking on it
(you can easily change it later if you change your mind)


The Fontwork you selected pops up on the screen.


Double click on the Fontwork image and you’ll see the boldface
word Fontwork in the middle of the fontwork design (Fig. 3.47)
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Fig. 3.47 Fontwork design before processing


Use the backspace key to remove the boldface word Fontwork
from the middle of the design and in its place type your First and
Last name, then click anywhere on the page and your name will
become the text for the Fontwork design

Click on your name and you’ll see handles appear around the
edges of the Fontwork design




Now you can use the Fontwork toolbar to make changes to the Fontwork
design of your name.


Try out some of the tools in the Fontwork toolbar now to see what
effect they have on the design of your name and when you see something
that looks good to you, grab any of the handles and reduce the size of
the Fontwork text till it can fit inside the space you made for it in
the textbox on the page

With the tip of the mouse pointer, click on the edge of the
box, hold down the left mouse button, and drag your name so that
it’s centered in the box over the paragraph of text




Fig. 3.48 shows how your name might look when you are done.
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Fig. 3.48 Fontwork example

Using the Fontwork tools, and with very little effort on your part, you
can create class handouts, banners, certificates, and other visual
materials which can be eye-catching, tasteful, and, above all,
instructive.

There are a couple of other things you need to learn about the Fontwork
tools.


Click again on the Fontwork of your name, then right click
on your name and, from the context menu, select the Area… tool

In the Area dialog box, click to select any Fill color for
your name, try out some shadow effects and gradients




Have fun with it; see what you can come up with. Enjoy!


Save the final version of this exercise (Practice Drawing 7)


SKILL CONSOLIDATION

Complete as many exercises as you can so as to reinforce what you have
learned in Lesson 3.

1. Make a list of at least 10 handouts or other documents that are
relevant to the school environment for the creation of which you would
use the drawing tools.

2. Team up with a group of your classmates and use the Writer drawing
tools to create at least 5 of the documents from the list you drew up in
Exercise 1. Save them on disk.

3. Open a new blank page and in Page Setup select Landscape
orientation. Complete the following tasks:


	Start a new page and draw a perfect square, fill it with color, and
make the line color the same as the fill color.

	Draw a perfect circle, fill it with a different color from the
square, and make the line color the same as the fill color.

	Move the circle on top of the square and adjust the size of the
circle so it fits exactly inside the square where the border of the
circle touches the border of the square at four points, north,
south, east, and west.

	Group the circle and the square, then rotate the grouped object 45
degrees, so that the shape resembles a diamond.

	Use the AutoShape of an Octagon to draw an octagon large enough to
completely cover the diamond, fill it with a different color from
either the square or the circle, and make the line color the same as
the fill color.

	Move the Octagon shape to the back. Select all the objects and
center them on the page. Group the objects.

	Use Word Art to write the following title for the drawing: inside a
Square inside an Octagon. Save the drawing with the name Geometric
Shapes.



4. Open a new blank page and in Page Setup select Landscape
orientation. Draw a picture of a house (yours if you want), including
the following items (with colors and effects of your choosing):


	Draw the house itself with at least two windows and a front door and
a separate roof (you’ll need to use the freeform drawing tool for
the angled roof so that you can fill it with color and a pattern).
The roof must have shingles, the walls must be of brick or siding
(unless you want to draw a log cabin!).

	A front lawn with shrubs and flowers here and there

	At least two trees

	The sky with a couple of clouds scudding by…

	Save the drawing with the name House.



5. Open a new blank page and in Page Setup select Landscape
orientation. Draw a picture of a technology-ready classroom. Use clip
art, if you want, for the objects in the classroom, including the items
in the list that follows (with colors and effects of your choosing).
Arrange the desks and so forth according to your own concept of the
ideal classroom. Save the drawing with the name House.


	Desks for 20 students

	At least 6 computer workstations (position them so the teacher can
easily see the screens)

	A desk for the teacher

	A separate computer workstation for the teacher

	A reading center

	Any other items you would want to include in your ideal classroom.



6. Use the AutoShapes menu to draw at least ten (10) Basic Shapes and
use an associated Callout to name each of them. Fit everything on one
side of an 8 ½” by 11” page. Use either Portrait or Landscape
orientation. Color the shapes, fonts and callouts with Fill Colors, Font
Colors, and Line Colors.

7. Open a new blank page and in Page Setup select Landscape
orientation. Then complete the following tasks:


	In the top left corner of the page, draw a self-portrait as best you
can, using colors and so forth

	Add a callout that looks like it’s coming from your mind (see
figure below)

	Select all the parts of your drawing and group them together as one
object

	Copy the object, then duplicate it 8 times as illustrated in the
figure below

	In the callouts, add the text of any story you like

	Save the strip cartoon with the name Strip Cartoon



[^1]: Slide your mouse pointer over the shapes in the Drawing
toolbar and the system will tell you which is a parallelogram or
trapezoid, etc.
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Lesson 4 Introduction to The Calc Spreadsheet



4   Introduction to the CALC spreadsheet

      Preparing a Home Inventory spreadsheet







LEARNING OUTCOMES

This tutorial will help you understand what a spreadsheet is and where a
spreadsheet might come in useful for classroom management. Specifically
you will learn about the following topics.


• Helpful hints for understanding the basic concepts of a spreadsheet,
including:

• cells, rows and columns

• cell coordinates

• entering data into a spreadsheet cell

• Setting up labels, including:

• setting column widths

• aligning data in cells

• entering column and row labels

• Creating and copying formulas

• Making changes in a spreadsheet

• inserting rows and columns

• deleting rows and columns

• Producing a printed copy of the contents of a spreadsheet document

• Saving a backup copy of your work

• Appreciating the power of spreadsheet templates




4.1 GETTING STARTED

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to Before we begin, on the next
page. If you did not complete Lesson 1, then you must do this now,
before proceeding with the rest of Lesson 4.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to take to prepare these folders now before
proceeding with this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will help
you with this if you are working with a class) and Extract them
onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 4.1).
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Fig. 4.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 4.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

Before we begin

For this lesson it will be good to have a separate folder inside your
Data Files folder for the spreadsheets you’re going to create.


When you are ready, go to Start > My Computer > Your
USB drive > Work Files for LibreOffice folder > Data
Files folder, and create a new folder called Spreadsheet
Documents


Some background about spreadsheets

Fig. 4.1 illustrates a typical spreadsheet for keeping track of an
inventory of items in your home.
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Fig. 4.1 Typical spreadsheet for a Home Inventory

As illustrated in Fig. 4.1, a spreadsheet is a grid divided into rows
that run across the spreadsheet from left to right, and columns that run
from top to bottom of the spreadsheet. As with the Word processor, the
best way to learn about the spreadsheet is to build one and work with
it. So here goes.


Go to Start > All Programs and open Microsoft Office
Calc


You should now see on your screen a new Calc spreadsheet document
titled Untitled 1.


Put your USB drive containing the Work Files for LibreOffice in
the disk drive

From the File menu select Save As and navigate to Work Files
for LibreOffice > Data Files > Spreadsheet Documents

Type Home Inventory Template as the name for the new spreadsheet
and click on the Save button




You should now be looking at a screen with the name of your document
(Home Inventory Template) at the top of a blank worksheet ready for
you to insert your data.

4.2 HELPFUL HINTS WHILE USING THE SPREADSHEET

A spreadsheet is a grid divided into rows and columns

The intersection of a column and row is referred to as a cell (Fig.
4.2).
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Fig. 4.2 Think of the spreadsheet as a grid divided into rows and
columns

Right now, cell A1 is selected in the top left-hand corner of the
spreadsheet (Fig. 4.4).


With cell A1 selected, type the number 2015 in cell A1 and
hit Enter so you have some data in the spreadsheet for what
follows


A cell is where information, in the form of either a label, or a number,
or a formula for calculation, will be entered.


	Labels are where you use text (which may or may not be numbers) to


describe the data in the columns and rows.






	Numbers are just that—numbers, as in mathematics. Numbers are what


spreadsheets are all about.






	Formulas (or Functions) are mathematical expressions built into


certain cells that instruct the spreadsheet to carry out
calculations on specified sets of numbers in the rows and columns.








Moving around in the spreadsheet

There are 1,048,576 rows and 16,384 columns in the Calc spreadsheet!
That means there are well over 17 billion cells in which you can store
data!

Usually you will use the mouse to select the cell you want to work in by
clicking on the cell. Once you have entered data into a particular cell,
you can use the commands in Table 4.1 to proceed to other related cells.



Key Pressed                             Effect
Tab                                     Moves selection to the right, to the next cell in the same row
Shift-Tab                               Moves selection to the left, to the previous cell in the same row
Arrow keys                              Move selection one cell in any direction
Shift-Enter                             Moves selection up to the previous cell in the same column
Enter                                   Moves selection down to the next cell in the same column
Scroll bars                             Scroll vertically and horizontally through the spreadsheet
[image: ]Accept button    Accepts data in a cell but does not move to another cell
Cancel button [image: ]   Cancels data in a cell but does not move to another cell



Table 4.1 Cell selection commands


Try out each option now before proceeding—this will help you follow
later directions

Practise by moving around the spreadsheet—after you have visited
several cells, end up by clicking on cell A1 to make it the
current or active cell.




Identifying the active cell’s coordinates

Look in the top left hand corner of the Calc screen (Fig. 4.2 on the
previous page) to see which cell is the active cell you are in at any
point in time.


Click on any cell now and look at the cell’s coordinates in the
top left corner of the spreadsheet window (see Fig. 4.2 previous
page)


Notice that each cell (a location in the spreadsheet) has an address
which begins with a letter to indicate the column, followed by a
number to indicate the row. For example, G6 identifies the cell at the
intersection of column G, row 6.


Click on cell G6 now and look at the cell’s coordinates in the
top left corner


Selecting a range (group) of cells

Table 4.2 lists the methods for selecting a group or range of cells.



Task                                                                   Method
To select a block of cells                                             Drag from the first cell to the last cell in the block
To select an entire row of cells (horizontally from left to right)     Click on the number (the row label) on the left edge of the spreadsheet
To select an entire column of cells (vertically, from top to bottom)   Click in the letter(s) of the alphabet (the column label) at the top of the column
To select several rows                                                 Drag the row numbers on the left edge of the spreadsheet
To select several columns                                              Drag across the column labels at the top of the columns



Table 4.2 Selecting a group or range group of cells


Once again, try each of these methods for selecting groups of cells


Location of the active (selected) cell after entering data into a
cell

When you type data into a cell, the data appear both in the cell you
have selected AND in the Entry bar at the top of the spreadsheet. See
how this works for yourself now.


Click on cell B1 and type the number 2015, then look at the
Entry bar above the spreadsheet cells (Fig. 4.3)
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Fig. 4.3 The spreadsheet Entry bar

The data are again in both places at once, but they are not yet
permanently accepted into the cell. The number 2015 awaits your
acceptance of it into the spreadsheet. The data are displayed in the
cell to give you the opportunity to:


1. check that they are correct before accepting them into the active
(selected) cell;

2. make up your mind whether they should be entered into the spreadsheet
at all;

3. decide which cell you would like to be the active cell next after the
data have been copied to the currently active cell.




You accept the data by either


	moving to another cell in the spreadsheet (by clicking on the Enter


key or Tab key on the keyboard or by using the mouse to click on
some other cell);








or


	clicking on the Accept ( [image: ]) icon to


the left of the Entry bar.








If you decide not to enter the data into the spreadsheet, you would
click on the Cancel box ([image: ]) in the Entry bar
(Fig. 4.5) and start over. If, on the other hand, the data are correct,
you would click the Accept button ([image: ]),
which also keeps the cell you are working in as the active cell.


Click the Accept button ([image: ]) now


Notice that the number 2015 in cell B1, as with the number 2015 in
cell A1, is right justified, aligned on the right edge of the cell,
which is the correct justification for numbers in mathematics.

Alternatively, you may want to proceed to the cell immediately to the
right of the active cell into which the number you just typed will go.
Or you may want to proceed to the cell just below the active cell, or
the cell just above the active cell, and so on.

A short while back you practised moving around the spreadsheet using the
commands listed below in Table 4.1 on page 106. This table also lists
the key(s) to press to tell Calc which cell to go to after you accept
the data you have typed into the Entry bar. It might be a good idea, if
you’re new to spreadsheets, to take a few minutes to check out that
table again.


Practise now by making the cell in which you just typed 2015 the
active cell (by clicking on it)

Then press each of the keys or key combinations in Table 4.1 (on page


	and verify the result of the action in the spreadsheet each time






Blanking out a cell or cells in the spreadsheet

The quickest way to blank out a selected cell or cells is to hit the
Del(ete) key on the keyboard. Let’s try this now.


Click on the cell holding the data 2015 (cell A1) and hit the
Del(ete) key


Now cell A1 is empty. The Delete key saves you having to use the mouse
and menus.


Undo what you just did by pressing Ctrl-z (to put back
2015 in cell A1)


To delete the data in a group of cells you would drag across the cells
to select them—they will become highlighted. Then you’d select Clear
from the Edit menu or hit the Del(ete) key as before.


Practise this by dragging across Cells A1 and B1 and hitting
the Del(ete) key


Bingo. Remember that you can undo the Delete operation (or any other
Edit operation) by immediately pressing Ctrl-z on the keyboard.

Editing the data in the Entry bar

While you are typing in data in the Entry bar you can edit them as if
you are using Word. So everything you learned in Lessons 1 and 2 will
apply.

Editing data after they have been entered into a cell

If you are past the cell where you have an error and want to make a
correction or change, move back to the cell in question by selecting
(clicking on) it. The data in that cell will be displayed in the Entry
bar at the top of the spreadsheet. Click in the Entry bar (the cursor
will show where you clicked on the text) and then just go ahead and make
any changes you want. Replace the old entry by clicking the Accept
button ([image: ]) or by selecting another cell in
the spreadsheet.

4.3 SETTING UP LABELS FOR YOUR HOME INVENTORY TEMPLATE

When you have completed this section, your Home Inventory Template
should look like Fig. 4.4.

[image: ]

Fig. 4.4 Home Inventory Template

The steps that follow will help you achieve this goal. Follow them
carefully.


Select cell A1 and type Home Inventory

Check the data in the Entry bar to make sure you typed the label
correctly; correct any errors

Click the Accept button ([image: ]) when you
are sure all is well (or press one of the other keys—arrow keys,
Enter/Enter key, Tab key—which accept data into the spreadsheet)




This is an example of a label—which is any text you use to describe
the data that are in a spreadsheet. All the column and row headings are
also labels.

Notice that the label “Personal Information” overflowed the cell in
which you typed it. The cell isn’t wide enough, so you need to widen the
A column to allow for the length of this and other Labels describing
information you will later be entering into that column.


Make sure you have any cell in column A selected, then from the
Home Ribbon select the Cells Group > Format >
Column Width

Type the number 25 in the dialog box that pops up, then click on
**OK **

While you’re at it, click anywhere in column B (Item(s)) and,
in the Home Ribbon again, select the Cells Group >
Format > Column Width and adjust the width to 25, too




Later in this section you’ll practise adjusting the width of other
columns.


Select cell A3 and type the label Personal Information:, then
press Enter to move the cell pointer to cell A4

Type the label Name: and press Enter to move the cell pointer
to cell A5

Next type the label Address Line 1: and press Enter to move
the cell pointer to cell A6, type the label Address Line 2:
and press Enter to move the cell pointer to cell A7, type the
label Phone:, then click on the Accept button
([image: ]) in the Entry bar




At this point you should be thinking about saving the work you have
completed to this point! Since you have already named the document
(Home Inventory Template), you can use a quick keyboard shortcut.


Press Ctrl-s to save your work to this point


Aligning data in spreadsheet cells

The grade book will look best if the three labels you just entered into
cells A3 to A7 of the spreadsheet are right aligned in their
respective cells. Right aligned means that the label is aligned to the
right side of the cell. Unless you tell Calc otherwise, the system
will left align any data that are regular text (letters of the
alphabet, for example). Likewise, the system will right align any data
that are made up of numbers. This makes sense if you look at Fig. 4.5.

[image: ]

Fig. 4.5 Text is left aligned; numbers are right aligned

However, text sometimes looks best when it is right aligned in the cell.
This is the case with the labels about your Personal Information that
you just entered into cells A4 to A7. Here is how you right align the
text in these cells.


Position the spreadsheet cursor on cell A4

Hold down the mouse button and drag down to cell A7, so that all
four cells are selected (cell A4 will still be selected even
though it is not highlighted—it has the heavier border which also
indicates selection in the spreadsheet)

In the Home Ribbon > Paragraph Group click on the Right
Alignment button




This will right align the cells that you have selected (A4 to A7). Check
this on the screen before you go on.


Press Ctrl-s to save your work so far (this is a good habit to get
into!)


Entering the column and row labels

Now you are going to enter the labels for each of the columns that
eventually will contain the data about your personal possessions (your
home inventory). But notice again that the columns are too narrow for
the text you’ll need to type in these columns. So let’s begin by
widening all the columns from C to H. For now, we’ll make them all a
width of 22 (if necessary we can adjust them again later). You widened
columns on the previous page, so this should be easy for you.


Use the mouse to click anywhere in Column C, then hold down
the Shift key, and keep it down as you click anywhere in
Column H, so the cells from C to H are selected

Go to Home > Cells > Format > Column Width
and, in the dialog box that pops us, enter 22 for the width of all
the cells from column C to column H

Now select cell D9 and enter the label Purchase Price, check
that you have typed the label correctly, then press the Tab key
three times to move to cell G9 and type the label Estimated
Value

Next select cell A10 and enter the label Location, check that
you have typed the label correctly, then press the Tab key to move
to the next cell across to the right and type the label
Item(s)

Do the same thing six (6) more times, using the labels Purchase
Price (in cell C10), Price Totals (in cell D10),
Condition (in cell E10), Estimated Value (in cell
F10), Est. Value Totals (in cell G10), and %
Depreciation (in cell H10), then click the Accept button
([image: ])




Now, before we move on, you need to type in the label in Cell C8 (see
Fig. 4.4 on page 109), which simply explains the meaning of the currency
symbols used in the spreadsheet.


Select cell C8, type Purchase Information (all values are in
GHS-Ghanaian Cedi (₵), then click the Accept button
([image: ]) and press Ctrl-s again to save
your work so far


Changing the alignment of the column labels

It would be a good idea at this point to change the alignment of the
column labels in cells A10 to H10 so that they are all center aligned.


Position the mouse over cell A10, hold down the mouse button, and
drag across to cell H10 before letting go of the mouse button


All the column labels in Row 10 should now be highlighted.


In the Home Ribbon > Alignment Group click on the
Center Alignment icon


Adjusting the width of columns

You’ll recall that in Calc the labels (text in general) are aligned on
the left of the column, while numbers are always aligned on the right
(check Fig. 4.7 above if you’re still confused about this).

You can simultaneously change the widths of several adjacent columns
(columns that are next to each other), provided you want them all to be
the same width. There are a couple of ways to do this. Let’s try both
ways and you decide which is easiest for you.


First use the mouse pointer to drag across the column headers from
column C to column H (Fig. 4.6)
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Fig. 4.6 Selecting a set of columns


From the Home Ribbon > Cells Group select Format >
Column Width… (or simply right click on the column header
and, in the context menu select Column Width…)


This will bring up the Column Width dialog box (Fig. 4.7).

[image: ]

Fig. 4.7 Column Width dialog box


Type 8.43 in the Column width: dialog box and click on OK,
then click anywhere to de-select the columns


All the selected columns (C to H) are now a column width of 8.43.
Simple.


Before you go on, you need to restore the column widths to 22,
so hit Ctrl-z (Undo) to restore the columns to their previous
widths


Another way to adjust the width of an adjacent set of columns is by
first selecting (highlighting) the set of columns, as you did for
columns C thru H just now, and then, with the cursor positioned between
any two column headers, drag to the left or the right, as illustrated in
Fig. 4.8.
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Fig. 4.8 Adjusting column width by dragging


Try this for yourself now by selecting (dragging across) all 6 of
the columns from Column C to Column H, and widening or narrowing
them as much or as little as you want

Do this a couple more times, widening or narrowing the column width of
a few adjacent columns (columns next to each other), each time
hitting Ctrl-z afterwards to restore the columns to their previous
width, and, before you try again, click anywhere on the spreadsheet to
remove any highlighted areas




Notice each time how each of the selected columns is the same width as
the others after you’ve dragged to adjust just one of the columns.

You also can simultaneously change the width of several, non-adjacent
columns, again provided you want them all to be the same width. You do
this by clicking on the column header of the first column you want to
change, then you would hold down the Ctrl key while clicking on the
Column Header of the other columns you want to adjust to the same width.
Then, with the mouse pointer positioned on the right edge of any the
selected columns so the pointer becomes a crosshair (Fig. 4.8 above),
you would drag to the left or the right. Try this for yourself now.


Click on any column header (say column C), then hold down the Ctrl
key while you click on any three other column headers (E, G, and
H, for example) to select them, and then position the mouse pointer on
the right edge of any selected column and widen or narrow them as
much or as little as you want

Click anywhere to de-select the columns, then hit Ctrl-z to
undo your work

Do this a couple more times, selecting a column, then holding down the
Ctrl key while select a few other non-adjacent columns (columns
that are NOT next to each other), and dragging the right
edge of any one of the columns to widen or narrow the column
width




Let’s now change specific column widths so that the Home Inventory
Template ends up looking like the example illustrated in Fig. 4.4 on
page 109. You’re going to start by changing the width of columns C, E
and F so that they are as wide as necessary for the data (descriptive
text) that will go in them.


Position the mouse pointer on the column header “C” at the top of
the column, hold down the Ctrl key, and keep it down, while you
click to select the column header for column E and column F
(Fig. 4.9)
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Fig. 4.9 Selecting a non-adjacent set of columns in the spreadsheet

When you have columns C, E and F selected, let go of
the Ctrl key and let go of the mouse button




All three columns (C, E and F) should now be highlighted.


From the Home Ribbon > Cells Group select Format >
Column Width… (or simply right click on the column header
and, in the context menu select Column Width…)


This will bring up the Column Width dialog box.


Type 25 for the column width, and click on OK, then click
anywhere to de-select the columns


Another way to change Column Widths is to drag with the mouse. Let’s try
this.


Position the mouse pointer in the column headers between column G
and column H so the pointer becomes a crosshair

Now drag left or right and notice the small box that appears,
telling you the exact column width (Fig. 4.10); end up with the width
of Column B at about 18
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Fig. 4.10 Adjusting column width using the mouse

Three columns in the spreadsheet (columns D, G and H) still need
adjustment.


Position the mouse pointer on the column header “D” at the top of
the column, hold down the Ctrl key, and keep it down, while you
click to select the column header for column G and column H,
then from the Home Ribbon > Cells Group select Format


Column Width… and increase the column width to 18





By now you must feel like you have a pretty good idea about various ways
to change column widths, but before you move on you need to return the
width of Columns C to H to 22.


Click on the column header for Column C, then hold down the
Shift Key as you click on the column header for Column H,
then from the Home Ribbon > Cells Group select Format


Column Width… and, in the Column Width dialog box enter
the value 22





This will bring up the Column Width dialog box.


Type 25 for the column width, and click on OK, then click
anywhere to de-select the columns

Press Ctrl-s again to save your work (Home Inventory Template)
when you have completed this exercise




4.4 COMPLETING YOUR HOME INVENTORY SPREADSHEET

Changing the name of the template document

The Home Inventory Template is safely saved on your disk. Now you can
start to use it to build a specific Home Inventory spreadsheet.

As you can see, the template is still on the computer screen after you
have saved a copy of it on your disk. Next you are going to fill it out
with actual rooms, along with the contents of each of the rooms in your
home.

Thus, the template will no longer be a template; it will become the Home
Inventory for a real home. Therefore, the first thing you must do is
Save the spreadsheet with a different file name, so that you will not
lose the template you have just created.

It is always a good idea to do this straight away because you might
forget to do it later.

Up until now you have been working with the document you originally
called “Home Inventory Template.” Let’s say the year is 2015. A good
document name for this spreadsheet would be Home Inventory 2015.


From the File menu select Save As…

In the Save As dialog box navigate to the Work Files for
LibreOffice folder > Data Files folder >
Spreadsheets folder, type the file name Home Inventory 2015,
then click on Save




The new document name will appear at the top of the Calc spreadsheet
window.

Entering data (labels and contents) for each of the rooms in your
home

When you have completed this section, your Home Inventory spreadsheet
will look like that illustrated in Fig. 4.11 on the next page. Refer
back to this Figure frequently as you work your way through the sections
that follow.

Start by adding the year to the spreadsheet title in cell A1.


Click on cell A1 and, in the data entry bar add 2015 at
the end of Home Inventory (see cell A1 in the figure above)


You should next fill in the specific Personal Information for your new
Home Inventory.


In cell B4 type your name, hit the Enter key to move the
selected cell to B5, and type the first line of your home
address (make one up if you wish)

Hit Enter again to move the selected cell to B6, and type the
second line of your address (the town or village you live in, for
example, along with the Ghana State)

Hit Enter again to move the selected cell to B7, then type a
phone number (make one up if you want), and click on Accept
([image: ])
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Fig. 4.11 The Completed Home Inventory 2015 spreadsheet

Entering the names of each of the rooms in your home


Now select cell A11 (this is where the name of the first room will
go), and type Living Room

Hit the Enter key 6 times to move to cell A18

Type Kitchen, hit Enter, move to cell A25, and type
Bedroom One Repeat these steps for cells A32 (type Bedroom
Two), A39 (type Bathroom), and A46 (type Other)




Notice how the room names are all lined up on the left of the column
(text is normally left aligned).

Entering the names of the items in each room

Your next step will be to enter specific items that you might have in
each room, along with the purchase price and current estimated value of
each item. Check back to Fig. 4.11 above if you have any doubt about
what to do. Bookmark this page, if necessary.

On the next page is a list of the kind of objects you might find in the
rooms of your home. This will help you to come up with ideas for items
to include in your Home Inventory:
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Click in cell B11 and type the name of an item (furniture, chairs,
rugs, TV, etc.) you might have in your living room

Hit enter to go to cell B12 and enter another living room
item—and continue until you have entered any 5 living room items,
then hit Ctrl-s to save your work

Now click in the cell in Column B that is next to the
Kitchen label in Column A (cell B18) and type the name of
an item (Stove, Dishes, etc.) you might have in your kitchen, hit
enter to go to the next cell down, and enter another
kitchen item—and continue until you have entered any 5 kitchen
items

Now click in the cell in Column B that is next to the
Bedroom One label in Column A (cell B25) and type the name
of an item (Stove, Dishes, etc.) you might have in your kitchen,
hit enter to go to the next cell down, and enter another
kitchen item—and continue until you have entered any 5 items you
might find in your bedroom

Do the same for Bedroom Two (starting in cell B32), the
Bathroom (starting in cell B39), and Other (starting in
cell B46), then hit Ctrl-s to save your work




Next, as you can see if you look at Fig. 4.11 on page 115 above, you
need to enter a label for a Sub-total for the Purchase Price and
Estimated Value of each of the items in each of the rooms. Let’s do the
Purchase Price Sub-total labels first.


Click in cell C16 and type Living Room Sub-total

Click in cell C23 and type Kitchen Sub-total

Click in cell C30 and type Bedroom One Sub-total

Click in cell C37 and type Bedroom Two Sub-total

Click in cell C44 and type Bathroom Sub-total

Click in cell C51 and type Other Sub-‘total

Do the same in Column F for the various Estimated Value
Sub-total labels (in cells F16, F23, F30, F37,
F44, and F51)




You need a couple more labels, one for the sum total of all the purchase
prices, and another for the sum total of all the estimated values.


Click in cell C53 and enter the label Total Purchase Price,
then click in Cell F53 and enter the label Total Estimated
Value

Check all these labels against those illustrated in Fig. 4.11 on page
115 and, assuming all is well, Save your all your hard work
(Ctrl-s)




Entering the Purchase Prices and Estimated Values

Now you need to come up with a Purchase Price for each of the items in
your inventory. But before you do that, it’ll be a good idea to define
the format for the cells that will contain currency (monetary) data.

Here are the steps to do this.


Click on cell C11, then in the Home Ribbon > Cells
Group > Format menu select Format Cells (the last item in
the menu)


This will bring up the Format Cells dialog box (Fig. 4.14).
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Fig. 4.14 The Format Cells dialog box


In the Format Cells dialog box, click on the Number tab (Fig.
4.14 above) and, in the Category menu select Currency

Leave the default Decimal places at 2, then click on the
down arrow at the end of the Symbol box and scroll in the
menu all the way down to the option GHS (it’s quite a way down,
so keep going till you find it), then click on OK

Now with cell C11 still selected, use the mouse pointer to grab
hold of the cell’s Fill handle (the mouse pointer becomes a bold
“+” sign) and drag the Fill handle down to cell C15 (Fig. 4.15
on the next page) to copy the contents of cell C11 to all 5
cells from C11 to C15
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Fig. 4.15 Using the cell’s Fill handle to copy the contents of a cell to
other adjacent cells

While you have this set of 5 GHS formatted cells selected, you can copy
them to the clipboard and then simply paste them into the several other
cells in the Home Inventory spreadsheet where you will soon be entering
currency amounts. Here are the steps to do this. Follow these next
directions carefully so you don’t make a mistake!


Hold down the Ctrl key—AND KEEP IT DOWN!—as you click on each
of the following 11 cells: C18, C25, C32, C39,
C46, F11, F18, F25, F32, F39, and F46,
then hit Ctrl-V to paste the data from the clipboard to all
these cells


You won’t see anything in the cells—yet. But soon you’ll be entering
monetary amounts (the purchase prices of the contents of your home) into
these cells, and they will all come up with the GHS symbol and 2 decimal
places—just like that!

But first you have to set the currency format for a few other cells that
will hold the Purchase Price sub-total for each room, and the various
cells that will hold the Estimated Value sub-total for each room (see
Fig. 4.11 on page 115).


Starting in cell C16, type Living Room sub-total, then in the
Home Ribbon > Alignment Group click on the Right
Alignment icon

Move to cell C23, type Kitchen sub-total and right align it, then
do the same for cells C30 (Bedroom One sub-total), C37
(Bedroom Two sub-total), C44 (Bathroom sub-total), and
C51 (Other sub-total), then save all your hard work
(Ctrl-s)




Now you need to copy these 6 labels into the Estimated Value column.


Click on cell C16, then hold down the Ctrl key—AND KEEP IT
DOWN!—as you click on each of the following 6 cells: F16,
F23, F30, F37, F44, and F51, then hit Ctrl-V
to paste the data from the clipboard to all these cells

Again, save all your hard work (Ctrl-s)




Now you have to think for yourself and come up with a Purchase Price and
an Estimated (current) Value for all the items in all the rooms of your
home. You can use the same values as are illustrated in Fig. 4.11 on
page 115 if you want.


Starting in cell C11, make up a Purchase Price and an
Estimated Value for each of the items in each of the rooms in your
home inventory list


This is tedious work, but it’s good practice and, in any case, it has to
be done, right? Notice that when you Accept the data into each cell,
the value now automatically comes up with the GHS symbol and 2 decimal
places. Neat, huh?

Entering the Condition of each of the items in each room

Your next task (in the Condition column) is to come up with a
condition for each of the items in your inventory.


Starting in cell E11, come up with a condition (either
Excellent, Good, or Fair) for each of the items in each of
the rooms in your home inventory list, then once again, save all your
hard work (Ctrl-s)


Before we go on to the next major section of this lesson, there is one
important thing you need to know about spreadsheets such as Calc. If, in
any cell, you ever see ###### signs like this, DO NOT PANIC! The
###### signs are simply telling you that the column the cell is in
is not wide enough to show all of the data. To fix it, all you have to
do is make the column wider. You already practiced doing this (Home
Ribbon > Cells Group > Format > Column Width and enter a column
width wide enough to show all the data in the column).


Remember if you ever see those ###### signs in a cell, they’re
not a problem. They’re just an alert to you that you need to make the
column wider to fit the size of the data.


4.5 CREATING AND COPYING FORMULAS

Functions and Formulas are powerful tools in spreadsheets, tools that
can save you hours of work.

Functions are routines that are built into the Calc spreadsheet—in
other words, there’s not much you need to do to set them up and make
them work. You just need to know what the functions do, and then how to
apply them when you think they will serve your purpose. But you do need
to know and understand what they do.

Formulas, on the other hand, are defined by you, the user—in other
words, you have to both know what you’re doing and set everything up
yourself.

Formulas will often include the spreadsheet built-in functions as part
of the formula.

Both functions and formulas accomplish the same task: they tell Calc
to do some kind of more or less complex calculation for you.

For example, in your home inventory spreadsheet you might want to
calculate a total value for the set of items in a particular room, and
the total value for the contents of the house as a whole. You might
also want to know the total estimated value, after time has passed, for
the set of items in a particular room, and the total estimated value
for the contents of the house as a whole. Then you might like to know
what is the percentage value, after depreciation, of all those items in
your house—what are they worth now as a percentage of what they were
worth when you originally bought, or otherwise acquired, them.

To do all this, you can program the spreadsheet to execute (carry out) a
formula based on the values in the cells that contain these monetary
values. You can have the spreadsheet add up the numbers in a set of
cells, for example. Or you can have the spreadsheet tell you the average
score in a range of cells, and so on. You can also have the system copy
a formula into other cells.

Let’s try a few things along these lines now.

Creating a formula

Let’s enter a formula and see what it does.


Select cell D16, type =SUM(C11:C15), then click on the
Accept button ([image: ]**) **


The “=” symbol at the beginning is a clue to Calc that what
follows is a function or formula. So remember this:


ALL SPREADSHEET FUNCTIONS AND FORMULAS BEGIN WITH THE EQUALS (=)
SIGN


The formula =SUM(C11:C15) tells Calc to sum (add together) the
monetary values entered in cells C11 through C15 and store the
result in cell D16 (cell D16 is the cell in which you want the
formula to put the result of its calculation—the Total Purchase Price of
the items in your living room).

If this is confusing to you, don’t feel bad. Spreadsheets do
mathematics—they calculate stuff. So in order to use spreadsheets
effectively, you need to understand some (mostly simple) mathematics.

SUM is one of many Calc built-in functions. It ADDS UP or TOTALS a
series of numbers to produce the required result. We’ll look at other
built-in functions in a moment.

If you typed in the formula correctly and clicked the Accept button
([image: ]), you should see that cell D16 contains
the sum of the Purchase Price for all the items in your Living Room.


Press Ctrl-s to save your work


Copying and pasting formulas

You already did this (copying and pasting), but in case you weren’t
quite sure what was going on when you followed the directions, here is a
description of what Copying and pasting involves. Fig. 4.16 illustrates
the process.
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Fig. 4.16 Copying and Pasting

Now you are going to copy the formula from cell D16 (the formula
that added up, or summed, all the values in cells C11-C15—the Total
Purchase Price for the items in the Living room of your home). Then you
are going to paste this formula into the other 11 relevant sub-total
cells in the Home Inventory spreadsheet (go to page 115 and check this
out in Fig. 4.11 once again).

Copying the formula...


Click on cell D16, and do Ctrl-c to copy the contents of the
cell to the clipboard


Cell D16 will now have a blinking border indicating that this is the
cell from which the formula has been copied to the clipboard.[^1]

Pasting the formula...

You are going to paste the formula that you just copied (from cell D16)
into the 11 other cells in your Home Inventory spreadsheet that have
sub-totals of the values for the items in the rooms of your home.


Hold down the Ctrl key—AND KEEP IT DOWN!—as you click on each
of the following 11 cells: D23, D30, D37, D44,
D51, G16, G23, G30, G37, G44, and G51,
then hit Ctrl-v to paste the data from the clipboard to all
these cells

Again, save all your hard work (Ctrl-s)




Notice that the value in each of the sub-total cells is correct for
the set of cells it is concerned with (related to by the formula). In
other words, Calc automatically adjusts the range of cells
relative to the set of cells being totalled.

This is called Relative referencing. What does Relative Referencing
mean?

Relative references

You might find this a bit tricky to follow, so put on your thinking cap,
OK? The system is copying the formula in cell D16 to all the other cells
in the Home Inventory spreadsheet that need to calculate a sub-total for
the inventory items in a room. In other words, just as the formula in
D16 sums the values stored in cells C11 to C15, so the formula copied to
other sub-total cells will sum the values relative to cells C11 to
C15.

Does that make sense? If so, give yourself a pat on the back! If not,
don’t despair. Read it over a couple of times. The alternative to a
Relative Reference, by the way, is an Absolute Reference. You will need
to use an Absolute Reference in the next lesson (lesson 5). For now,
let’s keep it simple.


Press Ctrl-s again to save your work so far (are you getting into
the habit of doing this?)


Setting up the % Depreciation formula

The next formula you need will go in the % Depreciation column (column
H) and will calculate the percentage depreciation for each of the items
in each of the rooms in your home. The formula will tell Calc to
divide the Estimated Value of an item by the Purchase Price of that same
item, thus telling us the percentage depreciation in value of that item
over time.


Select cell H11, since this is the cell in the % Depreciation
column for the first item in the Living Room


The formula you want to create will divide the value you entered into
cell F11 (which is the current Estimated Value for the first item in
the Living Room) by the value in cell C11 (which is the original
Purchase Price for that item). Here’s what you need to do.


Type the formula =F11/C11 (don’t forget the “=” sign which
tells Calc that you are about to type a formula) and press
Enter


Hmmm… Notice, in cell H11, that when you divide one number by another
the result is often a fraction. Thus the eventual percentage for each
room’s Percentage (%) Depreciation won’t look like a percentage at all.
Instead of, say, 85%, the computer will display 0.85, for example.

Setting the Cell Attribute for the % Depreciation column

It would be best to display the percentages as whole numbers (no
fractions) with a % sign after them, like 85%. No doubt you are familiar
with this seeing percentages this way. So you need to add this feature
to the Home Inventory 2015 file.

Follow these steps to format (select attributes for) the values in the
PCNT column so they will eventually look like recognizable percentages.


Make sure cell H11 is still selected and, in the Home Ribbon


Number Group click on the % (Percent) symbol to change
the format of the decimal number to a percentage


With cell H11 still selected, use the mouse pointer to grab hold
of the cell’s Fill handle (the mouse pointer becomes a bold
“+” sign) and drag the Fill handle all the way down to cell
H53 to copy (Fill down) the contents of cell H11 to all
of the cells in column H




Uh oh. You’ll notice that cells H16 and H17 (that do not have any value
associated with them) are coming up with error messages (#VALUE and
#DIV/0!). The same is true for cells H23 and H24; H30 and H31, H37 and
H38, H44 and H45, H51, H52, and H53.

Cells H17, H24, H31, H38, H45, and H52 are easy to fix because they do
not have any value associated with them. You just need to clear those
cells of the formula that has been copied there.


Hold down the Ctrl key—AND KEEP IT DOWN!—as you click on each
of the following 6 cells: H17, H24, H31, H38,
H45, and H52, then hit the Delete key on the keyboard to
remove the error formula from these cells


Now you need to fix the problem with the cells that have the error
message (#VALUE!). This message is telling you that the formula for
these cells is wrong.


Click on the first of these cells (cell H16), then look in the
data entry bar at the formula that is in the cell: =F16/C16


F16 and C16 contain labels, not numbers, so there’s no way you can
do any maths with them. The formula should be G16/D16 (the cells
containing the Purchase Price and the Estimated Value sub-totals). Now
that you know this, it’s easy to fix.


With cell H16 selected, type the formula G16/D16, hit the
Accept button ([image: ]), then hit Ctrl-c
to copy this correct formula to the clipboard

Now, with cell H16 still selected, hold down the Ctrl
key—AND KEEP IT DOWN!—as you click on each of the other 6
cells that need to be fixed—the cells that still contain the error
message #VALUE!, namely H23, H30, H37, H44,
H51, and H53—then hit Ctrl-v to paste the corrected
formula in to each of these cells

Hit Ctrl-s to save your work




If you followed all these steps correctly, your Home Inventory
spreadsheet should finally look like the one illustrated in Fig. 4.11 on
page 115. How did you do?

Checking out the formulas

It is useful to check out the formulas in the spreadsheet. Sometimes you
may be getting the wrong results and you may need to examine a formula
to see if there is an error. Or you may simply want to know how a
particular value is computed. Like everything else, this is easy enough
to do when you know how.


In the Formulas Ribbon > Formula Auditing Group select
Show Formulas


This will display all the formulas in your spreadsheet (Fig. 4.17, for
example, highlights the formulas used to calculate the values in Columns
H, G and elsewhere in the spreadsheet).
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Fig. 4.17 Showing formulas in the Home Inventory spreadsheet


Scroll over if necessary to check out the formulas displayed in the
other columns of your spreadsheet


After you have verified that the formulas are stored correctly relative
to each of the appropriate cells, you should reset the display so you
can see the values, not the formulas, in the cells.


In the Formulas Ribbon > Formula Auditing Group click on
Show Formulas again to toggle back to showing the data in the
cells


Notice that the formulas are hidden once again.

4.6 MAKING CHANGES TO YOUR HOME INVENTORY SPREADSHEET

Now that your Home Inventory is complete and saved on your disk, you can
still make changes to it. Perhaps you want to add one or more items to
some of the rooms in your home inventory. This can all be done with
little effort on your part.

Adding an item to a room (Inserting rows)

A new item can be added to any room by inserting a row. To insert a
row you would select the location ahead of which you want to place
the new row or rows (say before Row 16). Calc inserts a new row
immediately ahead of the row you have selected. Follow these steps to
try this now.


Select the whole of row 16 by clicking in the row label
(the number 16 at the left edge of the spreadsheet—Fig. 4.18)
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Fig. 4.18 Selecting a row


Now, with the cursor positioned on the number of the row (16),
right click and, in the context menu that pops up, select
Insert


Immediately Calc inserts a new empty row. If you inserted the row in
the wrong place, remember that you can undo what you just did by hitting
Ctrl-z.

Now you must fill the new row with data as in the rest of the
spreadsheet.


Across row 16, fill out another item for the living room, a
Purchase Price for the item, the Condition of the item, and an
Estimated Value


You will also need to update the formulas in cells D17 and G17 to
include the values for the new item.


Move, first, to cell D17 and, in the data entry bar, change the
formula to =SUM(C11:C16), then click on cell G17 and, in the
data entry bar, change the formula to =SUM(F11:F16)


You’ll notice that the values in cells D54 and G54 (the grand totals for
the Purchase Price and Estimated Value) have been automatically updated
by Calc. After you have updated the formulas you should check to see
that the results in the various cells make sense. Mistakes are always
possible.


NEVER ASSUME THAT THE COMPUTER IS GIVING YOU THE CORRECT DATA. THE
DATA ARE ONLY AS GOOD AS THE PERSON WHO ENTERED THEM—AND THAT PERSON
IS HUMAN!


Inserting columns

To insert a new column, you would again select where you want to insert
the column—say between columns F and G. Calc will insert the new
column(s) to the left of the column you select.


Highlight column G by clicking in the column header (the
letter “G” at the top of column G in the spreadsheet), then right
click on the Column Header (the letter G) and, in the context
menu, select Insert


Calc inserts an empty column between column F and G to allow you to
enter a new set of data. The column width is set to be the same as the
column next to which it is inserted. You don’t need a new column in this
spreadsheet, but you now know how to do it if you wanted to.

Deleting (cutting) rows and columns

If you need to delete rows or columns from a spreadsheet, you would
select a row or column, or a set of rows or columns, then hit the
Del(ete) key to delete them. No need to practise this now. Just
remember where to find this section if you ever need to delete rows or
columns from a spreadsheet.

The beauty of an electronic spreadsheet such as Calc is that, even
when you add or delete rows or columns, the system automatically updates
the formulas where appropriate to match the new state of the data.

Using boldface and other cosmetic tools to highlight cells

Take a look at again at Fig. 4.11 on page 115 and notice the rows in the
spreadsheet that are highlighted in boldface. This draws attention
to those cells and makes them easy to pick out from the mass of other
data in the spreadsheet. Let’s do that to your spreadsheet to finish the
job and give the spreadsheet a more professional look.


Start with cell A1, click on it, then, in the Home Ribbon >
Font Group, increase the font size to 20

Next click in cell A3 and hit Ctrl-b to boldface the
phrase Personal Information:

Click on the row label of row 9 (the number 9 at the
left edge of the spreadsheet) to select the whole row, then hit
Ctrl-b to boldface the data (labels) in the relevant cells in
row 9

Now do the same for rows 10, 17, 24, 31, 38,
45, 52, and 54




There you go. Your spreadsheet should now look very much like the one
illustrated in Fig. 4.11 on page 115. Check it out.

4.7 PRINTING YOUR HOME INVENTORY

You are now going to print a “hard copy” of the Home Inventory.
Printouts can be oriented in one of two possible ways: Portrait
orientation (the normal look of a page) or Landscape orientation (where
the page is turned on its side, like a landscape painting. Fig. 4.9
illustrates the difference between the two.
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Fig. 4.19 Portrait and Landscape page orientation

Unless you decide otherwise, Calc will print the page in the Portrait
orientation (Fig. 4.19 above).

If your Home Inventory is too wide to fit on the 8.5 inch width of
standard paper, you can print the Home Inventory sideways (Landscape
orientation). In fact, this is often the best orientation for a
spreadsheet because of the “shape” of the data which is often set up in
columns across the screen.


In the Page Layout Ribbon > Page Setup Group, select
Orientation, and click on Landscape


In the Page Setup dialog box you can also tell Calc to print or not to
print gridlines, row and column headings and so forth. You can thus
still make changes to the appearance of your spreadsheet on the printed
page. Let’s try this now.


In the View Ribbon > Show/Hide Group, click to remove the
check mark in the boxes next to Headings (if it’s not already
removed) and Gridlines (again, if it’s not already removed)


This is to tell Calc you do not want those headings and gridlines in
the first printout.


Now, in the File menu select Print to bring up the Print
dialog box (Fig. 4.20)
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Fig. 4.20 The Print dialog box

In the print dialog box, you can choose the number of copies you would
like. As a rule, it is best to have the computer print only one copy
(the default number of copies) unless you have a high speed printer,
since it is easier (and cheaper) to make multiple copies using a
photocopier.

Also, if you have an ink jet printer, select draft quality or quick
print the first time or two, so you don’t waste ink (this is not an
option with laser printers since laser printers always print best
quality).

Another tip, if you have control over your own printer, is to recycle
once used paper (clean on one side) for draft copies. You might even
start collecting this, instead of throwing it away. Help save the
planet!

For in the Print dialog box, the radio button for All is selected by
default. If you look a little lower in the dialog box (in the Print
what section) you’ll see that the radio button for Active sheet(s)
is also selected by default (see again Fig. 4.20 on the previous page).

These are the appropriate settings for our Home Inventory spreadsheet.
We’ll check out other options in Lesson 5.


Click on OK to print your Home Inventory 2015 Home Inventory
(it should print in Landscape orientation without gridlines or
row and column headings)


The printer will print the Home Inventory so you can send it to your
instructor. For further reinforcement of the options for printing a
spreadsheet, let’s print the Home Inventory again, but this time we’ll
include the row and column headers and the gridlines using a slightly
different method.


Select File menu > Print > Print Preview, and click
on the Page Setup button to bring up the Page Setup dialog box
(Fig. 4.21)
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Fig. 4.21 The Page Setup dialog box

As you see, you can set the Page Orientation in this Page Setup dialog
box.


Make sure the page orientation is still Landscape for the
Home Inventory 2015 printout

Now, in the Page Setup dialog box, click on the Sheet tab (Fig.
4.22)
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Fig. 4.22 The Page Setup dialog box


Put a check mark next to Gridlines and next to Row and
column headings, click on OK, click on the Print… button,
and wait while the printer does its job

Hand in both copies of the Home Inventory 2015 to your instructor




SKILL CONSOLIDATION

Complete as many of these exercises as you can to reinforce what you
have learned in Lesson 4.

1. Update Home Inventory 2015 by adding an extra column for another
assignment, quiz, project, or test score and hand in your printout of
the new spreadsheet.

2. Add two room items, along with their associated values, to the Home
Inventory spreadsheet that you created using this tutorial. Copy and
adjust the relevant formulas where necessary.

3. Design and create a spreadsheet to handle an income statement for
your personal checking account. The income statement will span one
full year, from January to December. The leftmost column will contain
a list of at least six items that you typically purchase during the
course of a month (Gas, phone bill, etc.). Then the column headers
across the spreadsheet will refer to months in the year. The numbers in
the cells will be the financial amounts (with $ signs and 2
decimal places) that you spent on each item per month. You will
include columns for the total for each item at the end of each
quarter (Quarter 1 is Jan., Feb., and March, for example) and a
column for the total at the end of the year. Then, at the bottom
of each column you will have a breakpoint total for each of the
months (with a row of its own as illustrated below), a total for
each of the Quarters (with a row of its own as illustrated below),
and a grand total for the whole year (in the rightmost cell
and with a row of its own as illustrated below). As you may have figured
out, there will be 18 columns in the spreadsheet, and at least 10 rows.


Send the exercise to your instructor as an attachment in email when
you are done. This could become an ambitious group project if you were
to add extra features such as weekly data with break points (sub
totals) and so forth—very useful, too. Here is an illustration of what
your final Income Statement might look like:
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4. Go to the Work Files for LibreOffice > Miscellaneous Files


Practice folder and open the Calc spreadsheet file Ghana
Facts and Figures. Update the spreadsheet in the following ways:



	Reduce the height of Row 24 to 3, by adding the label Totals
in cell B 25

	In Row 25 Cell B25 type the Label TOTALS; then in Cells
C25, D25, E25, G25, and I25, enter the formula to
SUM the numbers in columns C, D, E, G, and
I.

	Make boldface the entire contents of Row 25

	Create the correct formula for the columns of empty cells (Columns
D, F, H, and J).



The formulas you will need to create are based on the following:


	The calculation that will return the correct result for the cells in
column D is Area (in square kilometers) multiplied by (*)
0.3861

	The calculation that will return the correct result for the cells in
column F is Population by Region (column E) divided by the
National Population (Cell B7). Careful! This will need you to use
an Absolute reference for the National Population!

	The calculation that will return the correct result for the cells in
column H is Number of Males by Region (column G) divided by
the Population by Region (Column E)

	The calculation that will return the correct result for the cells in
column J is Number of Females by Region (column I) divided by
the Population by Region (Column E)



5. Get together with one other classmate and brainstorm for ideas about
using the Calc spreadsheet. List at least 10 suggestions and describe
briefly (a sentence or two) how you would use each of them in the home
or on the job.

[^1]: Think of the clipboard as a temporary holding area for a single
set of data. Once something is on the clipboard it can be pasted
anywhere you want—whether in this spreadsheet, or in another
spreadsheet, or into some other document altogether, such as a
Word document, a PowerPoint document, a Paint document, or
anywhere else on your own computer.
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Lesson 5 More on the Use of the Spreadsheet



5   MORE ON THE USE OF the spreadsheet

      Making changes to existing spreadsheets







LEARNING OUTCOMES

In this tutorial you will have the opportunity to learn the following.


	Updating an existing spreadsheet




	Making changes to the look of a spreadsheet




	Using the LibreOffice LOOKUP function




	Creating charts based on spreadsheet data




	Printing the updated spreadsheet



5.1 GETTING STARTED

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (Continuing with
the tutorial, on the next page). If you did not complete Lesson 1,
then you must do this now, before proceeding with the rest of Lesson 5.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to prepare these folders now before proceeding with
this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will
help you with this if you are working with a class) and Extract
them onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 5.1).
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Fig. 5.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 5.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

Continuing with the tutorial

You’re going to work with a Gradebook very similar to the one you
created in Lesson 4. For the sake of uniformity, and to avoid confusion,
you’re going to use a Grades Template and a Gradebook specially prepared
for use with this lesson.

You will work on the Gradebook first.


By now you should know the steps to open a document, so go to your
Work Files for LibreOffice > Miscellaneous Files >
Other Documents folder and Open the Gradebook spreadsheet

Go to File > Save As, then navigate to your USB drive


Work Files for LibreOffice > Data Files >
Spreadsheet Documents folder and Save the Gradebook there





5.2 RECAPITULATION AND REINFORCEMENT

The following sections give you an opportunity to refresh your memory of
the basic spreadsheet skills you learned in Lesson 4.

Moving from cell to cell in the spreadsheet

In Lesson 4, you learned some of the more useful commands for moving
around in the Calc spreadsheet (check Lesson 4, page 105, 106).

In Calc spreadsheet terminology, the cell that is selected (surrounded
by a heavier border) is called the current (or active) cell. Take a
moment now to reacquaint yourself with the methods for changing the
position of the currently active cell.


The arrow keys move the current cell to the adjacent cell
left, right, above, or below the current cell—press all four of the
arrow keys a few times, and watch how the current cell moves around

The TAB key (forward) and the Shift-TAB command (back) also
move the cursor to the adjacent cell, but only in a horizontal
(right or left) direction—try these two commands now.

The RETURN key (forward) and the Shift-RETURN command (back)
also move the cursor to the adjacent cell, but only in a vertical
(up or down) direction—try these two commands now

Use the scroll bars when you want to move around the spreadsheet
without changing the location of the current cell—try this, too




More cell selection commands

Selecting sets of cells in a spreadsheet

You occasionally may want to highlight all the cells in the
spreadsheet—in order to change a font, the font size, or the overall
cell background, for example. Here’s how you do this.


Click in the small box right above the Row headings and to
the left of the Column headings (Fig. 5.2)
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Fig. 5.2 Selecting an entire spreadsheet

The entire spreadsheet is now highlighted. However, perhaps you want to
select only the cells that you’re working in. There are a couple of ways
to do this.


Click anywhere in the spreadsheet to de-select the selected cells

Now, starting at cell A1, use the mouse to drag diagonally
down from cell A1 to cell O24




That’s one way. Here’s another way of doing the same thing.


Click anywhere to de-select the selected cells then click in cell
A1, hold down the Shift key, and click in cell O24


The same set of cells is selected. The Shift key is very useful for
selecting an especially large range of cells in Calc, or a range of
text in Writer, or even a range of slides in Impress, which
you’ll learn about soon enough. Dragging with the mouse can get tedious
and error prone when you have to select hundreds or thousands of
adjacent cells, dozens of pages, or scores of slides. Remember this
Shift key trick.

Going to a specific cell anywhere in a spreadsheet

If you are working in a large spreadsheet (consisting of thousands of
cells, say) and you know the approximate coordinates of a cell you want
to find, it is sometimes quicker to let Calc find the cell for you.
The following simple steps will show you how to make the cell that
intersects Column AJ and Row 423—a location quite deep inside the
spreadsheet—the current (or selected) cell.


Click again in the small box right above the Row headings
and to the left of the Column headings (Fig. 5.1 on the
previous page), type AJ423 (you can use either upper case (AJ) or
lower case (aj) for the column coordinate), then click on OK


There you go! Remember that the first (alphabetic) coordinate (AJ) is
always the column; the second (numerical) coordinate is always the Row.


Click again in the small box right above the Row headings
and to the left of the Column headings (Fig. 5.2 on the
previous page), then type A1, and click on OK


You are now back at the first cell (A1) in the spreadsheet. Some of the
options for moving about the spreadsheet are considerably slower than
others, which is why you should take the time to familiarize yourself
with all the different methods for moving around the spreadsheet,
especially if you become a regular user of Calc.

5.3 Updating an existing spreadsheet

The Gradebook would benefit from some cosmetic changes, such as the
following.


1. There should be double lines to set off different parts of the
spreadsheet. It is often useful, for example, to include extra space
(but not too much space) between the headings above the columns of data
and the data itself, and also before summary totals at the bottom of
columns of data.

2. It would be useful to include more formulas to increase the
information content of the spreadsheet. For example, you could add a
formula that calculates an average for each of the sets of grades so
that your students can see where they stand in relation to the rest of
the class on any particular assignment or test. A highest score and
lowest score for each set of grades would also be useful.

3. It would be a good idea to protect cells containing data that you
consider especially important. Protecting cells prevents you or someone
else from accidentally losing or changing cell contents. It takes time
to put together spreadsheet templates and other documents. Some cells
will contain functions that are tricky to figure out. Protecting them
will make it difficult to lose your work.

4. Finally, Calc can do some of the thinking for you if you include a
LOOKUP Table to figure out the Letter grades for your students
based on their percentage score at the end of a reporting period.




Let’s deal with these problems one at a time. In this section you’ll
learn how to handle the first three improvements. Later in the lesson
you’ll have the opportunity to learn how to create and use the LOOKUP
function.

Dividing up the spreadsheet to make it easier to read

After you have fixed change #1, the Gradebook will look similar to Fig.
5.3.
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Fig. 5.3 Gradebook after update #1

Breaks between sections of a spreadsheet help the eye locate important
data when scanning the page, whether on screen or on paper. In Calc,
the easiest way to do this is to use an extra row or column at the point
where you want to create a division between different parts of the
spreadsheet, and then put a border along the edges of the empty row
and also reduce the width of the inserted row or column so it appears
as a double line (Fig. 5.3 above).

Here are steps to update the spreadsheet along these lines.


On the left edge of the screen, in row 13, click on the row
number (13) to select the entire empty row


First you want to put a border around the set of cells in Row 13.


Right click on the Row number 13 and, in the context menu,
select Format Cells...

In the Format Cells dialog box click on the Borders tab, then
click on the tool to Set Outer Border Only (Fig. 5.4), and click
OK
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Fig. 5.4 Putting a border around a row of cells

Now you want to reduce the row height so the whole row looks like a
double line separating Rows 12 and 14.


Right click again on the Row Number 13 and, in the context
menu, select Row Height..., then in the Row Height dialog box
type the value 0.05” to replace the default height, and click
OK


You need to create a similar dividing line after Row 23, which holds the
data for the last student.


Right click on Row number 24 and, in the context menu, select
Format Cells..., then in the Format Cells dialog box click on
the Borders tab, then click on the Set outer border only tool
(Fig. 5.4), and click OK

Right click on Row Number 24 and, in the context menu,
select Row Height..., then in the Row Height dialog box type
0.05”, in the Shadow style section click on the first (no
shadow) button, and click OK, then save your work
(Ctrl-s)




Adding functions to the spreadsheet

Calc comes with many built-in functions. Let’s look at some of these
built-in functions so that you know how to find them when you need them.


Start this exercise by clicking in cell A1, then, in the Formula
Bar, click on the Function Wizard tool (Fig. 5.5)
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Fig. 5.5 The Function Wizard tool in the Formula Bar


Clicking on the Function Wizard tool will bring up the Function
Wizard dialog box (Fig. 5.6)
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Fig. 5.6 The Function Wizard dialog box


In the Category section, click on the down arrow to bring
up the various Categories of Functions available in LibreOffice

Select the Financial category (Fig. 5.6), then, in the Function
section of the dialog box, check out the several dozen Financial
functions available to you there

Do the same with the Calc Database, Date&Time,
Information, Logical, Mathematical, Statistical,
Spreadsheet, and Text sets of built-in Functions

Click on the Cancel button to close the Function Wizard dialog
box




You are going to add three new functions to the Gradebook: the
Average, the Max, and the Min functions. Let’s start with the
Average function, which will calculate the average score for a set
of student scores.

**Calculating an average for each of the Grade columns **

In Row 25 of the Gradebook spreadsheet, at the bottom of each of the
columns that contain scores for homework, etc., you are going to put the
value representing the average of the scores for each of the columns,
as illustrated in Fig. 5.7.
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Fig. 5.7 Average scores for each column

Notice, in Fig. 5.7, that cell B25, right under the column of first
names, has the row label Average. You need to put the same cell entry
in your Gradebook.


Select cell B25, type the label Average, and press Tab
twice to move to cell D25


A word about automatic calculation

When Automatic Calculation is switched on, Calc immediately
carries out any calculations that are necessary when you make any
changes to the data in the spreadsheet.

With automatic calculation, you don’t have to remember to do this. If
Automatic Calculation is not already on by default, it will be good
for you to turn it on, so here’s how you do this.


In the Tools menu > Cell Contents…, check, in the Cell
Contents sub menu, that there is a check mark next to
AutoCalculate (Fig. 5.8)


[image: ]

Fig. 5.8 Automatic Calculation

Back to the task at hand

An average is computed by adding (SUMming) the set of scores for an
assignment or test, and then dividing the total by the number of scores
in the set. You could put together this formula yourself, of course.
If you know what the formula would be for the first column of scores,
write it in the box below. Remember, a function or formula always begins
with the equals (=) sign.

Check the footnote below to see if you got the answer right[^1]. But
since Calc has a built-in Average function, you may as well use it.
Here are the steps to include the Average function in your spreadsheet.


Make sure cell D25 is still selected (the cell under the first
column of scores), then click on the **Function Wizard (*fx) ***icon
in the data entry bar and, in the Function Wizard dialog box,
from the list of Categories, select the Statistical category
(Fig. 5.9) and, from the list of Statistical functions, double
click on the AVERAGE function to select it
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Fig. 5.9 The Insert Function dialog box showing the Statistical category
of Functions

Calc pastes the function into the Formula area of the dialog box,
followed by a set of empty brackets. The brackets are for the set of
cells that contain the scores that are to be averaged. Notice that the
cursor is waiting between the brackets for you to select that set of
cells.


Type D14:D23 (Fig. 5.9) then click on OK


Alternatively, you could use the mouse to drag down the set of cells
from D14 to D23 with the same result. Look at the data entry bar at the
top of the spreadsheet and notice that the formula =AVERAGE (D14:D23)
is copied there, too.

Now look at cell D25. It should contain the average for the scores
in Column D. At this stage there are three problems that can occur:


1. If you see a series of pound signs (#####), this indicates
that there’s not enough room in the column to show the value, so you
will need to widen the column a little to make enough space for the
average score to appear. If this is the case (where you see #####
instead of an average score), make the column wider.

2. If a Bad Formula prompt pops up on the screen, check the formula in
the entry bar again, compare it to the correct Average formula
=AVERAGE(D14:D23), and make any corrections.

3. It is always possible that the values being averaged yield a result
that turns out to be a whole number (no fractions). But it would be
useful to show at least one decimal place, regardless of the outcome of
the Average calculation. If the average displayed in your Gradebook is
rounded to a whole number (no decimal places), here are the steps to
change the precision of the Average value to 1 decimal place.

In the Format menu select Cells… and in the Format Cells
dialog box > Options area, make sure that the number of
Decimal places is set to 1




Assuming all is well, your next task will be to copy this Average
formula into the cells immediately to the right of cell D25, so that
you have an average score under the other columns of scores (cells E25
through I25).


Cell D25 should still be selected (click on it if it is not
selected)


Fig. 5.10 shows you that you’re going to use the mouse to grab hold of
the Fill handle in the lower right corner of cell D25 (you practiced
doing this in Lesson 4) and drag it to the right to cell I25.
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Fig. 5.10 Cell Fill handle


Use the mouse to point at the handle in the lower right corner
of cell D25 (Fig. 5.10), and drag the handle across to Column
I—so that the formula is copied across to cells E25, F25,
G25, H25, and I25, which will all now have the correct
Average score for their respective columns


That’s all there is to it. If necessary (though it shouldn’t be the case
with this exercise) adjust the column widths if you see pound signs
(#####) in any cell instead of averages.


Time to save all your hard work (Ctrl-s)


Displaying the Highest (MAX) and Lowest (MIN) scores for each column
of scores

Now that you know how to use the Insert Function icon (fx) next to
the Data Entry bar, and in particular since you just used it to put the
Average function in your spreadsheet, you should be able to complete the
exercise that follows without much help.


In cell B26 put the heading Max score and in cell B27 put
the heading Min score

Make sure cell D26 is selected (the cell under the first Average
calculation), then click on the **Function Wizard (*fx) ***icon in the
data entry bar and, in the Function Wizard dialog box, from
the list of Categories, select the Statistical category (Fig.
5.9 on page 139)

From the list of Statistical functions, double click on the
MAX function to select it




Calc again pastes the function into the Formula area of the dialog
box, followed by a set of empty brackets. The brackets are for the set
of cells that contain the scores that are to be averaged. Notice that
the cursor is waiting between the brackets for you to select that set of
cells.


Type D14:D23 (Fig. 5.9—p. 139) then click on OK


In the data entry bar at the top of the spreadsheet notice that the
formula =MAX (D14:D23) is copied there, too. Now look at cell D26.
It should contain the maximum score in Column D.


Now make sure cell D27 is selected (the cell where you’re going to
put the MIN formula), then click on the **Function Wizard (*fx)
***icon in the data entry bar

In the Function Wizard dialog box, from the list of
Categories, select the Statistical category (Fig. 5.9 on page


	



From the list of Statistical functions, double click on the
MIN function




Calc again pastes the function into the Formula area of the dialog
box, followed by a set of empty brackets. The brackets are for the set
of cells that contain the scores that are to be averaged. Notice again
that the cursor is waiting between the brackets for you to select that
set of cells.


Type D14:D23 (Fig. 5.9—p. 139) then click on OK


Look at the data entry bar at the top of the spreadsheet and notice that
the formula =MIN (D14:D23) is copied there, too. Now look at cell
D27. It should contain the maximum score in Column D. Check to
confirm that that is indeed the case.

At this stage, the last task is to copy the Functions across to the
other cells in rows 26 and 27. You probably already know how to do this,
but here are the steps in case you need help.


With cell D26 selected, grab hold of the Fill handle in
the lower right corner of the cell and drag across to the
right to select cells E26 through I26—the cells in which you
want to include the Max function, and click OK

Now, click on cell D27, grab hold of the handle in the lower
right corner of the cell and drag across to the right to
select cells E27 through I27—the cells in which you want to
include the Min function, and click OK

Better Save your work (Ctrl-s)




When you’re done, your spreadsheet should look much the same as Fig.
5.11.
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Fig. 5.11 The Gradebook after adding the functions (your data will be
different)

Protecting (locking) important cells

Calc allows you to protect the contents of a cell or cells. This means
that neither you nor anyone else will be able to change the contents
unless you remove the protection. This feature is useful to prevent
accidental loss of data, and will also help prevent others from
interfering with the data you have collected.

Since all the data in a Grade book are important, it would be a good
idea to protect everything. The process to do this is the same as if you
were protecting a single cell, or a few cells, except that you select
every cell.


Press Ctrl-a to Select All the cells in the spreadsheet then,
from the Tools menu > Protect Document, click to put a
check mark in the box next to Sheet —to select protection for the
sheet (Fig. 5.12)
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Fig. 5.12 Protecting the spreadsheet data

This brings up the Protect Sheet dialog box (Fig. 5.13).
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Fig. 5.13 Protect Sheet dialog box

Take a look at this dialog box. Notice that the option to “Protect this
sheet and the contents of protected cells” is checked by default, which
is fine because that’s what you want to do. Notice, too, that you have
the option to include a password for the protection, which would be
important if this were a real world spreadsheet. But for the sake of
this exercise, we’ll not use a password.

But you do need to remove the check mark next to Select unprotected
cells. This is because you have opted to protect every cell in the
spreadsheet.


So, click to remove the check mark next to Select
unprotected cells, then click on OK


Now, even if you try to click on a cell, the system won’t let you. Every
cell in the spreadsheet is protected against unwarranted attack.

Password protection

Of course, someone who knows how to use Calc will know how to unlock
the protection—unless it’s protected by a password, of course. So if you
really want to prevent someone else from messing with the data in the
spreadsheet, you may need to take advantage of the option to include a
password.

This is a necessary feature if you want to lock the cells in your
spreadsheet in a way that prevents others from changing data you have
stored in the spreadsheet, such as scores or grades.

Passwords provide protection against unauthorized access. Choose a
password carefully; one that would be difficult to guess, of course, but
also one that you would be sure to remember! The weirder the password
the better—it should include upper case letters as well as numbers and
special characters such as the @ symbol or whatever. Remember, the
weirder your password the better—as long as you can remember it.
However, there’s no need to use a password in this exercise unless you
want to, of course.

Now all the cells in the Gradebook spreadsheet are unable to be changed
unless, in the Tools menu > Protect Document, you remove the check
mark next to Sheet in the sub menu.


Time to Save the changes to the Gradebook (Ctrl-s)


Dividing the spreadsheet into panes

Often a spreadsheet will be too long or too wide to view all the data at
once on the screen. For this purpose, Calc has a useful feature
(Split), which allows you to compare separate parts of a sheet
side-by-side. You can split any window horizontally and vertically into
sections (or Panes—like window panes). This allows you, while working or
scrolling in one section, to keep other section(s) fixed in place. This
applies whether the spreadsheet is protected or not.


To see how this works, first click in cell P28 to give Calc a
pivot for the split screen, then in the Window menu select
Split


Calc immediately divides up the worksheet into four sections, using a
vertical and a horizontal split bar (Fig. 5.14).
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Fig. 5.14 Calc’s vertical and horizontal split bars

The split bars are grey so not that obvious, especially with other cell
lines all over the place, but look carefully and you’ll see them well
enough.

The vertical and horizontal split occurs at the point in the spreadsheet
where you have a cell selected. You can change the position of the split
bars by positioning the mouse arrow on a split bar and dragging across
or down the screen. Try this for practice


Position the mouse arrow on either the vertical or horizontal split
bar (you’ll get a cross-hair cursor) and drag across or down the
screen

Now grab each of the scroll bars and check out the data in each of
the four panes




Notice how easy it is to compare different parts of a spreadsheet in
this way.


Finally, in the Window menu select Split again to turn off
the panes option


5.4 mAKING changes to the look of the spreadsheet

In Lesson 4 you learned how to change the width of columns and the
height of rows. Now you are going to learn how to put borders around
selected cells and how to remove the grid lines and column and row
headings.

Putting a border around a cell or set of cells

Before you can make any changes, you need to remove Protection from the
worksheet. Let’s do that before proceeding with the tutorial.


In the Tools menu select Protect Document and in the sub
menu select Sheet to remove the check mark there, thus
removing Protection on the Gradebook sheet


Now let’s make some more changes to the Gradebook. For example, you may
want to put a box around certain sections of your spreadsheet, such as
the Class info in cells A4 through B6. This will make the information
stand out on the sheet. Try this now.


Drag across the six cells A4 through B6 to select the set of
Class info, then, in the Format menu select Cells… to
bring up the Format Cells dialog box (Fig. 5.15)
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Fig. 5.15 Calc’s Borders options for cells or groups of cells


In the dialog box, click on the Borders tab (Fig. 5.15 above)


As you can see, the Borders dialog box gives you various options.


In the Line Arrangement section, click on the icon to Set Outer
Border Only then, in the Line section (see Fig. 5.15 above),
increase the Line Width to 2.00pt and the Line Color to
Green, then click on OK


The Class Info now has a distinctive green border around it, setting it
off from the rest of the data in the Gradebook (Fig. 5.16).
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Fig. 5.16 Spreadsheet cell with border

Removing grid lines and column and row headings

Grid lines and column and row headings are essential when developing a
spreadsheet or when you are updating the data. But for reporting
purposes it may look better, perhaps even easier to read, if they are
removed. You may recall doing this in Lesson 4, specifically in order to
print the spreadsheet without column and row headers and gridlines.
Here, however, you want to remove the column and row headers and
gridlines in the spreadsheet as it appears on the computer screen.


In the View menu select Column and Row Headers to remove the
headers then, in the Formatting toolbar, click on the tool to
Toggle Grid Lines for Current Sheet (Fig. 5.17)
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Fig. 5.17 Removing grid lines and column and row headings

No problem. The spreadsheet now looks quite different, as you can see.
For the next exercise, however, it will be best to have the Gridlines
and Headers showing in the Gradebook.


In the View menu select Column and Row Headers again to put
back the headers, then, in the Formatting toolbar, click on the tool
to Toggle Grid Lines for Current Sheet (Fig. 5.16 on previous
page)


Updating the Grades Template spreadsheet

You are now going to make the same changes to the Grades Template that
you just made to the Gradebook. To do this, it will be easiest if you
have both spreadsheets side-by-side on your screen.


Click on File > Open, then navigate to your disk
drive/USB drive > Work Files for LibreOffice >
Miscellaneous Files > Templates folder and open the
Grades Template


Now you should have both the Gradebook and the Grades Template open on
your screen.


If you have a large enough screen, use the mouse to drag each window
so they are side-by-side (Fig. 5.18)
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Fig. 5.18 Spreadsheets arranged side-by-side

If you are using a computer with a smaller screen, the two spreadsheets
can be layered on top of one another and you can toggle back and forth
using the Window menu (Fig. 5.19).
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Fig. 5.19 Using the Window menu to toggle back and forth between
spreadsheets

What you’re going to do now is update the Grades Template spreadsheet
with the same format and functions as the Gradebook spreadsheet so that
you could use the template in the future.

Hint: Use Copy and Paste to complete many of the tasks. DON’T
transfer any of the actual student data from the Gradebook to the
Grades Template—only transfer the functions and other formatting
features you added to the Gradebook.

Fig. 5.20 illustrates what you need to do—read the directions carefully
before you proceed.
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Fig. 5.20 Making updates to the Template


Go ahead now and update the Grades Template by putting a box
around the 6 Class info cells (A4 thru B6), then Copy and
Paste the columns of TOTAL and PERCENT formulas (


When you are done, your Grades Template spreadsheet will look like Fig.
5.21.
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Fig. 5.21 Grades Template spreadsheet after updates


Save the Grades Template when you have finished making the changes


Your next task is to once again protect the cells in the Gradebook
spreadsheet and also reset the protection on the worksheet. First you
must make the Gradebook the active document on the screen.


In the Window menu, click on the Gradebook.ods so as to make
this the current spreadsheet on the Desktop


Now you can go ahead and protect the Gradebook spreadsheet.


Press Ctrl-a to Select All the cells in the spreadsheet (this
is the quickest way to select all the cells in the spreadsheet, but
you may recall that you can also click in the small box in the top
left corner of the row and column headings)

From the Tools menu select Protect Document and click
Sheet… in the sub menu

In the Protect Sheet dialog box that pops up, click to remove the
check mark next to Select unprotected cells (see Figs. 5.12 and
5.13 on pages 142 and 143) then click on OK, and Save your
work




It might be a good idea to take a break at this point in the tutorial.
But if have time, and you feel up to it, proceed directly to the next
section, Section 5.5, on the next page, and learn all about the LOOKUP
function.

Time for a break?

FEEL FREE TO TAKE ONE…

THIS MIGHT BE ENOUGH FOR TODAY!

5.5 USING the Lookup function

The concept of the LOOKUP function

The LOOKUP function is a simple logic tool that you can use to
automatically assign grades to students based on the numbers in the
Percentage column of your spreadsheet (column L).

You are probably aware by now that if you have the automatic
calculation option selected, Calc carries out function-based
calculations as you make changes in a spreadsheet. Thus, once you have
programmed Calc to LOOKUP the grades, the system will automatically
update each student’s Letter Grade, along with Totals and Percentages,
even as you enter new scores for assignments, homework, tests, and so
forth.

Thus, with no effort on your part, you will be able to keep students
informed at any time during the semester as to exactly what grade they
currently carry for the class.

Fig. 5.2 illustrates the LOOKUP Table that will be the outcome of this
exercise.
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Fig. 5.22 LOOKUP table

You are going to tell Calc to compare a student’s percentage with the
range of values in the first column of the table. These are control
percentages. Calc will search through this first column, looking for
the highest value (percentage) that is less than or equal to the
student’s percentage. Once that value is located in the first column,
the function will assign the student the letter grade that is adjacent
to it in the second column.

Does that make sense? An example will help. Suppose the student’s
percentage is 87%. Well, in the table above, the highest value in the
first column that is still less than or equal to 87% is 80%, is it
not? 70%, 60%, and 0% are less than or equal to 87%, but they are not
the highest value that is less than or equal to 87%. So 80% is the
value that Calc will select from the Range column in its LOOKUP of the
table. The letter grade from the corresponding cell in the second
column—in this case a “B”—will then be posted to the GRADE column of
the Gradebook.

Once you understand the concept of “the highest value less than or equal
to another number”, the rest is easy. Here are a few student percentages
to try for yourself. Complete the exercise that follows.

From Fig. 5.22 above:


What is the highest value less than or equal to 45%, and what is the
resulting letter grade?_____________

What is the highest value less than or equal to 67%, and what is the
resulting letter grade?_____________

What is the highest value less than or equal to 59%, and what is the
resulting letter grade?_____________

What is the highest value less than or equal to 100%, and what’s the
resulting letter grade?_____________




The answers are in the footnote at the bottom of the page.[^2]

There are two parts to incorporating the Calc LOOKUP function into
your Gradebook. First you must build the LOOKUP Table into the
spreadsheet. Second you must enter into the appropriate cells the LOOKUP
function that will instruct Calc to carry out the LOOKUP operation.

Building the LOOKUP Table


You’ll need both the Gradebook (which you saved in the Data
Files folder in the Spreadsheet Documents folder) and the
Grades Template (which you also saved in the Data Files folder
in the Spreadsheet Documents folder) to complete the remainder of
this tutorial, so if these documents are not already open, open them
both now from your Work Files for LibreOffice folder before
proceeding

Next, in the Window menu select the Gradebook, if it is not
already the active window on the screen




Since all the cells are protected in the Gradebook, you’ll need to
unlock them first in order to make changes.


From the Tools menu select Protect Document, then make sure,
in the sub menu, that there is no check mark next to Sheet


Now, let’s build the Lookup table that’s illustrated in Fig. 5.22 above
(page 150). The first column of the LOOKUP Table (the lookup vector) has
a set of numbers which Calc calls the Search vector.

A vector is just another name for a single column of numbers. The
Search vector contains the set of values against which Calc compares
the data from a selected cell in the Gradebook.

Let’s create this column (vector) of the LOOKUP table first. As you work
your way through this exercise, be sure to hit the number 0 (zero),
NOT the letter O; they are so close together on the keyboard that some
students hit the wrong character by mistake.


Select cell P1 and type the column header Range (%) then press
Enter to move down to cell P2

Type 0 (the number zero (0) that is) in cell P2 and press
Enter to move down to cell P3

Type 0.6 (this is equivalent to 60% in mathematical terms) and
press Enter again to select cell P4

Type 0.7 and press Enter to make P5 the current cell

Type 0.8 and press Enter once more

Type 0.9 in cell P6 and press Enter again to make P7
the current cell

[image: ]Finally type 1 (this is equivalent to 100%
in mathematical terms) and click on the Accept ( ) button




Now you need to change the cell attributes of this first column of the
table so as to display the numbers in percent form (with the percent
(%) symbol). You did this before in Lesson 4, so the following is just a
reminder of how to do this.


Drag down to highlight all 6 of the values from cell P2 to
cell P7

In the Formatting toolbar click on the % (Percent) symbol to
change the format of the decimal numbers to percentages




That completes the first column of the table. Now for the second column
with the letter grades—what Calc calls the result vector. The
result vector contains the values which Calc returns to the
Gradebook cell which contains the formula which calls on (references)
the LOOKUP function.


Select cell Q1 and type the header Grade (A-E), then press
Enter to move down to cell Q2

Type the letter E (or whatever you would use for a failing grade)
and press Enter to go to cell Q3

Type a D and move down to cell Q4, then type a C and move
down to cell Q5

Type a B and move on down to cell Q6, then type an A and
move down to cell Q7

[image: ]Finally type an A again in cell Q7 and
click on the Accept ( ) button




The table is now almost ready for use. One more cosmetic adjustment will
improve its appearance.


Select the complete LOOKUP table in columns P and Q by
dragging across the column headers P and Q at the top of
the columns then, in the Home Ribbon > Paragraph Group,
click on the Center icon


Your LOOKUP Table should now look like Fig. 5.22 on page 150.


Save all your hard work before proceeding with the tutorial


Using the clipboard to copy cells from one document to another

Now that you have completed the task of building the LOOKUP Table in the
Gradebook spreadsheet you should update the Grades Template along the
same lines. First you must copy the relevant cells (those used for the
LOOKUP Table) from the Gradebook spreadsheet to the clipboard and then
paste them into the Grades Template spreadsheet. Here are the steps.


Select cell P1 and drag down diagonally across the LOOKUP
Table to cell Q7

Press Ctrl-c to copy the LOOKUP Table to the clipboard

Now switch to the Grades Template by switching windows in the
View Ribbon > Window Group or, more simply, just clicking
in any cell in the Grades Template

In the Grades Template, click on cell P1 to make it the
current cell

Press Ctrl-v to paste the LOOKUP Table from the clipboard to
the Grades Template, then Save your work (Ctrl-s) once
more




Entering the LOOKUP function into the Grade column

Take a moment to understand the next step in using the LOOKUP table.
Recall that the LOOKUP function instructs Calc to look up a table that
you have built and come back with a corresponding result to store in the
spreadsheet proper. Still confused? Maybe the following will help you
figure it out. The LOOKUP function has the following parts to it:


=LOOKUP(Search criterion,Search vector,result_vector)


Let’s examine each part of this function in order to understand how it
works.


	The “=” symbol at the start of the function simply tells Calc that
a function or formula is in the cell, as opposed to ordinary data
such as numbers or labels.




	The word LOOKUP tells Calc what task to carry out (look
something up in a list).




	Search criterion, Search vector, and result_vector are
variables (control values) that Calc uses when it is looking up
the table in columns P and Q:




	the Search criterion is either a number or text (such as a
person’s name); this value will be the “key” that Calc will
use as it searches through the cells in the Search vector or
column;




	the Search vector is the column of cells that Calc has to
check in its lookup of the table (column P in Fig. 5.22 on page
150);




	the result_vector is the column of cells in which Calc will
find the result of the LOOKUP operation (Column P in Fig. 5.22 on
page 150).



Still confused? Don’t feel bad; this is definitely tricky stuff. Maybe
an example will help you understand how the Lookup function works. It
will be easiest for you to follow the next exercise if you have an
actual grade book to work with.


The Grades Template and Gradebook spreadsheets should still be
side-by-side on your screen, so switch back to the Gradebook (use
the Window menu to Switch Windows for this or click on any
cell in the Gradebook)


Make sure you have at least the LOOKUP Table (columns P and Q)
showing on the screen, as well as columns M thru O of the
Gradebook containing the PCNT and GRADE data.


Scroll over if necessary until you have columns M thru Q showing
on the screen, with the LOOKUP Table at the top of the screen (Fig.
5.23)
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Fig. 5.23 Spreadsheet showing the Lookup Table


Select cell O14 (Fig. 5.23 on previous page)


This is the first cell in the GRADE column. You want Calc to use the
LOOKUP function to figure out the letter grade for each student and
display it in this column (Column O). So the LOOKUP function must go in
each cell of Column O.


Click on the Function Wizard icon (fx) in the data entry
bar towards the top of the spreadsheet window, then in the Function
Wizard dialog box select the Spreadsheet category and locate and
double click on the Lookup function to select it (Fig. 5.24)
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Fig. 5.24 Function Wizard dialog box before defining Lookup function
criteria

Notice in Fig. 5.24 that the cursor is positioned between the brackets
after the word =LOOKUP (|) in the formula area of the dialog box.
The three sets of data for the LOOKUP function will appear there as you
complete the steps that follow.


If the Function Wizard dialog box is covering the cells you need
to work with (column M and the Lookup Table in columns P and
Q), slide the Function Wizard dialog box down and off to the
right or left on the screen so that the dialog box is out of the way


On the right side of the Function Wizard dialog box in Fig. 5.24
above, you see three data entry boxes for the set of arguments (Search
criterion, Search vector, result_vector) which you need to fill out.

In Fig. 5.25 below you see the end result of this task, with the set of
arguments (Search criterion, Search vector, result_vector) filled out
relative to cell M14. Your task now is to reproduce this yourself.
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Fig. 5.25 Function Wizard dialog box showing the Spreadsheet > Lookup
function

Entering the Search criterion in the dialog box

Each student’s Percentage will determine the Letter Grade, so the
percentage is what we want Calc to use as the Search criterion to find
the letter grade from the Lookup Table.


In the Gradebook spreadsheet, click on cell M14 and notice
that M14 is immediately entered into the Search criterion data
entry box and also between the brackets after =LOOKUP (|)—you
should now see =LOOKUP (M14) there


So Calc enters this cell’s coordinates as the first of the LOOKUP
parameters, the Search criterion. You are telling Calc that it must
use this first student’s percentage as the value to check against the
first column of the LOOKUP Table (cells P2 through P7).

Entering in the Search vector

Cells P2 through P7 are the Search vector for the LOOKUP Table.


In the Function wizard dialog box, click to position the cursor in
the second data entry box—the Search vector entry area (see
Fig. 5.25 above)—so you can enter the cells which contain the Search
vector

Now, in the Gradebook spreadsheet, use the mouse to drag down
from cell P2 to cell P7




Notice that in the data entry bar Calc fills in the second of the
LOOKUP parameters for the LOOKUP function, namely the Search vector.
It also appears between the brackets after =LOOKUP (M14,P2:P7). Check
that it also appears in the Gradebook spreadsheet in the Data entry bar,
too. You are almost done with building the LOOKUP function.

Entering the result_vector

Cells Q2 through Q7 are the result_vector for the LOOKUP Table.


Click to put the cursor in the third data entry box so you can
specify the cells that contain the result_vector, then, in the
Gradebook spreadsheet, drag down from cell Q2 to cell Q7


Notice, once again, that Calc fills in the third of the =LOOKUP
(M14,P2:P7,Q2:Q7) parameters, the result_vector.


In the Gradebook spreadsheet itself, check the data entry bar
to see that the LOOKUP function is now complete—at this stage it
should read =LOOKUP(M14,P2:P7,Q2:Q7)

Finally, click on OK and Save your work




Applying the function

Calc will look for “the highest value in cells P2 through P7 that is
less than or equal to the student’s percentage”.


Take a look at cell O14 now and verify that it contains the
correct letter grade according to the value in cell M14 (the
percentage for this first student)


As you see, once the LOOKUP function has located the correct cell in
column 1 of the Lookup Table (the Range column), all that remains is for
Calc to make a note of the letter grade that is in the corresponding
cell in column 2 of the table (the Grade column), and the LOOKUP
function copies that grade into cell O14.

Don’t feel bad if your eyes are starting to glaze over; this is kinda
nerdy stuff. But hang in there, we’re nearly done.

Copying the LOOKUP function into the rest of the GRADE column

The first student’s grade is taken care of. The next task is to copy
this function from cell O14 down to the other cells in the GRADE column
(column O), but this is not as simple as it seems because we have to
consider the problem of Absolute and Relative cell references.

If you want to try and do this on your own (you will need to understand
the concept of Absolute and Relative references!), go ahead. If you are
successful you can skip the rest of this sub-section and go to the
Practice makes perfect section on the next page.

If you need help completing the LOOKUP function, read on to follow the
steps to correctly Fill down the LOOKUP function to the remaining
cells in column O.

First you must make a small change to the function itself. You also need
to put your thinking cap on, because if this is the first time you’ve
used a LOOKUP function, it can get mighty confusing.

You may recall learning about Relative and Absolute cell references in
Lesson 4. The function =LOOKUP(L14,P2:P7,Q2:Q7) will work fine for the
first student, but if you copy it to the other cells as is, Calc will
assume that all the cell references in the function are relative to
the cell into which they are being copied, and will adjust them
accordingly, resulting in the WRONG letter grades. If you enjoy math or
logic, you’ll be enjoying this; but if not, bear with us, OK?

What you have to bear in mind is that the references to the LOOKUP Table
(cells P2:P7 and Q2:Q7) must be absolute references—which means any
references to those cells must not change—because the data for the
LOOKUP Table will absolutely always be found in these specific
cells.

So you need to tell Calc to leave these LOOKUP Table references
unchanged when copying the LOOKUP function into the other cells in
column N. You do this by surrounding the LOOKUP Table’s cell coordinates
with $ (dollar) signs. Like this:


=LOOKUP(L14,$P$2:$P$7,$Q$2:$Q$7)


The reference to the lookup value (cell M14 for the first student) is
relative, and will be different for each student (M15, M16, and so
on), so it doesn’t need to have dollar signs around it. But the
references to the Search vector and to the result_vector are
absolute—fixed because they refer to the LOOKUP table in columns P and
Q.

Here is a reminder of the steps to tell Calc to treat references as
Absolute References when referring to the LOOKUP Table.


Click on cell O14


Take a look at the Data Entry bar at the top of the screen and you’ll
see that the LOOKUP function is spelled out in full (Fig. 5.26). It just
needs all those $ signs around the references to the cells that make up
the LOOKUP table.
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Fig. 5.26 LOOKUP function for cell N14


In the Data entry bar (Fig. 5.26 above), in the LOOKUP
formula, click to put the cursor immediately before the reference to
cell P2

Now put a dollar ($) sign in front of every coordinate (rows
and columns) for the LOOKUP Table (8 $ signs in all) as
illustrated in Fig. 5.27
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Fig. 5.27 Absolute references are preceded by dollar ($) signs

This will ensure that this part of the function will remain unchanged
(“absolute”) when you copy it shortly into the other cells in column O.


[image: ]Click the Accept button ( ) to accept the
LOOKUP function into cell O14


Here now are the steps to copy the function from cell O14 into the
remaining cells of the GRADE column (Column N).


Make sure the current cell is still cell O14

Grab hold of the small Fill handle in the lower right corner
of cell O14, drag down to cell O23 and let go of the mouse
button (or take your finger tip off the screen if you’re using a touch
screen)




You now should see the correct letter grade for each student in column
O.


While you have the cells in column O highlighted, center the
grades in the column (Formatting toolbar > Center icon)

Save the changes you have made to the Gradebook spreadsheet




If you need to think about the LOOKUP function a little more, go
carefully back over what you have just done. Once you have a clear idea
of how the LOOKUP function works, you and your students will be able to
apply it in myriad situations when you build spreadsheets of your own.

Practice makes perfect

Your task now is to switch to the Grades Template again, and add the
LOOKUP function there, too. You do not have any data in the template (or
at least you shouldn’t have!), so your LOOKUP function will produce a
column of meaningless grades (all E’s!) in the GRADE column, just as was
the case when you built a function into the PCNT column of the Grades
Template when you were working on Lesson 4. This is no problem, because
the data will be relevant and correct when you use the spreadsheet with
an actual class of your own and enter meaningful sets of scores,
as is the case in the Gradebook itself.

You either can add the functions to the Grades Template the long way, by
repeating all the steps you just carried out for the Gradebook cell by
cell, or you can use the Copy (Ctrl-c) and Paste (Ctrl-v) functions
as you did a short while ago to copy the LOOKUP Table from the one
document to the other.


Go ahead and copy the grades formulas in column O from the
Gradebook to the Grades Template; don’t forget, when you’re
done, to Save the changes you have made to the Grades Template
spreadsheet, then close the Grades Template


Finally in this exercise you must protect the Gradebook worksheet so
that no one can make unauthorized changes to the data in the cells.


Select all the cells in the Gradebook worksheet (Ctrl-a),
then, in the Tools menu > Protect Document click, in the
sub menu, to put a check mark back in front of Sheet…

Do the same for the Grades Template worksheet

Save your work and close just the Grades Template




You should now have only the Gradebook open on your screen.

5.6 PRINTING THE UPDATED SPREADSHEET

You’re going to print out the Gradebook twice. Here are the steps for
the first printout.

It is usually best to print a spreadsheet in landscape (sideways)
orientation.


In the Format menu > Page… dialog box, in the Orientation
section, click on the radio button next to Landscape
Orientation


You need to take care of a couple of other details before clicking on
the Print button. The printed spreadsheet will look better if you remove
column and row headings as well as the cell gridlines.


In the View menu click on Column & Row Headers to remove the
check mark there, thus removing column and row headers from the
spreadsheet

Next remove the gridlines by clicking, in the Formatting toolbar,
on the Toggle Grid Lines for Current Sheet icon (Fig. 5.28)
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Fig. 5.28 Toggling gridlines on and off

**Selecting a section of the spreadsheet for printing **

When you first print out your Gradebook, you do not want the LOOKUP
Table to appear on the printed report. You want to print only that block
of cells that contains the data pertaining to student grades for the
semester. This includes columns A through O and Rows 1 through 27.

The steps that follow will show you how to select just this block of
cells for printing. First you must select (highlight) the range of cells
that you want to print.


Drag down diagonally from cell A1 to cell O27 (this will
include the Average, Max Score, and Min Score summary
lines at the bottom of the Gradebook, but not the cells with the
LOOKUP table)

Now, from the File menu select Print to bring up the Print
dialog box (Fig. 5.29)
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Fig. 5.29 Setting the Print area in the Print dialog box

Notice that in the Print dialog box you have a Preview of the worksheet
before printing. Your spreadsheet has just one page. If you wanted to
check how many pages there are in your spreadsheet before printing, you
would find the answer underneath the Print Preview window (it reads 1
of 1 for this spreadsheet).


Check out how the spreadsheet looks in the Preview window, then
click on OK to print out the first hardcopy of the Gradebook


Now you are going to print a second copy of the Gradebook, but this time
you will include the LOOKUP table, the Column and row headers and the
gridlines.


In the Gradebook, drag down diagonally from cell A1 to cell
Q27 (this will include the LOOKUP table in columns P and Q)

In the View menu select Column & Row Headers to put back the
check mark there, then bring back the gridlines by
clicking, in the Formatting toolbar, on the Toggle Grid Lines
for Current Sheet icon (Fig. 5.28 on page 174)

Now, from the File menu select Print and, in the Print
dialog box make sure the radio button next to Selected cells
is on (check the Print Preview window to make sure the
LOOKUP table is included in this second printout), then click
on OK to print this second copy of the Gradebook
spreadsheet

If you are completing the lesson for a class at school, hand in both
hardcopies of the spreadsheet to your instructor




5.7 Creating charts based on SPREADSHEET data

The Calc charting capability

Calc makes it easy to create dozens of different types of charts. You
can create a chart from information gathered in most any spreadsheet. In
the next Lesson (Lesson6) you’ll learn how to incorporate a chart into a
Writer document.

A spreadsheet user can take advantage of charts based on the numbers
stored in its rows and columns of cells. The numbers on their own may
not provide much information. Charts based on those numbers, on the
other hand, may enable the user to visualize the data. “A picture,” as
they say, “is worth a thousand words.”

Creating a Column chart

For this exercise, we’ll set aside the work we’ve been doing with the
Gradebook. You are going to open a new grades spreadsheet so that you
can practice creating charts.


Go to File > Open and navigate to your Removable Disk


Work Files for LibreOffice > Miscellaneous Files >
Other Documents folder and open the Charts spreadsheet





Your Charts spreadsheet should look like Fig. 5.30.
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Fig. 5.30 Data for the Charts spreadsheet

The values represented in a chart are called a data series or a data
set. In the chart you are about to create, the number of students in
the various grade ranges (A, B, C, etc.) will be represented by bars.
The chart will have a title and a legend with names descriptive of
the data series.

Most charts, except pie charts, have axes, which are the perpendicular
lines along which the data are plotted or displayed. The Y axis is the
vertical axis (running from top to bottom). The X axis is the
horizontal axis (running from left to right).

To create a chart in Calc, you must first designate the set of cells
in the spreadsheet that you want included in the chart. This is called
the chart range. Let’s select the Chart Range now.


Select, by dragging and highlighting, cells A1 through F2


Now, let’s check out each of the various categories of LibreOffice
charts.


In the Standard toolbar, click on the Chart tool (Fig. 5.31)
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Fig. 5.31 The Chart tool in the Standard toolbar

This immediately brings up a basic chart (a bar chart) based on the data
highlighted in the spreadsheet, and also offers the Chart Wizard dialog
box (Fig. 5.32).
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Fig. 5.32 The LibreOffice Chart Wizard

The Chart Wizard dialog box opens up a world of opportunities to create
other eye-catching and, more importantly, effective chart
styles—effective, that is, in the sense of getting the true meaning of
the data across.


In the Chart Wizard dialog box > Choose a chart type menu,
click on Column (Fig. 5.33 on previous page), and look at the many
different types of Column Charts you can work with, from Plain
to 3D charts (including Box, Cylinder, Cone, and Pyramid charts)

Click on the Bar chart type and look at the different types of
Bar Charts

Click on the Pie chart type and look at the different types of
Pie Charts

Click on the Area chart type and look at the different types
of Area Charts

Click on the Line chart type and look at the different types of
Line Charts

Click on the XY (Scatter) chart type and look at the different
types of Scatter Charts

Click on the Bubble chart type and look at the different types
of Bubble Charts

Click on the Net chart type and look at the different types of
Net Charts

Click on the Stock chart type and look at the different types
of Stock Charts

Finally, click on the Column and Line chart type and look at
the different types of Column and Line Charts




Quite a selection—dozens of different kinds of charts. But let’s focus
for now on the Column charts.


After you have checked out the various chart types, in the Chart
Wizard dialog box, click on the Column charts type

In the Column Charts options, click to put a check mark in the
box next to 3D Look (Fig. 5.31 on the previous page) then, in the
Shape menu, click on Box (Fig. 5.31 again), and then click on
the Normal type




Immediately Calc creates the chart and displays it on the screen (Fig.
5.33).
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Fig. 5.33 A 3D Normal Box chart based on the spreadsheet data

Notice that Calc has automatically put the grades along the (horizontal)
X axis and the scale indicating the number of students “in Range”—i.e.
the number of students with each grade—along the (vertical) Y axis.

One change you need to make right now is to the chart title. It should
say something like “Class Grades Distribution.” While we’re doing that
we can make a couple of other changes as well.


In the Chart Wizard > Steps section, click on 4. Chart
Elements (Fig. 5.34)
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Fig. 5.34 Chart Wizard > Chart Elements dialog box


In the Chart Elements dialog box, fill out the Title,
Subtitle, X axis, and Y axis as per the data in Fig.
5.34—leave the check mark in the box next to Display legend
and click on Finish


The end result will look like Fig. 5.35.

[image: ]

Fig. 5.35 The final version of the 3D Column chart


Go to File > Save As… and, in your Work Files for
LibreOffice > Data Files > Spreadsheet Documents
folder, save the chart with the name Column Chart, then remove it
from the spreadsheet window before the next exercise


Creating a pie chart

Creating a pie chart is straightforward (not to say easy) if you just
successfully completed the Column chart exercise. You will use the same
set of data for the exercise that follows.


Drag to select cells A1 through F2, then, in the Standard
toolbar, click on the Chart tool to bring up the Chart
Wizard (Fig. 5.32 on page 177), and then, in the Choose a chart
type menu, click on Pie

In the Pie Charts dialog, click to put a check mark next to
3D Look and, in the 3D Look menu select the Simple option

In the Chart Wizard, click on each of the four Pie Chart styles
and check them out




The style of Pie Chart you are going to work with is the Exploded Pie
Chart (Fig. 5.36).
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Fig. 5.36 Exploded Pie Chart Style


In the Steps section on the left of the Chart Wizard dialog
box, click on 4. Chart Elements and change the Title to
Class Grades Distribution as you did for the Column Chart, with a
Subtitle of Grade 4 2014

Leave the check mark in the box next to Display legend and
click on Finish

Now, right click on any of the slices in the Pie chart
and, in the context menu that pops up, select the option to
Insert Data Labels




This puts a label on each of the slices indicating how many students got
that particular grade, thus adding information to the chart. It would be
helpful if the Font size were bigger on each of those slices and maybe
the color white would stand out more against the colors of the various
slices. This is easy enough to do.


Right click again on the number on any one of the slices in
the Pie chart and, in the context menu that pops up, select
the option to Format Data Labels


This brings up the dialog box titled Data Labels for Data Series
“Students in Range” (Fig. 5.37).
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Fig. 5.37 Changing the Font and Size of the Data labels in a Pie chart


Click on the Font tab and change the Style to Bold and the
font size to 18, then click on the Font Effects tab and
change the Font Color to White


There, that’s better (Fig. 5.38).
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Fig. 5.38 Final version of the Pie Chart


Save the chart in your Data Files > Spreadsheet
Documents folder with the name Pie Chart


That’s all you want to do with the pie chart, so you might as well
remove it from the spreadsheet window before the next exercise.


Left click on the border of the Pie chart to select the
whole chart and not some piece of the chart’s contents, then hit
the Del(ete) key


Creating a bar chart

One last Chart type will suffice for you to get the hang of creating
charts using spreadsheet data. This time you’ll create a 3D Bar chart.


If necessary, drag to select cells A1 through F2, then, in the
Standard toolbar, click on the Chart tool to bring up the
Chart Wizard (Fig. 5.34 on page 179), and then, in the Choose a
chart type menu, click on Bar

In the Bar Charts dialog, click to put a check mark next to
3D Look, then in the 3D Look menu select the Simple
option, and in the Shape section select Cylinder

Of the four Styles of Cylinder Bar Charts, select the first
(Normal) style, then, in the Steps section of the Chart
Wizard, click on Chart Elements and type the Title Class Grades
Distribution, with the Subtitle Grade 4 2014

Click the Finish button, then right click on any of the
Bars in the Bar chart and, in the context menu that pops
up, select the option to Insert Data Labels

In the Data Labels dialog box, click on the Font tab and
change the Style to Bold and the font size to 18, then
click on the Font Effects tab and change the Font Color to a
color of your choice




The end result might look something like Fig. 5.39.
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Fig. 5.39 Final version of the Bar Chart


Save the chart in your Data Files > Spreadsheet
Documents folder with the name Bar Chart, then close the
spreadsheet


SKILL CONSOLIDATION

Complete these exercises to reinforce what you have learned in Lesson 5.

1. List at least 5 applications, other than those presented in these
tutorials, for which you think you would use the Calc spreadsheet in a
classroom environment.

2. Either alone, or with a group, develop templates for each of the five
spreadsheets identified in exercise 1. This could be an excellent class
project. Each team would develop a different set of templates. Then all
groups would present their results for review by everyone else in the
class, and the complete set of templates could be made available on disk
for everyone to take away from the course.

3. Load the Gradebook to the Desktop.


• Add the function to calculate the average score for each of the
tests, quizzes, homework, etc. The system will add up all the scores
and divide by the number of cells that contain scores to arrive at the
average. You should use the copy function to duplicate the functions
across the spreadsheet.

• Save the updated spreadsheet.

• Print out only the columns that contain the student names and the
final totals and percentages (so you will need to temporarily delete
the columns in between—don’t save this!)




4. Load the Gradebook onto the Desktop.


• Add a new column for another set of scores

• Add a new row for another student

• Update the functions where necessary

• Sort the student records based on the First and Last Name columns

• Save the updated document




5. Create a line chart based on a set of values for populations in
several cities in the U.S. Generate a Bar chart from the data. Research
the populations on the web at
http://www.census.gov/popest/states/NST-ann-est.html

6. Create a pie chart based on a set of values for the amount of
rainfall for each of any ten cities world wide. Research the rainfall
data at this web address: http://www.worldclimate.com

[^1]: Your formula should look something like this: =SUM(D14:D23)/10

[^2]: 0% (E); 60% (D); 0% (E); 100% (A)
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Lesson 6 Introduction to the BASE  database



6   Introduction to the BASE DATABASE

      Keeping student records







LEARNING OUTCOMES

This tutorial will introduce you to the following:


• the general idea behind a database

• planning a new database

• creating a database template

• adding records to a new or existing database

• viewing the data in a database

• clearing entries and records from a database

• making a backup copy of a database




BEFORE YOU BEGIN

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (6.1 An Overview
of the Database Concept—next page). If you did not complete Lesson 1,
then you must do this now, before proceeding with the rest of Lesson 6.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to prepare these folders now before proceeding with
this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will
help you with this if you are working with a class) and Extract
them onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 6.1).
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Fig. 6.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 6.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

6.1 AN OVERVIEW OF THE DATABASE CONCEPT

How is a database organized?

Base is an object-oriented relational database management system. It
is designed to help an organization—such as a company or an institution
or a school or school district, and also the individual teacher—to
collect, organize, manage, and store data in such a way that they can be
easily accessed and made available to users in a variety of useful ways.

The various types of database objects that you can create using Base
are listed in the Database Objects menu in the left hand frame of any
LibreOffice database that you open, as illustrated in Fig. 6.2.
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Fig. 6.2 The Base database objects

Let’s take a look at each of these objects now to see how they can be
used to help you organize and access the information collected into a
database (in this case a database of information about different birds).


	A Table is the fundamental object in a relational database and


tables use rows and columns to present the data—rather like
a spreadsheet. You will learn about Tables and in this lesson, as
well as how to use the Design View to create a table, add fields
to a table, and define the type of data that is in a
specific field.






	A Query makes a request to the database, asking it to find some


specific data that are stored in the database. You will learn more
about queries in Lesson 7.






	A Form gives the user another way of looking at the data in


the database. Whereas a Table allows the user to view many records
at once, a Form displays the contents of just one record at a
time. Forms are very useful for entering data into new records or
updating the data in existing records. You will learn about Forms
in this lesson.






	A Report is used to present a selected set of information from a


database in a format that is neatly laid out and thus easier for
the user to mentally digest. You will learn about reports in
Lesson 7.








Base database terminology

A Base database is able to contain thousands, hundreds of thousands,
even millions of records. Records contain fields. Each field contains
entries made up of text and numbers, which are the basic building
blocks of data.

6.2 LET’S TAKE A LOOK AT AN EXISTING BASE DATABASE

It will be useful for you at this stage to see an actual Base
database.


Open LibreOffice > Base Database


Base presents you with the Database Wizard dialog box (Fig. 6.3).
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Fig. 6.3 The Database Wizard dialog box

This Wizard will step you through the process of either creating a new
database or opening an existing database or even connecting to an
existing database online.

Since you haven’t yet opened any Base files, you are offered the
opportunity to Create a new database. But instead you are going to
open a database that has already been created for you to work with in
this first section of the tutorial.


So, as illustrated in Fig. 6.3 on the previous page, click on the
radio button next to Open an existing database file, then
click on the Open button


This brings up the Open window.


In the Open window, navigate to your USB drive > Work
Files for LibreOffice folder > Base Files folder and double
click on the Birds database to Open it


In the Birds database dialog box you see the icons for the LibreOffice
Base database objects (Tables, Queries, Forms, and Reports), which are
listed one of top of the other in the Database menu on the left side
of the Birds database window (Fig. 6.4).
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Fig. 6.4 How do you want to view the data in the database?

One way to view the data is as a Table, where the data for all the
records in the database are displayed in columns or as a list—much like
in a spreadsheet (Fig. 6.5).
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Fig. 6.5 The Table View of the database

In the upper left corner of the Table window, in the window’s Title bar,
you see the Table name—Bird Sightings Table (Fig. 6.5 previous page).

In the lower left of the Table window are tools for you to access
specific records in the database (Fig. 6.6).
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Fig. 6.6 Navigation tools in the Base database

There are 50 records in the Birds database. The field names (Common
Name, Family, Size, etc.) are at the top of each column of data (Fig.
6.5 previous page). As you can see, the screen is not big enough to
allow you simultaneously to see all the records in the database. If
you want to scroll through the records or look at any specific record,
you have several options.

You can use the scroll bar on the right of the screen to scroll through
the records.


Try this now


To move one by one through the records, you can click left or right on
the arrows in the navigation tools in the lower left of the window (Fig.
6.6 above).


Try this now


To go directly to a specific record, you can select the number of the
record you want to view by typing the number of that record in the small
data entry box to the left of the arrows (Fig. 6.6).


Try this now to select record 12 (type the number 12 in the
box then hit Enter) and you’ll see a small green arrow head
pointing at the record #12 in the database table (it’s a bird
called a Pintail)


6.3 planning A NEW DATABASE

So much for the nuts and bolts of databases. You are now ready to get
your feet wet planning your own database of student records.


Click on the Table’s File menu and select Close to close the
Bird Sightings Table, then in the Birds Database File menu
select Close again


Points to ponder when planning a database

There are three rules of database design:


Rule 1—Plan;

Rule 2­—Plan;

Rule 3—Plan!




The more complex the data, the more you need to plan. But even the
simplest database should be thought through on paper before being
created in Base. Poor planning often results in a database that fails
to meet longer term needs.

So think about your database ahead of time—and PLAN!!

6.4 CREATing the DATABASE TEMPLATE

You are going to start a new database for Student Records, which
initially will be a template for a database of student records because
it won’t contain any actual records right away. This way you’ll be able
to use this template database for future groups of students you may
have.


Open LibreOffice > Base Database then, in the Database
Wizard which pops up on the screen, make sure the radio button
next to Create a new database is on and click on **Next



** (Fig. 6.7)
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Fig. 6.7 Starting a new Base database


There’s no need to register the database, so click on the radio
button next to No, do not register the database, leave the
check mark in the box next to Open the database for editing,
then click on the Finish button to save the new database

In the Save As dialog box which pops up, navigate to your USB
drive > Work Files for LibreOffice folder > Data Files
folder and create a New Folder with the name Database
Documents

Double click on the Database Documents folder to Open it,
then, in the File Name data entry box, type the file name
Student Records Template and click on Save




Base now displays the newly created Student Records Template
database (Fig. 6.8).
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Fig. 6.8 The new Student Records Template database

Notice, in the Database frame on the left side of the Base window,
that the Tables object is selected (highlighted in blue). A Table is
the default object in a new Base database. To the immediate right of
the Database frame, in the Tasks frame, there are three options, the
first of which is what we want.


Click once on the Create Table in Design View option (Fig. 6.8
above)


Immediately you are presented with the Table Design dialog box (Fig.
6.9)
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Fig. 6.9 Table Design dialog box, waiting for you to till out Field
entries

On the screen, Base is waiting for you to begin typing in the field
names. Before you enter the field names, however, read what follows.


Editing field names Remember, you’re building a template so that
you can use it for other student record databases at a future date.
You can easily change, add or delete fields at any time, though the
purpose of planning is to try your best to avoid having to make
significant changes after the database has been created.

Selecting the data type of a field As illustrated in Fig. 6.9
(previous page), after typing in the field name in the first column,
you’ll need to enter the field’s data type in the second column.
Table 6.1 below has all this information, too.




Entering field names for the database

Table 6.1 contains the complete list of field names for the Student
Records Template database.




Field Name          > Field Type   Required   Length   Format Example
First Name          > Text             Yes            15Middle Name         > Text             Yes            15Last Name           > Text             Yes            15Home Contact        > Text             Yes            30Nick Name           > Text             No             15Gender              > Text             Yes            6Address Line 1      > Text             Yes            50City                > Text             Yes            25State               > Text             Yes            2Zip Code            > Text             Yes            10Phone Number        > Text             No             12Email Address       > Text             No             40Date of Birth       > Text             Yes            -            January 1, 1998
Brothers            > Number           Yes            2Sisters             > Number           Yes            2Place in Family     > Number           Yes            2Clubs               > Memo             No             -Hobbies             > Memo             No             -Favorite Sports     > Memo             No             -Favorite Subjects   > Memo             No             -




Table 6.1 Template Field Name listing

You’ll be referring to this Table frequently as you work your way
through the next several pages, so you might like to bookmark Table 6.1
in order to easily find the Table whenever you need to.

Type only the Field Names that appear in the first column of Table 6.1
(there are 20 field names in all). The second column tells you what Data
Type to choose (from a drop down list that pops up when you click on the
down arrow at the right side of the entry box.

The other columns in the table (Required, Length, and Format Example
columns) are there to help you as you enter each field name and data
type and explain whether data is to be “Required” for that field and
what size (in text characters) and format the field is allowed to be.

Now you’re ready to begin entering the data listed in Table 6.1 above
into the Table Design dialog box


Click in the first entry box in the Field Name column, then
type First Name for the field name (Fig. 6.10)
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Fig. 6.10 Field Properties and Help

Notice that, in the lower right section of the Student Records Table
window (Fig. 6.10 above), Base provides help to guide you as you enter
the data for each part of each field. Read this help as you go along. In
the lower left you can see the Field Properties dialog area.

If you take a look at Table 6.1 on page 176, the Length column
specifies the number of characters required for several of the fields in
the database.


Check Table 6.1 to find out whether an entry is required for
the First Name field (the answer is Yes) and the correct
size for the First Name field (the answer is 15 characters)

Now, look down at the lower left corner of the Table Design
window (Fig. 6.9 again), where you can see a list of Field
Properties, along with data entry boxes to specify whether an entry
is required, the entry’s Length, Format example, and so
forth

In the Entry Required box select Yes, and in the Length
box type 15 (so as to allow up to 15 characters for the First
Name)

Hit the Tab key to move the cursor over to the Field Type
column, click on the down arrow to the right of the box and
select Text [VARCHAR] as the data type

Now click in the second Field Name box (below the First
Name box) so you can enter the next database field name

Enter the field names Middle Name (15 characters), Last
Name (15 characters), Home Contact (30 characters), in
each case making sure you have Yes in the Entry Required
Field Property for each of these fields

Now enter the field name Nick Name (15 characters), but leave
No in the Required Field Property box, since a Nick Name is
optional

Next enter the following field names, in each case making sure you
have Yes in the Entry Required Field Property for each of
the fields:

Gender (M/F) (1 character)

Address Line 1 (50 characters)

City (25 characters)

State (2 characters)

Zip Code (10 characters),

Now enter the field name Phone Number (12 characters), and
Email Address (40 characters) but leave No in the
Required Field Property box in case a student’s family does not
have a phone or email address




Using a Format example to control the format for a field

You want to make sure that certain fields have a consistent format, such
as the Date of Birth field, which is next in the listing in Table 6.1 on
page 176, you want to select [DATE] as the data type for the field,
and select a Format example for it, too.


Here’s how you do this.

Enter the next field name Date of Birth, then in the Field Type
column click on the arrow to bring down the menu of Field
Types

Select the Field Type Date [Date] then, in the Field
Properties area click on the ellipses at the end of the Format
example option (Fig. 6.11)
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Fig. 6.11 Click on the ellipses to specify a Format example for the Date
of Birth field


In the Format tab > Category select Date, then under
Format select the option (December 31, 1999) highlighted in Fig.
6.12
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Fig. 6.12 Selecting a Format example in the Field Format dialog box

The remaining fields in the database (Clubs, Hobbies, Favorite Sports,
and Favorite Subjects) will all be Memo data type to allow the user to
type a longer entry if desired. Notice, in the Table on page 188, that
data entries for these memo fields are optional, so No will be the
answer to Entry required.


For each of the last four database field names (Clubs, Hobbies,
Favorite Sports, and Favorite Subjects) select the Field type Memo
and select NO for Entry required

When you have completed the entries for all 20 field names, select
File > Save As… (Fig. 6.13), and, in the Save As dialog
box type the name Student Records Table and click on OK
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Fig. 6.13 Naming the Table

Whenever you attempt to save a new LibreOffice Base table for the
first time, you are asked to define a Primary Key for the Table (Fig.
6.14).
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Fig. 6.14 Prompt to define a Primary Key

So what is a Primary Key in a database?

The purpose of a Primary Key is to enable easy manipulation of the data
across multiple database objects. If, for example, you were designing a
database for an administrative application in the Principal’s or
Superintendent’s office, or for a sizable company, this would be an
important consideration, because your database would be large, and there
would be many ways of looking at the data in the database (called
“views” on the data) represented by different tables.


Click on Yes to tell Base that you do need a Primary Key
field in the database, then go to File > Close to close
the Table Design window


6.5 COMPLETING PREPARATION OF THE DATABASE TEMPLATE

Creating a Form for the new database

The following exercises will help you learn how to prepare a database
Form.

A Form is a database object which allows you to view the data one record
at a time, unlike a Table where you can view the data as a continuous
list of records—recall how the Table looked in the Birds database you
checked out at the beginning of this tutorial.

A Form is a convenient tool for data entry purposes because it allows
the user to see all the Field entries in a single record at one time,
unlike the Table view, which will often be unable to show all the data
fields of a single record across the screen.

Let’s create a Form for our Student Records Template database now. First
you need to bring up the Create Ribbon at the top of the database
window.


Click on the Create tab to show the Create Ribbon at the top
of the Base window and, in the Forms group, click on the Form
Wizard dialog box (Fig. 6.15)
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Fig. 6.15 Step 1 in the Form Wizard dialog box

As you see in Fig. 6.15 above, the Form Wizard dialog box steps you
through the 8 step process of creating a Form for the Student Records
Template database. Not all of the 8 Steps are relevant for our purposes,
but most of them are. Step 1 in designing a new form for the Student
Records database is devoted to selecting all the fields for the new
Form.


In the “Select the fields of your form” section (see Fig. 6.15
above), click on the double arrow (>>) symbol


This moves all 20 of the fields in the Student Records Template
database—that is to say, All the Available fields—over to the
Fields in the Form box (Fig. 6.16).
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Fig. 6.16 The result of Step 1 in the Form Wizard dialog box


Step 2—Set up a Subform—this is irrelevant to our purposes in
this tutorial, as are also Steps 3 and 4, so just click on Next
and Next to move on to Step 5, where you decide on the
design controls on your database Form (Fig. 6.17)
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Fig. 6.17 Selecting the Arrangement of the main form

Step 5—select the first of the four Arrangements of the main
form (Columnar – Labels left)—Fig. 6.17 above

In Step 6, accept the default data entry for the Form to
Display all data and click on Next to go to Step 7, where
you can choose any color and border you like for the Form Style
(Fig. 6.18)
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Fig. 6.18 Selecting the Style for the Form background

All that remains—Step 8—is to name the Form (Student Records
Form) and make sure the radio button next to Work with the
form is selected, then click on Finish (Fig. 6.19)
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Fig. 6.19 Naming the database Form

Base finally presents the Student Records Database window, ready for
you to start filling out the individual records with student data (Fig.
6.20)
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Fig. 6.20 The final look of the Student Records Database form

6.6 adding records to A NEW or existing DATABASE

Creating a new database based on a Template database

The Student Records Template is so named because you want to use this
same template document (with its table Student Records Table) and data
entry form (Student Records Form) over and over for class records in
the years ahead.

Before you start adding data about this year’s students, you need to
create a new database using this template as the model. For the sake of
this exercise, you’re going to call the new database Fall Roster 2015
(or some other appropriate name if you prefer). The name indicates that
the document will contain the database of student records for a Fall
2015 class.

The Template database should still be displayed on your screen. All you
need to do is Save the template with the new name Fall Roster 2015 and
you’re ready to add the data for the new class of students.


In the File menu select Save As… and, in the Save As dialog
box, type the file name Fall Roster 2015 and click on the
Save button


Entering the data for the records in the database


The Fall Roster 2015 database is open on your screen, so click
in the left hand frame on Forms then, in the Forms
frame, double click on Student Records Form to open it


Remember that each record in the Fall Roster 2015 database has a full
set of 19 entries for each student. You must enter a few records at this
stage (five will do for now) so that you can complete the rest of this
tutorial.


Begin by selecting the ID field for record #1 and enter the
number 1 as the Primary Key for the record (the next record
will have the Primary Key of 2, and so on—the Primary Key field
must be unique) and hit the Tab key to move to the next field’s
data entry box—the First Name field of record #1

Type in a First Name of a hypothetical student




The names don’t have to be in any particular order since you can quickly
sort them later on. Check the name you just typed. Is it correct?


If so, hit the Tab key again to proceed to the next field (you’d
press Shift-Tab if you wanted to move to a previous field)


Notice that the data are now stored in the data entry box for the First
Name field in Record #1. If you wanted to correct the data, you would
do so by clicking in the data entry box and then make any changes as if
you were in the word processor.


Continue entering data for Record #1 (the data for the first
student in a class roster); make up the data as you go along if you
don’t have actual students in mind


Adding a New Record to the database


After you type the last field entry for each record, press
Tab, and Base will automatically present a new record Form


Base will also automatically save each completed record into the
database on your disk, so you don’t have to worry about losing your work
as you go along, and you also won’t need to save the database at the
end.


Type the entries into each field one by one, starting with the ID
field which will contain the next number in sequence—2, if it’s
the second record and so on; be sure to press the Tab key
after each entry to get to the next field (eventually you should have
at least 5 records in the Fall Roster 2015 database)


Adding a record to an existing database is just the same. New records
are always added at the end of the database. If you want the new record
to appear in a specific place in the Datasheet view you would use the
Sort function. You’ll learn how to do this in Lesson 7.

The new record will always have the same layout and format
characteristics as the others in the database. Also, remember that
Base automatically saves a new record in the database after you have
filled in the data for every entry.

6.7 VIEWING THE DATA IN THE DATABASE

Here are some of the ways to move about in a database. Base makes it
easy for you to get around. Take a few moments to move from field to
field and from record to record. Try these exercises.


Click anywhere in the data box next to a field name


This allows you to edit or add data if needed.


Hit the Tab key to move to the next field in the same
record

To move to the same field in the next or previous
record, click on the left or right arrows in the Navigation
tools at the bottom of the Form window (Fig. 6.21)
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Fig. 6.21 The Base database navigation tools

In Lesson 7 you will learn other ways of searching through the database,
along with other ways of selecting sets of records from the database,
and so forth. For now, as a final exercise in Lesson 7, let’s just learn
how to update the data in a Base database.

6.8 UPDATING ENTRIES AND records IN the DATABASE

The following exercises will give you the opportunity to practice
working with the data in the database.

Updating the contents of a field (one item of data in a student
record)


You should still be looking at the Student Records Form


To delete, or otherwise change, the contents of a field in a record,
click on the field data entry box, then erase characters or words in the
same way as you would if you were in the word processor.

Deleting (clearing) a record

In order to delete a single record from a database, you need the Form
Navigation toolbar, which should already be open at the bottom of the
database Form, along with the other toolbars relevant to a Base
database Form (Fig. 6.22).
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Fig. 6.22 The Form toolbars


If these toolbars are not available in the Fall Roster 2015 database
Form, go to the View menu > Toolbars and make sure you
select each of the Form toolbars in turn—the Form Controls
toolbar, the Form Design toolbar, and the Form Navigation
toolbar (click to put a check mark next to each of them, as
illustrated in Fig. 6.21 on the previous page)


Now try this to practice deleting a record from the database.


[image: ]In the Navigation toolbar (the upper of
the two toolbars at the bottom of the Form window), click on the
record control tools to select Record #2 in the Fall Roster
2015 database (Fig. 6.23)


Fig. 6.23 Selecting a specific record in the database


In the Navigation toolbar, click on the Delete Record tool


Base will warn you that you are about to delete a record (Fig. 6.24).
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Fig. 6.24 Alert to inform you that deleting a record is undoable

This gives you the opportunity to change your mind, which you need to do
in this case. Base will otherwise immediately permanently remove the
record if you click on Yes.


Click on No in the dialog box


Deleting several records at once

It’s easiest to use the Table View to clear several records that are
listed next to each other. To delete a block of records at one time
here’s what you do.


In the File menu select Close to close the Fall Roster 2015
database Form, then, in the Database frame on the left hand
side of the Fall Roster 2015 window, click on the Tables icon,
and then double click in the Tables section on Student Records
Table

Now, in the left hand margin of the Table, click to select
Record #2, then hold down the Shift key while you click in
the left hand margin to select Record #4 (Records 2, 3, and 4
should now be highlighted—Fig. 6.25)
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Fig. 6.25 Selecting several records for deletion

In the Navigation toolbar, click on the Delete Record tool




Again you will get a warning (see Fig. 6.24 above) that you are about to
delete however many records you have selected, and will ask you if you
are sure you want to do this.


You don’t, so click on No in the dialog box


Bear in mind that the Delete Record command completely removes a record,
such that it is irretrievable once deleted.

SKILL CONSOLIDATION

Complete these exercises to reinforce what you have learned in Lesson 6.

1. Design and create a database for the names, addresses, and telephone
numbers you have in your address book. Enter as many names and addresses
as you like (as long as you have at least 6). Don’t forget to save the
database records as you go along.

2. Add a couple of records to the database you created in exercise 1.
Clear a record.

3. Add a field to the address book database—say Association (how are the
people associated to you—friend, colleague, etc.). Then enter the data
for each record for the new field.

4. Imagine you are teaching a class and you want your students to do
research on a topic. Design and create a database around that topic. You
could discuss the fields with your students. The students would then go
off, do the research, and enter the data into the database as a basis
for a paper they must prepare. This would be a nice group (team)
exercise.

5. Design and create a database for a Birthday List of your family and
friends. Include fields such as Name, Birthday, Greek sign, Favorite
color, Clothes sizes, Hobby, etc. Have at least 6 records in the
database, with each record containing at least 5 fields. Create a Form
for the database as well as a Table.

6. Open the Base database Fall Roster 2015 and enter a complete new
record for a student named Jane Doe.

7. Open the Base database named Template. Change the name to Grade
X.2015 so you won’t lose the template, and add three (3) records. Then
save the updated database.
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Lesson 7 Mail Merge and Related Operations



7   MAIL MERGE AND RELATED OPERATIONS

      Form Letters and Mailing Labels







LEARNING OUTCOMES

In this tutorial you will complete the following Mail Merge tasks[^1]:


• prepare a data source document (a LibreOffice Base database) for a
form letter;

• create the form letter;

• prepare a set of field trip notices;

• prepare mailing labels;

• prepare a new form letter using a macro and an existing data source
document (a LibreOffice Base database).




BEFORE YOU BEGIN

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (7.1 Preparing an
Address List in Calc—next page). If you did not complete Lesson 1,
then you must do this now, before proceeding with the rest of Lesson 7.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to prepare these folders now before proceeding with
this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will
help you with this if you are working with a class) and Extract
them onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 7.1).
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Fig. 7.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 7.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

**7.1 PREPARING aN Address List IN CALC **

This exercise will show you how to create an address list data source
document using the Calc spreadsheet, which you will then convert into
a Base database for the purpose of merging the data with a form
letter.

Entering the data for the Address List spreadsheet


Start by opening a new LibreOffice Calc spreadsheet

Now go to File > Save As…, navigate to your USB drive


LibreOffice Work Files > Data Files >
Spreadsheet Documents and Save the spreadsheet with the name
Address List


In the new Address List spreadsheet, across the first row
(row 1) enter the following eight (8) column headers:

Header for row 1, Column A: ID

Header for row 1, Column B: Home Contact

Header for row 1, Column C: Student First Name

Header for row 1, Column D: Student Last Name

Header for row 1, Column E: Address Line 1

Header for row 1, Column F: City

Header for row 1, Column G: State

Header for row 1, Column H: Zip Code




When you are done, the column headers in your spreadsheet should look
like Figure 7.2.
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Fig. 7.2 Naming the column headers for the data source document

In lessons 4 and 5 you learned how to widen columns. if your columns are
too narrow for the column headers here and there, go ahead and make them
wider, as in Fig. 7.2 on the previous page.

The ID field (column A) will start with the value 1 (one) and increase
by 1 for each record (this will be the Primary Key when you convert
the spreadsheet into a Base database).


Type in the data for the first record—starting with the value
1 for the ID; then make up data for each of the other fields
in the appropriate column of the spreadsheet, starting in column B
with the Home Contact (the name of the student’s parents or other
guardian—Mr. and Mrs. Brown, for example)

After the first (Home Contact) entry, hit Tab, then type a
Student First Name, and so on across the spreadsheet row

After you type in the Zip Code, the last entry for the first
record, click in the ID field for record #2, enter the ID
value 2, and carry on entering appropriate data till you have
entered the data for all 10 records (or for as many students as
you have in your class if you are a practicing teacher)

After you have entered the data for at least ten records, Save
the spreadsheet




7.2 converting the Calc spreadsheet to a base database

The next step in our mail merge process involves converting the Address
List spreadsheet, which you just created, into a Base database data
source object—which is necessary if you want to merge the data source
with a Writer form letter. Here are the steps to do this.


In the File menu select New and, in the menu of LibreOffice
applications, select Database (Fig. 7.3)
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Fig. 7.3 Opening a new database

This will bring up the Database Wizard (Fig. 7.4).
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Fig. 7.4 The LibreOffice Database Wizard


In Step 1 of the Wizard (Select Database), click to select the
radio button next to Connect to an existing database (Fig. 7.4
above), then click on the down arrow in the accompanying data box
and, from the list of different application types that pops up,
select Spreadsheet (Fig. 7.4 above) and click on Next>>
to go to Step 2 of the Database Wizard

In Step 2, click on Browse and, in the Open dialog box
that pops up, in your Work Files for LibreOffice > Data
Files > Spreadsheet Documents folder, double click on
Address List to put it in the Location and file name data box
(Fig. 7.5)
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Fig. 7.5 Setting up a Spreadsheet connection


Click on Next >>, then in Step 3 of the Wizard, leave
the selections as they are (Fig. 7.6), leave the radio button next
to Yes, register the database for me checked, and also leave
checked the box next to Open the database for editing, then click
on Finish
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Fig. 7.6 Final step in converting the Address List data source to a
Base database


The Wizard will ask you to Save the new database, so click on
Save, navigate to your USB drive > Work Files for
LibreOffice > Data Files > Database Documents folder,
name the database Address List, and click on Save again


The new Base database will open on your screen (Fig. 7.7).
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Fig. 7.7 The new Base database data source


Make sure Tables is selected in the Database frame (see Fig.
7.7 above), then double click on Sheet1 to open the Table
so that you can check that the Address List data has been
correctly imported from the spreadsheet you created at the
beginning of this exercise (Fig. 7.8 shows data created for this
lesson by the author; yours will be different)
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Fig. 7.8 The Address List imported to the Base database

Assuming everything looks good, you are ready to proceed with the next
step in the mail merge process, which involves the creation of the Form
Letter.

7.3 CREATING the form letter (THE FIELD TRIP notice)

Step 4: creating the Field Trip Notice into which will be merged the
records that you have prepared in the Address List database.

Fig. 7.9 on the next page shows the complete contents of this Field Trip
Notice letter.


Don’t start typing it just yet—follow the directions on the
ensuing pages in order to avoid making mistakes.


You’re going to begin by opening, and renaming, a Writer template
document called Letters, which is already stored in the Work Files
for LibreOffice folder on your USB drive.


In the File menu select Open, then navigate to your USB
drive > Work Files for LibreOffice > Miscellaneous
Files > Merge Documents, and double click on the
Letters document to open it

Now, in the File menu select Save As…, navigate to the Work
Files for LibreOffice > Data Files > Writer Documents
folder, type Field Trip Notice for the new document name, then
click on Save




You are now ready to use Writer’s mail merge tools to produce a
customized, that is to say individualized, letter to send to the
parents or guardians of each student in your class.

In Fig. 7.9, the placeholders (where the field names are enclosed by the
&lt;

 … > symbols) indicate the place in the form letter where
data from the Address List database, which you created in the previous
exercise, will be merged with each of the letters in order to
personalize them.

DO NOT START TYPING YET! Bookmark this page. The exercises on the
next page explain how to proceed. Follow the steps carefully.
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Fig. 7.9 The final version of the Field Trip Notice form letter

Inserting the date

The unedited Field Trip Notice document is open on your screen with the
bare bones of the form letter (the school address at the top, the
beginning of the salutation “Dear”, and the conclusion (Yours sincerely,
etc.).

You need to put the date at the top of your Field Trip Notice
document, immediately after the address, which, in a real situation,
would be the official address of the school where you are a teacher.


Position the cursor on the blank line immediately after the
address at the top of the page, then, in the Insert menu
select Fields > Date


You should now have the date displayed in your form letter right after
the school address at the top of the page. You’ll maybe recall from
Lesson 1 that the default all-numeric format for the date can be
confusing in other countries, so you need to select a style that is
unambiguous.


Right click on the inserted date and, in the context menu,
select Fields… then, in the Edit Fields dialog box, click on
the date format that looks like Friday, December 31, 1999 and
click on OK (Fig. 7.10)
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Fig. 7.10 Insert Date feature of LibreOffice

That takes care of the date format.

Viewing the Data Source for the Field Trip Notice

Now it’s time to connect your Field Trip Notice to the Address List
database that you created in the previous exercise (Section 7.3 of this
tutorial).


In the View menu, select Data Sources


You should now have a new window right at the top of your screen, at the
top of the page, showing, on the left, a list of the databases you have
registered with LibreOffice.

The Address List is the database you want to use with the Field Trip
Notice.


In the list of registered databases, click on the small + (plus
sign) to the immediate left of Address List to show
Queries and Tables (Fig. 7.11 on the next page)

Now click on the small + (plus sign) to the immediate left of
Tables to show Sheet1




Sheet1 contains the data that you imported into the database from the
Address List spreadsheet you created in Section 7.3 of this tutorial.


Click on Sheet1 and wait while LibreOffice fetches all the data
from the Sheet1 table and displays the data as a table in the
window above the form letter and to the right of the list of
registered databases (Fig. 7.11, again your data will be different)
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Fig. 7.11 Viewing the LibreOffice Data Sources

**Inserting fields (placeholders) into your form letter **

In the Figures that follow, ignore the data you see because yours will
be different.

You are now going to insert into the form letter the first set of
placeholders—for the receiver’s (recipient’s) name and address—the
receiver is the parent or guardian of one of your students.

The receiver’s address, after your own (school) address at the top of
the letter, will start with the Home Contact field. So you need to
tell Writer to merge the form letter with the corresponding data from
the Address List database. Here is how you do this.


In the form letter, use the mouse to position the cursor on the empty
line immediately above the salutation: “Dear” and press
Enter to space down one line

Use the mouse to drag the title Home Contact down to the correct
position for the Home Contact in the first line of the recipient’s
address (Fig. 7.12)
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Fig. 7.12 Dragging the Home Contact merge field down into the form
letter

Writer quickly displays &lt;

Home Contact> in the body of the
form letter immediately above the salutation “Dear” (with the brackets
around it as you see here—you never need to type the brackets with Mail
Merge). Now, when eventually the letters (all ten of them) are printed
out, the correct name of each student’s parent or guardian will be
copied from the Address List database and inserted into this position in
the letter.

Next you need to add the remaining placeholders for the Home Contact’s
address (see Fig. 7.12 previous page).


The cursor should be waiting at the end of &lt;

Home Contact>,
so press the Enter key to move to a new line

Once again, use the mouse to drag the title Address Line 1 down
to the correct position on the new line after &lt;

Home
Contact> (which will be the second line of the form letter
recipient’s address)




Writer adds the new merge field to the address.


Press the Enter key to move to a new line, use the mouse to drag
the title City down to the correct position on the new line
after &lt;

Address Line 1> (which will be the third and last
line of the form letter recipient’s address)

Now stay on the same line, type a comma (,) followed by a
space, and use the mouse to drag the title State down to the
correct position on the last line of the recipient’s (Home
Contact’s) address

Hit the space bar once, then use the mouse to drag the title
Zip down to the correct position at the end the last line of
the recipient’s (Home Contact’s) address




This rounds off the address that is to be merged with the Field Trip
Notice form letter, which should now look like Fig. 7.13.
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Fig. 7.13 Form letter after merging the recipient’s address and
salutation


Press the Enter key to space down after the address


So far, so good. Next you need to put a placeholder for the Home
Contact after the salutation Dear… at the beginning of the letter
(Fig. 7.13 above).


Put the cursor right after the word Dear, then press the Space
bar to space over one space and use the mouse to drag the
title Home Contact down to the correct position after the
salutation Dear…


By now you should be getting the idea of how to insert merge fields into
the Field Trip Notice as you go along.

Refer to the Field Trip Notice letter (Fig. 7.9 on page 196) as you
complete the form letter.


Type the remaining text of the Field Trip Notice letter
illustrated in Fig. 7.9, inserting the merge placeholders where
indicated

Be sure to put a space before and/or after each
Placeholder so that the data will be correctly spaced grammatically
in the final version of the letter

When you have finished, Save the Field Trip Notice form letter
once more




7.4 Printing the FIELD TRIP NOTICE

Before printing your Field Trip Notice letters on paper (hard copy),
it’s always a good idea to preview them on the screen (soft copy), with
the appropriate data filled in for each version of the letter, so that
you can confirm that the data from the Address List source document has
been correctly merged with the form letter. In LibreOffice, this is
all part of the Print function.


From the File menu select Print


LibreOffice immediately recognizes that the Field Trip Notice document
contains Address List database fields and asks you to confirm that you
want to print a form letter (Fig. 7.14).
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Fig. 7.14 Prompt to confirm form letter


Click on Yes


After a few seconds, you are presented with the Mail Merge dialog box
(Fig. 7.15).
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Fig. 7.15 Mail Merge dialog box

You want the output to go to a File. You also want to save the merged
document as a single document which will contain all 10 of the Field
Trip Notices, each one individually tailored to the Home Contact of a
different student in the class.


Click on the radio button next to File to select that
option and leave the radio button next to Save as single
document selected (Fig. 7.15 on the previous page) then click on
OK


LibreOffice now displays the Save As dialog box, prompting you to
Name the Field Trip Notice merge file and decide where you want to
save it.


In the Save As dialog box, navigate on your USB drive, to your
LibreOffice Work Files > Data Files > Writer
Documents folder, then, in the File name: data entry box, type
Field Trip Notice Merge Letters and click on the Save button


The document Field Trip Notice Merged Letters is several pages long—at
least 10 if each letter fits on one page, but 20 if each letter flows
over onto a second page. Saving the merged letters is a good idea. It
means that you have a copy of the final version of the updated letters
for your records—a customary practice with regard to professional
correspondence.

Previewing your letters on screen

You’re nearly there. But first you need to take a look at the Field Trip
Notice Merge Letters to check that the data from the Address List has
been correctly merged with the file.


Go to File > Open and double click on the Field Trip
Notice Merge Letters file to Open it

This a long document, containing all ten of the field trip
notices, so scroll through to the end to check (a) that there
are indeed 10 letters (or however many you records you entered into
the Address List database) and (b) that each letter has the
appropriate merged data




Notice how the data from the Address List has been merged into each of
the letters, giving each letter a personalized appearance (Fig. 7.16 on
the next page).

Editing (further customizing) the recipients’ letters

At this stage, you could do some final editing of the individual letters
(the Field Trip Notices), prior to printing them as hard copy. The set
of notices are all saved in one file and you can “visit” each letter and
add a comment here or there which pertains to a particular student or
the Home Contact.

For example, you could add a sentence to each letter saying something
special about the student. This would further individualize the letters,
giving parents the sense that the letter they receive is unique to them.
In this way you can further personalize what is, in fact, a form letter.
This is always a good thing to do, if you have the time.


After you have checked all ten of the Field Trip notices, and made
any final edits or personal touches you want, Save the Field
Trip Notice Merge Letters document
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Fig. 7.16 The Field Trip Notice Merged Letters

Saving a PDF version of the merged Field Trip Notices

Now is the time to convert the merged Field Trip Notices to PDF format.

At this stage, you have the Field Trip Notice merged with the Address
List database and safely saved as a LibreOffice Writer document. But
it would be a good idea to save the document as a PDF file, before going
on to print the letters as hard copy (on paper) or soft copy (on the
screen).

PDF stands for “Portable Document Format” and it was designed to allow
for easy sharing a documents across different computers and operating
systems. In other words, a PDF file, once saved, keeps its
formatting/layout no matter where it might be viewed or printed. It is a
more reliable format for all kinds of different types of documents.

Converting a document to PDF format is very easy to do. Essentially,
you’re going to repeat the steps you took when you completed the merge
of the Address List data into the Field Trip Notices merged document.


The Field Trip Notice merge document should still be open on your
screen, but if it is not, from the File menu select Open and
double click on the file Field Trip Notice to open it

Go to File > Print and, in the dialog box that pops up
asking you to confirm that this is a form letter that you want to
print, click on Yes

In the Mail Merge dialog box that comes up next, click on the
radio button next to File to select that option

Leave the radio button next to Save as single document
selected (Fig. 7.15 on page 200 above) then click on OK




The Save As dialog box comes up on the screen and you are asked to
name the document and decide where you want to save it. This time you’re
going to save the document as a PDF file, so here is how you do
that.


In the Save As Type: data entry box, click on the down arrow
next to Save as type: and, in the menu of file types that pops
up, click on the option for PDF - Portable Document Format (.pdf)
(Fig. 7.17)
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Fig. 7.17 Selecting the PDF file type for the Field Trip Notice merged
document


Make sure you are saving to your LibreOffice Work Files >
Data Files > Writer Documents folder (Fig. 7.17 above)

Now, in the File name: data entry box, type Field Trip Notice
Merge Docs and click on Save, then wait while the Mail Merge
Wizard’s Print Monitor saves the ten Field Trip Notices in PDF
format (Fig. 7.18)




[image: ]

Fig. 7.18 Saving the PDF version of the Field Trip Notices

Printing the PDF version of the Field Trip Notices


You no longer need the Field Trip Notice Writer document, so
close it, then go to File > Open and open the
Field Trip Notices Merge Docs document (the PDF file)


In the left hand frame of the PDF window, you are now presented with
thumbnails for each of the ten Field Trip Notices. On the right hand
side of the window, you can see the first of the 10 Field Trip Notices
containing all the merge field data from the first record in the Address
List database (Fig. 7.19).
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Fig. 7.19 Printing the PDF version of the letters with the Merge Fields
filled in


In the left hand frame of the PDF document (Fig. 7.19 above),
click in turn on each of the thumbnails of all ten versions of
the Field Trip Notice to scan through the recipients’ letters and
confirm that the correct data has been merged with each one

If you intend to print out the Notices on paper, assuming all is well,
and assuming you have a printer connected to your computer and turned
on (with paper in the hopper), go ahead and click on File >
Print… and Writer will print the 10 form letters

Close the Field Trip Notice Merge Docs PDF document when
you are done




7.5 Preparing mailing labels

Mailing labels are like those Return-Address stickers you put on the
outside of your envelopes, or those address stickers that you sometimes
find on mass-mailed items that you perhaps have received in the mail.
Producing them is simple enough, especially if you have completed all
the tutorials up to this point.

Deciding on the data for the mailing label

Writer Merge documents, such as mailing labels, are always linked to a
database. We’ll keep it simple for now, so you’ll use the Address List
database you created for the Field Trip Notice form letter. You know
by now how to create your own database of addresses, so you could create
an address list of your own; in fact you probably have an electronic
address list which you could, if you wanted, use for this exercise.

First you need to open a new Labels document.


Go to File > New > Labels


You should see the Labels dialog box on your screen (Fig. 7.20).
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Fig. 7.20 The new Labels dialog box

You now need to make selections in the Database, Table, and
Database field data entry boxes. You will also move into the Label
Text box a complete set of Address List database fields for the Home
Contact address, and you have to select the Brand and Type of
mailing label you want to use (Fig. 7.20 previous page).

Fig. 7.21 shows the Labels dialog box after you have completed these
tasks.
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Fig. 7.21 The Labels dialog box after filling out the various entries

The following directions will step you through this process of filling
out the Labels dialog box; follow them carefully. Notice, in Fig. 7.21,
that you are going to lay out the Recipient address as it would appear
on an envelope—as a mailing label.


In the Database entry box, click on the down arrow at the end
of the data entry box and, from the list of databases, select
Address List

Now, in the Table entry box, click on the down arrow at the
end of the data entry box and, from the list of Tables, select
Sheet1




Next you have to set up the layout for the recipient (Home Contact)
address for the mailing label.


In the Database field entry box, click on the down arrow at
the end of the data entry box and, from the list of database
fields, select Home Contact, then click on the large arrow to
transfer the Home Contact field across to the Label Text
area

Click on the Enter key to move the cursor to a new line

Again, in the Database field entry box, click on the down
arrow at the end of the data entry box and, from the list of
database fields, select Address Line 1, then click on the
large arrow to transfer the Address Line 1 field across to the
Label Text area

Click on the Enter key to move the cursor to a new line

In the Database field entry box, click on the down arrow and,
from the list of database fields, select City, then click on
the large arrow to transfer the City field across to the Label
Text area

Type a comma after the City field, then hit the **space bar **

In the Database field entry box, click on the down arrow and,
from the list of database fields, select State, then click on
the large arrow to transfer the State field across to the Label
Text area

Hit the space bar to space after the State field

Finally, in the Database field entry box, click on the down
arrow and, from the list of database fields, select Zip,
then click on the large arrow one last time to transfer the Zip
field across to the Label Text area




Selecting the standard format for the mailing label

The mailing labels are now filled with the database fields; all that
remains is to tell LibreOffice what standard format you want them to
have for your Field Trip Notices envelopes.

We’re going to go with Avery A4 for the Brand and C2160 Avery
Inkjet Label for the Type. But the label format doesn’t have to be
Avery A4, of course.

If you already have sheets of mailing labels that you intend to use for
this exercise, check out the box they come in and look for the Company
Brand and Type of label. Then look up the appropriate Brand and Label
Type in the menus that pop up when you click on the down arrows for the
respective data entry boxes.

So, for your own purposes you can select any option you like; otherwise,
for the sake of this tutorial go with the selections that follow for
now.


In the Format area of the Labels dialog box (Fig. 7.20
previous page), leave the Sheet option already selected

In the Brand data entry box, click on the down arrow to bring
up the menu of standard company mailing label formats and select
the Avery A4 option

Then, in the Type data entry box, select C2160 Avery Inkjet
Label

In the Labels dialog box, click on the Options tab, and be
sure to click to put a check mark next to Synchronize contents
to ensure that all the labels are merged with the Address List
database

Finally click on New Document




Immediately, LibreOffice presents a sheet of mailing labels with all
the database fields laid out as per the design you specified in the
Labels dialog box (Fig. 7.22).
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Fig. 7.22 The template mailing labels sheet


Click on the Synchronize Labels button (Fig 7.22), then go to
File > Save As…, navigate to your USB drive > Work
Files for LibreOffice > Data Files > Writer Documents
folder and save the new document with the name Field Trip
Notice Merged Mailing Labels


Previewing your mailing labels on screen

Now you are ready to go ahead and preview the sheet of mailing labels
with all the data from the database, which you should always do before
sending them to the printer.


From the File menu select Print


As before, LibreOffice immediately recognizes that the Field Trip
Notice Merged Mailing Labels document contains Address List database
fields and asks you to confirm that you want to print a form letter.


Click on Yes


After a few seconds, you are presented with the Mail Merge dialog box
(Fig. 7.23).
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Fig. 7.23 Mail Merge dialog box

You want the output to go to a File. You also want to save the merged
document as a single document which will contain all 10 of the Field
Trip Notice Mailing Labels, each one individually tailored to the Home
Contact of a different student in the class.


Click on the radio button next to File to send the output
to a File, and leave the radio button next to Save as single
document selected (Fig. 7.23 above) then click on OK


LibreOffice now displays the Save As dialog box, prompting you to
Name the merge file and decide where you want to save it.


In the Save As dialog box, navigate, on your USB drive, to
your LibreOffice Work Files > Data Files > Writer
Documents folder, then, in the File name: data entry box, type
Field Trip Notice Merged Mailing Labels as before and click on the
Save button

LibreOffice will ask you if you want to save the file with the same
name as the existing file, which you do, so click on Yes then
Close the Field Trip Notice Merged Mailing Labels




As noted above, it’s always a good idea to take a look at the Field Trip
Notice Mailing Labels to check that the data from the Address List has
been correctly merged with the file.


Go to File > Open and double click on the Field Trip
Notice Merged Mailing Labels file to Open it


Notice how the data from the Address List has been merged into each of
the mailing labels, giving each label a customized look.

Check out the layout and content of the mailing labels. If you had many
addresses in your Address List you might need to scroll to check them
all out, or you could check out individual addresses by clicking on
Ctrl-f to Find a recipient… This isn’t necessary for this exercise
since you have only a few (10) names and addresses in your Address List.


You don’t need the Field Trip Notice Mailing Labels file for the
exercise that follows, so go ahead and Close it, but keep open the
Field Trip Notice Merged Mailing Labels document


Saving a PDF version of the merged Field Trip Notice Mailing Labels

Now is the time to convert the Field Trip Notice Merged Mailing Labels
to PDF format so that you will have a version in that format for
printing purposes. You’ll recall that PDF stands for “Portable Document
Format” and it was designed to allow for easy sharing a documents across
different computers and operating systems. In other words, a PDF file,
once saved, keeps its formatting/layout no matter where it might be
viewed or printed. It is a more reliable format for all kinds of
different types of documents.

Converting a document to PDF format is very easy to do. Essentially,
you’re going to repeat the steps you took when you completed the merge
of the Address List database into the Field Trip Notice Merged Mailing
Labels document. Here’s a reminder of the steps to do this.


The Field Trip Notice Merged Mailing Labels document should still
be open on your screen, but if it is not, from the File menu
select Open and double click on the file Field Trip Notice
Merged Mailing Labels to open it

Go to File > Print and, in the dialog box that pops up
asking you to confirm that this is a form letter that you want to
print, click on Yes

In the Mail Merge dialog box that comes up next, click on the
radio button next to File to select that option

Leave the radio button next to Save as single document
selected (Fig. 7.23 on page 209 above) then click on OK




The Save As dialog box comes up on the screen and you are asked to
name the document and decide where you want to save it. This time you’re
going to save the document as a PDF file, so here is how you do
that.


In the Save As Type: data entry box, click on the down arrow
next to Save as type: and, in the menu of file types that pops
up, click on the option for PDF - Portable Document Format (.pdf)
(Fig. 7.24)
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Fig. 7.24 Selecting the PDF file type for the Field Trip Notice merged
document


Make sure you are saving to your LibreOffice Work Files >
Data Files > Writer Documents folder (Fig. 7.24 above)

Now, in the File name: data entry box, type Field Trip Notice
Merged Mailing Labels (you can keep the same name since it’s a
different file type (PDF) than the Writer version) and click on
Save, then wait while the Mail Merge Wizard’s Print Monitor
saves the mailing labels in PDF format




Printing the PDF version of the mailing labels


Go to File > Open and open the Field Trip Notice
Merged Mailing Labels document (the .pdf version)

In the right hand frame of the PDF document, scan through the
recipients’ address on each of the labels and confirm that the correct
data has been merged with each one

If you intend to print out the mailing labels on paper, and assuming
you have a printer connected to your computer, go ahead and click on
File > Print… and Writer will print the mailing label
sheet(s) for you

Close the Field Trip Notice Merged Mailing Labels PDF
document when you are done




7.6 PREPARING A NEW FORM LETTER USING AN EXISTING DATABASE

By way of reinforcement of what you have learned in this lesson, let’s
prepare another form letter, this time using an existing database.

In your Work Files for LibreOffice/Miscellaneous Files/Merge
Documents folder there is a database called Roster 2014. It is a set
of records for a sample class of 25 students. You are going to use the
data in this database to prepare a form letter called Mid Term Report,
which will report to parents/guardians on their child’s progress-to-date
half way through a semester. You are going to have Writer merge the
Mid Term Report with the Roster 2014 database.

First you need to open a Writer template as a basis for the report. The
template is called Letters.


Go to File > Open > navigate to your USB drive >
Work Files for LibreOffice > Miscellaneous Files >
Merge Documents > and double click on Letters to
open it


Registering the Roster 2014 database

You must register the Roster 2014 database with LibreOffice before
you can use it to merge the Roster 2014 data into the Letters merge
document. Follow these steps to do this.


Go to the Tools menu > Options…, then in the left hand
frame of the Options window select LibreOffice Base >
Databases (Fig. 7.25)
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Fig. 7.25 The Tools > Options dialog box


In the right hand frame, in the Registered databases section,
click on New


This brings up the Create Database Link dialog box (Fig. 7.26).
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Fig. 7.26 Create Database Link dialog box


In the Create Database Link dialog box, click on Browse and
navigate to your USB drive > Work files for LibreOffice


Miscellaneous Documents > Merge Documents and double
click on Roster 2014 to put it in the Registered name data
entry box (Fig. 7.26 above), then click on OK





Notice that the Roster 2014 database is now in the Registered Name
list in the Registered Databases section of the Options dialog box
(Fig. 7.27).
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Fig. 7.27 Adding Roster 2014 to the list of registered databases


Click on OK again to complete the registration of the Roster
2014 database


The Roster 2014 database is now a registered database and may be used
as a data source for the Letters document you are working with and
which should still be open on your screen.


In the View menu select Data Sources, then, in the list of
databases at top-left of the Letters window, click on the +
(plus sign) next to Roster 2014 and again on the + (plus
sign) next to Tables to bring up the Roster 2014 Table (Fig.
7.28)
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Fig. 7.28 Viewing the Roster 2014 data source


Now, still in the top-left frame, click once on Roster 2014
Table, then wait while the data from the Roster 2014 database is
displayed top-right (Fig. 7.29)
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Fig. 7.29 The Roster 2014 data displayed top right of the Letters window

Creating the Mid Term Report form letter

Next you are going to use the Letters Writer document (still on the
screen and also saved on your disk) to create a Mid Term Report
document which will go out to the parents of your students. The report
is illustrated in Fig. 7.29 on the next page. Do NOT start typing the
report in yet! You have a couple of other things to do to get set up
for the mail merge.

First you must save the Letters document with a different name so that
you will keep the copy of the Letters document as a template for
future use.


Select File > Save As…

Change the name of the Letters document to Mid Term Report
(this will be the name of the form letter you are going to create),
then navigate to your USB drive > Work Files for
LibreOffice > Data Files > Writer Documents folder and
click on Save




You are going to have Writer produce one letter for each student in
the Roster 2014 class. As you can see, the form letter illustrated in
Fig. 7.30 on the next page reports to parents on how well their child is
doing half way through the semester.

You already told Writer that you want to merge the form letter with
the data stored in the Roster 2014 database. The placeholders in Fig.
7.30 on the next page (where the field names are enclosed by the
&lt;

…> brackets) indicate the location in the form letter where data
from the Roster 2014 database is to be merged when the letters are
actually printed out.

Wherever you see a placeholder (&lt;

…>), use the mouse to drag the
appropriate field header down from the data displayed top right as you
work your way through the letter.

You already completed a similar exercise earlier in this lesson. If you
are still unsure about what to do, you might like to check back at what
you did—section 7.3 Creating the form letter (the Field Trip Notice),
starting on page 195.

All that remains is for you to type the letter as it is illustrated in
Fig. 7.30.


Hodge Road Elementary School

123 Mingo Bluff Avenue

Johnstown, PA 23456

Tuesday, March 10, 2015

&lt;

Home Contact>

&lt;

Address Line 1>

&lt;

City>, &lt;

State> &lt;

ZIP Code>

Dear &lt;

Home Contact>,

As you may already be aware, I am &lt;

First Name>’s home room
teacher this year. You will be pleased to know that the class has
settled down well, and the children are making excellent progress on
the whole.

I am writing to report to you about &lt;

First Name>’s participation
in school this first half of the current session. I’m sure you
appreciate how important it is for you to be aware of where your child
stands, especially in regard to class grades and attendance.

&lt;

First Name>’s current grade is &lt;

Grade>. &lt;

First
Name> has missed &lt;

Comment> days so far this session, which is
&lt;

Comment>.

Please feel free to contact me at any time to arrange a conference,
especially if the grade or attendance data in the previous paragraph
are not what you expected.

I can be contacted at school between the hours of 7:30 am and 4:00 pm,
Monday through Friday. My phone number is 814-269-2923. You may also
contact me using email. My email address is
vanstanden@keystone.k12.pa.us.

I look forward to hearing from you.

Yours very sincerely,

Mandi Van Staden

Instructional Technology Coordinator




Fig. 7.30 The Mid Term Report form letter


Type the contents of the Mid Term Report as illustrated in
Fig. 7.30 above; be sure to use the Date format illustrated
(Insert > Fields > Date, right click on the
default numeric Date and, in the pop up context menu of
Field Options, select the Wednesday, December 31, 1999
style)

When you are done, Save the Mid Term Report




Pasting a chart into the letter

The letter needs one final touch. You are going to put a chart in the
Mid Term Report. You will create the chart in a Calc spreadsheet, then
copy it into the Mid Term Report. It’s easy enough to do if you already
completed the Calc tutorials (Lessons 4 and 5) of this LibreOffice
book.


Go to File menu > Open…, navigate to USB drive >
Work Files for LibreOffice > Miscellaneous Files >
Merge documents and double click on the Gradedata
spreadsheet


You are going to create a simple chart using the data in the Gradedata
spreadsheet. This will be useful reinforcement of what you learned in
Lesson 5. Here are the steps, if you need the help.


Highlight cells A1 through B6 (the data that will be
represented in the chart), then go to Insert menu > Object


click on Chart… (Fig. 7.31)
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Fig. 7.31 Selecting the Chart option in Calc

LibreOffice Calc immediately creates a default plain Column chart based
on the data in the spreadsheet, and then presents the Chart Wizard
dialog box (Fig. 7.32) to help you create a more interesting or, more to
the point, more meaningful chart.
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Fig. 7.32 The Chart Wizard dialog box


Start, in Step 1, by selecting the Pie chart option, then
click in the check box next to 3D Look (Fig. 7.32 above)


Calc quickly assembles the chart and displays it on the screen (you
should see the small handles around the chart indicating that it is a
selected object)—Fig. 7.33.
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Fig. 7.33 The Grade 4 Reporting Period basic 3D Pie chart

As charts go, it’s pretty plain at this stage, and not very meaningful
at all. The chart needs a title and subtitle, and each of the slices
need numerical values associated with them.

Fig. 7.34 illustrates what we’re looking for in the final version of the
chart.
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Fig. 7.34 Final version of the Grade 4 grading period data chart

Essentially, a chart like this is an opportunity to create “a picture
worth a thousand words.” And the LibreOffice suite of productivity
software does a good job of making this possible with little effort on
your part.

Let’s do what is necessary to arrive at this final version of the chart.
We don’t need to do anything with Steps 2 and 3 of the Chart Wizard
because our data sample is very simple.

So… Start with the Chart Titles (see Fig. 7.33 above).


In the left hand frame of the Chart Wizard dialog box, click
on Step 4 to bring up the Chart Wizard > Chart Elements
dialog (Fig. 7.35)
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Fig. 7.35 The Chart Wizard > Chart Elements dialog


Go ahead and type in the Title: Grade Data Grade 4, Reporting
Period 1, then type in the Subtitle: August 18 – September 26,
2014 and click on Finish


Next, let’s change the font of the Title and Subtitle text.


On the Title text (Grade Data Grade 4, Reporting Period 1),
double click anywhere to put a blue box around it, then
triple click on the Title text to select the whole of the
title text (Fig. 7.36)
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Fig. 7.36 Selected Title text


Now, right click anywhere in the Title Text box and, in the
context menu that pops up, select Format Title… to bring up
the Main Title dialog box (Fig. 7.37)
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Fig. 7.37 Formatting the Chart Title


In the Main Title dialog box (see Fig. 7.37 above), click on the
Font tab and, in the Font menu, scroll to select Comic Sans
MS, then in the Style menu select Bold, and in the Size
menu select 12, then click on OK


Now you need to do the same for the Subtitle text: August 18 –
September 26, 2014.


Double click anywhere on the Subtitle text to put a blue
box around it, then triple click on the Subtitle text to
select the whole of the text

Now, right click anywhere in the Subtitle Text box and, in the
context menu that pops up, again select Format Title… to bring
up the Subtitle dialog box (more or less the same as Fig. 7.37
above)

In the Subtitle dialog box, click on the Font tab and, in the
Font menu, scroll to select Comic Sans MS, then in the Style
menu select Regular, and in the Size menu select 10,
then click on OK




That takes care of the chart titles. All that remains is to put labels
on each of the slices in the Pie Chart to help the reader of the Mid
Term Report interpret the data in the chart.


Right click anywhere on the pie chart itself and, in the
context menu that pops us, select Insert Data Labels


LibreOffice immediately updates each slice of the Pie Chart with the
value (number) from the Gradedata spreadsheet that corresponds to each
of the Grades—A, B, C, D, or E (Fig. 7.38).
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Fig. 7.38 Updated slices of the Pie Chart

Your last task is to format those numbers in each of the slices so that
they stand out and provide more information to the parents or guardians
who are going to use the chart to compare their child’s grade with those
of the rest of the class.


Right click anywhere on the Pie chart and, in the context
menu that pops up, select Format Data Labels… to bring up the
Data Labels for Data Series ‘Students’ dialog box (Fig. 7.39)
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Fig. 7.39 Data Labels dialog box


Click first on the Data Labels tab and click to put a check
mark in the box next to Show value as percentage

Next, click on the Font tab and select Comic Sans MS for the
Font, Bold for the Style, and 20 for the Size of
the font

Finally, click on the Font Effects tab and select White for
the Font Color, and Embossed for the Font Relief, then
click on OK

Save the Gradedata spreadsheet with the chart embedded in
it




Now you can copy the chart and paste it into the Mid Term Report.


Click anywhere on the white background of the pie chart so that
you see the small green handles around the edges of the chart
box—which means that the chart is selected (Fig. 7.40)
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Fig. 7.40 Finished chart ready to be copied and pasted


Press Ctrl-c to copy the chart to the clipboard

Locate and switch back to the Writer Mid Term Report which is
still open on your screen




The Mid Term Report document should now be the active window on the
screen.


Click to position the cursor at the very beginning of the
paragraph that reads “Please feel free to contact me….”

Press Ctrl-v to paste the chart into the Mid Term Report
document then, in the Formatting toolbar at the top of the screen,
click on the Center icon to center the chart




As is, the letter probably spills over onto a second page because of the
chart. This is no problem if it cannot be avoided.


Navigate to your USB drive > Work Files for LibreOffice


Data Files >Writer Documents folder and Save the
Mid Term Report





Final tasks

First you need to complete the merge of the Mid Term Report with the
Roster 2014 database.


In the File menu select Print, in the dialog box that pops up
click on Yes to confirm that this is a form letter

In the next dialog box, click to send the Output to a File and
click on the radio button to Save as a single document, name
the file Mid Term Report Merged Document, and Save it again




Next you need to save the merged Mid Term Report as a PDF file.


In the File menu, again select Print, and, in the dialog box
that pops up, click on Yes to confirm that this is a form
letter

In the next dialog box, click to send the Output to a File and
click on the radio button to Save as a single document, then
in the Save As dialog box, in the Save as type: data entry
box, click on the down arrow at the end of the entry box and, in
the menu of file types that pops up, click on the option for PDF -
Portable Document Format (.pdf)

Name the file Mid Term Report Merged Document, and Save it
again




If you wanted to print them all out on paper, make sure the printer is
turned on and has paper in it, then click on File >
Print… and proceed as you now know how.

SKILL CONSOLIDATION

Complete these exercises to reinforce what you learned in Lesson 7.

1. Imagine a scenario where you invite your students (as an assignment,
perhaps) to prepare sets of questions for tests based on the material
that you have covered in class. Each student types his or her questions
into the database. You would check the database to make sure that each
student had completed the assignment. Then you would print a copy of the
full set of test questions for every student to use as a study guide.
When the date for the test approaches you would simply select out those
that you want to use, and print up the test using the pre-prepared test
report format.

Individually or together with a team of your classmates, prepare a
database to store sets of test questions. Make up a representative set
of, say, 20 questions, and store them in the database. Prepare a test
report format (form letter) to merge with the test question database.
Use record selection rules to select ten out of the 20 questions. Print
out the test (merge to printer).

2. Get together with a group of your classmates or colleagues. Compile a
list of suggestions for useful macros to use with Writer—macros like
the SchoolAddress macro that you learned in this tutorial. For example,
you could create a macro that types out your letterhead—address,
telephone number, and the date, using different fonts and sizes. Create
half a dozen macros from the best suggestions.

3. Create a form letter to print a set of continuous index cards
cataloging your collection of music. Use the Mailing Labels feature for
this purpose. Set up a data source containing a sample set of data for
at least 6 records. Each record should have at least 5 fields (CD Title,
etc.).

4. Meet together with a group of your fellow students or colleagues,
come up with a list of suggestions for useful form letters to be used in
a school environment, share out the ideas among the group (a minimum of
two each), and create the templates for the form letters. Each person in
the group should save a complete set.

5. Create a Labels form letter to print a set of individualized set of
name tag stickers for a class of students to be worn on the first day of
class so that everyone can get to know each other. Use the Mailing
Labels feature for this purpose. Set up a data source containing a
sample set of data for at least 25 records (use an existing class
database, if you have one, or use the Roster 2014 database that
accompanies this tutorial).

[^1]: I am indebted to Tony Palaez for his video on Mail Merge at
http://www.youtube.com/watch?v=prZJ4w-q9AA
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Lesson 8 More on Database Use



8   MORE ON DATABASE USE

      Manipulating the Data in the Database







LEARNING OUTCOMES

Lesson 8, after reviewing the basics, will introduce you to the
following additional features of the Base database:


• searching and querying a database

• sorting records

• creating reports

• improving the report (making changes)

• printing reports




8.1 GETTING STARTED

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (Continuing with
the tutorial—next page). If you did not complete Lesson 1, then you
must do this now, before proceeding with the rest of Lesson 8.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to prepare these folders now before proceeding with
this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will
help you with this if you are working with a class) and Extract
them onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 8.1).
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Fig. 8.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 8.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

Continuing with the tutorial


Make sure you have your Work Files for LibreOffice available on
your computer, then Open LibreOffice and, from the File
menu, select Open


Base will display the Open dialog box.


Navigate to your USB Drive > Work Files for LibreOffice


Base Files folder





You are going to work first with a database similar to the one you
created in Lesson 6. The database, called Students 2014, has been
prepared for you to use with this tutorial in order to standardize the
directions that follow.


In the Base Files folder open the Students 2014 database

In the left frame of the Students 2014 Base window, click on
the Forms icon, then, in the Forms section, double click
to open the Students 2014 Form




You should see the Forms View of the Students 2014 database, as
illustrated in Fig. 8.2.
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Fig. 8.2 The Forms View of the Students 2014 database

8.2 REVIEWING THE BASICS

Let’s start with terminology.

A database is a document which contains a set of records. Each record
is made up of one or more fields, and each field may or may not contain
entries.

For example, a database of movie titles might have records for a few
thousand movies. Each record will have fields for the movie title, the
director, the producer, the star(s), and so on. A particular entry for
the Movie Title field might be “Star Wars.”

Viewing the data in the database

When you first open an existing database, it is generally best to open a
Forms View of the database because you can easily view the contents of
an entire record on the screen, thus showing you what all the records
basically contain.

In the Forms View, as you can see, the data for one complete record is
shown in the Form. Notice the database navigation tools at the bottom of
the Form window (Fig. 8.3).

Fig. 8.3 Navigation tools in the Base database

Look them over now to re-familiarize yourself with how they work.


Now, close the Student 2014 Form and, in the Database
frame, switch to Tables, and, in the Tables section,
double click on Student 2014 Table to open it


This Table view (Fig. 8.4) shows the records across the screen in rows
and columns much like the Spreadsheets you learned to use in Lessons 4
and 5.
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Fig. 8.4 Viewing records in the Table view

Adding a record to the database

You can add a new record to the database any time you want. After you’ve
added the record you can tell Base to sort everything into a specific
order whenever you need to do so. You will learn how to do this in a
later section of this tutorial (8.4 SORTING RECORDS).

You are going to add a couple of new records now. It’s easiest to do
this in the Forms view of the database.


Close the Student 2014 Table, in the left frame select
Forms, and double click to open the Student 2014 Form,
then click on the New button in the toolbar at the bottom of
the Form window (Fig. 8.5)
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Fig. 8.5 The New button in the Records Group of the Home Ribbon

This will open up a set of empty fields for the new record (Fig. 8.6)
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Fig. 8.6 Entering data for a new record


Enter the data for this new record, then add data for at least one
other new record (two records in all), pressing the Tab key
after you type the data for each field


You can put any data in the new records you are adding because you’ll
delete them in a bit. If no data is required for a particular field,
you can even skip a field (such as the last four fields), by simply
pressing Tab without entering any data.

Clearing a field in a record

You cannot clear entries from a field that has been defined as
requiring data of some kind in the field. If you try to clear data
from these fields (in our database the First Name through the Home
Contact fields, for example) you will get a warning from Base telling
you that you cannot have a null value in these fields.


Use the navigation tools (see Fig. 8.3 on page 227) to go back to
the first of the records you added just now

In the first of the records you added just now, in the Nick
Name field, double click in the entry box (not on the
field name) to highlight the Nick Name entry, then press
Ctrl-x on the keyboard to cut the data in the Nick Name field

Next go to the second of the records you added a moment ago, click
in the Clubs field entry box and again select the data in
the Clubs field, then press Ctrl-x on the keyboard to cut
the data in the Clubs field




Notice that this does not delete the field or the record; it simply
clears the selected data in the field. The field is still there, so
new data can be entered at any time.

Deleting (clearing) a record, or a set of records


Locate one of the records you just added, then in the Form
Navigation toolbar (Fig. 8.7), select Delete Record
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Fig. 8.7 Deleting a Record

Base immediately displays a warning dialog box (Fig. 8.8) to tell you
that if you go ahead you will permanently lose the data in the record.
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Fig. 8.8 Delete Record warning prompt


Click on Yes to delete the selected record


Notice that this removes the record entirely.

Changing the data in a field

Suppose some data gets entered incorrectly—through misspelling or a
typo. Let’s say you needed to update a nickname in a student’s record.
To change it you would do the following.


Locate the record in which you want to make the change (for this
exercise select any record you like)

Click in the entry box for the field data that needs to be changed
(use any entry in the Nick Name field), then change it to some
other nick name in the same way you would in a word processor




All of the exercises in this section were by way of recapitulating what
you learned in Lesson 6. Now let’s move on to learn some more advanced
features of the Base database.

8.3 searching and querying a DATABASE

This is a powerful function of the Base database. You can find
anything in the database if you know what to do.

All you have to do is give Base any set of characters as the key for a
search of the database, and the system will find that set of characters,
if it exists, even if it is just a part (a subset) of a larger word or
phrase. There are several ways you can do this.

But first you need to open another, larger, database.


Close the Students 2014 Form, then Close the Students
2014 database, and from the File menu select Open


The USB drive containing your Work Files for LibreOffice should still
be in a USB port on your computer.


On your USB drive > Work Files for LibreOffice > Base
Files folder open the Birds database

In the Database objects menu on the left side of the database
window, click on Forms and, in the Forms section, open the
Birds Form (Fig. 8.9)




[image: ]

Fig. 8.9 Bird Sightings Form

Finding a single record using data from a specific field

You often may need to locate and display the contents of one particular
record, or set of records, based on data from one specific field. The
Find function, which is in the Home Ribbon > Find Group, is the
Base command to do this. It works much the same as when you use the
Find command in the word processor, which you learned about in Lesson 2.

Suppose, for example, you wanted to find the record for the bird with
the Common Name Northern Oriole. Here is how you do this.


In the Form Navigation toolbar at the bottom of the Form
window, click on the Find Record tool—it looks like a spy glass
(Fig. 8.10)
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Fig. 8.10 The Find Record tool in the Form Navigation toolbar

LibreOffice now displays the Record Search dialog box (Fig. 8.11).

[image: ]

Fig. 8.11 The Record Search dialog box

You need to indicate what data you want to be found in the Birds
database by typing in a search string (which for our search will be
Northern Oriole).


In the Search for entry box type Northern Oriole (or
northern oriole—if you don’t check the “Match Case” box,
Base doesn’t care whether you use upper or lower case letters)


Before clicking on the Search button, you need to identify where you
want to search (All Fields). You also need to indicate if you want to
match the data in a whole field or part of a field.


Click to check the radio button next to All Fields, and leave
the selection for anywhere in the field, and there’s no need
to match case

Now click on Search, and notice that the number 35 appears in
the lower left hand corner of the search window, indicating that
the Northern Oriole is record #35 in the database




The record(s) you find with a Find request are called the “found set”.
As you see, Base quickly locates the record containing the name
“Northern Oriole.” The record is displayed in the Birds Form window.

Of course, if you typed Northern Oriole incorrectly, Base would tell
you that the search item was not found (Fig. 8.12).
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Fig. 8.12 Warning message after unsuccessful search of the database


Close the Find and Replace dialog box, then in the Home
Ribbon > Views menu, select Table View to see the records
following the Northern Oriole record


Finding two or more records based on data from a single field

Next, let’s search on criteria which will find more than one record. You
want to find any bird with the primary color (Color1) that has any
shade of black in its plumage.


Close the Record Search dialog box

In the Birds Form, click to put the cursor anywhere in the
Color1 field

In the Form Navigation toolbar at the bottom of the Form
window, click on the Find Record tool and, if it’s not already
the color you want, in the Search for > Text box, type the
word Black, and in the Where to search > Single field
box, make sure Color 1 is selected, and in the Settings >
Position box select the option for Anywhere in the field

Click on Search, then move the Record Search dialog box out of
the way, if necessary, so you can see the contents of the record




The search finds the first of 11 records where a bird in the database
has the color “black” or even “blackish” in its plumage.


To see the data in the next record, click on Search again, and so
on

See if you can count 11 records of birds with the color black
or blackish in the plumage?




To see a listing of just those 11 records that result from a search
such as this, you must use a filter.

Using the AutoFilter

In general, filtering is best done in the Table view of the database.
The exercise that follows will use LibreOffice’s AutoFilter tool to
select the set of birds whose habitat is “marshes.”


Close the Record Search dialog box and close the Birds
Form then, in the Database frame (Fig. 8.13), click on
Tables and, in the Tables section, double click on the
Birds Table
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Fig. 8.13 The Database Tables object > Birds Table


In the Birds table, scroll to the right to locate the
Habitat column (Fig. 8.14)
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Fig. 8.14 The Birds Table view showing the Habitat column


Now click, in the Habitat column, on the first Marshes entry
you see (there’s one in the third entry in the Habitat column),
then, in the Tables toolbar at the top of the Birds table,
click on the AutoFilter tool (Fig. 8. 15)
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Fig. 8.15 Using the AutoFilter tool to find all the birds that have a
Marshes Habitat

This tells Base that you want to filter by selection the set of birds
that live among marshes.

Base now displays a list of 15 birds in the database that live in
marshes (Fig. 8.16).
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Fig. 8.16 The found set of filtered records


To go back to viewing all the records in the database, click the
Reset Filter/Sort icon on the toolbar (Fig. 8.17)
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Fig. 8.17 Reset Filter/Sort tool in the Table Data toolbar

Using the Standard Filter

You also can filter records using LibreOffice’s Standard Filter. You
need this, for example, if you need to select a set of records based on
more than one criterion.

Let’s say you want to find all the records in which the birds have
either the color “black” or a combination of “black” and some other
color in their plumage. This involves filtering based on both the Color
1 and Color 2 fields.


In the Table Data toolbar, click on the Standard Filter tool
(Fig. 8.18)
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Fig. 8.18 The Standard Filter tool

When you click on the Standard filter tool, LibreOffice presents the
Standard Filter dialog box, in which you have the opportunity to set 2
or more criteria for the filter (Fig. 8.19).
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Fig. 8.19 The Standard Filter dialog box


In the first Field Name box, click on the down arrow to
show all the fields in the Birds database and click on Color
1, leave the equals sign (=) in the Condition box, then type
‘black’ in the Value box

In the second Field Name box, click on the down arrow to
show all the fields in the Birds database and click on Color
2, then step back to the Operator box, click on the down
arrow and select OR for the operator, then leave the equals
sign (=) in the Condition box, and type ‘black’ in the
Value box




These criteria that you have selected should find all the database
records in which the birds have either the color “black” or a
combination of “black” and some other color in their plumage. Let’s see.


In the Standard Filter dialog box, click on OK


Now look at the set of records that the filter found (Fig. 8.20).
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Fig. 8.20 Result of a Standard Filter of the Birds database

Check out the Color1 and Color 2 fields in the Found Set of 14 birds.
One or other of them has the color ‘black’ somewhere in their plumage.

This might seem like a silly exercise. Maybe it wouldn’t take you long
to find the 12 records out of the 50 records in the database. Wouldn’t
take you a minute or two to do that, right? But suppose you have 500
records, or 5000 records, or, as is common in school districts in large
cities, 500,000 records or more. The larger the database, the more you
need tools such as these filter tools—and the Sort tools in the next
section—to help you quickly find the data you need.


Click again on the Reset Filter icon (Fig. 8.17 page 235 above)
before proceeding to the next section in the tutorial


8.4 sorting records

The three major advantages of an electronic, digital data storage system
over a manual, paper-based filing system are these:


1. Digital, electronically stored data with its easy ability to quickly
access the data you need in any of multiple formats and the easy ability
to organize it in any of multiple ways, provides more or less instant
organizational flexibility—using filtering and sorting, for
example—which helps you cope with the inevitable complexity that
increases as the sheer amount of data grows.

2. Digital, electronically stored data saves space—physical space,
that is. You don’t need a filing cabinet, or oodles of filing cabinets
in a storage room, or, for some companies, a whole building for a data
repository. For teachers, like you and me, all we need is a few
gigabytes of storage on a USB drive, which we can carry on a car key
chain or in a pocket (provided we’re careful to backup all the data on
another computer in the office or at home).

3. Digital, electronically stored data increases the speed of data
access and thus saves time.




When we use old-fashioned filing cabinets to store data, we usually come
up with some kind of organization. So we put labels on the drawers in
the cabinets and labels on the folders inside the drawers. This
organization is often based on numeric or alphabetic sequencing. The
purpose, of course, is to enable us to quickly find what we have stored
in the appropriate folder in the appropriate drawer.

This is a good system as long as we have no cause to frequently change
the organization we have set up. It also assumes that space and time are
not at a premium in our day to day operations. Unfortunately, coping
with change, making good use of space, and saving time are factors
critical to our productivity. So we should welcome any system which
helps us cope with change and optimizes our use of space and time.

Today, using state of the art technology, we can electronically store
the equivalent of the Library of Congress in a shoe box. And we can now
access any specific item in that “box” in a few thousandths of a second.
What is more, software such as Base makes it possible for you to
organize that data more or less on the fly by sorting it any which way
you want.

Sorting on a single field

Take, for example, the Birds database that is on your desktop at this
time. As you can see, the names of the birds (in the Common Name field)
are not sorted in any particular order. In fact, the database is sorted
based on the ID field (which is the Primary Key for the relational
database).

So the ordering is numerical rather than alphabetical. It would
therefore be time consuming, if not well-nigh impossible—especially if
the database were very large—for you to visually scan the database to
find the record for a particular bird.

This is why Base makes available the Find Record, Filter Records,
and Sort Records functions accessible in the Form Navigation toolbar.
We’ve looked at the Find Record and Filter Records functions. Now
let’s check out the Sort Records function.

What if you wanted to print out a report listing all the birds in
alphabetical order by name of bird? You would have to begin by
organizing the records alphabetically on the bird names. Fortunately
Base has a set of Sort tools that enable you to complete this
operation with the greatest of ease. Fig. 8.21 illustrates where you
will find this set of Sort tools.
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Fig. 8.21 The Base Sort tools in the Table Data toolbar

You can best see the results of a sort if you are in the Table view of
the database, which is the view you should have on your screen from the
previous exercise.


Click to put the cursor in any cell in the Common Name field, then
click on the Sort Ascending button (Fig. 8.22)
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Fig. 8.22 The Sort Ascending tool

Immediately Base sorts the records alphabetically on the Common Name
field, with the American Bittern at the top of the list, and so on.
There are three basic sorting options depending on the type of data in
the field you are using as the basis, or key, for the sort:


• If your sort request is based on a Text field such as Common Name
or Location Sighted, the sort will be alphabetical and can be either
Ascending (A to Z) or Descending (Z to A).

• If you are sorting on a Number field such as the Count field, the
sort will be numerical and you again would be able to sort in
Ascending (low number to high number) or Descending (high number to
low number) order.

• Finally, if you are sorting on a Date field such as Date Sighted,
the sort will be chronological and you would be able to sort in
Ascending (chronological) or Descending (reverse chronological) order.




Let’s do another quick sort for practice—which, as we know so well,
makes perfect.


Click to position the cursor anywhere in the ID column, then click
on the Sort Ascending tool (see Fig. 8.22 above) and immediately
LibreOffice sorts the data based on the ID field, with the value
1 at the top and the value 50 at the bottom—and the data that goes
with each ID is, of course, sorted along with it


As you see, basic sorting of a database is simple.

8.5 CREATING QUERIES AND REPORTS

In the next sections you will continue to work with the Birds
database.

Initial definition of the layout or report

You are going to create a layout, or report, which will list all members
of the Duck family sighted during the reporting period covered by the
database. The fields in the report will include the Common Name (of the
bird), Family, Date Sighted and Count fields.

Bear in mind that most databases have many fields. If there are more
field names in a report layout than can fit across the screen or page,
the names simply wrap around, creating two or more lines, if necessary,
in the top section (the Header) of the layout.

This can make for untidy, not to say confusing, reports. The columnar
report you are about to work with will not have this problem because you
will be using only a small selection of the fields in the database (just
4 to be exact), but it is good to be aware of the problem should the
occasion arise where you want to create a report that uses many fields.

You can get around this problem is various ways, the simplest of which
is to change the font to one which requires less space, or reduce the
size of the font you want to use, or lay out the fields in some format
other than tabular (like a Table or spreadsheet). You might also
consider whether you really need all the fields that you have selected
for the report. Often, simpler is better. Simple reports are more likely
to make the desired impact on the reader.

Creating a Query

You need to start by using a Query to tell the Birds database exactly
which data you want to use for the Report. You want to select only the
birds in the Duck family for the Report. Once you have created the
Query, it will be a simple matter to create the Report. Here are the
steps to create the Query.


The Birds Table should still be open on your screen; close
it, since you’ll be using the Queries Database object for this
exercise

In the Database frame at left, click on the Queries icon,
then, in the Tasks section, click on Use Wizard to Create
Query… (Fig. 8.23)
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Fig. 8.23 Using a Wizard to create a Query

LibreOffice now presents the familiar Wizard window, asking you
(Step 1) to select the fields that will be involved in the Query (Fig.
8.24)
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Fig. 8.24 Step 1 of the Query Wizard

Notice that the fields are all coming from the Table: Birds Table in
the Birds Base database.


Double click, in turn, on Common Name, Family, Date
Sighted, and Count fields to move them across to the Fields in
the Query box, then click on the Next > button


The next step in the Wizard, Step 2, asks you if you want to sort the
data. There’s no need to do this—the query will take care of selecting
out the data you need.


Click on Next > to proceed to Step 3


In Step 3 you’re going to Select the search conditions for the Query
(Fig. 8.25).
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Fig. 8.25 Selecting the search conditions for the Query

In Step 1 you selected the Fields for the Query, and now you must
select a subset from the family field for the Report you will build
in the next exercise, a report which is based on the Query you are
creating right now.


Click on the down arrow in the first Fields box and, in the
drop down menu of Fields, select Birds Table.Family, leave the
Condition as is Equal to and, in the Value box, type the
entry Duck (we want every type of Duck—and only Ducks— in our
report), then click on Next >

In the next step of the Wizard—Step 4—Detailed query is the
default and that’s what you want, so click on Next > again

Steps 5 and 6 are greyed out because you don’t need them for
this query, nor do you need to change the field names in Step 7
(Aliases), so click on Next > once again




Step 8 presents an overview of what should go into the Query that is
going to determine the contents of the upcoming Report. The Title the
Report will be Count of Ducks Sighted.


So, in this last step of the Wizard, change the Name of the Query
to Query_Count of Ducks, leave the default to Display Query
when you finish this exercise so that you can check that the Query has
successfully produced the Found Set of data you want for the
report, then quickly read through the Overview section to see if
what you have done in the previous steps makes sense

When you’re ready, click on Finish




Quickly, Base uses the Query to produce a display of the Found Set
(Fig. 8. 26)
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Fig. 8.26 The Query_Count of Ducks Found Set

What you see on your screen should be the same as in Fig. 8.26—9
records, all of them from the Duck family, showing their Common Name,
Date Sighted, and Count. Now you’re ready to go ahead and create the
Count of Ducks Sighted Report.

Creating a Report based on the Query


Close the Query_Count of Ducks window and, in the Birds
database window, in the Database frame at left, click on the
Reports icon then, in the Tasks section click on Use Wizard
to Create Report… (Fig. 8.27)
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Fig. 8.27 Selecting the Wizard to create the report

This will bring up the Report Wizard dialog box (Fig. 8.28).

[image: ]

Fig. 8.28 The Report Wizard dialog box


In Step 1 of the Report Wizard, in the Tables or Queries
data box, leave the default Query: Query_Count of Ducks as the
source for the report’s data (Fig. 8.28 above)

Then, in the list of Available fields, click on the double
arrow (see Fig. 8.28 on previous page) to move all four fields
to the Fields in report box (Fig. 8.29), then click on **Next


**
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Fig. 8.29 Selecting the Fields for the report

This brings up Step 2 of the Report Wizard, where you are asked to
decide how you want to label the fields for the report (Fig. 8.30)
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Fig. 8.30 Step 2 of the Report Wizard


The labels are fine as they are, so click on Next >


In Step 3 of the Report Wizard you are asked if you want to add grouping
levels (Fig. 8.31).
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Fig. 8.31 Step 3 of the Report Wizard


Again there is no need to add grouping levels, so click on **Next


**


In Step 4 you are asked if you want to sort the data in the
database prior to producing the report, but you already sorted the
data in an earlier exercise based on the Common Name field, and
again, for practice, based on the ID field, so click on **Next


** to proceed to Step 5 of the Report Wizard, where you are
asked how you want to layout the data in the Report (Fig. 8.32)
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Fig. 8.32 Step 5 of the Report Wizard


Tabular layout is like a spreadsheet, where you have column
headers with the data for each column listed below each of the
headers, as in a Table, which is the default layout you want, so leave
Tabular as the Layout of data option

You have four (4) fields in the report, and you can fit them across
the Portrait-oriented page, so click on the radio button next
to Portrait for the Orientation (Fig. 8.32 above), then click
on Next > to proceed to Step 6 (Fig. 8.33)
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Fig. 8.33 Step 6 of the Report Wizard (Create Report)


In the Title of report box type the title: Report_Count of
Ducks

You want the report to be Dynamic so that the report will reflect
changes to the data at a later date should the data in the database
change, which is likely over time, so make sure the radio button
next to Dynamic is checked (Fig. 8.33 above)

You also want to go ahead and have LibreOffice create the report
after you click on Finish, so click on the radio button next to
Create report now (Fig. 8.33 previous page), then click on
Finish




On the screen you should now see a rough and ready version of the report
with column headers and, underneath them, the data for each column from
the Found Set of Duck records (Fig. 8.34).
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Fig. 8.34 Rough and ready version of the Count of Ducks report

Notice (Fig. 8.34 above) that the report is initially read-only—you
can’t actually interact with it and make any changes to it as is. There
are a couple of ways that you can work on the design of the report to
make it more meaningful and visually appealing. The first is to use the
Report Builder.


Close the Read-only version of the report then, in the Birds
database top level window (Fig. 8.35), make sure the Reports
object is selected in the left hand Database frame, and right
click, in the Reports section, on the Report_Count of Ducks
report to bring up the context menu (Fig. 8.35)
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Fig. 8.35 The context menu for the Report_Count of Ducks


In the context menu select Edit, which brings up the Count
of Ducks report in the Report Builder (Fig. 8.36)
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Fig. 8.36 LibreOffice Report Builder

The Report Builder has all the tools you need to work with the report
and eventually come up with a layout and design that is both meaningful
and pleasing to the eye. The report is essentially a Writer document
that contains the data from the database. If you were to use the Report
Builder to complete the design of the report, you would switch back and
forth from the Report Builder to the work-in-progress Writer document
by clicking on the Execute Report icon in the Standard toolbar, as
illustrated in Fig. 8.36 above. Let’s try this now.


In the Standard toolbar, click on the Execute Report icon to
quickly bring up the rough and ready version again, which still looks
much the same as Fig. 8.34 on page 246


However, depending on the version of LibreOffice you have installed on
your computer, the Report Builder is unfortunately not necessarily the
best tool to use to complete the design of the report. For this reason,
you would be as well advised to work directly with the rough-and-ready
version, using the tools that you have already learned about in
LibreOffice Writer in Lessons 1, 2, 3 and 7 of these tutorials.


The rough-and-ready version of the report should be open on your
screen, and in order to edit the report click, in the Standard
toolbar, on the Edit File icon (Fig. 8.37)
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Fig. 8.37 The Edit File icon in the Standard toolbar

Your goal now is to work with the report until you can create something
close to the version displayed in Fig. 8.38.
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Fig. 8.38 The final version of the Count of Ducks Sighted Report

Here are some tips to help you along the way. But bear in mind that
trial and error is the only way to end up with a final satisfactory
outcome, so be patient and don’t give up until you have something
resembling the report in Fig. 8.38.

The column headers move independently of the data that is listed in each
column. Let’s start with the Column Headers. Fig. 8.39 shows a close up
of what is involved with moving headers in the report.
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Fig. 8.39 Adjusting the position of headers in the report


Position the tip of the mouse pointer on the vertical line that
divides the Count field from the Date Sighted field (the pointer
becomes a cross hair), hold down the left mouse button, and
slide the Count header to the right an inch or so (Fig. 8.40)
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Fig. 8.40 The Count header moved over to the right


Now position the tip of the mouse pointer on the vertical line to
the immediate left of the data in the Count column (the pointer
becomes a cross hair), hold down the left mouse button, and
slide the set of data to the right until it is more or less
centered under the Count column header (Fig. 8.41)
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Fig. 8.41 The Count data set centered under the Count column header


Now do the same with the Common Name, Family, and Date
Sighted headers and data sets till you have them laid out much the
same as illustrated in Fig. 8.38 on page 248

Go to File > Page Preview to see how the page will look at
this stage (it should look like Fig. 8.42), then click on Close
Preview to continue working on the report design
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Fig. 8.42 Report after adjusting the column headers and data sets

All that remains is the report header, where you are going to insert a
Title and the date (see Fig. 8.38 on page 248).


Click anywhere in the Header area above the column headers (see
Fig. 8.43 below—look carefully, and you’ll see the cursor flicking on
and off in the top left corner of the header), then, in the Standard
toolbar, change the font to Liberation Sans, the font
size to 32 pt, and click on the Center icon to center the
title (Fig. 8.43)
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Fig. 8.43 Creating the title for the report

Go ahead and type the report title: Count of Ducks Sighted, hit the
Enter key to move the cursor to a new line, change the font
size to 14 pt, and go to Insert > Fields > Date,
then do File > Page Preview to check out the final product

If all went well, your report should now look very much like that
illustrated in Fig. 8.38 on page 248. There are many more changes you
could make to the report, such as adding graphics (maybe a picture of
some ducks on a pond, for example) or background colors, and the like.
If the report spanned several pages, you would almost certainly want to
include page numbers (Insert > Fields > Page Number, which you
learned about in Lesson 2). This is just an introduction to the topic of
creating queries and reports. It is now up to you to extend your skills
beyond these tutorials. Practice makes perfect, as you know so well.


8.6 PRINTING REPORTS


Once you have prepared the new report, it is a straightforward process
to print the report. The command to do this is the same as you have used
to print any other documents from within Microsoft Office, whether you
have been working in Word Processing or the Spreadsheet.


You should still be in the Page Preview window, so click on the
Print button in the Standard toolbar (Fig. 8.44) to print the
Count of Ducks Sighted report
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Fig. 8.44 The Print icon in the Standard toolbar

Remove the report from the printer and take a closer look at its
contents. Notice that the only records in the report are those relating
to ducks in the Family field. These are just a small subset of records
drawn from the larger Birds database.

SKILL CONSOLIDATION

Complete as many of these exercises as you can to reinforce what you
learned in Lesson 8.

1. Work with a group of your colleagues or classmates to specify and
create a series of reports to accompany a database of student data such
as the Roster Template database that you created in Lesson 6. Save the
template with the set of reports.

2. From the Work Files for LibreOffice folder on your USB drive, open
the Roster 2008 database onto the Desktop.


• Add a record

• Change the address and phone # in an existing field

• Arrange the records chronologically on date of birth




3. Create a new database (do not use a database you already created) on
any topic of your choosing.


• Design the fields (at least 10) to be included in the database

• Save the empty database document

• Add at least 20 records

• Save the database document again

• Prepare a report using just 5 of the fields in the database

• Save the database with the report and send the database to your
professor as an attachment in email




4. Open the Birds database (in the Practice folder on your Work Disk)
onto the Desktop.


• Find all the birds that have blue, grey, green, or olive in
their Color1 plumage

• Arrange (Sort) the birds in descending order (reverse alphabetical
order—from Z to A)—the Birds, not the Colors!

• Prepare a report using just the following 5 fields in the database:
Common Name, Family, Color1, Habitat, Count

• Save the Birds database with the report and send the database to
your professor as an attachment in email
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Lesson 9 IMPRESS  Presentations



9   > IMPRESS PRESENTATIONS
>
> Creating slide shows



LEARNING OUTCOMES

Here are the topics that will be covered in this lesson:


	introductory thoughts about presentations;

	Impress at work;

	building the presentation;

	adding bells and whistles to the presentation;

	printing presentation handouts.



BEFORE YOU BEGIN

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (9.1 Introductory
Thoughts About Presentations—next page). If you did not complete
Lesson 1, then you must do this now before proceeding with the rest of
Lesson 9.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to prepare these folders now before proceeding with
this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will
help you with this if you are working with a class) and Extract
them onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 9.1).
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Fig. 9.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 9.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

9.1 Introductory THOUGHTS ABOUT PRESENTATIONS

Making a successful—well-designed, content-rich,
pedagogically-sound—Impress presentation requires forethought and
advance preparation. It’s rather like what good cooks or chefs do before
starting to cook a delicious dish of food. They read the recipe, make
sure they have all the ingredients they need, gather all the ingredients
together—the raw food such as vegetables and eggs and milk and wine and
spices and other flavoring—what they call the mise en place. They make
sure they have all the tools they need to do the job.

Good cooks don’t start cooking till they’re good and ready. In the same
way, you have to get your thoughts together, know what you’re going to
talk about, and have your audio-visual material gathered together in one
place (mise en place) so that when you come to create the
presentation, it’s a snap!

A good presentation, like a term paper, is usually based on an outline,
such as is illustrated in Fig. 9.2.
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Fig. 9.2 Outline for the Tudor Monarchs presentation

You see on the left an outline of the text for each slide in the Tudor
Monarchs presentation. Think of the titles and text for each slide as an
outline you would have made for a high school or college paper. Similar,
right? This is why the outlining tool is built into Impress—to help
you plan.

Remember the golden rules of successful design: Rule 1—Plan; Rule
2—Plan; Rule 3—Plan! These golden rules apply whether you are designing
a term paper, an audio-visual aid, a class outing, or a class syllabus
and schedule.

You might begin with a brainstorming session to help you get an outline.
During brainstorming, members of the group would come up with as many
ideas as possible related to the topic of the project. Nobody’s ideas
are rejected in the early stages so as to encourage a fertile flow of
useful suggestions.

The result of the brainstorming session might be a somewhat disorganized
list of ideas. This list might have been entered directly into the
computer during the brainstorming session, or it might have been
collected on a blackboard or flip chart. Before changing the list into
outline form you would re-organize it so that the ideas flowed naturally
and logically from one to the other.

Along the way you might toss out some of the ideas for one reason or
another. Eventually you’ll have a working list which would end up as an
outline, perhaps in a word processor document.

9.2 IMPRESS AT WORK

Let’s see these ideas and others at work by looking at an example of an
Impress presentation.


Turn on your computer, open LibreOffice then click on Open File
and, in the Open dialog box, navigate to your USB drive >
Work Files for LibreOffice > Impress Files folder and
double click to open the Tudor Monarchs presentation


Fig. 9.3 shows the Tudor Monarchs presentation in Normal View as it
appears on your screen right after you open the document.
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Fig. 9.3 The Tudor Monarchs presentation

Take a look at the Slide View tools in the upper left corner of the
Impress window (Fig. 9.3 above). You’ll use these tools a lot while
you’re developing your slides, so let’s take a closer look at them right
away and find out what each of them is about (Fig. 9.4).
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Fig. 9.4 The Slide View tools

Different ways to view the slides in your presentation

Normal view

This is the view you see illustrated in Fig. 9.3 above. It is the one
you’ll use most of the time while you’re actually putting information on
each slide. In this view, you have a left hand frame where you see
thumbnails of all your slides in a scroll box. In the center of the
window you have the slide you are actually working on—the active slide.
Then, over in the right hand frame you have the Properties Pane (not
shown in Fig. 9.3 above), where you’ll find more tools to help you to
develop your presentation.

Outline View

The Outline View lets you see just the text on each slide. If you
want, you can use the outline tool to map out/plan the content of your
show before you “pretty up” the show with graphics and colors and
backgrounds and so forth.

Notes View

The Notes View is especially useful if you want to explain, or
reinforce, the content of each slide, either for your own use as the
presenter, or for your students, or for whoever is in your audience who
would like more information than is on each actual slide. In the Notes
View you are presented with a smaller version of each slide, one by one,
with ample space for extra notes pertaining to the content of each
slide, as illustrated in Fig. 9.5.
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Fig. 9.5 The Impress Notes View showing the supplementary notes for
Slide One

Handout View

Anyone who gives a presentation is, in a way, a teacher, and the people
listening to him or her are, in a way, students, hoping to learn
something they didn’t know before.

One of the problems with being a student is that it’s difficult to grasp
right away what the teacher is trying to get across. Good
teachers/presenters give their audience the opportunity to take away at
least a summary of what they have had to say. Hence handouts; and
LibreOffice makes handouts a snap.

Fig. 9.6 illustrates the Impress Handout View.
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Fig. 9.6 The Impress Handout View

The best presentations do not overdo the use of slides! In other words,
if you are presenting for 40 to 50 minutes, you shouldn’t need more than
half a dozen slides—ten max.

One good rule is based on Miller’s Magical number (pertaining to short
term memory). People can hold on to no more than about 7±2 items—ideas,
numbers, whatever—in short term memory before those items are very
quickly gone! Keep it simple and attractive to the eye is the golden
rule.

But reinforcing those ideas, numbers, or whatever with some kind of
follow up or repetition significantly helps retention. Handouts are one
way to serve that purpose, and the Impress Handout View makes it easy
to format and print (or e-share through email, Facebook, and the myriad
other online social media) the Impress presentation that you have so
carefully designed and produced.

*\


	



Slide Sorter view

This is the view you see illustrated in Fig. 9.7, and it is the one
you’ll find most useful when you want to get an overview of your show
while you’re working on it, since you’ll be able to see most all your
slides laid out for you on one screen or page.
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Fig. 9.7 The Slide Sorter View of the Presentation

You also can easily move your slides around, using the mouse to slide
them into place, changing the order to suit your purposes. This is why
it’s called the Slide Sorter view.

You’ll find yourself using these tools frequently to switch from one
view to another as you are developing your Impress presentations.
Let’s further check out the Slide Sorter view now.


Click on the Slide Sorter tool in the Slide Views toolbar
(Fig. 9.7 above)


Take a look at the Slide Sorter View window that is presented to you now
(more or less the same as Fig. 9.7 above, though your screen may be a
different width, so the slides may be arranged differently across the
page).

The presentation you are looking at demonstrates some of the basic
features of Impress. By the end of this lesson you will be able to
build your own presentations along the same lines.

It’s time you worked your way through the Impress presentation about
the Tudor Kings and Queens of England.


Click on the Normal View in the Slide Views tools and, in the
Presentation toolbar, click on the icon to Start from first
slide (Fig. 9.8)
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Fig. 9.8 Start from First Slide icon in the Presentation toolbar

Features to look out for in the demonstration presentation

While you click your way through the Tudor Monarchs presentation, look
out for the following Impress features that have been used in the
creation of the Tudor Monarchs slide show.

Transition effects and animations

The transition effects from one slide to another and the text animations
(which determine how the text will arrive on each slide) have been set
at random for the demonstration. This is to give you some idea of the
variety of transitions and animations you can use in Impress.

But this is not necessarily a good thing to do. Normally you would not
want to use many, if any, different transitions and animations since it
might distract from the impact you are trying to make. A good designer
homes in on a style that he or she likes best for a particular theme and
tends to stay with it for all the slides in the show.

Inserting clip art, pictures and other media

LibreOffice offers a database of clip art and other media on a
wide range of topics. This online database is available to all the
software in the LibreOffice suite.

Fig. 9.9 illustrates the Gallery from which you can select clip art and
other media (such as photos, movie clips, sound files, and so
forth) to insert onto your slides.
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Fig. 9.9 Ribbon for inserting images, illustrations, and other media

You can download clip art, photographs, sound files, video clips and
other media from a file you have saved on disk, or from collections
available free of charge on the Web. Or you can bring onto a slide all
kinds of charts and tables from other LibreOffice programs such as
Writer or Calc.

You can also scan pictures directly onto a slide. So, if you have a
scanner connected to your computer, you’re in business.

If you’re looking for multimedia material to accompany your slides, the
Web is the place to go. Companies, universities, schools, and
individuals, especially teachers, are creating and making available
excellent multimedia materials. These materials are available, mostly
free of charge, from websites such as flickr.com, youtube.com, and
so forth.

Impress makes it easy to incorporate such material into presentations,
with or without accompanying text.

Remember though: YOU MUST ALWAYS GIVE CREDIT FOR ANYTHING YOU
ACCESS ONLINE.

*Buttons, Slide Controls and Hidden Slides *

Notice the use of buttons to allow the user to control movement
through the slides, thus making slideshows both interactive and
non-linear—in other words, the user has control over the sequencing of
the slides.

For example, in the Tudor Monarchs slide show there is a Hidden Slide
(slide #5) which is only able to be seen if, on slide #4, you click on
the orange button to see the answer to the question posed there. Let’s
check this out (Fig. 9.10).
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Fig. 9.10 Using buttons to control the progress through the slide show


If you are actually viewing the slide show, hit the Esc(ape) key
on the keyboard to exit the slide show then, in the Slides
menu on the left of the Impress window, click on Slide #4
to make it the active slide

In the Slide Show menu click on Start from current Slide




Slide #4 is showing on your full screen as an active slide in the show.


Now, read the text on the slide, but DON’T click on the orange
button towards the bottom of the slide to find out the answer to the
question as to why Henry VIII broke away from the Church of Rome;
instead click on the yellow button at the top of the slide to
proceed to the next slide


So, you can create interesting interactive learning materials using
Impress. Lesson 10 will help you learn more about interactive
presentations such as this. Your students, too, will have a lot of fun
using Impress to develop projects of all kinds for every subject under
the sun.

Let’s continue checking out the remaining Impress features.

Timing and other considerations

Fig. 9.11 shows the Slide Sorter View of the presentation. Fig. 9.11
also highlights the type of transition you can choose, how fast you want
the transition to occur, whether you want a sound to accompany the
transition from slide to slide, and so forth.
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Fig. 9.11 The Slide Sorter View showing the Slide Transition settings


Notice, in the Slide Transition pane on the right hand side of the
Slide Sorter window, that the transition (Random Transition) is set to
Fast, with an accompanying sound called Apert. Each slide will
advance automatically after 15 seconds, unless the user clicks the
mouse on the “Click to proceed” button on each slide, in which case the
slide will advance right away.

Acknowledgements: Always give credit where credit is due

The last slide in any presentation, just as the last item in a term
paper or the credits that run at the end of a movie, should usually be
your list of sources cited or used—your Acknowledgements slide (Fig.
9.12).
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Fig. 9.12 The first Acknowledgements slide


So… If you haven’t already done so, in the Presentation toolbar,
click on the icon to Start from first slide (Fig. 9.8 on page 260)

Click your way through the presentation now (click on the Buttons
on each slide to proceed to the next slide)




The slides have been timed to allow the user (right now, that’s you) to
easily view and read what is on each slide without feeling rushed. If
you want the slides to proceed at a faster pace, simply click on the
Click to proceed button on each slide.


When you have finished reviewing the Tudor Monarchs slide show,
exit the show by hitting the Esc(ape) button in the top
left corner of the keyboard


So much for an overview of Impress. No doubt you are anxious to start
creating your own presentation. The next section will help you do just
that.


Close the Tudor Monarchs presentation when you are ready to
continue


9.3 BUILDING A NEW PRESENTATION

Preparation of the outline

You are going to prepare a simple outline, which will give you the
experience to prepare your own outlines when you develop your own
Impress presentations.

Whenever you’re preparing a new Impress presentation, take your time.
Think about it; gather your data; brainstorm, with yourself at least,
and with friends if necessary. Don’t just blunder along, OK? So let’s
begin.


From the File menu select New, then open a new Impress
presentation

Go to File > Save As, navigate (Browse) on your Computer to
your USB drive (Removable disk) > Work Files for
LibreOffice > Data Files folder and Create a new folder
called Impress Documents

Open the Impress Documents folder, name the new presentation
Screenbeans, and click on Save




When you first open a new, blank presentation in Impress, the program
presents you with the Normal View (Fig. 9.13).

[image: ]


Fig. 9.13 New Presentation window in Normal View


The first slide, by default, is in the Title Slide layout. This is
because you would normally want to start out a presentation with a slide
that displays the title of your show, along with sub titles such as your
name and so forth.

You don’t have to use this slide layout, of course. Impress provides
a set of slide layout templates from which you can choose when you are
working on a slide, including one layout which is blank. The Blank
Slide template allows you to create slides from scratch, entirely of
your own design.

Let’s take a look at these different Slide Layouts now (Fig. 9.14).
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Fig. 9.14 Slide Layouts

Click on each of the layouts to check them out, then click on the
Title layout last when you are ready to proceed with the lesson




Typing the outline entries

The Normal View is fine when you have your presentation built, bar the
shouting, and you want to be able to check out and edit individual
slides that you have already created. But when you are at the planning
stages and you want to create an outline of the text you want to
include on each slide, it is best to use the Outline View. Impress
provides a lot of help such as this while you’re developing your
presentation. Let’s switch to the Outline View now.


In the View Ribbon > Presentation Views Group click on the
Outline View tab (Fig. 9.15)
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Fig. 9.15 The screen at the start of a new blank presentation

As you type the text for each slide, the text will be entered onto the
slide itself with no extra effort on your part, thanks to Impress’s
slide layout features. You’ll see how this works when you switch back to
Normal View after you have typed in the outline that you see illustrated
in Fig. 9.16. Don’t start typing text just yet, though. Refer to the
outline as you work your way through the directions that follow.
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Fig. 9.16 The outline for the Screenbeans presentation


On the left side of the window, next to the icon for the first slide,
type the title No Problems, Only Solutions (see Fig. 9.16 above)
then hit Enter on the keyboard


Impress now goes to a new slide because it assumes that you have
finished adding text to the first slide. But you need to add a sub-title
on the Title slide. To do this, you must Demote the next set of text
(By [author’s name]) so that it stays on the same slide (which means
you must decrease its level on the slide). You’ll see how it works as
you follow along in these directions.

Fig. 9.17 illustrates the Demote tool that you use to further indent
the level of By [author’s name] on the slide. Either side of the
Demote tool are the Promote, Move up, and Move down tools.
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Fig. 9.17 The Demote tool


Click on the Demote tool now, then type By [your name]—type
your own name, of course—not “your name” or “Bernie Poole!!”—and hit
the Enter key


So now your outline entry for the first slide will look something like
this (Fig. 9.18).
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Fig. 9.18 The outline entry for the first slide

That’s all you need by way of text on the first slide. Now you need to
set up for a new slide. To do that in the outline, you must use the
Promote tool in the Text Formatting toolbar, which raises the level
back to the top level of a New Slide. The Promote tool is to the left
of the Demote tool (Fig. 9.18 above).


Click on the Promote tool and notice how the icon for a new slide
(Slide #2) pops up, with the cursor waiting for you to type in the
text for this second slide


Now you are ready to type in the entries for the second and remaining
slides. The content for all the slides is illustrated in Fig. 9.16 on
page 266.


Return your attention to the left hand frame of the Impress
window so you can continue with Slide 2 of the Outline

Type Confusion for the second slide title, and hit Enter




Now you need to switch levels as you did for slide #1 between the Title
entry and the Author’s name entry.

**Switching levels **

Let’s review the steps. Switching levels means moving up or down in the
hierarchy of entries on a slide by increasing (demoting) or decreasing
(promoting) the indent of the text on each slide.

If you look at the text for the second slide (Fig. 9.16 on page 266),
the word Confusion (the Title of the slide) is at the top level. Then
what immediately follows (A problem often presents itself…, etc ) is
indented—it’s lower level text (demoted). When you switch to the next
level down, the text is automatically indented to the right, that is
to say the level (in Impress speak) is further indented from the 1^st^
level to the 2^nd^—or demoted.

So, to summarize, moving the text to the LEFT promotes the list
level in an outline. Moving the text to the RIGHT demotes the list
level in an outline. For the remaining slides you have to enter text not
only for the Title of each slide, but also for the sub-text. This
sub-text will be at a demoted list level compared to the Title.

Demoting to a lower List Level

As we already observed when you were working on Slide #1, to change
levels in an outline, Impress provides list level control tools (Figs.
9.17 and 9.18 on page 267).


Go back and take a look at Figs. 9.17 and 9.18 now before
proceeding, then click on the Demote tool for the text you are
going to type into the outline for slide #2


Look at your outline now and notice that the next entry you type will be
indented and bulleted.


Type the lower level text for the second slide (A problem often
presents itself…, etc.) from the illustration in Fig. 9.16 on page
266, then hit Enter


Promoting to a higher List Level

That is all you need by way of text for the second slide. As you can
see, you must Promote to a higher level for the new slide 3. To do this
you use the Slide Level tools once more.


Click on the Promote tool to start a new slide for the next
text you are going to type into the outline


As you see, this begins a new slide (Slide #3). You should be starting
to get the hang of this.


So go ahead and complete the rest of the outline (using Fig. 9.16 on
page 266), demoting and promoting the text levels as you go
along

After you have typed the Title and text entries for slide
#9, be sure to navigate, if necessary, to your USB/flash drive


Work Files for LibreOffice > Data Files > Impress
Documents folder and Save this Screenbeans Impress slide
show





Click on the Slide Sorter tab to switch now to the Slide Sorter view
(Fig. 9.19).
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Fig. 9.19 The Slide Sorter view, showing the layout for Slide #2

In Fig. 9.18 above, notice that Impress automatically selected Title
and Content layout for all the slides after the Title slide. But the
layout you need for slides 2 thru 9 is Title and 2 Content. Let’s fix
this first.


In the Slide Sorter view, click on the thumbnail for Slide
#2 (Fig. 9.18 above), then hold down the Shift key and keep
it down while you click on Slide #9


Slides 2 thru 9 should all now be highlighted.


With Slides 2 thru 9 selected, in the set of layout templates
in the Properties frame on the right of the screen, locate and
click on the layout for a Title and 2 Content slide (Fig.
9.20)
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Fig. 9.20 Selecting the Title and 2 Content slide layout for slides 2
thru 9

Notice that you can see a thumbnail of each of slides 2-9 with, on the
left hand side, the text you typed in, and, on the right, an empty space
for further slide content, which can be more text, or a table from a
Base database, or images, or a chart imported from a Calc
spreadsheet, or even a movie clip.


Time to Save your work (Ctrl+s)


Notice, too, how easy it is to check out how your work is progressing on
the presentation as a whole by using the Slide Sorter view.


Still in the Slide Sorter view, click once on Slide #2 and
then click on the Normal tab to go back to Normal View (Fig.
9.21)
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Fig. 9.21 The Normal View for Slide #2 with the five Content options
annotated

In Normal View you see the slide as it will show in a presentation. All
you have to do now is add more text, or any one of several different
types of media in the Content Placeholder box on the right hand side
of the slide (Fig. 9.21 above).

For this first Impress presentation we’ll keep it simple, adding just
an image to each of the last eight slides. In Lesson 10 you’ll have the
opportunity to practice adding a table from a Base database, a chart
from a Calc spreadsheet, and a movie, too.

Adding pictures to the slides

For Slides #2 through #9 you are going to insert a Screenbean[^1]
graphic in the Content Placeholder.


On the right hand side of slide #2, click on the Insert
Image tool (the lower left of the four Insert object icons)—Fig.
9.21 above


This brings up the Insert Image dialog box (Fig. 9.22).
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Fig. 9.22 The Insert Image dialog box

The set of Screenbean pictures that you are going to use for this
presentation are from Microsoft’s clip art gallery, and they may not be
available on your computer since you may not be working online. So, for
the sake of this exercise, a folder containing eight Screenbean clip art
drawings has been prepared for you (Fig. 9.20 above). You’ll find it on
your USB drive, inside the Work Files for LibreOffice folder.


Navigate on your USB drive to your Work Files for LibreOffice


Impress Files > Screenbeans folder





In the Screenbeans folder there are the 8 pictures you need for the next
8 slides in the presentation. Fig. 9.23 lists the pictures in the order
in which you should use them in the slides.
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Fig. 9.23 The sequence you will use for the Screenbean pictures in the
presentation


In the Screenbeans folder, double click on the Confused
file (“Confused” with an “f”, not “Contused” with a “t”!)


Impress inserts the Screenbean figurine on Slide #2 inside the right
side placeholder, with handles around it so that you can re-size it, if
necessary, to fit the space provided for it on the slide.


Check to make sure the art is correctly positioned on the right
side of the slide (it should look something like Fig. 9.24), then
click anywhere off the image in order to set it in place (though
you can click back on it anytime to change the image’s size and
position)


[image: ]

Fig. 9.24 Slide #2 with the image in place


Repeat this exercise for the next seven slides, working from the
Slide Sorter View, double clicking on each slide in turn to
bring up the Normal View for that slide, then loading the
Screenbean images one by one in the order they are listed in Fig.
9.22 on the previous page

When you are done with slide #9, Save your work to this point,
then click on the Slide Sorter tab




Your Impress presentation should now resemble Fig. 9.25.

[image: ]

Fig. 9.25 Screenbeans slide show after inserting all the Screenbeans
images

9.4 ADDING BELLS AND WHISTLES TO THE PRESENTATION

Resizing the Screenbeans on each of the slides

The Screenbean images on each of the slides are smaller than they need
to be. If necessary you could also crop an image to select out just
the part of the image you want to use. To do this you would right
click on the image and, in the context menu that pops up, select the
Crop option. You don’t need to do that here, but you could if you wanted
to.


In the Slide Sorter View, double click on Slide #2, then
click on the Screenbean image to bring up the small green
handles around it (Fig. 9.24 below); then grab any one of the
handles to stretch the image so that it is as large as
possible in the space on the right side of the slide; just be
careful not to distort the image or to overflow the borders of the
slide, or to drag the top of the image higher than the top line of
sub-text (Fig. 9.26 below)
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Fig. 9.26 Stretch the Screenbean using the corner handles


Now do the same with the Screenbean images on the other 7
slides—to end up with something like Fig. 9.27—then Save your
work once more
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Fig. 9.27 Screenbeans show after resizing the images

Adding Transitions, Speed and Sound effects, and Timings

This task should best be done—and easiest to do—while you are in the
Slide Sorter View.


If necessary, click on the Slide Sorter View again


For this exercise, you are going to add the same Timing, Sound effect,
and Slide Transition to all the slides, though you could, if you wanted,
use different timings, sound effects, and transitions for each
individual slide. You’ll practice doing this in Lesson 10.

Slide Transitions


In the Edit menu, click on Select All (or press Ctrl+a on
the keyboard), then click on the Slide Transition button (Fig.
9.28)
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Fig. 9.28 The Slide Transition button


This Slide Transition button brings up, on the right side of the
Impress window, the Slide Transition pane (Fig. 9.28 above).


To get a Live Preview of any of the transitions, make sure you
check the box next to Automatic preview at the bottom of the Slide
Transition pane (see Fig. 9.27 above)

Click on any Transition in the menu and watch the effect of the
slide transition in the selected slide in the Slide Sorter view

Try several of them to get a feel for how they work, then select the
one you most like




Speed and Sound effects

The Transition can be timed to happen at any one of three speeds: Fast,
Medium, or Slow. We’ll go with Medium speed, but feel free to choose
whichever speed appeals to you. We’re going to use the Apert sound
effect, but again feel free to choose any sound effect that appeals to
you.


In the Modify Transition section, select one of the three
speeds, then select any one of the sound effects


Setting Timings for the slides

This will allow the user to advance to the next slide either manually
(by clicking the mouse) or automatically (after 10 seconds is our
choice).


In the Modify Transition section, click in the check box next
to Automatically after: and increase the Advance slide time to
10 (ten) seconds


You are applying these Timing and Transition effects to All the
slides. But you should bear in mind that you could have different
effects for each slide if you wanted, simply by going from slide to
slide, setting the options, and not applying them to All Slides.

This is only a good idea if you are designing a slide show where your
goal is to impress your audience (a) with your Impress skills, or (b)
with your artistic/creative nature, or (c) you actually want to distract
your audience from the flow of your presentation, or (d) you just have
no idea what you’re doing!

So, unless you know what you’re doing, and for the sake of this
exercise, let’s apply these settings to All Slides.


Click on the button to Apply to All Slides (see Fig. 9.27 previous
page), then Save the slide show (Ctrl+s)

Now would be a good time to check out the presentation, so click on
the Slide Show button and sit back and enjoy what you’ve made of
the show to this point (each slide will hold on screen for 10 seconds,
which is ample time to read what’s on the slide, but if you want to
move the show along, just click the left mouse button or tap on
your touch pad at any time)




Choosing a Master Page

Impress gives you all kinds of assistance in the design of your
slides. So far we’ve used the basic set of Slide Layouts, which are OK
when it comes to the general layout of each slide in your show.

The Slide Layouts help you throw together so-called “quick-and-dirty”
Impress presentations, where you’ve planned what you want to “show and
tell,” but you haven’t given much thought to how you want your show to
look.

The easiest way to make your slides more interesting is to use one of
the Master Pages that come with Impress, or those you create
yourself. You can select from a set of pre-formatted slide Master
Pages involving graphics, colors, and animations.

Let’s check out some of these Master Pages now.


Stay in the Slide Sorter view, with all the slides selected
(Ctrl+a), then click on the Master Pages icon in the column
of icons on the right edge of the Impress window (Fig. 9.29
next page)
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Fig. 9.29 The Impress Master Pages icon


Click on the various Master Pages designs to check them out


As you click on each one, wait while Impress updates each slide with
the Master Page design. As you’ll quickly see, the best Master Pages for
the Screenbeans slide show are those that have a predominantly white
background because the Screenbean images are themselves black on a white
background. So the best Master Page is probably the one called Bright
Blue.


For the sake of the exercises that follow, then, click to select
the Bright Blue Master Page design, then Save this final
version of the Screenbeans presentation


Impress quickly applies the selected design template to all the slides
in your show.


Go to the Slide Show menu > Start from first Slide (Fig.
9.30) and take a few minutes to check out the show from start to
finish
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Fig. 9.30 Checking out the presentation

9.5 PRINTING PRESENTATION HANDOUTS

A nice feature of Impress is its ability to provide you with hard copy
versions of the slides and/or of the outline text of a presentation.
This is useful for the preparation of handouts for an audience such as a
class or other lecture environment. Here are the steps to do this.


From the File menu choose Print (Fig. 9.31)
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Fig. 9.31 Selecting the Handouts option for printing


All slides should be selected for the Range and copies
section, and, in the Print section, click on the down arrow in
the Document data entry box and, in the menu of options, select
Handouts (see Fig. 9.30 above) and notice that the slides will be
printed six-by-six per page, left to right, then down

Click on OK to print a copy of the presentation




In the handout options, you can choose two, four, six, or nine slides
per page, and you can display the slides in order either horizontally or
vertically. This handout can then be distributed to an audience or a
class for note-taking, review or reinforcement.


Save this final version of the Screenbeans show then, before
you finish, go ahead and make a backup copy of your
Screenbeans presentation


****

SKILL CONSOLIDATION

1. Prepare a presentation on the subject of the American colonies. Make
sure you have at least eight first level topics (eight slides), as well
as a title slide and an acknowledgements slide.

2. Prepare a presentation on the subject of US Presidents (or any
subject of your choice that you might use with a K-12 age group
appropriate to your major). Make sure you have at least eight first
level topics (eight slides), as well as a title slide and an
acknowledgements slide.

3. Prepare a presentation on the subject of the American movie scene.
Make sure you have at least eight first level topics (eight slides), as
well as a title slide and an acknowledgements slide.

4. Prepare a presentation in a style of your own choosing with at least
three levels on the subject of contemporary music. Make sure you have at
least eight first level topics (eight slides), as well as a title slide
and an acknowledgements slide.

5. Create a slide show with yourself as the subject—you the person, you
the teacher. Use graphics drawn from any source you like. Make sure you
have at least eight first level topics (eight slides), as well as a
title slide and an acknowledgements slide.

6. Create a slide show on the subject of pets. Use graphics from clip
art or created in a Drawing or Painting environment. Make sure you have
at least eight first level topics (eight slides), as well as a title
slide and an acknowledgements slide.

7. Create a slide show on the subject of geometric shapes. Use graphics
drawn from clip art or created in a Drawing or Painting environment.
Make sure you have at
least eight first level topics (eight slides), as well as a title slide
and an acknowledgements slide.

[^1]: Screenbeans are cartoon characters created by Microsoft, Inc.
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10   IMPRESS beyond the basics

       Making interactive, non-linear slide shows







LEARNING OUTCOMES

In this tutorial you will be introduced to the basics of non-linear
interactive Impress slide shows, along with some more advanced
formatting and impact-enhancing tools. Amongst the skills you will learn
are:


	Creating and using Master Pages to add slide controls to presentations

	Using hidden slides

	Formatting and enhancing graphics

	Inserting sounds, clip art, movies, and hyperlinks



BEFORE YOU BEGIN

Setting up for the tutorial

If you completed Lesson 1 of these tutorials, you can skip the rest of
this section and proceed directly to the next section (10.1 Creating a
Master Page…—next page). If you did not complete Lesson 1, then you
must do this now, before proceeding with the rest of Lesson 10.

The set of Work Files for LibreOffice ideally should be stored on a
Flash drive (USB drive) in three folders named Base Files, Impress
Files, and Miscellaneous Files. You need to create a fourth folder
for the data files that you will be creating while working your way
through the tutorials. This fourth folder will be called Data Files.

Here are the steps to prepare these folders now before proceeding with
this tutorial.


First, Unzip the set of Work Files for LibreOffice by double
clicking on the File name on your computer (your instructor will
help you with this if you are working with a class) and Extract
them onto your flash drive

Double click on the Work Files for LibreOffice folder to
open it




Now, inside the Work Files for LibreOffice folder you need to create a
new, fourth, folder called Data Files. Here’s how you do this.


In the Work Files for LibreOffice folder, select New
Folder (Fig. 10.1).
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Fig. 10.1 Creating a New Folder

The system will create a new folder for you and then wait for you to
give it a name of your choice (Fig. 10.1 above).


Call the new folder Data Files


During the course of these tutorials you will be storing many files in
this Data Files folder.

10.1 CREATING A MASTER PAGE TO ADD SLIDE
CONTROLS TO AN EXISTING PRESENTATION

Creating Slide Controls

Slide Controls (otherwise known, in LibreOffice speak, as
Interaction…) are buttons or objects that you insert onto a slide or
slides to tell Impress, by clicking on them, to advance from one slide
to the next slide, or to the previous slide, or to the first slide, and
so on (Fig. 10.2).

[image: ]

Fig. 10.2 Interaction options

Creating a standard set of Slide Controls is simple enough. The best way
to do this is to create a Master Page Template which has on it the set
of Slide Control buttons that you’ll be able to use for any presentation
that you’ll be building, whether now or in the future.


Open a new LibreOffice Presentation document, and go to
File > Save As… (Fig. 10.3)
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Fig. 10.3 Saving a Master Page Template


In the Save As dialog box, navigate to your USB drive >
LibreOffice Work Files > Data Files > Impress
Documents

Click on the down arrow at the end of the Save as type: data
entry box (Fig. 10.3 above) and, in the menu of file types that
pops up, select ODF Presentation Template (.otp)

Name the new document Slide Controls Template and click on
Save




In the new Impress presentation document you want to start with a
Blank Slide layout.


Select the Blank Slide layout in the menu of Layout templates
on the right of the Impress window (Fig. 10.4)
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Fig. 10.4 Selecting the Blank Slide layout

Now you’ll use two of the Basic Shapes in the Drawing Toolbar (Fig.
10.3 above) to create a set of Slide Control buttons. You’ll end up with
something like the set of Slide Control buttons illustrated on the
left in Fig. 10.5.

[image: ]

Fig. 10.5 Different Slide Control styles for a typical presentation

The set of Slide Controls on the right, which uses one of the Block
Arrows in the Drawing toolbar, is another example of what you can do.
Creating these Slide Controls is simple enough, though can be
time-consuming because of the detail involved. Like all design, it
involves your creative skills, and doing it will enhance those creative
skills, so let’s get on with it.


In the drawing tools set of Basic Shapes, click once on the
Rectangle, Rounded tool and slide the pointer—which changes
into a plus sign (+)—onto the slide (Fig. 10.6)
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Fig. 10.6 Rounded Rectangle tool in the set of Basic Shapes


Drag with the pointer to draw a rounded rectangle near the
bottom center of the blank slide (Fig. 10.7)
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Fig. 10.7 Rounded rectangle


Now select any color to Fill the Area of the rectangle
with some contrasting color for the border (see Fig. 10.6
above)

Next, in the drawing tools set of Basic Shapes, click on the
Isosceles Triangle tool (Fig. 10.5 previous page) and drag
with the pointer to draw a small triangle inside the rounded
rectangle shape then use the Rotate tool to rotate the
triangle to the right 90 degrees (Fig. 10.8)
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Fig. 10.8 The Triangle shape inside the Rectangle shape

Get the idea? If you’ve been successfully following along, you now know
how to create any buttons you want. Feel free to create your own set of
Slide Controls illustrated on the left in Fig. 10.4 on the previous
page. But for the sake of this exercise (and maybe your sanity!), the
author has completed the two sets of four buttons and saved them, with
the name Slide Controls Template, in the Impress Documents folder as
a Master Page Template so that you can use them for the exercises that
follow.

Adding slide controls to an existing presentation

For the sake of uniformity, you are going to work with a version of the
Screenbeans presentation you may have developed in Lesson 9 and which
has been recreated especially for this tutorial.


In the Impress File menu click on Open

Navigate on your USB drive to the Work Files for LibreOffice


Impress Files folder, then double click on the file
Problems and Solutions to open it





You’ll be making changes to the Problems and Solutions presentation, and
since you may want to have a friend work through this tutorial at a
later date, it’ll be a good idea to save the version you are going to
work on in the Impress Documents folder in your Data Files folder, thus
preserving the original version.


Go to File > Save As…, navigate on your USB drive to the
Work Files for LibreOffice > Data Files > Impress
Documents folder, then click on Save


You’re going to put Slide Controls on each of the slides in the
Problems and Solutions presentation. The Title slide will have two
Slide Controls—one to go to the next slide and another to go to the last
slide. The last slide will also have two Slide Controls—one to go to the
previous slide and another to go back to the beginning of the slide
show. Every other slide will have all four of the Slide Controls.

Fig. 10.9 shows you how the Title slide will look after you’ve added the
Slide Controls.
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Fig. 10.9 The Slide Controls on the Title slide

The Slide Controls are waiting for you to copy them from the Slide
Controls Template Master Page, so you need to open that file first.


Navigate on your USB drive to the Work Files for LibreOffice


Data Files > Impress Documents > Master Page
Templates folder, then double click on Slide Controls
Template to open it





For the Problems and Solutions Title slide you want just the last two of
the Slide Controls—to go to the next slide and to go to the last slide
(Fig. 10.10).
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Fig. 10.10 Selecting and copying the Slide Controls


Make sure you have the Slide Controls Template Title Slide in
Normal View, then, in the Drawing toolbar, click on the
Select tool (Fig. 10.10 above)

Now drag with the mouse to select just the last two of the set
of Slide Controls on the left (see Fig. 10.10 above), then hit
Ctrl-c to copy those two Slide Controls to the clipboard

Switch back to the Problems and Solutions presentation, which
is already open on your screen, and hit Ctrl-v to paste the
Slide Controls from the clipboard onto the Title slide,
then use the arrow keys on the keyboard to move the Controls
to the right so that they end up in the lower right hand corner
of the Title slide (see Fig. 10.9 on the previous page)




You can adjust the size of the Slide Controls any time you want by
clicking on them and dragging on the handles.


If the Slide Controls looks too large or too small to you, go
ahead now and click on them, grab one of the handles and adjust
the size to your satisfaction

Save the presentation when you’re satisfied everything looks OK on
the Title slide




You should now see two professional-looking Slide Controls on the
Problems and Solutions Title slide. We’ll test them shortly. First,
though, you’re going to put all four of the Slide Control tools on the
next seven slides.


As you did before, click on the Select tool in the Drawing
toolbar and drag around all four of the Slide Control
buttons to put the green handles around them (Fig. 10.11)
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Fig. 10.11 Selecting and copying the four Slide Controls


Now right click on the selected Slide Controls and, in the
context menu that pops up, select copy to copy the Slide
Controls to the clipboard

In Slide Sorter View, double click on slide #2 to bring
it up in Normal View, and hit Ctrl-v to paste the copy
of the four Slide Controls from the clipboard onto slide
#2

Don’t click on the Slide Controls—you want the small green
handles to stay around them; again use the arrow keys on the
keyboard to slide the Controls into position, this time in the
lower left hand corner of Slide #2 (Fig. 10.12)
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Fig. 10.12 Position the Slide Controls in the lower left hand corner of
slide #2

Copying the Slide Controls to other slides

Next, you’re going to put the four Slide Controls on each of the next
seven slides. You already have them on the clipboard, so all you have to
do is paste them as a group, slide by slide.


In the Slide Sorter View, double click on slide #3 to bring
it up in Normal View, and press Ctrl-v to paste the
buttons onto the third slide


Notice that the buttons are pasted into the exact same place as where
you positioned them on the previous slide (Slide #2).


Now go to each of the remaining six (6) slides in the presentation
and do the same

Better Save your work to this point, then switch back to
Slide Sorter View to see how everything looks—should be much like
Fig. 10.13
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Fig. 10.13 All the slides now have the Slide Controls

Adding an Acknowledgements slide

The Problems and Solutions presentation is missing one final slide—the
Acknowledgements slide, which should accompany any presentation where
you use information or audio-visual material that is not your own.
Adding a new slide to a presentation is easy.


First, you want the Acknowledgements slide to be that last
slide in the show, so, in the Slide Sorter View, right click
immediately after the thumbnail for slide #10 to bring up
the small New Slide dialog box

Click on the New Slide dialog box to start a new slide
(Slide #11)




The layout for the new slide, as you can see, is the same as the layout
for the previous 8 slides, namely a Two Content layout. But for the
Acknowledgements slide it will be best if it is a Title slide layout.


In the Slide Sorter View, make sure Slide #11 is selected,
then click on the Properties icon at the top of the set of
design icons on the extreme left side of the Problems and
Solutions presentation window (Fig. 10.14) to bring up the Layout
menu and,

in the Layout menu, select the Title, Content slide layout
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Fig. 10.14 Selecting the Title, Content slide layout

You’ve just pasted the four Slide Controls onto each of the previous 7
slides, so the buttons are still available on the clipboard for you to
paste onto the new last slide.


Switch to the Normal View for slide #10, the last slide in
the show, and hit Ctrl-v to paste the four Slide Controls
here, too


As it happens, the set of buttons is slightly different on this last
slide. You still want the Slide Control to go back to the Go to
previous slide, and you need the Slide Control that returns you to the
beginning—the Go to first slide Control. But you don’t need a button
to go to the next slide; nor do you need a button to go to the last
slide; the Acknowledgements slide is already the last slide in the
show.


So…, first click anywhere on the slide (but NOT on the Slide
Controls) to deselect the Slide Controls, then click on the
Select tool in the Drawing toolbar and drag around the
two rightmost Slide Controls to put the green handles around
just the two of them (Fig. 10.15), then hit the Del(ete) key
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Fig. 10.15 Selecting just the two rightmost Slide Controls


Better save your hard work (Ctrl-s)


Now all you need to do is type the text onto this Acknowledgements
slide.


Click where you see “Click to add Title” and, in the Title
box, type Acknowledgements

Next, c

lick in the Click to add Text box and, by way of Acknowledgements,
type the text you see in Fig. 10.16
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Fig. 10.16 Final version of the Acknowledgements slide


After you type the line: “Text Courtesy of Bernie Poole” hit
Enter, then hit the backspace key to get rid of the bullet,
press Enter again, hit backspace to get rid of the bullet,
then type the last line: “Hit Esc(ape) to end the presentation”

Finally, drag across the three lines of text to
highlight them and, in the Formatting toolbar, change the
Font Size to 28

Hit Ctrl-s to save this (almost final) version of the
Problems and Solutions presentation




Your show is almost ready, but first you have to learn about hidden
slides.

10.2 USING HIDDEN SLIDES

Hidden Slides are slides that will be bypassed, unseen by the user as he
or she clicks through a presentation, except when the user clicks on a
Slide Control that specifically sends them to the Hidden Slide.

Here are the steps to create a Slide Control on one slide which will
take the user to a specific Hidden Slide in the Screenbeans slide show.


In the Slide Sorter View, double click on Slide #2 (the
Confusion slide) to open it in Normal View

Click to position the cursor right at the end of the text that you
typed in the slide’s text placeholder (after the words …tougher
than it really is)

Hit Enter to go to a new line, then type **If you’d like to read a
quote about problem-solving, click here: **

In the Slide Sorter View, right click between Slide #2
and Slide #3 and click on New Slide in the New Slide dialog
box to insert a new slide (which will now become the new Slide #3)




Immediately, Impress inserts a new empty slide right after the second
slide in the show.


Now, you want this to be a Title slide layout, so, still in the
Slide Sorter View, and with the new Slide #3 selected, click
on the Properties icon to bring up the menu of slide layouts
and click on the Title slide layout


You want this new slide to be a Hidden Slide.


In the Slide View toolbar click on the icon to Hide Slide
(Fig. 10.17)
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Fig. 10.17 The Hide Slide icon in the Slide View toolbar

Notice that now, in the Slide Sorter View, Slide #3 is screened out,
which indicates that this is a Hidden Slide (Fig. 10.17).


Click in the Title placeholder on the new slide (where it says
Click to add Title), and type the following quotation (including the
quotes): “Quality is in the details.” then drag across the
quote to highlight it and change the font size to 48

Click in the subtitle placeholder on the new slide (immediately
below the Title placeholder) and type the following: Bernie Poole,
Esq.




The Hidden Slide with the quote is now complete. But it’s hidden, so you
have to give Impress (and the user) a way to find it by creating a new
Slide Control that links to it.


In the Slide Sorter View, double click on Slide #2 (the
Confusion slide) to make it the active slide in Normal View

In the Drawing toolbar click on the Block Arrows icon and, in
the Block Arrows menu, select the Notched Right Arrow shape




Notice that the arrow pointer changes to a cross hair
([image: ]).


Without clicking the mouse button, roll the mouse cursor up over
the slide and

position the cross hair after the colon at the end of “If you’d
like to read a quote about problem-solving, click here: “ (Fig.
10.18), then hold down the left mouse button and drag to create
the Slide Control button that you are going to use to link to
slide #3—the hidden slide
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Fig. 10.18 Placement of the Slide Control linking to the hidden slide
(slide #3)


Let go of the mouse button when you’re done—you can adjust the
size and position of the button if you want by clicking on it
and then dragging on the handles around the button

Now right click on the new button and, in the context menu
that pops up, select Interaction…

In the Interaction dialog box, click on the down arrow at the
end of the Action at mouse click data box (Fig. 10.19) and, in the
drop down menu, select Go to page or object, then in the
list of slides that is displayed, click to select Slide 3,
then click on OK
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Fig. 10.19 Linking the new Slide Control to the hidden slide

This new Slide Control provides a link from slide #2 to the hidden
slide #3. When you run the show shortly and get to slide #2, if you
click on this Slide Control, you will go to slide #3. But if you do
not click on this Slide Control, slide #3 will be bypassed because it
is a hidden slide.

You have to do one more thing to complete the content on the hidden
slide (slide #3). You need to put a Slide Control on slide #3 to go to
the next slide (slide #4). Can you remember how to do it yourself? If
so, go ahead; but if you need help, here are the steps to follow:


In the Slide Sorter View, double click on slide #2 to bring
up the slide in Normal View, then, in the Drawing toolbar, c

lick on the Select tool and drag to select the third of the
four Slide Controls (the Slide Control to go to the next
slide), right click on it, then, in the context menu that pops up,
select Copy the Slide Control to the clipboard

Next, in the Slide Sorter View, double click on slide #3
to bring up the slide in Normal View, and press Ctrl-v to
paste the Slide Control onto the hidden slide

Then, while the button is still selected, drag on the green
handles to make the Slide Control about twice its size and use
the arrow keys to move it over to the lower right corner of
the slide (Fig. 10.20)
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Fig. 10.20 The repositioned and resized Slide Control on the Hidden
Slide


Right click on the new Slide Control and, in the context
menu, select Interaction… > Go to next slide

Save all the good work you’ve done so far, then Run the
Problems and Solutions slide show from the start (Slide Show
menu > Start from first slide), trying out every slide,
including the Slide Controls that you just created for the Hidden
Slide




10.3 ANIMATION SCHEMES

Impress Animation is a way of bringing objects, such as text and
pictures, to life on the screen, controlling and sequencing how text and
other slide objects emerge onto the screen during a presentation—sliding
in from the right or left, or fading in, and so forth. Let’s try some of
the Impress Animations now, using the Screenbean figures as our
models.


The Screenbean figure must be selected in order to apply
animations and other effects to it, so, in the Slide Sorter View,
click on the thumbnail for slide #2 (the slide with the
Confused Screenbean) and click to select the Screenbean
figure (you’ll see the green handles around it)

Right click on the Confused Screenbean figure and, in the
context menu that pops up, select Custom Animation




This brings up the Custom Animation pane on the right side of the
Impress window (Fig. 10.21).
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Fig. 10.21 The Custom Animation pane


Click on the green plus sign/cross to bring up a menu of
built-in LibreOffice animations (Fig. 10.22)
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Fig. 10.22 LibreOffice Animations dialog box


For the Screenbean figure on Slide #2, in the menu of
built-in LibreOffice animations, select the first option:
Appear, click on OK, then, in the Effect section >
Start entry box, select After Previous (Fig. 10.23)
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Fig. 10.23 Effect section > Start data entry menu


To check out the animation, go to the Slide Show menu > Start
from current Slide and watch as Impress gives you a demo of the
effect

In the Slide Sorter View, switch to Slide #4 and take a few
minutes to preview a few other animations to get a feel for what
is available

When you are done experimenting, go from Slide #4 to Slide #10
and, for each Screenbean figure, select any one of the Animations
you like, then, in the Effect Appear section, select the option to
Start > After Previous

When you are done selecting animations for all the Screenbean figures,
Save the presentation, then go to the Slide Show menu >
Start from current Slide to check out the Problems and Solutions
presentation once again




Pretty cool. So Impress makes it easy for you to experiment with
different schemes, try them out, remove them if you don’t like them, and
start over—all part of the design process.


In the File menu select Close


You can change any sequence, and you can also sequence the items to come
onto the screen all at once, and so forth. There will be occasions when
you will want to alter the sequence because, for example, you may decide
that you want to talk about one topic ahead of another. Also, you may
want the presentation to be presented as a running display in a
conference room or in the lobby of a building.

Bear in mind that it’s not a good idea to apply Animation Schemes
everywhere, on all the slides. Animations are best used sparingly, to
highlight specific ideas, or to spice things up in a presentation. But
too much spice can overwhelm a presentation and take away from its
enjoyment or effectiveness.

10.4 Interactive IMPRESS AT WORK

Let’s start by looking at an example of an interactive Impress
presentation.


You should still have the Work Files for LibreOffice folder
available in the USB port on your computer, so

in the File menu select Open

Navigate (Browse) on your computer to your USB drive > Work
Files for LibreOffice > Impress Files folder, then double
click to open the Mammal Test presentation




You’re going to examine the Mammal Test interactive presentation which
has been prepared for you and which will demonstrate the various
features of what makes a presentation interactive and non-linear.


In the Slide Show menu select Start from first Slide to view
the presentation

Follow the directions to move through the slides—be sure to click on
the answers when indicated

Answer at least one question incorrectly so you can see how the
presentation takes you back to re-answer a question should you get it
wrong

Make sure your speakers are turned up so you can hear the sound,
and notice the clip art and animations that are added to this
show




Features to look for in the demonstration presentation

General layout of an interactive presentation used for assessing
knowledge

Think of a test in your classroom. You start with a title on your test,
so the students know what subject matter the test is on and who wrote
it. Then you have an introduction, which might further define the
subject matter for the test. Alternatively, if used as a review, the
introduction might summarize the concept being tested.

A good interactive slide show thus begins with a title and an
introduction slide (Fig. 10.24).
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Fig. 10.24 Title and Introduction Slides

You then move to the set of directions which tell the user how to
complete the test. The test questions follow right on after the
directions.

An effective interactive slide show should have a directions slide
because a good teacher never assumes that all the students know how to
take a particular test. After the directions come the question slides,
which contain the questions themselves and the options for answers (Fig.
10.25).
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Fig. 10.25 Directions and Question One Slide

An interactive Impress presentation has the same elements as any
Impress presentation, with one significant difference: it has
question slides and feedback slides. In your class, you grade papers
and return them, giving the students feedback on their answers.

So, in the Mammal Test slide show, we have feedback slides that tell
the user “You’re Right” or “Sorry. Try Again.” (Fig. 10.26).
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Fig. 10.26 Question and Feedback Slides

Lastly, in an interactive Impress presentation it’s appropriate to
have a concluding slide which tells the students they’re done,
followed by an Acknowledgements slide (Fig. 10.27).
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Fig. 10.27 Ending and Acknowledgment Slides

In this way, you set good precedent for citing sources, and you also
clue your audience to the fact that it’s over! We’ll talk more about the
layout of an interactive Impress slide show as you begin creating your
own.

Slide Controls and Hyperlinks

In order to move outside the linear box of traditional Impress
presentations, we’ve used Slide Controls and Hyperlinks. Slide
Controls are the buttons that control your progress from slide to slide
as you work through the presentation. In the case of the Mammal Test
presentation, they let you either move on to the next question or
re-answer the previous one.

An Impress hyperlink, on the other hand, links you directly to a
location outside the presentation; if you are on the Web, the hyperlink
takes you from one Web site to another, or from a website to your email
program. If you are in an Impress presentation, the hyperlink might
take you from a slide to your E-mail program, or from a slide in your
presentation to a page on the Web.

Notice the transitions and animations in the Mammal Test presentation.
The presentation has a simple, clean style—no excessive bells and
whistles; just enough to keep the users’ attention.

So much for an overview of using an interactive Impress presentation.
It’s time to create your own interactive quiz.


Click anywhere to exit the slide show, then close (File


Close) the Mammal Test presentation when you are ready to
continue with the tutorial





10.5 BUILDING AN INTERACTIVE, NON-LINEAR PRESENTATION

You are going to use Impress to prepare a Class Test about the U.S.
states and capitals, which will give you the experience to prepare more
detailed interactive tests on your own.


Open LibreOffice and go to Create > Impress
Presentation to start a new slide show


You should always immediately save a new document; this allows you to
give the document a name, as well as the opportunity to save it in a
location you want on your disk drive (so that can more easily find it
again later!).


Go to File > Save As and, in the Save As dialog box,
navigate to your USB Drive > Work Files for LibreOffice


Data Files > Impress Documents folder


Give the new presentation the name States and Capitals Quiz, and
click on Save




It is usually a good idea to create the text outline for your slides
before you select a template for your design theme, slide transitions,
animations and so forth. This is because different templates have
different slide layouts (bigger title boxes, less room for bulleted
lists, and so on). So you will want to get a feel for what will be the
text on each slide, before you proceed with design considerations.

This brings to mind a good rule of thumb when creating anything that is
designed to provide information for the purpose of effective
communication: Substance Before Style! Or, to put it another way,
Content Counts! Keep this in mind when developing any Impress
presentation.

get to work

Title slide, Intro slide and Directions slide

Fig. 10.28 a-c illustrates the content you will be entering for the
first three slidesFollow the directions on the next page to complete
this first part of the exercise.
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Fig. 10.28a Content for Slide 1
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Fig. 10.28b Content for Slide 2
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Fig. 10.28c Content for Slide 3


For this presentation you’ll enter the text directly onto each slide
using the Normal View (Fig. 10.29).
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Fig. 10.29 Enter the text directly onto the slide

Entering data directly onto slides can be tricky because you have to be
careful how you use the Enter and Tab keys, so follow the directions
carefully.


The default layout for the first slide in any new Impress show is
always a Title slide.

In Normal View, click inside the Title box (Fig. 10.29 above)
and type U.S. States and Capitals Quiz, then hit Ctrl-Enter to
move the cursor down to the sub-title box

Hit the backspace key to get rid of the bullet, in the
formatting toolbar click on the Center alignment icon, then type,
By ______ (type your name in the blank)




The sub-title By _______ (your name) should now be in the
sub-title box of your first slide.


Now, in the Insert menu select Date and Time… to bring up the
Date and Time dialog box (Fig. 10.30)
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Fig. 10.30 The Date and Time dialog box


In the Date & Time dialog box, click to put a check mark next
to Date and Time, then click on the radio button next to
Variable and, in the drop down menu of date/time formats,
select the format indicated in Fig. 10.30

Click to put a check mark next to Page number, then click on
Apply to All

In Slide Sorter View, right click immediately to the right of
Slide #1, right click on the mouse, and then click on the
New Slide button that pops up to start a new slide




The default Slide Layout for the first slide in a presentation is Title
slide, but you want a different, Title, Content, layout for Slide
#2.


Right click on the new slide and, in the context menu that
pops up, select Slide Layout to bring up the menu of Slide
Layouts in the pane on the right side of the Impress window

You want the Title, Content layout for Slide #2 and subsequent
slides, so, in the menu of Slide Layouts, click on the
thumbnail for Title, Content layout




Get to know the Keyboard Shortcuts

Notice that Ctrl-Enter moves the cursor to the next text box on a
slide. You hit Enter only when you want to advance to the next line
inside the text box where you’re typing text.


Continue to type the information for the next 2 slides (see Fig.
10.28b and 10.28c above on pages 298 and 299)


As you just did for the previous two slides, press Ctrl-Enter to move
from one text box to the next (for example, from a slide’s Title box to
the Text box that has its bulleted list).

Get used to using these keyboard shortcuts rather than clicking in each
textbox. For the more experienced user, Keyboard Shortcuts are a
faster way to go.

Question and Feedback slides

Next you are going to type the 5 Question and Feedback slides—Slides 4-8
(Fig. 10.31a and b).
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Fig. 10.31a Content for Slides 4, 5 and 6
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Fig. 10.31b Content for Slides 7 and 8

If you are an experienced user of the Microsoft Office programs such
as Word, and if you already have completed the introductory Impress
tutorial (Lesson 9), you should be able to carry out the following tasks
without step-by-step help. However, in case you need guidance, here are
the directions for the first test question slide.


Click on the tab for Normal View, then, with the cursor waiting in
the Title box for slide #4, in the Formatting toolbar
click on the Left alignment icon

Now type the title Question One, then hit Ctrl-Enter to skip
to the text box below the Title box




You need to remove the Bullet at the beginning of the new line. This is
simple enough.


Before you start typing the first question (Which is the capital of
Texas?), in the Formatting toolbar click once on the
Bullets On/Off icon (Fig. 10.32) to remove the Bullet at the
beginning of the line, then type the question: Which is the capital
of Texas?
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Fig. 10.32 The Bullets on/off icon in the Formatting toolbar


Follow the same directions to complete the entries now for slides
#5 and #6, then Save your work


Now that the Titles and Questions are on the question slides, you next
need to type the content for the two feedback slides (see slides 7 and 8
in Fig. 10.31b on the previous page).


Click on the Slide Sorter View, right click after Slide #6
and click on the small dialog box to start a New Slide (Slide
#7), then double click on the new slide to open it in
Normal View


You need to change the layout of the feedback slides, because all you
need on them for now is a Title box. Fortunately, Impress has a
layout called Title Only.


In the Slide Layout menu on the right side of the window,
select the layout for Title Only

Now go ahead and, in the Title box for slide #7, type
You’re Right!

Create a new slide #8, which will again have a Title Only
layout, and, in the Title box for slide #8, type Sorry. Try
again.




Next, you must place a copy of these two feedback slides after each of
the other question slides. Copy and Paste is the easiest way to do this.


In Slide Sorter View, click on slide #7, hold down the
Shift key and at the same time click on slide #8 to
select both slides at once, then hit Ctrl-c on the keyboard to
copy these two slides to the clipboard

Now, with slides #7 and #8 on the clipboard, click between
slides #4 and #5 and hit Ctrl-v to paste the two answer
slides between them; so what was slide #5—Question Two—will
be bumped to slide #7 (Fig. 10.33)
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Fig. 10.33 The full set of Question and Answer slides


Do the same thing to Paste the answer slides right after what will
now be slide #7, then Save your work once more before going
on


The States and Capitals Quiz Impress now has 12 slides—the three
introductory slides and the nine question and answer slides.

For any Impress show, it is important to have a slide that signals the
end of the main body of content (such as the end of testing in the case
of our show). Impress presentations shouldn’t end abruptly. Also, it
is important to give credit where credit is due.

So, at the conclusion to most any slide show you should include an
Acknowledgements slide. These are your next two tasks.


Create two new slides (Slide #13 and Slide #14); Slide #13
will be Title Only layout and Slide #14 will be Title,
Content layout

Type the content for slides #13 and #14 as illustrated
in Fig. 10.34, then Save your work again
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Fig. 10.34 End of Test and Acknowledgement Slides


10.6 MAKING THE PRESENTATION INTERACTIVE

You are now going to tackle the two trickiest steps in this lesson. They
are:


	Creating four hyperlinking Slide Controls on each of the three
Question slides which the user will click on to indicate his or
her answer to the question.

	
	Creating a Slide Control on each of the six Feedback slides
that will hyperlink to the appropriate Question slide.





	



Creating Text Objects for the Slide Controls on the Question slides

A Text Object is text that has been converted into a LibreOffice
Object so that it can be used as a hyperlink and can also be animated,
just the same as any image.

Let’s do the first Question slide together (Slide #4), and then you’ll
know what to do for the other two question slides (Slides #7 and #10).


In Slide Sorter View, double click on Slide #4
(Question One) to open it in Normal View

In the Drawing toolbar at the bottom of the window, click on the
Rectangle tool to select it, then draw a rectangle about
½” below the Question and centered on the slide (Fig. 10.35)
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Fig. 10.35 Draw a rectangle about ½” below the Question


With the rectangle still selected, hit Ctrl-c to copy it,
then hit Ctrl-v to paste the copy back onto the slide (for reasons
best known to itself, LibreOffice pastes the copy directly on top of
the original, so you’re not aware of anything having been done—but the
copy is there!)

Use the arrow keys on the keyboard to slide the copy down below
the original, so that now you have two identical rectangles on the
slide (Fig. 10.36)
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Fig. 10.36 The two identical rectangles on Slide #4


Now use the Select tool (left end of the Drawing toolbar) to
drag to select both rectangles, hit Ctrl-c to copy them,
then hit Ctrl-v to paste the copies back onto the slide, and use
the arrow keys to slide the copies down below the originals, so
that now you have four identical rectangles on the slide (Fig.
10.37)
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Fig. 10.37 The four rectangles ready for processing into Text Objects

At this stage it will be a considerable time saver if you copy the four
rectangle shapes and paste them onto the other two Question slides—Slide
#7 and Slide #10.


Use the Select tool again to drag to select all four
rectangles, and hit Ctrl-c to copy them

In Slide Sorter View, double click on Slide #7 to
open it in Normal View and paste the four rectangles
directly onto the slide

Do the same for Slide #10, then Save your work




Now for the conversion of the Rectangles into Text objects. We’ll do
this together for Slide #4, then you can follow the same steps yourself
to convert the rectangles on Slide #7 and Slide #10.


	In Slide Sorter View, double click on Slide #7 to
open it in Normal View, then double click on the first
rectangle and type the first Answer: Houston

	Double click on Houston to highlight it and, in the
Text formatting toolbar, increase the Font Size to 28 pt

	Next, double click on the second rectangle and type the
second Answer: Dallas, then double click on Dallas to
highlight it and, in the Text formatting toolbar,
increase the Font Size to 28 pt

	Next, double click on the third rectangle and type the third
Answer: San Antonio, then double click on San Antonio to
highlight it and, in the Text formatting toolbar,
increase the Font Size to 28 pt

	Finally, double click on the fourth rectangle and type the
fourth Answer: Austin, then Double click on Austin to
highlight it and, in the Text formatting toolbar,
increase the Font Size to 28 pt




Better Save your work again, then follow the five (5) steps above
to enter the Answers for Slides #7 and #10


The answers for Slide #7 are as follows:

California

Alaska

Texas

Rhode Island

The answers for Slide #10 are as follows:

Hawaii

Florida

California

Mississippi

Over to you. Don’t forget to save your work when you’re done.

Linking the Text Objects to the appropriate Feedback Slides

Now you must revisit each of the four Answers on the three Question
slides to tell Impress which slide the Answer should link to after
it is clicked. This is where it gets tricky. If the answer the student
chooses for each question is correct, the link must send him or her to
the You’re Right! Slide, and move on to the next question; if the
answer is incorrect, it must send him or her to the Sorry. Try
again. Slide, and return him or her back to the original question to
try again.

If you’ve never done anything like this before, the best way to
understand the process is to do it. So here goes!


In Slide Sorter View, double click on Slide #4
(Question One) to open it in Normal View, then right click
on the Houston button and, in the Context menu, select
Interaction…


This brings up the Interaction dialog box (Fig. 10.38).
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Fig. 10.38 The Interaction dialog box

Houston, the first possible answer, is the wrong answer; it is NOT the
capital of Texas. So we want the student to be linked to the feedback
slide that says the answer is wrong.


In the Action at mouse click entry box, click on the down
arrow to bring up the menu of options and select the option to
Go to page or object, then click on Slide 6 and click OK

Repeat these steps for the answers Dallas and San Antonio
(also wrong answers)

Now, highlight Austin (the correct answer)




Since Austin is in fact the capital of Texas, we want to link that
answer to Slide #5, the feedback slide that states that the correct
answer has been selected.


Right click on the Austin button and, in the context menu,
select Interaction… and hyperlink to Slide 5


Now you need to put a Slide Control button on each of the Answer slides
(Slides 5 and 6).


With Slide 5 selected in Normal View, in the Drawing
toolbar at the bottom of the window click on the Block Arrows
icon to bring up the set of Block Arrow shapes and click to select
the Chevron shape (Fig. 10.39)


[image: ]

Fig. 10.39 The Chevron shape in the set of Block Arrows shapes


Now draw a nice big Chevron shape towards the right side of
the slide (Fig. 10.40)
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Fig. 10.40 The Slide Control on Slide 5


Right click on the Chevron shape and, in the context menu,
select the Area tab (Fig. 10. 41)
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Fig. 10.41 Choosing a Color for the Slide Control


Click on the Area tab and, in the drop down menu of
colors, select any color you like for the Chevron shaped Slide
Control


Next you need to put a chevron-shaped button on the Wrong answer slide
(Slide #6). Easiest way to do this is to copy and paste the button you
just created for Slide #5.


On Slide #5, click on the Slide Control to select it and
hit Ctrl-c, switch to Slide #6 and hit Ctrl-v to paste
the button onto Slide #6


You want this Wrong answer button to point back to Question One, so
you need to flip it horizontally.


Right click on the Slide Control and, in the context menu,
select Flip > Horizontally, then Save your work before
you proceed


Now you need to select the correct hyperlink for these two new buttons.
For the button on the correct answer slide (Slide #5) you want to send
the student on to the next question (Question Two), which is slide #7;
but for the button on the wrong answer slide (Slide #6) you want to
send the user back to Question One (Slide #4).


On Slide #5, right click on the Chevron shaped Slide
Control and, in the context menu, select Interaction… and
hyperlink to Slide 7

On Slide #6, right click on the Chevron shaped Slide
Control and, in the context menu, select Interaction… and
hyperlink to Slide 4




Time to make sure each answer on the Question One slide, and each
button on the Answer slides is correctly hyperlinked by testing each
of them in turn.


With Slide 4 selected in Normal View, in the Slide Show
menu select Start from current Slide, then click on each of the
True buttons one-by-one, make sure it sends you to the correct
Answer slide, then make sure the chevron-shaped Slide Control on
each of the answer slides sends the user forward or back to the
correct question


Everything OK? If not, fix any errors—hopefully there won’t be any, but
you never know. Breathe a sigh of relief if all went according to plan.


Now, follow these same series of steps (if you need help, the
directions start on Page 320 above) to activate the Slide Controls
with hyperlinks for Slides 7 thru 9 (where the correct answer
is Alaska), and Slides 10 thru 12 (where the correct answer is
Hawaii)


Adding Slide Controls to the remaining slides (Slides 1 thru 3 and
Slides 13 and 14)

You’re going to need Slide Controls on Slides 1 thru 3, and also on
Slides 13 and 14. You should be good at this now, but just in case here
are the steps you need to take.


In Slide Sorter View, double click on Slide #1 to open it
in Normal View, then, in the Drawing toolbar > Block
Arrows icon, click on the Chevron shape

Draw a small Chevron in the lower right corner of the Slide
window (Fig. 10.42)
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Fig. 10.42 Slide Control to go the Next Slide


Right click on the button, then, in the context menu, select
Interaction… and select the Action at mouse click option
to Go to next slide

While you’re at it, hit Ctrl-c to copy the Slide Control
to the clipboard




That’s all you need on the first slide. But you need the same button
on Slides 2, 3, 13, and 14. Fortunately, you have it copied to the
clipboard, so…


In Slide Sorter View, double click on Slide #2 and
paste the Slide Control onto the slide

Do the same for Slides 3, 13 and 14




On Slides 2, 3, and 14 you need a second Control button to Go to
previous slide.


In Slide Sorter View, double click on Slide #2 again,
right click on the Slide Control in the lower right
corner, copy it, then paste it (Ctrl-v)

Right click on the Slide Control again, and, in the context
menu select the option to Flip > Horizontally, then use
the arrow keys on the keyboard to slide this second Slide Control
to the left (Fig. 10. 43)
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Fig. 10.43 The second Slide Control button in position on Slide #2


Right click on this second Slide Control, copy it, then
paste it (Ctrl-v) onto Slides 3 and 14


Hope you’re doing OK, still. Hey, for some people, this is their idea of
fun! I hope you feel the same. One last task at this stage of the
Tutorial. The last slide, Slide #14, has a Slide Control to go to the
next slide, but there is no next slide. So you have to change the
Action on mouse click to Exit Presentation.


In Slide Sorter View, double click on Slide #14 if it is
not already in Normal View, right click on the rightmost
Slide Control in the lower right corner, select Interaction...
from the pop up context menu, and change the Action on mouse click
option to Exit presentation

Save your work before you proceed (and maybe take a break…)




Making the Text Object backgrounds invisible

On Slides 4, 7, and 10, those Blue rectangles behind the multiple choice
answers are unnecessary. It’s easy enough to get rid of them at this
stage, though they were necessary while you were developing the Text
Objects and hyperlinking them. Let’s make them invisible now.


In Slide Sorter View, double click on Slide #4 and
right click anywhere on the first blue rectangle, then, in the
context menu, select Line… to bring up the Line dialog box
(Fig. 10.44)


[image: ]

Fig. 10.44 The Line dialog box


In the Style drop down menu, select – none – to remove the
border around the rectangle shape, then click on OK

Still on Slide #4, right click anywhere on the first blue
rectangle, then, in the context menu, select Area… to bring up
the Area dialog box (Fig. 10.45)
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Fig. 10.45 The Area dialog box


In the Area dialog box, click on the Transparency tab, then in
the Transparency mode section make sure the radio button next
to Transparency is checked, and set the Transparency
percentage to 100%, then click on OK


Cool. Houston now appears as just plain old text, but it’s actually a
Text Object which holds a hyperlink (Fig. 10.46)
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Fig. 10.46 Text Objects with invisible backgrounds


Now do the same thing to the other 11 Text Object multiple choice
answers on Slides 4, 7, and 10, then Save your work when
you’re done


Forcing the user to click on a Slide Control to advance to another
slide

For the feedback slides such as the one illustrated in Fig. 10.30 above,
we must make sure that the user can only proceed from one slide to
another by clicking a Slide Control. As it is, when the user clicks the
mouse anywhere on the slide, the show will advance to the next slide
whether it’s supposed to go there or not.

So here’s how you give the user no option but to click on a Slide
Control in order to proceed.


In the Slide Sorter View, hit Ctrl-a to select all the slides,
then in the Slide Show menu select Slide Show Settings… to
bring up the Slide Show Settings dialog box (Fig. 10.47)
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Fig. 10.47 The Slide Show Settings dialog box

Check only the Radio buttons next to Range > All
slides and Type > Default, then, in the Options
section, make sure you only have check marks next to Mouse
pointer visible and Animations allowed—NOTHING else should be
checked!

Save your work again




You should test the work you’ve done to this point to make sure it works
the way you want it to.


Go to Slide Show menu > Start from first Slide and answer
each question incorrectly first, then watch as the Text Object
hyperlink takes you to the Wrong Answer feedback slide

Test all the Text Object answers to make sure the hyperlinks you
put on them work appropriately; also test to make sure that when you
click anywhere on the slide, other than on the Slide Control, the
show doesn’t go anywhere




Give yourself a round of applause if everything worked correctly.

If, on the other hand, a hyperlink or Slide Control doesn’t work, don’t
panic. You can remove a Slide Control by simply right clicking on it
and selecting Cut from the context menu. Then

follow the steps above again carefully, and you should be able to
straighten things out.

10.7 FORMATTING YOUR PRESENTATION

Selecting a Master Page

LibreOffice makes it easy to select a background, font type and style,
and color scheme for your presentation. All these features are combined
into what Impress calls a Master Page.

Earlier we mentioned that you could start your new presentation by
picking the Master Page before even typing in the text. Well, as we
already discussed, sometimes it is best to wait to select a Master Page
until you have an idea of where text should be on the slides and how
much text is on each slide. Some Master Pages, for example, have
graphics that take more space on the slide than others and might make it
hard to read your text.


In the Slide Sorter View, hit Ctrl-a to select all the
slides, then click on the Master Pages icon on the right edge
of the Impress window (Fig. 10.48)
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Fig. 10.48 The Master Pages icon


C


lick on any of the Master Page icons in the menu and wait as
Impress propagates the design to all the slides in the
Slide Sorter View

Preview several of the available Master Pages before deciding
which one you’d like to use




The Master Page chosen for the demonstration show, which is used in the
illustrations below, is called AbstractYellow and has the advantage of
needing little or no adjustments to be made to the slides after the
Master Page is applied. But feel free to use whichever of the Master
Pages you want for your presentation.[^1]


When you’ve decided which Master Page you want,

Save the presentation




Tips on color choices for printing

Lesson 9 covered the topic of printing Impress presentations, but this
is a good time to mention editing your background for how it will appear
on paper. Many of the Master Pages are attractive to look at; however,
when you print handouts or slides in black ink, the dark backgrounds
make some text hard to read. So, if you plan to print out your show,
choose a lighter background for all the slides. Then, when you are
ready to print, in the Print Settings section, click on the Color
button and, in the Color options, select Grayscale. This reduces
the background to more or less plain white with black text, making it
easier to read than color. It will also save a lot of money on the ink
cartridges for the printer!

Applying different Master Pages to certain slides in a show

Most of the time, we want our show to look the same on every slide. But
if you do need to vary the Master Page on different slides, here’s what
you do. Let’s say, for example, that you want a different Master Page
for the first slide and the last slide.


Change your view to Slide Sorter View, click on the first slide
and then hold down the Ctrl button as you click on the last
slide to select just those two slides

Click on one of the Master Page thumbnails to Live Preview it;
do this for a few themes that look good to you and, when you’ve made
up your mind, click on your chosen Master Page to select it, and
Save the presentation again




Notice that only those slides you selected have that specific Master
Page. You can do this for just one slide or several slides. You’re the
boss! You may be thinking that your slide show looks hideous right now.
That’s OK; you can change everything and anything once you have the text
for each slide in place. You can change the text, too. With Impress
(or computer apps in general) nothing is chiseled in stone until you say
so! And even then, you can still change your mind.

What you need, above all, when working with a computer app such as
Impress is PATIENCE. If you’re always in a hurry, you’d better be
either very talented or lucky to do good work. But if you’re
patient, Impress will help you to do the best job you’re capable of
doing, that’s for sure.

Creating customized, self-designed Master Page Templates

For most users, the Master Pages provided by Impress are more than
sufficient to meet their design needs. Other Master Pages can be
accessed online. But if you prefer to create your own background, or
wish to create a standard Master Page for your school or class, you
can save whatever you create as a Master Page Template—a subject we
already discussed earlier in the tutorial.

10.8 INSERTING CLIP ART AND OTHER CONTENT

Impress has simplified the process of inserting pictures, clip art,
tables, Fontwork graphics, sound and movie clips, and charts. You
learned about this in Lesson 9, but it will be good to review what you
learned. You’ll also learn in this section how to insert a clickable
e-mail address.

Inserting Clip Art


In the Slide Sorter View, double click on Slide #2
(Introduction)

Click on the Properties button on the left edge of the
Impress window and, in the Slide Layout menu, click to select
the Two Content layout




Slide two should now have the bulleted text on the left, with a box on
the right for different types of content, including text and so forth
(Fig. 10.49).

[image: ]

Fig. 10.49 Slide Two: Two Content slide layout


Click on the lower left Content Selector tool (the Insert
Pictures tool—Fig. 10.52 above)


When you click on the Insert Pictures tool, the Insert Image
dialog box will pop up on the screen.


On your USB drive, navigate to the Work Files for LibreOffice


Miscellaneous Files > Practice folder,
double-click on the US States image and watch it upload to the
slide (Fig. 10.50)


[image: ]

Fig. 10.50 Clip art accessed from the web and inserted onto a slide




Sometimes you will need to resize your clip art if it appears too small
or too large to fit into your presentation. This is easy enough to do.


If necessary, click once on the clip art to select it, then

click on a corner handle and drag diagonally left, right,
up, or down to enlarge or shrink the image

When everything looks good on the slide,

Save the presentation




Inserting other pictures or pictures of your own

A word about Copyright

The simple rule (law) about Copyright © is this: If you can see it,
it’s copyrighted.

In other words, if you didn’t create it yourself, and you see it out
there for the taking, you should get permission from the author of the
work if you intend to use it, especially if you intend to use it for
profit.

Like everything in the law, however, it’s open to interpretation. So, if
teachers want to use an image they’ve found ‘out there’ to give added
meaning or emphasis to something they’re trying to help their students
learn, they are not obliged to seek permission from the owner of the
art because there is no question that they are using the image for
profit (though the owner would undoubtedly be delighted to know their
work was being used in this way).

Once you are comfortable locating and placing clip art into your show,
try finding pictures and other graphics online. It is simple to insert
onto a slide a digital picture that you’ve saved on your computer.

Let’s try this now. If you have a digital picture of your own that you’d
like to use for this exercise, feel free to do so. If you do not have a
picture of your own, you can use a picture of the author which is saved
in the Work Files for LibreOffice.


First select slide #1—the Title slide—in the Home
Ribbon > Slides Group click on the Layout tool, and in
the menu of Layouts click on the Two Content slide layout,
then, on the right side of the slide window, click on the Insert
Image tool once again

Now navigate, on your USB drive, to the Work Files for
LibreOffice > Miscellaneous Files > Practice
folder, and double click on Prof Poole




The picture will quickly appear on the slide (Fig. 10.51), with the
handles around it so that you can move it to where you want on the slide
and resize it to fit the space where you want it to go.

[image: ]

Fig. 10.51 The Title slide with the picture of the author inserted onto
it

Inserting sound


First, make sure you have your computer Speakers turned on (not
muted) so that you can hear the sounds you are about to try out


In the U.S. States and Capitals show, we want to give our students a
reward for getting each answer correct. So, we’re going to insert
applause onto every You’re Right! slide.


Open Slide #5 (the first You’re Right! slide) in the Normal
View, then click on the Slide Transition icon on the right
edge of the Impress window (Fig. 10.52)


[image: ]

Fig. 10.52 The Sound menu


In the Slide Transition dialog, select any Transition you want
(try out a few of them to see what you like), then click on the down
arrow at the end of the Sound entry box and select the Sound
called Applause

Now scroll to slides #8 and #11 and repeat the above steps
(inserting the Applause sound)




You should now have applause on each of your positive feedback slides.


Save the presentation with your new sound effects


A caveat (warning) about sound. Like any bell or whistle, it’s easy to
get carried away with sounds. Stay focused on the purpose of your show
and your audience’s needs. A kindergarten class will welcomes lots of
sounds. For a presentation to the Board of Education, a more
professional approach may be required!

Inserting a negative feedback sound

Now you need to insert a sound on each of the Sorry. Try again. slides
(slides #6, #9, and #12). To vary things up, we’ll use an image to go
with each sound.

The images have been saved for you and you’ll find them on your USB
drive in the Work Files for LibreOffice.


Start by opening Slide#6 in Normal View, then navigate to
your USB drive > Work Files for LibreOffice >
Miscellaneous Files > Practice folder and double click
on the file called Falling Downstairs to Insert it onto
slide #6

Slide the image anywhere over to the left of the
Slide Control




Now for the animation to go with the picture.


Right click on the Falling Downstairs image and, in the
context menu, select Custom Animation, click on green
towards the bottom of the Custom Animation pane and, in the
Animation dialog box, select the Bounce animation (Fig. 10.53)


[image: ]

Fig. 10.53 The Animation dialog box


Do the same thing for Slide #9 and Slide #12

For Slide #9 use the image called Bomb (USB drive >
Work Files for LibreOffice > Miscellaneous Files >
Practice folder); and for Slide #12 use the image called
Explosion (USB drive > Work Files for LibreOffice >
Miscellaneous Files > Practice folder again)

Save your work




Inserting Videos or Animations

Inserting movies (or video) is just as easy as inserting clip art or
sounds. Whether it’s an animated clip or a short video clip, the steps
are the same.


Open Slide #13 (Great Job, Class!) in Normal View


You could go to the web to search for video and clip art examples to use
on the slide, but for convenience sake you will find the animated image
you need in the Work Files for LibreOffice.


Go to the Insert Ribbon > Images Group and click to
select Pictures…

Navigate to your USB drive > Work Files for LibreOffice


Miscellaneous Files > Practice folder and double
click on the file called Excited_man to Insert it onto
Slide #13


Feel free to grab the image (not on the handles) and move
it to wherever on the slide looks good to you—and grab the
handles if you want to resize the image




When you are done, your slide will look something like that illustrated
in Fig. 10.54.

[image: ]

Fig. 10.54 Final look of the Conclusion slide


Save the presentation before moving on to the last task


Keep in mind, as always, that moderation with content such as clip art,
sounds, and movies is key. Your topic (the Function), not the style
(the Form) of your show, must always be the main focus.

10.9 SOME FINAL THOUGHTS ABOUT PRESENTATIONS

Think you’re ready to make some engaging and relevant interactive
Impress shows? Before you jump in, consider the following suggestions.

It’s inevitable: Impress is so easy to use and fun to play with that
every beginning user from ages 6 to 96 wants to use all the tricks and
tools available. Yet, always remember the golden rule: Substance before
Style. Garbage, no matter how colorfully arrayed and beautifully
orchestrated, is still garbage.

Keep your focus on the content, then use only those tools that are
appropriate for your audience and task. Got a group of sleepy students
that don’t seem thrilled about photosynthesis? Sure, throw in lots of
sound and moving text. But for test-taking and concept review, make the
presentation simple, clean, and succinct.

Next, remember the three secrets to creating an Impress presentation:
plan, plan, and plan? This is even more vital in the interactive show,
when one bookmark linking the wrong answer (My teacher is NOT a mammal.)
could have unexpected consequences. Some of us learn better when we can
visualize our task, so you may want to sketch out your ideas on paper or
on a Writer document until you feel comfortable with this new testing
method.

Lastly, just because you’ve created your presentation doesn’t mean
you’ve finished. After planning a presentation and creating the show,
you need to spend time practicing using it. Take the test yourself.
Dummy-proof your show as much as your grade-level dictates (more Slide
Control on the introductory slides for example for younger children).
The beauty of all digital content such as an Impress presentation is
that it is easy to fix problems you may find, easy to update, easy to
improve, easy to maintain. So take the trouble to fine-tune your work
when you see that it needs further work.

SKILL CONSOLIDATION

1. Prepare an interactive presentation that introduces yourself to your
class at the start of a new school year. Have five silly questions about
your education, hobbies, family, etc. Students will enjoy learning about
you and will have a great introduction into your class. Use any graphics
and sounds you like. Be sure to have a Title slide, an Intro slide, and
an Acknowledgements slide.

2. Prepare an interactive presentation that reviews a basic concept that
must be memorized in your class (times tables, grammar rules, Spanish
vocabulary, periodic table). Have five questions related to the topic.
Depending on your class, have the presentation on a classroom computer,
E-mail it to your students to study with from home, or run it in the
computer lab. Use any graphics and sounds you like. Be sure to have a
Title slide, an Intro slide, and an Acknowledgements slide.

3. Modify the steps in this chapter and teach your students how to make
an interactive Impress presentation. Have them create a quiz on a
hobby or sport of their choosing. This not only teaches them advanced
computer skills, but it helps them synthesize and organize information.
The hyperlink and Slide Control steps require clear organization skills
and logical thinking, great practise for real classroom learning. Use
any graphics and sounds you like. Be sure to have a Title slide, an
Intro slide, and an Acknowledgements slide.

4. Prepare a presentation that works like an Internet scavenger hunt.
Choose your own topic (say, Dinosaurs). Come up with five questions
related to the topic. On each of the five Question slides, make each
question a hyperlink to a Web site with the answer on it. Then have four
possible answers to each question, only one of which is correct. Follow
the steps in this chapter to make the presentation interactive. For each
question you will need two hidden slides with the answer, one Correct
and the other Incorrect. After the title slide, you will have an
introductory slide which explains to the student how to proceed with the
exercise. Thus, your Impress will have 18 slides in all—a Title slide,
an Introductory slide, 15 Question and Answer slides, and an
Acknowledgements slide. Students will have to search the linked sites
for the information, requiring more sophisticated thinking skills than
simply memorizing facts. As in the lesson (US States and Capitals), when
the student clicks on an answer, the slide sends them to a hidden slide
which indicates whether the answer is right or wrong. If the answer is
wrong, a button on that slide sends the student back to the question
slide. If the answer is correct, a button sends the student to the next
Question slide in the presentation. Use any graphics and sounds you
like.

[^1]: LibreOffice maintains a website where you can access, as well as
contribute your own, Master Page
Templates.
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LibreOffice Shortcuts

Quick Keyboard Commands


    
        
            	Shortcut
            	Writer
            	Base
            	Calc
            	Impress
        

    
    
        
            	Ctrl-a or (with pointer in left margin) Ctrl-left click
            	Select entire document
            	Select All
            	Select All cells
            	Select All
        

        
            	Ctrl-b
            	Bold
            	Bold
            	Bold
            	Bold
        

        
            	Ctrl-c or F3
            	Copy
            	Copy
            	Copy
            	Copy
        

        
            	Ctrl-f
            	Find
            	Find Request
            	Find
            	n/a
        

        
            	Ctrl-Enter
            	Insert Page Break
            	n/a
            	n/a
            	Move to the next object on a slide or Add (create) slide
        

        
            	Ctrl-g
            	Go to
            	n/a
            	n/a
            	n/a
        

        
            	Ctrl-h
            	Find and Replace
            	Replace text
            	n/a
            	n/a
        

        
            	Ctrl-i
            	Italics
            	n/a
            	n/a
            	Italics
        

        
            	Ctrl-l
            	Left Justify text
            	n/a
            	n/a
            	n/a
        

        
            	Ctrl-m
            	Move tab ½” right
            	n/a
            	Format a Number
            	Add (create) slide
        

        
            	Shift-Ctrl-m
            	Move tab ½” left
            	n/a
            	n/a
            	n/a
        

        
            	Shift-Alt ↑ or ↓
            	Move a selected paragraph up or down a page in single paragraph increments
            	n/a
            	n/a
            	n/a
        

        
            	Ctrl-n
            	New document
            	n/a
            	n/a
            	n/a
        

        
            	Alt-n
            	n/a
            	New object
            	New sheet
            	New presentation
        

        
            	Ctrl-o
            	Open
            	Open
            	Open
            	Open
        

        
            	Ctrl-p
            	Print
            	Print
            	Print
            	Print
        

        
            	Ctrl-q
            	Quit
            	Quit
            	Quit
            	Quit
        

        
            	Ctrl-r
            	Right Justify text
            	New Record
            	Fill Right
            	n/a
        

        
            	Ctrl-Tab
            	Save As
            	Display Page
            	Save As
            	n/a
        

        
            	Ctrl-s
            	Save
            	Save Query
            	Save
            	Save
        

        
            	Ctrl-u
            	Underline
            	n/a
            	Underline
            	Underline text
        

        
            	Ctrl-v
            	Paste
            	Paste
            	Paste
            	Paste text
        

        
            	Ctrl-x
            	Cut
            	Cut
            	Cut
            	Cut
        

        
            	Ctrl-z
            	Undo
            	Undo
            	Undo
            	Undo
        

        
            	Ctrl-1 (one)
            	n/a
            	n/a
            	Format cell
            	n/a
        

        
            	F1
            	Help
            	Help
            	Help
            	Help
        

        
            	F7
            	Spelling/Grammar check
            	Spelling check
            	Spelling check
            	Spelling check
        

        
            	Ctrl-[
            	n/a
            	n/a
            	n/a
            	decrease font size
        

        
            	Ctrl-]
            	n/a
            	n/a
            	n/a
            	increase font size
        

    

Shortcuts when selecting Text


    
        
            	Selection Task
            	Shortcut
        

    
    
        
            	Select adjacent text
            	Click and drag over the text
        

        
            	Select a word
            	Double-click on the word
        

        
            	Select a sentence
            	Triple click anywhere in the sentence
        

        
            	Select a paragraph
            	Quadruple click anywhere in the paragraph
        

        
            	Select an extended section
            	Click at one end of the section, then Shift-Click at the other end
        

        
            	Select whole document
            	Ctrl-a or (with pointer in left margin) Ctrl-left click
        

        
            	Select from the insertion point to the beginning or end of document
            	Press Shift-Ctrl-Home or Shift-Ctrl-End
        

    

**Quick Keyboard Commands**

Shortcut | Writer | Base | Calc | Impress
--- | --- | --- | --- | ---
**Ctrl-a or** (with pointer in left margin) **Ctrl-left click** | Select entire document | Select All | Select All cells | Select All
**Ctrl-b** | Bold | Bold | Bold | Bold
**Ctrl-c** or **F3** | Copy | Copy | Copy | Copy
**Ctrl-f** | Find | Find Request | Find | n/a
**Ctrl-Enter** | Insert Page Break | n/a | n/a | Move to the next object on a slide or Add (create) slide
**Ctrl-g** | Go to | n/a | n/a | n/a
**Ctrl-h** | Find and Replace | Replace text | n/a | n/a
**Ctrl-i** | Italics | n/a | n/a | Italics
**Ctrl-l** | Left Justify text | n/a | n/a | n/a
**Ctrl-m** | Move tab ½” right | n/a | Format a Number | Add (create) slide
**Shift-Ctrl-m** | Move tab ½” left | n/a | n/a | n/a
**Shift-Alt ↑ or ↓** | Move a selected paragraph up or down a page in single paragraph increments | n/a | n/a | n/a
**Ctrl-n** | New document | n/a | n/a | n/a
**Alt-n** | n/a | New object | New sheet | New presentation
**Ctrl-o** | Open | Open | Open | Open
**Ctrl-p** | Print | Print | Print | Print
**Ctrl-q** | Quit | Quit | Quit | Quit
**Ctrl-r** | Right Justify text | New Record | Fill Right | n/a
**Ctrl-Tab** | Save As | Display Page | Save As | n/a
**Ctrl-s** | Save | Save Query | Save | Save
**Ctrl-u** | Underline | n/a | Underline | Underline text
**Ctrl-v** | Paste | Paste | Paste | Paste text
**Ctrl-x** | Cut | Cut | Cut | Cut
**Ctrl-z** | Undo | Undo | Undo | Undo
**Ctrl-1 (one)** | n/a | n/a | Format cell | n/a
**F1** | Help | Help | Help | Help
**F7** | Spelling/Grammar check | Spelling check | Spelling check | Spelling check
**Ctrl-\[** | n/a | n/a | n/a | decrease font size
**Ctrl-\]** | n/a | n/a | n/a | increase font size

**Shortcuts when selecting Text**

Selection Task | Shortcut
--- | ---
Select adjacent text | Click and **drag** over the text
Select a word | **Double-click** on the word
Select a sentence | **Triple click** anywhere in the sentence
Select a paragraph | **Quadruple click** anywhere in the paragraph
Select an extended section | Click **at one end** of the section, then **Shift-Click** at the other end
Select whole document | **Ctrl-a or** (with pointer in left margin) **Ctrl-left click**
Select from the insertion point to the beginning or end of document | Press **Shift-Ctrl-Home** or **Shift-Ctrl-End**
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Embedded Database: |HSQLDB Embedded [~
6.4 CREATING THE DATABASE TEMPLATE an ©) Open an existing database file
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database of student records because it won't contain any actual records right away. This way you'll By
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| Open LibreOffice > Base Database then, in the Database Wizard which pops
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Fig. 6.7 Stasting a new Base database
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Open the database for editing, then click on the Finish button to save the

new database pon o o
- In the Save As dialog box which pops up, navigate to your USB drive > Work e e
Files for LibreOffice folder > Data Files folder and create a New Folder with Gradebook

the name Database Documents

Double click on the Database Documents folder to Open it, then, in the File
Name data entry box, type the file name Student Records Template and click
on Save

Base now displays the newly created Student Records Template database (Fig. 6.7).
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FIRST THINGS FIRST

TRAINING FOR THE TEACHERS
by Bernard John Poole

Abstract

The teaching profession appears to be on the brink of radical transformation as a result of the infusion of
computing technology into schools. It is no easy fask making the transition from traditional teaching to teaching with
technology. This is because the transition is as much a culfural one as one of mere methodologies. It involves a shift in
teaching paradigms, a shift in the way of thinking sbout teaching. This shift, away from the teacher as imparter of leaming
0 the teacher as facilitator of leaming, demands a great deal of curriculum re-thinking and re-design as well as the learning.
of new methodologies vis-a-vis the use of computer-based technologies in the classroom. One teacher put it this way:
"We'e all philosophically committed to this, but it has involved so much work, we're barely keeping our heads above water.
We have spent a massive amount of time in rethinking things and rewriting courses.”

Training is thus important throughout 2 teacher's career. Exactly what technology skills and concepts is 2 teacher
expected to have leamed to be able to operate effectively in schools today? The Intemational Saciety for Tectnology in
‘Education (ISTE) is the largest not-for-profit profeshional organization supporting computer using educators in the world.
ISTE fully endorses the belief that "computer-related technology must become 2 tool that students and teachers use
routinely if studerts are to be adequately prepared for adult citizenship in our Information Age society” (STE, 1992). For
this reason, the society has drawn up  set of Cumriculum Guidelines for Accreditation of Educational Computing and
Technology Programs "to provide guidance to teacher preparation instiutions that are developing programs in educational
computing and technology and to asist them in preparing folios for the National Council for Accreditation of Teacher
‘Education (NCATE) program evaution.”

e «

i [Find

= Find All [] Match Case G

Page1/5 | 2418 words, 10061 characters | Fist Page | Engish (USA) | T B | [ Gonm | - o+ %





_images/image246.png
File Edt View Insert Tools Window Help

o b

Qe-

-

Common Name

Family.

Color2

[Purple Martin
Redhead
Northern shoveler

Barn Swallow
American Bittern
Ring-necked Duck
Mallard

Gadwall
Green-winged Teal
American Coot

Pintail

Common Snipe
Solitary Sandpiper
Killdeer

Canada Goose

Marsh Hawk

Virginia Rail

‘Common Yellowthroat
Red-winged Blackbird
Hooded Merganser
Screech Owl

Tree Sparrow

Turkey

Ring-necked Pheasant
Rock Dove

House Sparrow
Starling

‘Common Flicker

Swallow
Duck
Duck

Black-crowned Night Her Heron

Swallow
Heron

Duck large
Duck

Duck large
Duck large
Rail large
Duck very large
Sandpiper  medium
Sandpiper  medium
Plover medium
Duck very large
Hawk large
Rail medium
Wood Warbler small
Oriole. medium
Duck large
owl medium
Finch small
Turkey very large
Phessant verylarge
Pigeon large
Weaver Finch | smll
Starling medium
Woodpecker large.
Swift small
Nightiar  medium
Thrush medium
Finch small
Wood Warbler smll

blue
red

green
blackish green
bluish black
brown
black

green

gy

green

gy

brown
brown

gy

gy
grayish brown
gy

gy

black

black

black

gy

brown
brown
green

gy

brown
black
brown
brown

gy

brown

red

black

black

black
black, gray
white, brown
gy

black

gy, purple
white, brown
brown

gy

black

white, gray

white
brown

white

white red
cinnamon, white
green, yellow
red

white, cinnamon
brown

white

blue

black, brown
blue, white
black

green, purple
white, gray

brown
red

white, orange
orange






_images/image492.png
[Hatching [Bitmaps|

) Qriginsl

[ Atificial Turf
== Daisy

[ Relative






_images/image262.png
wees L SRR TR =

m

LOOKUP.

Determines a value in a vector by comparison to values in another vector.

result_vector (optional)
The vector (row or range) from which the value s to be determined.

mm‘ﬁ‘
saa.gm.-\ﬁ\
resutvector [ fx|

e e ]

M =
P27 =
=

s






_images/image315.png
File Edt Vew Iset Fomat Tooks Dote Window Help x
Bre-to@s THIKDB-A o BRI EPICBEI|O
i [Geneva el ada BEEERES 4% % e(EE B -E-a-F)
a1 <] % T = [Class Grades
’ slclole[F] ¢ W i 7 K L M
Grades A B C D E

StudentsinRange” 1 4 4 1 0 |

BRI S R IR RIS IS GRS A S S N = R S E TR (T

[)(€)3)1)\ Sheet1 (Sheel2 /Sheet3 [ Sheetd [ Sheets [ Sheet [ Sheet? [ Sheet® [ Shee® /3 « | i Vi
Sheet1/16 | Pagestyle Sheetl TalC] | Sum=0 [-——o—+ 0%






_images/image1110.png
LibreOffice Base

' Youintend to delete 1 record.

Ifyou click Yes, youwon't be able to undo this operation
Do you want to continue anyway?

(= No






_images/image393.png
Edit View Inset Format Tools Window Help

Yl [

= (R & |

PR E

BT fe b

BE2EE ©

Poe 5ol 10 [Brecute Report]

O D D T O

T

Common Name

Family

Date Sighted

Count

=Common Name

=Family

=Date Sighted

|=Count.






_images/image-install-ide.jpeg
Aways connect
Your first hard
disk drive h

The first hard disk drive  Connect to.
should be connected to  other IDE.
IDE1 cable. IDE' cable ~ device.
can connect a Mastar

and a Save drive. If

you connect two IDE

devices on the same  Connect fo.
cable, you should other IDE
configure the second  device.
dovice to Slave moda

by setting the jumper

Connect 1o other
IDE device.

accorgingly.
af DE2  IDEY
P
« & Hard Disk
O O

1. Plugthe power connector in your IDE devices.

2. Gonnectthe flat cable to your IDE devices.

3. Connect an audio cable from the CD-ROM/
DVD-ROM tothe connector on the mainboard

4. Configure the jumper to Slave mode. Refer to [5)
your CD-ROM / DVD-ROM manual

5. Insert this end to your mainboard.

CAREFUL! Handle your hard disk drive with care. It may not work properly

g:% if roushly handicd. Never move a compater while it tuned om; doing 55

may irreperably damage te hard drive.






_images/image422.png
b5

File Edit View Insert Format Table Tools Window Help x
B-8E0 BPE TS REP- 4 O Femeq®

P B B B B SRR SRS RRRRRRE
- &

- AfE ] o ] [mmenale] & [ [[[TT0 IS EEEFE &% 0

FEP) «

<

I i ] v
N/ mOeVTEIO-0--A-B-%-[Faxa:[ 0 5 8| 2

Page1/1 | Owords, 0 characters [ ettt sy | T [mi [ G| | %3065/388 224x] DO | - o + [100%






_images/image263.png
[ Student Records Table -

el &

e

&

Edit View Inset Tools Window Help

B Qe % »

1D | FustNome | MidaleName | Lost Name

Semard o Sose
5
=
Gelln Mwanda Mayoss
O Crorn

Record| 4 [of603) WD






_images/image312.png
EHS O- libreofficeL essont - Word 7@ - 8 x

EEBl HOME  INSIRT  DESIGN  PAGELAYOUT  REFERENCES  MALINGS | REVIW | VIEW Signin
ABC B Y @ &, BS[simpleMarkup + B - A

& fF B Blsmptermn | [ o #
aten® i A o B OB A
peling & ,p Tranlate Language  New ac Accep ompare Restict Sta
Grammar (8 - > Comment [E= Show Comments: Changes - [FIReviewing Pane ~ . 3 - Editing  Inking
Proofing Language Comments Tracking G Changes  Compare protec e A
m ' 2 3 B s N B

U LUIEL yOU Call SEC UIC K1 IMaent AN \F1g. 1.15).

Right Indent marker

First Line Indent marker
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Lefy/Hanging Indent marker

Fig. 1.18 The Indent Markers

In this exercise you will practice using just the First Line Indent marker and the Left Indent
marker. In Lesson 2 you will have plenty of opportunity to learn about the Hanging Indent
and the Right Indent markers.
Let’s learn how to use the First Line Indent marker now.
Click to put the cursor anywhere within the first paragraph of the letter
(this tells Writer which paragraph of text to reformat)
N In the Ruler bar, place the tip of the mouse pointer on the First Line

Indent marker (see Fig. 1.18)

Now use the mouse to drag the First Line Indent marker across 2" to

the right (to the 2” hash mark on the ruler)
Notice that the First Line Indent marker (the upper triangular marker) and the Left/Hanging
Indent marker (the lower triangular marker) moved independently and that only the first line

of the paragraph has moved to the right half an inch (%2").
Next you are going to set the First Line Indent marker for the second and third

paragraphs in the body of the letter.

B First, make sure you can see the whole letter in the window (maximize
the window if necessary), then click to position the cursor before the first
word of the second paragraph (before “The Institute...”)

Now, while holding down the Shift key, click at the end of the third (last)
paragraph (after the words “...from you soon.”) -
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ISTE Foundational skills and concepts

ISTE's Curricufum Guidelines include a listing of the set of "fundamental skills and concepts for applying
information technology in educational settings" (Table 1). These skills and concepts should form a foundation for

the studies that prepare teachers to teach in the modem computerized classroom.

Skill or Concept

[Demonstrate abilty to operate a computer system in order to successfully utiize
software.

Evaluate and use computers and related technologies to support the instructional
process.

Apply current instructional principles, research, and appropriate assessment practices to
the use of computers and related technologies.

Explore, evaluate, and use computeritechnology-based materials, including applications,
educational software and associated documentation.

Demonstrate knowledge of uses of computers for problem-salving, data collection,
information management, communications, presentations, and decision making.

Design and develop student learning activities that integrate computing and technology
for a variety of student grouping strategies and for diverse student populations.

Evaluate, select, and integrate computeritechnology-based instruction in the curriculum
of one’s subject area(s) andor grade levels

Demonstrate knowledge of uses of mukimedia, hypermedia, and telecommunications to
support instruction.

Demonstrate skl in using productivity tools for professional and personal use, including
word processing, database, spreadsheet, and print/graphic utiities.

Demonstrate knowledge of equity, ethical, legal, and human issues of computing and
technology use as they relate to society and model appropriate behaviors.

Identify resources for staying cument in applications of computing and related
technologies in education.
Use computer-based technologies to access information to enhance personal and
professional productivty.
Apply computers and related technologies to faciltate emerging roles of the leamer and

the educator]

Table 1 ISTE Foundational teacher skils and concepts.
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Count of Ducks Sighted

Monday, July 14, 2014

Common Name
Redhead

Northern shoveler
Ring-necked Duck
Mallard

Gadwall
Green-winged Teal
Pintail

Canada Goose
Hooded Merganser

Family Date Sighted
Duck 01-Sep-93
Duck 01-Sep-93
Duck 01-Sep-93
Duck 08-Sep-93
Duck 08-Sep-93
Duck 08-Sep-93
Duck 08-Sep-93
Duck 01-0ct-93
Duck 16-Oct-94
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[appears to-be-onrthe brinik-of radical transformatio as aTesult of thenfusion-of computing:

Itis noeasy task making the transition from traditional teaching to teaching with
the transition is-as much-a-culfural one-as-one of mere methodologies. Tt involves a
5,2 shift in the way-of thinking about teaching.- This-shift away from the teacher as-
teacher as facilitator of e aming, demands 2 great deal -of curriculum e-thinking and re-
g of new methodologies vis-a-vis the-use of computer-based technologies in-the-
it this way:"We're-all philosophically-committed o this, butit has involved so much:
g our heads dbove water.We have spent 2 massive amount of time inethinking things-

throughous-a teacher's career- Exactly what technology skills and conceptsis-ateacher-

1o be-able-to-operate effectively in-schools today? The Intemational-Society for-
(ISTE) s the largest not-for-profit profeshional organization supporting computer sing:
STE fully endorses the belief that "computer-related-technology must become-a tool that

routinely if students are to be adequately prepared for adult <itizenship in-our Information

[

).-For this reason, thesociety has drawn up-a-set-of Curriculum Guidelines for-

‘omputing and Technology Programs-"to provide-guidance to-teacher preparation:
\g programs ineducational-computing and tectnology and to-asist them in-preparing
i for Acereditation-of Teacher Education (NCATE) program-evahution."

IS TE Foundational skills-and conceptst
ISTE's Curricubum Guidelines include 2 fisting-of the set of "fundamental skills-and-concepts for applying
information technology in educational settings " (Table-1).- These skills-and concepts should form-a foundation:for-
the-studies that prepare teachers to teachin the modem computerized classroom.{

1
Skill-or Concept!

Demonsirate abilty-to-operate a computer system in order to-successfully tlize software.{
Evaluate and use computers-andrelated technologies to-support the instructional process
Apply currentinstructional principles, tesearch, and appropriate-assessment practices to the use-of computers and

related technologies.

Explore, evaluate, and-use computertechnology-based materials, including applications, educational scftware and:
associated-documentation €

Demonsirate knowledge-of uses of computers for problem-solving, data-collection, information management,
communications-presentations -anddecisionmaking ©

Design-and develop student leaming activities-that integrate computing and technology fora variety of student
‘erowping strategies and for diverse student populations.§

‘Evaluate,select and integrate computer/technology- based instruction-in the curriculum-of one's subject-area(s)

and/or gradeevels.S

Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to supportinstruction &

Demonsirate skillinusing productivity tools for professional-and personal use, including word:processing, database,

spreadsheet -and print graphic-wilities
Demonsirate knowledge of equity;-ethical, legal. and human issues of computing and technology use as they relate
to-society-andmodel -appropriate behaviors.
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[ see | Coort Color2 Habitat Dete Sighted_|_Location Sighted_| _ Weather__| Cod
medium _ blue black woods 97171993 woods nearhome _ sunny, warm 2
large red black. gray lakes 9/1/1993 ke sunny, warm 6
large green white, brown _ marshes 9/1/1993 ke sunny, warm 8
verylarge  blackish green gray freshwater  9/1/1993 lake sunny, warm 2
small bluishblack _ cinnamon ‘open country near 9/1/1993 fields near school _ sunny, warm 3
verylarge  brown black marshes 9/1/1993 lake sunny, warm |5
Duck large black gray.purple lakes 9/1/1993 ke sunny, warm 2
Duck verylarge green white, brown _ marshes 9/8/1993 riverbank sunny cool 4
Duck large aray brown marshes 9/8/1993 lake sunny, cool 10
|Green-winged Teal Duck large green aray marshes 9/8/1993 ke sunnycool 3
|| American Coot Rail large gray black ‘marshes 9/8/1993 riverbank sunny, cool 2
| |Pintail Duck verylarge  brown ‘white, gray ‘marshes 9/8/1993 lake sunny, cool 15
|__|Common Snipe Sandpiper  medium brown ‘marshes 10/1/1993 lake cloudy, cool 1
| |solitary Sandpiper Sandpiper  medium gray ‘white lakes 10/1/1993 lake cloudy, cool 1
| |Killdeer Plover ‘medium gray brown fields 10/1/1993 fields near school  cloudy, cool 1
| |Canada Goose Duck verylarge grayishbrown  white ‘marshes 10/1/1993 lake cloudy, cool 25
|| Marsh Hawk Hawk large gray ‘white,red ‘marshes 10/3/1993 lake cloudy, cool 2
| |virginia Rail Rail ‘medium gray cinnamon, white  marshes 10/3/1993 lake cloudy, cool 50
|| Common Yellowthroat Wood Warbler small black green, yellow  meadows 10/10/1995 fields near school _ sunny, cool 2
| |Red-winged Blackbird Oriole ‘medium black red ‘marshes 10/16/1996 lake cloudy, cool 1
| |Hooded Merganser Duck large black ‘white, cinnamon _lakes 10/16/1994  lake cloudy, cool 3
| |Screech Owl owl ‘medium gray brown ‘woods 10/30/1996  woods near home  sunny, cold 1
| |Tree Sparrow Finch ‘small brown ‘white fields 10/31/1996 fieldsnearschool  cloudy, cool 15
| |Turkey Turkey verylarge  brown blue ‘woods 11/1/1995 woods near home  cloudy, cold 4
| |Ring-necked Pheasant Pheasant  verylarge green black, brown  woods 11/6/1997 woods near home  cloudy, cold 2
| |Rock Dove Pigeon large gray blue, white cities 12/1/1997 city park cloudy,cold 5
| |House Sparrow Weaver Finch small brown black cities 12/20/1997  backyard cloudy,cold 10
| |stariing Starling ‘medium black green, purple _ cities 2/21/1994 city park cloudy, cold 20
|| Common Flicker Woodpecker mlarge brown ‘white, gray ‘woods 3/24/1995 backyard sunny, cold 1
| |Chimney Swift Swift ‘small brown ‘woods 3/25/1994 ‘woods near home _ sunny, cold 1
|| Whip-poor-will Nightjar ‘medium gray brown ‘woods 3/25/1997 ‘woods near home _ sunny, cold 2
|| American Robin Thrush ‘medium brown red cities 4/1/1997 backyard sunny, cool 6
|__|House Finch Finch ‘small red ‘woods 4/2/1997 woods near home  cloudy, cool 3
| |American Redstart Wood Warbler small black ‘white, orange  woods 4/15/1995 riverbank sunny, warm 2
| |Northern Oriole Oriole ‘medium black orange ‘woods 4/15/1995 backyard sunny, warm 2
|| Cardinal Finch ‘medium red ‘woods 4/15/1995 backyard sunny, warm 2
| |Vellow-breasted Chat Wood Warblel medium brown gray ‘meadows. 4/15/1996 fields near school sunny, warm 1
|| Vellow Warbler Wood Warbler small brown yellow ‘woods 4/15/1996 city park sunny, warm 2
| |Gray Catbird Mockingbird medium gray black, brown  woods 4/15/1996 woods near home _sunny, warm 1
|| Willow Fiycatcher Tyrant Flycatc medium olive brown ‘marshes 5/1/1994 lake sunny, cool 1
| |Black-capped Chickadee  Titmouse  small gray black, white ‘woods 5/1/1995 ‘woods near home _ sunny, cool 4
| |Warbling Vireo Vireo ‘small olive gray ‘woods 5/1/1997 ‘woods near home _ sunny, cool 2
| |Orange-crowned Warbler | Wood Warbler small green orange ‘woods 5/1/1997 ‘woods near home _ sunny, cool 1
| |Common Grackle Oriole large black green, purple  marshes 5/21/1994 lake sunny,warm 25
| |Bewick's Wren Wren ‘small brown ‘white, gray ‘woods 5/21/1995 woods near home  sunny, warm 2
| |Brown-headed Cowbird _ Oriole ‘medium green black ‘woods 5/21/199 woods near home _sunny, warm 1
|| Common Crow Crow large black rivers, meadows  5/21/1996 backyard sunny, warm 5
| |veery Thrush ‘medium brown buff ‘woods 5/21/1997 woods near home _sunny, warm 1
| |song Sparrow Finch ‘medium brown ‘white ‘marshes 5/21/1997 fields near school _sunny, warm 3
" [House Wren Wren small = brown woods 5/21/1997  woodsnear home sunny,warm 2
Record] 1 o0 ] < ] B
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Tane Doe -(Your name here-so your instructor knows-who youare)f

1

Hodge Road Elementary-Schoolf
123 Mingo BluffRoad{

Cape Coral, FL234567

L.(MMSM—szoshd[
856-SW-2e4Place]
Cape Coral, FL234567

Deare -andMrs. Mayosha,§

}mplmnd—iomfmmyonﬂziyomdznghm;ﬂzlkn,—hmi)eanscband—byﬂm—l’m—
Grade teachers to-tepresent Hodge Road Elementary Schoolat the Newfound Harbar-
Marine Biology Tnstitute in Key West Flarida, as a-Junior Biologist. Since Hellenhas-
shown both academic-excellence and-sound social skills this past-school year, she would:
‘bea great-candidate for the program. We-very much hope that you-will-support Hellen in
fhis opportunity. T

hd

‘The Institute has a wonderful reputation for both-child and adult programs. Thave-
attended the facility myself-and-had-a splendid time ‘Hellen would take partn a two-
weelk session in-June with S graders from all over the state-of Florida

Loy

1
Please call me (619)772-3223-or email me (mprendergast@hodgeroad edu) to discuss-
‘more details about the program THook forward to hearing from you-soon

‘Smn:ly‘yom,‘

1

:

Ms.Mary Prendergastf

Head of Sciencell
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~ 1. Demonstrate abilty to operate a computer system in order to successfully utilize software.
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- process.

- 3. Apply current instructional principles, research, and appropriate assessment practices to E
- the use of computers and related technologies.

- 4. Explore, evaluate, and use computer/technology-based materials, including applications, L
- educational software and associated documentation F
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- information management, communications, presentations, and decision making,
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N technology use as they relate to society and model appropriate behaviors.

- 11 Identify resources for staying current in applications of computing and related

- technologies in education

- 12. Use computer-based technologies to access information to enhance personal and
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N 13. Apply computers and related technologies to faciltate emerging roles of the learner and
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It il be useful o examine these skills and concepts more closely.
1 Teachers must demonstrate ability to operate 3 computer system in orderto successfuly utiize software.
The use of computer-based systems should become second nature for teachers, much Hke using the chalkboard.
Today this is more Hely than ten years ago. Systems are much easier to use because of improved operating
environments which shield the user from much of the technical detail. Graphical User Interfaces (GUIS) such as are
integral to the Apple Macintosh and Commodore Amiga computers are now also available to IBM users since the
introduction of MicrosoRt Windows and Windows NT. The major advantage of GUIs is standardization; users can
quickly leam hors to use all the new software because much of the interaction is gomqR across applications. There
are fewer suprises. However, for the beginner there is stil much to leam in order to amive at the point where the
use of computer-based technology can be integrated into cuniculum and lesson plazing.
2 Teachers must be able to evaluate and use computers and other related technologies to support the
ctional proce:
‘Evaluation invelves keeping current with state of the art hardware useful in educational computing. Itis important
Fortgechsys to know what is going on because othervise they are at the mercy of suppliers. They may not be getting
the best value for money or the appropriate equipment to meet theirneeds. One of the best ways to keep cument is
to subscribe to magazines and joumals, attend conferences where systems are demonstrated by other users and
vendors, and join professional organizations.
The best school districts will support teachers in attendance at cowses and seminars related to computer use in
education. Another successful way to keep cument with regard to methodologies, research, and assessment practices
s to set up an electronic bullein board system (BBS) in the district or statewide, as s the case in some parts of the
‘United States. This would allow teachers unrestricted exchange of ideas.
3 Teachers should leam to apply current instructional principles. research, and appropriate assessment
‘practices to the use of computers and related technologies.
This s another reason to subscribe to those publications, attend those conferences, and join those professional
‘organizations.Teashes should be familiar with changing philosophies of education, gspeshalli as they apply to
using the computerin the classroom. They should also knowhow best to evaluate the impact of methodologies that
involve computer-based technology. One of the deceptive dangers of using computers in the classroom is that
children enjoy using computers whether they are leaming anything or not! So teachers have to be disceming asto
the educational benefits accruing from the use of specific leaming svstems.
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1. Open the plastic clips at each side of Oen the clip Open the clip

the DIMM slot.

2. Insert the RAM modules vertically into DDD DI:'I:[]
the DIMM slot. Then push it in. ()

3. The clips will close automatically.

TIP! The RORAM, also called RAMBUS, can only work in pairs. When your
mainboard uses the RORAM modules, remember to buy them in pairs or you
should buy a C-RIMM instead.

CAREFUL! Do not touch or hold the RAM modules by the pins, also called
golden fi ngers. Oil on the pins or dust in the slot may cause the RAM
modules to work improperly. You can use a soft cloth to wipe the pins or
compressed air to blow the dust off the slot. Do NOT use solvent, which
may erode the metal content.
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side on your screen
Click on File > Open, then navigate to your disk drive/USB drive > Work Files

for LibreOffice > Miscellaneous Files > Templates folder and open the
Grades Template document

Now you should have both the Gradebook document and the Gradebook Template document open
on your screen.

Ifyou have a large enough screen, use the mouse to drag each window so they
are side-by-side (Fig. 5.20)

CEN-TC]

The two spreadsheets are open
"] side-by-side so you can work on
- both of them at the same time

Fig. 5.20 Spreadsheets arranged side-by-side
Now you can sce both spreadsheets side by side on your screen, as illustrated in Fig. 5.21

What you're doing now is update the Grades Template spreadsheet with the same format and
functions as the Gradebook document so that you can use the template with other classes you may
have in the future. Hint: Use Copy and Paste to complete many of the tasks. DON'T transfer any
of the actual student data from the Gradebook to the Grades Template—only transfer the functions
and other formatting features you added to the Gradebook document (Fig. 5.22 on the next page
illustrates what you need to do—read the directions carefully before you proceed)

Go ahead now and update the Grades Template by putting a box around the
6 Class info cells (A4 thru B6), then copy and Paste the TOTAL and PERCENT
formulas
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12. Use computer-based technologies to access information to enhance personal and professional productivity.

13. Apply computers and related technologies to faciltate emerging roles of the leamer and the educator.
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1. Teachers must demonstrate sbility to_operate a
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second rature for teachers, much like using the
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ISTE's Curiculum Guidelines include a listing of the set of "fndamental skils and concepts for applying
iformation techrology in educational settings" (Table 1). These skils and concepts should form  foundation for
the studies that prepare teachers t teachin the modem computerized classroom.

Skill or Concept

Demonstrate abilty to operate a computer system in order to successfully utiize software

Evaluate and use computers and related technologies to supportthe instructional process

Apply current instructional principles, research, and appropriate assessment pracices to the use L]
of computers and related technologies

4. Explore, evaluate, and use computertechnology-based materials, including applications,
educational software and associated documentation

5. Demonstrate knowledge of uses of computers for problem-solving, data collection, information
management, communications, presentations, and decision making.

6. Design and develop student leaming activties that integrate computing and technology for a
variety of student grouping strategies and for diverse student populations.

7. Evaluate, select, and integrate computerftechnology-based instruction in the curriculum of one’s
subject area(s) andlor grade levels

8. Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support
instruction

9. Demonstrate skil in using productivity tools for professional and personal use, including word
processing, database, spreadsheet, and print/graphic utilties

10. Demonstrate knowledge of equity, ethical, legal, and human issues of computing and technology
use as they relate to society and model appropriate behaviors

1. Identify resources for staying current in applications of computing and related technologies in
education

12. Use computer-based technologies to access information to enhance personal and professional
productivity

13. Apply computers and related technologies to facilitate emerging roles of the learner and the
educator.

Table 1 ISTE Foundational teacher skils and concepts.
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practces 1 10 set up an electronic buLletin boara system
(BBS) in the district or statewide, as s the case in some
parts of the Urited States. This would allow teachers
unrestricted exchange of ideas.

3 Teachers should learn to apply current
instructional principles, research, and appropriate
‘assessment practices to the use of computers and related.
technologies.

This s another reason to subscribe to those publications,
attend those conferences, and join those professional
organizations Teachers should be familiar with changing
‘philosophies of education, espeshally as they apply to
using the computer in the classroom. They should also
Enow how best to evaluate the impact of methodologies
that involve computer-based technology. One of the
eceptive dangers of using computers in the classroom is
that children enjoy using computers whether they are
Ieaning anything or not! So feachers have to be
discerning 23 to the educational benefits accruing from
the use of specific learning systems.

4 Teachers should take time to explore, evaluate,
and use computer/technology-based materials, including
applications, educational software and associated
docomentation.

This s a time-consuming, but nonetheless essential, task.
Once again, well-managed school districts will st aside,
on an on-going basis, adequate time for allteachers to
examine new learning systems, whether they do 0
individually or in groups. Teacher-computerists would.
e responsible for previewing all technology-based
‘materials, sifting out the good from the garbage, so that
the other teachers don' have to waste time fltering the
plethora of systems fludding the market today. If
acceptance of technology for teaching and learning has
‘been half-hearted in the past it has been at least in part
‘becanse the teachers have not been given a faif chance to
find out what is available, and to learn how best to
incorporate the technology nfo the curriculom.

. Teachers should be able to demonstrate
Enowledge of uses of computers for problem-solving,
data collection, information managemen,
communications, presentations, nd decision-making.
Teachers should uze computers to manage the whole
instructional process from lesson planning, delivery, and
evaluation. Courses and workshops are only useful i
they lead to application of what has been learned. Untold
hours have been spent by teachers who have attended
such courses and workshops without there having been 3
transfer of skills learned into thei professional life. Why
i5this? In some cases it is because the hardware and
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7. Tachers should b able to evalate,select, and
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abletoshare yous ideas with others. For example, math
feachers will be best t identifying appropriate
applications in the math classroor.
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nultimedia, bypermedia, and telecommunications o
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How to contribute to this project



		Taken from http://docs.readthedocs.io/en/latest/getting_started.html


$ pip install sphinx sphinx-autobuild





		To auto update as you write your document. The _build_html/index.html will be updated every time you update your document:


$ sphinx-autobuild . _build_html





		To build the output (folder _build):


$ make html











How to add new documents



		All the documents are stored in docs/ folder.


		Create a folder for your documentation and then link it on index.rst


		There’s a script called docx2md.sh that you can use to convert docx files to markdown.








Deployment for RACHEL



		Run make html to update the _build folder. It will get picked up by rachel-index.php automatically


		On the client, update by getting the file: wget --no-check-certificate https://github.com/SystemR/ict/archive/master.zip


		If the repository was checked out using git, do a git pull on the folder to update








Deployment for Read The Docs



		Every time you commit and push to the git repo, http://ict.readthedocs.io/ will be updated with the latest documentation
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TRAINING FOR THE TEACHERS
by Bernard John Poole

Abstract
The teaching profession appears to be on the brink of radical transformation as a result of the infusion of computing
technology into schools. Itis no casy task making the transition from traditional teaching to teaching with technology: This
s because the transition is as much a cultural one as one of mere methodologies. It involves a shift in teaching paradigms, a
shift in the way of thinking about teaching. This shift, away from the teacher as imparter of leaming to the teacher 25
facilitator of leaming, demands 2 great deal of curriculum re-thinking and re-design 2s well as the leaming of new
‘methodologies vis-a-vis the use of computer-based technologies in the classroom. One teacher put it this way: "We're all
philosophically committed to this, but it has involved so much work, we're barely kecping our heads above water. We have
spent a massive amount of time in rethinking things and rewsiting courses.”

Training is thus important throughout a teacher's career Exactly what technology skills and concepts is a teacher expected
to have leamed to be ble to operate effectively in schools today? The Intemational Society for Technology in Education
(ISTE) is the largest not-for-profit profeshional organization supporting computer using educators in the world. ISTE fully
endorses the belief that "computer.selated technology must become 2 tool that students and teachers use routinely if students.
are to be adequately prepared for adult citizenship in our Information Age society” (ISTE, 199). For this reason, the
society has drawn up a set of Curriculum Guidelines for Accreditation of Educational Computing and Technology Programs
"to provide guidance to teacher preparation institutions that are developing programs in educational computing and
technology and to asist them in preparing folios for the National Council for Acereditation of Teacher Education (NCATE)
program evaluation."

ISTE Foundational skills and concepts
ISTE's Curriculum Guidelines include a fisting of the set of "fundamental skills and concepts for applying information
technology in educational settings” (Table 1). These skills and concepts should form a foundation for the studies that
‘prepare teachers to teach in the modem computerized classroom.

Skill or Concept
Demonstrate abilty to operate a computer system in order to successfully utiize software.

Evaluate and use computers and related technologies to support the instructional process

Apply current instructional principles, research, and appropfiate assessment practices to the use of computers
and related technologies

Explore, evaluate, and use computeritechnology-based materials, including applications, educational software
and associated documentation

Demonstrate knowledge of uses of computers for problem-solving, data collection, information management,
communications, presentations, and decision making.

Design and develop student leaming activiies that integrate computing and technology for a variety of student
grouping strategies and for diverse student populations

Evaluate, select, and integrate computerftechnology-based instruction in the curriculum of one’s subject area(s)
and/or grade levels

Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support instruction
Demonstrate skill in using productivity tools for professional and personal use, including word processing,
database, spreadsheet, and print/graphic utiities

Demonstrate knowledge of equity, ethical, legal, and human issues of computing and technology use as they
relate to society and model appropriate behaviors
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Jane Doe

Hodge Road Elementary School
123 Mingo Bluff Road

Cape Coral, FL 23456

06/05/14

Mr. and Mrs. M Mayosha
856 SW 20 Place
Cape Coral, FL 23456

Dear Mr. and Mrs. Mayosha|

Tam pleased to inform you that your daughter, Hellen, has been selected by the
Fifth Grade teachers to represent Hodge Road Elementary School at the Newfound
Harbor Marine Biology Institute in Key West, Florida, as a Junior Biologist. Since
Hellen has shown both academic excellence and sound social skills this past school year,
she would be a great candidate for the program. We very much hope that you will
support Hellen in this opportunity.

‘The Institute has a wonderful reputation for its offerings for both children and
adults. Hellen would take part in a two-week session in June with 5s graders from all
over the state of Florida. She would thus be able to meet and make friends with others of
her own age and academic ability.

Please call me (619) 772-3232 or email me (mprendergast@hodgeroad.edu) to
discuss more details about the program. I look forward to hearing from you soon.
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FIRST THINGS FIRST
TRAINING FOR THE TEACHERS
by Bemard Jotn Poole

Abstact
The teaching profession appears to be on the brink of radical transformation as a result of the infusion of computing
technology into schools. Itis no easy task making the transition from traditional teaching to teaching with
technology. This i because the transition s as much a cultural one as one of mere methodologies. It nvolves 2
shiftin teaching paradigms, a shift in the way of thinking about teaching. This shift, away from the teacher as
impater of leaming to the teacher as facilitator of learning, demands a great deal of curriculum re-thinking and re-
design as well as the leaming of new methodologies vis-a-vis the use of computer-based technologies in the
classroom. One teacher put it this way: "We're all philosophically committed to this, butit has involved so much
work, we're barely keeping our heads above water. W have spent a massive amount of ime in rethinking things.
and rewriting courses.”

Training is thus important roughout a teachers career. Exactly what technology skills and concepts is a teacher
‘expected to have leamed to be able to operate effectively in schools today? The Intemational Society for
Technology in Education (ISTE) is the largest not-for-profit profeshional organization supporting computer using
educators in the world. ISTE fully endorses the belief that "computer-related technology must become a tool that
students and teachers use routinely if studerts are to be adequately prepared for adult ctizenship in our Information
Age society” (ISTE, 1992). For this reason, the society has drawn tp a set of Curriculum Guidelines for
Accreditation of E ducational Computing and Technology Programs "to provide auidance to teacher preparation
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Tt will be useful to examine these concepts and
skills more closely.
1. Teachers must demonstrate ability to operate a

Page 2

allow teachers unrestricted exchange of ideas.
3. Teachers should learn to current
instuctional _principles, rescarch, _and

computer system in_order to_successfully

‘appropriate assessment practices to the use of

R

uilize software.
he use of computer-based systems
should become second nature for
teachers, much like using the
chalkboard. Today this is more likely than ten
years ago. Systems are much casier to use
becanse of improved operating environments
which shield the user from much of the technical
detail. Graphical User Interfaces (GUIs) such as
are integral to the Apple Macintosh computers are
now also available to IBM users since the
introduction of Microsoft Windows and Windows
NI The major advantage of GUIs is
standardization; users can quickly leam how to
use all the new software because much of the
interaction is comon across applications. There
are fewer surprises. However, for the beginner
there is still much to learn in order to arrive at the
point where the use of computer-based
technology can be integrated into curriculum and
lesson planing.
2. Teachers must be able to evalate and use

i

‘computers and related techologies.

This is another reason to subscribe fo
those publications, attend those conferences, and
join those professional organizations. Teachers
Should be familiar with changing philosophies of
education, espeshally as they apply to using the
computer in the classroom. They should also
know how best to cvaluate the impact of
methodologies that involve computer-based
technology. One of the deceptive dangers of
using computers in the classroom is that children
enjoy using computers whether they are learning
anything or notl  So teachers have fo be
discerning as to the educational benefits accruing
from the use of specific learning systems.

4. Teachers should take toexplore,
‘evaluate, and use computer/technology-based
‘materials. including applications, educational
Software and associated documentation.

This is a time-consuming, but nonetheless
essential, task. Once again, well-managed school
districts will set aside, on an on-going basis,
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TRAINING FOR THE TEACHERS

by Bemard John Paole

Abstract
The teaching profession appears to be on the brink of radical transformation as a result of the infusion of computing
technology into schools. It is no casy task making the transition from traditional teaching to teaching with technology. This
s because the transition is as much a cultural one as one of mere methodologies. It involves 2 shiftin teaching paradigms, 2
Shift in the way of thinking about teaching. This shift, away from the teacher as imparter of leaming to the teacher as
facilitator of leaming, demands a great deal of curriculum e-thinking and re-design as well as the leaming of new
‘methodologies vis-a-vis the use of computer-based technologies in the classroom. One teacher put it this way: "Wetre all
philosophically committed to this, but it has involved somuch work, we're barely keeping our heads above water. We have
spent a massive amount of time in rethinking things and rewriting courses.”

Training is thus impostant throughout a teachers career. Exactly what technology skills and concepts is a teacher expected
0 have leamed to be able to operate effectively in schaols today? The Intemational Society for Technology in E ducation
(ISTE) i the largest not-for-profit profeshional organization supporting computer using educators in the world. ISTE fully
endorses the belief that "computer-related technology must become a tool that students nd teachers use routinely if students
are to be adequately prepared for adult citizenship in our Information Age society” (ISTE, 1992). For this reason, the
Society has drawn up a set of Curriculum Guidelines for Accreditation of Educational Computing and Technology Programs
"to provide guidance to teacher preparation institutions that are developing programs in educational computing and
technology and to asist them in preparing folios for the National Council for Accreditation of Teacher Education (NCATE)
program evaluation.”

ISTE Foundational skills and concepts
ISTE's Curriculum Guidelines include 2 listing of the set of "fundamental skills and concepts for applying information
technology in educational settings” (Table 1). These skills and concepts should form a foundation for the stadies that
‘prepare teachers to teach in the modem computerized classroom.

Skill or Coneept
Demonstrate ability to operate a computer system in order to successfully utilize software.

‘Evaluate and use computers and related technologies to support the instructional process.

Apply cuent instructional principles, research, and appropriate assessment practices to the use of computers and related
technologies.

Explor, evaust, mdse compuertechrology-based mateit,inchudingspplictions, ducationl sofware nd
associated documentation.

Demonstrate knowledge of uses of computers for problem.solving, data collection, information management,
‘communications, presentations, and decision making.

Design and develop student leaming activites that integrate computing and technology for a variety of student grouping
strategies and for diverse student populations.

‘Evaluate, select, and integrate computer technology-based instruction in the curriculum of one's subject area(s) and/or grade
fevels.

Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support nstruction.

Demonstrate skil in using productivity tools for professional and personal use, including word processing, database,
spreadsheet, and print graphic utiities.

Demonstrate knowledge of equity, ethical, legal, and human issues of computing and technology use as they relate to
society and model appropriate behaviors.

Identify resaurces for staying current in applications of computing and related technologies in education.

Use computer-based technologies fo access information to enhance personal and professional productivity:
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installation.
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HodgeRoad Elementary School
123 Mingo Bluff Avenue
Johnstown, PA 15905

Dear

Yours very sincerely

DomaHendy
15t Grade Teacher
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Skill or Concept

Demonstrate abilty to operate a computer system in order to successfully utiize software.
Evaluate and use computers and related technologies to support the instructional process

Apply current instructional principles, research, and appropfiate assessment practices to the use of computers
and related technologies

Explore, evaluate, and use computeritechnology-based materials, including applications, educational software
and associated documentation

Demonstrate knowledge of uses of computers for problem-solving, data collection, information management,
communications, presentations, and decision making.

Design and develop student leaming activiies that integrate computing and technology for a variety of student
grouping strategies and for diverse student populations

Evaluate, select, and integrate computerftechnology-based instruction in the curriculum of one’s subject area(s)
and/or grade levels

Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support instruction
Demonstrate skill in using productivity tools for professional and personal use, including word processing,
database, spreadsheet, and print/graphic utiities

Demonstrate knowledge of equity, ethical, legal, and human issues of computing and technology use as they
relate to society and model appropriate behaviors

Identity resources for staying current in applications of computing and related technologies in education

Use computer-based technologies to access information to enhance personal and professional productivity
Apply computers and related technologies to facilitate emerging roles of the leamer and the educator.
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By Berrard John Poole:

Uverery o pvssrgn Jorsrom
[

* Think you know the
U.5. 50 states and
their capitals>

* This quiz will test
your knowledge and
perhaps teach you
something new!

« Read each of the questions carefully.

« Click on what you think is the best
answer.

« If you don't get the answer correct, go.
back and ry again.

+ Good luck!

Which is the capital of Texas?
Houston
Dallas
San Antonio
Austin

Which is the largest U.S. state?

California
Alaska
Texas
Rhode Tslard
10, 1
Which is the southernmost U.S. state?
Hawaii
Florida
California
Mississippi
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Asare Bediako Secondary School
Alrokerri

Adansi-North, Ashanti, Ghana
Tuesday, April 21, 2015

«Home_Contact>
«Address_Line_l»
«City», Stater «ZIP_Coder

Dear «Home_Contact»,

This is to let you know that on June 3+ we plan to take «Student_First_Name»
«Student_Last_Name»'s class on a day-long field trip to the Kwame Nkrumah University
of Science and Technology in Kumasi. The trip will be the culminating activity of a five
week Science Unit where the various features of STEM (Science, Technology,

M Engincering, and Mathematics) have been stressed in order to encourage our Third Form
students to prepare themselves for 2 world where these areas of knowledge will be key to
their success on graduation from College.

«Student_First_Name» will leave and refurn within the normal time for the school day, so
K there will be no disruption to your own schedule.

Please prepare «Student_First_Name» a pack lunch for the trip. The restaurant facilities
at the University in Kumasi are somewhat expensive and we have been unable to

negotiate an acceptable reduced charge for school children.

Feel free to call me at school (+233-249-984-854) should you have need to discuss this
matter. Thank you for your help and support in this endeavor and throughout the year.

Yours very sincerely,

Dr. Kofi Adjaye
Department Chairperson

Ioikd
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TRAINING FOR THE TEACHERS

by Bemard John Paole

Abstract
The teaching profession appears to be on the brink of radical transformation as a result of the infusion of computing
technology into schools. It is no casy task making the transition from traditional teaching to teaching with technology. This
s because the transition is as much a cultural one as one of mere methodologies. It involves 2 shiftin teaching paradigms, 2
Shift in the way of thinking about teaching. This shift, away from the teacher as imparter of leaming to the teacher as
facilitator of leaming, demands a great deal of curriculum e-thinking and re-design as well as the leaming of new
‘methodologies vis-a-vis the use of computer-based technologies in the classroom. One teacher put it this way: "Wetre all
philosophically committed to this, but it has involved somuch wotk, we're barely keeping our heads above water. We have
Spent a massive amount of time in rethinking things and rewriting courses.”

Training is thus impostant throughout a teachers career. Exactly what technology skills and concepts is a teacher expected
0 have leamed to be able to operate effectively in schaols today? The Intemational Society for Technology in E ducation
(ISTE) i the largest not-for-profit profeshional organization supporting computer using educators in the world. ISTE fully
‘endorses the belief that "computer-related technology must become a tool that students and teachers use routinely if students.
are to be adequately prepared for adult citizenship in our Information Age society” (ISTE, 1992). For this reason, the
Society has drawn up a set of Curriculum Guidelines for Accreditation of Educational Computing and Technology Programs
"to provide guidance to teacher preparation institutions that are developing programs in educational computing and
technology and to asist them in preparing folios for the National Council for Accreditation of Teacher Education (NCATE)
program evaluation.”

ISTE Foundational skills and concepts
ISTE's Curriculum Guidelines include 2 listing of the set of "fundamental skills and concepts for applying information
technology in educational settings” (Table 1). These skills and concepts should form a foundation for the stadies that
‘prepare teachers to teach in the modem computerized classroom.

Skill or Coneept
Demonstrate ability to operate a computer system in order to successfully utilize software.

‘Evaluate and use computers and related technologies to support the instructional process.

Apply current instructional principles, research, and appropriate assessment practices to the use of computers and related
technologies.

Explor, evaust, mdse compuertechrology-based mateit,inchudingspplictions, ducationl sofware nd
associated documentation.

Demonstrate knowledge of uses of computers for problem.solving, data collection, information management,
‘communications, presentations, and decision making.

Design and develop student leaming activites that integrate computing and technology for a variety of student grouping
strategies and for diverse student populations.

‘Evaluate, select, and integrate computer technology-based instruction in the curriculum of one's subject area(s) and/or grade
fevels.

Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support nstruction.

Demonstrate skill in using productivity tools for professional and personal use, including word processing, datibase, <
spreadsheet, and pint graphic uliies. &
Demorsteate kmonledge of equity, athical legal, and human ssues of computing andtechnology e 3 thy elte o @
society e model appeopriats beaviors 5

i ] »
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Jane Doe (Your name here so your instructor knows who you are)

Fodge Road Elementary] School
123 Mingo Bluff Road

Cape Coral, FL 23456

06/05/14

Mr. and Mrs. M Mayosha
856 SW 2w Place
Cape Coral, FL 23456

Dear Mr. and Mrs. Mayosha,

Tam pleased to inform you that your daughter, Hellen, has been selected by the Fifth
Grade teachers to represent Hodge Road Elementary School at the Newfound Harbor
Marine Biology Instifute in Key West, Floridz, as a Junior Biologist Since Hellen has
shown both academic excellence and sound socia skills this past school year, she would
be a great candidate for the program. We very much hope that you will support Hellen in
this opportunity.

The Instifute has a wonderful reputation forits offerings for both child and adults.
Hellen would take partin a two-week session in June with 5 graders from all over the
state of Florida. She would thus be able to meet and make fiends with others ofher own
age and academic abiliy.

Please call me at schoal (619) 772-3232 or email me (mprendergast@hodgeroad.edu) to
discuss more details about the program. Ilook forward to hearing from you soon.

Sincerely yours,

Ms Mary Prendergast
Head of Science

m
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13 F Grades Distribution.

:: Triple click on the Title of the chart—Students in Range—and in its place

= type Class Grades Distribution

17 | You can easily make any other changes to the chart. Try this now.
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5 Now, in the Chart Tools > Design Ribbon > Chart Styles Group, Live

3] Preview some of the different preset styles

= There are several preset styles that are actually quite interesting.

50 When you're done trying things out, go to File menu > Save As... and, in your
(1) Sheet1 Sheet2 //Sheet3 /Sheetd]| « | I Work Files for LibreOffice > Data Files > Spreadsheet Documents foider,
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ISTE Foundstional skils and concepts
ISTE's Currculum Guidelines inciude 2 listing of the set of "fndamental skills and concepts for applying
infomation technology in educatonal settings" (Table 1). These skils and concepts should form  foundation for
the studies that prepare teachers t teachin the modem compuserized lassroom.
'Skill or Concept Ml
Demonstrate ability to operate a computer system in order to successfully utilize software.
Evaluate and use computers and related technologies to support the instructional process
Apply current instructional principles, research, and appropriate assessment practices to the use of L
computers and related technologies. =
Explore, evaluate, and use computer/technology-based materials, including applications, educational
N software and associated documentation.
. Demonstrate knowledge of uses of computers for problem-solving, data collection, information
N management, communications, presentations, and decision making.
- Design and develop student learning activities that integrate computing and technology for a variety of
- student grouping strategies and for diverse student populations.
Evaluate, select, and integrate computer/technology-based instruction in the curriculum of one's subject
- area(s) andlor grade levels
- Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support
- instruction
N Demonstrate skil in using productivity tools for professional and personal use, including word processing,
- database, spreadsheet, and print/graphic utilties.
= Demonstrate knowledge of equity, ethical, legal, and human issues of computing and technology use as.
N they relate to society and model appropriate behaviors.
- Identify resources for staying current in applications of computing and related technologies in education
- Use computer-based technologies to access information to enhance personal and professional
N productivity.
N Apply computers and related technologies to facilitate emerging roles of the leamer and the educator.
o Table 11STE Foundational teacher skills and concepts
- 5
- ©
N )
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Skill or Concept
Demonstrate ability to operate 2 computer system in order to successfully uilize software.

‘Evaluate and use computers and related technologies to support the instructionl process.

Apply cumentinstructiona principles, rescarch, and approprite assessment practices to the use of computers and
related technologics.

Esplore, evaluate, and use computertechnology-based materials, including applications, educational software and
associated documentation.

Demonstrate knowledge of uses of computers for problem- solving, data collection, information management,
communications,presenations, and decision making.

Design and develop student learning acivities that integrate computing and technology for 2 variety of student
‘zrowing strategies and for diverse studert populaticns.

‘Evaluate, select and integrate computer technology-based instruction in the curricufum of one’s subject area(s)
andlor grade levels.

Demonstrate knowledge of uses of multimedia, hypermedia, and telecommuications to support instruction.
Demonstrate skillin using productivity too’s for professional and persenl use, including word processing, database,
spreadshest, and print graphic wiliies.

Demonstrate kno wledge of equity, ethical legal, and human issues of computing and technology use as they relate
to society 2nd model appropriate behaviors.

Identify resources for staying current in applications of computing and related technologies in education.

Use computer-based technologies to access information to entance personal and professional productvity.

Apply computers and related technologies to facilitate emerging roles of the leamer and the eductor.

Table 1 ISTE Foundational teacher skills and concepts

Itwill be useful to examine these skils and concepts more closely.
1 Teachers must demonstrate ability to operate a computer system in order to successfilly wiilize software.
‘The use of computer-based systems should become second nature for teachers, much like using the chalkboard.
‘Today this is more likely than ten years ago. Systems are much easier to use because of improved operating

Pagel]

environments which shield the user from much of the technical detail. Graphical User Interfaces (GUIs) such as are
integral to the Apple Macintosh and Commodore Amiga computers are now alo available to IBM users since the
introduction of Microsoft Windows and Windows NT. The major advantage of GUIS is standardization: users can
quickly leam how to use all the new software because much of the interaction is comon across applications. There
are fewer suprises. However, for the beginner there s still much to leam in order to arrive at the point where the
use of computer-based technology can be integrated into curriculum and lesson planing.

2. Teachers must be able to evaluate and use computers and other related technologies to support the
instnuctional process.

‘Evaluation involves keeping current with state of the art hardware usefiilin educational computing. Itis important
for teechers to know whatis going on because ofherise they are at the mercy of suppliers. They may not be gefting
the best value for money o the approptiate equipment fo meet their needs. One of the best ways to keep curentis
to subscribe to magazines and joumaks, aftend conferences where systems are demonsirated by other users and
‘vendors, and join professional organizations.
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12. Use computer-based technologies to access information to enhance personal and professional productivity.

13. Apply computers and related technologies to faciltate emerging roles of the leamer and the educator.

Table 1 ISTE Fomdatonsl texcher conespts ud sl

Ry R I R AR
1. Identify resausces for staying current in applications of computing and related technologies in education.
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Tt will be useful to examine these concepts and sKlls

more closely.

1. Teachers must demonstrate sbility to_operate a
computer_system in oder fo_successfully utlize
software,

The use of computerbased systems should
become second rature for teachers, much like using the.
chalkboard. Today this is more fikely than ten years
ago. Systems are much easier to use because of
improved operating environments which shield the user
from much of the technical detail Graphical User
Interfaces (GUIS) such as are integral to the Apple
Macintosh computers are now ako available to IBM
users since the introduction of Microsoft Windows and
Windows NT. The major advantage of GUIS is
standardization; users can quickly leam how fo use all
the new software because much of the interaction i
‘common across applications. There are fewer suprises.
However, for the beginner there is still much to leam in
order to amive at the point where the use of computer-
‘based technology can be integrated into curriculum and
fesson planing.

2. Teaches must be able fo evaluate and use
‘computers and other related technologies to support
the mstructional process.

‘Evaluation involves keeping current with state

of methodologies _that involve
One of the deceptive dangers of using

technology.

Page3

computer-based

computers in the classroom is that children enjoy using.

computers whether they are leaming anything o not!
So teachers have to be disceming as to the educational
benefits accruing from the use of specific leaming

systems.

4. Teachers should ke time to explore. evahute, and

e computertechnology-based _material
inciudin; cations._educationsl software and
‘associated documentation.

This is a timeconsuming, but nonetheless
essential, task. Once again, wellmanaged school
distrits will set aside, on an on-going basis, adequate
time for all teachers to examine new leaming systems,
whether they do 5o individually or in groups. Teacher.
computerists would be responsible for previewing all
fechnology-based materials, sifting out the good from
the garbage, so that the ofher teachers dont have o
waste time fitering the plethora of systems flooding the
market today. If acceptance of technology for teaching
nd leaming has been half-hearted in the past it has been

at least in part because the teachers have not been given
a fair chance to find out what s available, and to leam
how best fo incorporate the technology into the

curricutum.
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1. Demonsirate abifity to operate a computer system in order to successfully utilize software.
2. Evaluate and use computers and related technologies to support the instructional process.

3. Apply cument instructional principles, research, and appropriate assessment practices to the use of
‘computers and related technologies.

4 Explore, evaluste, and use computer'technology-based materials, including spplications,
educational software and associated documertation.

5. Demonstrate knowledge of uses of computers for problem-solving, data collection, information
‘management, communications, presentations, and decision making. L

6. Desien and develop student leaming activites that integrate computing and technology for 2
varety of student grouping strategies and for diverse student populations.

7. Evatuate, select, and integrate computer technology-based instmction in the curriculum of one's
subject area(s) mdor grade leveks.

8. Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support
instruction.

9. Demonstrate skill in wsing productivity tools for professional and personal use, inchuding word
processing, database, spreadsheet, and print graphic utiliies.

10. Demonstrate knowledge of equity; ethical, legal. and fuman issues of computing 2nd technology
use asthey rlate to society md model appropriate behaviors.

11. Identify resources for staying current in applications of computing and related technologies in
education.

12. Use computer-based technologies to access information to enhance persoral and professional
productivity.

13. Apply computers and related technologies to facilitate emerging roles of the leamer and the
educator.
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- ‘because much of the interaction is comon across accruing from the use of specific learning
applications. There are fewer surprises. systems.
- However, for the beginner there is still much to 4. Teachers should take to explore
- learn in order to arrive at the point where the use evaluate, and use iter/technology-based
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into curriculum and lesson planing. are and associated documentation.
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Go ahead now and update the Grades Template by putting a box around the
6 Class info cells (A4 thru B6), then copy and Paste the TOTAL and PERCENT
formulas

Sign in
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The oval shape now looks like a picce of glass or transparent plastic or sheer material, partially
revealing the object that is behind it Fig. 3.21. Neat, huh?

Bear in mind that the purpose of this lesson is fo show you the many drawing tools in Office
2013 and let you practice with them. It's up to you now to use them with ereativity and skill to
produce art work of all kinds for use in your profession.

If the 256 colors of the Standard Colors palette aren't enough for you, you can use the Custom
Colors palette instead (Fig. 3.21).

VM DS DSGN  PAGLAOUT  ROGOKES  WALNGS  REW  VEW | FORAT

B =

fr——

aignTes o send

Stide the sider up and.
down for lighter or
darker colors

Fig. 3.21 Th Office 2013 Custom Colors palette

The Custom Colors palette lets you to choose from any of over 16 million different colors! That's
because the Custom colors palette uses 24 bits to store the colors in the computer memory. It's
called 24-bit color. The computer uses a mix of 24 microscopic on-off switches to store the code
for any one of 16+ billion different colors—hundreds of thousands of shades of green or blue or
pink, for example. Let's ry the Custom Colors paletie now..

Spend a couple of minutes in the Custom Colors palette illustrated in Fig. 3.21
using the color mixers (the cross hair and the slider) to practice mixing a few
of the multitude of colors available to you

Fill Effects
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) S

File Edit View Insert Tools Window Help
& QG- FiitIrY Y
10| Home Contact | StudentFrst Name | Student Lost Name | Adress ine | City | State | 2P |
[T |- and s Brow Jerome Brown 56 Summers Lane Johnsto PA_| 15900
27 Ms. Myers Amanda Myers 163 Windber Gard: Johnsto PA 15905
|3 Mr.and Mrs. John: Courtney Johnston 1 Main St. Johnsto PA 15904
[ ¢ Mr.and Mrs.Kiine Melissa Kiine 146 Hermitage Cir Windbe PA 15007
[ |5 Mr.and Mrs. Keim Jessica Keim 219 Holly Crescent Richlani PA 15904
|6 Mr.Hershberger Jessica Dartton 45BrindleLane  JohnstoPA 15905
[ |7 Dr. and Mrs. Schm Susan Schmidt 2113 Coverdale Bh Johnsto PA 15905
[ |8 Mr.andDr. Suvak Amber Suvak Gondola Mansion: MeyerscPA 15045
[ o Mr. and Mrs. Herte Desiree. Herter 43 Hermes Court Johnsto PA 15906
10 M. and Mrs. Plum Achley Plummer 2 MopleAve. Johnsto PA 15905
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Bird Sightings Table - Bids - LibreOffice Base: Table Data View
File Edit View Inset Tools Window Help
ME IR RS

[ see | Coort Color2 Habitat Dete Sighted_|_Location Sighted_|_ Weather__| Cod
medium _ blue black woods 97171993 woods nearhome _ sunny, warm 2
large red black. gray lakes 9/1/1993 ke sunny, warm 6
large green white, brown _ marshes 9/1/1993 ke sunny, warm 8
verylarge  blackish green gray freshwater  9/1/1993 lake sunny, warm 2
small bluishblack _ cinnamon ‘open country near 9/1/1993 fields near school _ sunny, warm 3
verylarge  brown black marshes 9/1/1993 lake sunny, warm |5
Duck large black gray.purple lakes 9/1/1993 ke sunny, warm 2
Duck verylarge green white, brown _ marshes 9/8/1993 riverbank sunny cool 4

Duck large aray brown marshes 9/8/1993 lake sunny, cool 10
|Green-winged Teal Duck large green aray marshes 9/8/1993 ke sunnycool 3
|| American Coot Rail large gray black ‘marshes 9/8/1993 riverbank sunny, cool 2
| |Pintail Duck verylarge  brown ‘white, gray ‘marshes 9/8/1993 lake sunny, cool 15
|__|Common Snipe Sandpiper  medium brown ‘marshes 10/1/1993 lake cloudy, cool 1
| |solitary Sandpiper Sandpiper  medium gray ‘white lakes 10/1/1993 lake cloudy, cool 1
| |Killdeer Plover ‘medium gray brown fields 10/1/1993 fields near school  cloudy, cool 1
| |Canada Goose Duck verylarge grayishbrown  white ‘marshes 10/1/1993 lake cloudy, cool 25
|| Marsh Hawk Hawk large gray ‘white,red ‘marshes 10/3/1993 lake cloudy, cool 2
| |virginia Rail Rail ‘medium gray cinnamon, white  marshes 10/3/1993 lake cloudy, cool 50
|| Common Yellowthroat Wood Warbler small black green, yellow  meadows 10/10/1995 fields near school _ sunny, cool 2
| |Red-winged Blackbird Oriole ‘medium black red ‘marshes 10/16/1996 lake cloudy, cool 1
| |Hooded Merganser Duck large black ‘white, cinnamon _lakes 10/16/1994  lake cloudy, cool 3
| |Screech Owl owl ‘medium gray brown ‘woods 10/30/1996  woods near home  sunny, cold 1
| |Tree Sparrow Finch ‘small brown ‘white fields 10/31/1996 fieldsnearschool  cloudy, cool 15
| |Turkey Turkey verylarge  brown blue ‘woods 11/1/1995 woods near home  cloudy, cold 4
| |Ring-necked Pheasant Pheasant  verylarge green black, brown  woods 11/6/1997 woods near home  cloudy, cold 2
| |Rock Dove Pigeon large gray blue, white cities 12/1/1997 city park cloudy,cold 5
| |House Sparrow Weaver Finch small brown black cities 12/20/1997  backyard cloudy,cold 10
| |stariing Starling ‘medium black green, purple _ cities 2/21/1994 city park cloudy, cold 20
|| Common Flicker Woodpecker mlarge brown ‘white, gray ‘woods 3/24/1995 backyard sunny, cold 1
| |Chimney Swift Swift ‘small brown ‘woods 3/25/1994 ‘woods near home _ sunny, cold 1
|| Whip-poor-will Nightjar ‘medium gray brown ‘woods 3/25/1997 ‘woods near home _ sunny, cold 2
|| American Robin Thrush ‘medium brown red cities 4/1/1997 backyard sunny, cool 6
|__|House Finch Finch ‘small red ‘woods 4/2/1997 woods near home  cloudy, cool 3
| |American Redstart Wood Warbler small black ‘white, orange  woods 4/15/1995 riverbank sunny, warm 2
| |Northern Oriole Oriole ‘medium black orange ‘woods 4/15/1995 backyard sunny, warm 2
|| Cardinal Finch ‘medium red ‘woods 4/15/1995 backyard sunny, warm 2
| |Vellow-breasted Chat Wood Warblel medium brown gray ‘meadows. 4/15/1996 fields near school sunny, warm 1
|| Vellow Warbler Wood Warbler small brown yellow ‘woods 4/15/1996 city park sunny, warm 2
| |Gray Catbird Mockingbird medium gray black, brown  woods 4/15/1996 woods near home _sunny, warm 1
|| Willow Fiycatcher Tyrant Flycatc medium olive brown ‘marshes 5/1/1994 lake sunny, cool 1
| |Black-capped Chickadee  Titmouse  small gray black, white ‘woods 5/1/1995 ‘woods near home _ sunny, cool 4
| |Warbling Vireo Vireo ‘small olive gray ‘woods 5/1/1997 ‘woods near home _ sunny, cool 2
| |Orange-crowned Warbler | Wood Warbler small green orange ‘woods 5/1/1997 ‘woods near home _ sunny, cool 1
| |Common Grackle Oriole large black green, purple  marshes 5/21/1994 lake sunny,warm 25
| |Bewick's Wren Wren ‘small brown ‘white, gray ‘woods 5/21/1995 woods near home  sunny, warm 2
| |Brown-headed Cowbird _ Oriole ‘medium green black ‘woods 5/21/199 woods near home _sunny, warm 1
|| Common Crow Crow large black rivers, meadows  5/21/1996 backyard sunny, warm 5
| |veery Thrush ‘medium brown buff ‘woods 5/21/1997 woods near home _sunny, warm 1
| |song Sparrow Finch ‘medium brown ‘white ‘marshes 5/21/1997 fields near school _sunny, warm 3
" [House Wren Wren small = brown woods 5/21/1997  woodsnear home sunny,warm 2
Record] 1 o0 ] < ] B
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FIRST THINGS FIRST
‘TRAINING FOR THE TEACHERS
by Bemard John Paole

Abstaact
‘e teachiag profession appears tobe o the bink of radical tansformation a a el of the infusion of computing
technology into schools. 1t i no asy tak makig th transiton rom traditona teaching to teaching withtechrology. This
s becaus th transitionis a5 much a cukural ane as one of mere methodologies. It nvolves a shift n teaching paradigns, a
it inthe way o thinking sbout eaching. This shift, away from the teacher as imparter ofleaming t th teacher 25
Saciltator of eamin, demands a grea deal of currcuum re-tiaking andre design as wellas th leaming of rew
‘methodologies vi-a-vi e use of computer based technologies inthe classroom. One teacher put i this way: "Wee al
philosophically committed totis, but it hs nvolved somuch wark, we're barly keeping our heads above water. We have
Spent a massive amount oftime i rethinking things and rewrting courses.”

Training is this important throughout ateacher's career. Exactly whattechnology skills and concepts is a teacher expected
o have leamed 10 be able o operate effecivelyfn schools today? The IntemationalSociety for Technology in Education
(ISTE) i the lrgest o for.profit pofeshional crganizaton supporting computer usig educatos n the wodd. ISTE fully
endorss th belief that"compiter elated technology mus become a ool that students and eachers use roveinely if sudeats
are to e adequately prepared for adilt citizenship n ou Information Ag society” (ISTE, 1992). For this reason the
Society has drawn up a se of Curiculum Guidelines for Accrditaton of Educationa! Computing and Techaology Programs
Yo provide guidanc toteacher preperation nstutions that are developing programs in educational computing and
{technology and o asst them in preparing folos for the Natonl Counclfor Accreditation of Teacher Education (NCATE)
pogram evaluation”

R IR

ERRE)

ISTE Foundational skills and concepts
ISTE's Curriculum Guidelines include 2 listing of the set of "fundamental skills and concepts for applying information
technology in educational settings” (Table 1). These skills and concepts should form a foundation for the stadies that
‘prepare teachers to teach in the modem computerized classroom.

ERRE)

Skill or Coneept
Demonstrate ability to operate a computer system in order to successfully utilize software.

‘Evaluate and use computers and related technologies to support the instructional process.

Apply current instructional principles, research, and appropriate assessment practices to the use of computers and related
technologies.

Explor, evaust, mdse compuertechrology-based mateit,inchudingspplictions, ducationl sofware nd
associated documentation.

Demonstrate knowledge of uses of computers for problem.solving, data collection, information management,
‘communications, presentations, and decision making.

Design and develop student leaming activites that integrate computing and technology for a variety of student grouping
strategies and for diverse student populations.

‘Evaluate, select, and integrate computer technology-based instruction in the curriculum of one's subject area(s) and/or grade
fevels.

Demonstrate knowledge of uses of multimedia, hypermedia, and telecommunications to support nstruction.

Demonstrate skill in using productivity tools for professional and personal use, including word processing, database,
spreadsheet, and print graphic utiities.

Demonstrate knowledge of equity, ethical, legal, and human issues of computing and technology use as they relate to
society and model appropriate behaviors.
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