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1. Introduction

This version of Cytoscape builds upon
the new 3.x architecture, developer API and set of user controls established. If you’re familiar with former versions of Cytoscape,
this version will feel completely familiar and you’ll be all set to go.
In future releases, we will continue to tweak and improve both the
software and the documentation. This manual will be updated to reflect
all the latest changes.

If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial chapter.

This manual describes the installation and use of Cytoscape. For a more
thorough understanding of Cytoscape and its ecosystem, we highly
recommend reading the Welcome Letter accessible on the
http://cytoscape.org website.





          

      

      

    

  

    
      
          
            
   


2. Launching Cytoscape

Cytoscape is a Java application verified to run on the Linux, Windows,
and Mac OS X platforms. Although not officially supported, other UNIX
platforms such as Solaris or FreeBSD may run Cytoscape if Java version 8
or later is available for the platform.

 


2.1. System Requirements

The system requirements for Cytoscape depend on the size of the networks
you want to load, view and manipulate.

Note that as of Cytoscape v3.2, networks are loaded faster and in less
memory than with previous versions. While this is good news, networks
created on v3.2 on a given memory configuration (e.g., 1GB) may not be
loadable by prior Cytoscape versions on the same memory configuration.


Required Resources
 	                           	Small Network Visualization 	Large Network Analysis/Visualization              

 	Processor     	1GHz               	As fast as possible, with multiple cores 

 	Memory     	512MB           	2GB+                                  

 	Graphics Card 	Integrated video   	High-end graphics card                   

 	Monitor    	XGA (1024X768)  	Wide or Dual Monitor                  



Specific system requirements, limitations, and configuration options
apply to each platform, as described in the Release Notes available
on the http://cytoscape.org website.

 


  
    
    
    3. Command Line Arguments
    
    

    

    

    
 
  
  

    
      
          
            
   


3. Command Line Arguments

Cytoscape recognizes a number of optional command line arguments,
including run-time specification of network files, node and edge data
files, and session files. This is the output generated when Cytoscape is
executed with the “-h” or “–help” flag:

usage: cytoscape.{sh|bat} [OPTIONS]
 -h,--help             Print this message.
 -v,--version          Print the version number.
 -s,--session <file>   Load a cytoscape session (.cys) file.
 -N,--network <file>   Load a network file (any format).
 -P,--props <file>     Load cytoscape properties file (Java properties
                       format) or individual property: -P name=value.
 -V,--vizmap <file>    Load vizmap properties file (Cytoscape VizMap
                       format).
 -S,--script <file>    Execute commands from script file.
 -R,--rest <port>      Start a rest service.





Any file specified for an option may be specified as either a path or as
a URL. For example you can specify a network as a file (assuming that
myNet.sif exists in the current working directory):
cytoscape.sh -N myNet.sif.

Note: if there are spaces in the file path, be sure to put quotes around
it:
cytoscape.bat -N "C:\Program Files\Cytoscape\sampleData\galFiltered.sif".

Or you can specify a network as a URL:
cytoscape.sh -N http://example.com/myNet.sif.


Command Line Arguments
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4. Quick Tour of Cytoscape

This chapter describes the basic layout and mechanics of using Cytoscape. If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial chapter.

 


4.1. Welcome Screen

When you start Cytoscape, you can access basic functions from the
Welcome Screen:

[image: Welcome_33.png]

The Welcome Screen is designed to access commonly used features of
Cytoscape including:


	Create new network

	Import network
	From file

	From public database





	Import interactome for model organisms

	Open recently used session file



Also, a news panel always display latest information for users. For
information on user privacy, see the Cytoscape Privacy
Policy.

 




4.2. Basic Features

When a network is loaded, Cytoscape will look similar to the image
below:

[image: NetworkLoaded.png]

Most functionalities are self-explanatory, but we’ll go through a
concise explanation for clarity. The main window here has several
components:


	The Menu Bar at the top (see below for more information about
each menu).

	The Tool Bar, which contains icons for commonly used functions.
These functions are also available via the menus. Hover the mouse
pointer over an icon and wait momentarily for a description to
appear as a tooltip.

	The Network Panel (Network tab of the Control Panel, top left). This
contains an optional network overview pane (shown at the
bottom left).

	The main Network View Window, which displays the network.

	The Table Panel (bottom right panel), which displays columns of
selected nodes and edges and enables you to modify the values of
column data.



The Network Panel and Table Panel are dockable tabbed Panels. You can
undock any of these panels by clicking on the Float Window control
[image: FloatWindow-v31.png]
in the upper-right corner of the CytoPanel. This is useful when you want
assign the network panel as much screen space as possible. To dock the
window again, click the Dock Window icon
[image: DockWindow.png].
Clicking the Hide Panel icon
[image: HideWindow.png]
will hide the panel; this can be shown again by choosing View → Show
and selecting the relevant panel.

If you click this control, for example on the Table Panel, you will now
have two Cytoscape windows, the main window, and a new window labeled
Table Panel, similar to the one shown below. A popup will be displayed
when you put the mouse pointer on a cell.

[image: TablePanel.png]

Note that Table Panel now has a Dock Window control. If you click this
control, the window will dock onto the main window. For more information
on the panels in Cytoscape, see the
Panels
section.

 


Network Editing

Cytoscape also has an edit functionality that enables you to build and
modify networks interactively within the network canvas. To edit a
network, just right-click on the open space of network window, select
the menu item Add → Node, a new node will be added to the canvas. To
add an edge, right click on a node, choose the menu item Edit → Add
Edge. Then select the target node, a new edge will be added between
the two nodes. In a similar way annotation objects can be added;
pictures, shapes or textboxes; much like in MS PowerPoint or similar
software. Detailed information on network editing can be found in the
Editing Networks
section.

[image: AddNodeMenu.png]

 






4.3. The Menus

 


File

The File menu contains most basic file functionality: File → Open
for opening a Cytoscape session file; File → New for creating a new
network, either blank for editing, or from an existing network; File →
Save for saving a session file; File → Import for importing data
such as networks and tables; and File → Export for exporting data.
File → Export as Image lets you export the
network in either JPEG, PDF, PNG, PostScript or SVG format.
File → Export as Web Page lets you export the entire session or
a single network as a Web page using Cytoscape.js.

File → Recent Session will list recently opened session files for
quick access. File → Run allows you to specify a Cytoscape script
file to run, and File → Print Current Network... allows printing.

[image: FileMenu.png]

 




Edit

The Edit menu contains Cut, Copy and Paste functions, as
well as Undo and Redo functions which undo and redo edits made
in the Table Panel, the Network Editor and to layout.

There are also options for creating and destroying views (graphical
representations of a network) and networks (the raw network data - not
yet visualized), as well as an option for deleting selected nodes and
edges from the current network. All deleted nodes and edges can be
restored to the network via Edit → Undo.

There are also other editing options; Remove Duplicated Edges will
delete edges that are complete duplicates, keeping one edge, Remove
Self-Loops removes edges that have the same source and target node,
and Delete Selected Nodes and Edges... deletes a selected subset of
the network. Rename Network... allows you to rename the currently
selected network.

Editing preferences for properties and apps is found under Edit →
Preferences → Properties.... More details on how to edit preferences
can be found
here.

[image: EditMenu.png]

 




View

The View menu allows you to display or hide the Control Panel,
Table Panel, Tool Panel and the Result Panel. It also
provides the control of other view-related functionality.

[image: ViewMenu.png]

 




Select

The Select menu contains different options for selecting nodes and
edges.

[image: SelectMenu.png]

 




Layout

The Layout menu has an array of features for visually organizing the
network. The features in the top portion of the network (Bundle
Edges, Clear Edge Bends, Rotate, Scale, Align and
Distribute) are tools for manipulating the network visualization. The
bottom section of the menu lists a variety of layout algorithms which
automatically lay a network out.

[image: LayoutMenu.png]

 




Apps

The Apps menu gives you access to the App Manager (Apps → App
Manager) for managing (install/update/delete) your apps and may have
options added by apps that have been installed. Depending on which apps
are loaded, the apps that you see may be different than what appear
here. The below picture shows a Cytoscape installation without installed
apps.

[image: AppsMenu.png]

Note: A list of available Cytoscape apps with descriptions is available online at: http://apps.cytoscape.org

In previous versions of Cytoscape, apps were called plugins and served a
similar function.

 




Tools

The Tools menu contains advanced features like the Command Line Dialog,
Network Analyzer,
Network Merge
and Workflow.

[image: ToolsMenu.png]

 




Help

The Help menu allows you to launch the online help viewer and browse
the table of contents for this manual (Contents).

[image: HelpMenu.png]

The Citations option displays the main literature citation for
Cytoscape, as well as a list of literature citations for installed apps.
The list will be different depending on the set of apps you have
installed.

[image: Citations.png]

The Update Organism Preset Networks option updates the preset
networks available on the Welcome screen to the latest version.

The Help menu also allows you to connect directly to Cytoscape Help
Desk and the Bug Report interface.

 






4.4. Network Management

Cytoscape allows multiple networks to be loaded at a time, either with
or without a view. A network stores all the nodes and edges that are
loaded by the user and a view displays them.

An example where a number of networks have been loaded is shown below:

[image: MultipleNetworkView.png]

The network manager (in Control Panel) shows the networks that are
loaded. Clicking on a network here will make that view active in the
main window, if the view exists. Each network has a name and size
(number of nodes and edges), which are shown in the network manager. If
a network is loaded from a file, the network name is the name of the
file.

Some networks are very large (thousands of nodes and edges) and can take
a long time to display. For this reason, a network in Cytoscape may not
contain a “view”. Networks that have a view are in normal black font and
networks that don’t have a view are highlighted in red. You can create
or destroy a view for a network by right-clicking the network name in
the network manager or by choosing the appropriate option in the
Edit menu. You can also destroy previously loaded networks this way.

Certain operations in Cytoscape will create new networks. If a new
network is created from an old network, for example by selecting a set
of nodes in one network and copying these nodes to a new network (via
the File → New → Network option), it will be shown immediately
follows the network that it was derived from.

Network views can also be detached (undocked) from the main Cytoscape window. When detached, a view window can be dragged to another monitor, resized, maximized and minimized by using the normal window controls for your operating system. Notice, however, that closing a view window does not destroy it, but simply reattaches it to the Cytoscape window.

 


Arrange Network Windows

When you have detached network view windows, you can arrange them by selecting one of these options under View → Arrange Network Windows:

Grid

[image: MultipleNetworks_Grid.png]

Cascade

[image: MultipleNetworks_Cascade.png]

Vertical Stack

[image: MultipleNetworks_VerticalStack.png]

Side by Side

[image: MultipleNetworks_SidebySide.png]

 






4.5. The View Navigator

The View Navigator (or “bird’s eye view”)  is a control that shows an overview of the network.
It can be used to navigate around a large network view. The
blue rectangle indicates the portion of the network currently displayed
in the network view window, and it can be dragged with the mouse to view
other portions of the network. Zooming in will cause the rectangle to
appear smaller and vice versa. You can show or hide it by clicking the “Show/Hide Navigator” button [image: ViewNavigatorControl.png] or pressing the key “N”.

[image: network_overview_34.png]
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5. Creating Networks

There are 4 different ways of creating networks in Cytoscape:


	Importing pre-existing, fixed-format network files.

	Importing pre-existing, unformatted text or Excel files.

	Importing data from from public databases.

	Creating an empty network and manually adding nodes and edges.



 


5.1. Import Fixed-Format Network Files

Network files can be specified in any of the formats described in the
Supported Network
Formats
section. Networks are imported into Cytoscape through the File →
Import → Network menu. The network file can either be located directly
on the local computer, or found on a remote computer (in which case it
will be referenced with a URL).

 


Load Networks from Local Computer

In order to load a network from a local file you can select File →
Import → Network → File... or click on
[image: Cy3_icon_net_file_import.png]
on the tool bar. Choose the correct file in the file chooser dialog and
press Open. Some sample network files of different types have been
included in the sampleData folder in Cytoscape.

After you choose a network file, another dialog will pop up. Here, you
can choose either to create a new network collection for the new
network, or load the new network into an existing network collection.
When you choose the latter, make sure to choose the right mapping column
to map the new network to the existing network collection.

[image: ImportNetwork.png]

Alternatively, you can simply drag and drop a network file from the desktop into the Network list
(Control Panel), rather than selecting the file from the menu option.

Network files in SIF, GML, and XGMML formats may also be loaded directly
from the command line using the -N option.

 




Load Networks from a Remote Computer (URL import)

To load a network from a remote file, you can select File → Import →
Network → URL.... In the import network dialog, insert the appropriate
URL, either manually or using URL bookmarks. Bookmarked URLs can be
accessed by clicking on the arrow to the right of the text field (see
the Bookmark Manager in
Preferences
for more details on bookmarks). Also, you can drag and drop links from a
web browser to the URL text box. Once a URL has been specified, click on
the OK button to load the network.

[image: ImportNetworkFromURL.png]

Another issue for network import is the presence of firewalls, which can
affect which files are accessible to a computer. To work around this
problem, Cytoscape supports the use of proxy servers. To configure a
proxy server, go to Edit → Preferences → Proxy Settings.... This is
further described in the
Preferences
section.

 






5.2. Import Networks from Unformatted Table Files

Cytoscape supports the import of networks from delimited text files and
Excel workbooks using File → Import → Network → File.... An
interactive GUI allows users to specify parsing options for specified
files. The screen provides a preview that shows how the file will be
parsed given the current configuration. As the configuration changes,
the preview updates automatically. In addition to specifying how the
file will be parsed, the user must also choose the columns that
represent the source and target nodes as well as an optional edge
interaction type.

[image: ImportNetworkDialog2.png]

 


Supported Files

The Import Network from Table function supports delimited text files
and Microsoft Excel Workbooks. For Excel Workbooks with multiple sheets,
one sheet can be selected for import at a time. The following is a
sample table file:


Sample Network in Table
 	source     	target     	interaction  	boolean data  	string data   	floating point data 

 	YJR022W    	YNR053C    	pp           	TRUE          	abcd12371     	1.2344543           

 	YER116C 	YDL013W 	pp       	TRUE      	abcd12372 	1.2344543       

 	YNL307C    	YAL038W    	pp           	FALSE         	abcd12373     	1.2344543           

 	YNL216W 	YCR012W 	pd       	TRUE      	abcd12374 	1.2344543       

 	YNL216W    	YGR254W    	pd           	TRUE          	abcd12375     	1.2344543           



The network table files should contain at least two columns for creating
network with edges. If the file has only one column, the created network
will not contain any edges. The interaction type is optional in this
format. Therefore, a minimal network table looks like the following:


Minimal Network Table
 	source     	target     

 	YJR022W    	YNR053C    

 	YER116C 	YDL013W 

 	YNL307C    	YAL038W    

 	YNL216W 	YCR012W 

 	YNL216W    	YGR254W    



One row in a network table file represents an edge and its edge data
columns. This means that a network file is considered a combination of
network data and edge column data. A table may contain columns that
aren’t meant to be edge data. In this case, you can choose not to import
those columns by clicking on the column header in the preview window.
This function is useful when importing a data table like the following
(1):

[image: sampleTableData1.png]

This data file is a tab-delimited text file and contains network data
(interactions), edge data, and node data. To import network and edge
data from this table, choose Unique ID A as source, Unique ID B as
target, and Interactor types as interaction type. Next, turn off columns
used for node data (Alternative ID A, species B, etc.). Other columns
can be imported as edge data.

The network import function cannot import node table columns - only edge
table columns. To import node table columns from this table, please see
the Node and Edge Column
Data
section of this manual.

Note (1): This data is taken from the A merged human interactome
datasets by Andrew Garrow, Yeyejide Adeleye and Guy Warner (Unilever,
Safety and Environmental Assurance Center, 12 October 2006). Actual data
files are available at http://wiki.cytoscape.org/Data_Sets/.
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6. Nested Networks

Cytoscape has the ability to associate a Nested Network with any
node. A nested network is any other network currently defined in
Cytoscape. This capability allows for creation of network hierarchies as
well as circular relationships. For example, various module-finding
plugins make use of nested networks in the overview network that they
generate. There each node representing a module contains a nested
network.

Note that Nested Networks are similar in concept to Groups, but with very different consequences. A Nested Network incorporates an independent network that does not share nodes or attributes with the current network – it can be edited only as a separate network collection or in a separate Cytoscape session. Its nodes cannot be connected to nodes in the current network and cannot be found or filtered using Cytoscape functions or apps. Conversely, nodes in a Group are part of the current network, can have edges to nodes outside of the group, and can be found or filtered using Cytoscape functions or apps.

Most often, Groups are more functional and easier to use.

 


6.1. Creating Nested Networks

There are currently two ways in which a user can create nested networks.


	By importing a Nested Network Format (NNF) file. (See: NNF
Network
Format).

	By manually constructing networks and assigning nested networks to
individual nodes through the right-click node context menu. (See
Nested Network Node Context
Menu).



 




6.2. Visualization of Nested Networks

Nodes containing nested networks that are zoomed in sufficiently display
an image for the nested network. If no current network view exists for
the nested network the image will be a default icon, otherwise it will
be a low-resolution rendering of the nested network’s current layout.

[image: NestedNetwork2.png]
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7. Supported Network File Formats

Cytoscape can read network/pathway files written in the following
formats:


	Simple interaction file (SIF or .sif format)

	Nested network format (NNF or .nnf format)

	Graph Markup Language (GML or .gml format)

	XGMML (extensible graph markup and modelling language).

	SBML

	BioPAX

	PSI-MI Level 1 and 2.5

	GraphML

	Delimited text

	Excel Workbook (.xls, .xlsx)

	Cytoscape.js
JSON [http://cytoscape.github.io/cytoscape.js/#notation/elements-json]



The SIF format specifies nodes and interactions only, while other
formats store additional information about network layout and allow
network data exchange with a variety of other network programs and data
sources. Typically, SIF files are used to import interactions when
building a network for the first time, since they are easy to create in
a text editor or spreadsheet. Once the interactions have been loaded and
network layout has been performed, the network may be saved to GML or
XGMML format for interaction with other systems. All file types listed
(except Excel) are text files and you can edit and view them in a
regular text editor.

 


7.1. SIF Format

The simple interaction format is convenient for building a graph from a
list of interactions. It also makes it easy to combine different
interaction sets into a larger network, or add new interactions to an
existing data set. The main disadvantage is that this format does not
include any layout information, forcing Cytoscape to re-compute a new
layout of the network each time it is loaded.

Lines in the SIF file specify a source node, a relationship type (or
edge type), and one or more target nodes:

nodeA <relationship type> nodeB
nodeC <relationship type> nodeA
nodeD <relationship type> nodeE nodeF nodeB
nodeG
...
nodeY <relationship type> nodeZ





A more specific example is:

node1 typeA node2
node2 typeB node3 node4 node5
node0





The first line identifies two nodes, called node1 and node2, and a
single relationship between node1 and node2 of type typeA. The second
line specifies three new nodes, node3, node4, and node5; here “node2”
refers to the same node as in the first line. The second line also
specifies three relationships, all of type typeB and with node2 as the
source, with node3, node4, and node5 as the targets. This second form is
simply shorthand for specifying multiple relationships of the same type
with the same source node. The third line indicates how to specify a
node that has no relationships with other nodes. This form is not needed
for nodes that do have relationships, since the specification of the
relationship implicitly identifies the nodes as well.

Duplicate entries are ignored. Multiple edges between the same nodes
must have different edge types. For example, the following specifies two
edges between the same pair of nodes, one of type xx and one of type yy:

node1 xx node2
node1 xx node2
node1 yy node2





Edges connecting a node to itself (self-edges) are also allowed:

node1 xx node1





Every node and edge in Cytoscape has a name column. For a network
defined in SIF format, node names should be unique, as identically named
nodes will be treated as identical nodes. The name of each node will be
the name in this file by default (unless another string is mapped to
display on the node using styles). This is discussed in the section on
Styles.
The name of each edge will be formed from the name of the source and
target nodes plus the interaction type: for example,
sourceName (edgeType) targetName.

The tag  can be any string. Whole words or concatenated
words may be used to define types of relationships, e.g. geneFusion,
cogInference, pullsDown, activates, degrades, inactivates, inhibits,
phosphorylates, upRegulates, etc.
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8. Node and Edge Column Data

Interaction networks are useful as stand-alone models. However, they are
most powerful for answering scientific questions when integrated with
additional information. Cytoscape allows the user to add arbitrary node,
edge and network information to Cytoscape as node/edge/network data
columns. This could include, for example, annotation data on a gene or
confidence values in a protein-protein interaction. These column data
can then be visualized in a user-defined way by setting up a mapping
from columns to network properties (colors, shapes, and so on). The
section on
Styles
discusses this in greater detail.

 


8.1. Import Data Table Files

Cytoscape offers support for importing data from delimited text and MS
Excel data tables.

Sample Data Table 1


Sample Data
 	Object Key  	Alias        	SGD ID  

 	AAC3    	YBR085W|ANC3       	S000000289    
 
 	AAT2 	YLR027C|ASP5    	S000004017 

 	BIK1    	YCL029C|ARM5|PAC14 	S000000534    



The data table file should contain a primary key column and at least one
data column. The maximum number of data columns is unlimited. The
Alias column is an optional feature, as is using the first row of
data as column names. Alternatively, you can specify each column name
from the File → Import → Table → File... user interface.

 


Basic Operation

[image: ImportColumnsFromTable.png]


	Select File → Import → Table → File....

	Select a data file. The file can be either a text or
Excel (.xls/.xlsx) file.
Alternatively, you can simply drag and drop the file from the desktop into the Table Panel.

	In the Target Table Data section, choose where to import the
data to. You can choose an existing network collection, a specific
network only, or you can choose to import the data to an
Unassigned Table (described below).

	Depending on what you choose in the Where to import Table Data
drop-down, you will need to select a network collection or
specific network. You will also need to select Importing Type,
that is whether the data is node, edge or network table columns.

	If the table is not properly delimited in the preview panel, change
the delimiter in the Advanced Options panel. The default
delimiter is tab. This step is not necessary for Excel Workbooks.

	By default, the first column is designated as the primary key.
Change the key column if necessary.

	Click OK to import.




Unassigned Table

As of Cytoscape 3.1. it is possible to import data tables without
assigning them to existing networks, meaning the data doesn’t have to
correspond to any nodes/edges currently loaded. If a data table is
imported as unassigned and a network is later imported that maps to the
data in terms of nodes or edges, the data will link automatically. This
is useful when loading a large dataset (for example expression data),
defining a Style for visualizing the data on networks and later
loading individual networks to view the data, for example from an online
database. This feature allows the data to be automatically linked to any
network that is applicable, without having to load the data for each
network.
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9. Ontology and Annotation Import

Annotations in Cytoscape are stored as a set of ontologies (e.g. the
Gene Ontology, or GO). An ontology consists of a set of controlled
vocabulary terms that annotate the objects. For example, using the Gene
Ontology, the Saccharomyces Cerevisiae CDC55 gene has a biological
process described as “protein biosynthesis”, to which GO has assigned
the number 6412 (a GO ID).

GO 8150 biological_process


	GO 7582 physiological processes
	GO 8152 metabolism
	GO 44238 primary metabolism
	GO 19538 protein metabolism
	GO 6412 protein biosynthesis



















Graphical View of GO Term 6412: protein biosynthesis

[image: ontology_dag1.png]

Cytoscape can use this ontology DAG (Directed Acyclic Graph) to annotate
objects in networks. The Ontology Server (originally called
“BioDataServer (http://www.ncbi.nlm.nih.gov/pubmed/12066840)”)
is a Cytoscape feature which allows you to load, navigate, and assign
annotation terms to nodes and edges in a network. Cytoscape 2.4 now has
an enhanced GUI for loading ontology and associated annotation, enabling
you to load both local and remote files.

 


9.1. Ontology and Annotation File Format

The standard file formats used in the Cytoscape Ontology Server are
OBO and Gene Association. The GO website details these file formats:

Ontologies and Definitions:
http://www.geneontology.org/GO.downloads.shtml#ont

Current Annotations:
http://www.geneontology.org/GO.current.annotations.shtml

 




9.2. Default List of Ontologies

Cytoscape provides a list of ontologies available in OBO format. If an
Internet connection is available, Cytoscape will import ontology and
annotation files directly from the remote source. The table below lists
the included ontologies.


Default List of Ontologies
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10. Column Data Functions and Equations

 


10.1. Column Formulas

 


Introduction

Column data values may be formulas. A typical example is
=ABS($otherColumn + LOG(10.2)). Formulas are modeled after
Excel(tm) but only support references to other columns at the same node,
edge or network. Since Cytoscape column names may contain embedded
spaces, optional braces around the column name (required if the name is
not simply a letter followed by one or more letters or digits) is
allowed e.g. ${a name with spaces}. Backslashes, opening braces and
dollar signs in column names have to be escaped with a leading
backslash. For example the column name ex$am{p\le would have to be
written as ${ex\$am\{p\\le}. Finally, column names are case
sensitive.

String constants are written with double-quotes “. In order to embed
a double-quote or a backslash in a string they have to be escaped with a
leading backslash, therefore the string “\ must be written as
“\“\\“. Formula results must be compatible with the type of the
column that they have been assigned to. The rules are rather lax though,
for example anything can be interpreted as a string and all numeric
values will be accepted for a boolean (or logical) column data where
non-zero will be interpreted as true and zero as false. For
integer columns, floating point values will be converted using the rules
of the Excel(tm) INT function. Parentheses can be used for grouping
and to change evaluation order. The operator precedence rules follow
those of standard arithmetic.

 




Operators

Currently supported operators are the four basic arithmetic operators
and the ^ exponentiation operator. +, -, *, and
\ are left-associative and ^ is right-associative. The string
concatenation operator is &. Supported boolean or logical operators
are the comparison operators <, >, <=, >=,
=, and <> (not equal).

 




Supported Functions

Currently we support the following functions:


Cytoscape-specific functions


	Degree – the degree of a node.

	InDegree – the indegree of a node.

	OutDegree – the outdegree of a node.

	SourceID – the ID of the source node of an edge.

	TargetID – the ID of the target of an edge.






Numeric Functions


	Abs – Returns the absolute value of a number.

	ACos – Returns the arccosine of a number.

	ASin – Returns the arcsine of a number.

	ATan2 – Returns the arctangent of two numbers x and y.

	Average – Returns the average of a group of numbers.

	Cos – Returns the cosine of an angle given in radians.

	Cosh – Returns the hyperbolic sine of its argument.

	Count – Returns the number of numeric values in a list.

	Degrees – Returns its argument converted from radians to degrees.

	Exp – Returns e raised to a specified number.

	Ln – Returns the natural logarithm of a number.

	Log – Returns the logarithm of a number to a specified base.

	Max – Returns the maximum of a group of numbers.

	Median – Returns the median of a list of numbers.

	Min – Returns the minimum of a group of numbers.

	Mod – Calculates the modulus of a number.

	Pi – Returns an approximation of the value of p.

	Radians – Returns its argument converted from degrees to radians.

	Round – Rounds a number to a specified number of decimal places.

	Sin – Returns the sine of an angle given in radians.

	Sinh – Returns the hyperbolic sine of its argument.

	Sqrt – Calculates the square root of a number.

	Tan – returns the tangent of its argument in radians.

	Tanh – returns the hyperbolic tangent of its argument in radians.

	Trunc – Truncates a number.






String Functions


	Concatenate – Concatenates two or more pieces of text.

	Left – Returns a prefix of s string.

	Len – Returns the length of a string.

	Lower – Converts a string to lowercase.

	Mid – Selects a substring of some text.

	Right – Returns a suffix of a string.

	Substitute – Replaces some text with other text.

	Text – Format a number using the Java DecimalFormat
class’ conventions.

	Upper – Converts a string to uppercase.

	Value – Converts a string to a number.






Logical/Boolean Functions


	And – Returns the logical conjunction of any number of
boolean values.

	Not – Returns the logical negation of a boolean value.

	Or – Returns the logical disjunction of any number of
boolean values.






List Functions


	First – Returns the first entry in a list.

	Last – Returns the last entry in a list.

	Nth – Returns the n-th entry in a list.






Statistical Functions


	Largest – the kth largest value in a list.

	GeoMean – the geometric mean of a set of numbers.

	HarMean – the harmonic mean of a set of numbers.

	Mode – the mode of a set of numbers.

	NormDist – Returns the pdf or CDF of the normal distribution.

	Permut – Returns the number of permutations for a given number
of objects.

	StDev - sample standard deviation.

	Var – sample variance.






Miscellaneous Functions


	Combin - Returns the number of combinations for a given number
of objects.

	If – Returns one of two alternatives based on a boolean value.

	ListToString – Returns a string representation of a list.

	Now – Returns a string representation of the current date and time.

	Today – returns a string representation of the current date.



 






Pitfalls

The possibly biggest problem is the referencing of other columns that
have null values. This is not allowed and leads to errors. In order to
mitigate this problem we support the following optional syntax for
column references: ${columnName:defaultValue}. The interpretation
is that if columnName is null, then the default value will be used,
otherwise the value of the referenced value will be used instead. The
referenced column must still be a defined column and not an arbitrary
name! The other potential problem is when there are circular column
reference dependencies. Circular dependencies will be detected at
formula evaluation time and lead to a run-time error.

 




Useful Tips

When working with formulas it can be very helpful to open the
Developer’s Log Console. Formula evaluation errors will be logged there.

 






10.2. The Formula Builder

In order to ease the creation of formulas as well as to facilitate
discovery of built-in functions we provide a Function Builder in the
Table Panel. After selecting a non-list column cell, you can invoke it
by clicking on
[image: fx-button.png].
This should bring up the Function Builder which looks like this:

[image: FunctionBuilder2.png]

Select a function on the left hand side of the dialog - here, we’ve
selected the ABS function. Next to the list of functions, you can
specify one or more arguments. This can either be a column (selected
from the drop-down list) or a constant specified in the box below. If
you select a column, the value of that column (in the row containing the
formula) will be used, and the function result will be updated
dynamically when that value changes. Click Add to add an argument -
you can add one or more depending on how many arguments the function
accepts. At the bottom of the dialog is a preview of the current
formula. Under Apply to, you can select whether the formula will
apply to the current cell only, the cell selection, or the entire
column. Click OK when you are satisfied with the result, or Cancel to
discard any changes.

The Function Builder is a useful tool for discovery of the list of
built-in functions, which has the return type matching the data type of
the column. Arguments can either be selected from a list of named
columns, or constant values can be entered in a text entry field. A
major shortcoming at this time is that the Formula Builder won’t let you
compose functions with function calls as arguments. If you need the most
general functionality, please type the expression directly into a cell.

 




10.3. A Note for App Writers

It is relatively easy to add your own built-in formula functions. A
simple function can probably be implemented in 15 to 20 minutes. It can
then be registered via the parser and becomes immediately available to
the user. It will of course also show up in the drop-down list in the
Function Builder.
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11. Finding and Filtering Nodes and Edges

 


11.1. Search Bar

You can search for nodes and edges by column value directly through
Cytoscape’s tool bar. For example, to select nodes or edges with a
column value that starts with “STE”, type ste* in the search bar. The
search is case-insensitive. The * is a wildcard character that matches
zero or more characters, while ”?” matches exactly one character. So
ste? would match “STE2” but would not match “STE12”. Searching for
ste* would match both.

[image: searchbar2.png]

To search a specific column, you can prefix your search term with the
column name followed by a :. For example, to select nodes and edges
that have a “COMMON” column value that starts with “STE”, use
common:ste*. If you don’t specify a particular column, all columns
will be searched.

Columns with names that contain spaces, quotes, or characters other than
letters and numbers currently do not work when searching a specific
column. This will be fixed in a future release.

To search for column values that contain special characters you need to
escape those characters using a “\”. For example, to search for
“GO:1232”, use the query GO\:1232. The complete list of special
characters is:

+ - & | ! ( ) { } [ ] ^ " ~ * ? : \





Note: Escaping characters only works when searching all columns. It
currently does not work for column-specific searching. This will be
fixed in a future release.

 




11.2. Filters

Cytoscape 3 provides a new user interface for filtering nodes and edges.
These tools can be found in the Select panel:

[image: select-panel.png]

There are two types of filters. On the Filter tab are narrowing
filters, which can be combined into a tree. On the Chain tab are
chainable filters, which can be combined in a linear chain.

 


Narrowing Filters

Narrowing filters are applied to the entire network, and are used to
select a subset of nodes or edges in a network based on user-specified
constraints. For example, you can find edges with a weight between 0 and
5.5, or nodes with degree less than 3. A filter can contain an arbitrary
number of sub-filters.

To add a filter click on the “+” button. To delete a filter (and all its
sub-filters) click the “x” button. To move a filter grab the handle
[image: filterhandle.png]
with the mouse and drag and drop the filter on its intended destination.
Dropping a filter on top of another filter will group the filters into a
composite filter.

 


Interactive Filter Application Mode

Due to the nature of narrowing filters, Cytoscape can apply them to a
network efficiently and interactively. Some filters even provide slider
controls to quickly explore different thresholds. This is the default
behavior on smaller networks. For larger networks, Cytoscape
automatically disables this interactivity. You can override this by
manually checking the Apply when filter changes box above the Apply
button:

[image: apply-automatically.png]

Cytoscape comes packaged with the following narrowing filters:

 




Column Filter

This filter will match nodes or edges that have particular column
values. For numeric columns sliders are provided to set minimum and
maximum values, or the values may be entered manually.

From string columns, a variety of matching options are provided:

[image: string-column.png]

For example, column values can be checked to see if they contain or
match exactly the text entered in the text box. More complex matching
criteria can be specified by using a Java-style regular expression.

By default string matching is case insensitive. Case sensitive matching
requires the use of a regular expression that starts with “(?-i)”. For
example to match the text “ABC” in a case sensitive way use the
following regular expression: “(?-i)ABC”.

Cytoscape uses Java regular expression
syntax [https://docs.oracle.com/javase/8/docs/api/java/util/regex/Pattern.html].

 




Degree Filter

The degree filter matches nodes with a degree that falls within the
given minimum and maximum values, inclusive. You can choose whether the
filter operates on the in-degree, out-degree or overall (in + out)
degree.

 




Topology Filter

The topology filter matches nodes having a certain number of neighbors
which are within a fixed distance away, and which match a sub-filter.
The thresholds for the neighborhood size and distance can be set
independently, and the sub-filter is applied to each such neighbor node.

The topology filter will successfully match a node if the sub-filter
matches against the required number of neighbor nodes.

 




Grouping and Organizing Filters

By default, nodes and edges need to satisfy the constraints of all your
filters. You can change this so that instead, only the constraints of at
least one filter needs to be met in order to match a node or edge. This
behavior is controlled by the Match all/any drop-down box. This
appears once your filter has more than one sub-filter. For example,
suppose you wanted to match nodes with column COMMON containing ste
or cdc, but you only want nodes with degree 5 or more, you’d first
construct a filter that looks like this:

[image: sample-group2.png]

This filter will match nodes where COMMON contains ste and
cdc. To change this to a logical or operation, drag either of the
column filters by its handle
[image: filterhandle.png]
onto the other column filter to create a new group. Now change the
group’s matching behavior to Match any:

[image: sample-group1.png]

You can also reorder filters by dropping them in-between existing
filters.

 






Chainable Filters

Chainable filters are combined in an ordered list. The nodes and edges
in the output of a filter become the input of the next filter in the
chain. The first filter in the chain gets its input from the current
selection or from a filter on the Filter tab. The output of the last
filter becomes the new selection.

You can specify the input to the first filter in the chain by selecting
a Start with, where Current selection refers to the nodes and
edges currently selected. You can also choose a narrowing filter, which
produces a different set of selected nodes and edges.

[image: ChainFilter1.png]

Chainable filters can be reordered by dragging one by the handle and
dropping it between existing filters.

Cytoscape currently bundles the following chainable filters:

 


Edge Interaction Transformer

This transformer will go through all the input edges and selectively add
their source nodes, target nodes, or both, to the output. This is useful
for adding nodes that are connected to edges that match a particular
filter.

Output options:


	Add (default): Automatically includes all input nodes and edges in
the output, and adds source or target nodes from input edges to
the output.

	Replace with: Does not automatically include input nodes and edges
in the output. Only outputs nodes that match the filter.



A sub-filter may be added as well. When a sub-filter is present the
source/target nodes must match the filter to be included in the output.

 




Node Adjacency Transformer

This transformer is used to add nodes and edges that are adjacent to the
input nodes. A sub-filter may be specified as well.

Note that pressing the Apply button repeatedly may cause the
selection to continuously expand. This allows adjacent nodes that are at
greater distances to be added.

Output options:


	Add (default): Automatically includes all input nodes and edges in
the output, and adds selected adjacent nodes and edges.

	Replace with: Only outputs the adjacent nodes/edges.



Select options:


	Adjacent nodes: Output nodes that are adjacent to the input nodes.

	Adjacent edges: Output edges that are adjacent (incident) to the
input nodes.

	Adjacent nodes and edges (default): Output both nodes and edges that
are adjacent to the input nodes.



Edge direction options. (Hidden by default, click the small arrow icon
to reveal.):


	Incoming: Only include adjacent nodes/edges when the adjacent edge
is incoming.

	Outgoing: Only include adjacent nodes/edges when the adjacent edge
is outgoing.

	Incoming and Outgoing (default): Ignore the directionality of
adjacent edges.



Sub-filter options. (Available when a sub-filter has been added.):


	Adjacent nodes (default): The sub-filter is only applied to
adjacent nodes. (Edges to the adjacent nodes are still included in
the output.)

	Adjacent edges: The sub-filter is only applied to adjacent edges.
(Nodes connected to the adjacent edges are still included in
the output.)

	Adjacent nodes and edges: Both the adjacent edge and its connected
node must match the filter. Note that for a filter to match an edge
and a node at the same time it should be a compound filter that is
set to “Match any (OR)”.



 






Working with Narrowing and Chainable Filters

The name of active filter appears in the drop-down box at the top of
Select panel. Beside this is the options button which will allow you
to rename, remove or export the active filter. It also lets you create a
new filter, or import filters.

[image: select-panel-options.png]

At the bottom of the Select panel, there is an Apply button that
will re-apply the active filter. On the opposite side of the progress
bar is the cancel button, which will let you interrupt a long-running
filter.

 






11.3. The Select Menu

The Select → Nodes and Select → Edges menus provide several
mechanisms for selecting nodes and edges. Most options are fairly
straightforward; however, some need extra explanation.

Select → Nodes → From ID List File... selects nodes based on node
identifiers found in a specified file. The file format is simply one
node id per line:

Node1
Node2
Node3
...
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12. Navigation and Layout

 


12.1. Basic Network Navigation

Cytoscape uses a Zoomable User
Interface [http://en.wikipedia.org/wiki/Zooming_User_Interface] for
navigating and viewing networks. ZUIs use two mechanisms for navigation:
zooming and panning. Zooming increases or decreases the magnification of
a view based on how much or how little a user wants to see. Panning
allows users to move the focus of a screen to different parts of a view.

 


Zoom

Cytoscape provides four mechanisms for zooming: toolbar buttons, menu options, keyboard shortcuts and the scroll wheel.

Use the zooming buttons located on the toolbar to zoom in
and out of the interaction network shown in the current network display.
Zoom icons are detailed below:

[image: image049.png]

From Left to Right:


	Zoom In

	Menu option: View → Zoom In

	Keyboard shortcut: Ctrl-Plus (Command-Plus on Mac OS X)




	Zoom Out

	Menu option: View → Zoom Out

	Keyboard shortcut: Ctrl-Minus (Command-Minus on Mac OS X)




	Zoom Out to Display all of Current Network

	Menu option: View → Fit Content

	Keyboard shortcut: Ctrl-0 (Command-0 on Mac OS X)




	Zoom Selected Region

	Menu option: View → Fit Selected

	Keyboard shortcut: Ctrl-9 (Command-9 on Mac OS X)



Using the scroll wheel, you can zoom in by scrolling up and zoom out by
scrolling downwards. These directions are reversed on Macs with natural
scrolling enabled (the default for Mac OS X Lion and newer versions).

 




Pan

There are two ways to pan the network:


	Left-Click and Drag - You can pan the network view by holding down the left mouse button and moving the mouse.

	Dragging Box on Network
Overview -
You can also pan the view by left-clicking and dragging the blue box in the overview panel in the lower part of the view.



 






12.2. Other Mouse Behaviors

 


Select


	Click the left mouse button on a node or edge to select that element.

	Hold down the Shift or Ctrl key (Command on Macs) and left-click a node or edge to add it to the selection. Doing the same on a selected element unselects it.

	Hold down the left mouse button on the canvas background and drag the mouse while holding down the Shift or Ctrl key (Command on Macs) to select groups of nodes/edges.



 




Context

Click the right mouse button (or Ctrl+left mouse button on Macs) on a
node/edge to launch a context-sensitive menu with additional information
about the node/edge.

 




Node Context Menu

This menu can change based on the current context. For nodes, it
typically shows:


	Add

	Edit

	Select

	Group

	Nested Networks

	Apps

	External Links

	Preferences



Edges usually have the following menu:


	Edit

	Select

	Apps

	External Links

	Preferences



Apps can contribute their own items into node and edge context menus.
These additions usually appear in the Apps section of the context
menu.

 


Nested Network Node Context Menu


	Add Nested Network: Lets the user select any network in
Cytoscape as the current node’s nested network. If the current node
already has a nested network it will be replaced.

	Remove Nested Network: Removes the currently associated nested
network from a node. The associated network is not deleted. Only the
association between the node and the network is removed.

	Go to Nested Network: The current node’s nested network will be
the current network view and have the focus. Should a network view
for the nested network not exist, it will be created.



More information about nested networks can be found in the Nested
Networks
section.

 








12.3. Automatic Layout Algorithms

The Layout menu has an array of features for organizing the network
visually according to one of several algorithms, aligning and rotating
groups of nodes, and adjusting the size of the network. Cytoscape
layouts have three different sources, which are reflected in the
Layout menu.

With the exception of the yFiles layouts (explained below),
Cytoscape Layouts have the option to operate on only the selected nodes,
and all provide a Settings... panel to change the parameters of the
algorithm. Most of the Cytoscape layouts also partition the graph before
performing the layout. In addition, many of these layouts include the
option to take either node or edge columns into account. A few of the
layout algorithms are:

 


Grid Layout

[image: grid_layout.png]

The grid layout is a simple layout the arranges all of the nodes in a
square grid. This is the default layout and is always available as part
of the Cytoscape core. It is available by selecting Layout → Grid
Layout. A sample screen shot is shown above.

 




Edge-weighted Spring-Embedded Layout

[image: spring.png]

The spring-embedded layout is based on a “force-directed” paradigm as
implemented by Kamada and Kawai (1988). Network nodes are treated like
physical objects that repel each other, such as electrons. The
connections between nodes are treated like metal springs attached to the
pair of nodes. These springs repel or attract their end points according
to a force function. The layout algorithm sets the positions of the
nodes in a way that minimizes the sum of forces in the network. This
algorithm can be applied to the entire network or a portion of it by
selecting the appropriate options from Layout → Edge-weighted Spring
Embedded.

 




Attribute Circle Layout

[image: attribute_circle_layout.png]

The Attribute Circle layout is a quick, useful layout, particularly
for small networks, that will locate all of the nodes in the network
around a circle. The node order is determined by a user-selected node
column. The result is that all nodes with the same value for that column
are located together around the circle. Using Layout → Attribute
Circle Layout → column to put all nodes around a circle using
column to position them. The sample screen shot above shows the a
subset of the galFiltered network organized by node degree.

 




Group Attributes Layout

[image: group_by_attributes_layout.png]

The Group Attributes layout is similar to the Attribute Circle
layout described above except that instead of a single circle with all
of the nodes, each set of nodes that share the same value for the column
are laid out in a separate circle. The same network shown above (network
generated by PSICQUIC Client) is shown above, using Layout → Group
Attributes Layout → taxonomy.

 




Prefuse Force Directed Layout

[image: force_layout.png]

The force-directed layout is a layout based on the “force-directed”
paradigm. This layout is based on the algorithm implemented as part of
the prefuse toolkit (http://www.prefuse.org/) provided by Jeff Heer.
The algorithm is very fast and with the right parameters can provide a
very visually pleasing layout. The Force Directed Layout will also
accept a numeric edge column to use as a weight for the length of the
spring, although this will often require more use of the Settings...
dialog to achieve the best layout. This algorithm is available by
selecting Layout → Prefuse Force-Directed Layout → (unweighted) or
the edge column you want to use as a weight. A sample screen shot
showing a portion of the galFiltered network provided in sample data is
provided above.

 




Compound Spring Embedder Layout

[image: cose_layout.png]

The Compound Spring Embedder (CoSE) [http://www.sciencedirect.com/science/article/pii/S0020025508004799]
layout is based on the traditional force-directed
layout algorithm with extensions to handle multi-level nesting (compound nodes),
edges between nodes of arbitrary nesting levels and varying node sizes.
It is the suggested Cytoscape layout for compound graphs,
although it also works very well with noncompound graphs.
It is available by selecting Layout → Compound Spring Embedder (CoSE).

 






12.4. yFiles Layouts

yFiles layouts are a set of commercial layout algorithms which are
provided courtesy of yWorks (http://www.yworks.com). Due to license
restrictions, the detailed parameters for these layouts are not
available (there are no yFiles entries in the Layout →
Settings...). The main layout algorithms provided by yFiles are:

 


yFiles Organic Layout

[image: yOrganic.png]

The organic layout algorithm is a kind of spring-embedded algorithm that
combines elements of the other algorithms to show the clustered
structure of a graph. This algorithm is available by selecting Layout
→ yFiles Layouts → Organic.

 




yFiles Circular Layout

[image: yCircular.png]

This algorithm produces layouts that emphasize group and tree structures
within a network. It partitions the network by analyzing its
connectivity structure, and arranges the partitions as separate circles.
The circles themselves are arranged in a radial tree layout fashion.
This algorithm is available by selecting Layout → yFiles Layouts →
Circular.

 




yFiles Hierarchical Layout

[image: yHir.png]

The hierarchical layout algorithm is good for representing main
direction or “flow” within a network. Nodes are placed in hierarchically
arranged layers and the ordering of the nodes within each layer is
chosen in such a way that minimizes the number of edge crossings. This
algorithm is available by selecting Layout → yFiles Layouts →
Hierarchical.

 






12.5. Layout Parameters

Many layouts have adjustable parameters that are exposed through the
Layouts → Settings... menu option. The Layout Settings dialog,
which allows you to choose which layout algorithm settings to adjust, is
shown below. The settings presented vary by algorithm and only those
algorithms that allow access to their parameters will appear in the
drop-down menu at the top of the dialog. Once you’ve modified a
parameter, clicking the Execute Layout button will apply the layout.

[image: layout_settings_dialog.png]

 




12.6. Edge Bend and Automatic Edge Bundling

From Cytoscape 3.0, Edge Bend is a regular edge property and can be
used as a part of a Style. Just like any other edge property, you
can select a Default Value, a Mapping and use Bypass for select nodes.
In the Styles tab, select the Bend property from the Properties
drop-down and click on either the Default Value, Mapping or Bypass cell
to bring up the Edge Bend Editor. In the editor, you can add as many
handles as you want to the edge using Alt-Click on Windows, Option-Click
on Mac, or Ctrl-Alt-Click on Linux.

[image: edbeBend1.png]

[image: bundle1.png]

To clear all edge bends, select Layout → Clear All Edge Bends.

In addition to adding handles manually, you can use the Bundle Edges
function to bundle all or selected edges automatically.

[image: bundle2.png]


	Select Layout → Bundle Edges → All Nodes and Edges.

	Set parameters.
	Details of the algorithm is described in this
paper (http://www.win.tue.nl/~dholten/papers/forcebundles_eurovis.pdf).





	Press OK to run. Edge bundling may take a long time if the number of
edges is large.
	If it takes too long, try decreasing Maximum Iterations.

	For large, dense networks, try setting Maximum iterations in
the range of 500 - 1000.







Note: The handle locations will be optimized for current location of
nodes. If you move node positions, you need to run the function again to
get proper result.

 




12.7. Manual Layout

The simplest method to manually organize a network is to click on a node
and drag it. All of the selected nodes are moved together.

In addition to the ability to click on a node and drag it to a new
position, Cytoscape now has the ability to move nodes using the arrow
keys on the keyboard. By selecting one or more nodes using the mouse and
clicking one of the arrow keys (←, ↑, →, ↓) the selected nodes will move
one pixel in the chosen direction. If an arrow key is pressed while
holding the Shift key down, the selected nodes will move 15 pixels in the
chosen direction.

 




12.8. Node Layout Tools

The Tool Panel is available via the menu command:  View → Show Tool Panel.

It contains several Node Layout Tools that can help to automate or fine tune a layout.

 


Scale

Adjust the Scale slider to change the length of edges.  The position of the nodes will be scaled, not the node sizes.
Node size can be adjusted using
Styles.
The images below show selected (yellow) nodes scaled to 50% of the default value.

Before
[image: scale_networkA.png]

After
[image: scale_networkB.png]
 




Rotate

The Rotate function will change the orientation of the entire
network or a selected portion of the network. The images below show a
network with selected nodes rotated 90 degrees.

Before
[image: rotate_networkA.png]

After
[image: rotate_networkB.png]

 




Align, Distribute and Stack

The Tool Panel contains buttons to set relative postions of nodes.

Align provides
different options for either vertically or horizontally aligning
selected nodes against a line. The differences are in what part of the
node gets aligned, e.g. the center of the node, the top of the node, the
left side of the node. Distribute evenly distributes selected nodes
between the two most distant nodes along either the vertical or
horizontal axis. The differences are again a function what part of the
node is used as a reference point for the distribution. Stack
vertically or horizontally stacks selected nodes with the full
complement of alignment options. The table below provides a description
of what each button does.


Align Options
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13. Styles

 


13.1. What are Styles?

One of Cytoscape’s strengths in network visualization is the ability to
allow users to encode any table data (name, type, degree, weight,
expression data, etc.) as a property (such as color, size of node,
transparency, or font type) of the network. A set of these encoded or
mapped table data sets is called a Style and can be created or
edited in the Style panel of the Control Panel. In this
interface, the appearance of your network is easily customized. For
example, you can:

Specify a default color and shape for all nodes.

[image: NodeShape.png]

Set node sizes based on the degree of connectivity of the nodes. You
can visually see the hub of a network...

[image: DegreeSize.png]

...or, set the font size of the node labels instead.

[image: DegreeLabelSize.png]

Visualize gene expression data along a color gradient.

[image: ColorGradient.png]

Encode specific physical entities as different node shapes.

[image: NodeShapeMapping.png]

Use specific line types to indicate different types of interactions.

[image: edge_types.png]

Control edge transparency (opacity) using edge weights.

[image: OpacityForEdges.png]

Control multiple edge properties using edge score.

[image: MultipleEdgeMapping.png]

Browse extremely-dense networks by controlling the opacity of nodes.

[image: OpacityForNodesAndEdges.png]

Show highly-connected region by edge bundling and opacity.

[image: Bundling.png]

Add photo/image/graphics on top of nodes.

[image: CustomGraphics1.png]
[image: CustomGraphics4.png]
[image: CustomGraphics5.png]

Cytoscape 3 has several sample styles. Below are a few examples of these
applied to the galFiltered.sif network :

[image: default_style.png]
[image: solid_style.png]
[image: ripple_style.png]
[image: universe_style.png]

 




13.2. Introduction to the Style Interface

The Style interface is located under the Style panel of the
Control Panel.

[image: StylesInterface.png]

This interface allows you to create/delete/view/switch between different
styles using the Current Style options. The panel displays the mapping
details for a given style and is used to edit these details as well.


	At the top of the interface, there is a drop-down menu for selecting
a pre-defined style. There is also an Options drop-down with
options to rename, remove, create and copy a Style, and an option to
create a legend for the selected Style.

	The main area of the interface is composed of three tabs, for Node,
Edge and Network.

	Each tab contains a list of properties relevant to the
current style. At the top of the list a Properties drop-down
allows you to add additional properties to the list.

	Each property entry in the list has 3 columns:
	The Default Value shows just that, the default value for
the property. Clicking on the Default Value column for any
property allows you to change the default value.

	Mapping displays the type of mapping currently in use for
the property. Clicking on the Mapping column for any
property expands the property entry to show the interface for
editing the mapping. Details on the mapping types provided
here.

	Bypass displays any style bypass for a selected node
or edge. Note that a node/edge or subset of nodes/edges must be
selected to activate the Bypass column. Clicking on the
Bypass column for selected node(s)/edge(s) allows you to
enter a bypass for that property for selected node(s)/edge(s).







The Default Value is used when no mapping is defined for a property,
or for nodes/edges not covered by a mapping for a particular property.
If a Mapping is defined for a property, this defines the style for
all or a subset of nodes/edges, depending on how the mapping is defined.
A Bypass on a specific set of nodes/edges will bypass and override
both the default value and defined mapping.

 




13.3. Introduction to Style

The Cytoscape distribution includes several predefined styles to get you
started. To examine a few styles, try out the following example:

Step 1. Load some sample data


	Load a sample session file: From the main menu, select File
→ Open..., and select the file sampleData/galFiltered.cys.

	The session file includes a network, some annotations, and
sample styles. By default, the style galFiltered Style
is selected. Gene expression values for each node are colored along
a color gradient between blue and yellow (where blue represents a
low expression ratio and yellow represents a high expression ratio,
using thresholds set for the gal1RGexp experiment bundled with
Cytoscape in the sampleData/galExpData.csv file). Also, node size
is mapped to the degree of the node (number of edges connected to
the node) and you can see the hubs of the network as larger nodes.
See the sample screenshot below:



[image: galFilteredSessionDefault.png]

Step 2. Switch between different styles

You can change the style by making a selection from the Current
Style drop-down list, found at the top of the Style panel.

For example, if you select Sample1, a new style will be applied to
your network, and you will see a white background and round blue nodes.
If you zoom in closer, you can see that protein-DNA interactions
(specified with the label “pd”) are drawn with dashed edges, whereas
protein-protein interactions (specified with the label “pp”) are drawn
with solid edges (see sample screenshot below).

[image: VizMapperSample1Style26.png]

Finally, if you select Solid, you can see the graphics below:

[image: VizMapperSolidStyle.png]

This style does not have mappings except node/edge labels, but you can
modify the network graphics by editing the Default Value for any
property.

Additional sample styles are available in the sampleStyles.xml file in
the sampleData directory. You can import the sample file from File →
Import → Styles....

 


List of Node, Edge and Network Properties

Cytoscape allows a wide variety of properties to be controlled. These
are summarized in the tables below.
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    14. App Manager
    
    

    

    

    
 
  
  

    
      
          
            
   


14. App Manager

 


14.1. What are Apps?

Cytoscape’s capabilities are not fixed. They can be expanded with
apps. They can extend Cytoscape in a variety of ways. One app can
have the ability to import data from an online database. Another app
could provide a new method for analyzing networks. You can install apps
after you have installed Cytoscape. Most apps were made by Cytoscape
users like you.

If you’re familiar with Cytoscape 2.x, you probably know that Cytoscape
apps were called plugins. Starting in Cytoscape 3.0, we are calling
them apps. Cytoscape 2.x plugins cannot be used in Cytoscape 3.0.

 




14.2. Installing Apps

You can install apps through the App Store [http://apps.cytoscape.org]
or within Cytoscape. In this section, we’ll talk about installing apps
through Cytoscape. You can learn how to install apps through the App
Store here [http://apps.cytoscape.org/help/getstarted_app_install].

To install apps within Cytoscape, go to the menu bar and choose Apps →
App Manager.... At the top of the App Manager window, make sure you
have the Install Apps tab selected.

[image: AppManager]

There are four ways you can find apps:


	If you know the name of an app you’re looking for, enter it in the
Search field. The App Manager will list the apps whose names or
descriptions match the Search field in the middle panel.

	If you’re not sure what sort of app you need and want to see everything,
click the all apps folder. In the middle pane, you will see a
list of all the apps.

	If you want to install a collection of apps for a specific use case,
click on the collections folder. This will display the available
collections in the middle pane. A collection is simply an app that
installs other apps for a specific use case.

	If you have a general idea of what sort of app you’re looking for,
double-click on the apps by tag folder, then click on one of the
tags that interests you. The apps with that tag are listed in the
middle pane.



When you click on an app (or collection) in the middle panel, the
App Manager shows its short description and icon in the right panel.
If you want more information, click the View on App Store
button on the bottom-right. If you want to go ahead and install,
click the Install button.

If you’ve downloaded an app to your computer, you can install it by
clicking the Install from File button on the bottom-left.

 




14.3. Managing your Installed Apps

You can see a list of all apps you have installed by clicking the
Currently Installed tab at the top. When you click on an app in the
list, you’ll see a description of your app at the bottom. At the bottom,
you’ll see a couple buttons where you can:


	Uninstall an app. This deletes the app from your computer. If
you want to reinstall the app, you will have to find it again in the
Install Apps tab or find it in the App Store site and
reinstall it from there.

	Disable an app. This temporarily disables the app. The app stays
on your computer, but Cytoscape does not load it. You can enable the
app by first selecting the disabled app in the list, then click
Enable.



Note that uninstalling or disabling a collection will not uninstall or disable any apps installed by the collection.
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15. Command Tool

The Command Line Tool provides a simple command-line interface to
Cytoscape using the Commands API. Any app that registers commands will
be available through the Command Tool. The Command Tool provides two
main functions: first, a Command Line Dialog is available from Tools →
Command Line Dialog, that allows the user to type commands into
Cytoscape and see the results in a “Reply Log”.

[image: CommandTool.png]

Second, and arguably more useful, it will read script files and execute
them. Each line in the script file is a command that is sent to a app.
Script files may be entered on the Cytoscape command line using the “-S”
flag to Cytoscape, through the File → Run Script File... menu item,
or through Tools → Execute Command File.

[image: RunScriptCommands.png]

Cytoscape commands consist of three parts: a command class, or
namespace; a command within that namespace; and a series of arguments or
options provided as a series of name=value pairs. For example, to
import an XGMML format file from the Command Line Dialog or a
command script, you would use:

network import file filePath="path-to-file"





where network is the namespace, import file is the command, and
there is only one argument: filePath=”path-to-file”. If there were
more arguments they would appear on the same line separated by spaces.

The Command Tool also uses the Command API to provide help. “help” by
itself will list all of the command classes (or namespaces) and “help “
followed by a namespace will list all of the commands supported by that
namespace. Details of a specific command are available by typing “help “
followed by the namespace and command (e.g. “help layout
force-directed”). The Command Tool registers the “command” namespace and
supports a single command: run, which takes a file argument. Here is the
help for the command run command from the command namespace:

help command run
       command run file=<File> 





Similarly, the help for the “network import file” example from above is:

help network import file
 network import file arguments:
 dataTypeList=<String>: List of column data types ordered by column index 
   (e.g. "string,int,long,double,boolean,intlist" or just "s,i,l,d,b,il")
 defaultInteraction=<String>: Default interaction type
 delimiters=<ListMultipleSelection [,,;, ,\t]>: Text Delimiters
 delimitersForDataList=<ListSingleSelection (\||\|/|,)>: 
   Text Delimiters for data list type
 file=<File>: Data Table file
 firstRowAsColumnNames=true|false: First row used for column names
 indexColumnSourceInteraction=<int>: Column for source interaction
 indexColumnTargetInteraction=<int>: Column for target interaction
 indexColumnTypeInteraction=<int>: Column for interaction type
 NetworkViewRendererList=<ListSingleSelection ()>: Network View Renderer
 RootNetworkList=<ListSingleSelection (-- Create new network collection 
   --|Network)>: Network Collection
 startLoadRow=<int>: Start Load Row
 TargetColumnList=<ListSingleSelection ()>: Node Identifier Mapping Column
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16. Merge

Cytoscape allows for merging of both network and table data, through
Tools → Merge.

 


16.1. Merge Networks

The Advanced Network Merge interface is available from Tools →
Merge → Networks... and allows for merging of two or more networks.

[image: Advanced NetworkMerge]

 


Basic Operations


	With the buttons select either “union”, “intersection”
or “difference”.

	Networks available for merge are listed under Networks to merge.
Select a network from the list and click the right arrow to transfer
the network to Selected networks. Click Merge to continue.
The merged network will be displayed as a separate network.



 




Advanced Options

The Advanced Network Merge interface includes an expandable
Advanced Network Merge panel, where you can specify the details of
how to merge the networks. The options available here are:


	Matching columns: This specifies the network columns that should
be used for merging. Typically, the “name” column or some other
column containing identifier information is used here.

	How to merge columns?: A table lets the user specify for each of
the individual network columns, what the corresponding column in the
merged network should be named and its data type.



[image: Advanced Network Merge Options]

 






16.2. Merge Tables
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17. NetworkAnalyzer

NetworkAnalyzer computes a comprehensive set of topological parameters
for undirected and directed networks, including:


	Number of nodes, edges and connected components.

	Network diameter, radius and clustering coefficient, as well as the
characteristic path length.

	Charts for topological coefficients, betweenness, and closeness.

	Distributions of degrees, neighborhood connectiveness, average
clustering coefficients, shortest path lengths, number of shared
neighbors and stress centrality.



NetworkAnalyzer also constructs the intersection, union and difference
of two networks. It supports the extraction of connected components as
separate networks and the removal of self-loops.

 


17.1. Network Analysis

 


Analyze Network

To run NetworkAnalyzer, select Tools → NetworkAnalyzer → Network
Analysis → Analyze Network.

[image: NetworkAnalyzer.png]

The NetworkAnalyzer will determine whether your network contains
directed or undirected edges. At this point, you can choose to ignore
edge direction information.

When results are calculated, they will appear in the Results Panel.

[image: NetworkAnalyzerResults.png]

The results have multiple tabs. Details on the network parameters can be
found
here [http://med.bioinf.mpi-inf.mpg.de/netanalyzer/help/2.7/index.html#complex].


	Simple Parameters

	Node Degree Distribution

	Avg. Clustering Coefficient Distribution

	Topological Coefficients

	Shortest Path Distribution

	Shared Neighbors Distribution

	Neighborhood Connectivity Distribution

	Betweenness Centrality

	Closeness Centrality

	Stress Centrality Distribution



You can also save the statistics for later use by using the Save
Statistics button.

 




Analyze Subset of Nodes

An exhaustive topological analysis of very large networks can be a time
consuming task. The computation of local parameters for the nodes is
significantly faster than the computation of global (path-related)
parameters. Examples of local parameters are node degree, neighborhood
connectivity, topological and clustering coefficients. Betweenness and
closeness centralities, as well as stress, are global parameters.

NetworkAnalyzer
provides the Analyze Subset of Nodes option for computing local
parameters for a subset of nodes. If one or more nodes in the network
are selected before starting an analysis, only the sub-network induced
by the selected nodes is analyzed. Moreover, only local parameters are
computed. Shared neighbors distribution and shortest path lengths
distribution, among others, are not displayed in the results.

 




Batch Analysis

The Batch Analysis option is used to perform topological analysis on
all networks stored in specific directory, using all possible
interpretations for every network. Batch analysis consists of three
simple steps:


	Selecting directories: The user selects the input and
output directories. The input directory should contain network files
that can be loaded into Cytoscape. Sub-directories of the input
directory are not considered. The output directory is the one that
will contain all analysis results after the batch analysis. In order
to avoid file overwriting, NetworkAnalyzer requires that the output
directory is empty (contains no files) before the batch
analysis starts.

	Analysis: NetworkAnalyzer scans the input directory and loads
all supported networks into Cytoscape, one at a time. Each loaded
network is inspected and then it is analyzed considering all
possible interpretations for it. The analysis step is complete after
all networks are analyzed. Note that depending on the number of
networks and their sizes, this might be a very time-consuming step.

	Inspection of results: After the analysis is complete, the
button Show Results is enabled, and it displays the
results dialog. The dialog contains a table of all topological
analyses performed. Every row in the results table lists the loaded
network, its interpretation and the resulting network statistics
file that was saved in the output directory. By clicking on a
network name and on statistics file name, the user can load the
network and topology analysis results, respectively.



 




Load Network Statistics

Existing network statistics can be loaded from a file saved previously
in
NetworkAnalyzer.

 




Plot Parameters

The Plot Parameters dialog offers a possibility to plot two
parameters against each other. The parameters to be plotted can be
chosen from two drop-down menus. The Table Column 1 menu provides
the values for the domain/category axis, and the Table Column 2 menu
specifies the values for the range/value axis. The plot is updated each
time a different parameter is selected in one of the menus.

 




Generate Style from Statistics

NetworkAnalyzer computed parameters can be visualized as node/edge size
and color, if the Store node / edge parameters in node / edge table
option in NetworkAnalyzer Settings is enabled. Parameters loaded
from a .netstats file cannot be visualized because the network itself is
not stored in the network statistics file. If, after performing
topological analysis, the network is modified by introducing or removing
nodes or edges, it is recommended (and sometimes required) to run
NetworkAnalyzer again before visualizing any parameters.

The visualization is initiated by the Generate Style from
Statistics... menu option. There are two ways of mapping computed
parameters.


	Map to node / edge size: The computed parameter is mapped to the
size of the nodes or edges. Mapping can be straight or inverse, that
is, low parameter values can be mapped to small sizes or to
large sizes. The smallest node size is set to 10 and the largest one
to 100. Regarding edges, size reflects the edge line width and
varies between 1 and 8. Refer to the
Styles
section for details.

	Map to node / edge color: A computed parameter is mapped to the
color of the nodes or edges. Two mapping styles are possible -
mapping low parameter values to bright colors or to dark colors. By
default, the brightest color is green and the darkest color is red.
The mapping also uses a middle (intermediate) color, which allows
for fine-grained perception of differing values through the
color gradient. The default middle color is yellow.



[image: NetworkAnalyzer_VisualizeParameters.png]

 




NetworkAnalyzer Settings

The following settings can be configured by the user:


	Store node / edge parameters in node / edge table: For every
node in a network, NetworkAnalyzer computes its degree (in- and
out-degrees for directed networks), its clustering coefficient, the
number of self-loops, and a variety of other parameters.
NetworkAnalyzer also computes edge betweenness for each edge in
the network. If the respective options are enabled, NetworkAnalyzer
can stores the computed values as columns of the corresponding nodes
and edges. This enables the users to use the values in Styles or to
select nodes or edges based on the values. A complete list of the
computed node and edge columns is available
here [http://med.bioinf.mpi-inf.mpg.de/netanalyzer/help/2.7/index.html#attributes].

	Use expandable dialog interface for the display of network
statistics: If this option is enabled, analysis results are
presented in a window in which all charts are placed below each
other in expandable boxes. If this option is disabled, analysis
results are presented in a window that contains tabs for the group
of simple parameters and for every complex parameter (default).
Users who wish to simultaneously view two or more complex parameters
of one network, should enable this option.

	NetworkAnalyzer allows the user to change the default colors of
parameter visualization.
	Background color for parameter visualization: The color of
the background in the network view. It is initially set to the
default Cytoscape background color.

	Bright color to map parameters: This color defines the
brightest color that parameters can be mapped to. By default its
value is green.

	Middle color: This color defines the intermediate color,
that parameters can be mapped to. By default its value
is yellow.

	Dark color: This color defines the darkest color that
parameters can be mapped to. By default its value is red.





	Location of the help documents: URL of the original help web
page for NetworkAnalyzer. This also enables the local download and
storage of this help page.



 






17.2. Subnetwork Creation

NetworkAnalyzer allows for the creation of sub-networks of connected
components. The user selects a number of connected components from a
list and each selected component is visualized as a sub-network. To create
sub-networks from connected components, select Tools → NetworkAnalyzer → Subnetwork Creation → Extract Connected Components.

[image: NetworkAnalyzer_ConnectedComponents.png]

 




17.3. NetworkAnalyzerDemo: Computation and Visualization of Topological Parameters and Centrality Measures for Biological Networks

Yassen Assenov1, Nadezhda Doncheva1, Thomas Lengauer1, and Mario Albrecht1

1 Department of Computational Biology and Applied Algorithmics, Max Planck Institute for Informatics, Campus E1.4, 66123 Saarbrücken, Germany

NetworkAnalyzer is a versatile and highly customizable Cytoscape plugin that requires no expert knowledge
in graph theory from the user. It computes and displays a comprehensive set of topological parameters and
centrality measures for undirected and directed networks, which includes the number of nodes, edges, and
connected components, the network diameter, radius, density, centralization, heterogeneity, clustering
coefficient, and the characteristic path length. In addition, NetworkAnalyzer shows charts of the distribution
of node degrees, neighborhood connectivities, average clustering coefficients, and shortest path lengths.
NetworkAnalyzer also contains extra functionality, for instance, for constructing the intersection or union of two networks.

The NetworkAnalyzer plugin and a comprehensive online documentation with a tutorial are available at http://med.bioinf.mpi-inf.mpg.de/networkanalyzer/.

Data keywords: network, graph, topology

Cytoscape keywords: Network Analysis
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18. Cytoscape Preferences

 


18.1. Managing Properties

The Cytoscape properties editor, accessed via Edit → Preferences →
Properties..., is used to specify default properties. Any changes made
to these properties will be saved in .props files under the
CytoscapeConfiguration subdirectory of the user’s home directory.

Cytoscape properties are configurable using the Add, Modify and Delete
buttons as seen below.

[image: Preferences_cy3.png]

App properties may also be edited in the same way as editing Cytoscape
properties. For example, to edit the properties of Linkout, select
‘linkout’ from the combobox of the Preferences Editor. Some apps may
store properties inside session files in addition to (or instead of)
storing them in the CytoscapeConfiguration directory.

[image: Preferences_linkout.png]

 




18.2. Managing Bookmarks

Cytoscape contains a pre-defined list of bookmarks, which point to
sample network files located on the Cytoscape web server. Users may add,
modify, and delete bookmarks through the Bookmark manager, accessed by
going to Edit → Preferences → Bookmarks....

[image: Preferences_bookmarks.png]

There are currently several types of bookmarks (based on data
categories), including network and table. Network bookmarks are URLs
pointing to Cytoscape network files. These are normal networks that can
be loaded into Cytoscape. Table bookmarks are URLs pointing to data
table files.

 




18.3. Managing Proxy Servers

You can define and configure a proxy server for Cytoscape by going to
Edit → Preferences → Proxy Settings....

[image: Preferences_proxy.png]

After the proxy server is set, all network traffic related to loading a
network from URL will pass through the proxy server. Cytoscape apps use
this capability as well. The proxy settings are saved in
cytoscape3.props. Each time you click the OK button after making a
change to the proxy settings, an attempt is made to connect to a well
known site on the Internet (e.g., google.com) using your settings. For
both success and failure you are notified and for failure you are given
an opportunity to change your proxy settings.

If you no longer need to use a proxy to connect to the Internet, simply
set the Proxy type to “direct” and click the OK button.

 




18.4. Managing Group Settings

The configuration of Cytoscape group view may also be edited through
Edit → Preferences → Group Preferences....

[image: Preferences_groups.png]

Note that Group Preferences apply to node groups established after the group preferences are set. They do not apply to groups that already exist.

The Group Preferences dialog provides access to three Group View Settings and all of the Attribute Aggregation Settings.
There are two interacting settings involved in the group view and group interaction:


	how an expanded group appears

	what happens when a node (group member or group node) is double-clicked

	what appears inside of a group node when it is collapsed




Group View Settings

The following node visualization options are available:


	None: No specific visualization – just do expand/contract, but don’t treat the expanded group special in any way

	Compound Node: Show the group node as an area surrounding the member nodes, but position it behind the member nodes to allow direct selection of each of the members.  If you move a node within this area, you may need to resize the area to encompass the newly positioned member node. Moving the group node will cause all member nodes to move with it.  There are visual styles that allow you to change the color, shape and padding for the compound node.

	Show Group Node: When the group is expanded, show the group node as an additional node and add “member edges” between the group node and each of the member nodes.  This is useful, for example, for complexes where it may be important to show a group node (the entire complex) at the same time as group member nodes (each individual protein).

	Single Node:  Show the group node as an area surrounding the member nodes, but put it in front of the member nodes so that the member nodes can not be selected or moved individually.



If you set the Double-Click action to something other than Expand/Contract, the groups won’t collapse on double-click, which may be appropriate for displaying group nodes that contain other nodes (i.e., the Compound Node visualization or Single Node visualization).




Attribute Aggregation Settings

Attribute aggregation provides an automated way for a group to aggregate all of the attributes of its children.  Since the columns in a Cytoscape network must all be of the same type, a group can’t simply create a list of integers to aggregate the integer columns of its members – the right approach to aggregating the attributes of group members will obviously depend on the application.  Cytoscape allows you to set the default aggregation approach for each type of column: Integer, Long, Double, String, Boolean, String List, Integer List, Long List, or Double List in the Default Aggregation Settings section.  In general, the user is provided with a list of some common aggregations.  For example, Integer aggregations include Average,  Minimum Value, Maximum Value, Median Value or Sum.

In addition, users can indicate that a specific column should use an aggregation approach different from the default by looking at Aggregation Overrides.




Grouping Tips

The Show collapsed node as a Nested Network checkbox determines the contents of a grouping node when its member nodes are hidden. If it is checked, the group node contains a graphic of the laid out member nodes. For the Compound Node visualization, this box should remain unchecked so the grouping node can appear as a background to member nodes.

Attribute aggregation only occurs when the group is collapsed or when the group visualization is changed (e.g., from Single Node to Compound Node).






18.5. Managing OpenCL Settings

You can choose between one or more OpenCL drivers installed on your system by going to
Edit → Preferences → OpenCL Settings....

[image: Preferences_opencl.png]

OpenCL is a library that enables Cytoscape to use your system’s graphics processing unit (GPU)
to accelerate certain layouts and other calculations. If no choices are presented, consult
the support web page for your system’s graphics card.
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19. Linkout

Linkout provides a mechanism to link nodes and edges to external web
resources within Cytoscape. Right-clicking on a node or edge in
Cytoscape opens a popup menu with a list of web links.

By default, Cytoscape includes a number of links such as
Entrez, SGD and Google, as well as a number of species-specific
links. In addition to the default links, users can customize the
External Links menu and add (or remove) links by using the Cytoscape
Preferences Editor (found under Edit → Preferences → Properties...
in the linkout group).

External links are listed as ‘key’-‘value’ pairs in the
editor where Property Name specifies the name of the link and
Value is the search URL. Linkout menus are organized in a
hierarchical structure that is specified as part of the key. Linkout key terms
specific to nodes start with the keyword nodelinkouturl; for edges
this is edgelinkouturl.

For example, the following entry:

nodelinkouturl.Model Organism DB.SGD (yeast)=http://www.yeastgenome.org/cgi-bin/locus.fpl?locus=%ID%





places the SGD link under the Model Organism DB submenu. This link will
appear in Cytoscape as:

[image: Figure1_linkout_Cy3.png]

In a similar fashion one can add new submenus.

The %ID% string in the URL is a place-holder for the node label.
When the popup menu is generated this marker is substituted with the
node label. In the above example, the generated SGD link for the YNL050C
protein is:

http://www.yeastgenome.org/cgi-bin/locus.fpl?locus=YNL050C





If you want to query based on a different column, you need to specify a
different node label using Styles.

For edges the mechanism is much the same; however here the placeholders
%ID1% and %ID2% reflect the source and target node label
respectively.

Currently there is no mechanism to check whether the constructed URL
query is correct and if the node label is meaningful. Similarly, there
is no ID mapping between various identifiers. For example, a link to
NCBI Entrez from a network that uses Ensembl gene identifiers as node
labels will produce a link to Entrez using the Ensembl ID, which results
in an incorrect link. It is the user’s responsibility to ensure that the
node label that is used as the search term in the URL link will result
in a meaningful link.

 


19.1. Adding and Removing Links

The default links are defined in the linkout.props file contained in the
CytoscapeConfiguration directory. These links are normal Java properties and can
be edited directly via text editor or by using the Cytoscape Configuration Editor (Edit → Preferences → Properties...) and
selecting linkout (shown below).

[image: Figure2_linkout26.png]

In addition, new links can be defined when starting Cytoscape from
command line by specifying individual properties. The formatting of the
command is cytoscape.sh -P [context_menu_definition]=[link].
context_menu_definition specifies the context menu for showing the
linkout menu item. The structure of this definition is nodelinkouturl or edgelinkouturl followed by
”.” and followed by the ”.”-separated menu hierarchy.

For instance this command:

cytoscape.sh -P nodelinkouturl.yeast.SGD=http://db.yeastgenome.org/cgi-bin/locus.pl?locus\=%ID%





will add this menu item:

[image: Figure3_linkout26.png]

To remove a link from the menu, simply delete the property using Edit
→ Preferences → Properties... and selecting commandline. Linkouts
added in the command line will be available for the running instance of
Cytoscape.
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20. Panels

Panels are floatable/dockable panels designed to cut down on the number of pop-up windows within Cytoscape
and to create a more unified user experience. They are named based on their functions – Control Panel,
Table Panel, Tool Panel and Results Panel. The following screenshot shows the file galFiltered.sif
loaded into Cytoscape, with a force-directed layout, Rotate tools showing in the Tool Panel, and with
results from Network Analyzer (Tools → Network Analysis → Analyze Network). The Control Panel (at the
left-hand side of the screen) contains the Network Manager, Network Overview, Styles and Select tabs. On the
bottom of the panel, there is another panel called Tool Panel. In the Table Panel, the Node Table
is shown. In addition, analysis results from Network Analyzer are shown in Results Panel (at the right-hand side).

[image: DockWindow-v3_3_3.png]

The user can then choose to resize, hide or float Panels. For example, in the screenshot below, the Control, Table
and Results panels are floating:

[image: FloatPanels-v3_3_3.png]

 


20.1. Basic Usage

Cytoscape includes four Panels: the Control Panel on the left, Tool Panel on the bottom of
the Control Panel, the Table Panel on the bottom right, and the Results Panel on the right.
By default, only the Control Panel and the Data Panel will appear. The Results Panel may appear,
depending on the mix of Cytoscape apps that you currently have installed. The Tool Panel will appear when
you select the following commands under the Layout menu: Rotate, Scale, and Align and Distribute.

All panels can be shown or hidden using the View → Show/Hide functions.

[image: cytopanel-menu-items.png]

In addition, Panels can be floated or docked using icon buttons at the top right corner of each Panel.
The Float Window control
[image: FloatWindow-v31.png]
will undock any panel which is useful when
you want assign the network as much screen space as possible. To dock the window again, click the
Dock Window icon
[image: DockWindow.png]
. Clicking the Hide Panel
icon
[image: HideWindow.png]
will hide the panel; this can be shown again by choosing
View → Show and selecting the relevant panel.
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21. Rendering Engine

 


21.1. What is Level of Detail (LOD)?

Cytoscape 3.0 retains the rendering engine found in version 2.8. It is
to be able to display large networks (> 10,000 nodes), yet retain
interactive speed. To accomplish this goal, a technique involving
level of detail (LOD) is being used. Based on the number of objects
(nodes and edges) being rendered, an appropriate level of detail is
chosen. For example, by default, node labels (if present) are only
rendered when less than 200 nodes are visible because drawing text is a
relatively expensive operation. This can create some unusual behavior.
If the screen currently contains 198 nodes, node labels will be
displayed. If you pan across the network, such that now 201 nodes are
displayed, the node labels will disappear. As another example, if the
sum of rendered edges and rendered nodes is greater than or equal to a
default value of 4000, a very coarse level of detail is chosen, where
edges are always straight lines, nodes are always rectangles, and no
anti-aliasing is done. The default values used to determine these
thresholds can be changed by setting properties under Edit |
Preferences | Properties....

Low LOD vs High LOD


Levels of Detail

 	Network with Low LOD                                                            	Network with High LOD                                                       

 	 	 




With low LOD values, all nodes are displayed as square and anti-aliasing
is turned off. With high LOD values, anti-aliasing is turned on and
nodes are displayed as actual shape user specified in the Style.

 


Parameters for Controlling LOD

NOTE: The greater these thresholds become, the slower performance
will become. If you work with small networks (a few hundred nodes),
this shouldn’t be a problem, but for large networks it will produce
noticeable slowing. The various thresholds are described below.


LOD Thresholds
 	Parameter                          	Description                                                                                                                                  

 	render.coarseDetailThreshold  	If the sum of rendered nodes and rendered edges equals to or exceeds this number, a very coarse level of detail will be chosen and all other detail parameters will be ignored. If the total number of nodes and edges is below this threshold, anti-alias will be turned on; this value defaults to 4000. 

 	render.nodeBorderThreshold 	If the number of rendered nodes equals to or exceeds this number, node borders will not be 