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CHAPTER 1

Overview

Cupid is a plugin for the Eclipse Integrated Development Environment (IDE) and provides developers with assistance
in writing code compliant with the National Unified Operational Prediction Capability (NUOPC) software Layer.

Note: The name Cupid is not an acronym. It originates from a Ph.D. project aimed at generating couplers for Earth
System Models. Cupid, in classical mythology, is the god of desire and attraction. Since this software is designed to
build couplers for “bringing models together,” the name Cupid seemed appropriate.

1.1 What is NUOPC?

NUOPC is a consortium of Navy, NOAA, and Air Force modelers and their research partners. It aims to advance
the weather prediction modeling systems used by meteorologists, mission planners, and decision makers. NUOPC
partners are working toward a common model architecture - a standard way of building models - in order to make
it easier to collaboratively build modeling systems. To this end, they have developed a NUOPC Layer that defines
conventions and templates for using the Earth System Modeling Framework (ESMF). Cupid version 0.2 is compatible
with ESMF version 7.0.

Note: The following resources are a good starting point for learning about the NUOPC Layer.
* The NUOPC home page: https://www.earthsystemcog.org/projects/nuopc

* The NUOPC reference manual and how to guide: https://www.earthsystemcog.org/projects/nuopc/refmans

1.2 What is Eclipse?

Eclipse is a graphical user interface or integrated development environment (IDE) used in computer programming
for writing software. It contains a base workspace and an extensible plugin system for customizing the environment.
Eclipse is written mostly in Java and its primary use is for developing Java applications, but it may also be used to
develop applications in other programming languages through the use of plugins



https://www.earthsystemcog.org/projects/cupid/
https://www.eclipse.org/
https://earthsystemcog.org/projects/nuopc/
https://earthsystemcog.org/projects/esmf/
https://www.earthsystemcog.org/projects/nuopc
https://www.earthsystemcog.org/projects/nuopc/refmans
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1.3 The basic premise behind Cupid

Cupid acts as a framework-aware code editing environment. This means that the requirements of writing NUOPC-
compliant code are built into the tool so that it can automatically generate code fragments and indicate places in the
code with potential errors before the code is compiled. To accomplish this, Cupid relies heavily on Fortran static
analysis capabilities provided by Photran, the Eclipse plugin that provides Fortran language tooling.

1.4 Target Audience

Cupid is intended for model developers who have prior experience with model development, but are new to developing
with NUOPC and have a need to work with existing NUOPC-compliant software or write code to make a Fortran-based
model code NUOPC compliant. Specifically, Cupid can help write a NUOPC “cap” for a model, i.e., the interface
layer that translates a model’s init/run/finalize methods and data types so that they can be understood by NUOPC and
used in a coupled system with other NUOPC components.

Cupid is also aimed at developers interested in exploring the benefits of using the Eclipse IDE for improving develop-
ment productivity.

1.5 Key Features

* A reverse engineering engine that reads existing NUOPC cap code and presents relevant initialize, run, finalize
phases and specialization points in an outline view. The outline is synchronized automatically as the code
changes. The tool indicates code-level compliance issues that may result in runtime errors. (The compliance
checking is limited to code errors than can be determined by static analysis.)

* A code generation engine that outputs NUOPC-compliant code fragments (i.e., initialization phases and spe-
cialization points). The generated code can often be used as is, although further customization of the generated
code is suported. The generated code is inserted into the user’s existing code at the appropriate places, keeping
the existing code structure intact. The code generation feature helps the developer understand what framework
code is required and where it should be located.
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CHAPTER 2

Installation

Information about installing Cupid is maintained on the Cupid website:
https://www.earthsystemcog.org/projects/cupid/

Note:
* Prerequisites: https://www.earthsystemcog.org/projects/cupid/installation/prerequisites
* Installation from the Eclipse marketplace: https://www.earthsystemcog.org/projects/cupid/installation/marketplace

* Installation with the Eclipse installer: https://www.earthsystemcog.org/projects/cupid/installation/eclipseinstaller



https://www.earthsystemcog.org/projects/cupid/
https://www.earthsystemcog.org/projects/cupid/installation/prerequisites
https://www.earthsystemcog.org/projects/cupid/installation/marketplace
https://www.earthsystemcog.org/projects/cupid/installation/eclipseinstaller
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CHAPTER 3

How To

3.1 Verify that Cupid is Installed

To verify that Cupid is installed, view the Eclipse Installation Details by selecting Help -> Installation Details from
the Eclipse menu. You should see Cupid in the list of installed software.

Eclipse Installation Details

Installed Software | Installation History Features Plug-ins Configuration

|’ type filter text & \
Name Version Id

» %7 Cupid 0.2.0.2016041916  org.earthsystemmodeling.
» [+ Eclipse for Parallel Application Developers 4.5.2.20160218-0¢  epp.package.parallel

» = Eclipse Platform 4.5.2v20160212-1 org.eclipse.platform.feaky

P = Eclipse RCP 4.5.2v20160212-1  org.eclipse.rcp.feature.grc

» g+ Domph Setup 1.4.0.v20160324-0  org.eclipse.oomph.setup.f

The Cupid IDE and Code Generation tool for Earth System Models

® Update... Uninstall... Properties Close
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3.2 Create a Fortran Project with Your Model Code

There are two options for creating a Fortran project in Eclipse based on whether the source code you are importing is
local or on a remote machine. The simplest approach is to have the source code available locally. However, that is not
always practical so Eclipse provides a synchronization capability with files on a remote system accessible via SSH.
The sections below describe briefly how to create these two kinds of projects.

See also:

This user guide provides only high level guidance in setting up local and remote Fortran projects. More details can be
found on the Parallel Tools Platform documentation site.

3.2.1 Projects with Local Files

To create a new Fortran project with local files, right-click (CTRL-click on Mac) on the Project Explorer and select
New -> Fortran Project. On the New Project screen you can un-check Use default location and browse to the location
of the files. If you use the default location, the project folder will be in the Eclipse workspace folder and you will need
to import files manually by selecting File -> Import... from the menu after creating the project.

Under Project type, it is recommended that you select Empty Project under the Makefile project folder. (The project
will not actually be empty if you selected the location of your local files.) Click Finish and the new project will be
created and will appear in the Project Explorer.

3.2.2 Synchronized Projects with Remote Files

A synchronized Fortran project will copy files from a remote file system and ensure that the remote and local copies
stay synchronized. This is convenient if the code will be built and executed on a remote system. The disadvantage
of this approach is that the initial synchronization can take multiple minutes if the size of the source tree is large.
However, once the initial synchronization is complete, only changed files need be communicated over the network.

The first step is set up the connection with the remote machine. Open the Connections view by selecting Window ->
Show View -> Other. In the list of views, filter for “Connections” and click OK to show the view.

Create a new connection by clicking the New Connection button (with a small yellow +) in the toolbar on the Connec-
tions view. Choose SSH connection on the following screen and click next. On the next screen fill in the details about
the connection. The password can be left blank and you will be prompted at each login. In some cases you may need
to create multiple connections and use one as the proxy for another, for example, if you must first authenticate through
a login node. Click Finish when you are done and you will see the new connection in Connetions view.

Now create a new synchronized Fortran project right-click in the Project Explorer and select New -> Synchronized
Fortran Project. Fill in the project name, select the remote connection you created and fill in the file path to the root
of the source code on the remote system.

You can optionally filter which files are synchronized by clicking Modify file filtering... and choosing certain direc-
tories to exclude. In particular, directories containing large data files and other non-source code should be excluded to
speed up the synchronization.

Under Project Type select Empty Project under Makefile project. Selecting local and remote toolchains is not required
unless you plan to use the Eclipse build system. Click Finish and the new project will appear in the Project Explorer.

The project will initially be empty and you will need to manually kick off the first synchronization. Do this by click-
ing the synchronize button in the toolbar or by right-clicking (CTRL-click on mac) the project folder and selecting
Synchronize -> Sync Active Now. Remote files will be copied to the local workspace. By default, future synchro-
nizations will happen automatically when changes are made to local files. If the remote files change, or if you notice
that changes have not been propagated to the remote system, force a sync using the procedure above.

8 Chapter 3. How To
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Fortran Project

Fortran Project <>

r y |

({1, Directory with specified name already exists.

Project name: | MyNewProject |

[ ] Use default location

Location: |:,."homefmckyfeclipsefcupiddEv—vCFE,fgitfcupid,forg.earthsystemr], Browse... |

-

Choose file system: | default 2 |

Project type: Toolchains:

> (= Executable — Other Toolchain -

» = Shared Library GCC Fortran

» = Static Library IBM XL Fortran Tool Chain

> = Others Intel(R) Fortran Toolchain on Intel(R) 64
¥ = Makefile project

~ Empty Project

® Empty Project-Fortran

® Demo - Hello World - Fortran

® Demo - Hello World - Fortran using MPI
® Demo - Calculate Pi-Fortran using MPI

]

& show project types and toolchains only if they are supported on the platform

@ < Back |  Next> || Cancel | &J

Fig. 3.1: The New Fortran Project wizard.

3.2. Create a Fortran Project with Your Model Code 9
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{2l Problems B console [ FortranDeclaration Clll Bookmarks |5 Connections &2 =R B8

B Local

Fig. 3.2: The Connections view.

New Connection

Specify properties of a new connection

Connection name: |MyRemote

Hosktinformation
Hosk: my.remote.com

User: rdunlap

) Public key based authentication Keys are set at Network Connections, SSH2

Passphrase:

{®) Password based authentication
Password:

» Advanced

@ < Back Next = Cancel [ Finish J

Fig. 3.3: The New Connection wizard.
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New Synchronized Fortran Project

New Synchronized Fortran Project Q
C

Create a synchronized Fortran project of the selected type

Project name: | MySyncProject

Local directory
® Use default location

Local directory: | Browse... |

Remote directory

-

Connection name: | my.remote.com - | | New... |

Remote directory: |/path/on/remote | Browse... |

Modify file filtering...

Project Type Remote Toolchain (select 1 or more)
> = Executable — Other Toolchain -
® = Shared Library GCC Fortran
> (= Static Library IBM XL Fortran Tool Chain
> = Others Intel(R) Fortran Toolchain on 1A-32
¥ = Makefile project Infel(R) Fartran Tanlchain nn 1A-64 -
@ Empty Project Local Toolchain (optional - select 0 or more)
® Empty Project-Fortran — Other Toolchain -
@& Demo - Hello World - Fortran GCC Fortran
@ Demo - Hello World - Fortran using MPI IBM XL Fortran Tool Chain
@ Demo - Calculate Pi - Fortran using MPI Intel(R) Fortran Toolchain on I1A-32
Intel/BY Fartran Tnnlrhain nn 1A-RA -

[ show project types and toolchains only if they are supported on the platform

@ <Back |  MNext> || Cancel || Finish

Fig. 3.4: The New Synchronized Fortran Project wizard.

3.2. Create a Fortran Project with Your Model Code 11
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Fortran - Eclipse

Fﬁ'v @v%vlumﬁvavggvéﬁvﬁﬁvﬁvé[g@s

(5 Project Explorer 52 = B

== =

%> MySyncProject

Fig. 3.5: After selecting a project, click the Synchronize button on the toolbar (circled in blue) to kick off the first
synchronization. Remote files will be copied to the local workspace.

3.2.3 Ensure Fortran Analysis is Enabled

Important: Turning on the Fortran analysis/refactoring engine is required for Cupid to work properly.

Cupid depends on the Fortran analysis engine being activated for projects containing NUOPC code. By default it is
turned off. To turn it on for a project, right-click (CTRL-click on Mac) on the project folder and select Properties.
Under Fortran General -> Analysis/Refactoring check the first box, Enable Fortran analysis/refactoring.

3.3 Reverse Engineer a NUOPC Cap

Cupid’s reverse engineering function is capable of analyzing the source code of a NUOPC component to create a
representation at a higher level of abstraction. The reverse engineering analysis is limited to only the NUOPC cap of
a component, which is typically a single Fortran module. The analysis does not descend into the model code itself.
Once the higher level representation is obtained, Cupid is able to provide NUOPC-aware capabilities, such as basic
validation of correct API usage and in-place code generation—i.e., weaving new code into the correct places of an
existing source file. The reverse engineering analysis phase happens automatically as a background process and an
index of NUOPC components in the workspace is maintained.

3.3.1 Show the NUOPC View

The results of the reverse engineered code can be seen in outline form in the NUOPC View.

The NUOPC View is set up to show whenever the Fortran perspective is selected. The current perspective is shown
in the upper right-hand corner of Eclipse. There is also an Open Perspective button which can be used to select the
Fortran perspective if it is not already shown.

There are other ways to show the NUOPC View:

* If the NUOPC View is not visible and you open a file with NUOPC code, a dialog will ask you if you would
like to open the NUOPC View. This behavior can be turned off in the Cupid preferences (select Window ->
Preferences from the menu and select Cupid in the list on the left).

* The main toolbar contains a Show NUOPC View button, circled in green below

12 Chapter 3. How To
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Fortran - Eclipse

rﬁ" @t'&t@ {,‘:[}té'-ﬁ:tl

[75 Project Explorer &3 i3 v = g

&* MySyncProject -

¥ = addon
» = ESMPy
= MAPL
= MAPLS5 1
* = NUOPC
| & makefile
> = apps
* = doc
> = epilogue
P = include
¥ = Infrastruckture

] ]

=d Progress i3 & Y = O

C/C++ Indexer
e

= Indexing: 401/1,77...e/Mesh/src/Zoltan)

£ MySyncProject

Fig. 3.6: After the synchronization process, files will be visible in the Project Explorer.
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Properties For MySyncProject

@

B

Resource
Builders
C/C++ Build
C/C++ General

® Fortran Build

Fortran General
Analysis/Refactoring
Paths and Symbaols
Source Form

Linux Tools Path

Project References

Run/Debug Settings

synchronize

Task Repository

Task Tags

Validation

WikiText

Analysis/Refactoring =

To enable Open Declaration, Find All References, the Fortran Declaration
view, content assist, and refactoring in Fortran programs, check the
following box. A program database (index) will be updated every time

a Fortran file is created or saved.

[ [Enable Fortran analysis/refactoring|

[ Enable Fortran Declaration view
[ Enable Fortran content assist (Ctrl+Space)

[ Enable Fortran Hover tips

The Following specify the paths searched for modules
and INCLUDE files during analysis and refactoring.
These MAY BE DIFFERENT from the settings used by
your compiler to build your project.

Folders to be searched for modules, in order of preference:

/MySyncProject New

Remove
Up

Down

Folders to be searched for INCLUDE files, in order of preference:

/MysSyncProject New...
Remove
Up
Down
| Restore Defaults | | Apply
Cancel . l 0K J

Fig. 3.7: Enable Fortran analysis/refactoring on in the project properties.

14
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71 ATM.FS0 23 = o = e & NUOPCView R © Make Targe! ]
Lo 2.0 .3 AT S A 8 ERRNT SR 2
A — NUOPC Definition Value
2 & NUOPCCoupled AtmOCn/ATM.FSO
3 use ESHF v ® NUOPC Model ATM
4 use NUOPC -
5 use NUOPC Model, model SetServices => SetServices, & E ESMFImpart
3 node1 label Advance => label Advance “= NUOPC Import
7 S “= Generic Import NUOPC_Model
& implicit none
9 » o setservices setservices
10 public SetServices v initialize
1
12 contains v Phases
H > initialize Phase Definition (v00)
14 subroutine Setservices(gcomp, rc) v Initialize Phase Definition (v01)
B Iype(ESHF _GridComp) :: gconp » © IPDVO1pO - Filter Initialization Phases IntializeP0
16 integer, intent(out) :: rc
7 » o IPDVO1p1 - Advertise Fields AdvertiseFields
18 rc = ESHF_SUCCESS @ IPDVO1p2 - (unspecified by NUOPC)
19
20 ! NUOPC Driver registers the generic methods " !
21 call NUOPC_CompDerive(gcomp, model SetServices, rc=rc) @ IPDVO1p4 - Verify All Connected & Set
2 if (ESHF_LogFoundError (rcToCheck=rc, msg=ESMF_LOGERR PASSTHRU, & @ IPDVO1pS- Initialize Fields
23 line= LI , & + Initislize Phase Definti
b e mie ' Initialize Phase Definition (v02)
25 return | bail out > Initialize Phase Definition (v03)
20 > Initialize Phase Definition (v04)
27 call ESF_GridConpSetEntryPoint(gconp, ESMF_METHOD INITIALIZE, & ;
28 userRoutine=InitializePo, phase=d, rc=rc) > Specializations
29 if (ESHF_LogFoundError (rcTocheck=rc, msg=ESMF_LOGERR PASSTHRU, &
30 line= LI , & > Run
1 file= FILE ) & -
32 return ! bail out > Finalize
33 » 2 NUOPCCoupledAtmOCH/ESM.F90
34 call NUOPC_CompSetEntryPoint (gcomp, ESMF_METHOD INITIALIZE, & '
35 phaseLabelList=(/*IPOvO1p1*/), userRoutine=AdvertiseFields, rc=rc)  NUOPCCoupledAtmOCn/OCN.F30
36 if (ESMF_LogFoundError(rcToCheck=rc, msg=ESMF_LOGERR PASSTHRU, & » 5 NUOPCCoupledAtmOcnMed/ATM.F90
37 line= LINE , & » & NUOPCCoupledAtmOcnMed/ESM.F90

Fig. 3.8: The NUOPC View (to the right of the source code) shows an outline of a reverse engineered NUOPC
component.

- .

Quick Access |

= F@ c/c% | @ Fortran|

= 8 8= Qutline &% NUOPC View 2 Make Target = g

8 NUOPC Definition value

#: NUOPC Model

T ‘= ESMF Import
‘= NUOPC Import

Fig. 3.9: The NUOPC View is set to appear automatically from the Fortran perspective (circled in blue). Click the
Open Perspective button (circled in green) to open a new perspective.

3.3. Reverse Engineer a NUOPC Cap 15
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Frea& - F- B0 8 %0 Q- ®¢

v =2 H [F] atm.F90 &3

¢ The NUOPC View can be accessed from the Window -> Show View -> Other menu

The NUOPC View will automatically refresh itself as files are changed and saved in the workspace. It is also possible
to force a refresh of the NUOPC View using the refresh button (blue circular arrow) in the top right corner of the
NUOPC View. This will first ensure that the Fortran analysis database is up to date and then it will rebuild the index
of NUOPC components in the workspace.

3.3.2 Elements in the NUOPC View outline

The top-level element in the NUOPC View tree are files in the workspace that contain code for a NUOPC compo-
nent. The first element under each file indicates that type of component (Model, Driver, or Mediator). Sub-elements
underneath the component type represent something in the source code, such as a SetServices subroutine, a NUOPC
initialization subroutine, a specialization point subroutine, imports of NUOPC generic modules, or calls into the
NUOPC API. Many of the elements have small icons: a blue circle with an M maps to a Fortran module, a green
circle maps to subroutine, and a yellow arrow pointing to the right represents a subroutine or function call. If a green
circle has a small upward triangle in the corner, it indicates that the subroutine is not in the current module, but is
inherited from a NUOPC generic component. Grayed out items do not map to any source code element, but represent
subroutines or API calls that can be generated. Red items indicate that there is a validation problem rooted at that
element. Some elements indicate a cardinality such as [1..n], which indicates that one or more elements of that type
can exist, or [0..1], which indicates the element is optional.

The outline is divided into several major sections:
* module imports (only specific ones are shown)
* SetServices
* initialization phases and specialization points
* run phases and specialization points
* finalize phases and specialization points

The NUOPC View is linked to the source code in the active editor. To navigate to the source code related to the
element, double-click the element. The relevant code segment will be brought into focus. If the element maps to a
subroutine definition, the name of the subroutine will be highlighted. If the element maps to an API call, the call will
be highlighted. If an element represents an inherited subroutine (a green circle with small triangle), then it does not
appear in the current file, so no code will be highlighted when double-clicking the element.

3.3.3 Validation Errors in the NUOPC View

Elements in red in the NUOPC View indicate a validation error. Currently, the validations performed are to check for
missing subroutines and API calls required by NUOPC, e.g., a missing initialization phase or a missing specialization
point. The NUOPC Reference Manual details, for each type of component, which subroutines are required and which
are optional. Red elements do not indicate a Fortran compilation issue, but indicate that NUOPC expects the element
to be present and a runtime error will occur without it. The figure below indicates that the Advance specialization point
could not be found during the reverse engineering procedure. Within NUOPC, specialization points are user-provided

16 Chapter 3. How To
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E= Outline & NUOPC View 52 ‘ Make Target 5 = O
NUOPC Definition Value

B NUOPCCoupledAtmOcn/ATM.F90

v @ NUOPC Model ATM

“= ESMF Import
‘= NUOPC Import
‘= Generic Import NUOPC_Model

P @ SetServices SetServices

v Inikialize

¥ Phases
» Initialize Phase Definition (v00)
¥ Initialize Phase Definition (v01)
» @ IPDvO1p0 - Filter Initialization Phases [0..1] : InitializeP0

P @ IPDVO1p1-Advertise Fields AdvertiseFields
@ IPDV01p2 - (unspecified by NUOPC)
B @ |IPDVO1p3 - Realize Fields RealizeFieldsProvidingGrid

@ IPDv01p4 - Verify All Connected & Set Clock
& IPDVO1p5 - Initialize Fields
» Initialize Phase Definition (v02)
B Initialize Phase Definition (v03)
P Initialize Phase Definition (v04)
» Specializations

»  Run
»  Finalize
» 5 NUOPCCoupledAtmOcn/ESM.F20
» 5 NUOPCCoupledAtmOcn/OCN.F90
» 5 NUOPCCoupledAtmOcnMed/ATM.F90
> = NUOPCCoupledAtmOcnMed/ESM.F90

e = R 1A msim e A b e b A m A fRAFS FAA

Fig. 3.10: The NUOPC View showing an outline of a NUOPC Model cap.

3.3. Reverse Engineer a NUOPC Cap 17
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[F atm.F90 = = O &= outline & NUOPC View &2 | @ Make Target = 0
. Tote 2o W 3 a4 L 5 L 6 LT L NUOPC Definition Value
13 implicit none v & NUOPC Model ATM (atm.F90)
14 . “= ESMF Import
15 private
16 UOPC Import
17 public SetServices “= Genericlmport NUOPC_Model
18 etServices
19 o .

20 =] NUOPC_CompDerive

21 ¥ Initialize

22 ¥ Phases

23-  subroutine FHEHREIEL (model, rc) o .

24 type (ESMF_GridComp) :: model » Initialize Phase Definition (v00)
25 integer, intent(out) :: rc > Initialize Phase Definition (v01)
26 S S

7 rc = ESMF_SUCCESS > Initialize Phase Definition (v02)
28 > Initialize Phase Definition (v03)
29 | the NUOPC model compenent will register the generic methods » Initialize Phase Definition (v04)
30 call NUOPC_CompDerive(model, model_routine SS, rc=rc) v  Specializations

31 if (ESMF_LogFoundError(rcToCheck=rc, msg=ESMF_LOGERR_PASSTHRU, & P

32 line= LINE , & > o

33 file= FILE )) & e

34 return ! bail out

35

36 I set entry point for methods that require specific implementation > Run

37 call NUOPC_CompSetEntryPoint(model, ESMF_METHOD INITIALIZE, & v Finalize

38 phaseLabelList=(/"IPDvEOpl"/), userRoutine=InitializePl, rc=rc)

39 if (ESMF LogFoundError(rcToCheck=rc, msg=ESMF LOGERR PASSTHRU, & >  Phases

40 line= LINE_ , & ¥ Specializations

41 file= FILE )) & >o

42 return ! bail out

43 call NUOPC_CompSetEntryPoint(model, ESMF_METHOD INITIALIZE, &

44 phaseLabellList=(/"IPDv@Op2"/), userRoutine=InitializeP2, rc=rc)

45 if (ESMF_LogFoundError(rcToCheck=rc, msg=ESMF_LOGERR_PASSTHRU, &

Fig. 3.11: Double-clicking on an element in the NUOPC View outline brings the relevant code segment into focus in
the editor.

subroutines that are called by NUOPC. Notice also that parent elements are red all the way to the root of the tree.
Therefore, if the root of the tree is red, it indicates a validation issue somewhere below.

To address the issue of the missing Advance element, a new subroutine needs to be added to the code and that subrou-
tine registered in the Set Services subroutine. When this is done, the reverse engineering engine will pick up this
code and the red elements will disappear. The section Generate NUOPC-compliant Code explains how to use Cupid
to generate skeleton code for missing elements.

Note: Cupid’s reverse engineering and validation engines are based on static source code analysis. The engine
depends on an internal program database (Virtual Program Graph or VPG) provided by the Photran plugin for Eclipse.

There are limitations to static analysis giving rise to false negatives—i.e., reporting a validation issue when in fact
the NUOPC component will behave correctly. For example, in some cases the reverse engineering engine expects
NUOPC API calls to appear within a given subroutine, say SetServices. In reality, the required API call may appear
in a different subroutine called by SetServices or even several levels down in the call tree. Cupid does not currently
perform a full control flow analysis to find NUOPC calls because it is an expensive operation. And, even control flow
analysis is limited due to conditional logic in the code that depends on the state of the program at runtime.

Cupid, therefore, is fundamentally limited by the realities of static analysis. However, most NUOPC caps have a
very similar structure with a fair amount of boilerplate code, so we expect that most codes will be correctly reverse
engineered.
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0= Qutline [% NUOPC View % | @ Make Target = B
NUOPC Definition Value

v @ NUOPC Model ATM (atm.F90)
‘= ESMF Import
‘= NUOPC Import
‘= Generic Import NUOPC_Model
v @ SelServices SetServices
=] NUOPC_CompDerive
¥ Run
#  Phases
v Specializations
X
X
v @ Advance [1..n]
=] Registration
P Finalize

Fig. 3.12: The Advance element is red because it could not be found by the reverse engineering engine.
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3.4 Generate NUOPC-compliant Code

Cupid’s code generation facilities make it easier to write the code for a NUOPC cap. A NUOPC cap acts as a kind of
translation layer between your model code and the coupling infrastructure. A NUOPC cap is implemented as a Fortran
module containing a set of subroutines. Cupid is capable of generating NUOPC Model caps, NUOPC Drivers, and
NUOPC Mediators. The code generator can create new Fortran modules for each of these components in new files, or
the code generator can insert snippits of code into an existing file after it has been reverse engineered.

There are several options for generating code:

e If there is an existing NUOPC component cap, it should be reverse engineered first as described in Reverse
Engineer a NUOPC Cap. Then, using context menus in the NUOPC View, new code can be generated and
inserted in-place. This is the right procedure to use, for example, if you need to add an additional specialization
point subroutine to an existing cap.

« If there is no existing NUOPC code, a template can be generated for NUOPC Model caps, NUOPC Drivers, and
NUOPC Mediators. This is the best option if you have an existing model and need to create a cap so that it can
be used in NUOPC-based coupled systems.

* An entire skeleton NUOPC coupled application can be generated, including a main program and Makefile. This
is covered in the Generate Skeleton Code for a Complete NUOPC Coupled Application section.

The sections below describe the first two generation options above.
See also:

This user guide is not a comprehensive guide to what comprises a NUOPC cap. For a gentle introduction to NUOPC
and what is required in a NUOPC cap, please see the Building a NUOPC Model document.

3.4.1 Generate Code In-Place in an Existing NUOPC component

If you need to modify code in an existing NUOPC component (Model cap, Driver, or Mediator), you should first open
up the file so that the reverse engineered outline is shown in the NUOPC View. In the following scenario, let’s assume
you have an existing NUOPC Model cap for a atmospheric model, but it is missing the required Advance specialization
point. This is the subroutine that should call into your model’s run phase to take a time step. In the NUOPC View,
right-click (CTRL-click on Mac) on the parent element of the element you would like to generate. The context menu
will show you all code generation options currently available.

In the context menu, select the element to generate, in this case Generate Advance. The requested element will be
added to the outline and the corresponding code generated in the editor. Often, the addition of one element results in
inserting several code fragments. In the case of the Advance element, a new subroutine is added, a new import is added
to the NUOPC_Model use statement, and a call to NUOPC_CompSpecialize is added in the SetServices
subroutine. After the code generator runs, yellow markers are added to the vertical bar to the right of the code editor
to indicate where new code was added. Clicking on one of the markers highlights the generated code.

The generated code will compile as is, although it almost always requires additional customization to complete the
implementation. In the case of the Advance subroutine just generated, additional code is needed to call into the
underlying model’s time step routine. This clearly cannot be generated automatically because it is model-dependent.
Therefore a typical workflow will start with a code generation action as just described, followed by filling in any model-
specific implementation. This will continue until all required initialization phases are complete and all specialization
points have been implemented.
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o= Outline |52 NUOPC View 2 | @ Make Target = B
NUOPC Definition Value
v @ NUOPC Model ATM (atm.F20)
‘= ESMF Import |
‘= NUOPC Import
‘= Generic Import NUOPC_Model
v @ SelServices SetServices

=] NUOPC_CompDerive
» Initialize
¥ Run
P Phases

¥ Specializations - .

Generakte SetRunClock

[ ] _ _
Generate Checkimport

@
Generate Advance

v @ Advance [1..n] ;

=] Registration

» Finalize

Fig. 3.13: Right-clicking on an element shows a context menu with the available options for code generation.
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B atm.Fo0 & | [ esmApp FS0 = A & MUOPC View 5 Make T = 4
1 i L 3 & ] > G, i ! a8
- return 1 bail out NUCPC Defindtlon Walue
13 call NUOPC CompSelEntryPointimodel, ESMF_METHOD INITIALIZE, & ¥ @ NUOPC Model ATM (atm.Far)
44 phaseLabellist={/"IPDveep2" /), userRoutine=Initializerz, rc=rc} ‘= ESMF Import
45 if (ESMF LogFoundErrar(rcToCheck=rc, msg=ESMF LOGERA PASSTHAU, &
46 Line=_ LINE_, & ¢ MUDPCImport
47 file= FILE ]} & MUDPC_Model
18 return ! bail out SetServices

call NUOPC_CompSpecialize(model, speclabel=model label Advance, &
specRoutine=ModelAadvance, ros=rc)
if (ESWF_LagFoundErrar(reTacheck=re, msg=ESMF_LOGERA_PASSTHAL, &

line= LINE_, &
file= FILE ]] &
return ! bail eut

Yellow bars indicate
areas of generated
code. Click to

Initialize Pl
Initialize Ph
end subroutine

' highlight.
62 subroutine InitializePl{model, importState, expartState, clock, re)
63 typelESHF GridComp) :: model
&4 typelESHF State) :: lmportState, exportstate
ES type(ESHF Clack) =: clack
& integer, intemt(oul) z: rc
o Phases
68 rc = ESMF SUCCESS
. @& Fun Phase 1
] ! Disabling the following macro, c©.g. renaming to WITHIMPORTFLELDS disable, * Specializations
71 ! will result in a model component that does not advertise any importable Fa
72 ! Fields. Use this it you want to drive the model independently.
13| #define WITHINPORTFIELDS ke
74| #ifdef WITHINPORTFIELDS k@ Advance [1..n] rModeladvance
75 ! inpartable field: sea surface temperature

¥ Finalize

Fig. 3.14: Yellow markers in the vertical bar next to the code editor indicate which code was generated during the last
code generation action.

3.4.2 Generate a NUOPC Model cap, NUOPC Driver, or NUOPC Mediator from
Scratch

Templates for NUOPC Model caps, NUOPC Drivers, NUOPC Mediators can be generated from scratch. This option
is available from the context menu in the Project Explorer. Right-click (CTRL-click on Mac) on a folder in a Fortran
project and select New from the context menu and you will see the three options as shown below.

You will be prompted to enter the name of the component. Click OK and a new Fortran file named <COMPO-
NENT>.F90 will appear in the folder (where <COMPONENT?> is the name you provided). The file will also automat-
ically open in the editor and you will see the outline in the NUOPC View. At this point the template can be customized
by manually adding code and/or generating code fragments from the NUOPC View outline as described above.

To compile the code, you will need to modify your model’s existing build system to include the new .F90 file.

3.5 Generate Skeleton Code for a Complete NUOPC Coupled Appli-
cation

A good way to learn about how NUOPC coupling infrastructure works is to build a skeleton application containing all
of the “plumbing” but with no real science code to keep it small.

Create a new NUOPC project using the NUOPC Project wizard. Select File -> New -> Project... from the menu.
Select the NUOPC Project option under the NUOPC folder and click Next.
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R B -/ & C RSB A B0 & B P

B rroject.. ess \| B B c/c++ | B Fortran|

Go Into File ‘[ 2 NUo B = g
Openin i / NUOPC Driver
NUOPC

NUOPC

MNUOPC Definition

b &l Includes Copy
> =5 > NUOPC 453 [http://svn.cf

d Fortran P

=g Progress £ Index ) nized Projec &I}

. . d Configuratic Xam
No operations to display at t BulciCogiiis i

& MyNUOPCAppP

Fig. 3.15: The Project Explorer context menu with options for generating a NUOPC Model cap, a NUOPC Driver, or
a NUOPC Mediator.

= Fortran - MyNUOPCAPpp/ATM.F90 - Eclipse

[ d m R @ AR A BT AR = R o I e PiE @Y - DR SRR .
[Quick Access  |!| & 0 cfc++ 'm
[ Project Explorer = B [ ATM.F90 3 = O &5 NUOPC View 5 = B8

& - . .. 2 . .3 .. 4 . 5 .. 6.+ T .. 8 1 .9 it
B & 1o module ATM NUOPC Definition Value
v & MyNUOPCApp 2 UOPC Madel ATM (ATM.FS0)
3 use ESHF ESMF Import
2 B.ATM.F20 4 use NUOPC . P
P il Includes 5 use NUOPC Model, & = NUOPCImport
» 5 > NUOPC 453 [http://svn.code.sF.ne 6 model SetServices => SetServices, & “= Generic Import NUOPC_Model
; model label Advance => label Advance v o Setservices setservices
9 implicit none =] NUOPC_CompDerive
10 ¥ Initialize
g public SetServices v  Phases
13 contains »  Initialize Phase Definition (v0O)
14 » Initialize Phase Definition (v01)
158 subroutine SetServices(gcomp, rc) > A .
15 type(ESMF_GridComp) :: gcomp Initialize Phase Definition (v02)
7 integer, intent(out) :: rc » Initialize Phase Definition (v03)
18 b Initialize Phase Definition (v04)
19 rc = ESMF_SUCCESS PP
20 = v Specializations
21 ! NUOPC Driver registers the generic methods (]
22 call NUOPC CompDerive(gcomp, model SetServices, rc=rc) bo
23 if (ESMF_LogFoundError(rcToCheck=rc, msg=ESMF _LOGERR PASSTHRU, &
24 line= LINE_, &
25 file= FILE )) & ¥ Run
26 return ! bail out v Phases
27
! e - B @ Run Phase 1
=g Progress & % ¥ = g B console &2 { ~E = 0
No operations to display at this tim No consoles to display at this time.
Writable Insert 1:11

Fig. 3.16: A NUOPC Model cap template.
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New Project

Select a wizard >

Wizards:

[ type filter text @ |

b= General
b= CfCH+

P (= Fortran
¥ (= NUOPC
b= RPM

P = Tracing
B = XL UPC

B 7= NFhar

@ <Back Next > Cancel Finish

On the next screen, select a starting configuration for the skeleton NUOPC application. Ideally, you should find a
configuration that looks something like the actual coupled application you are building.

Create NUOPC Project
Create NUOPC Project
Please select an option

starting configuration:

NUOPC - Single Model with Driver -
Model Architecture Coupling Behavior
Asingle Model component is called by a Driver in There is no coupling in this configuration.
regular intervals.
Driver: SINGLE
.
Driver:
13
SINGLE E
Model:ATM B
=2
. =
Model: oh 1h 2 3h
ATM Model Time: —}—}—} |,
® \ <Back ,I, Next> | Cancel Finish

On the final screen of the wizard, type in a project name and click Finish. The new project will be created. Initially,
the project will contain a .nuopc file which is a configuration file describing the coupled system.
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(-] Fortran - Eclipse

i B -] - @& CEErFr B0 A0 i® S
oo - Quick Access B c/c++ [ Fortran)
[ Project Explorer 22 = g = O Eoul X|&NO @Make = O

E 5 <

v NUOPCSingleModelwithDriver
[ singleModelwithDriver.aird
e elwithDriver.nuo

An outline is not available.

Cproperties 2 = 0
BES -’ -

Property Value

To generate all the NUOPC code for the system, right-click (CTRL-click on Mac) on the .nuopc file and select NUOPC
-> Generate NUOPC code from the context menu. The code for the NUOPC skeleton application will be generated.

This includes:

* A NUOPC cap for each Model component

A NUOPC Mediator, if present in the configuration
A NUOPC Driver

* A top-level main program

¢ A makefile

3.5. Generate Skeleton Code for a Complete NUOPC Coupled Application
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< Fortran - NUOPCSingleModelWithDriver/DRV.FS0 - Eclipse

i mif B-4/ - & B A BIE-S i ®E P
.ol - (ouickAccess  |i| & B c/cs+ [ Fortran)
[ Project Explorer = O [ DRV.FO % = g @mu " = 0
8% N muduie DR\1/ ! ‘ : ‘ ‘ ‘ ’ ‘ ¢ ‘ :

v & NUOPCSingleModelwithDriver » & NUOPCSingleModelv
use ESMF

1
2
3
> A
DRV.F30 4 use NUOPC
» [d MODEL.FS0 5 use NUOPC Driver, &
6

» [@ singleModelwithDriver.Foo driver SetServices => SetServices, &
driver label SetModelservices => label SetModelServices

[ makefile 8 use MODEL, only: MODEL SetServices => SetServices
£ singleModelwithDriver.aird g
n SingleModelWithDriver.nuopc 10 implicit mone

1

12 public SetServices

14 contains

15
16 subroutine SetServices(gcomp, rc)
17 type(ESMF_GridComp) :: gcomp
18 integer, intent(out) :: rc
19
20 rc = ESMF_SUCCESS
21
22 | NUOPC Driver registers the generic methods
23 call NUOPC_CompDerive(gcomp, driver_SetServices, rc=rc)
24 if (ESMF_LogFoundError(rcToCheck=rc, msg=ESMF_LOGERR PASSTHR
25 line= LINE , &
26 file= FILE )) &
27 return ! bail out
28
29 call NUOPC_CompSpecialize(gcomp, specLabel=driver label SetM
{}E Properties X = 0B
Erae ~
Property Value

3.5.1 Build the Skeleton Application Locally

The generated code can now be built using make and the generated Makefile. To build on the same system that Eclipse
is running (this is the easiest way), first ensure that ESMF v7 is installed.

The environment variable ESMFMKFILE needs to be set to the location of the esmf.mk file in the ESMF installation
directory. It is in the same directory with the ESMF library file(s). (More info on the esmf.mk file is available in the
ESMF User Guide.)

To set the ESMFMKFILE environment variable in Eclipse, right click on the project folder in the Project Explorer

and select Properties from the context menu. Select Fortran Build -> Environment in the list on the left and add a
new environment variable. Set the name to ESMFMKFILE and the value to the location of the esmf.mk file on your

system. Click OK when done.

x Properties for NUOPCSingleModelwithDriver

[type filter text ] Environment o . L.
> Resource
Builders Configuration: | Cupid Configuration [ Active] ~ || Manage Configurations...

»  C/C++Build

»  C/C++General

v FortranBuild Environment variables to set Add...
Build Variables Origin

Variable Value
Select..
certi cwp /homej/roc 1 UOPCSi ithDri BUILD SYSTEM e
ettings 7
B lci it ESMFMKFILE ~/ESMF-INSTALLS/ESMF_7_0_0/lib/libo/Linux.gfortran.64.openmpi.default/esmf.mk  USER: CONFIG Edit..
00l Chain Editor e
PWD home/rock iy llel-1 ' UOPCSingl ithDri BUILD SYSTEM
> Fortran General [home! Delete
Linux Tools Path Undefine
Project References —
Run/Debug Settings
b Task Repository
Task Tags
»  Validation
wikiText
© Append variables to native environment
Replace native environment with specified one
Restore Defaults Apply
@ B Cancel oK

To build from within Eclipse, find the Make Target view on the right side and double click the “all” target. If the Make
Target view is not shown, you can bring it up by selecting Window -> Show View -> Make Target from the menu.
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Fortran - NUOPCSingleModelWithDriver/Makefile - Eclipse
[mi] 52 ® -] & B0 -i& @ e EH ik 0 8B F i
(5 Project Explorer 22 = a LoMakefile 3 = O
% - 1# Auto-generated Makefile for NUOPC Application: SingleModelWithDrivel
2
#5 NUOPCSingleModelwithDriver 3# This Makefile was generated by Cupid on 2016-84-19 15:43:32.
» [& DRV.F30 4# https://earthsystencog.org/projects/cupid/
» [2 MODEL.F90 o
>[4 sit F90 7
Makefile 8## This Makefile must be able to find the "esmf.mk" Makefile fragment
e 9## 'include’ line below. Following the ESMF User's Guide, a complete |

10## installation should ensure that a single environment variable "ESMI
11## is nade available on the system. This variable should point to the
12## "esmf.mk" file.

13##

14## This example Makefile uses the "ESMFMKFILE" environment variable.
154

16## If you notice that this Makefile cannot find variable ESMFMKFILE ti
17 ## please contact the person responsible for the ESMF installation on
18## systen.

19## As a work-around you can simply hardcode the path to "esmf.mk" in
20## include line below. However, doing so will render this Makefile a
21## flexible and non-portable.

[2 singleModelwithDriver.aird
1 singleModelwithbriver.nuopc

23
24ifneq ($(origin ESMFMKFILE), environment)

25 $(error Environment variable ESMFMKFILE was not set.)
26 endif

27
28 include $(ESMFMKFILE)
29

31

Property Value

G
® @ c/c++ [ Fortran|

[Quick Access |

g2 Outline © Make Target 22 = 0
@ & =
v & NUOPCsingleModelwithDriver
5 settings
1
clean
dust
= o

I Properties &2

The output from the build will be shown in the Console view at the bottom. The last file built will be the executable

and it is typically named the same as the project itself.

Fortran - NUOPCSingleModelWithDriver/Makefile - Ec!

K ®- K@ B0 A B H k0 QS B
(5 Project Explorer 22 = a LoMakefile 3 = O
g% - 1# Auto-generated Makefile for NUOPC Application: SingleModelWithDrivel
2
NUOPCSingleModelwithDriver 34# This Makefile was generated by Cupid on 2016-84-19 15:43:32.
» [ DRV.F90 4# https://earthsystemcog.org/projects/cupid/
» [2 MODEL.F90 o
» [g it F90 7
[ drv.mod 8+## This Makefile must be able to find the "esmf.mk" Makefile fragment
§ 9## 'include' line below. Following the ESMF User's Gujde, a complete |
[ DRV.0 10## installation should ensure that a single envmnmei} variable "ESMI
L& Makefile 11## is made available on the system. This variable should point to the
12## "esmf.mk" file.
[@ model.mod 130
[&@ MODEL.o 14 ## This example Makefile uses the "ESMFMKFILE" environment variable.
15 ##

singleModelwithbriver
singleModelwithbriver.aird
1 singleModelwithriver. nuopc
singleModelwithDriver.o

16+## If you notice that this Makefile cannot find variable ESMFMKFILE ti
17+## please contact the person responsible for the ESMF installation on

& -

® B c/c++ [ Fortran|

[ Quick Access

Make Target 2 = 0

@ &
v & NUOPCsingleModelwithDriver
= settings

clean
dust

[l Bookmarks [ Properties

[£2 Problems | & console % |[€ Fe [ Forts

DT Build Console [NUOPCSingleModelwithbriver]
:18:

make -k all

mpif9e -c -0 -fPIC

mpif9e -c -0 -fPIC

mpif9e -c -0 -fPIC

mpif9e -m64 -mcmodel=small -pthread -Wl, --no-as-needed

-m64 -mcmodel=snall -pthread -ffree-line-length-none
-m64 -mcnodel=small -pthread -ffree-line-length-none
-mb4_-mcmodel=snall -pthread -ffree-line-length-none

16:18:23 Build Finished (took 4s.976ms)

¢ e@ = a

18 *+++ Build of configuration Cupid Configuration for project NUOPCSingleModelWithDriver *+++

-fopenmp -I/home/ rocky/ESMF-INSTALLS/ESMF 7 ©_8/mod/mod

-fopenmp -I/home/ rocky/ESMF-INSTALLS/ESMF 7 6 8/mod/mod

-fopenmp -I/home/ rocky/ESMF-INSTALLS/ESMF 7 ©_8/mod/mod

-fopenmp -L/home/rocky/ESMF- INSTALLS/ESMF 7 @ _6/1ib/1ib0/Linux.gfortran.6

3.5.2 Set up a Parallel Application run and Execute Locally

To execute the application on the same system on which Eclipse is running (again, this is the easiest way), set up a
Parallel Application run configuration by selecting Run -> Run Configurations... from the menu. The configuration
will be dependent on the MPI distribution on your local machine, but you should use the same MPI distribution
that was used to compile ESMF. On the Application tab, you need to select the location of the executable that was

generated.
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& Run Configurations

Create, manage, and run configurations

Create a configuration to launch a parallel application @
CEBxX B3~ Name: | NUOPCSingleModelwithDriver
'type filter text @ |||(8 Resources[B Application . = Arguments | B Environment| Synchronize| ] Common

[El¢/c++ Application oisc )

[ElFortran Local Application NUOPCSingleModelwithDriver Browse:

& Launch Group Application program:

i} Parallel Application '/homym(ky/wl. T

1 /NUOPCSingl. ithDriver/Singl \withoriver | [ Browse
! NUOPCSingleModelwithDriver

¥ SystemTap "] Copy executable from local filesystem

Path to local executable:

Browse
Display output from all processes in a console view
Re t Apply
Filter matched 6 of 6items s REVETL || e AROY s,
©) DY Close Run

After configuring the parallel run, click Run and you will see output from the run in Console. ESMF log files will also
be generated, one per process. These are named PETX.ESMF_LogFile. If you do not see the log files immediately
after the run, right click on the project folder and select Refresh from the context menu.

& Fortran - NUOPCSingleModelWithDriver/Makefile - Eclipse
0. /B B0 R B R Bt O @ 5 & B - ot G -
[QuickAccess  |i| B i c/cs+ [ Fortran)
(5 Project Explorer 22 = o LoMakefile 3 = O (® Make Target 2 = o
B & - | = Auto-generated Makefile for NUOPC Application: SingleModelWithDrive( ¢ @ & =
#3 NUOPCSingleModelWithDriver 3# This Makefile was generated by Cupid on 2016-64-19 15:43:32. v NUOPCSingleModelwithDriver
» [8 DRV.FS0 4# https://earthsystencog.org/projects/cupid/ & settings
5
B si thriver. 90 7 ®clean
8## This Makefile must be able to find the "esnf.mk" Makefile fragment ®
[ drvmod 9# ‘include’ line below. Following the ESMF User's Guide, a complete | ©dust
[ DRV.o Atimm nlail A ameiiea thad A cimale amudsanmant simmiahla LCCH
[ Makefile
[@ model.mod = console 2 = O
5 MODEL.o x% a@eE® »2-o-
[E) PETO.ESMF_LogFile i UOPCSi ithDriver [Parallel Ap plication] Runtime process 25dd5087-c119-4716-92b5-9c2ebd073d73
[2 PET1.ESMF_LogFile #PTP job_id=1824
2 PET2.ESMF_LogFile - Advancing MODEL from: 2016 6 1 © © HHIS
[Z PET3.ESMF_LogFile o
= Si il i 015
2 singl iver.aird s
@ si nuops o
i o 030
0
0 45
0
10
o b

0
1 0
0

1 0
0

1 0
0

1 0
0

1 0
0

1 0
o o
1030 0
0

1 0
0

1 0
0

1 0
0

1 [}
0

1 0
0

1 0

& NUOPCSingleModelwithDriver

3.6 Show the NUOPC Reference Manual

The NUOPC Reference Manual can be shown directly within Eclipse so that you do not need to leave the tool to read
API documentation. To open the NUOPC documentation viewer, either click on the Show NUOPC Doc View button
in the toolbar or from the menu select Window -> Show View -> Other and select the NUOPC Doc view in the list.

If you select a component in the NUOPC View, the documentation viewer will synchronize with the selected item. For
example, if a NUOPC Mediator component is selected in the NUOPC View outline, the documentation viewer will
bring that part of the Reference Manual into focus.
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Fig. 3.17: Click the blue book in the toolbar to show the NUOPC Reference Manual.

{2 Problems B Console [& Fortran Declarati [£i Fortran Analysis/ LIl Bookmarks | Bl NUOPC Doc &2 |% Connections = O

3.1 Generic Component: NUOPC_Driver 3

MODULE:

module NUOPC_Driver

DESCRIPTION:

Component that drives Model, Mediator, and Connector components. For every Driver time step the same
run sequence, i.e. sequence of Model, Mediator, and Connector rRun methods is called. The run sequence is
fully customizable. The default run sequence implements explicit time stepping.

SUPER:

ESMF_GridComp

USE DEPENDENCIES:

use ESMF

Fig. 3.18: The NUOPC Reference Manual is opened in a small browser built into Eclipse.
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