
Read the Docs Template
Documentation

Release latest

Read the Docs

Dec 03, 2018





General

1 FAQ 1

2 License 5

3 Installation Guide 7

4 Uninstallation 15

5 Translation 17

6 My Account 21

7 Upgrade Guide 27

8 Purchase, Payment and Invoices 31

9 Supports 33

10 Add Multiple Products to Cart 35

11 Admin Product Preview Plus 39

12 Advanced Search & Fast Auto Complete 43

13 Auto Invoice 45

14 Checkout Success Page 49

15 Configurable Product Matrix View 57

16 Configurable Product Table Ordering 61

17 Customer Group Without Tax 73

18 Defer JavaScript 77

19 Delete Order 85

20 Full Page Cache 91

i



21 Google Tag Manager 97

22 Improved Newletter 99

23 Lazy Image Loader 101

24 Limit Order Quantity per Category 107

25 Limit Order Quantity per Product 111

26 Minimum Order Amount for Customer Group 115

27 Minimum Quantity of Configurable Product 119

28 Minimum Amount for Category 121

29 Multiple Store View Pricing 127

30 Order Delivery Date 139

31 Percentage Tier Price 147

32 Pro Configurable Product Grid Table View 151

33 Redirect Cart to Checkout Page 165

34 Reorder Product 167

35 Rich Snippets 171

36 SEO Layered Navigation 173

37 Shipping Method for Category 179

38 Shipping & Payment Methods Per Customer Group 185

39 Shopping Cart Rule per Store View 191

40 Store Locator 197

41 Unboxed 207

42 Wholesale Fast Order 219

43 Add Multiple Products To Cart 229

44 Admin Product Preview Plus 233

45 Ajax Add To Cart 243

46 Ajax Social Login 249

47 ANZ eGate payment Gateway 265

48 Auto Invoice 269

49 Catalog Price Rule per Store View 273

50 Checkout Custom Field 281

ii



51 Checkout With Display Currency 283

52 Configurable Grid Table View 289

53 Configurable Product Wholesale Display 293

54 Custom Option Image 301

55 Defer JavaScript 305

56 Delete Order 309

57 Dynamic HTML Sitemap 315

58 Frequently Bought Together 319

59 Frontend Cancel Orders 331

60 Google AMP 337

61 Grouped Product with Custom Options 351

62 Hide Price/ Call For Price 355

63 Image Gallery 365

64 Infinite Scroll 373

65 Lazy Load 377

66 Limit Cart Quantity 381

67 Minimum Order Amount For Customer Group 385

68 Min/Max Order Quantity per Category 389

69 Multiple Store View Pricing 393

70 Multiple Wishlists 403

71 One Step Checkout 405

72 Order Delivery Date 409

73 Previous/Next Product Page 417

74 Quick View 419

75 Reorder Product List 423

76 Shipping and Payment Method for Customer Group 425

77 Shopping Cart Price Rule per Store View 429

78 Simple Details on Configurable Products 435

79 Wholesale Fast Order 441

80 Topics 447

iii



iv



CHAPTER 1

FAQ

1.1 Magento Extensions

1.1.1 Do your extensions support multiple domains?

One extension is used for only one domain and if you want to use for other domains, you have to purchase this
extension again.

1.1.2 What Magento Editions/Versions is compatible with?

Please note Magento 1 and Magento 2 are separate products and if you purchase an extension today, you have to select
whether you want to purchase it for Magento 1 OR Magento 2. If you purchased a Magento 1 extension, you will need
to re-purchase the extension for Magento 2, as Magento 2 is a completely new system and not a simple upgrade. All
our extensions had to be developed from scratch for Magento 2

Our Magento 1 extensions are compatible with:

Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

Enterprise:1.12.x.x, 1.13.x.x, 1.14.x.x

Our Magento 2 extensions are compatible with all current versions of Community and Enterprise

1.1.3 What browsers are your Magento extensions compatible with?

Our extensions are compatible with all popular browsers such as IE, Safari, Google Chrome, Mozilla FireFox, Opera.

1.1.4 Can I request trial?

We do not provide trial versions for our extensions. However, we are happy to offer 30-day money back guarantee if
our extensions fail to function properly due to a bug and we cannot support to fix it. However, we always try our best
to assist customer in solving problems.
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1.1.5 How can I receive the updated version?

When BSSCommerce publishes new version of any product, please take notice of the release note tab in the product
page to get the update news about the new version. Customers purchased product from us can get the updated version
by contacting us via email; we will send the new package version once we receive this kind of request. In addition,
you can go to My Account -> My Downloadable Products to download the latest version of the extension.

1.1.6 Can I get the updated versions of extensions for free?

Yes, of course. However, please remember that we do not provide free service (including free support and installation
service) for updated versions.

1.1.7 Are your extensions compatible with 3rd-party extensions?

All of our extensions were tested in clean Magento installations without third party extensions and we can’t make
sure whether they are compatible with 3rd party extensions or not. Therefore, in case you are not sure about the
comparability of our extensions with other 3rd party extensions installed on your site in advance, please contact us for
more information before your purchase.

1.1.8 Are your extensions open sources or encrypted?

Our extensions are 100% open source code

1.2 Installation, User guide and Translation

1.2.1 How can I install the extension?

To install the extension by your own, please read Installation Guide and follow steps we instruct you from this detailed
document.

1.2.2 What should I do if I can’t install the extension?

In case you cannot install the extension, please contact us to ask for more support. We are willing to install it for you
based on our policy.

1.2.3 Do you offer free installation?

We offer Free Installation for all paid extensions on a domain only. Once requested, we will contact you by asking for
your site’s credentials (Admin information, FTP account).

However, Free Installation Offer is just valid for 3 weeks (15 working days) for each order upon the date of purchase.
After this period, we will charge the extra fee for this kind of service (basically $40/ an Installation Request). Free
installation is not applied on free extensions and updated versions.

1.2.4 Where can I get the user guide of extension?

Our detailed user guide with clear instructions is attached on the product page of each extension you bought from our
site or you also get user guide of each extension in this Wiki.
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1.3 License

1.3.1 Do your extensions have license keys?

Yes, each of our extension has a license key and the license key is used for only one domain. If you want to use the
extension for another domain, please purchase this module again for installing it to that new domain.

1.4 Payment, Invoice and Refund

1.4.1 What payment methods do you support?

We support PayPal as our payment method you can use to pay for the extension you purchase on our site.

1.4.2 How long does it take to receive my extension after purchasing?

When you finish your purchase, we will immediately send you an email including download link for you
to get the module. In addition, the link for downloading your paid extension will be provided for you
in your account. Please go to My Account -> My Downloadable Products to see the available link and
download the extension.

1.4.3 How can I get my Invoice?

Your invoice is sent to your email after you finish your payment

1.4.4 Can I ask for refund after purchasing your extensions?

You absolutely ask for refund after purchasing our extension as long as the number of your purchase days does not
excess 30 days because we only make refund for customer for a period of 30 days since the date you completed orders
on our site.

1.4.5 What cases can I get refund?

If you are not satisfied about our extensions because our extensions do not function properly, you can ask for refund
for the period of 30 days since the purchase date.

For more details, there are some cases you can get money return such as: Your site faces to some conflicts or bugs
caused by our extensions, not modules of other Magento providers. In this case, you have to provide us access to your
site to fix and if we cannot fix problems for you, you will be refunded. In addition, you cannot receive refund from us
in the following cases:

• You do not give access account for us to fix bugs if our extension causes these bugs for your site

• The period for 30 – day money back is expired

• You do not purchase the right extension that you tend to buy.

• The extension does not have functions as you want and these functions are not written in the description.

• The incompatibility with third party extensions unless we confirmed compatibility with the specific extensions
before your purchase.

1.3. License 3
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• Installation services, conflicts resolution and customization services are not refundable

1.5 Some common conflicts/bugs
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CHAPTER 2

License

This license agreement is an agreement between BSSCommerce and you (the person or company who is being licensed
to use extensions). The agreement applies to all extensions and services you purchase from us.

When you buy and use our products, you acknowledge that you have read this agreement and agree with all the content
and terms of the agreement and comply it seriously.

This agreement takes effective at the moment when you order extensions from our site or receive it through email or
on data medium or by any other means.

1. License

This agreement gives you the right to use only one license for one extension to install for your site. This license
remains valid until when you do not want to continue using the module and uninstall from your Magento site or you
break terms of the agreement. In addition, when you want to install the extension for another domain, you are required
to purchase this extension again.

You just own a copy of extension to install for you site. Therefore, you are not allowed to distribute our extension for
any third parties for non-commercial or commercial purposes without our permission. Every distribution by your own
decision is regarded as the violation of this Agreement and entails liability, according to the current law.

You may not use any part of the code in whole or part in any other software or product or website.

You may not give, sell, sub-license, rent, lease or lend any portion of our extensions to anyone. You may not place the
extension on a server so that it is accessible via a public network such as the Internet for distribution purposes.

2. Termination

In the issue of termination, if you fail in the compliance with terms and conditions of this License Agreement such
as any violations of the agreement, BSSCommerce will terminate this license at any time. Your license to use our
extension is revoked and you must destroy all copies of the extension on your site.

After we give you a notice of license termination, if you continue to use the module, you hereby agree to accept an
injunction to enjoin you from its further use and to pay all costs (including but not limited to reasonable attorney fees)
to enforce our revocation of your license and any damages suffered by us because of your misuse of the extension. In
addition, we are not bound to return you all amount spent on the purchase of the extension for the termination of this
license.

3. Limitation of Liability
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BSSCommerce are not responsible for any damages on your site such as loss of profits/saving or loss of information
which are not caused by the use of our extension. We are not also liable for any prosecution arising from use of the
extension against law or for any illegal use.

4. Laws

We are the copyright holder of the extension. The module or a portion of it is a copyrightable matter and is liable to
protection by the law. Any activity that infringes terms of this Agreement violates copyright law and will be prosecuted
according to the current law.

In case you are holding an invalid license, we will reserve the right to revoke the license

6 Chapter 2. License



CHAPTER 3

Installation Guide

3.1 Installation Guide for Magento 1 Extensions

Step 1:

When you finish purchasing process, we will immediately send you an email that includes the link to download the
extension. On the other hand, you can log in your account, in My Downloadable Products section, click on Download
Link to download the extension.

Step 2:

The file that you download is normally a zip file. Then, please properly unzip that file before installing it.

Step 3:

Turn off Magento Compilation by navigating to System-Tools-Compilation or you can try to use following command
line to disable it

7
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php -f shell/compiler.php – clear

Step 4:

It’s required to disable cache in the administration panel of your site. Go to System/Cache Management. Select all
caches and click “Disable” then submit.

Step 5:

Use FTP client (such as Filezilla, WinSCP, cuteFtp) to upload or copy all folders in the zip package to your Magento
site root folder. This will not overwrite any existing file; just add new files to the folder structure.

Step 6:

After uploading is done, log in your Magento administration panel to refresh cache. Go to System/Cache Manage-
ment. Select all caches and take action “Refresh” then submit.
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Step 7:

Navigate to System/Configuration, if you can see the extension tab, it isinstalled properly.

*Note: Some extensions don’t have Configuration in BSSCOMMERCE section of CATALOG tab. Therefore, please
take a look their User guides for better usage.

Step 8:

Now if you get Access denied error when click on the extension tab, you need to log out admin panel and log in again.

Step 9:

3.1. Installation Guide for Magento 1 Extensions 9
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Check everything in front-end and try to process, make sure that the extension is successfully installed and well
compatible with your site.

*Note

After purchasing it, you should add our skype account at support.bsscommerce to contact us if you cannot install
the extension by yourself. BSS Support Team will help you to install the Magento module and the installation
fee will follow our Terms and Condition in Installation Policy section. Further assistance is available via Email
and Skype. In case, you have followed all above steps but the extension doesn’t work properly, you can delete the
file or change the module’s filename extension to keep your website function as normal. Then please contact us at
support@bsscommerce.com or Skype: support.bsscommerce. Our supporters will assist you in resolving any issues
within 24 hours. You also can see the example about installation guide for Checkout Success Page exention’s video
below:

3.2 Installation Guide for Magento 2 Extensions

Step 1:

Unzip the file

Step 2:

Create another directory called app/code/Bss/MODULENAME/ where MODULENAME must be replaced by the
modules internal identifier. You can find it in the “composer.json” file in the extension ZIP file you downloaded, look
at the node “psr-4”.

For example, it could say “Bss\AjaxCart" or “Bss\OneStepCheckout" there, then the MODULENAME is the part
after \ and before \, so in our examples AjaxCart” or “OneStepCheckout”. This is what you call the directory, then, for
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example app/code/Bss/AjaxCart, and you put the contents of the extension ZIP file in there.

Step 3:

Upload the directory app/code/Bss/MODULENAME/ into the root directory of your Magento installation. The root
directory of Magento is the directory that contains the directories “app”, “bin”, “lib” and more. All directories should
match the existing directory structure.

3.2. Installation Guide for Magento 2 Extensions 11



Read the Docs Template Documentation, Release latest

Step 4:

Go to Magento 2 root directory.

Run: php bin/magento setup:upgrade

Step 5:
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Run: php bin/magento setup:static-content:deploy

Step 6:

Clear all Cache

*Note

If you have installed our extension via composer, please remove the module totally in vendor folder, delete line of
module in composer.json and execute composer update before installing the updated version according to the guide
above.

After purchasing it, you should add our skype account at support.bsscommerce to contact us if you cannot install
the extension by yourself. BSS Support Team will help you to install the Magento module and the installation
fee will follow our Terms and Condition in Installation Policy section. Further assistance is available via Email
and Skype. In case, you have followed all above steps but the extension doesn’t work properly, you can delete the
file or change the module’s filename extension to keep your website function as normal. Then please contact us at
support@bsscommerce.com or Skype: support.bsscommerce. Our supporters will assist you in resolving any issues
within 24 hours.

Installation guides for Magento 2 extensions purchased from Magento Marketplace

You can also see an example about the installation guide of Quick View for Magento 2 extension in the following
video:

3.2. Installation Guide for Magento 2 Extensions 13
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CHAPTER 4

Uninstallation

How to uninstall magento 2 extension?

Here’s our steps to uninstall this module:

Step 1: Connect via SSH to your magneto installation and execute below commands:

php bin/magento module:disable <ExtensionProvider_ExtensionName> –clear-static-content php bin/magento
setup:upgrade

Step 2: Remove extension files:

cd app/code/<ExtensionProvider>/ rm -rf <ExtensionName>

!Note: If you are using more extensions from the same provider make sure not to remove the shared extension, most
providers use a shared extension or dependancy pack as a base for all their extensions.
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CHAPTER 5

Translation

5.1 Translation Guide for Magento 1 Extensions

To translate text in a custom module, you can use a language translation csv file.

Step 1: You access the app/locale/en_US/name_of_the_module.csv folder

• name_of_the_module.csv is the csv file of the module you want to translate

• en_US: This is the language folder. Remember that each site will have different language folders depending on
what languages are available on the site. The other site, for examples, uses Japanese, then its language folder
will be ja_JP. The module already contains US language folder.

After identifying the language folder of the site, you copy the name_of_the_module.csv file and paste it into the
language folder.

Step 2: You open the name_of_the_module.csv file

In this file, you will see all text of the module displayed in 2 columns like below:
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(This is an example when opening the Bss_FastOrder.csv file of Magento Wholesale Fast Order extension by BSS)

All you need to do is adding the translation in the right column corresponding to the content in left column

5.2 Translation Guide for Magento 2 Extensions

To translate text in a custom module, you can use a language translation csv file.

Step 1: You access the app/code/Bss/name_of_the_module/i18n/en_US.csv folder

• i18n: This is the language folder. Remember that each site will have different language folders depending on
what languages are available on the site. The other site, for examples, uses Japanese, then its language folder
will be ja_JP. The module already contains US language folder.

• Create a csv file in the app/code/Bss/name_of_the_module/i18n/ folder. For example: You create a file called
app/code/Bss/extensionname/i18n/fr_FR.csv

Step 2: You open the fr_FR.csv file

In this file, you will see all text of the module displayed in 2 columns like below:
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(This is an example when opening the Bss_FastOrder.csv file of Magento Wholesale Fast Order extension by BSS)

All you need to do is adding the translation in the right column corresponding to the content in left column

5.2. Translation Guide for Magento 2 Extensions 19
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CHAPTER 6

My Account

6.1 Change or reset your password

Your password is the key to not only logging into your account, but also to changing your private information such
as username or email address and your account setting. Therefore, it is vital that you keep your passwords safe. This
guided assistance article will help you change your password for security reasons or reset it if you forget it.

6.1.1 1. Change your password

Step 1: Go to Login/Register.

Step 2: Under “REGISTERED CUSTOMERS”, fill in “Email Address” and “Password” blank, then click Login.
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Step 3: In Account Dashboard/Account Information, choose CHANGE PASSWORD
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Step 4: Enter Current Password, New Password, and Confirm New Password, then click Save.

6.1.2 2. Reset your password

Step 1: Go to Login/Register.

6.1. Change or reset your password 23
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Step 2: Under “REGISTERED CUSTOMERS”, choose “Forgot Your Password?”

Step 3: Enter your email address that you registered before into the blank, the click Submit.

Step 4: Check your email. A request confirmation email will be sent to your email, with a link to reset your password.
Follow the link that you receive (if clicking the link does not work, please copy and paste the URL into your browser
instead).
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Step 5: Enter your New Password and Confirm New Password, then click Reset a Password.

*Note:For security, password reset links become invalid once used.

We hope this article is helpful for you. If you don’t succeed in changing or resetting your password, please feel free to
contact us for any further assistance.

Skype: support.bsscommerce.

Email: support@bsscommerce.com

Tel: +84 983513599

6.1. Change or reset your password 25



Read the Docs Template Documentation, Release latest

26 Chapter 6. My Account



CHAPTER 7

Upgrade Guide

7.1 Update Module in Magento 1 Manually

Update module via FTP

Extract module’s file, place this file into code folder of Magento site:

Log into backend, flush Magento cache and check the module function after updating. In case you want to completely
uninstall the old module before updating, follow these steps:

Step 1: To disable module, edit this file

/app/etc/modules/<your_module>.xml;

Replace <active>true</active> by <active>false</active>;

Step 2: Delete all mysql tables created by the module
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Step 3: Delete the module in the core_recourse table

Step 4: Delete files in the <project_root>/var/cache folder

Step 5: Refresh Magento site and the module has been removed successfully

Then put the code of the module to site’s folder via ftp as mentioned above and flush Magento cache

7.2 Update Module in Magento 2 Manually

I. Extension Update via FTP/SSH

If you have an odd extension on your Magento 2, update the module manually following the steps below.

Step 1: Connect to the root of your Magento 2 installation (the folder contains the extension folder) via SSH:

Step 2: Remove the module files using the command:

cd app/code/<VendorName>/

rm -rf <ComponentName>

Step 3: Update module latest version

Put code module into app/code/<ExtensionProvider>/<ExtensionName>

(<VendorName>/<ComponentName> find in file composer.json )

Apply the commands to install it:

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy

php bin/magento cache:flush

Finally you should check again the function of module

II. Extension Update via Composer

The extension update process is the same as the module installation process. To update the extension, simply execute
the command:

composer update <composer_name>

Instead of the ‘composer_name’ please specify the corresponding module name which is indicated in your customer
account. This command updates only the last two version numbers: e.g. 1.x.x ( only x.x will be updated).
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To update the version from 1.x.x to 2.x.x you need to execute the following command:

composer require <composer_name> ^x.0.0 –update-with-dependencies

Where x corresponds to the first version number. For example, to update the Improved Layered Navigation Extension
for M2 from the 1.x.x version to the 2.x.x version you need to execute the command:

composer require bsscommerce/defer-js ^2.0.0 –update-with-dependencies

7.2. Update Module in Magento 2 Manually 29
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CHAPTER 8

Purchase, Payment and Invoices

1. Purchase process

Step 1:

Choose your wanted extension with edition and quantity and then Click “Add to cart” button

Step 2:

Check again the extension along with quantity and total amount in the shopping cart page.

• You can edit your purchase by clicking Edit and then Click Update Shopping Cart. If you
want to continue shopping, please click to “Continue Shopping” to come back our Homepage.

• Enter discount code if you are provided

• After that, please click “Proceed to Checkout” button to redirect to the checkout page
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Step 3:

• Fulfill all required information in the Name & Address section

• Enter discount code if you have not yet used it in the shopping cart

• Review your order carefully

• Click “Place Order” button

Step 4:

After you click “Place Order” button, you will be redirected to PayPal website to complete your payment
here.

2. Payment

We provide customers PayPal as our payment method to purchase extensions from our site

3. Invoices

After you finish your payment, the invoice will be sent to your email with order information.

32 Chapter 8. Purchase, Payment and Invoices
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Supports

BSSCommerce offers Free 1-year support for all customers when purchasing Magento extensions.

Please notice that we just provide support for only a domain for each purchasing time of customers. Support includes
answering any question related to our products and fixing any bug/error caused by our products which is reported by
customers to make sure it works well as the demo version. Support does not include customizing our product to fit
your own needs; with any request for customization will require extra fee. Free support service is just applied on paid
products. Please notice that we do not offer free support for free extensions, that means if customers ask for any kind
of support for a free extension, there will be extra fee for this kind of service. Customer can contact for support by
Email, sending Ticket or through our Live Chat. Please kindly understand all support request on weekend will be
processed when we’re back to office on next Monday (GMT+7).

Email: support@bsscommerce.com

Skype: support.bsscommerce

Live Chat

There is a note that when you contact us for fixing bugs on your site, please provide us access to your website (including
Admin account and FTP information) so that we are able to support you as soon as possible.

33
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CHAPTER 10

Add Multiple Products to Cart

10.1 User Guide

10.1.1 Magento Add Multiple Products to Cart Extension Overview

As you know, Magento default does not allow customers to add many products to carts at one time in the product list
pages such as category pages and search result pages. Therefore, customers cannot order their desired products with a
large quantity when they do not want to visit each product page one by one because it is very time-consuming.

Magento Add Multiple Products to Cart is developed by BSSCommerce to solve this issue and bring better shopping
experience for customers. By allowing customers to add multiple items to cart with various quantities at once, they
can save a lot of time with the quicker order process than the normal one and also store owners can increase sales well,
especially when target customers are wholesalers.

10.1.2 How does Magento Add Multiple Products to Cart Extension work?

You go to System -> Configuration -> Add Multiple Products to start making configuration.

35
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In Enable:

• Choose Yes to enable the module

• Choose No to disable it

In Add Lib jQuery:

• Choose Yes to add Library jQuery if your site doesn’t have it

• Choose No if your site already have it

In Validate bug: in this field, you will select the way to notify errors occurring when customers add products to cart.

• If you choose Yes, a popup of error notification will appear when customers add to cart products without select-
ing custom options or when no products are added to cart

• If you choose No, error notification will be displayed in the shopping cart for products that customers do not
select custom options for them. Other products are still added to cart.
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In Category: you select categories that you want to apply this module to. It means that when you choose a category,
customers can add multiple products belonging to this category to cart

In Custom Option Product:

• Choose Yes to enable the function of adding multiple products to cart for products with custom options

• Choose No to disable this function for products with custom options

Next, you can choose product types to apply this module:

In Downloadable Product:

• Choose Yes and customers can add multiple downloadable products to cart

• Choose No and there are not check box and quantity box for this product type. It means that customers cannot
also add downloadable products along with other product types

In Configurable Product:

• Choose Yes and customers can add multiple configurable products to cart

• Choose No and there are not check box and quantity box for this product type. It means that customers cannot
also add configurable products along with other product types

In Bundle Product:

• Choose Yes and customers can add multiple bundle products to cart

• Choose No and there are not check box and quantity box for this product type. It means that customers cannot
also add bundle products along with other product types

Finally, you click Save Config and see changes in the frontend.

10.1. User Guide 37
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10.1.3 Note

Magento Add Multiple Products to Cart Extension does not work with pagination of product list pages. It means that
if customers select multi products in page 1, they can add all of these products to cart in only page 1, not in other pages

10.2 Compatibility

Our Add Multiple Products to Cart is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

10.3 Changelog

10.4 FAQs
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CHAPTER 11

Admin Product Preview Plus

11.1 User Guide

11.1.1 Magento Admin Product Preview Plus Extension Overview

Magento Admin Product Preview Plus Extension by BSSCommerce helps administrators to check out the front end
page right from Magento admin by just some clicks without saving any configuration. This extension adds preview
buttons in Product grid view and Product Edit Page to view the frontend product page directly in the backend. It allows
accessing customer and product information easily by clicking to the product and customer names. Magento Admin
Product Preview Plus Extension also provides preview buttons in Category and CMS page for linking to the front end
of Category and CMS page quickly. Especially, this extension links to shipping address by Google Map to locate
customer positions and optimize shipping process.
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11.1.2 How does Magento Admin Product Preview Plus Extension work?

1. Add Product Table And Customer Link

In Enable: Choose Yes to make product table, customer link and product link active or choose No if you want to
deactivate them

In Title of product table: You name your own title for product table as your wish

In Add columns in product table: You choose columns that you want to add to the product table such as SKUs,
names, images and so on

In Filter Products: You can select Product names or Product SKUs to filter products

In Sort Table: You choose the column to sort and the product table will be displayed behind this column.

In Type of product link: You can choose to link to Frontend or Backend page

In Open link with pop up: Choose Yes to open link in a pop up and choose No to open in a new tab [Please note that
this function just applies for product link (in order grid and order view ) and customer link]

In Add customer link: Choose Yes to display customer links in the column “Billing name” or choose No to exclude
them.
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2. Add Button Preview

In Button view CMS page: Choose Yes to add preview buttons in Admin-CMS page or choose No to disable them.
Please remember that in case CMS page status is Disable, the buttons will not be active.

In Button view Category page: Choose Yes to add preview buttons in Admin-Category page or choose No to disable
them. Please remember that in case the category is not active, the button will not be available to use.

In Button view Product page: Choose Yes to add preview buttons in Admin-Product Edit Page or choose No to
disable them. Please remember that in case Product status is Disable or Not Visible Individually, the button will not
be active.

In Add column View product: Choose Yes to add a column of View product to Admin-Product Grid View or choose
No to disable them. Please remember that in case Product status is Disable or Not Visible Individually, the link will
not be shown in the column.

3. Google Map For Shipping

In Active Google Map: Choose Yes to link to shipping address by Google Map or choose No to disable this function.

11.2 Compatibility

Our Admin Product Preview Plus is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

11.3 Changelog

First Release: v1.0.0
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11.4 FAQs
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CHAPTER 12

Advanced Search & Fast Auto Complete

12.1 User Guide

12.1.1 Advanced Search and Fast AutocompleteOverview

Everybody knows how important is make customers find what they want faster, it’s an important part of any ecommerce
system because it seems impossible to show all products with full details to customers at the same time. With a
powerful search tool, a web-store can increase selling chance as well as customer ease of use. Magento by default use
a simple searching function which takes a long time to show the entire search result page and does not provide most
relevant results at first case.

On average, 15% of visitors use the product search in online store. These are the visitors who know what they want
and are looking for it to buy, which brings about half of orders to your shop. Therefore, the sales of online store depend
on whether a website search is able to quickly find a proper and satisfying goods and services. BSS Magento Search
and Fast AutoComplete Extension will effectively deal with this issue.

12.1.2 How does Advanced Search and Fast Autocompletework?

As an admin, you can set up your own store page by the most effective way that supports your trading objective. To
polish the website configuration:

• Step 1: Go to Admin Panel -> System ->Configuration.

• Step 2: At the left side of the page, find BSS COMMERCE -> select Advanced Search + FastAutoCompelete.

You can select between enable and disable Advanced Search and Fast Autocomplete Extension by selecting Yes/ No
in Enabled Module box.

There are 6 sections for admin to continue configuring the extension: Enable search categories, Enabled jQuery,
Search by, Autocomplete minimum characters, Max results to show products, Max result to show categories.

1. Enabled searchcategories

Choose Yes to enable searching by category
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2. EnabledjQuery

Choose Yes to enable jQuery of module

3. Searchby

In this field, you can configure which attributes of product will be used to search product. Click to “Add” button to
add more attribute, then choose attribute name from dropdown selection. Type a number in “Weight” box for each
attribute. Search results will be sorted from high to low weight.

4. Autocomplete minimumcharacters

Type a number to this box to set up the minimum number of characters before displaying autocomplete result

5. Max results to showproducts

Type a number to this box to set up the maximum of product will be shown when searching

6. Max results to showcategories

Type a number to this box to set up the maximum of category will be shown when searching

12.2 Compatibility

Our Advanced Search & Fast Auto Complete is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

12.3 Changelog

12.4 FAQs
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CHAPTER 13

Auto Invoice

13.1 User Guide

13.1.1 Magento Auto Invoice Overview

Magento Auto Invoice simplifies order status management which not only reduces significant admin works but also
satisfies customers? need. Customers always want the place order as fast as possible and at once. With Auto Invoice,
all status of orders will be automatically changed into “Complete” and invoices will accordingly be created. As a
result, Magento Auto Invoice will put an end of overload of manually creating an invoice too much for Magento Store
Owners.

13.1.2 How Magento Auto Invoice works?

Invoice Management

Step 1: After the orders has been successfully made with all required fields to be filled in, checking in your Sales-
>Invoices
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Step 2: Submit your wanted confirmed orders, choose “Action” status into “PDF” if you want to attach invoice PDF
files into the email. After submitting, Click “View” button!

Click “Send Email” and your customer will be successfully received it.
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Backend Configuration

Magento Auto Invoice is easily configured from backend by these steps:

Go to Backend-> system->configuration

Easily enable/disable the extension and select the suitable Payment Methods

Set enable or disable for automatic invoice and shipment generation in the same page as:

13.2 Compatibility

Our Auto Invoice is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

13.3 Changelog

13.4 FAQs
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CHAPTER 14

Checkout Success Page

14.1 User Guide

14.1.1 Magento Checkout Success Page Overview

Magento Checkout Success Page extension is a unique extension which allows admin to tweak the success page or
also called “thank you page” for better sales conversion.

The Success page, which appears when customer’s order process is accomplished, is often forgotten by many Magento
users. Interestingly, this page can be of much value when admin know how to make use of it properly. Our Checkout
Success Page Extension is designed with the hope to help you utilize the success page to empower your sale.

14.1.2 How does Magento Checkout Success Page extension work?

As an admin, you can set up your own store page by the most effective way that supports your trading objective. To
polish the website configuration:

• Step 1: Go to Admin Panel => System => Configuration

• Step 2: At the left side of the page, find BSS COMMERCE => select Checkout Success Page

After these 2 steps, a screen for configuration appears like the below picture:
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There are 6 sections for admin to continue configuring the extension: General, Order Information Section, Newslet-
ter Subscription Section, Cross Sell Block Section, CMS Block Section, Social Network Sharing Section.

1. General Settings

There are 2 options in box Enable: Yes and No.

• Choose Yes to enable the module and continue customizing on other sections.

• Choose No to disable this module.

2. Order Information Section
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There are 5 boxes appear in this section:

• Enable: Choose Yes to enable appearing order’s detail information on the Thank you page. Otherwise, choose
No.

• Sort Order: Insert appearing ordinal number of order information (E.g: if you insert “1” => order information
will appear first on the thank you page)

• Show Order Number: Choose Yes to enable showing Order number on the thank you page. Otherwise, choose
No.

• Show Order Button: Choose Yes to show View Order button for customer on thank you page. This button
allow customers view all their orders’ detail information when click on through a navigation.

The frontend will appear like this below picture:

*Note: Customers who check out as guests will not able to see View Order button.

• Custom Message: Insert your custom message which appears on the thank you page to inform that orders are
successful or being processed. (E.g: Your order has been processed)

After configuration, click on Save config button and reload the frontend to see the change.

3. Newsletter Subscription Section

There are 2 boxes appear for customization in this section:

• Enable: Choose Yes to enable appearing newsletter subscription on the Thank you page which allows customers
subscribe their email for your newsletter. Otherwise, choose No.

• Sort Order: Insert appearing ordinal number of newsletter subscription on the thank you page (E.g: if you
insert “5” => newsletter subscription will appear last on the thank you page)

The frontend will appear like this below picture:
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4. Newsletter Subscription Section

There are 3 boxes appear for customization in this section:

• Enable: Choose Yes to enable appearing cross sell block which shows related products on the Thank you page.
Otherwise, choose No.

• Sort Order: Insert appearing ordinal number of cross-selling products on the thank you page.

• Number of products displayed: Insert the number of related products you want to display on the thank you
page. (E.g: 3).

The frontend will appear like this below picture:
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5. CMS Block Section

There are 3 boxes appear for customization in this section:

• Enable: Choose Yes to enable appearing CMS block on the Thank you page. Otherwise, choose No.

• Sort Order: Insert appearing ordinal number of CMS block on the thank you page.

• CMS: Pick from the list the CMS block you wish to appear on the landing page.

E.g: If you choose “Electronics Landing”, the frontend will appear like this picture:
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6. Social Network Sharing Section

There are 3 boxes appear for customization in this section:

• Enable: Choose Yes to enable appearing Social Network Sharing on the Thank you page which allows customer
to share their orders on their own social pages. Otherwise, choose No.

• Sort Order: Insert appearing ordinal number of Social Network Sharing on the thank you page.

• Sharing Buttons Style: There are 3 options for admin to choose for the social icon appearances as wish: Large
icons, Small icons, Small icons with titles.

E.g: If choosing “Large icons” the frontend will appear like this picture:
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14.2 Compatibility

Our Checkout Success Page is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

14.3 Changelog

14.4 FAQs
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CHAPTER 15

Configurable Product Matrix View

15.1 User Guide

15.1.1 Magento Configurable Product Matrix View Extension Overview

Magento Configurable Product Matrix View Extension is one of three kinds of display for configurable products
which are developed by BSSCommerce . This extension helps administrators to create a matrix form for configurable
products with two attributes including unlimited custom options. Attributes are put in a column and a row and options
are combined together to make a complete children product. Moreover, stock numbers are displayed in the matrix
form to let customers know about product availability and also enable store owners take control in supplying products
timely.

With the help of Magento Configurable Product Matrix View, store owners can target wholesale customers effectively
because they can purchase your products in a large quantity without repeating this process. Therefore, owners will
have more chances to boost up their sales and retain customers for better shopping experience in the site. In addition,
this module is especially good for inventory management with stock numbers direct displayed in the matrix form.

15.1.2 How does Magento Configurable Product Matrix View Extension Extension
work?

You go to System -> Configuration -> BSSCOMMERCE -> Configurable Matrix View
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In Enabled: Choose Yes to enable the module or choose No to disable it in your site

In Enabled jQuery Library:

• Choose Yes to enable jQuery Library to run things related to jQuery.

• Choose No if your site already has jQuery Library already because it will cause some conflicts

In Display Stock Number:

• Choose Yes to show stock number in the matrix form

• Choose No to hide them

In Display Out of Stock Status:

• If you choose Yes, out of stock products are still shown in the matrix form and stock numbers are
equal to 0

• If you choose No, customer cannot choose these products due to no quantity box to select and also
stock number are not displayed.
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15.2 Compatibility

Our Configurable Product Matrix View is compatible with:

• Community: 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

15.3 Changelog

Version 1.0.0:

15.4 FAQs
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CHAPTER 16

Configurable Product Table Ordering

16.1 User Guide

16.1.1 Magento Configurable Product Table Ordering Extension Overview

Magento Configurable Product Table Ordering by BSSCommerce allows displaying configurable products in a very
simple table to help customers easily choose multiple products at once.

Magento Configurable Product Table Ordering displays custom options of the first attribute of configurable products
in a tab and custom options of the second one in a table. This brings customers the easier selection when they just
need to choose a custom option of an attribute first and then other corresponding custom options of the second attribute
will come out in a table with stock availability, stock number, out of stock status, tier prices, quantity and subtotal.
In addition, this extension also allows showing advanced tier prices in a separated table for children products with
the same tier prices and also functions for advanced tier price calculation for children products. In case, all children
products have different tier prices or at least a children product have different tier price from others, this extension will
show tier prices in the table.
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16.1.2 How does Magento Configurable Product Table Ordering Extension work?

In Enabled: Choose Yes to enable this module or choose No to disable it

In Enabled jQuery Library: Choose Yes/No to enable or disable it

In Display Stock Availability:

Choose Yes to show the column of Availability in the table

Choose No to exclude this column from the table

In Stock Number: If you choose to enable Stock Availability, you just choose Yes to show Stock number in the table
or choose No to hide Stock number. In case you choose to disable Stock Availability, Stock number is also not active.

In Display Out of Stock Status:

Choose Yes to display Out of Stock Status in the table

Choose No to exclude out of stock products from the table

In Show Subtotal:

Choose Yes to display the column of Subtotal in the table

Choose No to exclude it

In Advanced Tier Price:

Choose Yes to display Tier Prices in a separated table (Only apply to children products with the same tier
prices). Tier prices are shown as below:
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Choose No to display Tier Prices in the table (Please note that Tier prices are shown in the table when
children products have different tier prices or at least a children product has different tier prices from other
ones). In that case, Tier prices are displayed as below:
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In Advanced Tier Price Calculation:

If you choose Yes, Tier price is based on tier prices of total quantity of chosen children products
to calculate total amount

For example, tier price of buying 1-9 Pink-M shirts and 1-9 Pink-L shirts is similarly $210. Tier price of
buying 10-more Pink-M shirts and 10-more Pink-L shirts is $200. Therefore, when you buy 5 Pink-M
shirts and 5 Pink-L shirts, tier price is now determined as $200/shirt (Tier price of buying 10-more Pink-M
shirts and 10-more Pink ?L shirt). Total amount is now $2,000.
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If you choose No, Magento default Tier Pricing function will be used to calculate. It means
that total amount is calculated by tier prices of each children product multiply to total quantity
of each chosen children product.

For the above example, when using Magento default tier price calculation, total amount is
determined as $2,100,000 because it is calculated based on each tier price of each children
product (Tier price is equal to $210 shirt)
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In Show Unit Price: Choose Yes to show unit price in the table (Please note that Unit prices are shown in the table
only when products have fixed prices, not tier prices)

In Use Option Swatch: Choose Yes to enable Color Swatch function or choose No to disable it

In Show Detailed Qty Selected:

Choose Yes to display detailed quantity of selected products corresponding to each custom option in the
attribute tab as below:

66 Chapter 16. Configurable Product Table Ordering



Read the Docs Template Documentation, Release latest

Choose No to disable this function

16.2 Compatibility

Our Configurable Product Table Ordering is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

16.3 Changelog

Version 1.0.5:

• Fix bugs with special price

16.4 Common Problems

1. How to resolve conflict with Ajax Shopping Cart extension by Amasty?

https://amasty.com/ajax-shopping-cart.html

Edit file:

app/code/local/Amasty/Cart/controllers/AjaxController.php
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Add function: _initProduct();

Edit function indexAction() into:

public function indexAction()
{
$idProduct = Mage::app()->getRequest()->getParam('product_id');
$idProduct = Mage::app()->getRequest()->getParam('product')?

→˓Mage::app()->getRequest()->getParam('product'): $idProduct;
$IsProductView = Mage::app()->getRequest()->getParam('IsProductView');
$params = Mage::app()->getRequest()->getParams();
$related = $this->getRequest()->getParam('related_product');
unset($params['product_id']);
unset($params['IsProductView']);

if($this->getRequest()->getParam('configurable_grid_table') == 'Yes') {
$params = $this->getRequest()->getParams();
$config_super_attributes = $params['super_attribute_quickshop'];
$cart = Mage::getSingleton('checkout/cart');
$config_table_qty = $params['config_table_qty'];
$options = isset($params['options']) ? $params['options'] : null;

$qty_config = array();

foreach($config_table_qty as $sup_qty => $_super_qty) {
$qty_config[$sup_qty] =$_super_qty;
$required += $_super_qty;

}

if($required == 0) {
$this->_getSession()->addError($this->__('Cannot add the item to

→˓shopping cart.'));
$this->_goBack();
return;

}

$config_table_qty = $qty_config;

foreach($config_super_attributes as $sId => $config_attribute) {
if(!isset($config_table_qty[$sId]) || $config_table_qty[$sId]==''

→˓|| !is_numeric($config_table_qty[$sId])){
if($config_table_qty[$sId] != '0'){
$config_table_qty[$sId] = 1;

}
}

if(isset($config_table_qty[$sId]) && $config_table_qty[$sId]!='' &&
→˓ $config_table_qty[$sId] > 0) {

$product= $this->_initProduct();
$related= $this->getRequest()->getParam('related_product');

if (!$product) {
$this->_goBack();
return;

}

if(isset($config_table_qty[$sId])) {
$params = array();

(continues on next page)
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(continued from previous page)

$params['qty'] = $config_table_qty[$sId];
$params['super_attribute'] = $config_attribute;

if($options != null) $params['options'] = $options;

try {
if($params['qty'] > 0 && $params['qty']!='') {
$cart->addProduct($product, $params);
if (!empty($related)) {

$cart->addProductsByIds(explode(',', $related));
}
$cart->save();
Mage::getSingleton('checkout/session')->

→˓setCartWasUpdated(true);
if (!$cart->getQuote()->getHasError()){

$responseText = $this->addToCartResponse($product,
→˓$cart, $IsProductView, $params,0);

}
} else {
$responseText = $this->showOptionsResponse($product,

→˓$IsProductView);
}

} catch (Exception $e) {
$responseText = $this->addToCartResponse($product, $cart,

→˓$IsProductView, $params, $e->getMessage());
Mage::logException($e);

}
}

}
}

} else {
if($related) unset($params['related_product']);

$product = Mage::getModel('catalog/product')
->setStoreId(Mage::app()->getStore()->getId())
->load($idProduct);

$responseText = '';
if ($product->getId())
{

if(!array_key_exists('qty', $params)) {
$params['qty'] = $product->getStockItem()->getMinSaleQty();

}
try{

if(($product->getTypeId() == 'simple' && !($product->
→˓getRequiredOptions() || (Mage::getStoreConfig('amcart/general/display_
→˓options')

&& $product->
→˓getHasOptions())))

|| count($params) > 2
|| ($product->getTypeId() == 'virtual' && !($product->

→˓getRequiredOptions() || (Mage::getStoreConfig('amcart/general/display_
→˓options')

&& $product->
→˓getHasOptions()))))

{
$cart = Mage::getSingleton('checkout/cart');
$cart->addProduct($product, $params);

if (!empty($related)) {
(continues on next page)

16.4. Common Problems 69



Read the Docs Template Documentation, Release latest

(continued from previous page)

$cart->addProductsByIds(explode(',', $related));
}
$cart->save();
Mage::getSingleton('checkout/session')->

→˓setCartWasUpdated(true);
if (!$cart->getQuote()->getHasError()){

$responseText = $this->addToCartResponse($product,
→˓$cart, $IsProductView, $params,0);

}
}
else{

$responseText = $this->showOptionsResponse($product,
→˓$IsProductView);

}

}
catch (Exception $e) {

$responseText = $this->addToCartResponse($product, $cart,
→˓$IsProductView, $params, $e->getMessage());

Mage::logException($e);
}

}
}
$this->getResponse()->setBody($responseText);

}

------------------------------

Sample file:

https://www.dropbox.com/s/vz9bjgx9rd2ue97/AjaxController.php?dl=0

16.5 FAQs

16.5.1 Features

How many attributes can your module support?

Our extension supports just two attributes with unlimited options of each attribute

How does this module calculate total quantity?

This module calculates total quantity based on the quantity of each selected option in the attribute tab.

When are tier prices displayed in a separate table?

Tier prices are shows in a separate table only when all children products have the same tier prices

Assume that I have 9 simple products that have the same tier prices and another simple product with different
tier prices from 9 other ones, whether can this extension display tier prices of 10 products in a separate table or
not?

No, in this case our module will display tier prices of your 10 products in a table along with other information of
products.

If tier prices of my children products are not similar, whether can I use advanced tier price calculation?

No, advanced tier price calculation is only applied for children products with same tier prices.
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Does this extension automatically calculate total amount when I change quantity for each children product?

Yes, total amount are also calculated automatically anytime you adjust your desired quantity

Can your module support displaying the tab table in the category page?

No, it cannot. Our module just shows the tab table on the product page

16.5.2 Guide

How to disable this extension from my site?

If you do not want to continue using this module, you go through System -> Configuration -> Configurable Product
Table Ordering

In Enable, you set No to disable this extension

Are children products with the same tier prices always displayed in a separate table?

No, this depends on your setting in the backend.

In Advanced Tier Prices: if you set Yes, these products are just shows in a separate table

Otherwise, they are still in the original table when you set No

I just want to know total product quantity I have chosen, not quantities of options in the attribute tab, so how
can I do it?

It’s very simple, you find Show Detailed Qty Selected in the configuration of this module from backend, set No for it
to only display total product quantity.

16.5. FAQs 71



Read the Docs Template Documentation, Release latest

72 Chapter 16. Configurable Product Table Ordering



CHAPTER 17

Customer Group Without Tax

17.1 User Guide

17.1.1 Magento Customer Group without Tax Overview

Magento Customer Group without Tax extension has ability to reject taxes on category page and product page. Also,
customers won’t see tax rate in their cart and check out with pay no tax. This unique extension also allows admin
apply for specific customers and individual customer groups while tax rates are still shown to remained customers.
Hence, it’s really useful for your website’s marketing and sale policy.

17.1.2 How Magento Customer Group without Tax works

1. Instruction Manual

As an admin, you can set up your own store page by the most effective way that supports your trading objective. To
make the configuration:

• Step 1: Go to System => Configuration.

• Step 2: At the left side of the page, find BSS Commerce => select Customer Group Without Tax

After this 2 steps, a screen for configuration appears like the following picture:
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In box Enable module, choose Yes to enable the module. After being enabled, a box named Apply for customer
groups will appear for you to continue configuring the extension.

In the box Apply for customer groups, select one, some or all customer groups’ names which you want to reject taxes
on website view.

After all above configuration is done, you save the configuration by clicking on Save config button to the right of the
backend. To see the change, go to frontend and reload the page.

2. Preview tax policy on customer groups

To preview which customer group is applied tax policy, go to Admin Panel -> Customers -> Customer Groups. All
groups of customer will be shown with applied tax policy like this following picture:
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The result in frontend when applying Magento Customer Group without Tax will be shown like this:

17.2 Compatibility

Our Customer Group Without Tax is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

17.3 Changelog

17.4 FAQs
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CHAPTER 18

Defer JavaScript

18.1 User Guide

18.1.1 Defer Javascript Extension Overview

Defer Parsing of JavaScript is listed as one of the most impactful factors of speed improvement for websites that you
can implement among many website optimization tips.

When customers visit your website, they do not expect to wait so long for loading pages because this makes them im-
patient and leave your website after waiting in vain. Therefore, Defer JavaScript Extension is developed to effectively
reduce loading time by automatically putting JavaScript files to the end of page after loading all HTML and CSS. As
a result, you will keep customers stay on your site as well as engage more customers and your sales is of course on the
way to boost up!

18.1.2 How does Defer JavaScript Extension work?

To configure the module, follow these below instructions:

Step 1: Go to Admin Panel -> System -> Configuration

Step 2: On the left side of the page, find BSS COMMERCE -> select Defer JavaScript

After these two steps, you can see your admin screen as this image:
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1. Enable Defer JavaScript

You can easily enable or disable BSS Defer JavaScript module by selecting “Yes” or “No” in the Enable box.

2. Manage Controllers, Path, and Homepage

There may be some pages you do not want them to be affected by Defer JavaScript. Therefore, to exclude impact of
BSS Defer JavaScript from some pages, you can fulfill these pages’ information into Excluded boxes:

• Exclude controllers and paths: By clicking Add Match button and then write down your wished paths or
controllers you can disable defer JavaScript on these paths or controllers page.

• Exclude Homepage: you can disable this module on Homepage through only a click. Select “Yes” in the
Exclude Home Page box, you can disable the module on your home page.
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Please remember that, when you click Add Match button, you have to fill in the controllers/ paths which you want
not to be affected by our module. You should not leave it blank as below picture.

If you do not fill it up, the system will automatically set all pages in your website affected by our module.

You can click on Delete button in the right side of the box to close the created blank box.

If you want to disable Defer JavaScript function in some pages, however, you do not know the controllers/ paths to
fulfill the Exclude Controllers box or Exclude Paths box;

Show Controller and Paths will help you solve the problem. When you select “Yes” like this:

You can see the information you need in the table shown in the end of frontend page. For example:

After finishing configuration process, you can click on “Save Config” button to save all of your setting with Defer
JavaScript.

18.2 Compatibility

Our Defer JavaScript is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x
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• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

18.3 Changelog

Version 1.0.4:

• Fix bugs for configuring with Full Page Cache module

• Document update: How to fix BSS Defer Javascript for other Full Page Cache modules

Version 1.0.5:

• Fix bugs for configuring with Full Page Cache module

Version 1.0.6:

• Fix bugs when working with Full Page Cache module

Version 1.0.8:

• Option to not defer selected script

Version 1.0.9:

–

Version 1.1.1:

18.4 Common Problems

18.4.1 1. I’ve uploaded the files to the site. Now when I tried to access to the
module get this error message:

Fatal error: Class ‘Bss_DeferJS_Block_Adminhtml_Form_Field_Regex’ not found
in/home/storedep/public_html/includes/src/__default.php on line 28651**

When installation Defer Javascript extension , customers often run into this kind of error as they forget to
disable compilation as it’s required that before you make any changes to your Magento installation you
should always disable compilation. To fix this problem, just simply run the compilation process, and
then enable it.

To disable Compilation in Magento, please navigate to Admin panel Go to System > Tools > Compilation
page and click on Disable button

18.4.2 2. Configure Defer Javascript with Full Page Cache

To configure module Defer Javascript with module Full Page Cache, please follow all following instruc-
tions (2 steps).

step1: In the folder named “Model” of module Full Page Cache, find all functions named “setBody” or
“setHtml” (In almost cases, you can find these functions in file “Observer.php”)

*Note: “setHtml” function just appears in some cases

-For example in Lesti_Full Page Cache module :
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$response = Mage::app()->getResponse();
$response->setBody($body);

...
$observer->getEvent()->getResponse()->setBody($body);

...

$observer->getTransport()->setHtml($placeholder);

step2: Still in this example, add one of the following code defer above function “setBody” or “setHtml”

*Note: there are 3 types of code defer for each type of function:

For example:

$response = Mage::app()->getResponse();

//code defer
if(Mage::helper('bss_deferjs')->isEnabled()) {

$body = Mage::helper('bss_deferjs')->deferJs($body);
}
//end

$response->setBody($body);

....

//code defer
if(Mage::helper('bss_deferjs')->isEnabled()) {

$body = Mage::helper('bss_deferjs')->deferJs($body);
}
//end
$observer->getEvent()->getResponse()->setBody($body);

...

//code defer
if(Mage::helper('bss_deferjs')->isEnabled()) {

$body = Mage::helper('bss_deferjs')->deferJs($body);
}
//end
$observer->getTransport()->setHtml($placeholder);

After all of these steps, you have done configuring module Defer Javascript to work well with module
Full Page Cache.

18.4.3 3. Defer JavaScript cannot interfere JavaScript fills from frames

For Magento sites including a lot of video embedded for the third parties such as Youtube, Vimeo and so
on, site speed is also considerably influenced (slower)and causes customers to wait so long for loading
these video. When installing Defer JavaScript extension, there is an issue that the module cannot interfere
JavaScript files from frames, so it does not have any effect on deferring these JavaScript files in order to
make sites perform faster.

To solve this problem, we need to defer video loading to save many file requests and resource downloads,
which can improve site performance effectively. It means that we will keep the video from loading all the
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associated files by not identifying the iframe src until after the page loads.

Step 1: Get the embed code of the video you want to defer

Take an example:

<iframe width=”853” height=”480” src=”https://www.youtube.com/embed/7ngPu_kUdN4?rel=0”
frameborder=”0” allowfullscreen></iframe>

Step 2: Alter the embed code by making 2 following changes

• Make the “src” empty by removing the url from it as below: src=”“

• Put the url that is cut from “src” and add it to “data-src”.

data-src=”//www.youtube.com/embed/7ngPu_kUdN4?rel=0”

Therefore, the code becomes:

<iframe width=”853” height=”480” src=”” data-src=”//www.youtube.com/embed/7ngPu_kUdN4?rel=0”frameborder=”0”
allowfullscreen></iframe>

Step 3: Add the script to bottom of page

<script>
function init() {
var vidDefer = document.getElementsByTagName('iframe');
for (var i=0; i<vidDefer.length; i++) {
if(vidDefer[i].getAttribute('data-src')) {
vidDefer[i].setAttribute('src',vidDefer[i].getAttribute('data-src'));
} } }
window.onload = init;
</script>

18.4.4 4. The Defer score does not increase in case Magento sites uses Full Page
Cache also

We need to fix the Full Page Cache module to overcome this problem (Let’s look at the instruction en-
closed with installation guide) For more details, it can be explained as below:

The purpose of the Full Page Cache extension is saving HTML of Magento sites into Caches and these
HTML are set up again by using events when loading sites. Therefore, to fix this module, we firstly use
keywords such as setBody and setHTML to search for code snippets that have HTML setup again. Next,
we add a code snippet of Defer JavaScript (called from helper) into those HTML codes (have HTLM
setup again) and then setBody and setHTML.

18.4.5 5. The Defer score does not increase although JavaScript files stay on
</body>

Let’s set No for Put Javascript In HTML Body Tag section in the configuration of the module
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The purpose of this option is to meet W3C checking on this site: https://validator.w3.org/

18.4.6 6. The Defer score does not increase although JavaScript files stay on the
bottom of page

If the Magento site uses a Minify HTML module, we need to disable it and then check on GTMetrix

In case this solution does not make the defer score go up, we need to check again to find out which
JavaScript is causing this error.

18.4.7 7. Some images from the third parties that are inserted by using JavaScript
are pulled down after deferring

There are two ways to solve this problem:

• Use nodefer tags to make these images not be pulled down

• Rewrite their JavaScript in case you want to get higher defer scores

18.5 FAQs
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CHAPTER 19

Delete Order

19.1 User Guide

19.1.1 Delete Order Overview

Imagine that a ton of unnecessary orders, invoices, shipments and credit memos are account for large scale of Database
memory, which results in diminishing Server performance and bothers shop owners. Magento, however, allows you to
cancel the orders, it does not support you to delete them. Moreover, there is almost no plug-in solve this problem.

Fortunately, Delete Order extension addresses this vital weakness of Magento and helps you to manage the Data better
with superior benefits.

19.1.2 How does Delete Order work?

1. Delete orders

In order to delete orders, following these below instructions:

In Sales section, choose Orders. Here, a list of orders is shown.
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• First: Go to Admin Panel => Sales => Orders

• Next: Choose the excessive orders you want to delete

• Next: In the Actions box => choose Delete Orders

• Last: click on Submit button

*Note: Remember that if you choose Delete Orders , all the related information about order’s invoice, shipment, credit
memo will be deleted from backend at ease.

If you want to delete only invoice or shipment or credit memo of any order, you have to keep this order remaining.

NOTE: You can choose to delete one, more or all orders

2. Delete Invoices

In order to delete Invoices, follow this following instructions:

• First: Go to Admin Panel => Sales => Invoices

• Next: Choose the excessive invoices you want to delete
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• Next: In the Actions box => choose Delete Invoices

• Last: click on Submit button

3. Delete Shipments

In order to delete Shipments, follow this following instructions:

• First: Go to Admin Panel => Sales => Shipments

• Next: Choose the excessive shipments you want to delete

• Next: In the Actions box => choose Delete shipments

• Last: click on Submit button

4. Delete Credit Memos

In order to delete Credit Memos, follow this following instructions:

• First: Go to Admin Panel => Sales => Credit Memos

• Next: Choose the excessive shipments you want to delete

• Next: In the Actions box => choose Delete Credit Memos
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• Last: click on Submit button

19.2 Compatibility

Our Delete Order Extension is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

19.3 Changelog

Version 1.0.2:

• Update deleting order function: completely clear all related invoices, credit memos and shipments

• Compatible with all Magento sites

Version 1.0.3:

• Fix bugs on Magento version 1.9.2.4

19.4 Common Problems

I purchased “Delete Order/Invoice/Shipment/Credit Memo”. I uploaded the files to my root folder now I get this
page “Service Temporarily Unavailable The server is temporarily unable to service your request due to maintenance
downtime or capacity problems. Please try again later.” –> Could you please try to check if there is a file called
maintenance.flag in your magento root? If so Delete it. The problem will be sorted out.

19.5 FAQs

19.5.1 Features

What are the differencies between version 1 and version 2 of BSS Delete Order extension? Is version 2 the
upgraded and better one?
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In facts, BSS Delete Order version 2 is the upgraded one to be able to compatible with Magento 2 platform. But basics
function of the version 2, for now, is simplier (only enables deleting orders along with all other relating data at the
same time) and you cannot remove unwanted invoices, shipment and credit memos separately. In other words, version
1 is the more full-function one.

If I delete a piece of data using this extension, is other relating data/information deleted either?

When deleting unnecessary orders, all respective shipment, invoices, credit memo are deleted too. However, when you
only delete any data of shipment, invoices, credit memo, its order still remains under your control

Is is posible to choose to delete all types of unneccesary data in one click, or I have to do it seperately for each
type?

Yes, by deleting orders, other data relating to it will be wiped out immediately. In case you want to keep orders data,
deleting other types of info will have to be done seperately.

Using this extension, if I delete a certain order by mistake, is it moved to a folder like recycle bin from which I
can find and restore it or it is deleted for good?

Unfortunately, the answer is no. When you delete an order, it is deleted permanently and can not be restore. So before
hitting the Submit button for this action, please take a second look carefully

19.5.2 Guide

May I have to make any configuration from the backend?

No, you just install this module to to your site and an action of Delete Order is automatically added to the backend to
choose.
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CHAPTER 20

Full Page Cache

20.1 User Guide

20.1.1 What is Full Page Cache?

Full Page Cache for Magento is an ideal way to speed up your Magento eCommerce site by reducing server responsive
time, reducing hardware requirements and costs, and making your Website more responsive to shop on. A fast site can
place directly higher in search engines and increase profits amazingly.

Full page caching ensures your content is always up to date with the auto refresh cache system and allows for easily
configurable hole, punching from the admin panel. With a quick and simple install, our Full Page Cache helps you
achieve blazing fast page load times. This massively improves page load time and allows your server to handle many
more requests!

20.1.2 Why should install Full Page Cache?

Literally, Full Page cache relates to the storage of the full output of a page in a cache, so that in subsequent page loads
will not require much server load at all.

Full Page cache extension is indispensable especially for enterprise level eCommerce sites with high-traffic visiting
in order to keep server load as low as possible, and to avoid downtime during periods of high traffic. For instance,
If 1000 users are visiting the site at once, memory capacity used with full page caching enabled is inappropriate in
comparison to the server load caused by 1000 Users Magento at a time.

Throughly considered, Full page cache extension will increase site speed, since all the server needs to do is fetch and
render the page from the cache.

20.1.3 Configuration Settings

BSS’s FPC has a handful of configurable settings to control how pages are cached. All settings are located in “System
-> Configuration -> Brim Extensions -> Full Page Cache”

91

http://bsscommerce.com/magento-full-page-cache.html
http://bsscommerce.com/magento-full-page-cache.html


Read the Docs Template Documentation, Release latest

General Settings

Cache Conditions Settings
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Mobile Settings

Storage Setttings

Config File Settings
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20.2 Compatibility

Our Full Page Cache is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

20.3 Changelog

Version 1.0.0:

• First Release

Version 1.0.1:

• Fix the issue with compilation

Version 1.0.2:

• Fix bugs for Ultimo theme

20.4 FAQs
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CHAPTER 21

Google Tag Manager

21.1 User Guide

21.2 Compatibility

Our Magento Google Tag Manager is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

21.3 Changelog

21.4 FAQs
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CHAPTER 22

Improved Newletter

22.1 User Guide

22.2 Compatibility

Our Improved Newsletter is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

22.3 Changelog

22.4 FAQs
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CHAPTER 23

Lazy Image Loader

23.1 User Guide

23.1.1 Magento Lazy Image Loader Extension Overview

If you are a Facebook user, you definitely know its image load mechanism. For the purpose of reducing image load
time to enhance customer experience, Facebook permits pages loading images as customers’ scroll.

Magento Lazy Image Loader extension possesses the same functionality which loads product images on your Magento
site only when customers scroll the page. By the same token, the extension easy usage drives Magento newcomers at
ease. Likewise, the abilities to exclude particular controllers and paths from the effect of Lazy Image Loader extension
promote the extension to be the adorable extension that needs to be added to shop owners carts.

23.1.2 How does Magento Lazy Image Loader extension work?

To make configuration of this module, follow these below instruction:

• Step 1: Go to Admin Panel => System => Configuration

• Step 2: At the left side of the page, find BSS Commerce => select Lazy Image Loader

After these 2 steps, a screen for configuration appears like the below picture:
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1. Enabled

You can select between enable and disable Magento Lazy Image Loader Extension by setting the status in Enabled
box into “Enable” or “Disable”.

2. Loading Icon

In Loading Icon: you choose the files to upload images from your computer

In Loading Icon Width: you set the width for icon loading

3. Manage Jquery Library

When setting up Lazy Image Loader, you can also control Jquery Library in your website. You can select “Yes” to
allow Jquery Library combining with Lazy Image Loader extension when it runs on your website.

4. Threshold

In Threshold box, you can set the number pixel before image appear on the screen, then the image will be loaded
earlier as the pixels you set. For instance, if you set the number in the box is 14, it means that the images will be
loaded before when your scroll position is far from 14 pixels.
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5. Exclude controllers, Path, Homepage

Magento Lazy Image Loader Extension allows admin deciding which part will be excluded from lazy-loaded function.
To exclude controller, admin can click on Add Match and then filling the match in the box. Admin also can delete the
Match and add more by clicking on Delete, and Add Match button alternately.

Similar to Controller, admin can control the Path which they do not want to be affected by Lazy Image Loader.

Finally, admin can set whether Homepage be affected by lazy image load or not in the box Exclude Home Page.
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6. Exclude lazy images

In Help Exclude lazy images: Our extensions allows adding attribute notlazy after src attribute to <img> to help you
prevent loading lazy images and make them not be affected by this extension.

For example: If you want to exclude an image named BSS from Lazy Image Loader’s impact, you do as the following:

From: <img src=”bss.png” alt=”Bss”>

To: <img src=”bss.png” notlazy alt=”Bss”>

It means that you just need to add notlazy after src attribute to <img> and then this image is not affected by Lazy
Image Loader

After finishing all of these set-up steps, you can click on Save Config button to start using Magento Lazy Image
Loader extension.

23.2 Compatibility

Our Lazy Image Loader is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

23.3 Changelog

Version 1.0.3:

• SEO-friendly improvement

• Support Jquery Library

Version 1.0.4:

• Loading effect

• Option to not load some wanted images

Version 1.0.5:

• Option to upload loading icon

Version 1.0.6:

• Support srcset attribute
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23.4 FAQs
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CHAPTER 24

Limit Order Quantity per Category

24.1 User Guide

24.1.1 Magento Limit Order Quantity Per Category Overview

Magento Limit Order Quantity Per Category Extension allows setting minimum and maximum quantity of all products
per category in an order that customers have to meet before successfully checking out. This extension also helps
Magento store owners limit order quantity per category for each specific customer group, which gives them more
control over order product quantity to reduce shipping costs and other related costs like storage management and
package.

24.1.2 How does Magento Limit Order Quantity Per Category Extension work?

Go to System -> Configuration -> BSSCOMMERCE -> Min/Max Order Quantity per Category for Customer
Group to begin setting up
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1. In Enable:

Choose Yes to enable module or choose No to disable it

2. In Show Category:

• Choose Yes to display all product category in the shoppingcart.

• Choose No to hide product category

3. In Messages Limit Max:

You can change the notification messages when maximum required order quantity per category is not met (This
message locates at the top left corner of the Shopping Cart). Without any changes,default message will be shown as:
The max quantity allowed for purchase at category{category_name} is {qty_limit} [ Product Name : {product_name}
]

4. In Messages Limit Min:

You can change the notification messages when minimum required order quantity per category is not met. Without
any changes, default message will be shown as: The min quantity allowed for purchase at category {category_name}
is {qty_limit} [ Product Name : {product_name}]

5. In Min/Max Order Quantity

You can freely choose customer group and category to apply the min/max quantity rule. Click Add button for more
options.

After finishing with setup, choose Save Config

*Note:

For products belong to multiple categories, the order quantity of products needs to meet the min/max requirement of
all thosecategories. The min/max rule is applied to the total number of products in each category added to cart, not the
order quantity of each particular product.

24.2 Compatibility

Our Limit Order Quantity Per Category is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x
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24.3 Changelog

Version 1.0.0:

• First Release

Version 1.0.1:

• Fix bugs when getting current category is NULL

24.4 FAQs

24.3. Changelog 109



Read the Docs Template Documentation, Release latest

110 Chapter 24. Limit Order Quantity per Category



CHAPTER 25

Limit Order Quantity per Product

25.1 User Guide

25.1.1 Magento Limit Order Quantity Per Product Extension Overview

Magento Limit Order Quantity per Product Extension by BSSCommerce is developed to help administrators to take
control the allowed number of products that customer need to order for a sucessful purchase. In Magento default, you
can also set up the minimum and maximum order quantity for each product but it does not allow you to apply these
settings to specific customer groups. Therefore, this module enhance your customization to make it suitable with your
products and your customers you want to control their order quantity.

By setting minimum and maximum order quantity per product for specific customer groups, you can save a lot of
shipping costs and other related costs due to preventing the very small quantity of products and also increases sales
effectively for your store.

25.1.2 How does Limit Order Quantity Per Product Extension work?

You go to System -> Configuration -> BSS COMMERCE -> Sales Qty for Customer Group

In General: Choose Yes to enable the module or choose No to disable it
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After you enable the module, you go to Catalog -> Manage Products -> Product Edit -> Inventory. (At this step,
you choose each product in product grid table to make configuration)

After going to Inventory of each product, you set up minimum and maximum order quantity for each customer group.

In Min Sales Qty: click Add Group Min Sales Qty to set up the minimum order quantity for each customer group

In Max Sales Qty: Click Add Group Max Sales Qty to set up the maximum order quantity for each customer group
=>Then Save configuration and repeat this process for other products.

In the frontend, if the requirements about minimum and maximum order quantity for a product are not met, they cannot
add it to cart and Magento default will show a notification about the order quantity limitation of this product.

25.2 Compatibility

Our Limit Order Quantity Per Product is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x
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25.3 Changelog

25.4 FAQs

25.4.1 Features

Can Limit Order Quantity per Product take effects independently on different store views?

No. These limits are all applied to global scope

What limits this extension let me set for order quantity per product?

BSS Limit Order Quantity per Product extension enables configuration of lowest and highest order quantity for each
product that is valid for a customer to procced to check out.

For each product, are maximum and minimum limits of order quantity fixed for every customer? What if I
only want to set order quantity limits to some specific customers?

Using this extension, limit order quantity per product can be set up differently among your customer groups, even
when only one group is set up limits and others aren’t. But you can also use a fixed limit for all customers by setting
the same limits for all customer groups

Does this extension support a customized message to notice customers about the limits of order quantity per
product?

With this extension, only the default notification of Magento is used to notice customers when limit order quantity is
not satisfied

25.4.2 Guide

How to set up order quantity limits per product in this extension?

This extension is very easy to handle:

• You just need to enable the module. To do that, go to System Configuration BSS Commerce Sales QTy for
Customer Group, then at General settings section of this module you choose Yes

• Then go set up limits for which product you want (Catalog Manage Products (choose the product) Inventory Set
up Min/Max Sales Qty for customer groups as picture below:
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CHAPTER 26

Minimum Order Amount for Customer Group

26.1 User Guide

26.1.1 Magento Minimum Order Amount for Customer Group Extension Overview

Magento Minimum Order Amount for Customer Group Extension is a must-have extension that allows setting up the
minimum amount of an order that each customer group has to meet.

• Flexibly set the limitation for each customer group

• Extremely Suitable For B2B Business Model

• Well-compatible with all Magento theme

• Life time support and free installation

26.1.2 How does Magento Minimum Order Amount for Customer Group Extension
work?

Administrator can easily enable/disable this extension from backend without special knowledge needed. Check it at
System-> Configuration -> Sales -> Minimum Order Amount
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In Enable: Choose Yes to enable the module or choose No to disable it.

In Minimum Amount: click “Add Minimum Amount” to set up minimum order amount for each customer group.

In Description Message: you customize your own message/notification to show customers in the shopping cart in
case requirements about order amount are not met.

For example, if customer does not order with the minimum amount of $100, the message is displayed in the shopping
cart as below:

26.2 Compatibility

Our Minimum Order Amount For Customer Group is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x
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26.3 Changelog

26.4 FAQs

26.4.1 Features

I’d like to experience this helpful extension but what if it conflicts with my using theme?

That’s not a problem because this one is built well-compatible with all Magento themes. This module has nothing to
do with display customization in the frontend, so it has no effect on whatever theme you are using on your site

Why should I use this module when requirement of minimum order amount may make my customers feel
annoyed because of their limited budget?

When deciding whether to use this module or not, you have to thoroughly consider your business model and your
targeted customers. Sometimes, delivery of orders with tiny amount are not cost-efficient for your business, then you
can avoid it by setting up a minimum order amount for your customer.

Magento also has a default minimum order amount function, so why should I use another extension like BSS
Minimum Order Amount for my website?

The reason why we develop this extension is to optimize the similar default function in Magento. Magento itself just
allows you to set up a specific minimum order amount for the whole website, meanwhile our extension enables you
to choose different minimum amounts for different customer groups, especially at the scope of a storeview only. It is
super convenient when your website has multi-store view.

Using this module, whether discount is included in total amount when compraring with minimum order amount
or not?

The amount to compare with minimum level is the subtotal after discount is applied.

Does this module set limitation to the number of customer groups on which I want to place minimum order
amount?

No. You can manage the number of your customer groups and the limit of their order value also

What is the difference between Description message and Error to show in shopping cart?

They work quite similarly, both are customized message to inform customers that they still can not check out. De-
scription message will be displayed in shopping cart when the subtotal after discount is less than minimum amount,
and Error to show in shopping cart will only be shown when customers click on the button Proceed to checkout
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CHAPTER 27

Minimum Quantity of Configurable Product

27.1 User Guide

27.1.1 Minimum Quantity of Configurable Product Extension Overview

Minimum Quantity of Configurable Product is developed to allows admin to set minimum quantity as the compulsory
condition for customer?s checkout. This minimum quantity value can be specifically set for a configurable product or
some specific configurable products. Besides, admin can also choose to apply this minimum value for all configurable
products on large scale.

27.1.2 How does Minimum Quantity of Configurable Product Extension work?

1. Set minimum quantity for all configurable product

Navigate to System -> Configuration -> BSSCOMMERE -> Minimum Quantity of Configurable Product

In Enabled, choose Yes to enable or No to disable the extension
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In Minimum Qty of Configurable Product, enter a number to set minimum quantity for all configurable products in
store.

2. Set minimum quantity for a specific configurable product

Go to Catalog -> Manage Product -> Find the configurable product -> Inventory

In Minimum Qty Allowed in Shopping Cart, use config setting or remove tick from the checkbox to enter a new
value for minimum quantity of the chosen configurable product

27.2 Compatibility

Our Minimum Quantity of Configurable Product is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

27.3 Changelog

Version 1.0.0: First Release

27.4 FAQs
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CHAPTER 28

Minimum Amount for Category

28.1 User Guide

28.1.1 Magento Minimum Amount For Category Overview

Magento Minimum Amount For Category extension is a unique extension which allows admin to customize the mini-
mum order amount for individual categories.

In order to better boost up your sale, shop owners always try to make efforts to promote customers’ amount pur-
chase. Set up a minimum order amount for each category when customers are purchasing is a good idea. Only when
customers’ total amount is met with the minimum amount admin already set up, can customers’ order be moved to
checkout process.

In order to avoid tiny order amount, setting the minimum order amount is the optimal choice. Besides minimum order
amount for customer group, we can also configure minimum order amount for different categories. The extension
is beneficial as it forces customers to shop more to meet the minimum order amount if they would like to complete
the checkout process. The extension is one simple tool to boost your sales in particular and your overall revenue in
general.

28.1.2 How does Magento Minimum Amount For Category extension work?

1. Instruction Manual

As an admin, you can set up your own store page by the most effective way that supports your trading objective. To
polish the website configuration:

• Step 1: Go to Admin Panel => System => Configuration

• Step 2: At the left side of the page, find BSS COMMERCE => select Categories Minimum Amounts

After these 2 steps, a screen for configuration appears like the below picture:
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In the configuration table, there are 4 boxes for admin to customize the extension: Enabled, Show Category, Select
children categories price, Notification.

In Enabled: There are 2 options in Enable box: Yes and No.

• Choose Yes to enable the module and continue customizing on other sections.

• Choose No to disable this module.

In Show Category:

There are 2 options in Show Category box: Yes and No.

• Choose Yes to enable showing category name of item in shopping cart page

• Choose No to disable showing category name of item in shopping cart page

In Select children categories price:
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There are 2 options in box: Min Price and Max Price

This box allows admin to set up price displaying for products which belong to many categories and have different
prices in each category. When customers don’t add product to cart from any specific category but adding from other
pages, for instance in the search result page, the price will be shown as the customization.

• Choose Min Price to show the lowest price in all categories which products belong to when products are pur-
chased.

• Choose Max Price to show the highest price in all categories which products belong to when products are
purchased.

In Notification:

In this box, admin can insert a custom notification message appears when customers order an amount lower than the
minimum order amount being set.

Remember to use {{category}} in the custom message to automatically display exactly name of category the product
are in, use {{price}} to automatically display exactly the minimum price for each category being set.

E.g: Category {{category}} has an order minimum of {{price}}

After all, click on Save Config button to save all configuration.

2. Set up Minimum Order Amount for each category

To set up minimum order amount for each category, follow these below instructions:

• Step 1: Go to Admin Panel => Catalog => Manage Categories

• Step 2: In Root Catalog at the left side => select category to set up minimum order amount.

• Step 3: In the appearing configuration page, choose Minimum Order Amount section

After these 3 steps, a screen for configuration appears like the below picture:
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In the box Minium Amount, fill in with number of the minimum amount of each category.

In this example, when filling 1000 => the minimum amount of Furniture category is $1000 *for customers. So that
customers have to place orders which worth more than 1000$ to proceed checkout.

If customer orders under-$1000-product, a message notification will appear in frontend like this picture:

After all, don’t forget to click on Save Config button to save all configuration.

28.2 Compatibility

Our Minimum Amount for Category is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

28.3 Changelog

Version 1.0.3:

• Fix bugs with price including tax
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28.4 FAQs

28.4.1 Features

In what case specifically this module’s function work best?

When store owners want to refuse orders with tiny amounts that are not effective to run through the whole process
until delivered to save shipping costs.

Does this extension have another version compatible with Magento 2 platform?

Unfortunately, version for Magento 2 of BSS Minimum Order Amount for Categories extension is still not available
until now. However, there is another one already having two versions for Magento 1 and Magento 2 which works in a
quite similar function: BSS Minimum Order Amount for Customer Group . Check it out if you are interested.

Does this extension allow me to set minimum order amount for every subcategory or just for main categories?

Yes. Minimum order amount can be set up for all categories and subcategories of products on your website

Does this extension support a customized notification to customers when their order amount is less than the
minimum set?

Yes. And remember to follow the structure to create this customized message, for example: “Category “{{category}}”
has an order minimum of {{price}}”. Because {{category}} and {{price}} are added to make sure each name and
minimum order amount of a certain category to be shown in a specific notification

Does this minimum order amount configuration take effect at website level or store view level?

Only at store view level. To change the store view, select which one you want at the section “Current Configuration
Scope” on the top left of Categories Minimum Amount configuration page

28.4.2 Guide

When a product is shorted into multiple categories and minimum order amounts of them are set differently,
which one will be the final minimum order amount for that product?

There are two options for you to decide the final minimum order amount for a certain product in multiple categories: it
will be the min or max price among different minimum order amounts for all those categories. To do so, go to System
Configuration BSS Commerce Categories Minimum Amount then enable the module, at “Select children categories
price” you choose Min Price or Max Price

• Min Price: The final one will be the lowest among minimum amounts of all categories into which that product
is sorted

• Max Price: The final one will be the highest among minimum amounts of all categories into which that is sorted

When I don’t fill in a specific minimum order amount for a subcategory, does the minimum order amoun of its
root category count?

This is also decided by your options: the answer can be Yes or No depending on which one you choose at the section
“Select minimum order amount of parent categories” (System Configuration BSS Commerce Categories Minimum
Amount)

• Choose Yes: Minimum amount of root category will be counted as minimum amount of that subcategory

• Choose No: Minimum order amount of root category will not be counted, which means that subcategory has no
minimum order amount
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CHAPTER 29

Multiple Store View Pricing

29.1 Installation Guide

To install Multiple Store View Pricing, you follow our Installation Guide for Magento 1 extensions .

*Note: Please remember that after you install Multiple Store View Pricing, you go to System -> Configuration ->
Catalog -> Catalog Price Scope and choose Store View.

Then you need to reindex product prices and also apply catalog price rules again.

29.2 User Guide

29.2.1 Magento Multiple Store View Pricing Extension

Being an e-Commerce shop owner, have you ever found a temporary solution to set particular prices for each store
view of the whole store system? Nevertheless, what will you do if you have a desire for setting multiple prices of the
same items in each store view of each local store but all default Magento functions cannot help you handle it?

Multiple Store View Pricing extension is a useful tool which allows online shop owners set and display different prices
for each product in each store view of the corresponding store as wish. With this powerful extension, now you will not
face with any trouble in

29.2.2 How does Magento Multiple Store View Pricing Extension work?

1. Enable Multiple Store View Pricing Extension

You go to System -> Configuration -> Catalog. Among all sections shown up in the page, find Price section to start
the customization.
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In box Catalog Price Scope, there are 3 options for admin to choose: Global, Website, Store.

You choose Store to enable the module. Then you click Save Config and begin to customize prices of products in each
store view of each store

2. Set up price for a product in the English store view: Madison 8GB Digital Media Player, for
example

2.1 Set up base currency and default currency for English store view

In Configuration, you go to General -> Currency Setup to set up base currency for English store view

Choose English store view from Current Configuration Scope

In Base Currency: Choose British Pound Sterling as base currency and customers will use this one to
checkout.

In Default Display Currency: you can choose British Pound Sterling or any other currency because
this one is only displayed in the product or category page, not used in the checkout.

In Allowed Currencies: Choose British Pound Sterling

Then, click to Save config and start to set up price for a product in the English store view
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2.2. Set up price for Madison 8GB Digital Media Player in the English store view

Go to Manage Products and choose Madison 8GB Digital Media Player to edit

Step 1: Choose English store view per store (Main Store) in Choose store view box

Step 2: In Price section (on the left side column), you unmark “Use Default Value” and add your wanted
price for the product in this English store view: 600, for instance

In addition, you can also set up Group Price, Special Price and Tier Price per store view for this
product if you want.

• In Group Price For Store View: Click Add Group Price button to add new group prices. You choose
each customer group in the drop-down list and set up a particular price of this product

• In Special Price: Set up a special price of this product in English store view

• In Tier price For Store View: Click Add Tier for adding new Tier prices

Finally, you save configuration and see the changes from the frontend page

Prices of Madison 8GB Digital Media Player in the English store view from the product page:
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3. Set up price for a product in the French store view: Madison 8GB Digital Media Player, for example

3.1. Set up base currency and default currency for French store view

In Configuration, you go to General -> Currency Setup to set up base currency for French store view

Choose French store view from Current Configuration Scope

In Base Currency: Choose Euro as base currency and customers will use this one to checkout.

In Default Display Currency: you can choose Euro or any other currency because this one is only
displayed in the product or category page, not used in the checkout.

In Allowed Currencies: Choose Euro

Then, click to Save config and start to set up price for a product in the French store view

130 Chapter 29. Multiple Store View Pricing



Read the Docs Template Documentation, Release latest

3.2. Set up price for Madison 8GB Digital Media Player in the French store view

Go to Manage Products and choose Madison 8GB Digital Media Player to edit

Step 1: Choose French store view per store (Main Store) in Choose store view box

Step 2: In Price section (on the left side column), you unmark “Use Default Value” and add your wanted
price for the product in this French store view: 800, for instance

For Special prices, Group prices for Store View and Tier Prices For Store View, you do similarly to that
in English store view as mentioned before.

Finally you save configuration in go to the frontend to see the changes:

Prices of Madison 8GB Digital Media Player in the French store view from the product page:
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4. Conclusion

After all above settings, you can see differences in prices of Madison 8GB Digital Media Player between English and
French store view.

29.3 Compatibility

Our Multiple Store View Pricing is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

29.4 Changelog

Version 2.0.4:

• Fix bugs with Group Price

Version 2.0.5:

• Fix bugs with Special Price and Special Price dates

Version 2.0.6:

• Fix bugs with Catalog Price Rule

Version 2.0.7:

• Fix price display in category page
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29.5 How to Delete Multiple Store View Pricing extension

Step 1: Go to Admin -> System -> Configuration -> Catalog -> Catalog Price Scope

You change Catalog Price Scope to Website or Global

Step 2: Go to Admin -> Catalog-> Attributes -> Manage Attributes

You need to delete 2 attributes with attribute code as “tier_price_for_store” and “group_price_for_store”

Step 3: Setup base currency again by navigating to Admin -> System -> Configuration -> Currency Setup ->
Base Currency

Step 4: Delete product prices at each store view

You upload the delete_price_store.php file to Magento root folder and run it. It is noticeable that you had better
backup the catalog_product_entity_decimal table in DB before running.

This is the script of the delete_price_store.php file:

<?php
require_once('app/Mage.php');
umask(0);
Mage::app();

$resource = Mage::getSingleton('core/resource');
$readConnection = $resource->getConnection('core_read');
$writeConnection = $resource->getConnection('core_write');

$query = "SELECT attribute_id FROM " . Mage::getSingleton('core/resource')->
→˓getTableName('eav/attribute') . "
WHERE attribute_code = 'price' AND backend_model != '' LIMIT 1";

$attribute_id = $readConnection->fetchOne($query);

if($attribute_id) {
$query = "DELETE FROM ".Mage::getSingleton('core/resource')->getTableName(

→˓'catalog_product_entity_decimal')."
WHERE `attribute_id` = ".$attribute_id." AND `store_id` != '0'";

$writeConnection->query($query);
}

echo 'Delete price per store view success.';
echo '<br>';

$query = "SELECT attribute_id FROM " . Mage::getSingleton('core/resource')->
→˓getTableName('eav/attribute') . "
WHERE attribute_code = 'special_price' AND backend_model != '' LIMIT 1";

$attribute_id = $readConnection->fetchOne($query);
if($attribute_id) {

$query = "DELETE FROM ".Mage::getSingleton('core/resource')->getTableName(
→˓'catalog_product_entity_decimal')."

WHERE `attribute_id` = ".$attribute_id." AND `store_id` != '0'";

(continues on next page)
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(continued from previous page)

$writeConnection->query($query);
}

echo 'Delete special price per store view success.';

Step 5: Remove the code of the module

You delete the folder: app/code/local/Bss/MultiStoreViewPricing and

also remove the file: app/etc/modules/Bss_MultiStoreViewPricing.xml

Step 6: Finally, you should clear all caches

29.6 FAQs

29.7 How to Import Price with Data Flow

Step 1

Go to Admin - System - Import/Export - Dataflow - Profiles

Step 2

Choose “Import All Products” in the Profile Name tab

Step 3

• Click to the Upload File section

• Upload the CSV file that you want to import

• Click to Save Files button

This is a sample file that you can take as a reference:

Download a Sample CSV file here: import_price_dataflow (copy).csv

You need to complete this CSV file with necessary information about products: store view codes, SKUs, prices and
special prices

You go to System - Manage Stores to get a store view code. For example, English store view has a code as default.

Step 4

• Click to the Run Profiles section

• Select the uploaded csv file

• Click to Run Profile in Popup button in order to import prices

Step 5

Finally, go to Catalog - Manage Products to check prices and special prices of products at each store view.

29.8 Import Product Price Per Store View

Step 1: Export file

• Go to System -> Import/ Export -> Export
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• In Entity Type, choose Product

• Skip unnecessary attributes. If you just want to make change to price attribute, you can skip all
entity attributes except SKU, price, special price

• Click Continue at the right bottom corner of the table to download a CSV file to your computer.

Step 2: Set up price for store view

• Open the CSV file

• Find SKU of the product you want to set up price for store view

• In the _store column equivalent to each SKU, replace the current store code by code of store view
or add a new row to add new code of store view (Check code of store views at System -> Manage
Store)

• Fill in equivalent price and special price for in price and special_price column as you want

• Save file

Step 3: Import file

• Go to System -> Import/ Export -> Import

• In Entity Type, choose Product

• In Import Behavior, choose Append Complex Data

• Upload the CSV file that you have made changes in step 2
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29.9 How to update product price per Magento store view by SOAP
API v2

Step 1: Create an an API account to use SOAP

You go to System -> Web Services -> SOAP/XML-RPC -> Roles to create Roles

In Role Resources, tick Update (as the following image) to have rights to update products :

Next, you go to System -> Web Services -> SOAP/XML-RPC -> Users to create users. In User Role, you choose
Roles that you have just created.
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Step 2: Call API to update product price per store view)

• Assume that the account created in the step 1 has the following information:

– User name: api

– Password: api123

• You use this code to run update:

// If some stuff requires api authentification,
// then get a session token
$session = $client->login('api', 'api123');
$result = $client->catalogProductUpdate(

$session,
{product_sku},
array(

'price' => {price},
),
{store}

);

*Note: you need to change some things such as:

• Replace {magentohost} by the domain of the website that you want to update

• Replace {product_sku} by the SKU of product that you want to update

• Replace {price} by prices that you want to update

• Replace {store} by store code or store idd of store that you want to update product price
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CHAPTER 30

Order Delivery Date

30.1 User Guide

30.1.1 Order Delivery Date Extension Overview

After installing Order Delivery Date Extension, your customers can choose their preferable delivery arrival dates and
can leave a message for their postal or delivery person as well. With Order Delivery Date, store owners can set their
own regulations including “Cut off Time”, “Processing time”, “Holidays/Exclude Days/Blackout Days” in backend.
In specific time and date fixed, customers cannot choose these options and these dates because they will be fader than
the others and non-clickable.

30.1.2 How does Order Delivery Date Extension work?

The Order Delivery Date professionally provides an advanced configuration to determine where to place delivery date
from customers.

You can set the most convenient delivery schedule for your business and your customers. Check it in System ->
Configuration -> Order Delivery.

In “Display at”, you can set up where the delivery date customization will display. It means the steps in the check-out
process at which customers can give their requirements of delivery.

139

http://bsscommerce.com/magento-order-delivery-date-extension.html


Read the Docs Template Documentation, Release latest

“Processing time” is a minimal time that store owner can process purchasing order and start delivering your goods.
For instance, admin sets the processing time is 2 days then customers can choose after 3 days processing time.

“Cut off time” is defined as the “last hour” they can order goods. If customers place order after this time, the date
when orders made will be counted as the following day

With Order Delivery Date, admin can also exclude holidays or blackout days by choosing exactly days from the table
“Holidays/Exclude Days/Blackout Days”
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These unavailable days will come up as processing days, fader and non-clickable.

Beside the days excluded, if a company or store wants to disable any other days which are not suitable for shipping
goods for their own reasons or regulations, “Time Slots” will be selected as store owners’ wishes. Then customers
can choose one of options as below:
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In case, customers find hard to choose one of available slots, they can comment directly in the box “Delivery com-
ments”

Finally, your customer can see all of their requirements including order delivery date info through transactional emails
sent out to them
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To add Order Delivery Date info to transactional emails, please check out below example.

We will do an example about inserting delivery date in the New Order Confirmation Template.

Step 1: Go through System -> Transactional Emails -> Add new template:

In Load Default Template: choose the email template in which you want to add delivery date (New Order in this
case) and then click “Load Template” button.

In Template Information:

• Firstly, set up Template name (New Order Delivery Date, for example)

• Secondly, set up Delivery Date as your wish in Template Content by adding:

+{{var deliverydate_arrival_date}} in corresponding to Shipping Arrival Date: xxxx
(xxx is the time in each order)

+{{var deliverydate_comment}} in corresponding to Shipping Arrival Comment: xxxx
(xxxx is the comment in each order)

• Finally, click “Save Template” button

Step 2: Go through System -> Configurable -> Sales Emails -> Tab Order
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In New Order Confirmation Template, you choose the name of the template created in the previous steps and click
“Save Config” button.

As a result, your email to confirm orders sent to customers will be added with delivery date information.
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You can do the same when creating/editing other email templates to add delivery date information.

30.2 Compatibility

Our Order Delivery Date is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

30.3 Changelog

Advanced Version 2.0.0:

• Insert delivery date Information in variable tabs: Orders, Invoices, Shipments and Credit Memos

• Embed order delivery information into confirmation email

• Add delivery date information into new order created from backend
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• Include order delivery date in pdf files of invoice, shipment and credit memo

Advanced Version 2.0.2:

• Add option to display delivery date on product pages

• Correct time difference issue

• New Feature: Option to show Delivery Date info on Orders Grid View Page

30.4 FAQs
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Percentage Tier Price

31.1 User Guide

31.1.1 Magento Percentage Tier Price Extension Overview

Magento Percentage Tier Price extension extends default Magento Tier Price function by allowing admin to define tier
prices as a percentage.

• Easily set up tier price based on standard price or group price

• Set tier price in a fixed amount or in percentage

• Automatically update tier price when price is changed

Magento Percentage Tier Price updates the tier prices according to the percentages you have inputted when you update
the price of your product. This extension will effectively reduces your time-consuming and optimizes your sale activity.

31.1.2 How does Magento Percentage Tier Price work?

1. Instruction Manual

As an admin, you can set up your own store page by the most effective way that supports your trading objective. To
polish the website configuration:

• Step 1: Go to Admin Panel => System => Configuration.

• Step 2: At the left side of the page, find BSS Commerce => select Percentage Tier Price.

After these 2 steps, a screen for configuration appears like the following picture:
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The General tab appears with a box named “Enabled” for admin to enable Percentage Tier Price extension. There
are 2 options in the box: Yes or No. Choose Yes to enable the extension, choose No to not.

After that, don’t forget to click on Save config button to continue the configuration.

2. Set up tier price in percentage or a fix amount based on standard price or group price

To continue setting up tier price based on standard price or group price for each product, go to Catalog => Manage
Products.

The list of all products that are available in your own store is shown up.

Click on Edit button at right side to set up tier price for each shown-up product on the list.

After choose to edit the product price, go to board Product Information on the left => choose Price to see standard
price.
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*In this example, standard price of the product which being set up tier price is $50.

Next, go to Percentage Tier Price to set up the tier price as you want. There are 2 sections for admin to configure:
Group Price and Tier Price.

• In Group Price, click on Add Group Price button to add specific price for each customer group.

*In this example, the group price for “Not logged in” customers is $50, for “General” customers is $45, for Whole-
salers is $40.

• In Tier Price, click on Add Tier button to set up tier price in percentage or a fixed amount for each customer
group based on Standard price and Group price.

There are 4 criterias admin need to know and fill in: Customer Group, Quantity, Discount Type, Applied Price, Tier
Value.

+In Customer Group column, choose each customer group (E.g: Not Logged In, General, Wholesale,
VIP Member, Private Sales Member?) you want to set tier price on.

+In Qty column, fill minimum quantity of product which each customer group has to buy with to get the
tier price.

+In Type column, there are 2 types of discount: Fixed and % Discount. Choose one of them to apply on
new tier price.

+In Of column, choose 1 of 2 options to apply discount on: Standard Price and Group Price. Remember
that if admin choose Fixed on Type column, this section is disabled.
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+In Value column, fill with new value for tier price by a new dollar amount (for fixed discount) or by
percentage (for % discount)

*For this example:

-Only when not-logged-in customers buy this product with at least 5 items, they will get the new tired price which is
fixed-discount ($47).

-Only when general customers buy this product with at least 10 items, they will get the new tier price which is 5%
discount on the standard price ($50).

The new tier price = $50 - $50*5% = $47.5

-Only when the wholesalers buy this product with at least 15 items, they will get the tier price which is 10% discount
on the group price ($40)

The new tier price = $40 - $40*10% = $36

After all, click on Save or Save and continue edit buttons to save the configuration. All the tier prices will be
automatically updated and displayed on frontend.

31.2 Compatibility

Our Percentage Tier Price is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

31.3 Changelog

31.4 FAQs
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CHAPTER 32

Pro Configurable Product Grid Table View

32.1 User Guide

32.1.1 Pro Configurable Product Grid Table View Extension’s Overview

Pro Configurable Products Table View enables Magento Shop Owners to display associated products, creating a neat
and professional table to show specific features of selected products, especially including color-swatch function built-
in and tier price display.
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32.1.2 How does Pro Configurable Product Grid Table View Extension work?

1. In the frontend

Detailed explanation

• Professional grid view table for configurable products

• Ability to increase/ decrease product quantity in convenient table and automatically calculate the total
payment

• Built-in Color swatch function

– Color swatch displays as label with Magento version 1.4.x to 1.8.x

– Color swatch displays as picture with Magento version 1.9.x

• Tier price display for configurable product

• Demonstrate in stock/ out of stock status

• Display different price and tier price for each simple product

• Display the price range of configurable product

• Allow customer to add more than one product configuration to cart at a time
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2. How to configure Pro Configurable Products Grid Table View Extension in the backend

Go through System -> Configuration -> BSS COMMERCE -> Configurable Grid View
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• In Enable: Choose Yes/ No to enable or disable the module

• In Enable jQuery Library: Choose Yes/ No to enable or disable jQuery Library. You can also choose to
display Stock Availability. When you enable it, you

can see stock availability in the configurable grid table.

• In Show Subtotal, you can choose Yes or No to display or hide the subtotal column

• You can choose to show or hide Tier Price by selecting Yes or No

• In Use Option Swatch: Choose Yes or No to enable/disable Swatch

• In Configurable Product Use Simple Price:

If you choose Yes, you have to do the two following things:

+You have to set different prices for simple products.

Go through: Catalog -> Manage Catalog

You click to each simple product to set price and choose Price in Product Information:
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In Price: you set specific price for the product

+Set different tier prices of simple products for ranges of quantities (the quantity ranges of products are
the same):

In Tier Price, click Add Tier to set up specific tier price for each range of quantity and customer group

The pro configurable product grid table view is displayed as below:

If you choose No, this extension will display the prices of configurable products instead of the different prices of
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simple products.

The pro configurable product grid table view is displayed as below:

• In Show Unit Price: Choose Yes to display unit price column in the grid table view and choose No to hide it.

32.2 Compatibility

Our Pro Configurable Grid Table View is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

32.3 Changelog

Version 1.0.0:

• Showing table price with product tier price

• Showing color swatch

• Modify product quantity

• Including product attributes

Version 1.0.1:

• Compatible with Magento option of sending the user to the cart or leaving them on the page

• Auto selected quantity on product config page when editing the item from shopping cart

• Using the increment qty control of current theme instead of forcing to use the up down arrow

Version 1.0.8: Stable Version

Version 1.1.1: Update New Feature
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• Support Simple Product Pricing

32.4 Common Problems

How to fix “Please specify the product’s option(s)” error?

Common error with Pro configurable product grid table view extension is conflict with ajax add to cart extension. The
conflict is shown with error message “Please specify the product’s option(s)”

Please find below some ways to fix this issue with some ajax add to cart extension from various extension’s provider.

1. Conflict with Smartwave_Ajaxcart

Edit file : Smartwave/Ajaxcart/controller/IndexController.php

• Edit function addAction();

• Edit extends => Bss_Configurablegridview_CartController

Sample file: https://www.dropbox.com/s/1xzfpakoqftlk3t/IndexController.php?dl=0

2. Conflict with PT_Ajax

edit file: PT/Ajax/controllers/Checkout/CartController.php

• Edit extends Bss_Configurablegridview_CartController

• Edit function addAction();

• Edit function updateItemOptionsAction();

Sample file: https://www.dropbox.com/s/qvlfx1jg2z6743r/PT_Ajax_CartController.php?dl=0

3. Conflict with Amasty Ajax add to cart

In the file: app/code/local/Amasty/Cart/controllers/AjaxController.php

Add function: _initProduct();

Edit function indexAction() into:

public function indexAction()
{

$idProduct = Mage::app()->getRequest()->getParam('product_id');
$idProduct = Mage::app()->getRequest()->getParam('product')? Mage::app()->

→˓getRequest()->getParam('product'): $idProduct;
$IsProductView = Mage::app()->getRequest()->getParam('IsProductView');
$params = Mage::app()->getRequest()->getParams();
$related = $this->getRequest()->getParam('related_product');
unset($params['product_id']);
unset($params['IsProductView']);

if($this->getRequest()->getParam('configurable_grid_table') == 'Yes') {
$params = $this->getRequest()->getParams();
$config_super_attributes = $params['super_attribute_quickshop'];
$cart = Mage::getSingleton('checkout/cart');
$config_table_qty = $params['config_table_qty'];
$options = isset($params['options']) ? $params['options'] : null;

$qty_config = array();

foreach($config_table_qty as $sup_qty => $_super_qty) {

(continues on next page)
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(continued from previous page)

$qty_config[$sup_qty] =$_super_qty;
$required += $_super_qty;

}

if($required == 0) {
$this->_getSession()->addError($this->__('Cannot add the item to shopping

→˓cart.'));
$this->_goBack();
return;

}

$config_table_qty = $qty_config;

foreach($config_super_attributes as $sId => $config_attribute) {
if(!isset($config_table_qty[$sId]) || $config_table_qty[$sId]=='' || !is_

→˓numeric($config_table_qty[$sId])){
if($config_table_qty[$sId] != '0'){
$config_table_qty[$sId] = 1;

}
}

if(isset($config_table_qty[$sId]) && $config_table_qty[$sId]!='' && $config_
→˓table_qty[$sId] > 0) {

$product= $this->_initProduct();
$related= $this->getRequest()->getParam('related_product');

if (!$product) {
$this->_goBack();
return;

}

if(isset($config_table_qty[$sId])) {
$params = array();
$params['qty'] = $config_table_qty[$sId];
$params['super_attribute'] = $config_attribute;

if($options != null) $params['options'] = $options;

try {
if($params['qty'] > 0 && $params['qty']!='') {
$cart->addProduct($product, $params);
if (!empty($related)) {

$cart->addProductsByIds(explode(',', $related));
}
$cart->save();
Mage::getSingleton('checkout/session')->setCartWasUpdated(true);
if (!$cart->getQuote()->getHasError()){

$responseText = $this->addToCartResponse($product, $cart,
→˓$IsProductView, $params,0);

}
} else {
$responseText = $this->showOptionsResponse($product,

→˓$IsProductView);
}

} catch (Exception $e) {
$responseText = $this->addToCartResponse($product, $cart,

→˓$IsProductView, $params, $e->getMessage());
(continues on next page)
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(continued from previous page)

Mage::logException($e);
}

}
}

}
} else {

if($related) unset($params['related_product']);
$product = Mage::getModel('catalog/product')

->setStoreId(Mage::app()->getStore()->getId())
->load($idProduct);

$responseText = '';
if ($product->getId())
{

if(!array_key_exists('qty', $params)) {
$params['qty'] = $product->getStockItem()->getMinSaleQty();

}
try{

if(($product->getTypeId() == 'simple' && !($product->
→˓getRequiredOptions() || (Mage::getStoreConfig('amcart/general/display_options') &&
→˓$product->getHasOptions())))

|| count($params) > 2
|| ($product->getTypeId() == 'virtual' && !($product->

→˓getRequiredOptions() || (Mage::getStoreConfig('amcart/general/display_options') &&
→˓$product->getHasOptions()))))

{
$cart = Mage::getSingleton('checkout/cart');
$cart->addProduct($product, $params);

if (!empty($related)) {
$cart->addProductsByIds(explode(',', $related));

}
$cart->save();
Mage::getSingleton('checkout/session')->setCartWasUpdated(true);
if (!$cart->getQuote()->getHasError()){

$responseText = $this->addToCartResponse($product, $cart,
→˓$IsProductView, $params,0);

}
}
else{

$responseText = $this->showOptionsResponse($product,
→˓$IsProductView);

}

}
catch (Exception $e) {

$responseText = $this->addToCartResponse($product, $cart,
→˓$IsProductView, $params, $e->getMessage());

Mage::logException($e);
}

}
}
$this->getResponse()->setBody($responseText);

}

Sample file: https://www.dropbox.com/s/vz9bjgx9rd2ue97/AjaxController.php?dl=0

4. Conflict with Magentothem_Ajaxcartsuper

Edit file: /app/code/local/Magentothem/Ajaxcartsuper/controllers/AjaxcartController.php
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Edit function addAction() to:

{quote}public function addAction()
{

header("Content-type: application/json");

if($this->getRequest()->getParam('callback')) {
$cart = $this->_getCart();
$ajaxData = array();
$productInfo = array();
$params = $this->getRequest()->getParams();

try {
if($this->getRequest()->getParam('configurable_grid_table') == 'Yes')

→˓{
$params = $this->getRequest()->getParams();
$config_super_attributes = $params['super_attribute_quickshop'];
$cart = $this->_getCart();
$config_table_qty = $params['config_table_qty'];
$options = isset($params['options']) ? $params['options'] : null;
$qty_config = array();
foreach($config_table_qty as $sup_qty => $_super_qty) {

$qty_config[$sup_qty] =$_super_qty;
$required += $_super_qty;

}
if($required == 0) {
$this->_getSession()->addError($this->__('Cannot add the item

→˓to shopping cart.'));
$this->_goBack();
return;

}
$config_table_qty = $qty_config;
foreach($config_super_attributes as $sId => $config_attribute) {
if(isset($config_table_qty[$sId]) && $config_table_qty[$sId]!='

→˓' && $config_table_qty[$sId] > 0) {
$product= $this->_initProduct();
$related= $this->getRequest()->getParam('related_product');
if (!$product) {
$this->_goBack();
return;

}
if(isset($config_table_qty[$sId])) {
$params2 = array();
$params2['qty'] = $config_table_qty[$sId];
$params2['super_attribute'] = $config_attribute;
if($options != null) $params2['options'] = $options;
if($params2['qty'] > 0 && $params2['qty']!='') {
$cart->addProduct($product, $params2);
if (!empty($related)) {
$cart->addProductsByIds(explode(',', $related));

}
}

}
}

}
} else {

if (isset($params['qty'])) {
$filter = new Zend_Filter_LocalizedToNormalized(

(continues on next page)
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array('locale' => Mage::app()->getLocale()->
→˓getLocaleCode())

);

$params['qty'] = $filter->filter($params['qty']);
}

$product = $this->_initProduct();
if($params['type_product']==1) {

$productInfo['type_product'] = $product->getTypeId();
$this->getResponse()->setBody(Mage::helper('core')->

→˓jsonEncode($productInfo));
return ;

}

$related = $this->getRequest()->getParam('related_product');

/**
* Check product availability

*/
if (!$product) {

$ajaxData['status'] = 0;
$ajaxData['message'] = $this->__('Unable to find Product

→˓ID');
}

$cart->addProduct($product, $params);

if (!empty($related)) {
$cart->addProductsByIds(explode(',', $related));

}
}

$cart->save();
$this->_getSession()->setCartWasUpdated(true);

/**

* @todo remove wishlist observer processAddToCart

*/

Mage::dispatchEvent('checkout_cart_add_product_complete',

array('product' => $product, 'request' => $this->getRequest(),
→˓'response' => $this->getResponse())

);

if (!$this->_getSession()->getNoCartRedirect(true)) {
if (!$cart->getQuote()->getHasError()){

$message = $this->__('%s was added to your shopping cart.',
→˓Mage::helper('core')->escapeHtml($product->getName()));

// $this->_getSession()->addSuccess($message);
(continues on next page)
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$ajaxData['status'] = 1;
$this->loadLayout();
$sidebarCart = "";
$mini_cart = "";
$toplink = "";

if ($this->getLayout()->getBlock('cart_sidebar')) {
$sidebarCart = $this->getLayout()->getBlock('cart_sidebar

→˓')->toHtml();
}

if ($this->getLayout()->getBlock('cart_sidebar_mini')) {
$mini_cart = $this->getLayout()->getBlock('cart_sidebar_

→˓mini')->toHtml();
}

if ($this->getLayout()->getBlock('top.links')) {
$toplink = $this->getLayout()->getBlock('top.links')->

→˓toHtml();
}

$pimage = Mage::helper('catalog/image')->init($product,
→˓'small_image')->resize(55);

$ajaxData['sidebar_cart'] = $sidebarCart;
$ajaxData['top_link'] = $toplink;
$ajaxData['mini_cart'] = $mini_cart;
//show or hide cofirmbox when add product to cart

if (Mage::getStoreConfig('ajaxcartsuper/ajaxcartsuper_config/
→˓show_confirm')) {

$ajaxData['product_info'] = Mage::helper('ajaxcartsuper/
→˓data')->productHtml($product->getName(), $product->getProductUrl(), $pimage);

}

}

}
} catch (Mage_Core_Exception $e) {

$msg = "";

if ($this->_getSession()->getUseNotice(true)) {
$msg = $e->getMessage();

} else {
$messages = array_unique(explode("\n", $e->getMessage()));
foreach ($messages as $message) {

$msg .= $message . '<br/>';
}

}

$ajaxData['status'] = 0;
$ajaxData['message'] = $msg;
$ajaxData['type_product_ajax'] = 1;

} catch (Exception $e) {
$ajaxData['status'] = 0;
$ajaxData['message'] = $this->__('Cannot add the this product to

→˓shopping cart.');
(continues on next page)
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(continued from previous page)

}
$this->getResponse()->setBody($this->getRequest()->getParam('callback').'(

→˓'.Mage::helper('core')->jsonEncode($ajaxData).')');
return;

} else {
parent::addAction();

}
}{quote}

Sample file: https://www.dropbox.com/s/frkidfqdke3p5kp/AjaxcartController.php?dl=0

32.5 FAQs

32.5.1 Features

What is the difference between Configurable product grid table view and Pro configurable product grid table
view?

The differences are mainly concentrated on some advanced features of Pro configurable product grid table view com-
pared with normal version:

• Support tier prices: specific price for each range of quantity

• Support Color Swatch

• Support Simple product pricing

What is Color Swatch function?

Color swatch is the function that helps customers to show configurable products with different colors and designs
when they click to each attribute such as color, fabric or size (attributes depend on your configurable products)

What is the function of simple product pricing?

Simple product pricing means that the module will display different prices and tier prices of simple products instead
of configurable products in the table

Can I add multiple products to cart at once?

Yes, of course. You absolutely add a lot of products to cart at one time just by choosing your desired quantities.

In what cases does color swatch display as a label or as a picture?

• Color swatch displays as label with Magento version 1.4.x to 1.8.x

• Color swatch displays as picture with Magento version 1.9.x

Can I show price ranges in the category page?

Yes, you can. Price ranges of configurable products are displayed in the category page under both grid list and product
list.

How is the price range of a configurable product shown in the category page determined?

The price range of configurable product is determined by the lowest price (or tier prices) and the highest price (or tier
prices) of children products
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32.5.2 Guide

Can I enable Jquery Library in your extension?

Yes, it supports you to enable Jquery Library.

If I set Yes for Configurable products use simple price, what will I have to do next?

When you use simple product pricing for your configurable products, you have to set up prices and tier prices for
children product by going through Catalog-> Manage Product and choose each simple product to set up these prices
in the Price section.

If I do not choose to use Simple product pricing, so what are the prices of children products displayed in the
table and May I make any configuration in the Price section of children products?

In case you do not want to use simple product pricing, prices of children products are prices of your configurable
products. It means that these prices (or tier prices) of simple products are the same in the table.

So you needn’t configure anything in the price section of each simple product other than set No for Configurable
products use simple price

How to disable Color Swatch for my configurable products?

You go through System->Configuration->Configurable Grid View

In Use Option Swatch, you set No to disable this function
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CHAPTER 33

Redirect Cart to Checkout Page

33.1 User Guide

33.2 Compatibility

Our Magento Redirect Cart to Checkout Page is compatible with:

• Community: 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

33.3 Changelog

33.4 FAQs
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CHAPTER 34

Reorder Product

34.1 User Guide

34.1.1 Magento Reorder Extension Overview

Magento Reorder Products is an excellent extension that facilitates customers to reorder products on their dashboard.
Your customers can rearrange product positions as they wish, which increases their satisfaction with your services.
Magento Reorder Product Extension allows customers to quickly reorder their previously chosen products and make
any necessary changes as they wish!

This extension enables to separate reorder product section on customer account page to a board named My reorder
product which helps customers reorder any products they want instantly and easily add them back to cart as fastest as
possible for checkout.
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34.1.2 How Magento Reorder Extension works

In order to configure BSS Reorder extension,

Step 1: Go to Admin Panel => System => Configuration

Step 2: At the left side of the page, find BSS Commerce => select Reorder Products

After these 2 steps, a screen for configuration appears like the following picture:

There are two sections for admin to continue configuration: General Settings and Products List Settings.

• First section: General Settings

In Display Controls box, choose Yes to enable the extension. To disable all functions of this exten-
sion, choose No.

• Second section: Product List settings

Sort By box allows admin to choose from listed options for setting the arrangement of reorder prod-
ucts in “My Reorder Products” board of customer account page.

Admin can set customer’s reoder products by 3 following features: Name, Price, Recent Order.

In Maximum Order amount box, type the maximum amount of orders that can be reordered.

For all orders with total amount is more than this typed amount will not be able to be reordered and will not be
displayed in “My reorder products” board of customer account page.
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After all above configuration is done, you save the configuration by clicking on Save config button to the right of the
backend. To see the change, go to frontend and reload the page.

34.2 Compatibility

Our Reorder Product is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

34.3 Changelog

Version 1.2.2:

• Allow reorder cancelled orders

34.4 FAQs
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CHAPTER 35

Rich Snippets

35.1 User Guide

35.2 Compatibility

Our Magento Rich Snippet is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

35.3 Changelog

35.4 FAQs
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CHAPTER 36

SEO Layered Navigation

36.1 User Guide

36.1.1 SEO Layered Navigation Extension Overview

Filtering product with layered navigation is a very useful tool that Magento supports users. However, it still has a lot of
disadvantages: selecting only one option at once; inflexible price filter; unfriendly URLs? It will take much valuable
time as well as be inconvenient for users. With the aim of providing best experience in filtering product by layered
navigation, BSSCommerce launched Magento SEO Layered Navigation Extension to improve all above drawbacks of
Magento default.

SEO Layered Navigation Extension provides powerful functions that help users to filter products in the most effective
way. Thus, your site will become more professional and user- friendlier, which is an important factor that keeps loyal
customers as well as enhance business performance.

36.1.2 How does SEO Layered Navigation Extension work?

1. SEO Layered Navigation Setting

To make configuration of this module, follow these below instruction:

• Step 1: Go to Admin Panel =>System => Configuration

• Step 2: At the left side of the page, find BSS Commerce => select SEO Layered Navigation

After these 2 steps, a screen for configuration appears like the below picture:
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There are 4 main parts you can fix as your wishes: General settings, Price Filter, Decimal Filter, SEO Filter

1.1 General settings

• Enable jQuery

When setting up SEO Layered Navigation, you can also control Jquery Library in your website. You can select “Yes”
in Enable Jquery to allow Jquery Library combining with SEO Layered Navigation Extension when it runs on your
website.

• Expand/Collapse

In Expand/ Collapse, choose Yes/No to enable/ disable expand/ collapse function.

When this function is enabled, in frontend, users will have choice of expanding or collapsing an attribute as wish.
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• Use Ajax in Category View/ Search Result

You can manage whether to use Ajax to load product or not. Using Ajax will help you to load product only with
changed part instead of the whole page.

Select Yes/No to enable/disable Ajax loading for category view and search result separately.

1.2 Price Filter

• Display

In Display box, you can choose how to display price filter from 4 forms: Default, Slider, From/to, and finally combi-
nation of Slider and From/to

• Default: price will be displayed in fixed ranges as default of Magento

• Slider: price will be displayed in a slider which allows users to slide leftward and rightward to choose a suitable
price range

• From/to: users can add specific values into 2 input boxes and click Submit to select a suitable price range

• Slider and From/to: users can use both slider and input box to filter price

This is an example of Slider and From/to displaying:
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• Slider Step

In this field, you can decide how many price units will be added/ subtracted each time users slide rightward/ leftward.
For example, if you set up Slider Price = 3, users only can slider from $1 to $4 to $7 and so on.

• Show Currency in Slider

If you choose Yes, the currency will be displayed beside price in slider. If you choose No, it will be hidden.

• Slider Skin

In this field, you can choose the appearance of slider with 4 forms: Classic/ Round/ Plastic/ Round Plastic

1.3 Decimal Filter

In this field, you can set up how to display attributes which are in decimal forms such as size, weight, height, age?

Similar to Price Filter, you can decide how to display, slider step and slider skin for decimal filter.
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1.4 SEO Filter

If you enable SEO URLs, all URLs created after filtering will follow a logical rule. It will contain the product name
and selected attribute?s options.

For example, this is the URL created after user select pants and denim category, price from $75 to $510 and size 32
for a kind of men shirt:

2. Attribute Configuration

• Use in Layered Navigation

You can set up whether to show an attribute in layer navigation or not by going to Catalog -> Attributes -> Manage
Attributes

Select one attribute -> Attribute Property -> Frontend Properties, select from 3 options: No/ Filterable (with results)/
Filterable (with results)/ Filterable (no results) in field Use In Layered Navigation

• No: not show this attribute in layered navigation

• Filterable (with results): attribute will be shown in layered navigation only when result > 0

• Filterable (no results): attribute will be shown in layered navigation even when result = 0

• Use In Search Results Layered Navigation

Select Yes/No to set up whether to show attribute in search results layered navigation or not
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After finishing all of these set-up steps, you can click on Save Config button and go to frontend to see how SEO
Layered Navigation Extension makes change to your site.

36.2 Compatibility

Our SEO Layered Navigation is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

36.3 Changelog

v1.0.0

• First Release

36.4 FAQs

178 Chapter 36. SEO Layered Navigation

http://bsscommerce.com/magento-seo-layered-navigation.html
http://bsscommerce.com/magento-seo-layered-navigation.html


CHAPTER 37

Shipping Method for Category

37.1 User Guide

37.1.1 Magento Shipping Method for Category Extension Overview

Have you ever wished to disable one shipping method in some categories in Magento platform? As you know, in
Magento default, whenever admin sets up a shipping method in backend, this method will be applied for every product
in all categories. Therefore, it is difficult to set up some special Magento shipping methods by category. For instance,
your website sells both fresh and dried fishes. You can ship dried ones to customers via air highway, however, you
cannot do the same method with fresh fish, in this situation; you can have some troubles when setting up this method
in the backend.

With Magento Shipping Method for Category , managers do not need to worry about this problem anymore. This
extension allows admin to enable a shipping method based on category. As in the above example, admin can disable
airline shipping method of all fishes in ‘Fresh’ category in the backend.

37.1.2 How does Magento Shipping Method for Category extension work?

To make configuration of this module, follow these below instruction:

• Step 1: Go to Admin Panel => System => Configuration

• Step 2: At the left side of the page, find Sales => Shipping Methods => select Bss Shipping Method for
Category

After these 2 steps, a screen for configuration appears like the below picture:
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There are 8 parts you can fix as your wishes: Enabled, Title, Ship to Applicable Countries, Ship to Specific Countries,
Sort Order, Express Weight Threshold, Price, Disable for Category

1. Enabled

After opening this part in Shipping methods, you can enable the method by selecting “Yes” status in Enabled box.

2. Title

You can easily change the title name displayed on the frontend as a name of shipping method in Title box. As in the
example, the name of method is “BSS shipping method”, and then in the frontend page, this shipping method will also
appear in this name.

Backend
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Frontend

3. Ship to Applicable Countries

You can choose which countries this shipping method could be applied in the Ship to Applicable Countries box.

4. Ship to Specific Countries

If you decide the shipping method can only be used in some specific countries, you can select “Specific countries” in
Ship to Applicable Countries box.

Then you can select your wished countries in the table in the box Ship to Specific Countries.
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5. Sort Order

In the Sort Order box, you can decide the position of the Shipping method. For example you set in the Sort Order
box number 2, then in the front end the Bss shipping method will appear in the no.2 position.

Backend

Frontend

6. Express Weight Threshold

You also can set the maximum-allowed weight in this shipping method by filling the value in Express Weight Thresh-
old box.

7. Price

As another shipping method, to set the price for each method, you can fill the number in the Price box

8. Disable for Category

Finally part is also the most important part, which creates the difference from other Shipping method function.

You can control which product category can apply this shipping method or cannot apply. You can decide which
category will be not applied Bss Shipping Method by Disable for Category box. For example, if you choose Category
1, then when customer buys any products in category 1, Bss Shipping Method will not appear in customers’ shipping
options.
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After finishing all of these set-up steps, you can click on Save Config button to start using Shipping Method for
Category extension.

37.2 Compatibility

Our Shipping Method for Category is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

37.3 Changelog

Version 1.0.0:

• Compatible with all Magento 1 versions

• Allow disabling shipping method in some selected categories

37.4 FAQs
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CHAPTER 38

Shipping & Payment Methods Per Customer Group

38.1 User Guide

38.1.1 Magento Shipping and Payment Per Customer Group overview

Magento Shipping and Payment Per Customer Group enables admin to set up different shipping and payment methods
for various groups of customers. Once set up in the backend, only chosen methods display for particular customer
groups in the shipping and payment process in the frontend.

This extension permits admin to satisfy their customers by providing their customers the most suitable products in the
neatest organization.

38.1.2 How Magento Shipping and Payment per Customer Group works

After installing Magento Shipping and Payment Per Customer Group into your website, a new tab named Advanced
Shipping/Payment methods will appear in your backend page allowing admin to set up advanced shipping and pay-
ment methods for each specific customer group.

1. Set up Payment Methods for customer groups

To customize shipping methods for each specific customer group, follow steps below:

Go to Admin Panel => Advanced Shipping/Payment Methods => Payment methods

After that, a screen appears showing many payment methods for admin to make configuration.

NOTE: Before making configuration, you must firstly consider the Current scope for your configuration. Right in the
top, there is a “current scope” box, in which there have two options.

• Admin: If you choose the current scope to be Admin, the configuration runs in all of your websites.

• Main website: The configuration is only applied in the main website.
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Here, all payment methods which are set up by admin in payment section will be listed with various options of
customer groups.

In order to set up any payment method for customer group(s),

Choose the Payment method

Choose your desired customer group(s)

Save your configuration

For instance, if you wish to set up Payment by cards or by PayPal account for NOT LOGGED IN CUSTOMERS

Go to Payment by cards or by PayPal account

Click on NOT LOGGED IN

Click on “save Visibility settings” to save your configuration

The process is the same as other payment methods with any other customer groups.
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2. Set up Shipping Methods for customer groups

Go to Admin Panel => Advanced Shipping/Payment Methods => Shipping methods

After that, a screen appears showing many payment methods for admin to make configuration.

NOTE: Before making configuration, you must firstly consider the Current scope for your configuration. Right in the
top, there is a “current scope” box, in which there have two options.

• Admin: If you choose the current scope to be Admin, the configuration runs in all of your websites.

• Main store: The configuration is only applied in the main website.

Just the same as payment methods, all shipping methods which are set up by admin in shipping section will be listed
with various options of customer groups.

You can entirely configure the shipping methods for specific customer group:

Choose the Shipping method
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Choose your desired customer group(s)

Save your configuration.

For example: you would like to set flat rate, Federal express, United Parcel Service for General customers, In Flat rate,
Federal express, United Parcel Service, you click on General.

As a result, these shipping methods will be shown for general customers.

38.2 Compatibility

Our Shipping & Payment Per Customer Group is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x
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• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

38.3 Changelog

Version 2.1.4:

• Stable version

38.4 Common Problems

1. Solve conflicts between BSS Shipping and Payment Method per Customer Group and another module
(IG_FlatShipping5)

Step 1:

Edit file: /app/code/community/IG/FlatShipping5/Block/Available.php

Step 2:

Add fucntion

public function getShippingRates()
{
$modules = Mage::getConfig()>getNode('modules')>children();
$modulesArray = (array)$modules;
if(isset($modulesArray['Bss_Methods']) && Mage::helper('core')->

→˓isModuleEnabled('Bss_Methods')) {
if (empty($this->_rates)) {
$this->getAddress()>collectShippingRates()>save();
$groups = $this->getAddress()->getGroupedAllShippingRates();
// checking methods visibility for customer groups
foreach ($groups as $methodCode => $method){
if (!Mage::helper('bssmethods')->canUseMethod($methodCode, 'shipping

→˓')){
unset($groups[$methodCode]);

}

}
return $this->_rates = $groups;

}
return $this->_rates;

}
return parent::getShippingRates();

}

38.5 FAQs
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CHAPTER 39

Shopping Cart Rule per Store View

39.1 User Guide

39.1.1 Magento Shopping Cart Price Rule per Store View Extension Overview

If you are using multiple store views function to do business on your Magento site, have you ever had a demand of
creating different shopping cart rules for each store view? Do you want to offer different promotional prices for each
target customer group in each store view?

Magento Shopping Cart Price Rule per Store View Extension is developed to optimize the multiple store view function
by enabling admin to set up different price rules in shopping cart of different store views. With this powerful extension,
you can manage your promotional price strategy effectively, leading to boosting up sale and completing multiple store
view system.

39.1.2 How does Magento Shopping Cart Price Rule per Store View Extension
work?

1. Enable Shopping Cart Price Rule per Store View Extension

You go to System -> Configuration -> Shopping Cart Price Rules Per Store

After choosing Yes to enable the extension, click Save Config to start set up shopping cart price rules per store as wish.
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2. Set up different shopping cart price rules for products in each store view

Go to Promotions -> Shopping Cart Price Rules Manage Products and click Add New Rule to customize rules for
shopping cart in each store view.

• In Rule Information, fill in Rule Name, Description, Status and other fields with needed information
as usual.

• In Conditions, choose Store View as an option in condition for rule

Then choose one Store View in the list of Website/ store/ store view that you want to set up rule for it
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• In Actions, set up detail rules for the chosen store view

• Save configuration, then come back to Conditions and choose other store view to continue to set up

Example

Set up $ 100 discount rule for orders which have 3 items in English store view

Step 1: Creating Conditions

-Choose Store View as a condition and select English store view (Main Website/ Madison Island Store)

-Choose Total Items Quantity as a condition and fill in “3” in the box
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Step 2: Creating Rules

Go to Actions, choose Fixed amount discount for the whole cart as a rule to apply and fill in “100” in
Discount Amount box

Finally, save configuration and go to the frontend to see the changes:

• Shopping Cart in the English store view:
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• Shopping Cart in the French store view:

39.2 Compatibility

Our Shopping Cart Price Rule per Store View is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x
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39.3 Changelog

39.4 FAQs
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CHAPTER 40

Store Locator

40.1 User Guide

40.1.1 BSS Store Locator Overview

Magento Store Locator is an effective extension that efficiently supports your customers to search for store locations
in any eligible positions by using Google Map API. Equipped with various searching tools, this extension allows
customers to find stores by nation, state, zip code, suburb, their current location or a specific address in n-km radius.
Magento Store Locator is also designed to display the overview of stores so that customers can see and link to these
stores right when they find out them. As for admins, Magento Store Locator allows them to operate it as they wish in
the backend. By and large, this searching tool is an efficient extension that can surely motivate your trading in the way
that it supports customers to find your stores without difficulty.

40.1.2 How BSS Store Locator works?

1. Instruction Manual

1.1. Store Setting

As an admin, you can set up your own store in the way that it can most effectively support your trading aim. To set up
your store, go to “Store Locator -> Store Setting”
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A screen will appear like as follow:

• In “Enable for Filter” box, you can choose more than one criterion by pressing “Ctrl” and click on criteria
you want.
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• In “template” box, there are two templates for the frontend. The admins can choose between template 1 and
template 2 freely.

Template 1: Art template

Template 2: There are 2 types of interface: two-column & one-column
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• Two-column interface

Two-column interface on the front end

• One-column interface: In case the first seven criteria of “Enable for filter” box are not chosen, the
store will be automatically changed into one-column interface one
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Backend: choose 3 final criteria -> Frontend: One-column Interface

• Remember to save your setting by pressing “Save Configuration” button in the right top of the
screen, and wait until the green line “The configuration has been saved” appears.

• To see the change in the frontend, reload the frontend.

1.2. Store Management

This mode enables you to:

• Add new stores
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• Reset stores

• Export store’s database to csv file

To use this function, go through “Store Locator -> Manage Stores”

• Add A New Store:

There are two ways to add stores: add a new store manually or import stores using csv file when you want to add stores
in mass.

To add stores manually, please go to Store Locator ? Manage stores

then Choose Add New Store button
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Then, fill in required fields such as Business, Country, State, Postcode, Suburb and Address

NOTE: If admin does not provide longitude and latitude, BSS Store Locator will automatically search store locations
by Google map based on address. Thus, remember to check this carefully as Google may misunderstand your address.

1.3. Export and Import:

1.3.1. Export: BSS Store Locator allows admins to export database from store to csv file or XML file.

• To export database to csv file, go through “Store Locator -> Manage Store”. In “Export to” box, choose “csv
file -> Export”.

• After exporting, a csv file will be created and you can save it on your computer. When the file is opened, it
appear like this:
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Example of Exporting Database To csv File

1.3.2. Import:

• Firstly, export to see the file structure

• Secondly, add database into appropriate cells on file exported.

• Import into the system by going through: “Store Locator -> Import/Export -> Import”

You can choose freely overwriting existing files or not -> select file from your computer, then, press “Import”.

Unless you input co-ordinates, the system will automatically search through Google Map. However, if customers use
the system too many times on a daily basis, the system may be locked for one day. Unless you input longitude and
latitude of your stores, the system should be use less than 100 times per day.

2. Algorithms for finding stores

Once users choose input cells, the system will work out all the results that perfectly match the information users wish
to filter (country, state, city, postcode, or suburb).

• If no stores in the target location can be found, the BSS Store Locator will automatically find information about
the location in Google Maps and work out n nearest stores (in case the system can find the store in Google
Maps. If not, “0 Store Found” will be displayed).

• If customers use module “Use My Location”, the system will find n nearest stores in the vicinity of their
location.

• If users input the radius, the system will automatically search for locations of store within the provided radius
(via filter or location).

NOTE: n is the number of results to be shown in the frontend set by admins in the Store setting.

204 Chapter 40. Store Locator



Read the Docs Template Documentation, Release latest

40.2 Compatibility

Our Store Locator is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

40.3 Changelog

40.4 FAQs
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CHAPTER 41

Unboxed

41.1 User Guide

41.1.1 BSS Unboxed extension overview

Magento Unboxed Extension creatively uses customer unboxed product images as effective social proofs to attribute
on marketing efforts. The extension shows customer product images of your products they have JUST purchased in a
particular area and indirectly uses those images to attract more customers and make the higher conversion rate. There
is beyond two facts that: “when buying new items, whether in direct or indirect ways, clients are likely to show them
off and want to receive compliments from others.”

Not a few people are influenced by mob mentality. People are easily impacted by their peers to ratify assertive
behaviors, follow trends to buy items. There is also no deny that the power of visual content marketing can become
magical: “Use a picture. It’s worth a thousand words.”

41.1.2 How Magento Unboxed extension works

1. Manual instruction

As an admin, you can set up your own store page by the most effective way that supports your trading objective. To
make the configuration:

• Step 1: Go to System -> Configuration.

• Step 2: At the left side of the page, find BSSCOMMERCE -> select Unboxed

After these 2 steps, a screen for configuration appears like the following picture:
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There are many boxes displaying on the page for shop owners to configure as they want.

1.1. Enable module

In box Enable, there are 2 options for admin to choose: Yes or No. Choose Yes to enable the module, choose No to
disable it.

Save the configuration by clicking on Save config button on the right of the page.

1.2. Header displaying

To set up the display of header of your unboxed page on frontend, please follow these instructions.

• In box Logo, click on the button Choose File to browse from your computer a picture to display as your logo
on the frontend. Remember that there are 3 file types are allowed including *.jpg, *.png and *.gif. The picture
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uploaded from your computer will be resized to fixed size (300 x107 pixels).

• In box Enable Map, there are 2 options for admin to choose: Yes or No. Choose Yes to enable the map on
frontend, otherwise choose No.

• In box Name, type a name for the page as you desire (e.g: Unboxed)

• In box Info, type the text to describe the page to your customers

(e.g: Unboxed is gallery page displayed real pictures of products uploaded by real customers who have purchased
those products on our main website)

Save the configuration by clicking on Save config button on the right of the page. Then go to frontend, reload the page
and see the change.

That is an example for the page header displaying on frontend:

1.3. Footer displaying

The module allows admin to configure footer of the page with place special links and social media links.
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In all boxes named Footer Name 1, Footer Name 2, Footer Name 3, type in the boxes names of the footer links that
you want to show on frontend.

(e.g: Term & Conditions; Contact us)

In all boxes named Footer Link 1, Footer Link 2, Footer Link 3, copy and paste in the boxes the links you want to
redirect customer to.

Note: the footer names must be corresponding with the footer links

In box named Facebook Link, copy and paste in the box link of your facebook page

Do the same with other boxes named Pinterest Link, Instagram Link, Twitter Link

After that, save the configuration by clicking on Save config button on the right of the page. Then go to frontend,
reload the page and see the change.

That is an example for the page footer displaying on frontend:

2. Manage/Edit/Upload image by admin

2.1. Manage image

As an admin, you can manage all pictures uploaded. To find and manage all pictures, go to tab Unboxed on the top
(beside tab System), then click on Unboxed -> Manage

After that, pictures uploaded by all users will appear in a page like this:
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From this page, you can find customer’s basic information (customer name, customer email), pictures are uploaded by
which customers, picture uploading time and picture status. You also can filter picture by uploading time, picture ID,
customer name, customer email?

2.2. Edit image

• Step 1: To edit pictures from admin, find the picture you want to edit on the list and then click on Edit button:

After choosing edit the picture, a screen will appear for you to edit like this:
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• Step 2: In tab Information, you can edit the picture information and change the image as you want:

• In box Status, you can set for this picture enabled or disabled

• In box Title, type the title for the picture uploaded

• In box Description, type the text describing the picture uploaded

• In box Location, choose the location for the picture uploaded (auto-complete location searching)

• In box Upload Images, you can change the current image to other image by click on Choose File button, then
you will be able to browse image from your computer to upload.

After that, click on Save and Continue Edit button to save the configuration and continue editing.

• Step 3: In tab Product Tag, you can tag any product to the picture being edited. Here, a list of product will be
shown like this:
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You can tag one or more products on the list by clicking on the checkbox of column Select in each product line.

You also can filter product by name, SKU, attribute, product type, price?to find out the product you want to tag on the
picture.

Click on Save and Continue Edit button to save the configuration and continue editing.

• Step 4: In tab Comments, you can add comments for the picture being edited with any user account shown on
the list.

Find one user to give comment to the picture, then click on the checkbox on column Select like this following example:

Note: you can also filter user by name, email? to find out the relevant user who you want her/him to give comment on
the picture being edited.
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After choosing user, scroll down to the bottom of the page to write a comment under the name of the choosen user:

Click on Add button to add the comment you have already written on the picture. After adding comment, you will
receive a success notification, scroll up to the top to see the all comments added to the picture:

After all these steps, you have done picture edits. Click on Save button to save the result after editing. Go to front end,
reload the page and see the change.

2.3. Upload new image

• Step1: To upload new image by admin, click on Add new button on the right of the page.

• Step 2: After that, you have will be redirected to a page to choose user who will own the new picture first. Click
on checkbox in column Select to choose customer as you want:
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Note: you can create a new user as you want and upload image under this new customer yourself by going to Admin
Panel => Customer => Manage Customer => Add New Customer. After creating new customer, the new customer
information will appear on this list as an user of Unboxed page.

Click on Save and Continue Edit button to go to the next step.

• Step 3: Now you are in tab Information. In this tab, you fill all the boxes with image information and upload
your image from your computer as desired.

41.1. User Guide 215



Read the Docs Template Documentation, Release latest

• In box Status, you can set for this picture enabled or disabled

• In box Title, type the title for the picture uploaded

• In box Description, type the text describing the picture uploaded

• In box Location, choose the location for the picture uploaded (auto-complete location searching)

• In box Upload Images, upload new image by click on Choose File button, then you will be able to browse
image from your computer to upload.

After that, click on Save and Continue Edit button to save the configuration to go to the next step.

• Step4: In this last step, you are in tab Product Tag. In this tab, you can tag any product to the picture already
uploaded.

Here, a list of product will be shown like this:
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You can tag one or more products on the list by clicking on the checkbox of column Select in each product line.

You also can filter product by name, SKU, attribute, product type, price?to find out the product you want to tag on the
picture.

After all these steps, you have done uploading picture under a specific user name. Click on Save button to save the
result. Go to front end, reload the page and see the change.

41.2 Compatibility

Our Unboxed Extension is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

41.3 Changelog

Version 2.0.1 :

• Compatible with all Magento1 versions

• Compatible with Rwd responsive theme

41.4 FAQs
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CHAPTER 42

Wholesale Fast Order

42.1 User Guide

42.1.1 Wholesale Fast Order Extension Overview

Recently many researches have proved that even one second delay in buying process can engage your loyal customers
in abandoning your online store. Therefore, you can enhance your online store performance and encourage customers
to start searching and selecting products by using Wholesale Fast Order by BSS Commerce right now.

42.1.2 How does Wholesale Fast Order Extension work?

1. How to use functions of Wholesale Fast Order Extension

Wholesale Fast Order is a very useful extension that allows selecting multiple products at the same time and then
adding them to shopping cart without spending too much time purchasing one by one. By this way, Wholesale Fast
Order can optimize order process and decrease buying time by following these steps:

Step 1: Click “Fast Order” shortcut

When you install Wholesale Fast Order Extension, Fast Order shortcut will appear in the right side of your website.
Customers click to Fast Order shortcut and there is a Fast Order pop up for them to search.
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Step 2: Search products by typing names or SKU in the search boxes of the Fast Order pop up

There will be some suggestions for customers to choose and both names and SKU are included in the search results
with the highlighted search keyword.

Step 3: Select your wanted products with quantity and add them to cart
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In addition, customers also import a CSV file of products (just require product name and SKU) to carry out the buying
process faster without spending much time

If customers search for a configurable product, Wholesale Fast Order displays attributes in a pop up to choose. More-
over, you can edit product attributes and other custom options by clicking “EDIT” button.

Step 4: Customers can also view your shopping cart page to see chosen products. In the shopping cart page, there
may be Fast Order Section to help customers continue their searching process.
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Step 5: Process to checkout right after adding products into cart. The grand total will be automatically calculated as
you add multiple desired items to cart at a time.

2. How to configure Wholesale Fast in the backend

For Admin Configuration, go through “System > Configuration > BSS Commerce > Fast Order”.
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In Enabled: You can switch on/switch off Whole Sale Fast Order by choosing Yes or No it in the backend.

In Fast Order Display: Choose Popup to display Fast order function in a Popup. It will display a Fast Order shortcut
in Magento default toplink. If the site does not have toplink or toplink has been edited this setting does not take
effect. To put Fast Order shortcut to your wanted position please insert this html into the file you want the shortcut
will display:

<a href=”domain/fastorder/ajax/loadform/” title=”Fast Order” class=”bss-fastorder” data-
featherlight=”ajax”>Fast Order</a>

Select CMS Page if you want to show Fast Order in a CMS Page. It’s required to create a CMS Page from Admin
panel and add this code below into its content.

{{block type=”core/template” template=”bss/fastorder/form.phtml}}

In Enabled jQuery Library:

• Choose Yes to enable jQuery Library to run things related to jQuery.

• Choose No if your site already has jQuery Library already because it will cause some conflicts.

With Wholesale Fast Order, you can easily set up the number of lines shown in the pop up and the shopping cart page.
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In Number of lines (Shopping Cart): you set the number of lines of Fast Order shown in the Shopping cart. For
example, you set equal to 1 and the number of lines in the shopping cart is 1 as bellows:

In Number of lines (Pop up): you set the number of lines of Fast Order shown in the pop up. For example, you set
equal to 3 and Fast order pop up contains 3 lines as bellows:

If you set these numbers of lines equal to 0, there is not any fast order shown in the pop up and the shopping cart page.

In Autocomplete minimum characters: you set the minimum characters customers have to type in the search box so
that the result can appear.

In Max results to show: you set the number of results displayed in the autocomplete box

One of the differences of Wholesale Fast Order by BSS is the function of allowing admin to hide specific products
with certain customer groups in fast order’s searching box.
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In Enable for customer groups: you choose group for whom you do not want to enable Wholesale Fast Order

In Hide products with customer group: You click “Add” to choose customer group and add product names or SKU
that will be hidden from this group.

In XML of update blocks:

42.2 Compatibility

Our Wholesale Fast Order is compatible with:

• Community: 1.4.x.x, 1.5.x.x, 1.6.x.x, 1.7.x.x, 1.8.x.x, 1.9.x.x

• Enterprise: 1.12.x.x, 1.13.x.x, 1.14.x.x

42.3 Changelog

Version 2.0.2:

• Show shortcut to fast order popup on all web layouts

• Show popup of product attributes and custom options for customers when input configurable product in fast
order

• Allow customer to change product attributes and other custom options of configurable product by clicking on
EDIT button

• Automatically calculate total price when customers increase or decrease product quantiy
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• Allow customers to import product in fast order with CSV file

• Showing success message after products are successfully added to cart

• Allow admin to hide specific products with certain customer groups in fast order’s seaching box

Version 2.0.3:

• Switch on/ off fast order shortcut on web layouts

Version 2.0.9:

• New Feature: Allow display Fast Order in CMS Page

• Fix form key issue for Magento 1.9.2.3

Version 2.1.0:

42.4 Common Problems

1. Having problems with Currency Decimal separator?

In some countries Currency separator is ” , ” while ” . ” is used in US or UK. To fix problem when
installing Wholesale Fast Order on the store using Decimal separator as ” , ” please follow below changes:

Edit file: /skin/frontend/base/default/js/bss/fastorder.js

Change:

finalprice = Number(finalprice.replace(/[^0-9\.]+/g,""));

Into:

finalprice = Number(finalprice.replace("," , "."));

Change:

function convertPrice(price) {
price = parseFloat(price).toFixed(2).replace(/(\d)(?=(\d{3})+\.

→˓)/g, "$1,");
return price;

}

Into:

function convertPrice(price) {
price = parseFloat(price).toFixed(2);
price = price.replace(".",",");
price = price.replace(/(\d)(?=(\d{3})+\,)/g, "$1.")
return price;

}

42.5 FAQs

42.5.1 General

Is this extension compatible with Magento rwd theme?
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Yes, it is compatible with rwd theme of Magento

How can I get user guide of Wholesale Fast Order?

You can get user guide in the PDF file right on the product page of Wholesale Fast Order or user guide in this wiki

Do you provide free support and free installation for Wholesale Fast Order?

Yes, we will install and support you for free. When you request for installation, we will contact you for your credential
information (admin information, FTP account). However, free installation offer for Wholesale Fast Order is just valid
for 3 weeks since the purchase date, so after this period, you will pay an extra fee ($40) for installation request.

How can I install this module by myself?

You can follow Installation guide and carry out as instructed to install on your own.

42.5.2 Features

What types of products does your Magento extension support?

Magento Wholesale Fast Order extension by BSSCommerce can be applied to not only simple products but also
configurable products with custom options and virtual products.

Can I apply Magento Wholesale Fast Order for some certain customer groups?

Yes, you can. You configure it in “Enable for customer group” in the Magento admin panel and you select groups as
your wish.

I want to hide some products from retailer group but they still appear on Magento Wholesale Product list. Can
the extension do this? And how?

Yes. The extension supports the feature. You can hide some products from particular customer group. To do this, click
“Add” button on “Hide products with customer group” and complete information there.

Do I need to complete the product names when searching them?

No, you don’t. The only thing you need to do is typing the configured number of initial letters configured from the
backend of product names or SKUs, the AJAX search equipped shall automatically find the product as your needs.

For example, when you set “2” on “Autocomplete minimum characters” on the backend, AJAX search will find the
product when your customers type 2 initial letters of the product name or SKU on the frontend.

Can I search products by category, price or by description?

No, you cannot. Our extension allows you to search products by name and SKU.

Can I enable Jquery Library in your extension?

Yes, it supports you to enable Jquery Library.

42.5.3 Guide

I want Magento Fast Order to display as a page instead of Popup. What should I do?

You may go to the Magento backend, create a “Fast Order” page on CMS page. Then, complete page information
including page information, content, design and meta data. It is important for inserting the code string: “” on “Content”
bar of the page and complete page layout and custom design on “Design” bar. Afterward, click “Save and Continue
Edit”.

The next step, please go to Configuration. On Fast Order Display choose CMS Page and save. After that, go to
frontend and scroll down the page, you can click “QUICK ORDER” shortcut in your Magento site footer and see the
result.
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How are the configurable products set on Magento Wholesale Fast Order popup?

When a configurable product is searched and chosen, the popup showing different variants of the products with differ-
ent attributes will appear.

I do not want Fast Order to be shown in Shopping Cart, what should I do?

You just configure the setting from backend

Go through System-> Configuration-> BSSCommerce-> Fast Order

In Number of lines (Shopping cart), you set it to 0 or leave it blank and Fast Order Function will disappear in your
shopping cart page.

I do not want Magento Fast Order Popup shortcut to be displayed in Homepage, what should I do?

Please go to the backend, you can set 0 or leave it blank on “Number of lines (Popup)” to make Fast Order shortcut
disappear from Magento Homepage.

I have a list of products that I want to buy, how can I use Fast Order to buy all listed products without typing
each name or SKU one by one?

Magento Wholesale Fast Order Extension supports importing a CSV file containing product SKU and quantity for a
faster buying process. With this function, there is no need for you to insert product information one by one, which
save time.

You only need to save your list into a CSV file and upload this file in the Fast order pop up and then all listed products
are processed. Remember that products’ SKU and quantity are required in the CSV file.

How to manage the number of results shown in Fast Order popup?

In “Max results to show” from the Magento admin, you choose the number of results shown.

42.6 Translation

42.6.1 Instruction to translate text in BSS Wholesale Fast Order extension

Step 1. Go to folder app/locale/en_US/Bss_FastOrder.csv

• en_US: language folder. Depending on each site it has language folder according to the site?s language. In the
module, it already have US language folder.

According to the site?s language you have to copy file Bss_FastOrder.csv in to the language folder. For examplate, if
the site is in Japanese it?s required to copy Bss_FastOrder.csv into older ja_JP.

• Bss_FastOrder.csv is csv file of the module

Step 2. Enable file Bss_FastOrder.csv

In this csv file it stores all text of the module which is divided into 2 columns

https://gyazo.com/6980baccff367eb9ba15f9a590cf0737

You need to add translation into second column.
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CHAPTER 43

Add Multiple Products To Cart

43.1 User Guide

43.1.1 Add Multiple Products To Cart for Magento 2 Overview

For customers who want to buy a variety of products in default Magento store, they would have to spend more time
on the purchasing process as the default setting does not allow buyers to add many products to cart at once. It is
a real challenge for store owners especially those targeting for wholesalers. And BSSCommerce has come up with
an effective and useful solution to this problem by developing Add Multiple Products To Cart for Magento 2. The
extension helps customers to add multiple items to cart in different quantities at once on the homepage, category pages
and search result pages. Moreover, they can select custom options for the products without visiting the product pages
separately.

43.1.2 How does Add Multiple Products To Cart For Magento 2 work?

You go to Admin -> Store -> Configuration -> BSSCOMMERCE -> Ajax Add Multiple Products Cart and start
configuration
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In Enabled: Choose Yes to enable the module or choose No to disable it. The module can be enable/disable on Store
view level.

In Customer group: Choose customer group which you want to apply this module. Only customers in selected one
are allowed to add multiple products to cart.

In Apply addmultiple: Use class or id html to apply the module. For example, use “.products-grid,.products-list” for
the module to be applied in all pages with that class.

In Default qty: Select default quantity displaying in quantity box.
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In Image size (px) - For single add: Choose the image size of the product displaying in the success pop-up in case
of adding only one product to cart.

In Image size (px) - For multiple add list error: Choose the image size of the product displaying in the pop-up in
case of having error in adding multiple products to cart (unselected custom options, error in quantity).

In Image size (px) - For multiple add: Choose the image size of the products displaying in the success pop-up in
case of adding multiple products to cart.

In Number of Items: Choose the number of item displaying in one success pop-up slide at a time.

In Slide Speed: Choose the transition duration of the slide in a millisecond.

In Auto Slide: Choose Yes for the slide in the success pop-up to be moved automatically.

In Show “Continue” Button: Choose Yes to show the continue shopping button at the success pop-up.

In Show Product Price: Choose Yes show product price in success pop-up in case of adding only one product to cart.

In Show Product Image: Choose Yes to show the products’ images in the success pop-up.

In Countdown time for Button:

• Choose either View cart Button or Continue Button to show the countdown time.

• Choose No to not display the countdown time.

In Countdown time:. . . (s): Choose the period of time to countdown until redirecting to either View cart or Continue
shopping.

In Show mini cart: Choose Yes to display the mini cart on the success pop-up.

In Checkout link in mini cart: Choose Yes to show checkout link in the mini cart.
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In Text button add multiple to cart: Choose the text to be displayed in the Add multiple to cart button.

In Button text color: Choose the text color in the buttons.

In Continue button text: Choose the text to be displayed in the Continue button.

In Continue button color: Choose the color of the Continue button.

In Continue button color on hover: Choose the color of the Continue button when hovering.

In View cart button text: Choose the text to be displayed in the View cart button.

In View cart button color: Choose the color of the View cart button.

In View cart button color on hover: Choose the color of the View cart button when hovering.

43.2 Compatibility

Our Add Multiple Products To Cart for Magento 2 is compatible with all current versions of Community and Enterprise

43.3 Changelog

43.4 FAQs
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CHAPTER 44

Admin Product Preview Plus

44.1 User Guide

44.1.1 Admin Product Preview Plus for Magento 2 Extension Overview

Admin Product Preview Plus for Magento 2 is an excellent tool that allows administrators to check preview of prod-
ucts/Category Pages/CMS Pages/customer information in the frontend while setting up in the backend panel. This
extension offers great flexibility to add preview link of product and customer in order grid view, permission to log in
customer account in the frontend with full display of account information; besides, it allows to edit frontend page by
navigating to backend Edit Page, and offers backend data linked for both product and customer information.

44.1.2 How does Admin Product Preview Plus for Magento 2 Extension work?

1. In Stores

Please navigate to Stores -> Settings -> Configuration
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In General Configuration

In Enabled Admin Preview, choose Yes to enable module or choose No to disable module

In Product Grid Preview Button Position, set position of product grid preview button by choosing In New Column
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or In Action Column

In Customer Grid Login Button Column, set position of column of customer Log-in button by choosing In New
Column or In Action Column

In Product Preview Link Type, choose Frontend or Backend to decide the navigation of preview links

In Disable Page Cache For Admin User, choose Yes to activate automatic cache flush before admin log in as customer
and set show Product Preview Link Type to Frontend, otherwise choose No.

In Show Edit Link In Frontend For, choose one or multiple pages to place Edit Page buttons which directs admin
to backend Edit Page from the frontend.

2. In Sales

Please go to Sales -> Operations -> Orders

Then check the Sales Order Grid table consisting of various columns, in which Bill-to-name column presenting
name of customers who have placed orders on site, and Item Ordered column displaying brief information of ordered
product (SKU, name, image?)
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Click name of customer to navigate to Customer Information section in the backend to check or make changes if
needed.

Click name of product to see preview of Product Page in the frontend.
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3. In Products

Please navigate to Products -> Inventory -> Catalog

Click Preview button in product grid view in Catalog section to see preview of Product Page in the frontend, make
changes in product information in Edit if necessary and click save.
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Please go to Products -> Inventory -> Categories

Check the list of Category Pages, make changes if needed, click Save then use Preview button to check frontend
display of the chosen Category Page.

Display of the Category Page in frontend after clicking Preview button.
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4. In Customers

Please go to Customers -> All customers

Click Login button to log in customer account from backend

44.1. User Guide 239



Read the Docs Template Documentation, Release latest

The module will permit admins to log in as customer in frontend page.

In Customers -> Login As Customer Log
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Login As Customer Log shows history of how many times admin have logged in as customer in frontend

5. In Content

Please go to Content -> Elements -> Pages

Check the list of CMS Pages, click select and choose Edit to make changes in content of CMS Pages, then click Save.

In Edit CMS page, make changes if necessary, click Save Page and use Preview button to check frontend display of
the edited page.
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44.2 Compatibility

Our Admin Product Preview Plus for Magento 2 is compatible with all current versions of Community and Enterprise

44.3 Changelog

44.4 FAQs

242 Chapter 44. Admin Product Preview Plus



CHAPTER 45

Ajax Add To Cart

45.1 User Guide

45.1.1 Ajax Add To Cart for Magento 2 Extension Overview

Ajax Add To Cart for Magento 2 is an extension that allows convenient pop-up when adding product into shopping cart
with ability to select product options and display of product information without leaving the current page. Furthermore,
it also offers flexible customization of pop-up’s design and layout in backend configuration.

45.1.2 How does Ajax Add To Cart for Magento 2 Extension work?

Please go to Stores -> Configuration -> BSSCOMMERCE -> Ajax Cart

1. In General Options

In Ajax Cart, go to General Options to begin setting up.
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In Enabled: choose Yes to enable or No to disable the module

In Enabled in product view:

Choose Yes to allow this module to be activated in Product page

Choose No to disable this function, so if you choose No when clicking “Add to Cart” button on Product page, the
Success Popup will not be displayed.
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2. In Success Popup Setting

In Show Product Image, Show Product Price and Show mini cart (including number of items in cart and cart
subtotal): choose Yes to have display of product image, price, and mini cart information in Success Popup, otherwise
choose No.

In Show “Continue” Button: choose Yes to enable Continue Shopping button in the Success Popup or No to disable
this button.

In Countdown time for button: decide to set countdown time for View Cart button or Continue button; then set time
(measured in seconds) in Countdown Time section.

In Checkout link in mini cart: choose Yes to have checkout link embedded in Success Popup, otherwise choose No.
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3. In Success Popup Design

In Button text color: decide what color the text in Success Popup will have.

In Continue button text: type the text content to be displayed for continue button, then choose color and color on
hover in the 2 following sections.

In View Cart button text: type the text content to be displayed for view cart button, then choose color and color on
hover in the last 2 sections.

4. In Quick View Popup Setting

Finally, go to Quick View Popup Setting to change the setting for Quick View Popup

In Show “Go to Product” link, choose Yes to enable “Go to Product” link which allows to go to Product page in
Quick View Popup, otherwise choose No.
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In Show Additional Data, choose Yes to have display of other information of product (including product detail,
review and more information), or No to hide this section.

45.2 Compatibility

Our Ajax Add To Cart for Magento 2 is compatible with all current versions of Community and Enterprise

45.3 Changelog

45.4 FAQs
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CHAPTER 46

Ajax Social Login

46.1 User Guide

46.1.1 Magento 2 Ajax Social Login Overview

The ease of login or register process will inevitably encourage customers to interact more with your site. While
traditional sign up form might drive customers to bounce out immediately due to the complication and amount of time
they have to spend on that step, login with social media method can give them more incentive to sign up on your site.

Understand the demand for a quicker and more convenient method of login and register on Magento site, BSSCom-
merce has developed Magento 2 Ajax Social Login which allows customers to sign through social media accounts like
Facebook, Twitter, Google Plus. . . quickly via Ajax pop-up. With Magento 2 Ajax Social Login, customer can signup
or login on a site quickly within few clicks instead of wasting time on filling in register or login form. Ajax pop-up
is also a method to save up time customers might spend on loading new pages. While many people tend to forget the
information they used for signup like email, username and password, social login function will help them get rid of
remembering all above information. Social login also benefits shop owners by encourage site visitors to share content
with their social network, which is one of the most powerful free word-of-mouth advertising.

46.1.2 How does Magento 2 Ajax Social Login work?

Log in as admin from backend, go to Store -> Configuration -> BSS COMMERCE -> Ajax Social Login to start
setting configuration.
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1. In General

• In Enable:

– Choose Yes to enable the module.

– Choose No to disable it.

• In Use Popup Ajax:

– Choose Yes to enable the Ajax pop-up to replace Login and Create An Account pages.

– Choose No if disable it.

• In Display button social: Hightlight to select position(s) on site that you want to place the social login block.

• In Send Password: After customers successfully signed up through a social media account, you can decide
whether to send them a password for following times they log in on site. With the password, customer can sign
in in both ways: choose login with social account or use the email of that social account along with

the password that they received.
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• In Display Customer Photo:

– Choose Yes to display the customer’s profile photo from the social account they used for signup at wherever
the customer’s photo on site usually shows up.

– Choose No to not display customer’s social photo.

• In Redirect after Login: Select the page on site or any particular URL you want to redirect after customer login
successfully.

• In Redirect after Register: Select the page on site or any particular URL you want to redirect after customer
completed register process.

• In Show Limit Button: Choose the number of social login buttons which you want to display in social login
block. If this number is smaller than the total amount of social accounts enabled on site, the “Show more” button
will appear in social login block for customers to look for more available options.

• In Social Button Sorting: You can hold and drag the social accounts to re-order the position they appear in
social login block.
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2. In reCaptcha

• In Site Key and Secret Key: Click “Create a site key” and register reCaptcha

After registering, you will got the Site key and Secret key as below:
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• In Theme: Choose the theme of reCaptcha between:

– Light:

– Dark:

• In Type: Choose the type of robot checking between Image and Audio.

• In Size: Choose the size of reCaptcha widget between Normal and Compact.

• In Popup Form: Choose the form(s) of popup on site to place the reCaptcha widget. Forms of popup to select
from includes Login, Register and Forgot Password?

3. Configuration of specific social account

Take Facebook account as the example:
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• In Enable:

– Choose Yes to enable Facebook account for login and register on site.

– Choose No to disable Facebook account for login and register on site.

• In App ID and App Secret: Click on “click here” below Enable dropdown box, you will be redirect to a page
to set up new API like below

After completing register step, you will see a page as below. Click on Get Started in Facebook Login
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Click on Dashboard, you will see your App ID and App Secret - copy them and paste correspondingly into App ID
and App Secret box in backend configuration.

• In URI redirection valid OAuth copy the Valid OAuth redirect URIs like below and paste into the box URI
redirection valid OAuth
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• In Small Icon: Upload the file for icon of this account displayed in frontend.

• In Login Button Text: Customize the text in social login button.

• In Registration Button Text: Customize the text in social registration button.

For other social accounts, follow similar steps like the setting for Facebook:

• Twitter
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• Google
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• Yahoo
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• Linkedin
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• Window-Live

• Instagram
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• Vkontakte
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Finally, click Save Config and to complete setting process.

*Note : As claimed in the description, this module can support unlimited social accounts. Beside 8 accounts currently
available for configuration, you can totally add more social media accounts to the list as wish by following below
simple steps:

Step 1: Add code below to a template file

<?php echo $this->getLayout()->createBlock("Bss\SocialLogin\Block\Buttons")->
setTemplate("Bss_SocialLogin::customer/form/login/buttons.phtml")-> toHtml();

→˓?>

Step 2: Put a social login button block on a CMS page

{{block class="Bss\SocialLogin\Block\Buttons" name="buttons.sociallogin"
template=" Bss_SocialLogin::customer/form/login/buttons.phtml"}}

Step 3: Copy and paste the code below into one of xml layout files where you want to show the social button block

<block class="Bss\SocialLogin\Block\Buttons" name="sociallogin.customer.form.login.
→˓buttons"

as="sociallogin_buttons" template="Bss_SocialLogin::customer/form/login/
→˓buttons.phtml" />

46.2 Compatibility

Our Ajax Social Login for Magento 2 is compatible with all current versions of Community and Enterprise
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46.3 Changelog

46.4 FAQs
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CHAPTER 47

ANZ eGate payment Gateway

47.1 User Guide

47.1.1 Multiple Store View Pricing for Magento 2 Extension Overview

ANZ eGate Payment Gateway for Magento 2 is developed to integrate ANZ eGate into Magento 2 sites to allow credit
card processing right on the sites. This module provides more secure and reliable payment methods for customers to
choose besides available ones.

47.1.2 How does Multiple Store View Pricing for Magento 2 Extension work?

You go to Stores -> Sales -> Payment Method

In the Payment Method, you go to ANZ Egate to begin setting up:
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In Enabled: choose Yes to enable this module or choose No to disable it

In Title: You type the name of payment method displayed on your site

In Test module: choose Yes to set up module in the test mode status, otherwise choose No

In New Order Status: you pick up an order status that are displayed after these orders are successfully placed by
customers

In Actions: you can choose Authorize Capture or Authorize

In these sections: Merchant ID, Access Code, User and Password: you fill in with your account information in ANZ
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In Credit Card Types: you select types of credit cards that are allowed for payment

In Payment from Applicable Countries: You can select all countries allowed to apply this payment method or select
some specific countries
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In Payment from Specific Countries: if you choose some specific countries to apply this payment in the previous
section, you can pick up your own countries from the drop-down list in this filed.

In Instructions: you can type some text to explain or describe more about this payment method

In Sort Order: you choose the order of this payment method on the checkout page

47.2 Compatibility

Our ANZ eGate Payment Gateway for Magento 2 is compatible with all current versions of Community and Enterprise

47.3 Changelog

v1.0.0 . First Release

47.4 FAQs
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CHAPTER 48

Auto Invoice

48.1 User Guide

48.1.1 BSS Auto Invoice for Magento 2 Overview

To reduce time and effort to generate invoice and shipment manually, BSS Auto Invoice for Magento 2 is specially
created to automatically create invoice/shipment as well as send emails to customer. As a result, it will put an end of
overload of manually creating invoices for Magento Store Owners. With this powerful extension, admin can easily
manage orders and contact with customers quickly and effectively.

48.1.2 How does BSS Auto Invoice for Magento 2 work?

As an admin, you can set up your own store page by the most effective way that supports your trading objective. To
polish the website configuration:

Step 1: Go to Admin Panel => Store => Settings => Configuration

Step 2: At the left side of the page, find BSS COMMERCE => select Auto Invoice

Choose Yes/No to enable/disable BSS Auto Invoice for Magento 2 Extension

There are 3 sections for admin to continue configuring the extension: Select Payment Methods, Enable automatic
invoice generation, Enable automatic shipment generation.
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1. Select Payment Methods

In the box Select Payment Methods, select all the payment methods for which you want invoice and shipment will be
generated automatically.

Remember that with Paypal method, invoice will be generated automatically by default.

2. Enable automatic invoice/ shipment generation

In “Enable automatic invoice generation” box, after you choose Yes to enable the function, invoices will be generated
automatically after orders are completed.

You set up similarly with automatic shipment generation in the following box.

Remember that only when automatic invoice generation is enabled, can you enable automatic shipment generation.

If you enable both automatic invoice and shipment generations, your customers will receive 3 emails after ordering
completely: Order confirmation, Shipment confirmation and Invoice

If you only enable automatic shipment generation, the first and third emails will be sent.

You can see email samples as below:

• Invoice
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• Shipment confirmation
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48.2 Compatibility

Our Auto Invoice for Magento 2 is compatible with:

• Community: 1.4.x.x

• Enterprise: 1.12.x.x

48.3 Changelog

48.4 FAQs

272 Chapter 48. Auto Invoice



CHAPTER 49

Catalog Price Rule per Store View

49.1 User Guide

49.1.1 Catalog Price Rule Per Store View for Magento 2 Overview

As you know, default Magento just allows creating catalog price rules for the whole website. It means that a rule
will be set up and applied for all stores or store views of a website. Therefore, Catalog Price Rule per Store View for
Magento 2 is developed to help administrators to set up catalog price rules for each store view easily, which can offer
different promotion programs for customers in particular areas and generate sales more effectively.

49.1.2 How Does Catalog Price Rule Per Store View for Magento 2 Work?

After installing this module, you will select store views to set up cart price rules when you create new rules.

You go to MARKETING -> Catalog Price Rules -> Add New Rule.

You fill in necessary information in sections of Rule information. Especially, in Store View section, you will select
store views to set up this rule and apply in the frontend. You can select multiple store views to carry out setup at one
time.

Take 2 following examples to see how Shopping Cart Price Rule per Store View for Magento 2 can function in details.

• Example 1: Set up a rule “20% OFF for all products belonging category Bag” for English store view.
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In Rule Information:

• Fill in Rule name and Description.

• Set Yes for Active.

• Select English of Main Website Store in Store View section.

• Select customer groups to apply.

• Fill in other information: time and priority

In Conditions: Set up the right condition for this rule.
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In Actions: Choose suitable actions for the rule.

Finally, you Save and Apply the rule and then see how it is applied in the frontend of English store view:
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• Example 2: Set up a rule “10% discount for all products belonging category Bag” for French store view.

You do the same steps as in Example 1 but you need to choose French store view to set up in Store Views section.
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In Conditions:

In Actions:
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Finally, you Save and Apply the rule and then see how it is applied in the frontend of French store view:

*Note: To know how to create a catalog price rule for Magento 2, let’s take a look at our following tutorial: How to
Create Catalog Price Rules in Magento 2.

49.2 Compatibility

Our Catalog Price Rule per Store View for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x
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49.3 Changelog

49.4 FAQs
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CHAPTER 50

Checkout Custom Field

50.1 User Guide

50.2 Compatibility

Our Checkout Custom Field for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x

50.3 Changelog

50.4 FAQs
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CHAPTER 51

Checkout With Display Currency

51.1 User Guide

51.1.1 Checkout with Display Currency for Magento 2 Extension Overview

Checkout with Display Currency for Magento 2 helps customers to pay with display currency of their selected store
views.

In default Magento, customers always have to checkout with base currency of the whole website no matter which store
view they are staying. Therefore, this module will make checkout process more convenient when customers use their
own currencies corresponding to their store view in order to pay.

51.1.2 How does Checkout with Display Currency for Magento 2 Extension work?

You go to Stores -> Configuration -> BSSCOMMERCE -> Checkout with Display Currency to start settings.

1. Enable Checkout with Display Currency Extension for Magento 2

In Enabled: Choose Yes to enable the module or choose No to disable it.
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2. Set up Display Currency for each store view

Go to Stores -> Configuration -> General -> Currency Setup -> Currency Option.

Then select each store view in Scope to set up display currency for each store view.

Example 1: Set up display currency for French store view

In Store View: Choose English.

In Default Display Currency: choose British Pound Sterling.

In Allowed Currencies: choose British Pound Sterling also.

Then save config.

When customers buy products in the frontend of French store view and go to checkout, they can checkout easily with
Euro.

You can see this image:
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For checking out via online payment methods such as Paypal:

*Note:

• You should test with your Paypal test account on Test Mode to see how it pays with display currency of store
views.

51.1. User Guide 285



Read the Docs Template Documentation, Release latest

• The module does not work with currencies that online payment methods don’t support.

Example 2: Set up display currency for English store view

You fill in information as in French store view and then save config.

When customers buy products in the frontend of English store view and go to checkout, they can checkout easily with
British Poumd Sterling.

You can see this image:
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51.2 Compatibility

Our Checkout with Display Currency for Magento 2 is compatible with all current versions of Community and Enter-
prise

51.3 Changelog

51.4 FAQs
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CHAPTER 52

Configurable Grid Table View

52.1 User Guide

52.1.1 Configurable Product Grid Table View for Magento 2 Overview

Along with Magento 1 version, Configurable Product Grid Table View for Magento 2 extension supports better shop-
ping experience by allowing customers to add multiple products to cart at once. This module displays all children
products of the configurable product in a very simple table with fields such as product availability, price, quantity and
subtotal. Especially, a price range of the configurable product is also shown on the category page, which is determined
by the lowest and highest one among prices of children products.

52.1.2 How does Configurable Product Grid Table View for Magento 2 Extension
work?

You go to Admin -> Store -> Configuration -> BSSCOMMERCE -> Configurable Grid View and start setting up
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In Enabled: Choose Yes to enable the module or choose No to disable it

In Display Stock Availability:

• Choose Yes to display stock availability in the grid table. When you enable this feature, you can set up Stock
number and Out of stock status.

• Choose No to hide Availability column from the table

In Display Stock Number: Choose Yes to show stock number in the table or choose No to replace it by In Stock status

In Display Out of Stock Products:

• Choose Yes to show out of stock products in the table

• Choose No to hide out of stock products

In Subtotal: Choose Yes to show subtotal column in the table or choose No to exclude it

In Show Unit Price: Choose Yes to display the column of Unit price in the grid table or choose No to hide it.

290 Chapter 52. Configurable Grid Table View



Read the Docs Template Documentation, Release latest

In Disable for Customer Group: Choose specific customer groups to disable this module. It means that the grid table
does not display with selected customer groups

52.2 Compatibility

Our Configurable Grid Table View for Magento 2 is compatible with all current versions of Community and Enterprise

52.3 Changelog

Version 1.0.0

• New Release

52.4 FAQs
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CHAPTER 53

Configurable Product Wholesale Display

53.1 User Guide

53.1.1 Configurable Product Wholesale Display for Magento 2 Overview

Configurable Product Wholesale Display for Magento 2 displays all associated products in a grid table view which
allows wholesale customers to order and add all chosen items to cart at once. This extension not only enhances display
for configurable products, but helps customers simplify selecting items process as well. It absolutely deserves to be a
brilliant solution for any Magento site for selling larger quantity.

53.1.2 How does Configurable Product Wholesale Display for Magento 2 Extension
work?

1. Function of Configurable Product Wholesale Display for Magento2

• Show associated products in a grid table with all options, so that customers just need to enter quantity and then
add all chosen products to cart by oneclick.

• Show SKU, Availability, Unit Price, Tier Price and Subtotal in this grid table. Especially, the module supports
showing Tier Price as Tooltips when hovering onit.

• Show Price Range for configurableproducts.

• Show selected quantity details based on options of the first attribute below thetable.
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• Work well with Color swatch function of Magento default with clickable options. Customers can still click
options to see images of childrenproducts.

• Work well with all type of customoptions.

2. How to configure Configurable Product Wholesale Display for Magento 2 in the backend

Go through System -> Configuration -> BSSCommerce -> Configurable Product Wholesale Display.

• Enabled: choose Yes to enable theextension.
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• Display Attributes: choose attributes to show in the grid table for laptop aswish.

• Display StockNumber:

– Choose Yes to show number of stock in the gridtable.

– Choose No, it will show stock status: In stock and Out ofstock.

• Advanced TierPrice:

– Choose Yes: total amount is based on tier price of total quantity of children products added tocart.

Note:

• This feature is only applied for children products having same tier prices. That means: if a configurable product
has 50 children products, all 50 children products need to have the same tierprice.

• If there is at least 1 children product does not have tier price or have different tier price with others, this feature
will not beapplied

For example, tier price of buying 1-9 Black-S shirt, 1-9 Gray-S shirt is similarly $45. Tier price of buying 10-more
for every children products is $40. Therefore, when you buy 3 Black-S shirts and 7 Black-XL shirts, tier price is now
$40/shirt. Total amount is now $400.

• Choose No: total quantity will take default tier price, which means that total amount is calculated by tier prices
of each children product multiply to total quantity of each chosen childrenproduct.

For the above example, when using Magento default tier price calculation, total amount is determined as $450 because
it is calculated based on each tier price of each children product (Tier price is equal to $45/shirt)

• Price Range:

– Choose Yes if you want to display Price Range for configurable product above thetable.

– If not, choose No.
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• Hide Price on Table for Customer Groups: choose which customer group you want to hideprice.

• Enable for Customer Groups: choose which customer group to show this wholesale display.
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• Header Row Background Color: choose color you want for Header Row Background

• Header Row Text Color: choose color for Header Row Text aswish

• Enabled Mobile Display: choose Yes to make it responsive onmobiles

• Display Mobile Attributes: choose attributes to show in the grid table view for mobiles

• Enabled Tablet Display: choose Yes to make it responsive ontablets.

• Display Tablet Attributes: choose attributes you want to show in the grid table on tablets.
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3. Changing sort order of attributes for configurable products

If you get a problem like the order of attributes is not as you wish.

Here is an example: You want to change the sort order, the size attribute should be in the table.

Here is solution: changing sort order of attributes.

Please follow these steps:

Step 1: Go to Product details page in the backend:

Product -> Catalog -> choose a product detail page of a configurable product.

Step 2: Click Edit Configuration

select Attribute Value
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Step 3: Change the sort order of attributes.

Step 4: Choose Next in the two following steps in Create Product Configurations.

Then Save.

Step 5: Go the frontend, reload the product page.
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Here is result:

53.2 Compatibility

Our Configurable Product Wholesale Display for Magento 2 is compatible with all current versions of Community
and Enterprise

53.3 Changelog

53.4 FAQs
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CHAPTER 54

Custom Option Image

54.1 User Guide

54.1.1 Custom Option Image for Magento 2 Extension Overview

Custom Option Image for Magento 2 extension allows admin to add images/colors to custom options of products. It
supports uploading unlimited images and assigning to custom option of different types, such as drop-down, multiple
select, checkbox, radio button.

54.1.2 How Does Custom Option Image for Magento 2 Extension Work?

Please go to Stores -> Configuration -> BSSCOMMERCE -> Custom Option Image.

1. General

In Enabled, choose Yes to enable the extension, or No to disable it.

Note: The module works with simple product, configurable product, bundle product (without dynamic pricing), down-
loadable and virtual product.

It only supports adding images for products that can have custom options by Magento default so the extension does
not work with grouped product. In case of bundle product, it only supports uploading images for the custom options
created by admin, not the bundle items.
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2. Frontend View

In Drop-down Option View, choose one of the following options:

• Show image when selected: Image is only displayed when the custom option is selected.

For example:

• Show all images: All images are displayed in each custom option. If customer selects an option, its
image will be highlighted.

In Multiple Select Option View, choose one of the following options:

• Show image when selected: Image is only displayed when the custom option is selected.

• Show all images: All images are displayed in each custom option. If customer selects an option, its
image will be highlighted.

For example:
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3. Image Size Settings

In Drop-down Option Image Height, set image height for drop-down option type.

In Drop-down Option Image Width, set image width for drop-down option type.

In Radio Buttons Option Image Height, set image height for radio buttons option type.

In Radio Buttons Option Image Width, set image width for radio buttons option type.

In Checkbox Option Image Height, set image height for checkbox option type.

In Checkbox Option Image Width, set image width for checkbox option type.

In Multiple Select Option Image Height, set image height for multiple select option type.

In Multiple Select Option Image Width, set image width for multiple select option type.

4. Upload Image for Custom Option

Go to Products -> Catalog -> Choose the product -> Customizable Options.

• Click upload icon to upload image from local. Save configuration after finishing.

• To remove the uploaded image, hover on the chosen image and click the delete icon.

• To recover the deleted image, hover on the chosen image and click the retrieve icon.
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Note: Don’t delete the custom option before save configuration or the images uploaded for options won’t be saved.

54.2 Compatibility

Our Custom Option Image for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x

54.3 Changelog

54.4 FAQs
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CHAPTER 55

Defer JavaScript

55.1 User Guide

55.1.1 Defer JavaScript Extension for Magento 2 Overview

Defer JavaScript Extension for Magento 2 is developed based on the version for Magento 1. Like its initial version,
Defer JavaScript Extension for Magento 2 is one of the most powerful factors that help to improve the website’s speed.

This module is very useful in reducing the loading time of a website, so that customers can enjoy a better shopping
experience at your store site, leading to a stronger engagement and higher brand loyalty.

55.1.2 How does Defer JavaScript Extension for Magento 2 work?

You go to Stores -> Configuration -> BSSCOMMERCE -> Defer JavaScript to start setting up

Step 1: Enable Defer JavaScript Extension for Magento 2:

At backend, you can easily enable or disable BSS Defer JavaScript module by selecting “Yes” or “No” in the Enable
box

Step 2: Manage Controllers, Path, and Homepage:

If you want some of your pages not being affected by Defer JavaScript Extension for Magento 2, you can easily
exclude it by fulfilling these pages’ information into these excluded boxes:
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• Exclude controllers and paths: Click Add Match button and write down your wished paths or controllers that
you want to disable Defer JavaScript for Magento 2

• Exclude Homepage: you can disable this module on Homepage faster and easier by selecting “Yes” in the
Exclude Home Page box.

NOTE:

• You have to fill in the controllers/ paths that you want to exclude the affection of Defer JavaScript
Extension for Magento 2 when selecting Add Match button.

• If you do not fill it up, the system will automatically set all pages in your website affected by our
module.

• You can click on the wastebasket symbol in the right side of the box to delete the created blank box.

If you do not know the controllers / paths to fulfill the Exclude Controllers / Paths box, but you still want to disable
Defer JavaScript function for some pages, you can select “Yes” in the Show Controllers and Paths box
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After selecting “Yes”, you can find information of the Controllers / Paths in the table at the end of frontend page.

In Put JavaScript In HTML Body Tag:

• Choose Yes to put all deferred JavaScript in the end of HTML body tag

• Choose No to put all deferred JavaScript in the end of page

When you finish changing the configuration, you can click on “Save Config” button to save all of your setting with
Defer JavaScript.

55.2 Compatibility

Our Defer JavaScript Extension for Magento 2 is compatible with all current versions of Community and Enterprise

55.3 Changelog

Version 2.0.2
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55.4 FAQs
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CHAPTER 56

Delete Order

56.1 User Guide

56.1.1 Delete Order extension for Magento 2 Overview

Delete Order for Magento 2 is a helpful and easy-to-use extension which allows website admin to clear out the backend
from all unwanted orders, invoices, shipments, as well as credit memos. Thanks to that, users can effectively keep
track on and control over all remaining important orders.

56.1.2 How does it work?

• Delete Order(s)

After installing this module, log in as admin, go to Sales -> Orders, a list of all orders will be shown as usual. Tick
on the checkbox of unwanted order(s) and choose the action Delete Orders in Select Items box.
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Then a pop-up will appear for action confirmation. Select OK to completely delete the order(s).

You can also delete order from Order View Page by choosing Delete button in Information tab of a particular order
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Note:

• You can delete many delete orders at a time by ticking on their checkboxes.

• Once you delete an order, it would be removed permanently from the system and could not be restored. You?d
better do it carefully

• When an order is deleted, all of its related information like shipment, invoice, credit memo will be erased too

• Delete Invoice(s)

Go to Sale -> Invoices and select Invoices you want to wipe out of the backend and then choose Delete Invoices in
Select Items box. After that, a popup appears and you click OK to confirm removing these selected Invoices.

After Invoices are deleted, order status turns back to Pending (if shipments have not been created) or Processing (if
shipments have already created). Credit memos are also removed. Invoices can be also recreated

You can also delete invoice of a particular order in its Order View Page by going to tab Invoices, click on Delete
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button or choose Delete Invoices in Actions dropdown box.

• Delete Shipment(s)

Similar to deleting orders and invoices, we can erase unneeded shipments by navigating to Sales -> Shipments and
select Shipments that you want to rub out. Then, you choose Delete Shipments in Select Items box and press OK in
the confirmation popup to finish the process.

Similarly, you can delete shipment from Order View Page under Shipments tab by clicking on Delete button or choose
Delete Invoices in Actions dropdown box.

When a shipment is removed, its order status is updated to Pending (if invoices have not been created) or Processing
(if invoices have already been created). Admin can totally recreate shipments.

• Delete Credit memo(s)

Like Invoices and Shipments, there are two ways to remove redundant Credit memos:

(i) Go to Sales -> Credit memos, select unwanted Credit memo(s) choose Delete Credit memos in Select
Items box, then click OK in the popup to completely exclude them from the backend.

2. Under Credit Memos tab in Order View Page of a particular order, click on Delete or select Delete
Credit Memos in Actions dropdown box.

Order Status are altered to Complete (if invoices and shipments have already been generated) or Processing (if only
invoices have been created). Credit memos are easily recreated.

After finishing with set up, choose Save Config

56.2 Compatibility

Our Delete Order for Magento 2 is compatible with all current versions of Community and Enterprise

56.3 Changelog

Version 2.0.2
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56.4 FAQs
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CHAPTER 57

Dynamic HTML Sitemap

57.1 User Guide

57.1.1 Dynamic HTML Sitemap for Magento 2 Extension Overview

Dynamic HMTL Sitemap for Magento 2 by BSSCommerceis developed to generate a detailed and useful sitemap
including links to categories, products, CMS pages and store views of your Magento 2.This module helps enhance
SEO performance of your business and provide your customers with a clear structure of your site.

57.1.2 How Does Dynamic HTML Sitemap for Magento 2 Extension Work?

You go to Stores -> Configuration -> BSSCOMMERCE -> HTML Sitemap to start setting up.

Please flush all Magento caches after you make any configuration of the module for the changes to take effect.

In Enable, choose Yes to enable module, otherwise choose No.

In Title of Site, choose the title for the sitemap.

In Session Order, fill in the order of sessions to be displayed. Please fill in all 4 items separated by a coma. ID of
sessions as below:

1: Product List

2: Store View List

3: Additional Link List

4: Category and CMS Page List
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In Meta Title, choose the meta title for your sitemap.

In Meta Keywords, choose the meta keywords for your sitemap.

In Meta Description, write meta description for your sitemap.

In Show Product Link, choose Yes to show product links in the sitemap, otherwise choose No.

In Title of “Product List”, choose the title for the product list session in the sitemap.

In Sort Product by, choose among DESC for descending or ASC for ascending.

In Arrange Product by, choose Name/Date/Price to sort product links.

In Maximum Products Displayed on Sitemap, choose the maximum for the number of product links to be shown.
The limit number you can fill in is 50000.

In Show Store View Link, choose Yes to show store view links in the sitemap, otherwise choose No.

316 Chapter 57. Dynamic HTML Sitemap



Read the Docs Template Documentation, Release latest

In Title of “Store View List”, choose the title for the store view list session in the sitemap.

In Show Category Link, choose Yes to show category links in the sitemap, otherwise choose No.

In Title of “Category List”, choose the title for the category list session in the sitemap.

In Disable Category, fill in ID of categories you want to hide in sitemap (separated by a coma). For example:
1,2,5,9,23,45,77.

In Title of “Additional Link List”, choose the title for the additional link list session in the sitemap.

In Open Additional Link in a New Tab, choose Yes to open additional links in a new tab, otherwise choose No.

In List of Additional Links, choose the links and the anchor you want to display for each link. Follow this example:
[http://yourlink1.com{]}{[}Anchor Text 1].

In Show CMS Link, choose Yes to show CMS links in the sitemap, otherwise choose No.

In Title of “CMS List”, choose the title for the CMS link list session in the sitemap.

In Disable CMS Link, choose the CMS links you want to hide from sitemap. Hold Ctrl when choosing multiple
options.
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57.2 Compatibility

Our Dynamic HTML Sitemap for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x

57.3 Changelog

57.4 FAQs
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CHAPTER 58

Frequently Bought Together

58.1 User Guide

58.1.1 Frequently Bought Together for Magento 2 Extension Overview

Frequently Bought Together for Magento 2 extension effectively boosts sale by suggesting products that are commonly
bought together. The list of items can be chosen from related, cross-sell, up-sell products, or the hand-pick products
set admin. The extension can use purchase history to track product commonly sold together and add them to the
frequently block.

58.1.2 How Does Frequently Bought Together for Magento 2 Extension Work?

1. Set Frequently Bought Together List for Product

Go to Product -> Catalog -> Product Edit Page -> Related Products, Up-Sell, Cross-Sells and Frequently Bought
Together.
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In Frequently Bought Together, add products which are commonly bought together with the main product.

2. General

Go to Store -> Configuration -> BSSCommerce -> Frequently Bought Together -> General.
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In Enable, choose Yes to enable the extension, or No to disable it.

In Priority List, there are five methods of selecting frequently bought together products. Drag and drop to prioritize the
methods to be applied. For example: The extension will prioritize to choose items from Frequently Bought Together
Product block. If no items found, the extension will get data from Related Products, then Up-Sell Product, Real Data
and Cross-sell Products.

• Frequently Bought Together Products: Select items from the frequently bought together product list set in
2.1.

• Related, Up-Sell, Cross-Sell Products: Select items from related, up-sell, cross-sell product list.

• Real Data: Track product which are commonly sold together in purchase. The items will be calculated in
according to the frequency of appearance with the main products of orders in the select time period.

In Start Date, select date to begin calculating frequently bought together products for Real Data method.

3. Frequently Bought Together List Setting

Go to Store -> Configuration -> BSSCommerce -> Frequently Bought Together -> Frequently Bought Together
List Setting.
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In Display List, there two ready-made design for displaying Frequently Bought Together list.

Style 1:

Style 2:
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In Show Main Product in List, choose Yes to include the main product in Frequently Bought Together list. Choose
No to exclude it.

In Title of List, enter the message shown above the list. For example: Based on your choice, here are other options
you may like.

In Limit Product in List, restrict the number of products displayed in Frequently Bought Together list.
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In Limit Products in Slider, restrict the number of item displayed in one slide.

In Slider Speed, set transition duration between 2 continuous slides.

In Auto Slider, choose Yes to enable automatic slider. No to disable this function.

In Show Price, choose Yes to display prices of products in Frequently Bought Together list.

In Show Review, choose Yes to display reviews of products in Frequently Bought Together list.

In Preview Selected Items, choose Yes to enable previewing brief information of selected product in Frequently
Bought Together list. The information includes product name, quantity, and unit price.
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In Show “Add to Cart” button, choose Yes to display “Add to Cart” button.

Config customize “Add Multiple to Cart” button:

• Show “Add Multiple to Cart” button.

• Text on “Add Multiple to Cart” button.

• Background Color of “Add Multiple to Cart” button.

• Color of Text on “Add Multiple to Cart” button.

Config customize “Add Multiple to Wishlist” button:

• Show “Add Multiple to Wishlist” button.

• Text on “Add Multiple to Wishlist” button.

• Background Color of “Add Multiple to Wishlist” button.

• Color of Text on “Add Multiple to Wishlist” button.

4. Pop-up Setting

Go to Stores -> Configuration -> BSSCommerce -> Frequently Bought Together -> Pop-up Setting.
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When adding products in Frequently Bought Together list to cart, the extension will work like Add Multiple Products
to Cart . There are two ways to add product in Frequently Bought Together list to cart:

• Add each product to cart separately: Display success pop-up, choose option/quantity in pop-up for product with
options.

• Add multiple products to cart: Tick on products and click “Add Multiple to Cart” button. The products added to
cart successfully will be displayed in slider of success pop-up. For products with options, customer can select
options/quantity right from pop-up.

*Note:

• To add all product in Frequently Bought Together list, tick on “Select all product” then click “Add Multiple to
Cart” button.

• To add selected products to wishlist, click “Add Multiple toWishlist” button.
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In Limit Product in Slider, restrict the number of products displayed in slider of success pop-up.

In Slider Speed, set transition duration between two continuous slides.

In Auto Slider, choose Yes to enable automatic slider.

In Show Price, choose Yes to display price of product.

In Show “Continue” button, choose Yes to display “Continue Shopping” button.

In Countdown Time on Button, set countdown function for “Continue” button or “View Cart” button.

In Countdown Time, set countdown time.

In Show Cart Quantity and Cart Subtotal, choose Yes to display total items in cart and cart subtotal.

In Show “Go to Checkout” Link, choose Yes to display “Go to Checkout” link.
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Config customize “Add Multiple to Cart” button:

• Text on “Add Multiple to Cart” button.

• Background Color of “Add Multiple to Cart” button.

• Color of Text on “Add Multiple to Cart” button.

Config customize “View Cart” button:

• Text on “View Cart” button.

• Background Color of “View Cart” button.

• Color of Text on “View Cart” button.

Config customize “Continue” button:

• Text on “Continue” button.

• Background Color of “Continue” button.

• Color of Text on “Continue” button.

58.2 Compatibility

Our Frequently Bought Together for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x
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58.3 Changelog

58.4 FAQs
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CHAPTER 59

Frontend Cancel Orders

59.1 User Guide

59.1.1 Frontend Cancel Order for Magento 2 Overview

As you know, the default of Magento does not allow customers to cancel orders from the frontend, which causes some
inconvenience for them when shopping, hence, our Frontend Cancel Order for Magento 2 module totally completes
this missing feature of Magento. The extension is developed to help customers cancel their orders with Pending status
from My Account dashboard and My Order page in the frontend. Frontend Cancel Order for Magento 2 definitely
brings more convenience for customers and enhance their shopping experience.

59.1.2 How does Frontend Cancel Order for Magento 2 work?

1. Functions of Frontend Cancel Order for Magento 2

• Allow customers to cancel orders from the frontend: Customers need to login, then go to My Account ->
Account Dashboard or My Orders.
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• Allow customers to add comments in a confirmation popup: When customers click Cancel Order button, there
will be a confirmation popup which allows them to enter comments.

– If they click Yes, orders will be canceled.

– If they still do not want to cancel orders, they can choose No.

• Send Notification Emails to admins automatically after customers canceled orders
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• Change order status from Pending to Canceled and auto restock products

2. How to configure Frontend Cancel Order for Magento 2 in the backend

• Go through System -> Configuration -> BSSCommerce -> Cancel Order
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• Status Module: Choose Enable to ativate the module

• Email Sender: admin can set which email will be email sender

• Email Address to receive notification: enable to set which email will receive notification emails

• Choose Email Template: admin can configure to choose email template for the notification emails

• Notice when customers click cancel orders: admin can customize Notice Note in the confirmation popup
when customers click cancel orders.

• Label for button cancel order: change the label of Cancel Order button

• NOTE: If you want to customize Email Template to have more choices in Choose Email Template, follow
these steps:

– Go to Marketing -> Communications -> Email Templates -> Add New Template

– In Load default template, choose Template you want, then click Load Template

– In Template Information, enter text as you want in Template Name, Template Subject.
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– In Template Content and Template Styles, you can edit html or css as you want.

59.2 Compatibility

Our Frontend Cancel Orders for Magento 2 is compatible with all current versions of Community and Enterprise

59.3 Changelog

59.4 FAQs
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CHAPTER 60

Google AMP

60.1 User Guide

60.1.1 Google AMP Extension for Magento 2 Overview

Google AMP - Accelerated Mobile Pages is the hottest trending technology for a faster and smoother loading for mo-
bile web pages. With the ability to be loaded in just few seconds, the new mobile pages will increase user engagement
on your store and drop the exit rate. Google AMP Extension for Magento 2 by BSSCommerceis an effective tool to
generate and customize AMP pages for your site as your wishes.

60.1.2 How Does Google AMP Extension for Magento 2 Work?

1. How to create and customize Magento 2 AMP pages

The module will auto-generate the category page and product page for your Magento 2 store. For the homepage and
parent category, admins will have to create by themselves using the AMP widgets provided by the extension. Please
follow the steps below to create and customize your own AMP pages in Magento 2
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Please go to Admin -> Content -> Pages -> Add New Page and start configuration.

Set a name for the Page in Page Title.

In Content, choose Insert Widget.

In Widget Type, please select among 6 AMP Widget Types including: Product list, Banner, Iframe, Social Share,
Youtube and Image.
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In the following parts, we will introduce how to configure each type of AMP widgets provided by the extension.
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2. AMP Product List Widget

In Title: Fill in the text displaying above the products.

In Height: Choose height for product slider.

In Number of Products to Display: Choose the number of products which will be shown.

In Image Height: Choosethe height of product image.

In Image Width: Choosethe width of product image.

In Condition: Choose the condition for products which will be shown.

3. AMP Banner Widget

Please go to Admin -> BSSCommerce -> AMP Banner -> Create New Banner and start configuration.
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In Enable: Choose Yes.

In Name: Choose the name for the banner (for management purpose at backend only, not to be displayed at frontend).

In Autoplay: Choose Yes for the banner to be auto played, otherwise choose No.

In Width: Choose the width for the banner.

In Height: Choose the height for the banner.

In the next step, we will make a slide for the above banner.

Please go to Admin -> BSSCommerce -> AMP SlidesCreate New Slides and start configuration.

In Enable: Choose Yes.

In Banner: Choose the banner which you just created
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In Title: Choose the title for the slide (displayed in frontend).

In Link: Choose a link where customer will be directed to once clicking on the banner.

In Caption: Choose the caption which will be displayed under the image.

In Open Url in a New Window: Choose Yes for the link to be displayed in a new window, otherwise choose No.

In Sort Order: Choose the order of the image in the slide.

In Image: Upload the image you want to display.

Repeat these steps for all the images you want to be displayed in the slide. The slide can include many images. Below
is an example of the images we put in the slide for homepage.

342 Chapter 60. Google AMP



Read the Docs Template Documentation, Release latest

After finishing making the slide for the AMP banner, insert the banner in the AMP page.
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4. AMP Iframe Widget

In Link: Choose the link to the Iframe.

In Width: Choose the width for the Iframe.

In Height: Choose the height for the Iframe.

5. AMP Social Share Widget

There are 8 types of available social share including Facebook, Email, Gplus, Linkedin, Pinterest, Tumblr, Twitter
and Whatsapp.

Choose Yes to enable otherwise choose No.

For Facebook, please fill in app ID.
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6. AMP Youtube Widget

In Youtube ID: Choose the text after “https://www.youtube.com/watch?v=”.

In Autoplay: Choose Yes for the video to be auto played, otherwise choose No.

In Width: Choose the width for the video.

In Height: Choose the height for the video.
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7. AMP Image Widget

In Image: Choose the image you want to display.

In Alt: Choose Alt text for the image.

In Width: Choose the width for the image.

In Height: Choose the height for the image.
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8. General Configuration

Please go to Store -> Configuration -> BSS COMMERCE -> Accelerated Mobile Pages and start configuration.

In Enabled: Choose Yes to enable the module, otherwise choose No.

In AMP Homepage: Choose the page you created to be AMP Homepage.

In AMP Analytics Account: Fill in the ID of your Google Analytics account to integrate AMP pages to Analytics.

In Use Https: This configuration works for https website only. Choose Yes to display search box and subscription
box, otherwise choose No. If your site is not using https, please choose No.
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In Button Background Color: Choose the background color for button on AMP pages.

In Button Background Color (Hover): Choose the background color for button on AMP pages when hovering.

In Button Text Color: Choose the color for text on button on AMP pages.

In Button Text Color (Hover): Choose the color for text on buttonon AMP pages when hovering.

In Custom CSS: Set the CSS for all AMP pages.

In Custom CSS for Home Page/ Category Page/Product Page/: Set the CSS for each type of AMP page.
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9. Note

• All the CSS configuration must follow AMP standard. Please visit https://www.ampproject.org/ to know more
details about the standard.

• To validate your AMP pages, please use these three tools:

• https://search.google.com/search-console/amp

• https://validator.ampproject.org

• AMP Validator Extension available for Chrome and Opera

60.2 Compatibility

Our Google AMP for Magento 2 is compatible with all current versions of Community and Enterprise

60.3 Changelog

60.4 FAQs
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CHAPTER 61

Grouped Product with Custom Options

61.1 User Guide

61.1.1 Grouped Product with Custom Options for Magento 2 overview

Grouped Product is an amazing type of product that supports showing multiple products for order on a single page.
However, as you know, the default of Magento only allows admin to add simple products without custom options
to a grouped product. Whereas, with Grouped Product with Custom Options for Magento 2 supports adding simple
products with custom options to a grouped product, which makes customers purchase grouped product conveniently
when having more choices to select their wanted attributes of products. Moreover, Grouped Product with Custom
Options for Magento 2 helps to show custom options of associated products when customers set quantity which helps
to have an economy space and make beautiful sliding effect for grouped product pages.

61.1.2 How Grouped Product with Custom Options for Magento 2 works

1. At the frontend

All custom options of simple product will be shown up only when customers choose quantity.
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2. At the backend

2.1. Add simple products with custom options to a grouped product

• At first, you need to create custom options for simple products.

• Then, add simple products with custom options to grouped product:

– Go to Product -> Catalog

– Choose a grouped product you need to add simple product with custom options.

– At Grouped Products tab, click Add Products to Group, then select simple products with custom op-
tions.

– Next, choose Add Selected Products.

– Save.
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2.2. Make configuration for module

Now you enable this module as follow: Go to Stores -> Configuration

• Enabled: choose Yes to enable the module.

• Show Image:

– Choose Yes if you want to show image of simple product with custom options.

– If you do not want that, choose No.

• Show Product URL:

– Choose Yes if you want to link to product page of associated product with custom options.

– Choose No if you do not want.
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61.2 Compatibility

Our Grouped Product with Custom Options for Magento 2 is compatible with all current versions of Community and
Enterprise

61.3 Changelog

61.4 FAQs
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CHAPTER 62

Hide Price/ Call For Price

62.1 User Guide

62.1.1 Hide Price/Call For Price for Magento 2 Extension Overview

Advanced Hide Price for Magento 2 is an extension that allows to flexibly hide price for a particular product, a certain
category, or specific customer groups. Besides hiding price, the extension also hide “Add to Cart” button and replace
it with a custom message or a Call For Price button that link to an Inquiry form in Ajax popup to obtain customer’s
request.

62.1.2 How does Hide Price/Call For Price for Magento 2 Extension work?

1. In Configuration

Navigate to BSS Advanced Hide Price -> Configuration

355

http://bsscommerce.com/magento-2-hide-price-call-for-price.html


Read the Docs Template Documentation, Release latest

In Configuration, there are four main sections: General Config, Call For Price/Hide Price Priority, Call For Price
Global Config and Hide Price Global Config

1.1. In General Config
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In Enabled Advanced Hide Price, choose Yes to enable the extension or No to disable it.

In Inquiry Form, customize the inquiry form by adding/ deleting fields in the form to obtain customer requests.
Filling in the following options:

• Decide filed name in Label. E.g: Customer request.

• Decide filed type in Type. There are 3 options to select: Text Field, Text Area, Checkbox.

• Decide the order of the field in Inquiry Form in Order.

Tick Required and Enable checkbox to enable the field, or click action button to discard it.

In Show Customer Name and Email, choose No to exclude Name and Email field in Inquiry Form if customers have
logged in their accounts on site. Otherwise choose Yes to include these filed for both logged-in and non-logged-in
customers.

In Email Answer Customer Inquiry, select an email to send reply to customer?s request then select Email Template.

In Email Notify Admin, fill in your email to immediately receive email notifying customer request, then select Email
Template.

1.2. In Call For Price/Hide Price Priority

Prioritize Call For Price or Hide Price Config by selecting that config in Call For Price/Hide Price Priority.

1.3. In Call For Price Global Config
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In Call For Price Text, enter a text to display in Call For Price button which is in replace of Add to Cart button.

In Apply For Categories, select which categories to apply Call For Price config. Choose one, multiple or all cate-
gories.

In Apply For Customer Groups, select which customer groups to apply Call For Price config. Choose one, multiple
or all customer groups.

In Not Applied For Product IDs, enter ID of products to exclude from applying Call For Price config.

1.4. In Hide Price Global Config
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In Hide Price Text, enter a text to display in custom message which is in replace of Add to Cart button.

In Apply For Categories, select which categories to apply Hide Price config. Choose one, multiple or all categories.

In Apply For Customer Groups, select which customer groups to apply Hide Price config. Choose one, multiple or
all customer groups.

In Not Applied For Product IDs, enter ID of products to exclude from applying Hide Price config.

2. In Customer Inquiry List

Go to BSS Advanced Hide Price -> Customer Inquiry List
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In Customer Inquiry List, check the list of customers who have sent requests with information, including: ID (ID
of request), product name, customer name, customer email, created at (time and date when customers sent request),
email response and action.

In Action, choose View in dropdown Select to navigate to inquiry information page.

2.1. In General Information

Check information of the request sent from customer, including general information and additional information.
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2.2. In Send Mail

In Send Email, fill in a number to notify customer of price for the requested product in Price For Request.

Enter a comment to answer customer inquiry if needed in Comment.

Finally, click Send Email for Customer button.

3. In Catalog

Navigate to Products -> Catalog

In Catalog, search for a product that you want to apply Hide Price or Call for Price config.
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In Action, click Edit to go to Product Edit page. Scroll down to find Hide Price/Call For Price config.

In Call/Hide Price type, decide the config you want to apply for that specific product.

In Call/Hide Price text, enter a text to display in place of Add to Cart button

In Call/Hide Price For Customer Group, select which customer to apply config.

62.2 Compatibility

Our Hide Price/ Call For Price for Magento 2 is compatible with all current versions of Community and Enterprise
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62.3 Changelog

62.4 FAQs
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CHAPTER 63

Image Gallery

63.1 User Guide

63.1.1 Image Gallery for Magento 2 Extension Overview

Image Gallery for Magento 2 allows admin to create image gallery from scratch, including uploading images, adding
new albums, and configuring for each image and album regarding its content, layout and display effect. It is an
optimal tool to help admin manage all products’ images and provide better visualization of product for customer
thanks to widget support and full responsiveness.

63.1.2 How does Image Gallery for Magento 2 Extension work?

1. In Manage Item

Please navigate to Content -> BSS Gallery Manage -> Manage Item
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See the list of items here with concise presentation of information including: title, album ids (which albums the item
belongs to), description, sort order, status (enabled/disabled), action (click here to edit item information)

• Click Add New Item to include a new item into album
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• In Item Title, pick title for the new item; then upload image for the new item in Image

• If your item is a video which has already been uploaded on YouTube, add the embedded url link in Video

• Fill in the information in Sort Order and set Status as Enabled

• Finally, choose one or multiple albums to assign your new item in Select Albums and write its description if
needed in Description.

2. In Manage Album

Please navigate to Content -> BSS Gallery Manage -> Manage Album

See the list of albums here with concise presentation of information including: title, thumbnail (choose a picture in the
album to be album thumbnail), url key (automatically updated based on album title, item ids (show items included in
album), status (enabled/disabled), action (click here to edit item information)

• If you want to add new albums into gallery, click Add New Album
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In New Gallery Album -> Album Information -> General

• In General Information, decide Album Title, write Album Description if needed, then write meta data in
Meta Keywords and Meta Description to support SEO.

• Then, choose album layout type in Layout: Standard or Slider.

• If you want to set automatic sliding action for your album then choose Yes in Slide Auto Play, otherwise choose
No.

• In Status choose Enabled to activate the new album otherwise choose Disabled.

• In New Gallery Album -> Album Information -> Manage Item

In Manage Item, choose one or several items to add to the new album, then in Album Thumbnail, choose an item to
be album thumbnail
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3. In Manage Config

Please navigate to Content -> BSS Gallery Manage -> Manage Config

• In Enabled Gallery, choose Yes to enable the gallery, otherwise choose No.

• In Image Per Page, limit the display of number of items for each page.

• In Album Layout, choose one of the two available of album layout: Ajax or Standard.

• In Popup Auto Play, choose Yes to enable automatic next image for the gallery, then decide next speed in
Popup Auto Play Speed; otherwise choose No.

• Then, decide position of fancybox title in Popup Title Position with 3 options, including: Over, Inside, and
Outside.

• Choose the wanted effect of image display for Popup in Popup Transition Effect with 3 options: Fade, Elastic,
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or None.

4. In Widgets

Please navigate to Content -> Elements -> Widgets -> Bss Gallery

In Bss Gallery -> WIDGET -> Storefront Properties
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In Storefront Properties, choose title for the widget in Widget Title, and pick which store view to place widget: All
Store View, Main Website, Main Website Store, Default Store View.

In Layout Updates, choose which category/product type/page for gallery displaying in Display On, click to see drop
down and pick an option among the available list, including: Categories (Anchor Categories, Non-anchor Categories),
Products (All Product Types, Simple Product, Virtual Product, Bundle Product, Downloadable Product, Grouped
Product, Configurable Product), Generic Pages (All Pages, Specified Page, Page Layouts).

In Container, choose an option among the available list of position in drop down to place widget on page.

In Bss Gallery -> WIDGET -> Widget Options
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• In Widget Description, write description for the widget.

• In Widget Album, choose which album to be displayed on widget.

• In Widget Layout, choose one of the 2 layout types for widget: Slider, or Standard.

• If choose Slider for Widget Layout, select True to enable Auto Play, otherwise select False, then fill in Auto
Play Time if needed

63.2 Compatibility

Our Image Gallery for Magento 2 is compatible with all current versions of Community and Enterprise

63.3 Changelog

63.4 FAQs
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CHAPTER 64

Infinite Scroll

64.1 User Guide

64.1.1 Infinite Scroll for Magento 2 Extension Overview

In Magento 2 default, in product pages such as catalog or search result, pagination will be displayed at the end of each
page as an option to load the next pages. With this function, users only can load the next page one by one. In general,
it is not convenient for users if there are a great numbers of pages. To optimize the searching experience for Magento
users, BSSCommerce quickly develops Infinite Scroll for Magento 2 Extension - providing new functions that give
admin more choices in setting up how to load the next pages: automatically load with Ajax when customers scroll
down to the end of pages, free to customize Load More button/ Back to Top button, create smart URL. Besides, admin
can choose which categories the module will work for. Our extension will contribute to making your site become more
professional and user ?friendlier.

64.1.2 How does Infinite Scroll for Magento 2 Extension work?

To make configuration of this module, follow these below instruction:

• Step 1: Go to Admin Panel => Store => Configuration

• Step 2: At the left side of the page, find BSS Commerce => select Infinite Scroll

There are 3 main parts you can fix as your wishes: General, Go To Top, Button Load More

1. General

• Enabled

Choose Yes/ No to enable/ disable module

• Loading Icon

373

http://bsscommerce.com/magento-infinite-scroll-for-magento-2.html


Read the Docs Template Documentation, Release latest

Click button Choose File -> Select an image file from your computer location. This image will be used as icon
displayed while loading product with Ajax

Click Delete Image if you want to use default icon

• Show load more button pages

Add a page number into this field. Once set up, when auto ajax loading till this page number, a button will be display
for users to load the next pages manually.

If you set up this field to 0, there will be no Load More button.

If you set up this field to 1, Load More button will be displayed right at the first page

You can customize Load More button in the following box.

• Exclude Category

Add ID of categories which you don?t want the module work for

2. Button Load More

You can set up button Load More as wish in term of:

• guiding texts

• background color

• Trigger

• Location

• Speed
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3. Button Load More

You can set up button Load More as your wish in term of guiding texts and background color for button.
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64.2 Compatibility

Our Infinite Scroll for Magento 2 is compatible with all current versions of Community and Enterprise

64.3 Changelog

64.4 FAQs
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CHAPTER 65

Lazy Load

65.1 User Guide

65.1.1 Magento 2 Lazy Load Extension Overview

Magento 2 Lazy Load extension serves Magento 2 based website. It not only creates eye-catching image emerging
transition but also optimizes Magento 2 site speed. Especially, the extension is developed with SEO which promotes
site rank in the SERPs.

65.1.2 How does Magento 2 Lazy Load extension work?

To make configuration of this module, follow these below instruction:

• Step 1: Go to Admin Panel => Stores => Configuration

• Step 2: At the left side of the page, find BSS Commerce => select Lazy Image Loader

After these 2 steps, a screen for configuration appears like the below picture:
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There are 5 parts you can fix as your wishes: Enabled, Threshold, Exclude controllers, Exclude path, Exclude Home
Page.

1. Enabled

You can select between enable and disable Magento 2 Lazy Load Extension by setting the status in Enabled box into
“Enable” or “Disable”.

2. Threshold

In Threshold box, you can set the number pixel before image appear on the screen, then the image will be loaded
earlier as the pixels you set. For instance, if you set the number in the box is 14, it means that the images will be
loaded before when your scroll position is far from 14 pixels.

3. Exclude controllers, Path, Homepage

Magento 2 Lazy Load Extension allows admin deciding which part will be excluded from lazy-loaded function. To
exclude controller, admin can click on Add and then filling the match in the box. Admin also can delete the Match
and and add more by clicking on Delete, and Add button alternately.
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Similar to Controller, admin can control the Path which they do not want to be affected by lazy image load.

Finally, admin can set whether Homepage be affected by lazy image load or not in the box Exclude Home Page.

After finishing all of these set-up steps, you can click on Save Config button to start using Magento 2 Lazy Load
extension .

65.2 Compatibility

Our Lazy Image Loader Extension for Magento 2 is compatible with all current versions of Community and Enterprise

65.3 Changelog

65.4 Common Problems

1. Having a problem when installing Magento 2 Lazy Load extension on magento 2.1?

Error message

Invalid XML in file /www/magento2/app/code/Bss/LazyImageLoader/etc/adminhtml/system.xml:
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Element ‘field’, attribute ‘validate’: The attribute ‘validate’ is not allowed.

Line: 52

Element ‘field’, attribute ‘validate’: The attribute ‘validate’ is not allowed.

Line: 56

#0 /www/magento2/vendor/magento/framework/Config/Reader/Filesystem.php(127):
→˓Magento\Config\Model\Config\Structure\Reader
->_readFiles(Object(Magento\Framework\Config\FileIterator))

#1 /www/magento2/vendor/magento/framework/Config/Data/Scoped.php(103):
→˓Magento\Framework\Config\Reader\Filesystem->read('adminhtml')

#2 /www/magento2/vendor/magento/framework/Config/Data/Scoped.php(81):
→˓Magento\Framework\Config\Data\Scoped->_loadScopedData()

#3 /www/magento2/vendor/magento/module-config/Model/Config/Structure.
→˓php(66): Magento\Framework\Config\Data\Scoped->get()

#4 /www/magento2/var/generation/Magento/Config/Model/Config/Structure/
→˓Interceptor.php(14): Magento\Config\Model\Config\Structure
->__construct(Object(Magento\Config\Model\Config\Structure\Data),
→˓Object(Magento\Config\Model\Config\Structure\Element\Iterator\Tab),
Object(Magento\Config\Model\Config\Structure\Element\FlyweightFactory),
→˓Object(Magento\Config\Model\Config\ScopeDefiner))

#5 /www/magento2/vendor/magento/framework/ObjectManager/Factory/
→˓AbstractFactory.php(103): Magento\Config\Model\Config\Structure\Interceptor
->__construct(Object(Magento\Config\Model\Config\Structure\Data),
→˓Object(Magento\Config\Model\Config\Structure\Element\Iterator\Tab),
Object(Magento\Config\Model\Config\Structure\Element\FlyweightFactory),
→˓Object(Magento\Config\Model\Config\ScopeDefiner))

#6 /www/magento2/vendor/magento/framework/ObjectManager/Factory/Compiled.
→˓php(88): Magento\Framework\ObjectManager\Factory\AbstractFactory
->createObject('Magento\\Config...', Array)

How to fix?

Delete validate tag in app/code/Bss/LazyImageLoader/etc/adminhtml/system.xml

Example :

<field id="loading_width" translate="label" type="text" validate="validate-
→˓number
validate-zero-or-greater" sortOrder="6" showInDefault="1" showInWebsite="1"
→˓showInStore="1">

change to :

<field id="loading_width" translate="label" type="text" sortOrder="6"
showInDefault="1" showInWebsite="1" showInStore="1">

65.5 FAQs
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CHAPTER 66

Limit Cart Quantity

66.1 User Guide

66.1.1 Limit Cart Quantity For Magento 2 Overview

Setting up a limit for order quantity is an essential need for many store owners as it has a remarkable effect on sales
policy. However, the default Magento is able to support few of those demands. Hence, BSSCommerce has developed
Limit Cart Quantity For Magento 2 with the hope it will become a useful and effective solution for E-commerce
business. The extension helps admin to set a minimum and maximum total quantity of all products in a cart for
specific customer groups before checking out successfully. Moreover, the content of message notifying about quantity
error can be customized with expressive choices of words to encourage customers to shop more pleasantly.

66.1.2 How does Limit Cart Quantity For Magento 2 work?

You go to Admin -> Store -> Configuration -> Catalog -> Inventory and start configuration
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In Minimum Quantity Allowed for Entire Cart, go to Customer Group column, each line has a drop down list
showing all of your customer groups to select.

In Minimum Qty column, you can set any number you want for the minimum order quantity of all products in cart
for each customer group.

In Action column, click to the trash bin icon to remove the minimum quantity required for any customer group.

Click Add to add more rows to set the minimum for more customer group.

In Message Alert For Minimum Value, add the message you want to show to your customer, insert “-conf-” for
minimum quantity require and “-cart-” for customer’s cart quantity to be displayed.
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66.2 Compatibility

Our Limit Cart Quantity for Magento 2 is compatible with all current versions of Community and Enterprise

66.3 Changelog

66.4 FAQs
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CHAPTER 67

Minimum Order Amount For Customer Group

67.1 User Guide

67.1.1 Minimum Order Amount For Customer Group Extension For Magento 2
Overview

Minimum Order Amount For Customer Group Extension For Magento 2 is developed from the initial version for
Magento 1 to work well on Magento 2 platform. This extension allows admin to set a limitation of minimal order
value for each group of customer. Customers will not be able to check out if they order a smaller amount of value than
required. This function is especially suitable for B2B e-commerce. Using this extension can help you reach greater
revenue.

67.1.2 How does Minimum Order Amount For Customer Group For Magento 2 Ex-
tension work?

This module can be easily configured on the backend. Check it in Store -> Configuration -> Sales -> Sales

1. Set the limitation

You can customize customer groups and add the minimal amount of value you want to force for each group
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You also can add more or delete a group as you wish.

2. Notify your customer

You can leave message for customers to notify them about your limitation.
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When the module is enabled, when they do not order enough amount of value, your customer will see your message
and cannot check out.

After they order enough, they can check out as usual.

67.2 Compatibility

Our Minimum Order Amount For Customer Group For Magento 2 is compatible with all current versions of Commu-
nity and Enterprise

67.3 Changelog

Version 2.0.2

67.4 FAQs
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CHAPTER 68

Min/Max Order Quantity per Category

68.1 User Guide

68.1.1 Min/Max Order Quantity per Category for Magento 2 Overview

Min/Max Order Quantity per Category for Magento 2 is a useful tool for online store owners to limit order quantity
for all products in a category that each customer group has to meet before checking out successfully.

With the help of this module, Magento store owners can save up a lot of costs especially shipping costs or package
costs. No need to worry about too small or too large number of order products each category, using this extension,
admin can avoid all obstacles in managing order product quantify per categories.

68.1.2 How does Min/Max Order Quantity per Category for Magento 2 work?

Go to Store -> Configuration -> BSSCOMMERCE -> Min/Max Order Quantity per Category for Customer
Group to begin setting up
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1. In Enable: Choose Yes to enable the module or choose No to disable it

2. In ShowCategory:

• Choose Yes to show product category in the shopping cart. Withproduct belonging to multiple categories, all
those categories will be displayed regardless of where customer added the product tocart.

• Choose No to hide the productcategory.

3. In Messages Limit Max: you can change the notification messages when maximum required order quantity per
category is not met (This message locates at the top left corner of the Shopping Cart). Without any changes, default
message will be shown as: The max quantity allowed for purchase at category{category_name} is {qty_limit} [
Product Name : {product_name} ]

4. In Messages Limit Min: you can change the notification messages when minimum required order quantity per
category is not met. Without any changes, default message will be shown as: The min quantity allowed for purchase
at category {category_name} is {qty_limit} [ Product Name : {product_name}]

5. In Min/Max orderquantity:

You can freely choose customer group and category to apply the min/max quantity rule. Click Add button for more
options.

After finishing with setup, choose Save Config

*Note:

For products belong to multiple categories, the order quantity of products needs to meet the min/max requirement of
all thosecategories.

The min/max rule is applied to the total number of products in each category added to cart, not the order quantity of
each particular product.

68.2 Compatibility

Our Min/Max Order Quantity per Category for Magento 2 is compatible with all current versions of Community and
Enterprise
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68.3 Changelog

v1.0.0 . First Release

68.4 Common Problems

How to show the category name?

If customers use the similar theme to default or they customized item section in
the cart, comment folder Bss/MinMaxQtyOrderPerCate/view and add file into theme
(view/frontend/templates/cart/item/default.phtml)

<?php
// get session and show cate
$objectManager = \Magento\Framework\App\ObjectManager::getInstance();
$customerSession = $objectManager->get('Magento\Customer\Model\Session');
$_catename = $customerSession->getCatecheckoutcart();
?>

<!-- add category name -->
<?php if (!empty($_catename)): ?>

<span> Category name: <?php echo $block->escapeHtml($_catename[
→˓$product->getSku()])?></span>
<?php endif ?>
<!-- -->

compared to file

Bss/MinMaxQtyOrderPerCate/view/frontend/templates/cart/item/default.phtml to add exactly

edit message Bss/MinMaxQtyOrderPerCate/Observer/MinMaxQty.php

--message Min Qty
if(!empty($_qty['min_qty'])) {

.................
$message = "The min quantity allowed for purchase at

→˓category ".$cate_name." is
".$qtylimit.' [ Product Name : '.$product_

→˓name.' ]';
.................

}
--message Max Qty
if(!empty($_qty['max_qty'])) {

.................
$message = "The max quantity allowed for purchase at

→˓category ".$cate_name." is
".$qtylimit.' [ Product Name : '.$product_

→˓name.' ]';
.................

}

68.5 FAQs
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CHAPTER 69

Multiple Store View Pricing

69.1 User Guide

69.1.1 Multiple Store View Pricing for Magento 2 Extension Overview

Multiple Store View Pricing for Magento 2 extension helps store owners to set up different prices for the same product
in various store views of a store while Magento 2 default does not support this function. For example, you want to
sell a table at 50 in English store view but in the French store view, the price you want customers to pay is 80. It all
depends on demands of store owners as well as business strategies for each local target customers.

Moreover, this module also allows administrators to set up base currency for each store view so that customers can
easily checkout with currency of store view. It can be said that this is really another very outstanding features of
Multiple Store View Pricing for Magento 2 to make more convenient for both customers and store owners.

69.1.2 How does Multiple Store View Pricing for Magento 2 Extension work?

1. Enable Multiple Store View Pricing for Magento 2 Extension

You go to Store -> Configuration -> Catalog

Next, you continue to click Catalog section and among all sections shown up in the page, find Price section to start
the customization.
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In box Catalog Price Scope, there are 3 options for admin to choose: Global, Website and Store View. You choose
Store View to enable the module.

Then you click Save Config and begin to customize prices of products in each store view of each store

2. Set up base currency for each store view

2.1. Set up base currency for English store view

In Configuration, you go to General -> Currency Setup to set up base currency for English store view

Choose English store view from Store View Section

In Base Currency: Choose British Pound Sterling as base currency and customers will use this one to checkout.

In Default Display Currency: you can choose British Pound Sterling or any other currency because this one is only
displayed in the product or category page, not used in the checkout.

In Allowed Currencies: Choose British Pound Sterling

Then, click to Save config and start to set up price for a product in the English store view
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2.2. Set up base currency for French store view

In Configuration, you go to General -> Currency Setup to set up base currency for French store view

Choose French store view from Store View Section

In Base Currency: Choose Euro as base currency and customers will use this one to checkout.

In Default Display Currency: you can choose Euro or any other currency because this one is only displayed in the
product or category page, not used in the checkout.

In Allowed Currencies: Choose Euro

Then, click to Save config and start to set up price for a product in the French store view

3. Set up different prices for a product in store views of a store

3.1. Set up price for a product in the English store view: Put It Messenger Bag, for example
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Step 1: Choose English in Store View box

Step 2: In Price section, you unmark “Use Default Value” and add your wanted price for the product in this English
store view: 100, for instance

In addition, you can also set up Special Prices for this product by clicking Advanced Pricing

Finally, you save configuration and continue to set up price in the other store view

3.2. Set up price for a product in the French store view: Put It Messenger Bag, for example

Step 1: Choose French in Store View box

Step 2: In Price section, you unmark “Use Default Value” and add your wanted price for the product in this French
store view: 200, for instance
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Finally you save configuration in go to the frontend to see the changes:

• Price of Put It Messenger Bag in the English store view:

• Price of Put It Messenger Bag in the French store view:

As a result, you can set up different price for a product: Put It Messenger Bag in two store views

69.2 Compatibility

Our Multiple Store View Pricing for Magento 2 is compatible with all current versions of Community and Enterprise
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69.3 Changelog

69.4 Common Problems

69.5 FAQs

69.6 Import Product Price Per Store View

Step 1: Get the SKU of product you want to import price

• Go to Product -> Catalog -> Manage Products

• Then choose a product you want to import price -> copy its SKU

Step 2: Get the export file

• Go to System -> Data Transfer -> Export

• In Entity Type, choose Products

• Paste the SKU on SKU box

• Click Continue, then a CSV file will be exported

• Open the downloaded CSV file

• Skip unnecessary attributes and leave 3 important attributes: SKU, store_view_code, price

Step 3: Get store view code and paste in CSV file

• Get store view code: Store -> All stores -> choose a store view to get its code

• Open the CSV file, in the store_view_code column equivalent to each SKU, replace the current store code by
code of store view or add a new row to add

new code of store view

• Fill in price in the price column as you want

• Save the CSV file

Step 4: Import the CSV file to site

• Go to System -> Data Transfer -> Import

• In Import Settings, choose Products for Entity Type

• In Import Behavior, choose Add/Update

• In File to import, select a CSV file to import

• Click Check Data and then click Import

There will be a note shown up: File is valid! To start import process press “Import” button

It is the end of import price process for multiple store views.

Now you will check again your product on each store view.

You also can see the example about import product price per store view for Magento 2 Multiple Store View Pricing
extension’s video below:
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69.7 Installation Guide

Step 1:

Copy code to folder root magento 2

Step 2:

Run php bin/magento setup:upgrade in ssh in folder root of magento 2

Step 3:

Run php bin/magento indexer:reindex

Step 4:

Delete folder var/generation

69.8 Uninstallation Guide

69.8.1 Magento 2 Multiple Store View Pricing

Step 1: Change Price Scope to Global

You go to Admin and navigate to Store→ Configuration→ Catalog→ Catalog→ Price. In Catalog Price Scope,
you select Global.

Step 2: Remove EAV attributes and tables that this extension adds to database

*Note: You should backup your database before removing.

• Remove tier_price_config_for_store and tier_price_for_store attributes in the eav_attribute table of
database.

• Remove tables that this extension adds to database.

– catalog_product_index_price_store

– catalogrule_product_price_store

– catalog_product_index_price_store_idx

– catalog_product_index_price_store_tmp

– catalog_product_index_price_final_store_tmp

– catalog_product_index_price_final_store_idx

– catalog_product_index_price_bundle_store_idx

– catalog_product_index_price_bundle_store_tmp

– catalog_product_index_price_bundle_sel_store_idx

– catalog_product_index_price_bundle_sel_store_tmp

– catalog_product_index_price_bundle_opt_store_idx

– catalog_product_index_price_bundle_opt_store_tmp

– catalog_product_index_price_cfg_opt_agr_store_idx
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– catalog_product_index_price_cfg_opt_agr_store_tmp

– catalog_product_index_price_cfg_opt_store_idx

– catalog_product_index_price_cfg_opt_store_tmp

– catalog_product_index_price_downlod_store_idx

– catalog_product_index_price_downlod_store_tmp

– catalog_product_entity_tier_price_store

• Remove rows whose store_id values are not 0 in the catalog_product_entity_decimal table.
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Step 3: Remove code of this module in the BSS folder.

Step 4: Run Reindex by SSH

Run this command: php bin/magento indexer:reindex
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CHAPTER 70

Multiple Wishlists

70.1 User Guide

70.2 Compatibility

Our Multiple Wishlists for Magento 2 is compatible with all current versions of Community and Enterprise

70.3 Changelog

70.4 FAQs
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CHAPTER 71

One Step Checkout

71.1 User Guide

71.1.1 One Step Checkout for Magento 2 Overview

One Step Checkout for Magento 2 extension helps customers to checkout simply and quickly by displaying all elements
in 1 page only. They do not need to experience two parts (Shipping Address and Reviews & Payments) as in Magento 2
default, but fill all information in one place conveniently. Therefore, the checkout process becomes more user friendly,
which can reduce abandonment rate and bring higher conversion rate for online stores.

71.1.2 How Does One Step Checkout for Magento 2 Work?

Please go to Store -> Configuration -> BSS ONESTEPCHECKOUT -> One Step Checkout
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1. In Fields Display

In Show Discount Code:

• Choose Yes to display a box to enter discount code.

• Choose No to hide this box from the checkout page.

In Show Gift Message:

• Choose Yes to show Gift options that let customers to add their own gift messages.

• Choose No to disable this function.

In Enable Subscribe Newsletter:

• Choose Yes to allow customers to subscribe newsletter in the checkout page.

• Choose No to disbale this option.

In Enable Order Comment:

• Choose Yes to show a text box for customers to leave their comments for order

• Choose No to exclude this box from the checkout page

In Enable Delivery time and date:

• Choose Yes to display Order delivery date and time that allows customers to choose their own suitable dates and
times to receive orders.

• Choose No to disable this funtion.
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2. In General

In Enable:

• Choose Yes to enable Magento 2 One Step Checkout extension.

• Choose No to disable this module.

In Enable suggesting address by Google:

• Choose Yes to enable the address suggesting function of Goole. It will suggest customer addresses when they
type some letters.

• Choose No to disable this function.

In Google API Key: Fill in your API Key.

In case you haven’t yet had an API Key, please click the link after this configuration to get it.

In Router Name: Choose your wanted url name for your checkout page.

In Default Payment Method: Select default payment method.

In Default Shipping Method: Select default shipping method.
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71.2 Compatibility

Our One Step Checkout for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x

71.3 Changelog

71.4 FAQs
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CHAPTER 72

Order Delivery Date

72.1 User Guide

72.1.1 Order Delivery Date for Magento 2 Extension Overview

With help of Order Delivery Date for Magento 2 Extension , shipment information for every order from your Magento
2 based websites will be more detailed and clearer than ever. In the fron-end, customers can choose the exact dates
and time slots; even leave a comment about it. In the back-end, website admin can easily control his own conditions
to build timing options for customers, including: Processing Time, Cut-off Time, Holidays/Exclude days/Blackout
days, Time slots, Disable Delivery Date

72.1.2 How does it work?

1. Set up Delivery Order Date in the back-end

Order Delivery Date for Magento 2 offers store owners an easy way to set up and control advanced delivery time
choices for their customers’ orders. In Admin Panel, navigate to the section of this extension: Stores Configuration
BSS Commerce Order Delivery Date
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At “Enabled” field, you just simply select Yes/No to turn on or off this extension from taking effects.

“Display At” is the section that lets you decide where the part for customers fill in details about delivery dates will be
shown: Shipping method, Shipping Address

“Processing Time” is the number of days from the time an order is placed in the website until when the delivery
can begin. If you set it as 1 day, then a customer placing an order today has his options of delivery date start from
tomorrow

“Cut Off Time” is set up as a point of time in the day when order made after that will be counted as being made on
the next day
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“Holidays/Exclude Days/Blackout Days”: These are the days that are not available for delivery picked in the calendar
by admin. They will be faded in the delivery calendar shown for customers and of course, they cannot be selected.
Admin can add more unavailable days like that by click the button “Add” or delete them by clicking on trash bin icon
under column “Action”. Content for each one may be filled in, the reason for its out-of-options status for instance.

There are “Time Slots” to set up delivery time more exactly by hours in the day. You can also Add new time slots or
Delete them, and write a note for each one just in similar way to what you do with Holidays/Exclude Days/ Blackout
Days before. In “Disable Delivery Date” section, you can fix the days in every week that are not available for delivery
options.
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2. Insert Order Delivery Date Information into Orders, Invoices, Shipments, Credit Memos and emails

Besides allowing a very detailed timing customization, Order Delivery Date for Magento 2 Extension also add cus-
tomers’ Delivery Date, Time Slots and Arrival Comments directly to Orders/Invoices/Shipments/Credit Memos info
in the backend for admin to keep tracking more easily. To check it, from Admin Panel you go to Sales section and
choose which one you want to see. Opening every single order/invoice/ shipment/credit memo you will see the added
part of this module.
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As for Emails, Order Delivery Date for Magento 2 Extension automatically adds Delivery Date, Time slots and
Arrival Comments as given by customers into email variables so that when creating an email template, you can use
this information if needed. To do so, from Admin Panel you go to Marketing Email Templates Add new template
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After loading default template, in Template Information section, click Insert Variable. . . then you will see added
variables added by this module

When you continue to send emails to your customers as usual using the templates that were just created, Delivery
Date, Delivery Time Slot and Shipping Arrival Comment will be included.

72.2 Compatibility

Our Order Delivery Date for Magento 2 is compatible with all current versions of Community and Enterprise
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72.3 Changelog

Version 1.0.0

• First release

Version 1.0.1

• Ability to display delivery date at shipping method section on checkout page

72.4 FAQs
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CHAPTER 73

Previous/Next Product Page

73.1 User Guide

73.2 Compatibility

Our Previous/Next Product Page for Magento 2 is compatible with all current versions of Community and Enterprise

73.3 Changelog

v1.0.0: First Release

73.4 FAQs
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CHAPTER 74

Quick View

74.1 Installation Guide

To install Quick View for Magento 2 Extension , please follow this following video for better installation:

74.2 User Guide

74.2.1 Quick View for Magento 2 Extension Overview

Quick View for Magento 2 Extension allows customers to check preview of products and add products to cart in Quick
View popup without visiting product page. Besides, customers can also execute other actions just like in a real product
page, such as: add products to compare, wish list, send email, write review and check related/up-sell products. Admin
can easily settings and design of Quick View Popup.

74.2.2 How Does Quick View for Magento 2 Extension Work?

Please go to Store -> Configuration -> Ajax Quick View
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1. General

In Enable, choose Yes to enable the extension or No to disable it.

In Show Related Product Block, choose Yes to include related product block in Quick View popup, or No to exclude
this information.

In Show Up-sell Product Block, choose Yes to include up-sell product block in Quick View popup, or No to exclude
this information.

In Show Mail-to, choose Yes to enable mail-to option in Quick View popup, or No to leave it out.

In Show Add to Wishlist, choose enable add to wish list option in Quick View popup, or No to leave it out.

In Show Add to Compare, choose enable add to compare option in Quick View popup, or No to leave it out.

In Show Review and Ratings, choose Yes to include review and ratings in Quick View popup, or No to exclude this
information.

In Show Additional Information, choose Yes to include addition information (product detail block) in Quick View
popup, or No to exclude this information.

In Show Go To Product Link, choose Yes to enable Show Go To Product link in Quick View popup, or No to leave
it out.
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2. Quick View Popup Design

In Button Text Color, set color for text on Quick View button.

In Button Text, enter text for Quick View button. Eg: Quick View, View Product?

In Button Color, set color for Quick View button.

74.3 Compatibility

Our Quick View for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x

74.4 Changelog

74.5 FAQs
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CHAPTER 75

Reorder Product List

75.1 User Guide

75.2 Compatibility

Our Reorder Product List for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x

75.3 Changelog

v1.0.0: First Release.

75.4 FAQs
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CHAPTER 76

Shipping and Payment Method for Customer Group

76.1 User Guide

76.1.1 Shipping and Payment per Customer Group for Magento 2 Extension
Overview

Shipping and Payment per Customer Group for Magento 2 allows admin to assign shipping and payment methods to
specific customer groups, thus promotes better order management and faster customer checkout process.

76.1.2 How does Shipping and Payment per Customer Group for Magento 2 Exten-
sionwork?

Please go to BSS COMMERCE -> Methods for Customer Group -> Payment / Shipping
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1. In Payment

In Payment Methods, choose one or multiple customer groups in each of enabled payment methods available.

Then, click Submit button to save all figuration.
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2. In Shipping

In Shipping Methods, select one or multiple customer groups in each of enabled shipping methods available.

Then, click Submit button to save all figuration.
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76.2 Compatibility

Our Shipping and Payment Method per Customer Group for Magento 2 is compatible with all current versions of
Community and Enterprise

76.3 Changelog

76.4 FAQs
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CHAPTER 77

Shopping Cart Price Rule per Store View

77.1 User Guide

77.1.1 Shopping Cart Price Rule per Store View for Magento 2 Overview

Shopping Cart Price Rule per Store View for Magento 2 helps administrators to set up shopping cart price rule for store
views, instead of the whole website as Magento default. Therefore, store owners can provide their local customers
particular promotions programs to encourage them to purchase more and enhance sales effectively.

77.1.2 How Does Shopping Cart Price Rule per Store View for Magento 2 Work?

After installing this module, you will select store views to set up cart price rules when you create new rules.

You go to MARKETING -> Cart Price Rules -> Add New Rule.
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You fill in necessary information in sections of Rule information. Especially, in Store View section, you will select
store views to set up this rule and apply in the frontend. You can select multiple store view to carry out setup at one
time.

Take 2 following examples to see how Shopping Cart Price Rule per Store View for Magento 2 can function in details.

Example 1: Set up a rule “20% OFF for orders including 3 or more products” for English store view.

In Rule Information:

• Fill in Rule name and Description.

• Set Yes for Active.

• Select English of Main Website Store in Store View section.

• Select customer groups to apply.

• Set up Coupon, Uses per Customers, Valid Time and Priority for this rule.

In Conditions: Set up the right condition for this rule.
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In Actions: Choose suitable actions for the rule.

In Labels: Write a label for each store view to specify which promotion is being applied.

Finally, you save the rule and see how it is applied in the frontend:
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Example 2: Set up a rule “30% OFF for orders which has subtotal greater than $500” for French store view.

You do the same steps as in Example 1 but you need to choose French store view to set up in Store Views section.
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In Conditions:

In Actions:
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Finally, you save the rule and see how it is applied in the frontend:

*Note: For more understandings about how to create a shopping cart price rule for Magento 2, you can take a look at
our following tutorial:

How to Create Shopping Cart Price Rule for Magento 2

77.2 Compatibility

Our Shopping Cart Price Rule per Store View for Magento 2 is compatible with:

• Community: 2.0.x - 2.1.x

• Enterprise: 2.0.x - 2.1.x

77.3 Changelog

v1.0.0: First Release.

77.4 FAQs
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CHAPTER 78

Simple Details on Configurable Products

78.1 User Guide

78.1.1 Simple Details on Configurable Product for Magento 2 Overview

Simple Details on Configurable Product for Magento 2 supports showing all detailed information of each child product
when choosing options,namely SKU, name, tier price, stock status, stock number, description and URL. Therefore,
this extension is absolutely suitable for those selling configurable product with many different children products or for
business purpose of each child item.

78.1.2 How does Simple Details on Configurable Product for Magento 2Extension
work?

1. In the frontend

This is how Simple Details on Configurable Product is displayed in the fronted:
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• Show details of children items of configurable product, such as: name, SKU, tier price, stock status, stock
number and description.

• Get URL for each child product with preselected options.

– URL: URL will change as chosen options. If customers access to the URL, options are also selected in the
product page.

– Custom URL has a form: . . . /Product-Name+attr1-Value1+attr2-Value2 (For instance: . . . /hero-
hoodie+color-Black+size-S), it changes when choosing attributes of product.

• Support minimum quantity for product separately added to cart instead of the default of Magento 2, which only
allows for configurable products.

• Support quantity increment for children products. This function outweighs the default with ability to set incre-
ment for each associated product of configurable product. For example, if you set 5 for quantity increment for a
skirt-red-L, then your customer cannot buy this item with quantity 1-2-3 or 6-7-8 only choose this product with
5-10-15 etc in quantity box.
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2. In the backend

In General:

• Enabled: choose Yes to enable the module.

In Attributes Display Config: choose Yes to show the attributes you want in the frontend:

• SKU

• Name

• Description

• Tier Price

• Stock Status

• Product Image

• Min/Max Quantity Allow in shopping cart: this default feature now can support for simple products individually.
Edit each child item page in the backend to set minimum or maximum quantity.

• Quantity Increment: this feature of Magento default now supports every simple product of configurable product.
Edit each simple product to set quantity increment.

In Advanced Settings:

• Custom URL: choose Yes to enable this feature.

*Note: in this configuration, if you want to get a new URL for simple product, you can type URL as you
wish in the box (Do not have neither ‘+’ nor ‘~’); or you can let it blank and tick on checkbox as image
below to take the URL of configurable product.
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• Preselect: the attributes are preselected in the product detail page in the backend. Go to product
details page in the backend, preselect option of attributes.

*Note: in Magento 2.0.x version, there will be a separate Preselect tab in product detail page:
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78.2 Compatibility

Our Simple Details on Configurable Products for Magento 2 is compatible with all current versions of Commu-
nity and Enterprise

78.3 Changelog

78.4 FAQs
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CHAPTER 79

Wholesale Fast Order

79.1 User Guide

79.1.1 Overview Of Wholesale Fast Order For Magento 2 Extension

The Wholesale Fast Order For Magento 2 Extension can assist customers in purchasing a large number of multiple
products and adding all of them to cart at once instead of spending lots of time to order each one of products then
adding to shopping cart. Therefore, with this magento 2 extension developed by BSS Commerce, online wholesalers
will be no longer delayed even one second while purchasing.

79.1.2 How does Wholesale Fast Order For Magento 2 Extension work?

1. How to use functions of Wholesale Fast Order For Magento 2 Extension

Wholesale Fast Order For Magento 2 is a very useful extension that allows selecting multiple products at the same
time and then adding them to shopping cart without spending too much time purchasing one by one. By this way,
Wholesale Fast Order For Magento 2 can optimize order process and decrease buying time by following these steps:

Step 1: Click “Fast Order” shortcut in the right side of the website

• Fast Order shortcut will be displayed in the right side of your Magento site when you installed Wholesale Fast
Order For Magento 2

• Customers click to Fast Order shortcut and there is a Fast Order CMS page for them to search
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Step 2: Search products by typing names or SKU in the search boxes

There will be several suggestions as you set up for customers to choose. Both names and SKUs are included in the
search results with the highlighted search keyword.

As you can see, it also supports autocomplete

Step 3: Select your wanted products with quantity and add them to cart
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For configurable products, there will be a popup of custom option attributes for customers to choose. Evenmore, if
your customers want to edit product attributes or other custom options, they just need to click on “EDIT” button

If they want to get more lines for searching and ordering, they can click on “Add lines” button at the right bottom of
the ordering table

Step 4: Customers can also view your shopping cart page to see chosen products

Step 5: Process to checkout right after adding products into cart. The grand total will be automatically calculated as
you add multiple desired items to cart at a time.

2. How to configure Wholesale Fast Order For Magento 2 Extension in the backend

• For Admin Configuration, go through “Stores -> Configuration -> BSS Commerce -> Fast Order”.
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• In Enabled: You can switch on/switch off Wholesale Fast Order For Magento 2 by choosing Yes or No it in the
back end.

• In Number of lines: you set the number of lines of Fast Order shown in the CMS page

• In Enabled search by SKU:

– Choose Yes to enable customers to search by SKUs

– Choose No and customers can only search by names as default

• In Autocomplete minimum characters: you set the minimum characters customers have to type in the search
box so that the result can appear.

• In Max results to show: you set the number of results displayed in the autocomplete box
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• In Head Background Color and Head Text Color: you can choose which color as you wish for your ordering
table on the CMS Page to get more attraction from your customers

• In Enabled Shortcut Top Link:

– Choose Yes to enable shortcut top link -> Then there will be a Shortcut Url Key box for you to type the
name for the shortcut url.

– Choose No if you want to disable it

• In Enable for customer groups: you choose group for whom you do not want to enable Wholesale Fast Order

79.2 Compatibility

Our Wholesale Fast Order for Magento 2 is compatible with all current versions of Community and Enterprise

79.3 Changelog

Version 1.0.0:

• First Release

79.4 FAQs
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CHAPTER 80

Topics

1. How to Create Htpasswd for Magento Site

2. How to Solve the Issue of Image Dimension Specifying in Magento

3. How To Upgrade Magento 2.0.2 to Magento 2.0.4 Version

4. Solve “Unable to Communicate With The PayPal Gateway” Error in Magento

5. Problem When Using CDN in Magento: Cannot Loading Font Files

6. Flat Catalog Product Function: Problem in Sorting Product

7. Magento 2 - Got Problems While Importing Products?

8. Magento Redirect to Checkout after Adding To Cart: An Easy How-To Guide

9. Magento Tutorial: Create Color Swatches for Configurable Product

10. Newsletter Tutorial: How to Create and Send Newsletter in Magento?

11. How To Delete Order in Magento

12. How to Optimize Magento Site Speed with GTMetrix

13. How to Set up Payment Sections in Magento Site? [Part 1]

14. How to Set up Payment Section in Magento Site? [Part 2]

15. How to Set up Payment Section in Magento Site? [Part 3]

16. Equip Impervious Magento Security for Your Online Store [Part 1]

17. Equip Impervious Magento Security for Your Online Store [Part 2]

18. Magento Fix: Customers Can’t Login to Version 1.8, 1.8.1 and 1.9

19. How to Set Up Payment Methods in Magento 2 (Part 1)

20. How to Set Up Payment Methods in Magento 2 (Part 2)

21. How to Set Up Multiple Store Views in Magento 2

22. How to Create Configurable Products in Magento 2
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23. How to Set Up Shipping Methods in Magento 2 (Part 1)

24. Easy Steps to Set Up Minimum Order Amount in Magento 2 in 2 Minutes

25. How to Set Up Shipping Methods in Magento 2 (Part 2)

26. Simple Steps to Set Minimum and Maximum Order Quantity in Magento 2

27. Magento 1 Tutorial: How to Import Price Per Store View

28. How to Manage Currency Symbol and Currency Rate in Magento 2

29. How To Set Minimum Quantity for Configurable Product

30. How to Set up Multiple Languages and Currencies in Magento 1 and 2

31. How To Create Shopping Cart Price Rule in Magento 2

32. How to Create Catalog Price Rules in Magento 2
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